$$INTRODUCTION$$ - %%projecttitle%%

SIDRASolutions.SI.API 8.0 Reference Documentation
Introduction
Send Feedback

Glossary Item Box

This help file provides detailed information about all parameters and the structure accessible in the SIDRA INTERSECTION Application Programming Interface (API) for use by programmers.

The SIDRA INTERSECTION API provides a programming interface that enables external applications to communicate with SIDRA INTERSECTION. This API provides the following capabilities:

  • full programmatic access to the Site / Network input and output data contained in the SIDRA INTERSECTION 8 Project file (extension sip8),
  • ability to create a Project file, add a Site / Network / Common Control Group (CCG) / Route, specify geometry data (e.g. add and remove intersection legs and lanes, specify lane configuration and lane disciplines), specify phasing and timing data, and so on, and
  • provision for processing a Site or Network (running the program).

In addition to the API, full access is provided to input and output data that resides in the Project File database (extension sip8). This data can be accessed directly via SQL queries. Input and output data structures in the SIDRA INTERSECTION project file were developed for this purpose.

The API assembly can be accessed natively from any .NET (4.5 Minimum) programming language or it can be accessed via classes exposed by COM. The API defines a number of classes / objects which define a simple hierarchy for a SIDRA INTERSECTION Project.

A licensed version of SIDRA INTERSECTION must be installed on a computer before the API can be used.

For information on SIDRA INTERSECTION API, refer to the SIDRA SOLUTIONS website.

For understanding the input and output parameters used in SIDRA INTERSECTION, refer to the User Guide and SIDRA Glossary which are accessible using buttons at the top-right corner of the ribbon or under the File menu in the software user interface.

Sample API programs in C# and C++ are also available.

For feedback on the use of SIDRA INTERSECTION API applications and experience with programming using SIDRA INTERSECTION API, please contact us by completing and submitting the Contact Form on the SIDRA SOLUTIONS online support system:
support.sidrasolutions.com

Copyright ©2000-2018 Akcelik and Associates Pty Ltd

© 2018 All Rights Reserved.


%%ItemTitle%%

SIDRASolutions.SI.API Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | SIAPI | SIDRA INTERSECTION API wrapper class
Class | SIAPIAnalysis |
Class | SIAPIDiagnosticMsg |
Class | SIAPIDiagnosticMsgs |
Class | SIAPIGapAcceptanceSpecificApp |
Class | SIAPIIsland |
Class | SIAPIIslands |
Class | SIAPILaneApproach |
Class | SIAPILaneApproachMovement |
Class | SIAPILaneApproachMovementMC |
Class | SIAPILaneApproachMovementMCs |
Class | SIAPILaneApproachMovements |
Class | SIAPILaneApproachs |
Class | SIAPILaneExit |
Class | SIAPILaneExits |
Class | SIAPILaneMovement |
Class | SIAPILaneMovementMC |
Class | SIAPILaneMovementMCs |
Class | SIAPILaneMovements |
Class | SIAPILaneSegment |
Class | SIAPILaneSegmentMC |
Class | SIAPILaneSegmentMCs |
Class | SIAPILeg |
Class | SIAPILeg_rou_hcm |
Class | SIAPILeg_roundabout |
Class | SIAPILegs |
Class | SIAPIModelSetting | SIDRA INTERSECTION Model Setting wrapper class
Class | SIAPIMovement_ped | SIDRA INTERSECTION Pedestrian Movement wrapper class
Class | SIAPIMovement_peds | SIAPIMovement_ped collection
Class | SIAPIMovement_vehicle_od | SIDRA INTERSECTION Vehicle OD Movement wrapper class
Class | SIAPIMovement_vehicle_od_mc | SIDRA INTERSECTION Vehicle OD Movement (per Movement Class) wrapper class
Class | SIAPIMovement_vehicle_od_mcs | SIAPIMovement_vehicle_od_mc collection
Class | SIAPIMovement_vehicle_ods | SIAPIMovement_vehicle_od collection
Class | SIAPIMovementClass |
Class | SIAPIMovementClasses |
Class | SIAPIMovementClassFuelEmission |
Class | SIAPIMovementClassFuelEmissions |
Class | SIAPINetwork |
Class | SIAPINetworkCCG | Wrapper class for a Common Control Group (CCG) in a particular Network
Class | SIAPINetworkCCGPhase |
Class | SIAPINetworkCCGPhases |
Class | SIAPINetworkCCGs |
Class | SIAPINetworkCCGSequence |
Class | SIAPINetworkCCGSequences |
Class | SIAPINetworkDemandSensitivity |
Class | SIAPINetworkLegConnection |
Class | SIAPINetworkLegConnections |
Class | SIAPINetworks |
Class | SIAPINetworkSite | Wrapper class for the Site in a particular Network
Class | SIAPINetworkSites |
Class | SIAPIOpposingmovement_ped |
Class | SIAPIOpposingmovement_peds |
Class | SIAPIOpposingmovement_vehicle |
Class | SIAPIOpposingmovement_vehicles |
Class | SIAPIOutputAnalysis |
Class | SIAPIOutputCirculatingLane |
Class | SIAPIOutputCirculatingLanes |
Class | SIAPIOutputGraphTuple |
Class | SIAPIOutputGraphTuples |
Class | SIAPIOutputLane | SIDRA INTERSECTION Output Lane wrapper class
Class | SIAPIOutputLaneGreenPeriod |
Class | SIAPIOutputLaneGreenPeriods |
Class | SIAPIOutputLaneMC |
Class | SIAPIOutputLaneMCs |
Class | SIAPIOutputLaneOD |
Class | SIAPIOutputLaneODMC |
Class | SIAPIOutputLaneODMCs |
Class | SIAPIOutputLaneODs |
Class | SIAPIOutputLanes | SIAPIOutputLane collection
Class | SIAPIOutputLeg | SIDRA INTERSECTION Output Leg wrapper class
Class | SIAPIOutputLegMC |
Class | SIAPIOutputLegMCs |
Class | SIAPIOutputLegPerson |
Class | SIAPIOutputLegPersons |
Class | SIAPIOutputLegs |
Class | SIAPIOutputMeteredRoundabout |
Class | SIAPIOutputMovementPed | SIDRA INTERSECTION Pedestrian movement output wrapper class
Class | SIAPIOutputMovementPed_GreenPeriod |
Class | SIAPIOutputMovementPed_GreenPeriods |
Class | SIAPIOutputMovementPeds | SIAPIOutputMovementPed collection
Class | SIAPIOutputMovementPersonOD |
Class | SIAPIOutputMovementPersonODs |
Class | SIAPIOutputMovementVehicleOD |
Class | SIAPIOutputMovementVehicleODMC |
Class | SIAPIOutputMovementVehicleODMC_GreenPeriod |
Class | SIAPIOutputMovementVehicleODMC_GreenPeriods |
Class | SIAPIOutputMovementVehicleODMCs |
Class | SIAPIOutputMovementVehicleODs |
Class | SIAPIOutputNetwork |
Class | SIAPIOutputNetworkGraphTuple |
Class | SIAPIOutputNetworkGraphTuples |
Class | SIAPIOutputNetworkPedestrian |
Class | SIAPIOutputNetworkPerson |
Class | SIAPIOutputNetworkVehicle |
Class | SIAPIOutputPhase |
Class | SIAPIOutputPhaseMovTimingPath |
Class | SIAPIOutputPhaseMovTimingPathMovement |
Class | SIAPIOutputPhaseMovTimingPathMovements |
Class | SIAPIOutputPhaseMovTimingPaths |
Class | SIAPIOutputPhases |
Class | SIAPIOutputRouteMovementBasedPerson |
Class | SIAPIOutputRouteMovementBasedVehicle |
Class | SIAPIOutputSequence |
Class | SIAPIOutputset | SIDRA INTERSECTION Outputset wrapper class
Class | SIAPIOutputSitePedestrian | SIDRA INTERSECTION Output Site Pedestrian wrapper class.
Class | SIAPIOutputSitePerson | SIDRA INTERSECTION Person specific site output wrapper class.
Class | SIAPIOutputSiteRoute |
Class | SIAPIOutputSiteRoutes |
Class | SIAPIOutputSiteVehicle | SIDRA INTERSECTION Output Site Vehicle wrapper class
Class | SIAPIPhase |
Class | SIAPIPhasemovement_ped |
Class | SIAPIPhasemovement_peds |
Class | SIAPIPhasemovement_vehicle |
Class | SIAPIPhasemovement_vehicles |
Class | SIAPIPhases |
Class | SIAPIProject | SIDRA INTERSECTION Project wrapper class
Class | SIAPIRoute |
Class | SIAPIRouteNwSite |
Class | SIAPIRouteNwSites |
Class | SIAPIRoutes |
Class | SIAPISensitivity |
Class | SIAPISequence |
Class | SIAPISequences |
Class | SIAPISite | SIDRA INTERSECTION Site wrapper class
Class | SIAPISites | SIAPISite collection
Class | SIAPITwoWaySignControlAdjGeometryControl |
Class | SIAPITwoWaySignControlAdjGeometryControls |
Class | SIAPITwoWaySignControlAdjMajorNumLane |
Class | SIAPITwoWaySignControlAdjMajorNumLanes |

Interfaces

 | Interface | Description
Interface | ISIAPI | SIDRA INTERSECTION API wrapper interface.
Interface | ISIAPIAnalysis |
Interface | ISIAPIDiagnosticMsg |
Interface | ISIAPIDiagnosticMsgs |
Interface | ISIAPIGapAcceptanceSpecificApp |
Interface | ISIAPIIsland |
Interface | ISIAPIIslands |
Interface | ISIAPILaneApproach |
Interface | ISIAPILaneApproachMovement |
Interface | ISIAPILaneApproachMovementMC |
Interface | ISIAPILaneApproachMovementMCs |
Interface | ISIAPILaneApproachMovements |
Interface | ISIAPILaneApproachs |
Interface | ISIAPILaneExit |
Interface | ISIAPILaneExits |
Interface | ISIAPILaneMovement |
Interface | ISIAPILaneMovementMC |
Interface | ISIAPILaneMovementMCs |
Interface | ISIAPILaneMovements |
Interface | ISIAPILaneSegment |
Interface | ISIAPILaneSegmentMC |
Interface | ISIAPILaneSegmentMCs |
Interface | ISIAPILeg |
Interface | ISIAPILeg_rou_hcm |
Interface | ISIAPILeg_roundabout |
Interface | ISIAPILegs |
Interface | ISIAPIModelSetting | SIDRA INTERSECTION Model Setting wrapper interface
Interface | ISIAPIMovement_ped | SIDRA INTERSECTION Pedestrian Movement wrapper interface
Interface | ISIAPIMovement_peds |
Interface | ISIAPIMovement_vehicle_od | SIDRA INTERSECTION Vehicle OD Movement wrapper interface.
Interface | ISIAPIMovement_vehicle_od_mc | SIDRA INTERSECTION Vehicle OD Movement (per Movement Class) wrapper interface.
Interface | ISIAPIMovement_vehicle_od_mcs |
Interface | ISIAPIMovement_vehicle_ods |
Interface | ISIAPIMovementClass |
Interface | ISIAPIMovementClasses |
Interface | ISIAPIMovementClassFuelEmission |
Interface | ISIAPIMovementClassFuelEmissions |
Interface | ISIAPINetwork |
Interface | ISIAPINetworkCCG | Wrapper interface for a Common Control Group (CCG) in a particular Network
Interface | ISIAPINetworkCCGPhase |
Interface | ISIAPINetworkCCGPhases |
Interface | ISIAPINetworkCCGs |
Interface | ISIAPINetworkCCGSequence |
Interface | ISIAPINetworkCCGSequences |
Interface | ISIAPINetworkDemandSensitivity |
Interface | ISIAPINetworkLegConnection |
Interface | ISIAPINetworkLegConnections |
Interface | ISIAPINetworks |
Interface | ISIAPINetworkSite | Wrapper interface for the Site in a particular Network
Interface | ISIAPINetworkSites |
Interface | ISIAPIOpposingmovement_ped |
Interface | ISIAPIOpposingmovement_peds |
Interface | ISIAPIOpposingmovement_vehicle |
Interface | ISIAPIOpposingmovement_vehicles |
Interface | ISIAPIOutputAnalysis |
Interface | ISIAPIOutputCirculatingLane |
Interface | ISIAPIOutputCirculatingLanes |
Interface | ISIAPIOutputGraphTuple |
Interface | ISIAPIOutputGraphTuples |
Interface | ISIAPIOutputLane | SIDRA INTERSECTION Output Lane wrapper interface
Interface | ISIAPIOutputLaneGreenPeriod |
Interface | ISIAPIOutputLaneGreenPeriods |
Interface | ISIAPIOutputLaneMC |
Interface | ISIAPIOutputLaneMCs |
Interface | ISIAPIOutputLaneOD |
Interface | ISIAPIOutputLaneODMC |
Interface | ISIAPIOutputLaneODMCs |
Interface | ISIAPIOutputLaneODs |
Interface | ISIAPIOutputLanes |
Interface | ISIAPIOutputLeg | SIDRA INTERSECTION Output Leg wrapper interface
Interface | ISIAPIOutputLegMC |
Interface | ISIAPIOutputLegMCs |
Interface | ISIAPIOutputLegPerson |
Interface | ISIAPIOutputLegPersons |
Interface | ISIAPIOutputLegs |
Interface | ISIAPIOutputMeteredRoundabout |
Interface | ISIAPIOutputMovementPed | SIDRA INTERSECTION Pedestrian movement output wrapper interface.
Interface | ISIAPIOutputMovementPed_GreenPeriod |
Interface | ISIAPIOutputMovementPed_GreenPeriods |
Interface | ISIAPIOutputMovementPeds |
Interface | ISIAPIOutputMovementPersonOD |
Interface | ISIAPIOutputMovementPersonODs |
Interface | ISIAPIOutputMovementVehicleOD |
Interface | ISIAPIOutputMovementVehicleODMC |
Interface | ISIAPIOutputMovementVehicleODMC_GreenPeriod |
Interface | ISIAPIOutputMovementVehicleODMC_GreenPeriods |
Interface | ISIAPIOutputMovementVehicleODMCs |
Interface | ISIAPIOutputMovementVehicleODs |
Interface | ISIAPIOutputNetwork |
Interface | ISIAPIOutputNetworkGraphTuple |
Interface | ISIAPIOutputNetworkGraphTuples |
Interface | ISIAPIOutputNetworkPedestrian |
Interface | ISIAPIOutputNetworkPerson |
Interface | ISIAPIOutputNetworkVehicle |
Interface | ISIAPIOutputPhase |
Interface | ISIAPIOutputPhaseMovTimingPath |
Interface | ISIAPIOutputPhaseMovTimingPathMovement |
Interface | ISIAPIOutputPhaseMovTimingPathMovements |
Interface | ISIAPIOutputPhaseMovTimingPaths |
Interface | ISIAPIOutputPhases |
Interface | ISIAPIOutputRouteMovementBasedPerson |
Interface | ISIAPIOutputRouteMovementBasedVehicle |
Interface | ISIAPIOutputSequence |
Interface | ISIAPIOutputset | SIDRA INTERSECTION Outputset wrapper interface
Interface | ISIAPIOutputSitePedestrian | SIDRA INTERSECTION Pedestrian specific site output wrapper interface.
Interface | ISIAPIOutputSitePerson | SIDRA INTERSECTION Person specific site output wrapper interface.
Interface | ISIAPIOutputSiteRoute |
Interface | ISIAPIOutputSiteRoutes |
Interface | ISIAPIOutputSiteVehicle | SIDRA INTERSECTION Vehicle specific site output wrapper class.
Interface | ISIAPIPhase |
Interface | ISIAPIPhasemovement_ped |
Interface | ISIAPIPhasemovement_peds |
Interface | ISIAPIPhasemovement_vehicle |
Interface | ISIAPIPhasemovement_vehicles |
Interface | ISIAPIPhases |
Interface | ISIAPIProject | SIDRA INTERSECTION Project wrapper interface
Interface | ISIAPIRoute |
Interface | ISIAPIRouteNwSite |
Interface | ISIAPIRouteNwSites |
Interface | ISIAPIRoutes |
Interface | ISIAPISensitivity |
Interface | ISIAPISequence |
Interface | ISIAPISequences |
Interface | ISIAPISite | SIDRA INTERSECTION Site wrapper interface
Interface | ISIAPISites | Site collection wrapper interface
Interface | ISIAPITwoWaySignControlAdjGeometryControl |
Interface | ISIAPITwoWaySignControlAdjGeometryControls |
Interface | ISIAPITwoWaySignControlAdjMajorNumLane |
Interface | ISIAPITwoWaySignControlAdjMajorNumLanes |

See Also

Reference

SIDRASolutions.SI.API Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

SIDRASolutions.SI.API Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPI
SIDRASolutions.SI.API.SIAPIAnalysis
SIDRASolutions.SI.API.SIAPIDiagnosticMsg
SIDRASolutions.SI.API.SIAPIDiagnosticMsgs
SIDRASolutions.SI.API.SIAPIGapAcceptanceSpecificApp
SIDRASolutions.SI.API.SIAPIIsland
SIDRASolutions.SI.API.SIAPIIslands
SIDRASolutions.SI.API.SIAPILaneApproach
SIDRASolutions.SI.API.SIAPILaneApproachMovement
SIDRASolutions.SI.API.SIAPILaneApproachMovementMC
SIDRASolutions.SI.API.SIAPILaneApproachMovementMCs
SIDRASolutions.SI.API.SIAPILaneApproachMovements
SIDRASolutions.SI.API.SIAPILaneApproachs
SIDRASolutions.SI.API.SIAPILaneExit
SIDRASolutions.SI.API.SIAPILaneExits
SIDRASolutions.SI.API.SIAPILaneMovement
SIDRASolutions.SI.API.SIAPILaneMovementMC
SIDRASolutions.SI.API.SIAPILaneMovementMCs
SIDRASolutions.SI.API.SIAPILaneMovements
SIDRASolutions.SI.API.SIAPILaneSegment
SIDRASolutions.SI.API.SIAPILaneSegmentMC
SIDRASolutions.SI.API.SIAPILaneSegmentMCs
SIDRASolutions.SI.API.SIAPILeg
SIDRASolutions.SI.API.SIAPILeg_rou_hcm
SIDRASolutions.SI.API.SIAPILeg_roundabout
SIDRASolutions.SI.API.SIAPILegs
SIDRASolutions.SI.API.SIAPIModelSetting
SIDRASolutions.SI.API.SIAPIMovement_ped
SIDRASolutions.SI.API.SIAPIMovement_peds
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od_mc
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od_mcs
SIDRASolutions.SI.API.SIAPIMovement_vehicle_ods
SIDRASolutions.SI.API.SIAPIMovementClass
SIDRASolutions.SI.API.SIAPIMovementClasses
SIDRASolutions.SI.API.SIAPIMovementClassFuelEmission
SIDRASolutions.SI.API.SIAPIMovementClassFuelEmissions
SIDRASolutions.SI.API.SIAPINetwork
SIDRASolutions.SI.API.SIAPINetworkCCG
SIDRASolutions.SI.API.SIAPINetworkCCGPhase
SIDRASolutions.SI.API.SIAPINetworkCCGPhases
SIDRASolutions.SI.API.SIAPINetworkCCGs
SIDRASolutions.SI.API.SIAPINetworkCCGSequence
SIDRASolutions.SI.API.SIAPINetworkCCGSequences
SIDRASolutions.SI.API.SIAPINetworkDemandSensitivity
SIDRASolutions.SI.API.SIAPINetworkLegConnection
SIDRASolutions.SI.API.SIAPINetworkLegConnections
SIDRASolutions.SI.API.SIAPINetworks
SIDRASolutions.SI.API.SIAPINetworkSite
SIDRASolutions.SI.API.SIAPINetworkSites
SIDRASolutions.SI.API.SIAPIOpposingmovement_ped
SIDRASolutions.SI.API.SIAPIOpposingmovement_peds
SIDRASolutions.SI.API.SIAPIOpposingmovement_vehicle
SIDRASolutions.SI.API.SIAPIOpposingmovement_vehicles
SIDRASolutions.SI.API.SIAPIOutputAnalysis
SIDRASolutions.SI.API.SIAPIOutputCirculatingLane
SIDRASolutions.SI.API.SIAPIOutputCirculatingLanes
SIDRASolutions.SI.API.SIAPIOutputGraphTuple
SIDRASolutions.SI.API.SIAPIOutputGraphTuples
SIDRASolutions.SI.API.SIAPIOutputLane
SIDRASolutions.SI.API.SIAPIOutputLaneGreenPeriod
SIDRASolutions.SI.API.SIAPIOutputLaneGreenPeriods
SIDRASolutions.SI.API.SIAPIOutputLaneMC
SIDRASolutions.SI.API.SIAPIOutputLaneMCs
SIDRASolutions.SI.API.SIAPIOutputLaneOD
SIDRASolutions.SI.API.SIAPIOutputLaneODMC
SIDRASolutions.SI.API.SIAPIOutputLaneODMCs
SIDRASolutions.SI.API.SIAPIOutputLaneODs
SIDRASolutions.SI.API.SIAPIOutputLanes
SIDRASolutions.SI.API.SIAPIOutputLeg
SIDRASolutions.SI.API.SIAPIOutputLegMC
SIDRASolutions.SI.API.SIAPIOutputLegMCs
SIDRASolutions.SI.API.SIAPIOutputLegPerson
SIDRASolutions.SI.API.SIAPIOutputLegPersons
SIDRASolutions.SI.API.SIAPIOutputLegs
SIDRASolutions.SI.API.SIAPIOutputMeteredRoundabout
SIDRASolutions.SI.API.SIAPIOutputMovementPed
SIDRASolutions.SI.API.SIAPIOutputMovementPed_GreenPeriod
SIDRASolutions.SI.API.SIAPIOutputMovementPed_GreenPeriods
SIDRASolutions.SI.API.SIAPIOutputMovementPeds
SIDRASolutions.SI.API.SIAPIOutputMovementPersonOD
SIDRASolutions.SI.API.SIAPIOutputMovementPersonODs
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleOD
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC_GreenPeriod
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC_GreenPeriods
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMCs
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODs
SIDRASolutions.SI.API.SIAPIOutputNetwork
SIDRASolutions.SI.API.SIAPIOutputNetworkGraphTuple
SIDRASolutions.SI.API.SIAPIOutputNetworkGraphTuples
SIDRASolutions.SI.API.SIAPIOutputNetworkPedestrian
SIDRASolutions.SI.API.SIAPIOutputNetworkPerson
SIDRASolutions.SI.API.SIAPIOutputNetworkVehicle
SIDRASolutions.SI.API.SIAPIOutputPhase
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPath
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPathMovement
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPathMovements
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPaths
SIDRASolutions.SI.API.SIAPIOutputPhases
SIDRASolutions.SI.API.SIAPIOutputRouteMovementBasedPerson
SIDRASolutions.SI.API.SIAPIOutputRouteMovementBasedVehicle
SIDRASolutions.SI.API.SIAPIOutputSequence
SIDRASolutions.SI.API.SIAPIOutputset
SIDRASolutions.SI.API.SIAPIOutputSitePedestrian
SIDRASolutions.SI.API.SIAPIOutputSitePerson
SIDRASolutions.SI.API.SIAPIOutputSiteRoute
SIDRASolutions.SI.API.SIAPIOutputSiteRoutes
SIDRASolutions.SI.API.SIAPIOutputSiteVehicle
SIDRASolutions.SI.API.SIAPIPhase
SIDRASolutions.SI.API.SIAPIPhasemovement_ped
SIDRASolutions.SI.API.SIAPIPhasemovement_peds
SIDRASolutions.SI.API.SIAPIPhasemovement_vehicle
SIDRASolutions.SI.API.SIAPIPhasemovement_vehicles
SIDRASolutions.SI.API.SIAPIPhases
SIDRASolutions.SI.API.SIAPIProject
SIDRASolutions.SI.API.SIAPIRoute
SIDRASolutions.SI.API.SIAPIRouteNwSite
SIDRASolutions.SI.API.SIAPIRouteNwSites
SIDRASolutions.SI.API.SIAPIRoutes
SIDRASolutions.SI.API.SIAPISensitivity
SIDRASolutions.SI.API.SIAPISequence
SIDRASolutions.SI.API.SIAPISequences
SIDRASolutions.SI.API.SIAPISite
SIDRASolutions.SI.API.SIAPISites
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjGeometryControl
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjGeometryControls
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjMajorNumLane
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjMajorNumLanes

See Also

Reference

SIDRASolutions.SI.API Assembly


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPI Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPI Class

Glossary Item Box

SIDRA INTERSECTION API wrapper class

Object Model

SIAPI ClassISIAPIProject Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPI
   Implements ISIAPI
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
C#
public sealed class SIAPI : ISIAPI
Managed Extensions for C++
public __gc __sealed class SIAPI : public ISIAPI
C++/CLI
public ref class SIAPI sealed : public ISIAPI

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPI

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPI Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPI Class

Glossary Item Box

The following tables list the members exposed by SIAPI.

Public Constructors

 | Name | Description
Public Constructor | SIAPI Constructor | SIAPI Constructor
Top

Public Properties

 | Name | Description
Public Property | DbConnection | Current DataContext.Connection
Public Property | IntPtrSize |
Public Property | IsLicensed | Indicates whether the installed version of SIDRA INTERSECTION is licensed.
Public Property | LastErrorMessage |
Public Property | Project | Current open SIDRA INTERSECTION project.
Top

Public Methods

 | Name | Description
Public Method | Close |
Public Method | CloseDbConnection | Closes the connection to the database (i.e. the project file)
Public Method | CloseProject | Closes a SIDRA INTERSECTION Project.
Public Method | CreateAndOpenProject | Creates and opens a SIDRA INTERSECTION Project.
Public Method | Dispose |
Public Method | OpenDbConnection | Opens the connection to the database (i.e. the project file)
Public Method | OpenProject | Opens a SIDRA INTERSECTION Project.
Public Method | SubmitDataChanges | Submits data changes to the database (i.e. the project file).
Top

See Also

Reference

SIAPI Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPI Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : SIAPI Constructor

Glossary Item Box

SIAPI Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPI()
C#
public SIAPI()
Managed Extensions for C++
public: SIAPI();
C++/CLI
public:
SIAPI();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPI Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPI Class

Glossary Item Box

For a list of all members of this type, see SIAPI members.

Public Methods

 | Name | Description
Public Method | Close |
Public Method | CloseDbConnection | Closes the connection to the database (i.e. the project file)
Public Method | CloseProject | Closes a SIDRA INTERSECTION Project.
Public Method | CreateAndOpenProject | Creates and opens a SIDRA INTERSECTION Project.
Public Method | Dispose |
Public Method | OpenDbConnection | Opens the connection to the database (i.e. the project file)
Public Method | OpenProject | Opens a SIDRA INTERSECTION Project.
Public Method | SubmitDataChanges | Submits data changes to the database (i.e. the project file).
Top

See Also

Reference

SIAPI Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Close Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Close() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.Close()
C#
public bool Close()
Managed Extensions for C++
public: bool Close();
C++/CLI
public:
bool Close();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloseDbConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : CloseDbConnection Method

Glossary Item Box

Closes the connection to the database (i.e. the project file)

Syntax

Visual Basic (Declaration)
Public Function CloseDbConnection() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.CloseDbConnection()
C#
public bool CloseDbConnection()
Managed Extensions for C++
public: bool CloseDbConnection();
C++/CLI
public:
bool CloseDbConnection();

Remarks

If the program is connecting to a temporary copy of the original project file, one thing needs to be considered. The submitted data changes might have not been saved to the temporary project file because there is a time interval before all submitted changes are flushed to disk. When the temporary project file is copied back to the original project file, some changes might not be included.

Call the CloseDbConnection() method to close the database connection to force all submitted changes to be flushed to disk. Call the OpenDbConnection() method to open the database connection again for later operations.

After all the changes are flushed to disk, the temporary project file includes all the submitted changes and is ready to be copied back to the original project file.

If the program is connecting to the original project file directly, the call to CloseDbConnection() is not required. All submitted changes will be flushed to disk every few seconds or when the project is closed at the end.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloseProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : CloseProject Method

Glossary Item Box

Closes a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Public Function CloseProject() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.CloseProject()
C#
public bool CloseProject()
Managed Extensions for C++
public: bool CloseProject();
C++/CLI
public:
bool CloseProject();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateAndOpenProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : CreateAndOpenProject Method

filename
Path of the SIDRA INTERSECTION Project file to open
newProjectName
The Project name

Glossary Item Box

Creates and opens a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Public Function CreateAndOpenProject( _
   ByVal filename As String, _
   ByVal newProjectName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim filename As String
Dim newProjectName As String
Dim value As Boolean

value = instance.CreateAndOpenProject(filename, newProjectName)
C#
public bool CreateAndOpenProject(
   string filename,
   string newProjectName
)
Managed Extensions for C++
public: bool CreateAndOpenProject(
   string* filename,
   string* newProjectName
)
C++/CLI
public:
bool CreateAndOpenProject(
   String^ filename,
   String^ newProjectName
)

Parameters

filename
Path of the SIDRA INTERSECTION Project file to open
newProjectName
The Project name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dispose Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As SIAPI

instance.Dispose()
C#
public void Dispose()
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpenDbConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : OpenDbConnection Method

Glossary Item Box

Opens the connection to the database (i.e. the project file)

Syntax

Visual Basic (Declaration)
Public Function OpenDbConnection() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.OpenDbConnection()
C#
public bool OpenDbConnection()
Managed Extensions for C++
public: bool OpenDbConnection();
C++/CLI
public:
bool OpenDbConnection();

Remarks

If the program is connecting to a temporary copy of the original project file, one thing needs to be considered. The submitted data changes might have not been saved to the temporary project file because there is a time interval before all submitted changes are flushed to disk. When the temporary project file is copied back to the original project file, some changes might not be included.

Call the CloseDbConnection() method to close the database connection to force all submitted changes to be flushed to disk. Call the OpenDbConnection() method to open the database connection again for later operations.

After all the changes are flushed to disk, the temporary project file includes all the submitted changes and is ready to be copied back to the original project file.

If the program is connecting to the original project file directly, the call to CloseDbConnection() is not required. All submitted changes will be flushed to disk every few seconds or when the project is closed at the end.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpenProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : OpenProject Method

filename
Path of the SIDRA INTERSECTION Project file to open

Glossary Item Box

Opens a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Public Function OpenProject( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim filename As String
Dim value As Boolean

value = instance.OpenProject(filename)
C#
public bool OpenProject(
   string filename
)
Managed Extensions for C++
public: bool OpenProject(
   string* filename
)
C++/CLI
public:
bool OpenProject(
   String^ filename
)

Parameters

filename
Path of the SIDRA INTERSECTION Project file to open

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SubmitDataChanges Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : SubmitDataChanges Method

Glossary Item Box

Submits data changes to the database (i.e. the project file).

Syntax

Visual Basic (Declaration)
Public Function SubmitDataChanges() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.SubmitDataChanges()
C#
public bool SubmitDataChanges()
Managed Extensions for C++
public: bool SubmitDataChanges();
C++/CLI
public:
bool SubmitDataChanges();

Remarks

This method calls the underlying DataContext.SubmitChanges() method.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPI Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPI Class

Glossary Item Box

For a list of all members of this type, see SIAPI members.

Public Properties

 | Name | Description
Public Property | DbConnection | Current DataContext.Connection
Public Property | IntPtrSize |
Public Property | IsLicensed | Indicates whether the installed version of SIDRA INTERSECTION is licensed.
Public Property | LastErrorMessage |
Public Property | Project | Current open SIDRA INTERSECTION project.
Top

See Also

Reference

SIAPI Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DbConnection Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : DbConnection Property

Glossary Item Box

Current DataContext.Connection

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DbConnection As DbConnection
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As DbConnection

value = instance.DbConnection
C#
public DbConnection DbConnection {get;}
Managed Extensions for C++
public: __property DbConnection* get_DbConnection();
C++/CLI
public:
property DbConnection^ DbConnection {
   DbConnection^ get();
}

Property Value

Type: System.Data.Common.DbConnection

If no project is open, NULL is returned.

Remarks

This property does not exist in COM Interface.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IntPtrSize Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : IntPtrSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IntPtrSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Integer

value = instance.IntPtrSize
C#
public int IntPtrSize {get;}
Managed Extensions for C++
public: __property int get_IntPtrSize();
C++/CLI
public:
property int IntPtrSize {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsLicensed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : IsLicensed Property

Glossary Item Box

Indicates whether the installed version of SIDRA INTERSECTION is licensed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsLicensed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As Boolean

value = instance.IsLicensed
C#
public bool IsLicensed {get;}
Managed Extensions for C++
public: __property bool get_IsLicensed();
C++/CLI
public:
property bool IsLicensed {
   bool get();
}

Property Value

Type: System.Boolean

True if licensed. False if unlicensed or in Trial Mode.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPI Class : Project Property

Glossary Item Box

Current open SIDRA INTERSECTION project.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As SIAPI
Dim value As ISIAPIProject

value = instance.Project
C#
public ISIAPIProject Project {get;}
Managed Extensions for C++
public: __property ISIAPIProject* get_Project();
C++/CLI
public:
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Property Value

Type: ISIAPIProject

If no project is open NULL is returned.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPI Class
SIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIAnalysis Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIAnalysis Class

Glossary Item Box

Object Model

SIAPIAnalysis ClassISIAPISensitivity InterfaceISIAPISensitivity InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIAnalysis
   Implements ISIAPIAnalysis
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
C#
public sealed class SIAPIAnalysis : ISIAPIAnalysis
Managed Extensions for C++
public __gc __sealed class SIAPIAnalysis : public ISIAPIAnalysis
C++/CLI
public ref class SIAPIAnalysis sealed : public ISIAPIAnalysis

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIAnalysis

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIAnalysis Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIAnalysis Class

Glossary Item Box

The following tables list the members exposed by SIAPIAnalysis.

Public Constructors

 | Name | Description
Public Constructor | SIAPIAnalysis Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis_option | Analysis Option
Public Property | Design_Life_Constant_num_years |
Public Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Public Property | Design_Life_Is_constant_num_years_applied |
Public Property | Design_Life_Objective | Design Life Analysis Objective
Public Property | Design_Life_Years |
Public Property | Flow_Scale_Constant_factor |
Public Property | Flow_Scale_Is_constant_factor_applied |
Public Property | Flow_Scale_Lower |
Public Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Public Property | Flow_Scale_Upper |
Public Property | Result_lane_origin |
Public Property | Result_laneno |
Public Property | Result_leg_origin |
Public Property | Result_mc_class |
Public Property | Result_option | Results For
Public Property | Result_pedmov_option | Pedestrian Movement Results Option
Public Property | Result_pedmov_origin |
Public Property | Result_pedmov_stage_no |
Public Property | Result_pedmov_type |
Public Property | Result_vehmov_dest |
Public Property | Result_vehmov_origin |
Public Property | Selected_sensitivity_groupno | Selected Sensitivity Parameter Group Number
Public Property | SensitivityGeneralParameterGroup |
Public Property | SensitivityRoundaboutParameterGroup |
Public Property | Site |
Top

See Also

Reference

SIAPIAnalysis Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIAnalysis Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : SIAPIAnalysis Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIAnalysis()
C#
public SIAPIAnalysis()
Managed Extensions for C++
public: SIAPIAnalysis();
C++/CLI
public:
SIAPIAnalysis();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIAnalysis Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIAnalysis Class

Glossary Item Box

For a list of all members of this type, see SIAPIAnalysis members.

Public Properties

 | Name | Description
Public Property | Analysis_option | Analysis Option
Public Property | Design_Life_Constant_num_years |
Public Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Public Property | Design_Life_Is_constant_num_years_applied |
Public Property | Design_Life_Objective | Design Life Analysis Objective
Public Property | Design_Life_Years |
Public Property | Flow_Scale_Constant_factor |
Public Property | Flow_Scale_Is_constant_factor_applied |
Public Property | Flow_Scale_Lower |
Public Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Public Property | Flow_Scale_Upper |
Public Property | Result_lane_origin |
Public Property | Result_laneno |
Public Property | Result_leg_origin |
Public Property | Result_mc_class |
Public Property | Result_option | Results For
Public Property | Result_pedmov_option | Pedestrian Movement Results Option
Public Property | Result_pedmov_origin |
Public Property | Result_pedmov_stage_no |
Public Property | Result_pedmov_type |
Public Property | Result_vehmov_dest |
Public Property | Result_vehmov_origin |
Public Property | Selected_sensitivity_groupno | Selected Sensitivity Parameter Group Number
Public Property | SensitivityGeneralParameterGroup |
Public Property | SensitivityRoundaboutParameterGroup |
Public Property | Site |
Top

See Also

Reference

SIAPIAnalysis Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Analysis_option Property

Glossary Item Box

Analysis Option

Syntax

Visual Basic (Declaration)
Public Property Analysis_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Analysis_option = value

value = instance.Analysis_option
C#
public int Analysis_option {get; set;}
Managed Extensions for C++
public: __property int get_Analysis_option();
public: __property void set_Analysis_option(
   int value
);
C++/CLI
public:
property int Analysis_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Sensitivity,
2 = Design Life,
3 = Flow Scale.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Constant_num_years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Design_Life_Constant_num_years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Constant_num_years As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Design_Life_Constant_num_years = value

value = instance.Design_Life_Constant_num_years
C#
public int Design_Life_Constant_num_years {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Constant_num_years();
public: __property void set_Design_Life_Constant_num_years(
   int value
);
C++/CLI
public:
property int Design_Life_Constant_num_years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Growth_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Design_Life_Growth_Model Property

Glossary Item Box

Design Life Analysis Growth Model

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Growth_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Design_Life_Growth_Model = value

value = instance.Design_Life_Growth_Model
C#
public int Design_Life_Growth_Model {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Growth_Model();
public: __property void set_Design_Life_Growth_Model(
   int value
);
C++/CLI
public:
property int Design_Life_Growth_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Uniform,
1 = Compound.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Is_constant_num_years_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Design_Life_Is_constant_num_years_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Is_constant_num_years_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Boolean

instance.Design_Life_Is_constant_num_years_applied = value

value = instance.Design_Life_Is_constant_num_years_applied
C#
public bool Design_Life_Is_constant_num_years_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Design_Life_Is_constant_num_years_applied();
public: __property void set_Design_Life_Is_constant_num_years_applied(
   bool value
);
C++/CLI
public:
property bool Design_Life_Is_constant_num_years_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Design_Life_Objective Property

Glossary Item Box

Design Life Analysis Objective

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Design_Life_Objective = value

value = instance.Design_Life_Objective
C#
public int Design_Life_Objective {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Objective();
public: __property void set_Design_Life_Objective(
   int value
);
C++/CLI
public:
property int Design_Life_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
2 = Worst Lane Level of Service Target,
3 = Worst Movement Level of Service Target,
4 = Final Year.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Design_Life_Years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Years As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Design_Life_Years = value

value = instance.Design_Life_Years
C#
public int Design_Life_Years {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Years();
public: __property void set_Design_Life_Years(
   int value
);
C++/CLI
public:
property int Design_Life_Years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Flow_Scale_Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Constant_factor = value

value = instance.Flow_Scale_Constant_factor
C#
public float Flow_Scale_Constant_factor {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Constant_factor();
public: __property void set_Flow_Scale_Constant_factor(
   float value
);
C++/CLI
public:
property float Flow_Scale_Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Flow_Scale_Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Boolean

instance.Flow_Scale_Is_constant_factor_applied = value

value = instance.Flow_Scale_Is_constant_factor_applied
C#
public bool Flow_Scale_Is_constant_factor_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Flow_Scale_Is_constant_factor_applied();
public: __property void set_Flow_Scale_Is_constant_factor_applied(
   bool value
);
C++/CLI
public:
property bool Flow_Scale_Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Flow_Scale_Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Lower = value

value = instance.Flow_Scale_Lower
C#
public float Flow_Scale_Lower {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Lower();
public: __property void set_Flow_Scale_Lower(
   float value
);
C++/CLI
public:
property float Flow_Scale_Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Flow_Scale_Objective Property

Glossary Item Box

Flow Scale Analysis Objective

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Flow_Scale_Objective = value

value = instance.Flow_Scale_Objective
C#
public int Flow_Scale_Objective {get; set;}
Managed Extensions for C++
public: __property int get_Flow_Scale_Objective();
public: __property void set_Flow_Scale_Objective(
   int value
);
C++/CLI
public:
property int Flow_Scale_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
2 = Worst Lane Level of Service Target,
3 = Worst Movement Level of Service Target,
4 = Upper Limit.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Flow_Scale_Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Upper = value

value = instance.Flow_Scale_Upper
C#
public float Flow_Scale_Upper {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Upper();
public: __property void set_Flow_Scale_Upper(
   float value
);
C++/CLI
public:
property float Flow_Scale_Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_lane_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_lane_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_lane_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_lane_origin = value

value = instance.Result_lane_origin
C#
public int Result_lane_origin {get; set;}
Managed Extensions for C++
public: __property int get_Result_lane_origin();
public: __property void set_Result_lane_origin(
   int value
);
C++/CLI
public:
property int Result_lane_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_laneno = value

value = instance.Result_laneno
C#
public int Result_laneno {get; set;}
Managed Extensions for C++
public: __property int get_Result_laneno();
public: __property void set_Result_laneno(
   int value
);
C++/CLI
public:
property int Result_laneno {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_leg_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_leg_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_leg_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_leg_origin = value

value = instance.Result_leg_origin
C#
public int Result_leg_origin {get; set;}
Managed Extensions for C++
public: __property int get_Result_leg_origin();
public: __property void set_Result_leg_origin(
   int value
);
C++/CLI
public:
property int Result_leg_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_mc_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_mc_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_mc_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_mc_class = value

value = instance.Result_mc_class
C#
public int Result_mc_class {get; set;}
Managed Extensions for C++
public: __property int get_Result_mc_class();
public: __property void set_Result_mc_class(
   int value
);
C++/CLI
public:
property int Result_mc_class {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_option Property

Glossary Item Box

Results For

Syntax

Visual Basic (Declaration)
Public Property Result_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_option = value

value = instance.Result_option
C#
public int Result_option {get; set;}
Managed Extensions for C++
public: __property int get_Result_option();
public: __property void set_Result_option(
   int value
);
C++/CLI
public:
property int Result_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Intersection - Vehicles,
2 = Intersection - Pedestrians,
3 = Intersection - Persons,
4 = Lane,
5 = Vehicle OD Movement,
6 = Pedestrian Movement,
7 = Approach (All Movements / All Lanes).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_pedmov_option Property

Glossary Item Box

Pedestrian Movement Results Option

Syntax

Visual Basic (Declaration)
Public Property Result_pedmov_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_option = value

value = instance.Result_pedmov_option
C#
public int Result_pedmov_option {get; set;}
Managed Extensions for C++
public: __property int get_Result_pedmov_option();
public: __property void set_Result_pedmov_option(
   int value
);
C++/CLI
public:
property int Result_pedmov_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Movement in front of an Approach,
2 = Diagonal Crossing Movement.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_pedmov_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_pedmov_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_origin = value

value = instance.Result_pedmov_origin
C#
public int Result_pedmov_origin {get; set;}
Managed Extensions for C++
public: __property int get_Result_pedmov_origin();
public: __property void set_Result_pedmov_origin(
   int value
);
C++/CLI
public:
property int Result_pedmov_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_stage_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_pedmov_stage_no Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_pedmov_stage_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_stage_no = value

value = instance.Result_pedmov_stage_no
C#
public int Result_pedmov_stage_no {get; set;}
Managed Extensions for C++
public: __property int get_Result_pedmov_stage_no();
public: __property void set_Result_pedmov_stage_no(
   int value
);
C++/CLI
public:
property int Result_pedmov_stage_no {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_pedmov_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_pedmov_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_type = value

value = instance.Result_pedmov_type
C#
public int Result_pedmov_type {get; set;}
Managed Extensions for C++
public: __property int get_Result_pedmov_type();
public: __property void set_Result_pedmov_type(
   int value
);
C++/CLI
public:
property int Result_pedmov_type {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_vehmov_dest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_vehmov_dest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_vehmov_dest As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_vehmov_dest = value

value = instance.Result_vehmov_dest
C#
public int Result_vehmov_dest {get; set;}
Managed Extensions for C++
public: __property int get_Result_vehmov_dest();
public: __property void set_Result_vehmov_dest(
   int value
);
C++/CLI
public:
property int Result_vehmov_dest {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_vehmov_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Result_vehmov_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Result_vehmov_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Result_vehmov_origin = value

value = instance.Result_vehmov_origin
C#
public int Result_vehmov_origin {get; set;}
Managed Extensions for C++
public: __property int get_Result_vehmov_origin();
public: __property void set_Result_vehmov_origin(
   int value
);
C++/CLI
public:
property int Result_vehmov_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_sensitivity_groupno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Selected_sensitivity_groupno Property

Glossary Item Box

Selected Sensitivity Parameter Group Number

Syntax

Visual Basic (Declaration)
Public Property Selected_sensitivity_groupno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As Integer

instance.Selected_sensitivity_groupno = value

value = instance.Selected_sensitivity_groupno
C#
public int Selected_sensitivity_groupno {get; set;}
Managed Extensions for C++
public: __property int get_Selected_sensitivity_groupno();
public: __property void set_Selected_sensitivity_groupno(
   int value
);
C++/CLI
public:
property int Selected_sensitivity_groupno {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = General Parameter Group,
1 = Roundabout Parameter Group.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityGeneralParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : SensitivityGeneralParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SensitivityGeneralParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As ISIAPISensitivity

value = instance.SensitivityGeneralParameterGroup
C#
public ISIAPISensitivity SensitivityGeneralParameterGroup {get;}
Managed Extensions for C++
public: __property ISIAPISensitivity* get_SensitivityGeneralParameterGroup();
C++/CLI
public:
property ISIAPISensitivity^ SensitivityGeneralParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityRoundaboutParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : SensitivityRoundaboutParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SensitivityRoundaboutParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As ISIAPISensitivity

value = instance.SensitivityRoundaboutParameterGroup
C#
public ISIAPISensitivity SensitivityRoundaboutParameterGroup {get;}
Managed Extensions for C++
public: __property ISIAPISensitivity* get_SensitivityRoundaboutParameterGroup();
C++/CLI
public:
property ISIAPISensitivity^ SensitivityRoundaboutParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIAnalysis Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIAnalysis
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIAnalysis Class
SIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsg Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsg Class

Glossary Item Box

Object Model

SIAPIDiagnosticMsg Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIDiagnosticMsg
   Implements ISIAPIDiagnosticMsg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsg
C#
public sealed class SIAPIDiagnosticMsg : ISIAPIDiagnosticMsg
Managed Extensions for C++
public __gc __sealed class SIAPIDiagnosticMsg : public ISIAPIDiagnosticMsg
C++/CLI
public ref class SIAPIDiagnosticMsg sealed : public ISIAPIDiagnosticMsg

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIDiagnosticMsg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsg Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsg Class

Glossary Item Box

The following tables list the members exposed by SIAPIDiagnosticMsg.

Public Constructors

 | Name | Description
Public Constructor | SIAPIDiagnosticMsg Constructor |
Top

Public Properties

 | Name | Description
Public Property | Log_time |
Public Property | Message |
Public Property | Message_type | Message Type
Top

See Also

Reference

SIAPIDiagnosticMsg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsg Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsg Class : SIAPIDiagnosticMsg Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIDiagnosticMsg()
C#
public SIAPIDiagnosticMsg()
Managed Extensions for C++
public: SIAPIDiagnosticMsg();
C++/CLI
public:
SIAPIDiagnosticMsg();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsg Class
SIAPIDiagnosticMsg Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsg Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsg Class

Glossary Item Box

For a list of all members of this type, see SIAPIDiagnosticMsg members.

Public Properties

 | Name | Description
Public Property | Log_time |
Public Property | Message |
Public Property | Message_type | Message Type
Top

See Also

Reference

SIAPIDiagnosticMsg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Log_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsg Class : Log_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Log_time As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsg
Dim value As Date

value = instance.Log_time
C#
public DateTime Log_time {get;}
Managed Extensions for C++
public: __property DateTime get_Log_time();
C++/CLI
public:
property DateTime Log_time {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsg Class
SIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Message Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsg Class : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsg
Dim value As String

value = instance.Message
C#
public string Message {get;}
Managed Extensions for C++
public: __property string* get_Message();
C++/CLI
public:
property String^ Message {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsg Class
SIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Message_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsg Class : Message_type Property

Glossary Item Box

Message Type

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Message_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsg
Dim value As Integer

value = instance.Message_type
C#
public int Message_type {get;}
Managed Extensions for C++
public: __property int get_Message_type();
C++/CLI
public:
property int Message_type {
   int get();
}

Property Value

Type: System.Int32;

0 = Information,
1 = Warning,
2 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsg Class
SIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsgs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsgs Class

Glossary Item Box

Object Model

SIAPIDiagnosticMsgs ClassISIAPIDiagnosticMsg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIDiagnosticMsgs
   Implements ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsgs
C#
public sealed class SIAPIDiagnosticMsgs : ISIAPIDiagnosticMsgs
Managed Extensions for C++
public __gc __sealed class SIAPIDiagnosticMsgs : public ISIAPIDiagnosticMsgs
C++/CLI
public ref class SIAPIDiagnosticMsgs sealed : public ISIAPIDiagnosticMsgs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIDiagnosticMsgs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsgs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsgs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsgs Class

Glossary Item Box

The following tables list the members exposed by SIAPIDiagnosticMsgs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIDiagnosticMsgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIDiagnosticMsgs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsgs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsgs Class : SIAPIDiagnosticMsgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIDiagnosticMsgs()
C#
public SIAPIDiagnosticMsgs()
Managed Extensions for C++
public: SIAPIDiagnosticMsgs();
C++/CLI
public:
SIAPIDiagnosticMsgs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsgs Class
SIAPIDiagnosticMsgs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsgs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsgs Class

Glossary Item Box

For a list of all members of this type, see SIAPIDiagnosticMsgs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIDiagnosticMsgs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsgs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsgs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsgs Class
SIAPIDiagnosticMsgs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIDiagnosticMsgs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIDiagnosticMsgs Class

Glossary Item Box

For a list of all members of this type, see SIAPIDiagnosticMsgs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIDiagnosticMsgs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsgs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsgs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsgs Class
SIAPIDiagnosticMsgs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIDiagnosticMsgs Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIDiagnosticMsg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIDiagnosticMsgs
Dim index As Integer
Dim value As ISIAPIDiagnosticMsg

value = instance.Item(index)
C#
public ISIAPIDiagnosticMsg this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIDiagnosticMsg* get_Item   int index
;
C++/CLI
public:
property ISIAPIDiagnosticMsg^ default [int] {
   ISIAPIDiagnosticMsg^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIDiagnosticMsgs Class
SIAPIDiagnosticMsgs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIGapAcceptanceSpecificApp Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIGapAcceptanceSpecificApp Class

Glossary Item Box

Object Model

SIAPIGapAcceptanceSpecificApp Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIGapAcceptanceSpecificApp
   Implements ISIAPIGapAcceptanceSpecificApp
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
C#
public sealed class SIAPIGapAcceptanceSpecificApp : ISIAPIGapAcceptanceSpecificApp
Managed Extensions for C++
public __gc __sealed class SIAPIGapAcceptanceSpecificApp : public ISIAPIGapAcceptanceSpecificApp
C++/CLI
public ref class SIAPIGapAcceptanceSpecificApp sealed : public ISIAPIGapAcceptanceSpecificApp

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIGapAcceptanceSpecificApp

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIGapAcceptanceSpecificApp Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIGapAcceptanceSpecificApp Class

Glossary Item Box

The following tables list the members exposed by SIAPIGapAcceptanceSpecificApp.

Public Constructors

 | Name | Description
Public Constructor | SIAPIGapAcceptanceSpecificApp Constructor |
Top

Public Properties

 | Name | Description
Public Property | Critical_gap |
Public Property | End_departures |
Public Property | Exit_flow_effect |
Public Property | Followup_headway |
Public Property | Percent_opposed_by_nearest |
Top

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIGapAcceptanceSpecificApp Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : SIAPIGapAcceptanceSpecificApp Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIGapAcceptanceSpecificApp()
C#
public SIAPIGapAcceptanceSpecificApp()
Managed Extensions for C++
public: SIAPIGapAcceptanceSpecificApp();
C++/CLI
public:
SIAPIGapAcceptanceSpecificApp();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIGapAcceptanceSpecificApp Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIGapAcceptanceSpecificApp Class

Glossary Item Box

For a list of all members of this type, see SIAPIGapAcceptanceSpecificApp members.

Public Properties

 | Name | Description
Public Property | Critical_gap |
Public Property | End_departures |
Public Property | Exit_flow_effect |
Public Property | Followup_headway |
Public Property | Percent_opposed_by_nearest |
Top

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : Critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Critical_gap = value

value = instance.Critical_gap
C#
public float Critical_gap {get; set;}
Managed Extensions for C++
public: __property float get_Critical_gap();
public: __property void set_Critical_gap(
   float value
);
C++/CLI
public:
property float Critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : End_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property End_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.End_departures = value

value = instance.End_departures
C#
public float End_departures {get; set;}
Managed Extensions for C++
public: __property float get_End_departures();
public: __property void set_End_departures(
   float value
);
C++/CLI
public:
property float End_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_flow_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : Exit_flow_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Exit_flow_effect As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Exit_flow_effect = value

value = instance.Exit_flow_effect
C#
public float Exit_flow_effect {get; set;}
Managed Extensions for C++
public: __property float get_Exit_flow_effect();
public: __property void set_Exit_flow_effect(
   float value
);
C++/CLI
public:
property float Exit_flow_effect {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : Followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Followup_headway = value

value = instance.Followup_headway
C#
public float Followup_headway {get; set;}
Managed Extensions for C++
public: __property float get_Followup_headway();
public: __property void set_Followup_headway(
   float value
);
C++/CLI
public:
property float Followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_opposed_by_nearest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIGapAcceptanceSpecificApp Class : Percent_opposed_by_nearest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Percent_opposed_by_nearest As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Percent_opposed_by_nearest = value

value = instance.Percent_opposed_by_nearest
C#
public float Percent_opposed_by_nearest {get; set;}
Managed Extensions for C++
public: __property float get_Percent_opposed_by_nearest();
public: __property void set_Percent_opposed_by_nearest(
   float value
);
C++/CLI
public:
property float Percent_opposed_by_nearest {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIGapAcceptanceSpecificApp Class
SIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIsland Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIsland Class

Glossary Item Box

Object Model

SIAPIIsland Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIIsland
   Implements ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
C#
public sealed class SIAPIIsland : ISIAPIIsland
Managed Extensions for C++
public __gc __sealed class SIAPIIsland : public ISIAPIIsland
C++/CLI
public ref class SIAPIIsland sealed : public ISIAPIIsland

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIIsland

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIsland Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIsland Class

Glossary Item Box

The following tables list the members exposed by SIAPIIsland.

Public Constructors

 | Name | Description
Public Constructor | SIAPIIsland Constructor |
Top

Public Properties

 | Name | Description
Public Property | Fill_style | Island Fill Style
Public Property | Is_pedstage_separator |
Public Property | Is_rou_splitter |
Public Property | Island_no | Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Width | Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.
Public Property | Width_back | Island's Back Width
Top

See Also

Reference

SIAPIIsland Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIsland Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : SIAPIIsland Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIIsland()
C#
public SIAPIIsland()
Managed Extensions for C++
public: SIAPIIsland();
C++/CLI
public:
SIAPIIsland();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIsland Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIsland Class

Glossary Item Box

For a list of all members of this type, see SIAPIIsland members.

Public Properties

 | Name | Description
Public Property | Fill_style | Island Fill Style
Public Property | Is_pedstage_separator |
Public Property | Is_rou_splitter |
Public Property | Island_no | Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Width | Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.
Public Property | Width_back | Island's Back Width
Top

See Also

Reference

SIAPIIsland Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fill_style Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Fill_style Property

Glossary Item Box

Island Fill Style

Syntax

Visual Basic (Declaration)
Public Property Fill_style As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Integer

instance.Fill_style = value

value = instance.Fill_style
C#
public int Fill_style {get; set;}
Managed Extensions for C++
public: __property int get_Fill_style();
public: __property void set_Fill_style(
   int value
);
C++/CLI
public:
property int Fill_style {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Solid,
2 = Hatched,
3 = Chevron,
4 = Parking Strip.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_pedstage_separator Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Is_pedstage_separator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_pedstage_separator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Boolean

instance.Is_pedstage_separator = value

value = instance.Is_pedstage_separator
C#
public bool Is_pedstage_separator {get; set;}
Managed Extensions for C++
public: __property bool get_Is_pedstage_separator();
public: __property void set_Is_pedstage_separator(
   bool value
);
C++/CLI
public:
property bool Is_pedstage_separator {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_rou_splitter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Is_rou_splitter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Is_rou_splitter As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Boolean

value = instance.Is_rou_splitter
C#
public bool Is_rou_splitter {get;}
Managed Extensions for C++
public: __property bool get_Is_rou_splitter();
C++/CLI
public:
property bool Is_rou_splitter {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Island_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Island_no Property

Glossary Item Box

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Island_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Integer

value = instance.Island_no
C#
public int Island_no {get;}
Managed Extensions for C++
public: __property int get_Island_no();
C++/CLI
public:
property int Island_no {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Width Property

Glossary Item Box

Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width_back Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIsland Class : Width_back Property

Glossary Item Box

Island's Back Width

Syntax

Visual Basic (Declaration)
Public Property Width_back As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIsland
Dim value As Single

instance.Width_back = value

value = instance.Width_back
C#
public float Width_back {get; set;}
Managed Extensions for C++
public: __property float get_Width_back();
public: __property void set_Width_back(
   float value
);
C++/CLI
public:
property float Width_back {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIsland Class
SIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIslands Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIslands Class

Glossary Item Box

Object Model

SIAPIIslands ClassISIAPIIsland Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIIslands
   Implements ISIAPIIslands
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIslands
C#
public sealed class SIAPIIslands : ISIAPIIslands
Managed Extensions for C++
public __gc __sealed class SIAPIIslands : public ISIAPIIslands
C++/CLI
public ref class SIAPIIslands sealed : public ISIAPIIslands

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIIslands

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIslands Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIslands Class

Glossary Item Box

The following tables list the members exposed by SIAPIIslands.

Public Constructors

 | Name | Description
Public Constructor | SIAPIIslands Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | IslandExists |
Top

See Also

Reference

SIAPIIslands Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIslands Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIslands Class : SIAPIIslands Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIIslands()
C#
public SIAPIIslands()
Managed Extensions for C++
public: SIAPIIslands();
C++/CLI
public:
SIAPIIslands();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Class
SIAPIIslands Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIslands Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIslands Class

Glossary Item Box

For a list of all members of this type, see SIAPIIslands members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | IslandExists |
Top

See Also

Reference

SIAPIIslands Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIslands Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIslands
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Class
SIAPIIslands Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IslandExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIslands Class : IslandExists Method

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IslandExists( _
   ByVal island_no As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIslands
Dim island_no As Integer
Dim value As Boolean

value = instance.IslandExists(island_no)
C#
public bool IslandExists(
   int island_no
)
Managed Extensions for C++
public: bool IslandExists(
   int island_no
)
C++/CLI
public:
bool IslandExists(
   int island_no
)

Parameters

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Class
SIAPIIslands Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIIslands Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIIslands Class

Glossary Item Box

For a list of all members of this type, see SIAPIIslands members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIIslands Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIslands Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIslands
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Class
SIAPIIslands Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIIslands Class : Item Property

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal island_no As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As SIAPIIslands
Dim island_no As Integer
Dim value As ISIAPIIsland

value = instance.Item(island_no)
C#
public ISIAPIIsland this[
   int island_no
]; {get;}
Managed Extensions for C++
public: __property ISIAPIIsland* get_Item   int island_no
;
C++/CLI
public:
property ISIAPIIsland^ default [int] {
   ISIAPIIsland^ get(int island_no);
}

Parameters

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIIslands Class
SIAPIIslands Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproach Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproach Class

Glossary Item Box

Object Model

SIAPILaneApproach ClassISIAPILaneApproachMovements InterfaceISIAPILaneApproachMovement InterfaceISIAPILaneMovements InterfaceISIAPILaneMovement InterfaceISIAPILeg InterfaceISIAPILaneSegment InterfaceISIAPILaneSegment Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproach
   Implements ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
C#
public sealed class SIAPILaneApproach : ISIAPILaneApproach
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproach : public ISIAPILaneApproach
C++/CLI
public ref class SIAPILaneApproach sealed : public ISIAPILaneApproach

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproach

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproach Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproach Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproach.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproach Constructor |
Top

Public Properties

 | Name | Description
Public Property | Basic_saturation_flow |
Public Property | Buses_stopping |
Public Property | Buses_stopping_user |
Public Property | Capacity_adjustment |
Public Property | Configuration | Lane Configuration
Public Property | Control_type | Lane Control Type
Public Property | Departure_headway_awsc |
Public Property | Grade |
Public Property | Is_capacity_adj_for_network |
Public Property | Is_departure_headway_awsc_applied |
Public Property | Is_dominant_lane |
Public Property | Is_sliplane_excluded_from_signal_analysis |
Public Property | Is_sliplane_included_in_entry_lane_count |
Public Property | LaneApproachMovements | Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).
Public Property | LaneMovements |
Public Property | Laneno | Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.
Public Property | LastErrorMessage |
Public Property | Leg |
Public Property | Length | Lane Length
Public Property | Parking_manoeuvres |
Public Property | Parking_manoeuvres_user |
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Saturation_speed |
Public Property | Saturation_speed_user |
Public Property | Segment1 | Lane Segement 1
Public Property | Segment2 | Lane Segement 2
Public Property | Slip_control_type | Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.
Public Property | Type | Lane Type
Public Property | Utilisation |
Public Property | Utilisation_user |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | RemoveDisciplines | Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).
Top

See Also

Reference

SIAPILaneApproach Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproach Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : SIAPILaneApproach Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproach()
C#
public SIAPILaneApproach()
Managed Extensions for C++
public: SIAPILaneApproach();
C++/CLI
public:
SIAPILaneApproach();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproach Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproach Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproach members.

Public Methods

 | Name | Description
Public Method | RemoveDisciplines | Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).
Top

See Also

Reference

SIAPILaneApproach Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveDisciplines Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : RemoveDisciplines Method

Glossary Item Box

Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).

Syntax

Visual Basic (Declaration)
Public Function RemoveDisciplines() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

value = instance.RemoveDisciplines()
C#
public bool RemoveDisciplines()
Managed Extensions for C++
public: bool RemoveDisciplines();
C++/CLI
public:
bool RemoveDisciplines();

Return Value

true if all Disciplines are removed successfully; otherwise, false.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproach Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproach Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproach members.

Public Properties

 | Name | Description
Public Property | Basic_saturation_flow |
Public Property | Buses_stopping |
Public Property | Buses_stopping_user |
Public Property | Capacity_adjustment |
Public Property | Configuration | Lane Configuration
Public Property | Control_type | Lane Control Type
Public Property | Departure_headway_awsc |
Public Property | Grade |
Public Property | Is_capacity_adj_for_network |
Public Property | Is_departure_headway_awsc_applied |
Public Property | Is_dominant_lane |
Public Property | Is_sliplane_excluded_from_signal_analysis |
Public Property | Is_sliplane_included_in_entry_lane_count |
Public Property | LaneApproachMovements | Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).
Public Property | LaneMovements |
Public Property | Laneno | Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.
Public Property | LastErrorMessage |
Public Property | Leg |
Public Property | Length | Lane Length
Public Property | Parking_manoeuvres |
Public Property | Parking_manoeuvres_user |
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Saturation_speed |
Public Property | Saturation_speed_user |
Public Property | Segment1 | Lane Segement 1
Public Property | Segment2 | Lane Segement 2
Public Property | Slip_control_type | Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.
Public Property | Type | Lane Type
Public Property | Utilisation |
Public Property | Utilisation_user |
Public Property | Width |
Top

See Also

Reference

SIAPILaneApproach Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Basic_saturation_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Basic_saturation_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Basic_saturation_flow As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Basic_saturation_flow = value

value = instance.Basic_saturation_flow
C#
public int Basic_saturation_flow {get; set;}
Managed Extensions for C++
public: __property int get_Basic_saturation_flow();
public: __property void set_Basic_saturation_flow(
   int value
);
C++/CLI
public:
property int Basic_saturation_flow {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Buses_stopping Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Buses_stopping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Buses_stopping As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Buses_stopping = value

value = instance.Buses_stopping
C#
public int Buses_stopping {get; set;}
Managed Extensions for C++
public: __property int get_Buses_stopping();
public: __property void set_Buses_stopping(
   int value
);
C++/CLI
public:
property int Buses_stopping {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Buses_stopping_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Buses_stopping_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Buses_stopping_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Buses_stopping_user = value

value = instance.Buses_stopping_user
C#
public bool Buses_stopping_user {get; set;}
Managed Extensions for C++
public: __property bool get_Buses_stopping_user();
public: __property void set_Buses_stopping_user(
   bool value
);
C++/CLI
public:
property bool Buses_stopping_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adjustment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Capacity_adjustment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity_adjustment As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Capacity_adjustment = value

value = instance.Capacity_adjustment
C#
public float Capacity_adjustment {get; set;}
Managed Extensions for C++
public: __property float get_Capacity_adjustment();
public: __property void set_Capacity_adjustment(
   float value
);
C++/CLI
public:
property float Capacity_adjustment {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Configuration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Configuration Property

Glossary Item Box

Lane Configuration

Syntax

Visual Basic (Declaration)
Public Property Configuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Configuration = value

value = instance.Configuration
C#
public int Configuration {get; set;}
Managed Extensions for C++
public: __property int get_Configuration();
public: __property void set_Configuration(
   int value
);
C++/CLI
public:
property int Configuration {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Full-Length Lane,
2 = Short Lane,
3 = Short Lane with Parking,
4 = Two-Segment Lane.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Control_type Property

Glossary Item Box

Lane Control Type

Syntax

Visual Basic (Declaration)
Public Property Control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Control_type = value

value = instance.Control_type
C#
public int Control_type {get; set;}
Managed Extensions for C++
public: __property int get_Control_type();
public: __property void set_Control_type(
   int value
);
C++/CLI
public:
property int Control_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Signals,
2 = Giveway/Yield,
3 = Stop,
4 = Continuous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Departure_headway_awsc Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Departure_headway_awsc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Departure_headway_awsc As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Departure_headway_awsc = value

value = instance.Departure_headway_awsc
C#
public float Departure_headway_awsc {get; set;}
Managed Extensions for C++
public: __property float get_Departure_headway_awsc();
public: __property void set_Departure_headway_awsc(
   float value
);
C++/CLI
public:
property float Departure_headway_awsc {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Grade As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Grade = value

value = instance.Grade
C#
public float Grade {get; set;}
Managed Extensions for C++
public: __property float get_Grade();
public: __property void set_Grade(
   float value
);
C++/CLI
public:
property float Grade {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_capacity_adj_for_network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Is_capacity_adj_for_network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_capacity_adj_for_network As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Is_capacity_adj_for_network = value

value = instance.Is_capacity_adj_for_network
C#
public bool Is_capacity_adj_for_network {get; set;}
Managed Extensions for C++
public: __property bool get_Is_capacity_adj_for_network();
public: __property void set_Is_capacity_adj_for_network(
   bool value
);
C++/CLI
public:
property bool Is_capacity_adj_for_network {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_departure_headway_awsc_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Is_departure_headway_awsc_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_departure_headway_awsc_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Is_departure_headway_awsc_applied = value

value = instance.Is_departure_headway_awsc_applied
C#
public bool Is_departure_headway_awsc_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_departure_headway_awsc_applied();
public: __property void set_Is_departure_headway_awsc_applied(
   bool value
);
C++/CLI
public:
property bool Is_departure_headway_awsc_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_dominant_lane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Is_dominant_lane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_dominant_lane As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Is_dominant_lane = value

value = instance.Is_dominant_lane
C#
public bool Is_dominant_lane {get; set;}
Managed Extensions for C++
public: __property bool get_Is_dominant_lane();
public: __property void set_Is_dominant_lane(
   bool value
);
C++/CLI
public:
property bool Is_dominant_lane {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_sliplane_excluded_from_signal_analysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Is_sliplane_excluded_from_signal_analysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_sliplane_excluded_from_signal_analysis As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Is_sliplane_excluded_from_signal_analysis = value

value = instance.Is_sliplane_excluded_from_signal_analysis
C#
public bool Is_sliplane_excluded_from_signal_analysis {get; set;}
Managed Extensions for C++
public: __property bool get_Is_sliplane_excluded_from_signal_analysis();
public: __property void set_Is_sliplane_excluded_from_signal_analysis(
   bool value
);
C++/CLI
public:
property bool Is_sliplane_excluded_from_signal_analysis {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_sliplane_included_in_entry_lane_count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Is_sliplane_included_in_entry_lane_count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_sliplane_included_in_entry_lane_count As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Is_sliplane_included_in_entry_lane_count = value

value = instance.Is_sliplane_included_in_entry_lane_count
C#
public bool Is_sliplane_included_in_entry_lane_count {get; set;}
Managed Extensions for C++
public: __property bool get_Is_sliplane_included_in_entry_lane_count();
public: __property void set_Is_sliplane_included_in_entry_lane_count(
   bool value
);
C++/CLI
public:
property bool Is_sliplane_included_in_entry_lane_count {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : LaneApproachMovements Property

Glossary Item Box

Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproachMovements As ISIAPILaneApproachMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As ISIAPILaneApproachMovements

value = instance.LaneApproachMovements
C#
public ISIAPILaneApproachMovements LaneApproachMovements {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachMovements* get_LaneApproachMovements();
C++/CLI
public:
property ISIAPILaneApproachMovements^ LaneApproachMovements {
   ISIAPILaneApproachMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : LaneMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneMovements As ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As ISIAPILaneMovements

value = instance.LaneMovements
C#
public ISIAPILaneMovements LaneMovements {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovements* get_LaneMovements();
C++/CLI
public:
property ISIAPILaneMovements^ LaneMovements {
   ISIAPILaneMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Laneno Property

Glossary Item Box

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

value = instance.Laneno
C#
public int Laneno {get;}
Managed Extensions for C++
public: __property int get_Laneno();
C++/CLI
public:
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As ISIAPILeg

value = instance.Leg
C#
public ISIAPILeg Leg {get;}
Managed Extensions for C++
public: __property ISIAPILeg* get_Leg();
C++/CLI
public:
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Length Property

Glossary Item Box

Lane Length

Syntax

Visual Basic (Declaration)
Public Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Length = value

value = instance.Length
C#
public float Length {get; set;}
Managed Extensions for C++
public: __property float get_Length();
public: __property void set_Length(
   float value
);
C++/CLI
public:
property float Length {
   float get();
   void set (    float value);
}

Remarks

For Full-Length Lane or Two-Segment Lane, this is the Length of the whole Lane; for Short Lane or Short Lane with Parking, this is synchronized with the Segment 1 Length

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Parking_manoeuvres Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Parking_manoeuvres Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Parking_manoeuvres As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Parking_manoeuvres = value

value = instance.Parking_manoeuvres
C#
public int Parking_manoeuvres {get; set;}
Managed Extensions for C++
public: __property int get_Parking_manoeuvres();
public: __property void set_Parking_manoeuvres(
   int value
);
C++/CLI
public:
property int Parking_manoeuvres {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Parking_manoeuvres_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Parking_manoeuvres_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Parking_manoeuvres_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Parking_manoeuvres_user = value

value = instance.Parking_manoeuvres_user
C#
public bool Parking_manoeuvres_user {get; set;}
Managed Extensions for C++
public: __property bool get_Parking_manoeuvres_user();
public: __property void set_Parking_manoeuvres_user(
   bool value
);
C++/CLI
public:
property bool Parking_manoeuvres_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Saturation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Saturation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Saturation_speed = value

value = instance.Saturation_speed
C#
public float Saturation_speed {get; set;}
Managed Extensions for C++
public: __property float get_Saturation_speed();
public: __property void set_Saturation_speed(
   float value
);
C++/CLI
public:
property float Saturation_speed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_speed_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Saturation_speed_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Saturation_speed_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Saturation_speed_user = value

value = instance.Saturation_speed_user
C#
public bool Saturation_speed_user {get; set;}
Managed Extensions for C++
public: __property bool get_Saturation_speed_user();
public: __property void set_Saturation_speed_user(
   bool value
);
C++/CLI
public:
property bool Saturation_speed_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Segment1 Property

Glossary Item Box

Lane Segement 1

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segment1 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As ISIAPILaneSegment

value = instance.Segment1
C#
public ISIAPILaneSegment Segment1 {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegment* get_Segment1();
C++/CLI
public:
property ISIAPILaneSegment^ Segment1 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Segment2 Property

Glossary Item Box

Lane Segement 2

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segment2 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As ISIAPILaneSegment

value = instance.Segment2
C#
public ISIAPILaneSegment Segment2 {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegment* get_Segment2();
C++/CLI
public:
property ISIAPILaneSegment^ Segment2 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Slip_control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Slip_control_type Property

Glossary Item Box

Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.

Syntax

Visual Basic (Declaration)
Public Property Slip_control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Slip_control_type = value

value = instance.Slip_control_type
C#
public int Slip_control_type {get; set;}
Managed Extensions for C++
public: __property int get_Slip_control_type();
public: __property void set_Slip_control_type(
   int value
);
C++/CLI
public:
property int Slip_control_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Signals,
2 = Giveway/Yield,
3 = Stop,
4 = Continuous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Type Property

Glossary Item Box

Lane Type

Syntax

Visual Basic (Declaration)
Public Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Integer

instance.Type = value

value = instance.Type
C#
public int Type {get; set;}
Managed Extensions for C++
public: __property int get_Type();
public: __property void set_Type(
   int value
);
C++/CLI
public:
property int Type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Normal,
2 = Slip/Bypass (High Angle),
3 = Slip/Bypass (Low Angle).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Utilisation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Utilisation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Utilisation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Utilisation = value

value = instance.Utilisation
C#
public float Utilisation {get; set;}
Managed Extensions for C++
public: __property float get_Utilisation();
public: __property void set_Utilisation(
   float value
);
C++/CLI
public:
property float Utilisation {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Utilisation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Utilisation_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Utilisation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Boolean

instance.Utilisation_user = value

value = instance.Utilisation_user
C#
public bool Utilisation_user {get; set;}
Managed Extensions for C++
public: __property bool get_Utilisation_user();
public: __property void set_Utilisation_user(
   bool value
);
C++/CLI
public:
property bool Utilisation_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproach Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproach
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproach Class
SIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovement Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovement Class

Glossary Item Box

Object Model

SIAPILaneApproachMovement ClassISIAPILaneApproach InterfaceISIAPILaneApproachMovementMCs InterfaceISIAPILaneApproachMovementMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproachMovement
   Implements ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovement
C#
public sealed class SIAPILaneApproachMovement : ISIAPILaneApproachMovement
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproachMovement : public ISIAPILaneApproachMovement
C++/CLI
public ref class SIAPILaneApproachMovement sealed : public ISIAPILaneApproachMovement

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproachMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovement Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovement Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproachMovement.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproachMovement Constructor |
Top

Public Properties

 | Name | Description
Public Property | Destination | Movement Destination Leg
Public Property | Free_queue |
Public Property | LaneApproach |
Public Property | LaneApproachMovementMCs |
Top

See Also

Reference

SIAPILaneApproachMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovement Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovement Class : SIAPILaneApproachMovement Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproachMovement()
C#
public SIAPILaneApproachMovement()
Managed Extensions for C++
public: SIAPILaneApproachMovement();
C++/CLI
public:
SIAPILaneApproachMovement();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Class
SIAPILaneApproachMovement Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovement Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovement Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovement members.

Public Properties

 | Name | Description
Public Property | Destination | Movement Destination Leg
Public Property | Free_queue |
Public Property | LaneApproach |
Public Property | LaneApproachMovementMCs |
Top

See Also

Reference

SIAPILaneApproachMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovement Class : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovement
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Class
SIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Free_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovement Class : Free_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Free_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovement
Dim value As Single

instance.Free_queue = value

value = instance.Free_queue
C#
public float Free_queue {get; set;}
Managed Extensions for C++
public: __property float get_Free_queue();
public: __property void set_Free_queue(
   float value
);
C++/CLI
public:
property float Free_queue {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Class
SIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproach Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovement Class : LaneApproach Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproach As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovement
Dim value As ISIAPILaneApproach

value = instance.LaneApproach
C#
public ISIAPILaneApproach LaneApproach {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproach* get_LaneApproach();
C++/CLI
public:
property ISIAPILaneApproach^ LaneApproach {
   ISIAPILaneApproach^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Class
SIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovementMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovement Class : LaneApproachMovementMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproachMovementMCs As ISIAPILaneApproachMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovement
Dim value As ISIAPILaneApproachMovementMCs

value = instance.LaneApproachMovementMCs
C#
public ISIAPILaneApproachMovementMCs LaneApproachMovementMCs {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachMovementMCs* get_LaneApproachMovementMCs();
C++/CLI
public:
property ISIAPILaneApproachMovementMCs^ LaneApproachMovementMCs {
   ISIAPILaneApproachMovementMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovement Class
SIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMC Class

Glossary Item Box

Object Model

SIAPILaneApproachMovementMC ClassISIAPILaneApproachMovement Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproachMovementMC
   Implements ISIAPILaneApproachMovementMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMC
C#
public sealed class SIAPILaneApproachMovementMC : ISIAPILaneApproachMovementMC
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproachMovementMC : public ISIAPILaneApproachMovementMC
C++/CLI
public ref class SIAPILaneApproachMovementMC sealed : public ISIAPILaneApproachMovementMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproachMovementMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMC Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproachMovementMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproachMovementMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Exists | Flag indicating whether this Movement Class OD Movement is running on this Approach Lane. The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.
Public Property | LaneApproachMovement |
Public Property | MC_class | Movement Class Number
Top

See Also

Reference

SIAPILaneApproachMovementMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMC Class : SIAPILaneApproachMovementMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproachMovementMC()
C#
public SIAPILaneApproachMovementMC()
Managed Extensions for C++
public: SIAPILaneApproachMovementMC();
C++/CLI
public:
SIAPILaneApproachMovementMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMC Class
SIAPILaneApproachMovementMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMC Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovementMC members.

Public Properties

 | Name | Description
Public Property | Exists | Flag indicating whether this Movement Class OD Movement is running on this Approach Lane. The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.
Public Property | LaneApproachMovement |
Public Property | MC_class | Movement Class Number
Top

See Also

Reference

SIAPILaneApproachMovementMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMC Class : Exists Property

Glossary Item Box

Flag indicating whether this Movement Class OD Movement is running on this Approach Lane.

The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.

Syntax

Visual Basic (Declaration)
Public Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMC
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
public bool Exists {get; set;}
Managed Extensions for C++
public: __property bool get_Exists();
public: __property void set_Exists(
   bool value
);
C++/CLI
public:
property bool Exists {
   bool get();
   void set (    bool value);
}

Remarks

SIAPISite.ResetLaneMovements() needs to be called manually or the related SIAPILaneMovementMC.Flow_proportion need to be revised manually after Lane Discipline changes.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMC Class
SIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMC Class : LaneApproachMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproachMovement As ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMC
Dim value As ISIAPILaneApproachMovement

value = instance.LaneApproachMovement
C#
public ISIAPILaneApproachMovement LaneApproachMovement {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachMovement* get_LaneApproachMovement();
C++/CLI
public:
property ISIAPILaneApproachMovement^ LaneApproachMovement {
   ISIAPILaneApproachMovement^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMC Class
SIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMC Class : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMC Class
SIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMCs Class

Glossary Item Box

Object Model

SIAPILaneApproachMovementMCs ClassISIAPILaneApproachMovementMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproachMovementMCs
   Implements ISIAPILaneApproachMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMCs
C#
public sealed class SIAPILaneApproachMovementMCs : ISIAPILaneApproachMovementMCs
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproachMovementMCs : public ISIAPILaneApproachMovementMCs
C++/CLI
public ref class SIAPILaneApproachMovementMCs sealed : public ISIAPILaneApproachMovementMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproachMovementMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproachMovementMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproachMovementMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMCs Class : SIAPILaneApproachMovementMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproachMovementMCs()
C#
public SIAPILaneApproachMovementMCs()
Managed Extensions for C++
public: SIAPILaneApproachMovementMCs();
C++/CLI
public:
SIAPILaneApproachMovementMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIAPILaneApproachMovementMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovementMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIAPILaneApproachMovementMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovementMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovementMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovementMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIAPILaneApproachMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovementMCs Class : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneApproachMovementMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovementMCs
Dim mcClass As Integer
Dim value As ISIAPILaneApproachMovementMC

value = instance.Item(mcClass)
C#
public ISIAPILaneApproachMovementMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachMovementMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPILaneApproachMovementMC^ default [int] {
   ISIAPILaneApproachMovementMC^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovementMCs Class
SIAPILaneApproachMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovements Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovements Class

Glossary Item Box

Object Model

SIAPILaneApproachMovements ClassISIAPILaneApproachMovement Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproachMovements
   Implements ISIAPILaneApproachMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovements
C#
public sealed class SIAPILaneApproachMovements : ISIAPILaneApproachMovements
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproachMovements : public ISIAPILaneApproachMovements
C++/CLI
public ref class SIAPILaneApproachMovements sealed : public ISIAPILaneApproachMovements

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproachMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovements Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovements Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproachMovements.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproachMovements Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneApproachMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovements Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovements Class : SIAPILaneApproachMovements Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproachMovements()
C#
public SIAPILaneApproachMovements()
Managed Extensions for C++
public: SIAPILaneApproachMovements();
C++/CLI
public:
SIAPILaneApproachMovements();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovements Class
SIAPILaneApproachMovements Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovements Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovements members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneApproachMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovements Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovements
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovements Class
SIAPILaneApproachMovements Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachMovements Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachMovements members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneApproachMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovements Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovements
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovements Class
SIAPILaneApproachMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachMovements Class : Item Property

destination

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal destination As Integer _
) As ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachMovements
Dim destination As Integer
Dim value As ISIAPILaneApproachMovement

value = instance.Item(destination)
C#
public ISIAPILaneApproachMovement this[
   int destination
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachMovement* get_Item   int destination
;
C++/CLI
public:
property ISIAPILaneApproachMovement^ default [int] {
   ISIAPILaneApproachMovement^ get(int destination);
}

Parameters

destination

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachMovements Class
SIAPILaneApproachMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachs Class

Glossary Item Box

Object Model

SIAPILaneApproachs ClassISIAPILaneApproach Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneApproachs
   Implements ISIAPILaneApproachs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
C#
public sealed class SIAPILaneApproachs : ISIAPILaneApproachs
Managed Extensions for C++
public __gc __sealed class SIAPILaneApproachs : public ISIAPILaneApproachs
C++/CLI
public ref class SIAPILaneApproachs sealed : public ISIAPILaneApproachs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneApproachs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachs Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneApproachs.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneApproachs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | AddLane | Add an Approach Lane If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Approach Lane, a new default Approach Lane is added.
Public Method | GetEnumerator |
Public Method | LaneApproachExists |
Public Method | RemoveLane | Remove an Approach Lane If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

SIAPILaneApproachs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : SIAPILaneApproachs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneApproachs()
C#
public SIAPILaneApproachs()
Managed Extensions for C++
public: SIAPILaneApproachs();
C++/CLI
public:
SIAPILaneApproachs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachs members.

Public Methods

 | Name | Description
Public Method | AddLane | Add an Approach Lane If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Approach Lane, a new default Approach Lane is added.
Public Method | GetEnumerator |
Public Method | LaneApproachExists |
Public Method | RemoveLane | Remove an Approach Lane If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

SIAPILaneApproachs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : AddLane Method

Glossary Item Box

Add an Approach Lane

If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left.
If the Leg does not have any Approach Lane, a new default Approach Lane is added.

Syntax

Visual Basic (Declaration)
Public Function AddLane() As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
Dim value As ISIAPILaneApproach

value = instance.AddLane()
C#
public ISIAPILaneApproach AddLane()
Managed Extensions for C++
public: ISIAPILaneApproach* AddLane();
C++/CLI
public:
ISIAPILaneApproach^ AddLane();

Return Value

The new added Approach Lane

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : LaneApproachExists Method

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneApproachExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneApproachExists(laneno)
C#
public bool LaneApproachExists(
   int laneno
)
Managed Extensions for C++
public: bool LaneApproachExists(
   int laneno
)
C++/CLI
public:
bool LaneApproachExists(
   int laneno
)

Parameters

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : RemoveLane Method

Glossary Item Box

Remove an Approach Lane

If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.

Syntax

Visual Basic (Declaration)
Public Sub RemoveLane()
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs

instance.RemoveLane()
C#
public void RemoveLane()
Managed Extensions for C++
public: void RemoveLane();
C++/CLI
public:
void RemoveLane();

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneApproachs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneApproachs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneApproachs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneApproachs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneApproachs Class : Item Property

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneApproachs
Dim laneno As Integer
Dim value As ISIAPILaneApproach

value = instance.Item(laneno)
C#
public ISIAPILaneApproach this[
   int laneno
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproach* get_Item   int laneno
;
C++/CLI
public:
property ISIAPILaneApproach^ default [int] {
   ISIAPILaneApproach^ get(int laneno);
}

Parameters

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneApproachs Class
SIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExit Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExit Class

Glossary Item Box

Object Model

SIAPILaneExit ClassISIAPILaneMovements InterfaceISIAPILaneMovement InterfaceISIAPILeg InterfaceISIAPILaneSegment InterfaceISIAPILaneSegment Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneExit
   Implements ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
C#
public sealed class SIAPILaneExit : ISIAPILaneExit
Managed Extensions for C++
public __gc __sealed class SIAPILaneExit : public ISIAPILaneExit
C++/CLI
public ref class SIAPILaneExit sealed : public ISIAPILaneExit

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneExit

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExit Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExit Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneExit.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneExit Constructor |
Top

Public Properties

 | Name | Description
Public Property | Configuration | Lane Configuration
Public Property | Grade |
Public Property | LaneMovements |
Public Property | Laneno | Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.
Public Property | Leg |
Public Property | Length | Lane Length
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Segment1 | Lane Segement 1
Public Property | Segment2 | Lane Segement 2
Public Property | Width |
Top

See Also

Reference

SIAPILaneExit Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExit Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : SIAPILaneExit Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneExit()
C#
public SIAPILaneExit()
Managed Extensions for C++
public: SIAPILaneExit();
C++/CLI
public:
SIAPILaneExit();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExit Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExit Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneExit members.

Public Properties

 | Name | Description
Public Property | Configuration | Lane Configuration
Public Property | Grade |
Public Property | LaneMovements |
Public Property | Laneno | Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.
Public Property | Leg |
Public Property | Length | Lane Length
Public Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Public Property | Segment1 | Lane Segement 1
Public Property | Segment2 | Lane Segement 2
Public Property | Width |
Top

See Also

Reference

SIAPILaneExit Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Configuration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Configuration Property

Glossary Item Box

Lane Configuration

Syntax

Visual Basic (Declaration)
Public Property Configuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Integer

instance.Configuration = value

value = instance.Configuration
C#
public int Configuration {get; set;}
Managed Extensions for C++
public: __property int get_Configuration();
public: __property void set_Configuration(
   int value
);
C++/CLI
public:
property int Configuration {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Full-Length Lane,
2 = Short Lane,
3 = Short Lane with Parking,
4 = Two-Segment Lane.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Grade As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Single

instance.Grade = value

value = instance.Grade
C#
public float Grade {get; set;}
Managed Extensions for C++
public: __property float get_Grade();
public: __property void set_Grade(
   float value
);
C++/CLI
public:
property float Grade {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : LaneMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneMovements As ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As ISIAPILaneMovements

value = instance.LaneMovements
C#
public ISIAPILaneMovements LaneMovements {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovements* get_LaneMovements();
C++/CLI
public:
property ISIAPILaneMovements^ LaneMovements {
   ISIAPILaneMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Laneno Property

Glossary Item Box

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Integer

value = instance.Laneno
C#
public int Laneno {get;}
Managed Extensions for C++
public: __property int get_Laneno();
C++/CLI
public:
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As ISIAPILeg

value = instance.Leg
C#
public ISIAPILeg Leg {get;}
Managed Extensions for C++
public: __property ISIAPILeg* get_Leg();
C++/CLI
public:
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Length Property

Glossary Item Box

Lane Length

Syntax

Visual Basic (Declaration)
Public Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Single

instance.Length = value

value = instance.Length
C#
public float Length {get; set;}
Managed Extensions for C++
public: __property float get_Length();
public: __property void set_Length(
   float value
);
C++/CLI
public:
property float Length {
   float get();
   void set (    float value);
}

Remarks

For Full-Length Lane or Two-Segment Lane, this is the Length of the whole Lane; for Short Lane or Short Lane with Parking, this is synchronized with the Segment 1 Length

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Segment1 Property

Glossary Item Box

Lane Segement 1

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segment1 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As ISIAPILaneSegment

value = instance.Segment1
C#
public ISIAPILaneSegment Segment1 {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegment* get_Segment1();
C++/CLI
public:
property ISIAPILaneSegment^ Segment1 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Segment2 Property

Glossary Item Box

Lane Segement 2

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segment2 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As ISIAPILaneSegment

value = instance.Segment2
C#
public ISIAPILaneSegment Segment2 {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegment* get_Segment2();
C++/CLI
public:
property ISIAPILaneSegment^ Segment2 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExit Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExit
Dim value As Single

instance.Width = value

value = instance.Width
C#
public float Width {get; set;}
Managed Extensions for C++
public: __property float get_Width();
public: __property void set_Width(
   float value
);
C++/CLI
public:
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExit Class
SIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExits Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExits Class

Glossary Item Box

Object Model

SIAPILaneExits ClassISIAPILaneExit Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneExits
   Implements ISIAPILaneExits
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
C#
public sealed class SIAPILaneExits : ISIAPILaneExits
Managed Extensions for C++
public __gc __sealed class SIAPILaneExits : public ISIAPILaneExits
C++/CLI
public ref class SIAPILaneExits sealed : public ISIAPILaneExits

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneExits

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExits Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExits Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneExits.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneExits Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | AddLane | Add an Exit Lane If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Exit Lane, a new default Exit Lane is added.
Public Method | GetEnumerator |
Public Method | LaneExitExists |
Public Method | RemoveLane | Remove an Exit Lane If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

SIAPILaneExits Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExits Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : SIAPILaneExits Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneExits()
C#
public SIAPILaneExits()
Managed Extensions for C++
public: SIAPILaneExits();
C++/CLI
public:
SIAPILaneExits();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExits Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExits Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneExits members.

Public Methods

 | Name | Description
Public Method | AddLane | Add an Exit Lane If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Exit Lane, a new default Exit Lane is added.
Public Method | GetEnumerator |
Public Method | LaneExitExists |
Public Method | RemoveLane | Remove an Exit Lane If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

SIAPILaneExits Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : AddLane Method

Glossary Item Box

Add an Exit Lane

If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left.
If the Leg does not have any Exit Lane, a new default Exit Lane is added.

Syntax

Visual Basic (Declaration)
Public Function AddLane() As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
Dim value As ISIAPILaneExit

value = instance.AddLane()
C#
public ISIAPILaneExit AddLane()
Managed Extensions for C++
public: ISIAPILaneExit* AddLane();
C++/CLI
public:
ISIAPILaneExit^ AddLane();

Return Value

The new added Exit Lane

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExitExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : LaneExitExists Method

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneExitExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExitExists(laneno)
C#
public bool LaneExitExists(
   int laneno
)
Managed Extensions for C++
public: bool LaneExitExists(
   int laneno
)
C++/CLI
public:
bool LaneExitExists(
   int laneno
)

Parameters

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : RemoveLane Method

Glossary Item Box

Remove an Exit Lane

If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.

Syntax

Visual Basic (Declaration)
Public Sub RemoveLane()
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits

instance.RemoveLane()
C#
public void RemoveLane()
Managed Extensions for C++
public: void RemoveLane();
C++/CLI
public:
void RemoveLane();

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneExits Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneExits Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneExits members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneExits Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneExits Class : Item Property

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneExits
Dim laneno As Integer
Dim value As ISIAPILaneExit

value = instance.Item(laneno)
C#
public ISIAPILaneExit this[
   int laneno
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneExit* get_Item   int laneno
;
C++/CLI
public:
property ISIAPILaneExit^ default [int] {
   ISIAPILaneExit^ get(int laneno);
}

Parameters

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneExits Class
SIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovement Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovement Class

Glossary Item Box

Object Model

SIAPILaneMovement ClassISIAPILaneMovementMCs InterfaceISIAPILaneMovementMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneMovement
   Implements ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
C#
public sealed class SIAPILaneMovement : ISIAPILaneMovement
Managed Extensions for C++
public __gc __sealed class SIAPILaneMovement : public ISIAPILaneMovement
C++/CLI
public ref class SIAPILaneMovement sealed : public ISIAPILaneMovement

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovement Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovement Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneMovement.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneMovement Constructor |
Top

Public Properties

 | Name | Description
Public Property | Destination |
Public Property | DestinationLaneno |
Public Property | Lane_blockage_calib_factor |
Public Property | LaneMovementMCs |
Public Property | Origin |
Public Property | OriginLaneno |
Top

See Also

Reference

SIAPILaneMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovement Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : SIAPILaneMovement Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneMovement()
C#
public SIAPILaneMovement()
Managed Extensions for C++
public: SIAPILaneMovement();
C++/CLI
public:
SIAPILaneMovement();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovement Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovement Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovement members.

Public Properties

 | Name | Description
Public Property | Destination |
Public Property | DestinationLaneno |
Public Property | Lane_blockage_calib_factor |
Public Property | LaneMovementMCs |
Public Property | Origin |
Public Property | OriginLaneno |
Top

See Also

Reference

SIAPILaneMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DestinationLaneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : DestinationLaneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DestinationLaneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As Integer

value = instance.DestinationLaneno
C#
public int DestinationLaneno {get;}
Managed Extensions for C++
public: __property int get_DestinationLaneno();
C++/CLI
public:
property int DestinationLaneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_calib_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : Lane_blockage_calib_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Lane_blockage_calib_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As Single

instance.Lane_blockage_calib_factor = value

value = instance.Lane_blockage_calib_factor
C#
public float Lane_blockage_calib_factor {get; set;}
Managed Extensions for C++
public: __property float get_Lane_blockage_calib_factor();
public: __property void set_Lane_blockage_calib_factor(
   float value
);
C++/CLI
public:
property float Lane_blockage_calib_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovementMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : LaneMovementMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneMovementMCs As ISIAPILaneMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As ISIAPILaneMovementMCs

value = instance.LaneMovementMCs
C#
public ISIAPILaneMovementMCs LaneMovementMCs {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovementMCs* get_LaneMovementMCs();
C++/CLI
public:
property ISIAPILaneMovementMCs^ LaneMovementMCs {
   ISIAPILaneMovementMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OriginLaneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovement Class : OriginLaneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OriginLaneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovement
Dim value As Integer

value = instance.OriginLaneno
C#
public int OriginLaneno {get;}
Managed Extensions for C++
public: __property int get_OriginLaneno();
C++/CLI
public:
property int OriginLaneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovement Class
SIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMC Class

Glossary Item Box

Object Model

SIAPILaneMovementMC ClassISIAPILaneMovement Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneMovementMC
   Implements ISIAPILaneMovementMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMC
C#
public sealed class SIAPILaneMovementMC : ISIAPILaneMovementMC
Managed Extensions for C++
public __gc __sealed class SIAPILaneMovementMC : public ISIAPILaneMovementMC
C++/CLI
public ref class SIAPILaneMovementMC sealed : public ISIAPILaneMovementMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneMovementMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMC Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneMovementMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneMovementMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Flow_proportion |
Public Property | LaneMovement |
Public Property | MC_class | Movement Class Number
Top

See Also

Reference

SIAPILaneMovementMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMC Class : SIAPILaneMovementMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneMovementMC()
C#
public SIAPILaneMovementMC()
Managed Extensions for C++
public: SIAPILaneMovementMC();
C++/CLI
public:
SIAPILaneMovementMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMC Class
SIAPILaneMovementMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMC Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovementMC members.

Public Properties

 | Name | Description
Public Property | Flow_proportion |
Public Property | LaneMovement |
Public Property | MC_class | Movement Class Number
Top

See Also

Reference

SIAPILaneMovementMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_proportion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMC Class : Flow_proportion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_proportion As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMC
Dim value As Single

instance.Flow_proportion = value

value = instance.Flow_proportion
C#
public float Flow_proportion {get; set;}
Managed Extensions for C++
public: __property float get_Flow_proportion();
public: __property void set_Flow_proportion(
   float value
);
C++/CLI
public:
property float Flow_proportion {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMC Class
SIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMC Class : LaneMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneMovement As ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMC
Dim value As ISIAPILaneMovement

value = instance.LaneMovement
C#
public ISIAPILaneMovement LaneMovement {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovement* get_LaneMovement();
C++/CLI
public:
property ISIAPILaneMovement^ LaneMovement {
   ISIAPILaneMovement^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMC Class
SIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMC Class : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMC Class
SIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMCs Class

Glossary Item Box

Object Model

SIAPILaneMovementMCs ClassISIAPILaneMovementMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneMovementMCs
   Implements ISIAPILaneMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMCs
C#
public sealed class SIAPILaneMovementMCs : ISIAPILaneMovementMCs
Managed Extensions for C++
public __gc __sealed class SIAPILaneMovementMCs : public ISIAPILaneMovementMCs
C++/CLI
public ref class SIAPILaneMovementMCs sealed : public ISIAPILaneMovementMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneMovementMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneMovementMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneMovementMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMCs Class : SIAPILaneMovementMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneMovementMCs()
C#
public SIAPILaneMovementMCs()
Managed Extensions for C++
public: SIAPILaneMovementMCs();
C++/CLI
public:
SIAPILaneMovementMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMCs Class
SIAPILaneMovementMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovementMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMCs Class
SIAPILaneMovementMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovementMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovementMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovementMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneMovementMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMCs Class
SIAPILaneMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovementMCs Class : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneMovementMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovementMCs
Dim mcClass As Integer
Dim value As ISIAPILaneMovementMC

value = instance.Item(mcClass)
C#
public ISIAPILaneMovementMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovementMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPILaneMovementMC^ default [int] {
   ISIAPILaneMovementMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovementMCs Class
SIAPILaneMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovements Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovements Class

Glossary Item Box

Object Model

SIAPILaneMovements ClassISIAPILaneMovement Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneMovements
   Implements ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovements
C#
public sealed class SIAPILaneMovements : ISIAPILaneMovements
Managed Extensions for C++
public __gc __sealed class SIAPILaneMovements : public ISIAPILaneMovements
C++/CLI
public ref class SIAPILaneMovements sealed : public ISIAPILaneMovements

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovements Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovements Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneMovements.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneMovements Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneMovementExists |
Top

See Also

Reference

SIAPILaneMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovements Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovements Class : SIAPILaneMovements Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneMovements()
C#
public SIAPILaneMovements()
Managed Extensions for C++
public: SIAPILaneMovements();
C++/CLI
public:
SIAPILaneMovements();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Class
SIAPILaneMovements Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovements Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovements members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneMovementExists |
Top

See Also

Reference

SIAPILaneMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovements Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovements
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Class
SIAPILaneMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovements Class : LaneMovementExists Method

leg
laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneMovementExists( _
   ByVal leg As Integer, _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovements
Dim leg As Integer
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneMovementExists(leg, laneno)
C#
public bool LaneMovementExists(
   int leg,
   int laneno
)
Managed Extensions for C++
public: bool LaneMovementExists(
   int leg,
   int laneno
)
C++/CLI
public:
bool LaneMovementExists(
   int leg,
   int laneno
)

Parameters

leg
laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Class
SIAPILaneMovements Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneMovements Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneMovements members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovements Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovements
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Class
SIAPILaneMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneMovements Class : Item Property

leg
laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal leg As Integer, _
   ByVal laneno As Integer _
) As ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneMovements
Dim leg As Integer
Dim laneno As Integer
Dim value As ISIAPILaneMovement

value = instance.Item(leg, laneno)
C#
public ISIAPILaneMovement this[
   int leg,
   int laneno
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneMovement* get_Item   int leg,
   int laneno
;
C++/CLI
public:
property ISIAPILaneMovement^ default [int,int] {
   ISIAPILaneMovement^ get(int leg, int laneno);
}

Parameters

leg
laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneMovements Class
SIAPILaneMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegment Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegment Class

Glossary Item Box

Object Model

SIAPILaneSegment ClassISIAPILaneApproach InterfaceISIAPILaneExit InterfaceISIAPILaneSegmentMCs InterfaceISIAPILaneSegmentMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneSegment
   Implements ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
C#
public sealed class SIAPILaneSegment : ISIAPILaneSegment
Managed Extensions for C++
public __gc __sealed class SIAPILaneSegment : public ISIAPILaneSegment
C++/CLI
public ref class SIAPILaneSegment sealed : public ISIAPILaneSegment

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneSegment

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegment Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegment Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneSegment.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneSegment Constructor |
Top

Public Properties

 | Name | Description
Public Property | Colour |
Public Property | Display_id |
Public Property | LaneApproach |
Public Property | LaneExit |
Public Property | LaneSegmentMCs |
Public Property | Length |
Public Property | Overflow_merge_lane_num_1 |
Public Property | Segment_no |
Public Property | Type | Lane Segment Type
Top

See Also

Reference

SIAPILaneSegment Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegment Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : SIAPILaneSegment Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneSegment()
C#
public SIAPILaneSegment()
Managed Extensions for C++
public: SIAPILaneSegment();
C++/CLI
public:
SIAPILaneSegment();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegment Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegment Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneSegment members.

Public Properties

 | Name | Description
Public Property | Colour |
Public Property | Display_id |
Public Property | LaneApproach |
Public Property | LaneExit |
Public Property | LaneSegmentMCs |
Public Property | Length |
Public Property | Overflow_merge_lane_num_1 |
Public Property | Segment_no |
Public Property | Type | Lane Segment Type
Top

See Also

Reference

SIAPILaneSegment Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Colour Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Colour Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Colour As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As Integer

instance.Colour = value

value = instance.Colour
C#
public int Colour {get; set;}
Managed Extensions for C++
public: __property int get_Colour();
public: __property void set_Colour(
   int value
);
C++/CLI
public:
property int Colour {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Display_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
public string Display_id {get; set;}
Managed Extensions for C++
public: __property string* get_Display_id();
public: __property void set_Display_id(
   string* value
);
C++/CLI
public:
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproach Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : LaneApproach Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproach As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As ISIAPILaneApproach

value = instance.LaneApproach
C#
public ISIAPILaneApproach LaneApproach {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproach* get_LaneApproach();
C++/CLI
public:
property ISIAPILaneApproach^ LaneApproach {
   ISIAPILaneApproach^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : LaneExit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneExit As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As ISIAPILaneExit

value = instance.LaneExit
C#
public ISIAPILaneExit LaneExit {get;}
Managed Extensions for C++
public: __property ISIAPILaneExit* get_LaneExit();
C++/CLI
public:
property ISIAPILaneExit^ LaneExit {
   ISIAPILaneExit^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneSegmentMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : LaneSegmentMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneSegmentMCs As ISIAPILaneSegmentMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As ISIAPILaneSegmentMCs

value = instance.LaneSegmentMCs
C#
public ISIAPILaneSegmentMCs LaneSegmentMCs {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegmentMCs* get_LaneSegmentMCs();
C++/CLI
public:
property ISIAPILaneSegmentMCs^ LaneSegmentMCs {
   ISIAPILaneSegmentMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As Single

instance.Length = value

value = instance.Length
C#
public float Length {get; set;}
Managed Extensions for C++
public: __property float get_Length();
public: __property void set_Length(
   float value
);
C++/CLI
public:
property float Length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Overflow_merge_lane_num_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Overflow_merge_lane_num_1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Overflow_merge_lane_num_1 As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As Integer

instance.Overflow_merge_lane_num_1 = value

value = instance.Overflow_merge_lane_num_1
C#
public int Overflow_merge_lane_num_1 {get; set;}
Managed Extensions for C++
public: __property int get_Overflow_merge_lane_num_1();
public: __property void set_Overflow_merge_lane_num_1(
   int value
);
C++/CLI
public:
property int Overflow_merge_lane_num_1 {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Segment_no Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Segment_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As Integer

value = instance.Segment_no
C#
public int Segment_no {get;}
Managed Extensions for C++
public: __property int get_Segment_no();
C++/CLI
public:
property int Segment_no {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegment Class : Type Property

Glossary Item Box

Lane Segment Type

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegment
Dim value As Integer

value = instance.Type
C#
public int Type {get;}
Managed Extensions for C++
public: __property int get_Type();
C++/CLI
public:
property int Type {
   int get();
}

Property Value

Type: System.Int32;

0 = None,
1 = Short Lane,
2 = Parking.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegment Class
SIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMC Class

Glossary Item Box

Object Model

SIAPILaneSegmentMC ClassISIAPILaneSegment Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneSegmentMC
   Implements ISIAPILaneSegmentMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
C#
public sealed class SIAPILaneSegmentMC : ISIAPILaneSegmentMC
Managed Extensions for C++
public __gc __sealed class SIAPILaneSegmentMC : public ISIAPILaneSegmentMC
C++/CLI
public ref class SIAPILaneSegmentMC sealed : public ISIAPILaneSegmentMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneSegmentMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMC Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneSegmentMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneSegmentMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Exists | Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.
Public Property | LaneSegment |
Public Property | MC_class | Movement Class Number
Public Property | Percent_change_to_left | Percent Lane Change to the Left, only applies to the Exit Lane Segment 1.
Public Property | Percent_change_to_right | Percent Lane Change to the Right, only applies to the Exit Lane Segment 1.
Top

See Also

Reference

SIAPILaneSegmentMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : SIAPILaneSegmentMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneSegmentMC()
C#
public SIAPILaneSegmentMC()
Managed Extensions for C++
public: SIAPILaneSegmentMC();
C++/CLI
public:
SIAPILaneSegmentMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMC Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneSegmentMC members.

Public Properties

 | Name | Description
Public Property | Exists | Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.
Public Property | LaneSegment |
Public Property | MC_class | Movement Class Number
Public Property | Percent_change_to_left | Percent Lane Change to the Left, only applies to the Exit Lane Segment 1.
Public Property | Percent_change_to_right | Percent Lane Change to the Right, only applies to the Exit Lane Segment 1.
Top

See Also

Reference

SIAPILaneSegmentMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : Exists Property

Glossary Item Box

Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.

Syntax

Visual Basic (Declaration)
Public Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
public bool Exists {get; set;}
Managed Extensions for C++
public: __property bool get_Exists();
public: __property void set_Exists(
   bool value
);
C++/CLI
public:
property bool Exists {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneSegment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : LaneSegment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneSegment As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
Dim value As ISIAPILaneSegment

value = instance.LaneSegment
C#
public ISIAPILaneSegment LaneSegment {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegment* get_LaneSegment();
C++/CLI
public:
property ISIAPILaneSegment^ LaneSegment {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : Percent_change_to_left Property

Glossary Item Box

Percent Lane Change to the Left, only applies to the Exit Lane Segment 1.

Syntax

Visual Basic (Declaration)
Public Property Percent_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
Dim value As Single

instance.Percent_change_to_left = value

value = instance.Percent_change_to_left
C#
public float Percent_change_to_left {get; set;}
Managed Extensions for C++
public: __property float get_Percent_change_to_left();
public: __property void set_Percent_change_to_left(
   float value
);
C++/CLI
public:
property float Percent_change_to_left {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMC Class : Percent_change_to_right Property

Glossary Item Box

Percent Lane Change to the Right, only applies to the Exit Lane Segment 1.

Syntax

Visual Basic (Declaration)
Public Property Percent_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMC
Dim value As Single

instance.Percent_change_to_right = value

value = instance.Percent_change_to_right
C#
public float Percent_change_to_right {get; set;}
Managed Extensions for C++
public: __property float get_Percent_change_to_right();
public: __property void set_Percent_change_to_right(
   float value
);
C++/CLI
public:
property float Percent_change_to_right {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMC Class
SIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMCs Class

Glossary Item Box

Object Model

SIAPILaneSegmentMCs ClassISIAPILaneSegmentMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILaneSegmentMCs
   Implements ISIAPILaneSegmentMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMCs
C#
public sealed class SIAPILaneSegmentMCs : ISIAPILaneSegmentMCs
Managed Extensions for C++
public __gc __sealed class SIAPILaneSegmentMCs : public ISIAPILaneSegmentMCs
C++/CLI
public ref class SIAPILaneSegmentMCs sealed : public ISIAPILaneSegmentMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILaneSegmentMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPILaneSegmentMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPILaneSegmentMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneSegmentMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMCs Class : SIAPILaneSegmentMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILaneSegmentMCs()
C#
public SIAPILaneSegmentMCs()
Managed Extensions for C++
public: SIAPILaneSegmentMCs();
C++/CLI
public:
SIAPILaneSegmentMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMCs Class
SIAPILaneSegmentMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneSegmentMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPILaneSegmentMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMCs Class
SIAPILaneSegmentMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILaneSegmentMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILaneSegmentMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPILaneSegmentMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPILaneSegmentMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMCs Class
SIAPILaneSegmentMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILaneSegmentMCs Class : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneSegmentMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPILaneSegmentMCs
Dim mcClass As Integer
Dim value As ISIAPILaneSegmentMC

value = instance.Item(mcClass)
C#
public ISIAPILaneSegmentMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPILaneSegmentMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPILaneSegmentMC^ default [int] {
   ISIAPILaneSegmentMC^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILaneSegmentMCs Class
SIAPILaneSegmentMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg Class

Glossary Item Box

Object Model

SIAPILeg ClassISIAPIIslands InterfaceISIAPIIsland InterfaceISIAPILaneApproachs InterfaceISIAPILaneApproach InterfaceISIAPILaneExits InterfaceISIAPILaneExit InterfaceISIAPILeg_roundabout InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILeg
   Implements ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
C#
public sealed class SIAPILeg : ISIAPILeg
Managed Extensions for C++
public __gc __sealed class SIAPILeg : public ISIAPILeg
C++/CLI
public ref class SIAPILeg sealed : public ISIAPILeg

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILeg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg Class

Glossary Item Box

The following tables list the members exposed by SIAPILeg.

Public Constructors

 | Name | Description
Public Constructor | SIAPILeg Constructor |
Top

Public Properties

 | Name | Description
Public Property | Approach_control | Approach Control Type
Public Property | Approach_distance |
Public Property | Area_type_factor | Area Type Factor, for Legs in Signalised Site only
Public Property | Exit_distance |
Public Property | Exit_distance_user |
Public Property | Extra_bunching |
Public Property | Extra_bunching_user |
Public Property | Is_departure_headway_awsc_applied |
Public Property | Islands |
Public Property | LaneApproachs |
Public Property | LaneExits |
Public Property | LastErrorMessage |
Public Property | Leg_roundabout |
Public Property | LegGeometry | Leg Geometry
Public Property | Name |
Public Property | Orientation | Leg Orientation
Public Property | Site |
Top

Public Methods

 | Name | Description
Public Method | InsertApproachLane | Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.
Public Method | InsertExitLane | Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.
Public Method | InsertIsland | Insert an new Island to the Leg at the specified position. The Island is created automatically.
Public Method | InsertIsland_RoundaboutSplitter | Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.
Public Method | RemoveItem | Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.
Top

See Also

Reference

SIAPILeg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : SIAPILeg Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILeg()
C#
public SIAPILeg()
Managed Extensions for C++
public: SIAPILeg();
C++/CLI
public:
SIAPILeg();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg Class

Glossary Item Box

For a list of all members of this type, see SIAPILeg members.

Public Methods

 | Name | Description
Public Method | InsertApproachLane | Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.
Public Method | InsertExitLane | Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.
Public Method | InsertIsland | Insert an new Island to the Leg at the specified position. The Island is created automatically.
Public Method | InsertIsland_RoundaboutSplitter | Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.
Public Method | RemoveItem | Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.
Top

See Also

Reference

SIAPILeg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertApproachLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : InsertApproachLane Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.

Syntax

Visual Basic (Declaration)
Public Function InsertApproachLane( _
   ByVal positionOnLeg As Integer _
) As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPILaneApproach

value = instance.InsertApproachLane(positionOnLeg)
C#
public ISIAPILaneApproach InsertApproachLane(
   int positionOnLeg
)
Managed Extensions for C++
public: ISIAPILaneApproach* InsertApproachLane(
   int positionOnLeg
)
C++/CLI
public:
ISIAPILaneApproach^ InsertApproachLane(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Approach Lane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertExitLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : InsertExitLane Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.

Syntax

Visual Basic (Declaration)
Public Function InsertExitLane( _
   ByVal positionOnLeg As Integer _
) As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPILaneExit

value = instance.InsertExitLane(positionOnLeg)
C#
public ISIAPILaneExit InsertExitLane(
   int positionOnLeg
)
Managed Extensions for C++
public: ISIAPILaneExit* InsertExitLane(
   int positionOnLeg
)
C++/CLI
public:
ISIAPILaneExit^ InsertExitLane(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Exit Lane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertIsland Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : InsertIsland Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Island to the Leg at the specified position. The Island is created automatically.

Syntax

Visual Basic (Declaration)
Public Function InsertIsland( _
   ByVal positionOnLeg As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPIIsland

value = instance.InsertIsland(positionOnLeg)
C#
public ISIAPIIsland InsertIsland(
   int positionOnLeg
)
Managed Extensions for C++
public: ISIAPIIsland* InsertIsland(
   int positionOnLeg
)
C++/CLI
public:
ISIAPIIsland^ InsertIsland(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Island

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertIsland_RoundaboutSplitter Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : InsertIsland_RoundaboutSplitter Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.

Syntax

Visual Basic (Declaration)
Public Function InsertIsland_RoundaboutSplitter( _
   ByVal positionOnLeg As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPIIsland

value = instance.InsertIsland_RoundaboutSplitter(positionOnLeg)
C#
public ISIAPIIsland InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)
Managed Extensions for C++
public: ISIAPIIsland* InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)
C++/CLI
public:
ISIAPIIsland^ InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Roundabout Splitter Island

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveItem Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : RemoveItem Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.

Syntax

Visual Basic (Declaration)
Public Function RemoveItem( _
   ByVal positionOnLeg As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim positionOnLeg As Integer
Dim value As Boolean

value = instance.RemoveItem(positionOnLeg)
C#
public bool RemoveItem(
   int positionOnLeg
)
Managed Extensions for C++
public: bool RemoveItem(
   int positionOnLeg
)
C++/CLI
public:
bool RemoveItem(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

true if the item is successfully removed. This method returns false if the item was not found.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg Class

Glossary Item Box

For a list of all members of this type, see SIAPILeg members.

Public Properties

 | Name | Description
Public Property | Approach_control | Approach Control Type
Public Property | Approach_distance |
Public Property | Area_type_factor | Area Type Factor, for Legs in Signalised Site only
Public Property | Exit_distance |
Public Property | Exit_distance_user |
Public Property | Extra_bunching |
Public Property | Extra_bunching_user |
Public Property | Is_departure_headway_awsc_applied |
Public Property | Islands |
Public Property | LaneApproachs |
Public Property | LaneExits |
Public Property | LastErrorMessage |
Public Property | Leg_roundabout |
Public Property | LegGeometry | Leg Geometry
Public Property | Name |
Public Property | Orientation | Leg Orientation
Public Property | Site |
Top

See Also

Reference

SIAPILeg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Approach_control Property

Glossary Item Box

Approach Control Type

Syntax

Visual Basic (Declaration)
Public Property Approach_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Integer

instance.Approach_control = value

value = instance.Approach_control
C#
public int Approach_control {get; set;}
Managed Extensions for C++
public: __property int get_Approach_control();
public: __property void set_Approach_control(
   int value
);
C++/CLI
public:
property int Approach_control {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Major Road,
2 = Giveway,
3 = Stop,
7 = Signals.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Approach_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Approach_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Single

instance.Approach_distance = value

value = instance.Approach_distance
C#
public float Approach_distance {get; set;}
Managed Extensions for C++
public: __property float get_Approach_distance();
public: __property void set_Approach_distance(
   float value
);
C++/CLI
public:
property float Approach_distance {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Area_type_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Area_type_factor Property

Glossary Item Box

Area Type Factor, for Legs in Signalised Site only

Syntax

Visual Basic (Declaration)
Public Property Area_type_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Single

instance.Area_type_factor = value

value = instance.Area_type_factor
C#
public float Area_type_factor {get; set;}
Managed Extensions for C++
public: __property float get_Area_type_factor();
public: __property void set_Area_type_factor(
   float value
);
C++/CLI
public:
property float Area_type_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Exit_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
public float Exit_distance {get; set;}
Managed Extensions for C++
public: __property float get_Exit_distance();
public: __property void set_Exit_distance(
   float value
);
C++/CLI
public:
property float Exit_distance {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Exit_distance_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Exit_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Boolean

instance.Exit_distance_user = value

value = instance.Exit_distance_user
C#
public bool Exit_distance_user {get; set;}
Managed Extensions for C++
public: __property bool get_Exit_distance_user();
public: __property void set_Exit_distance_user(
   bool value
);
C++/CLI
public:
property bool Exit_distance_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Extra_bunching Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Extra_bunching As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Single

instance.Extra_bunching = value

value = instance.Extra_bunching
C#
public float Extra_bunching {get; set;}
Managed Extensions for C++
public: __property float get_Extra_bunching();
public: __property void set_Extra_bunching(
   float value
);
C++/CLI
public:
property float Extra_bunching {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Extra_bunching_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Extra_bunching_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Boolean

instance.Extra_bunching_user = value

value = instance.Extra_bunching_user
C#
public bool Extra_bunching_user {get; set;}
Managed Extensions for C++
public: __property bool get_Extra_bunching_user();
public: __property void set_Extra_bunching_user(
   bool value
);
C++/CLI
public:
property bool Extra_bunching_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_departure_headway_awsc_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Is_departure_headway_awsc_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_departure_headway_awsc_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Boolean

instance.Is_departure_headway_awsc_applied = value

value = instance.Is_departure_headway_awsc_applied
C#
public bool Is_departure_headway_awsc_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_departure_headway_awsc_applied();
public: __property void set_Is_departure_headway_awsc_applied(
   bool value
);
C++/CLI
public:
property bool Is_departure_headway_awsc_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Islands Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Islands Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Islands As ISIAPIIslands
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As ISIAPIIslands

value = instance.Islands
C#
public ISIAPIIslands Islands {get;}
Managed Extensions for C++
public: __property ISIAPIIslands* get_Islands();
C++/CLI
public:
property ISIAPIIslands^ Islands {
   ISIAPIIslands^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : LaneApproachs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneApproachs As ISIAPILaneApproachs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As ISIAPILaneApproachs

value = instance.LaneApproachs
C#
public ISIAPILaneApproachs LaneApproachs {get;}
Managed Extensions for C++
public: __property ISIAPILaneApproachs* get_LaneApproachs();
C++/CLI
public:
property ISIAPILaneApproachs^ LaneApproachs {
   ISIAPILaneApproachs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExits Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : LaneExits Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LaneExits As ISIAPILaneExits
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As ISIAPILaneExits

value = instance.LaneExits
C#
public ISIAPILaneExits LaneExits {get;}
Managed Extensions for C++
public: __property ISIAPILaneExits* get_LaneExits();
C++/CLI
public:
property ISIAPILaneExits^ LaneExits {
   ISIAPILaneExits^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg_roundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Leg_roundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg_roundabout As ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As ISIAPILeg_roundabout

value = instance.Leg_roundabout
C#
public ISIAPILeg_roundabout Leg_roundabout {get;}
Managed Extensions for C++
public: __property ISIAPILeg_roundabout* get_Leg_roundabout();
C++/CLI
public:
property ISIAPILeg_roundabout^ Leg_roundabout {
   ISIAPILeg_roundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegGeometry Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : LegGeometry Property

Glossary Item Box

Leg Geometry

Syntax

Visual Basic (Declaration)
Public Property LegGeometry As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Integer

instance.LegGeometry = value

value = instance.LegGeometry
C#
public int LegGeometry {get; set;}
Managed Extensions for C++
public: __property int get_LegGeometry();
public: __property void set_LegGeometry(
   int value
);
C++/CLI
public:
property int LegGeometry {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = No Leg,
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Remarks

Cannot remove a Leg by setting LegGeometry to 0. Call ISIAPILegs.RemoveLeg() method to remove a Leg.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Orientation Property

Glossary Item Box

Leg Orientation

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As Integer

value = instance.Orientation
C#
public int Orientation {get;}
Managed Extensions for C++
public: __property int get_Orientation();
C++/CLI
public:
property int Orientation {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg Class
SIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_rou_hcm Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_rou_hcm Class

Glossary Item Box

Object Model

SIAPILeg_rou_hcm ClassISIAPILeg_roundabout Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILeg_rou_hcm
   Implements ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
C#
public sealed class SIAPILeg_rou_hcm : ISIAPILeg_rou_hcm
Managed Extensions for C++
public __gc __sealed class SIAPILeg_rou_hcm : public ISIAPILeg_rou_hcm
C++/CLI
public ref class SIAPILeg_rou_hcm sealed : public ISIAPILeg_rou_hcm

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILeg_rou_hcm

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_rou_hcm Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_rou_hcm Class

Glossary Item Box

The following tables list the members exposed by SIAPILeg_rou_hcm.

Public Constructors

 | Name | Description
Public Constructor | SIAPILeg_rou_hcm Constructor |
Top

Public Properties

 | Name | Description
Public Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment (HCM)
Public Property | Hcm_model | HCM Model
Public Property | Leg_roundabout |
Public Property | Model_calib_factor |
Public Property | Multi_circ_multi_entry_dominant_param_a |
Public Property | Multi_circ_multi_entry_dominant_param_b |
Public Property | Multi_circ_multi_entry_subdominant_param_a |
Public Property | Multi_circ_multi_entry_subdominant_param_b |
Public Property | Multi_circ_single_entry_param_a |
Public Property | Multi_circ_single_entry_param_b |
Public Property | Single_circ_multi_entry_param_a |
Public Property | Single_circ_multi_entry_param_b |
Public Property | Single_circ_single_entry_param_a |
Public Property | Single_circ_single_entry_param_b |
Top

See Also

Reference

SIAPILeg_rou_hcm Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_rou_hcm Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : SIAPILeg_rou_hcm Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILeg_rou_hcm()
C#
public SIAPILeg_rou_hcm()
Managed Extensions for C++
public: SIAPILeg_rou_hcm();
C++/CLI
public:
SIAPILeg_rou_hcm();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_rou_hcm Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_rou_hcm Class

Glossary Item Box

For a list of all members of this type, see SIAPILeg_rou_hcm members.

Public Properties

 | Name | Description
Public Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment (HCM)
Public Property | Hcm_model | HCM Model
Public Property | Leg_roundabout |
Public Property | Model_calib_factor |
Public Property | Multi_circ_multi_entry_dominant_param_a |
Public Property | Multi_circ_multi_entry_dominant_param_b |
Public Property | Multi_circ_multi_entry_subdominant_param_a |
Public Property | Multi_circ_multi_entry_subdominant_param_b |
Public Property | Multi_circ_single_entry_param_a |
Public Property | Multi_circ_single_entry_param_b |
Public Property | Single_circ_multi_entry_param_a |
Public Property | Single_circ_multi_entry_param_b |
Public Property | Single_circ_single_entry_param_a |
Public Property | Single_circ_single_entry_param_b |
Top

See Also

Reference

SIAPILeg_rou_hcm Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Entry_circ_adj Property

Glossary Item Box

Roundabout Entry/Circulating Flow Adjustment (HCM)

Syntax

Visual Basic (Declaration)
Public Property Entry_circ_adj As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Integer

instance.Entry_circ_adj = value

value = instance.Entry_circ_adj
C#
public int Entry_circ_adj {get; set;}
Managed Extensions for C++
public: __property int get_Entry_circ_adj();
public: __property void set_Entry_circ_adj(
   int value
);
C++/CLI
public:
property int Entry_circ_adj {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hcm_model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Hcm_model Property

Glossary Item Box

HCM Model

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hcm_model As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Integer

value = instance.Hcm_model
C#
public int Hcm_model {get;}
Managed Extensions for C++
public: __property int get_Hcm_model();
C++/CLI
public:
property int Hcm_model {
   int get();
}

Property Value

Type: System.Int32;

1 = HCM 2010,
2 = HCM 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg_roundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Leg_roundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg_roundabout As ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As ISIAPILeg_roundabout

value = instance.Leg_roundabout
C#
public ISIAPILeg_roundabout Leg_roundabout {get;}
Managed Extensions for C++
public: __property ISIAPILeg_roundabout* get_Leg_roundabout();
C++/CLI
public:
property ISIAPILeg_roundabout^ Leg_roundabout {
   ISIAPILeg_roundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_calib_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Model_calib_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Model_calib_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Model_calib_factor = value

value = instance.Model_calib_factor
C#
public float Model_calib_factor {get; set;}
Managed Extensions for C++
public: __property float get_Model_calib_factor();
public: __property void set_Model_calib_factor(
   float value
);
C++/CLI
public:
property float Model_calib_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_dominant_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_multi_entry_dominant_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_multi_entry_dominant_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_dominant_param_a = value

value = instance.Multi_circ_multi_entry_dominant_param_a
C#
public float Multi_circ_multi_entry_dominant_param_a {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_multi_entry_dominant_param_a();
public: __property void set_Multi_circ_multi_entry_dominant_param_a(
   float value
);
C++/CLI
public:
property float Multi_circ_multi_entry_dominant_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_dominant_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_multi_entry_dominant_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_multi_entry_dominant_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_dominant_param_b = value

value = instance.Multi_circ_multi_entry_dominant_param_b
C#
public float Multi_circ_multi_entry_dominant_param_b {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_multi_entry_dominant_param_b();
public: __property void set_Multi_circ_multi_entry_dominant_param_b(
   float value
);
C++/CLI
public:
property float Multi_circ_multi_entry_dominant_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_subdominant_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_multi_entry_subdominant_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_multi_entry_subdominant_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_subdominant_param_a = value

value = instance.Multi_circ_multi_entry_subdominant_param_a
C#
public float Multi_circ_multi_entry_subdominant_param_a {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_multi_entry_subdominant_param_a();
public: __property void set_Multi_circ_multi_entry_subdominant_param_a(
   float value
);
C++/CLI
public:
property float Multi_circ_multi_entry_subdominant_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_subdominant_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_multi_entry_subdominant_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_multi_entry_subdominant_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_subdominant_param_b = value

value = instance.Multi_circ_multi_entry_subdominant_param_b
C#
public float Multi_circ_multi_entry_subdominant_param_b {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_multi_entry_subdominant_param_b();
public: __property void set_Multi_circ_multi_entry_subdominant_param_b(
   float value
);
C++/CLI
public:
property float Multi_circ_multi_entry_subdominant_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_single_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_single_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_single_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_single_entry_param_a = value

value = instance.Multi_circ_single_entry_param_a
C#
public float Multi_circ_single_entry_param_a {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_single_entry_param_a();
public: __property void set_Multi_circ_single_entry_param_a(
   float value
);
C++/CLI
public:
property float Multi_circ_single_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_single_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Multi_circ_single_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Multi_circ_single_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_single_entry_param_b = value

value = instance.Multi_circ_single_entry_param_b
C#
public float Multi_circ_single_entry_param_b {get; set;}
Managed Extensions for C++
public: __property float get_Multi_circ_single_entry_param_b();
public: __property void set_Multi_circ_single_entry_param_b(
   float value
);
C++/CLI
public:
property float Multi_circ_single_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_multi_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Single_circ_multi_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Single_circ_multi_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_multi_entry_param_a = value

value = instance.Single_circ_multi_entry_param_a
C#
public float Single_circ_multi_entry_param_a {get; set;}
Managed Extensions for C++
public: __property float get_Single_circ_multi_entry_param_a();
public: __property void set_Single_circ_multi_entry_param_a(
   float value
);
C++/CLI
public:
property float Single_circ_multi_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_multi_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Single_circ_multi_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Single_circ_multi_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_multi_entry_param_b = value

value = instance.Single_circ_multi_entry_param_b
C#
public float Single_circ_multi_entry_param_b {get; set;}
Managed Extensions for C++
public: __property float get_Single_circ_multi_entry_param_b();
public: __property void set_Single_circ_multi_entry_param_b(
   float value
);
C++/CLI
public:
property float Single_circ_multi_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_single_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Single_circ_single_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Single_circ_single_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_single_entry_param_a = value

value = instance.Single_circ_single_entry_param_a
C#
public float Single_circ_single_entry_param_a {get; set;}
Managed Extensions for C++
public: __property float get_Single_circ_single_entry_param_a();
public: __property void set_Single_circ_single_entry_param_a(
   float value
);
C++/CLI
public:
property float Single_circ_single_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_single_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_rou_hcm Class : Single_circ_single_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Single_circ_single_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_single_entry_param_b = value

value = instance.Single_circ_single_entry_param_b
C#
public float Single_circ_single_entry_param_b {get; set;}
Managed Extensions for C++
public: __property float get_Single_circ_single_entry_param_b();
public: __property void set_Single_circ_single_entry_param_b(
   float value
);
C++/CLI
public:
property float Single_circ_single_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_rou_hcm Class
SIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_roundabout Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_roundabout Class

Glossary Item Box

Object Model

SIAPILeg_roundabout ClassISIAPILeg InterfaceISIAPILeg_rou_hcm InterfaceISIAPILeg_rou_hcm Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILeg_roundabout
   Implements ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
C#
public sealed class SIAPILeg_roundabout : ISIAPILeg_roundabout
Managed Extensions for C++
public __gc __sealed class SIAPILeg_roundabout : public ISIAPILeg_roundabout
C++/CLI
public ref class SIAPILeg_roundabout sealed : public ISIAPILeg_roundabout

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILeg_roundabout

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_roundabout Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_roundabout Class

Glossary Item Box

The following tables list the members exposed by SIAPILeg_roundabout.

Public Constructors

 | Name | Description
Public Constructor | SIAPILeg_roundabout Constructor |
Top

Public Properties

 | Name | Description
Public Property | App_half_width |
Public Property | Capacity_at_zero_flow |
Public Property | Capacity_at_zero_flow_user |
Public Property | Circulating_transition_line |
Public Property | Circulating_width |
Public Property | Entry_angle |
Public Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment
Public Property | Entry_circ_adj_user |
Public Property | Entry_radius |
Public Property | Environment_factor |
Public Property | Environment_factor_user |
Public Property | Flare_length |
Public Property | Grade_separated |
Public Property | Inscribed_diameter |
Public Property | Inscribed_diameter_user |
Public Property | Is_raindrop_design |
Public Property | Island_diameter |
Public Property | Leg |
Public Property | LegRouHCM2010 |
Public Property | LegRouHCM6 |
Public Property | Num_circulating_lanes |
Public Property | Num_downstream_circulating_lanes |
Public Property | Num_downstream_circulating_lanes_user |
Top

See Also

Reference

SIAPILeg_roundabout Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_roundabout Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : SIAPILeg_roundabout Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILeg_roundabout()
C#
public SIAPILeg_roundabout()
Managed Extensions for C++
public: SIAPILeg_roundabout();
C++/CLI
public:
SIAPILeg_roundabout();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILeg_roundabout Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILeg_roundabout Class

Glossary Item Box

For a list of all members of this type, see SIAPILeg_roundabout members.

Public Properties

 | Name | Description
Public Property | App_half_width |
Public Property | Capacity_at_zero_flow |
Public Property | Capacity_at_zero_flow_user |
Public Property | Circulating_transition_line |
Public Property | Circulating_width |
Public Property | Entry_angle |
Public Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment
Public Property | Entry_circ_adj_user |
Public Property | Entry_radius |
Public Property | Environment_factor |
Public Property | Environment_factor_user |
Public Property | Flare_length |
Public Property | Grade_separated |
Public Property | Inscribed_diameter |
Public Property | Inscribed_diameter_user |
Public Property | Is_raindrop_design |
Public Property | Island_diameter |
Public Property | Leg |
Public Property | LegRouHCM2010 |
Public Property | LegRouHCM6 |
Public Property | Num_circulating_lanes |
Public Property | Num_downstream_circulating_lanes |
Public Property | Num_downstream_circulating_lanes_user |
Top

See Also

Reference

SIAPILeg_roundabout Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
App_half_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : App_half_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property App_half_width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.App_half_width = value

value = instance.App_half_width
C#
public float App_half_width {get; set;}
Managed Extensions for C++
public: __property float get_App_half_width();
public: __property void set_App_half_width(
   float value
);
C++/CLI
public:
property float App_half_width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_at_zero_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Capacity_at_zero_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity_at_zero_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Capacity_at_zero_flow = value

value = instance.Capacity_at_zero_flow
C#
public float Capacity_at_zero_flow {get; set;}
Managed Extensions for C++
public: __property float get_Capacity_at_zero_flow();
public: __property void set_Capacity_at_zero_flow(
   float value
);
C++/CLI
public:
property float Capacity_at_zero_flow {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_at_zero_flow_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Capacity_at_zero_flow_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Capacity_at_zero_flow_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Capacity_at_zero_flow_user = value

value = instance.Capacity_at_zero_flow_user
C#
public bool Capacity_at_zero_flow_user {get; set;}
Managed Extensions for C++
public: __property bool get_Capacity_at_zero_flow_user();
public: __property void set_Capacity_at_zero_flow_user(
   bool value
);
C++/CLI
public:
property bool Capacity_at_zero_flow_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_transition_line Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Circulating_transition_line Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Circulating_transition_line As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Circulating_transition_line = value

value = instance.Circulating_transition_line
C#
public bool Circulating_transition_line {get; set;}
Managed Extensions for C++
public: __property bool get_Circulating_transition_line();
public: __property void set_Circulating_transition_line(
   bool value
);
C++/CLI
public:
property bool Circulating_transition_line {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Circulating_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Circulating_width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Circulating_width = value

value = instance.Circulating_width
C#
public float Circulating_width {get; set;}
Managed Extensions for C++
public: __property float get_Circulating_width();
public: __property void set_Circulating_width(
   float value
);
C++/CLI
public:
property float Circulating_width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_angle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Entry_angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Entry_angle As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Entry_angle = value

value = instance.Entry_angle
C#
public float Entry_angle {get; set;}
Managed Extensions for C++
public: __property float get_Entry_angle();
public: __property void set_Entry_angle(
   float value
);
C++/CLI
public:
property float Entry_angle {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Entry_circ_adj Property

Glossary Item Box

Roundabout Entry/Circulating Flow Adjustment

Syntax

Visual Basic (Declaration)
Public Property Entry_circ_adj As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Integer

instance.Entry_circ_adj = value

value = instance.Entry_circ_adj
C#
public int Entry_circ_adj {get; set;}
Managed Extensions for C++
public: __property int get_Entry_circ_adj();
public: __property void set_Entry_circ_adj(
   int value
);
C++/CLI
public:
property int Entry_circ_adj {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Entry_circ_adj_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Entry_circ_adj_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Entry_circ_adj_user = value

value = instance.Entry_circ_adj_user
C#
public bool Entry_circ_adj_user {get; set;}
Managed Extensions for C++
public: __property bool get_Entry_circ_adj_user();
public: __property void set_Entry_circ_adj_user(
   bool value
);
C++/CLI
public:
property bool Entry_circ_adj_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Entry_radius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Entry_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Entry_radius = value

value = instance.Entry_radius
C#
public float Entry_radius {get; set;}
Managed Extensions for C++
public: __property float get_Entry_radius();
public: __property void set_Entry_radius(
   float value
);
C++/CLI
public:
property float Entry_radius {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Environment_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Environment_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Environment_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Environment_factor = value

value = instance.Environment_factor
C#
public float Environment_factor {get; set;}
Managed Extensions for C++
public: __property float get_Environment_factor();
public: __property void set_Environment_factor(
   float value
);
C++/CLI
public:
property float Environment_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Environment_factor_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Environment_factor_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Environment_factor_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Environment_factor_user = value

value = instance.Environment_factor_user
C#
public bool Environment_factor_user {get; set;}
Managed Extensions for C++
public: __property bool get_Environment_factor_user();
public: __property void set_Environment_factor_user(
   bool value
);
C++/CLI
public:
property bool Environment_factor_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flare_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Flare_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flare_length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Flare_length = value

value = instance.Flare_length
C#
public float Flare_length {get; set;}
Managed Extensions for C++
public: __property float get_Flare_length();
public: __property void set_Flare_length(
   float value
);
C++/CLI
public:
property float Flare_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade_separated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Grade_separated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Grade_separated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Grade_separated = value

value = instance.Grade_separated
C#
public bool Grade_separated {get; set;}
Managed Extensions for C++
public: __property bool get_Grade_separated();
public: __property void set_Grade_separated(
   bool value
);
C++/CLI
public:
property bool Grade_separated {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Inscribed_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Inscribed_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Inscribed_diameter = value

value = instance.Inscribed_diameter
C#
public float Inscribed_diameter {get; set;}
Managed Extensions for C++
public: __property float get_Inscribed_diameter();
public: __property void set_Inscribed_diameter(
   float value
);
C++/CLI
public:
property float Inscribed_diameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Inscribed_diameter_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Inscribed_diameter_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Inscribed_diameter_user = value

value = instance.Inscribed_diameter_user
C#
public bool Inscribed_diameter_user {get; set;}
Managed Extensions for C++
public: __property bool get_Inscribed_diameter_user();
public: __property void set_Inscribed_diameter_user(
   bool value
);
C++/CLI
public:
property bool Inscribed_diameter_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_raindrop_design Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Is_raindrop_design Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_raindrop_design As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Is_raindrop_design = value

value = instance.Is_raindrop_design
C#
public bool Is_raindrop_design {get; set;}
Managed Extensions for C++
public: __property bool get_Is_raindrop_design();
public: __property void set_Is_raindrop_design(
   bool value
);
C++/CLI
public:
property bool Is_raindrop_design {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Island_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Island_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Island_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Single

instance.Island_diameter = value

value = instance.Island_diameter
C#
public float Island_diameter {get; set;}
Managed Extensions for C++
public: __property float get_Island_diameter();
public: __property void set_Island_diameter(
   float value
);
C++/CLI
public:
property float Island_diameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As ISIAPILeg

value = instance.Leg
C#
public ISIAPILeg Leg {get;}
Managed Extensions for C++
public: __property ISIAPILeg* get_Leg();
C++/CLI
public:
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegRouHCM2010 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : LegRouHCM2010 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LegRouHCM2010 As ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As ISIAPILeg_rou_hcm

value = instance.LegRouHCM2010
C#
public ISIAPILeg_rou_hcm LegRouHCM2010 {get;}
Managed Extensions for C++
public: __property ISIAPILeg_rou_hcm* get_LegRouHCM2010();
C++/CLI
public:
property ISIAPILeg_rou_hcm^ LegRouHCM2010 {
   ISIAPILeg_rou_hcm^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegRouHCM6 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : LegRouHCM6 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LegRouHCM6 As ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As ISIAPILeg_rou_hcm

value = instance.LegRouHCM6
C#
public ISIAPILeg_rou_hcm LegRouHCM6 {get;}
Managed Extensions for C++
public: __property ISIAPILeg_rou_hcm* get_LegRouHCM6();
C++/CLI
public:
property ISIAPILeg_rou_hcm^ LegRouHCM6 {
   ISIAPILeg_rou_hcm^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_circulating_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Num_circulating_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Num_circulating_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Integer

instance.Num_circulating_lanes = value

value = instance.Num_circulating_lanes
C#
public int Num_circulating_lanes {get; set;}
Managed Extensions for C++
public: __property int get_Num_circulating_lanes();
public: __property void set_Num_circulating_lanes(
   int value
);
C++/CLI
public:
property int Num_circulating_lanes {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_downstream_circulating_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Num_downstream_circulating_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Num_downstream_circulating_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Integer

instance.Num_downstream_circulating_lanes = value

value = instance.Num_downstream_circulating_lanes
C#
public int Num_downstream_circulating_lanes {get; set;}
Managed Extensions for C++
public: __property int get_Num_downstream_circulating_lanes();
public: __property void set_Num_downstream_circulating_lanes(
   int value
);
C++/CLI
public:
property int Num_downstream_circulating_lanes {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_downstream_circulating_lanes_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILeg_roundabout Class : Num_downstream_circulating_lanes_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Num_downstream_circulating_lanes_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILeg_roundabout
Dim value As Boolean

instance.Num_downstream_circulating_lanes_user = value

value = instance.Num_downstream_circulating_lanes_user
C#
public bool Num_downstream_circulating_lanes_user {get; set;}
Managed Extensions for C++
public: __property bool get_Num_downstream_circulating_lanes_user();
public: __property void set_Num_downstream_circulating_lanes_user(
   bool value
);
C++/CLI
public:
property bool Num_downstream_circulating_lanes_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILeg_roundabout Class
SIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILegs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILegs Class

Glossary Item Box

Object Model

SIAPILegs ClassISIAPILeg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPILegs
   Implements ISIAPILegs
Visual Basic (Usage) Copy Code
Dim instance As SIAPILegs
C#
public sealed class SIAPILegs : ISIAPILegs
Managed Extensions for C++
public __gc __sealed class SIAPILegs : public ISIAPILegs
C++/CLI
public ref class SIAPILegs sealed : public ISIAPILegs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPILegs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILegs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILegs Class

Glossary Item Box

The following tables list the members exposed by SIAPILegs.

Public Constructors

 | Name | Description
Public Constructor | SIAPILegs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Leg. Return a Leg if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegExists | Get a value indicating whether a Leg data exists in the data structure.
Top

See Also

Reference

SIAPILegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILegs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILegs Class : SIAPILegs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPILegs()
C#
public SIAPILegs()
Managed Extensions for C++
public: SIAPILegs();
C++/CLI
public:
SIAPILegs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Class
SIAPILegs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILegs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILegs Class

Glossary Item Box

For a list of all members of this type, see SIAPILegs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegExists | Get a value indicating whether a Leg data exists in the data structure.
Top

See Also

Reference

SIAPILegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILegs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPILegs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Class
SIAPILegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILegs Class : LegExists Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Get a value indicating whether a Leg data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function LegExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPILegs
Dim orientation As Integer
Dim value As Boolean

value = instance.LegExists(orientation)
C#
public bool LegExists(
   int orientation
)
Managed Extensions for C++
public: bool LegExists(
   int orientation
)
C++/CLI
public:
bool LegExists(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Class
SIAPILegs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPILegs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPILegs Class

Glossary Item Box

For a list of all members of this type, see SIAPILegs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Leg. Return a Leg if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPILegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILegs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPILegs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Class
SIAPILegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPILegs Class : Item Property

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Get a Leg.
Return a Leg if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPILegs
Dim orientation As Integer
Dim value As ISIAPILeg

value = instance.Item(orientation)
C#
public ISIAPILeg this[
   int orientation
]; {get;}
Managed Extensions for C++
public: __property ISIAPILeg* get_Item   int orientation
;
C++/CLI
public:
property ISIAPILeg^ default [int] {
   ISIAPILeg^ get(int orientation);
}

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPILegs Class
SIAPILegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIModelSetting Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIModelSetting Class

Glossary Item Box

SIDRA INTERSECTION Model Setting wrapper class

Object Model

SIAPIModelSetting Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIModelSetting
   Implements ISIAPIModelSetting
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
C#
public sealed class SIAPIModelSetting : ISIAPIModelSetting
Managed Extensions for C++
public __gc __sealed class SIAPIModelSetting : public ISIAPIModelSetting
C++/CLI
public ref class SIAPIModelSetting sealed : public ISIAPIModelSetting

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIModelSetting

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIModelSetting Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIModelSetting Class

Glossary Item Box

The following tables list the members exposed by SIAPIModelSetting.

Public Constructors

 | Name | Description
Public Constructor | SIAPIModelSetting Constructor |
Top

Public Properties

 | Name | Description
Public Property | Calibration_note |
Public Property | Downstream_SL_CalibrationParameter |
Public Property | Downstream_SL_Distance_FullLaneUtil |
Public Property | Downstream_SL_Distance_Min |
Public Property | Downstream_SL_Util_Ratio_Min |
Public Property | Gap_Acceptance_Capacity | Gap Acceptance Capacity
Public Property | Hours_per_Year |
Public Property | Is_geometric_delay_excluded |
Public Property | Is_hcm_delay_formula_applied |
Public Property | Is_hcm_queue_formula_applied |
Public Property | Is_ped_cost_included |
Public Property | LOS_Method | Level of Service Method
Public Property | LOS_Target | Level of Service Target
Public Property | Major_road_turn_flow_factor |
Public Property | Min_prob_blockage |
Public Property | Ped_average_income |
Public Property | Ped_LOS_Method |
Public Property | Ped_los_target | Pedestrian Level of Service Target
Public Property | Ped_time_value_factor |
Public Property | Percentile_Queue |
Public Property | Percentile_queue_option | Percentile Queue Option
Public Property | Performance_Measure | Performance Measure
Public Property | Platoon_disp_distance_max |
Public Property | Platoon_disp_distance_min |
Public Property | Platoon_disp_factor_max |
Public Property | Platoon_disp_factor_min |
Public Property | Platoon_disp_n |
Public Property | Platoon_front_factor |
Public Property | Reduct_opposing_flow_rate_level | Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)
Public Property | Rou_Capacity_Model | Roundabout Capacity Model
Public Property | Rou_FHWA_2000_model_applied |
Public Property | Rou_FHWA_2000_Urban_compact_applied |
Public Property | Rou_HCM_2000_model_applied |
Public Property | Rou_HCM_2010_OD_pattern_effects_included |
Public Property | Rou_HCM_6_OD_pattern_effects_included |
Public Property | Rou_LOS_Method | Roundabout LOS Method
Public Property | Rou_NAASRA_1986_model_applied |
Public Property | Shortlane_queue_storage_ratio_incl |
Top

See Also

Reference

SIAPIModelSetting Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIModelSetting Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : SIAPIModelSetting Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIModelSetting()
C#
public SIAPIModelSetting()
Managed Extensions for C++
public: SIAPIModelSetting();
C++/CLI
public:
SIAPIModelSetting();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIModelSetting Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIModelSetting Class

Glossary Item Box

For a list of all members of this type, see SIAPIModelSetting members.

Public Properties

 | Name | Description
Public Property | Calibration_note |
Public Property | Downstream_SL_CalibrationParameter |
Public Property | Downstream_SL_Distance_FullLaneUtil |
Public Property | Downstream_SL_Distance_Min |
Public Property | Downstream_SL_Util_Ratio_Min |
Public Property | Gap_Acceptance_Capacity | Gap Acceptance Capacity
Public Property | Hours_per_Year |
Public Property | Is_geometric_delay_excluded |
Public Property | Is_hcm_delay_formula_applied |
Public Property | Is_hcm_queue_formula_applied |
Public Property | Is_ped_cost_included |
Public Property | LOS_Method | Level of Service Method
Public Property | LOS_Target | Level of Service Target
Public Property | Major_road_turn_flow_factor |
Public Property | Min_prob_blockage |
Public Property | Ped_average_income |
Public Property | Ped_LOS_Method |
Public Property | Ped_los_target | Pedestrian Level of Service Target
Public Property | Ped_time_value_factor |
Public Property | Percentile_Queue |
Public Property | Percentile_queue_option | Percentile Queue Option
Public Property | Performance_Measure | Performance Measure
Public Property | Platoon_disp_distance_max |
Public Property | Platoon_disp_distance_min |
Public Property | Platoon_disp_factor_max |
Public Property | Platoon_disp_factor_min |
Public Property | Platoon_disp_n |
Public Property | Platoon_front_factor |
Public Property | Reduct_opposing_flow_rate_level | Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)
Public Property | Rou_Capacity_Model | Roundabout Capacity Model
Public Property | Rou_FHWA_2000_model_applied |
Public Property | Rou_FHWA_2000_Urban_compact_applied |
Public Property | Rou_HCM_2000_model_applied |
Public Property | Rou_HCM_2010_OD_pattern_effects_included |
Public Property | Rou_HCM_6_OD_pattern_effects_included |
Public Property | Rou_LOS_Method | Roundabout LOS Method
Public Property | Rou_NAASRA_1986_model_applied |
Public Property | Shortlane_queue_storage_ratio_incl |
Top

See Also

Reference

SIAPIModelSetting Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calibration_note Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Calibration_note Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Calibration_note As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As String

instance.Calibration_note = value

value = instance.Calibration_note
C#
public string Calibration_note {get; set;}
Managed Extensions for C++
public: __property string* get_Calibration_note();
public: __property void set_Calibration_note(
   string* value
);
C++/CLI
public:
property String^ Calibration_note {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_CalibrationParameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Downstream_SL_CalibrationParameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Downstream_SL_CalibrationParameter As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Downstream_SL_CalibrationParameter = value

value = instance.Downstream_SL_CalibrationParameter
C#
public float Downstream_SL_CalibrationParameter {get; set;}
Managed Extensions for C++
public: __property float get_Downstream_SL_CalibrationParameter();
public: __property void set_Downstream_SL_CalibrationParameter(
   float value
);
C++/CLI
public:
property float Downstream_SL_CalibrationParameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Distance_FullLaneUtil Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Downstream_SL_Distance_FullLaneUtil Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Downstream_SL_Distance_FullLaneUtil As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Distance_FullLaneUtil = value

value = instance.Downstream_SL_Distance_FullLaneUtil
C#
public float Downstream_SL_Distance_FullLaneUtil {get; set;}
Managed Extensions for C++
public: __property float get_Downstream_SL_Distance_FullLaneUtil();
public: __property void set_Downstream_SL_Distance_FullLaneUtil(
   float value
);
C++/CLI
public:
property float Downstream_SL_Distance_FullLaneUtil {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Distance_Min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Downstream_SL_Distance_Min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Downstream_SL_Distance_Min As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Distance_Min = value

value = instance.Downstream_SL_Distance_Min
C#
public float Downstream_SL_Distance_Min {get; set;}
Managed Extensions for C++
public: __property float get_Downstream_SL_Distance_Min();
public: __property void set_Downstream_SL_Distance_Min(
   float value
);
C++/CLI
public:
property float Downstream_SL_Distance_Min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Util_Ratio_Min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Downstream_SL_Util_Ratio_Min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Downstream_SL_Util_Ratio_Min As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Util_Ratio_Min = value

value = instance.Downstream_SL_Util_Ratio_Min
C#
public float Downstream_SL_Util_Ratio_Min {get; set;}
Managed Extensions for C++
public: __property float get_Downstream_SL_Util_Ratio_Min();
public: __property void set_Downstream_SL_Util_Ratio_Min(
   float value
);
C++/CLI
public:
property float Downstream_SL_Util_Ratio_Min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_Acceptance_Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Gap_Acceptance_Capacity Property

Glossary Item Box

Gap Acceptance Capacity

Syntax

Visual Basic (Declaration)
Public Property Gap_Acceptance_Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Gap_Acceptance_Capacity = value

value = instance.Gap_Acceptance_Capacity
C#
public int Gap_Acceptance_Capacity {get; set;}
Managed Extensions for C++
public: __property int get_Gap_Acceptance_Capacity();
public: __property void set_Gap_Acceptance_Capacity(
   int value
);
C++/CLI
public:
property int Gap_Acceptance_Capacity {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Standard (Akcelik M3D),
1 = Akcelik M1,
2 = Siegloch M1,
3 = Traditional M1.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hours_per_Year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Hours_per_Year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Hours_per_Year As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Hours_per_Year = value

value = instance.Hours_per_Year
C#
public int Hours_per_Year {get; set;}
Managed Extensions for C++
public: __property int get_Hours_per_Year();
public: __property void set_Hours_per_Year(
   int value
);
C++/CLI
public:
property int Hours_per_Year {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_geometric_delay_excluded Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Is_geometric_delay_excluded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_geometric_delay_excluded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Is_geometric_delay_excluded = value

value = instance.Is_geometric_delay_excluded
C#
public bool Is_geometric_delay_excluded {get; set;}
Managed Extensions for C++
public: __property bool get_Is_geometric_delay_excluded();
public: __property void set_Is_geometric_delay_excluded(
   bool value
);
C++/CLI
public:
property bool Is_geometric_delay_excluded {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_hcm_delay_formula_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Is_hcm_delay_formula_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_hcm_delay_formula_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Is_hcm_delay_formula_applied = value

value = instance.Is_hcm_delay_formula_applied
C#
public bool Is_hcm_delay_formula_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_hcm_delay_formula_applied();
public: __property void set_Is_hcm_delay_formula_applied(
   bool value
);
C++/CLI
public:
property bool Is_hcm_delay_formula_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_hcm_queue_formula_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Is_hcm_queue_formula_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_hcm_queue_formula_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Is_hcm_queue_formula_applied = value

value = instance.Is_hcm_queue_formula_applied
C#
public bool Is_hcm_queue_formula_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_hcm_queue_formula_applied();
public: __property void set_Is_hcm_queue_formula_applied(
   bool value
);
C++/CLI
public:
property bool Is_hcm_queue_formula_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_ped_cost_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Is_ped_cost_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_ped_cost_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Is_ped_cost_included = value

value = instance.Is_ped_cost_included
C#
public bool Is_ped_cost_included {get; set;}
Managed Extensions for C++
public: __property bool get_Is_ped_cost_included();
public: __property void set_Is_ped_cost_included(
   bool value
);
C++/CLI
public:
property bool Is_ped_cost_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : LOS_Method Property

Glossary Item Box

Level of Service Method

Syntax

Visual Basic (Declaration)
Public Property LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.LOS_Method = value

value = instance.LOS_Method
C#
public int LOS_Method {get; set;}
Managed Extensions for C++
public: __property int get_LOS_Method();
public: __property void set_LOS_Method(
   int value
);
C++/CLI
public:
property int LOS_Method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Delay (SIDRA),
1 = Degree of Saturation (SIDRA),
2 = Delay and v/c (HCM 2010),
3 = Delay (RTA NSW),
4 = Degree of Saturation (ICU),
5 = Delay and Degree of Saturation (SIDRA),
6 = Delay and v/c (HCM 6).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOS_Target Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : LOS_Target Property

Glossary Item Box

Level of Service Target

Syntax

Visual Basic (Declaration)
Public Property LOS_Target As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.LOS_Target = value

value = instance.LOS_Target
C#
public int LOS_Target {get; set;}
Managed Extensions for C++
public: __property int get_LOS_Target();
public: __property void set_LOS_Target(
   int value
);
C++/CLI
public:
property int LOS_Target {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Major_road_turn_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Major_road_turn_flow_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Major_road_turn_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Major_road_turn_flow_factor = value

value = instance.Major_road_turn_flow_factor
C#
public float Major_road_turn_flow_factor {get; set;}
Managed Extensions for C++
public: __property float get_Major_road_turn_flow_factor();
public: __property void set_Major_road_turn_flow_factor(
   float value
);
C++/CLI
public:
property float Major_road_turn_flow_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_prob_blockage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Min_prob_blockage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Min_prob_blockage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Min_prob_blockage = value

value = instance.Min_prob_blockage
C#
public float Min_prob_blockage {get; set;}
Managed Extensions for C++
public: __property float get_Min_prob_blockage();
public: __property void set_Min_prob_blockage(
   float value
);
C++/CLI
public:
property float Min_prob_blockage {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_average_income Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Ped_average_income Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Ped_average_income As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Ped_average_income = value

value = instance.Ped_average_income
C#
public float Ped_average_income {get; set;}
Managed Extensions for C++
public: __property float get_Ped_average_income();
public: __property void set_Ped_average_income(
   float value
);
C++/CLI
public:
property float Ped_average_income {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Ped_LOS_Method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Ped_LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Ped_LOS_Method = value

value = instance.Ped_LOS_Method
C#
public int Ped_LOS_Method {get; set;}
Managed Extensions for C++
public: __property int get_Ped_LOS_Method();
public: __property void set_Ped_LOS_Method(
   int value
);
C++/CLI
public:
property int Ped_LOS_Method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_los_target Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Ped_los_target Property

Glossary Item Box

Pedestrian Level of Service Target

Syntax

Visual Basic (Declaration)
Public Property Ped_los_target As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Ped_los_target = value

value = instance.Ped_los_target
C#
public int Ped_los_target {get; set;}
Managed Extensions for C++
public: __property int get_Ped_los_target();
public: __property void set_Ped_los_target(
   int value
);
C++/CLI
public:
property int Ped_los_target {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_time_value_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Ped_time_value_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Ped_time_value_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Ped_time_value_factor = value

value = instance.Ped_time_value_factor
C#
public float Ped_time_value_factor {get; set;}
Managed Extensions for C++
public: __property float get_Ped_time_value_factor();
public: __property void set_Ped_time_value_factor(
   float value
);
C++/CLI
public:
property float Ped_time_value_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_Queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Percentile_Queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Percentile_Queue As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Percentile_Queue = value

value = instance.Percentile_Queue
C#
public int Percentile_Queue {get; set;}
Managed Extensions for C++
public: __property int get_Percentile_Queue();
public: __property void set_Percentile_Queue(
   int value
);
C++/CLI
public:
property int Percentile_Queue {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Percentile_queue_option Property

Glossary Item Box

Percentile Queue Option

Syntax

Visual Basic (Declaration)
Public Property Percentile_queue_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Percentile_queue_option = value

value = instance.Percentile_queue_option
C#
public int Percentile_queue_option {get; set;}
Managed Extensions for C++
public: __property int get_Percentile_queue_option();
public: __property void set_Percentile_queue_option(
   int value
);
C++/CLI
public:
property int Percentile_queue_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Percentile,
2 = Average.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_Measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Performance_Measure Property

Glossary Item Box

Performance Measure

Syntax

Visual Basic (Declaration)
Public Property Performance_Measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Performance_Measure = value

value = instance.Performance_Measure
C#
public int Performance_Measure {get; set;}
Managed Extensions for C++
public: __property int get_Performance_Measure();
public: __property void set_Performance_Measure(
   int value
);
C++/CLI
public:
property int Performance_Measure {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Delay,
1 = Queue,
2 = Stop Rate,
3 = Performance Index,
4 = Degree of Saturation,
5 = Capacity,
6 = Spare Capacity,
7 = Cost,
8 = Fuel,
9 = CO2,
10 = HC,
11 = CO,
12 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_distance_max Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_disp_distance_max Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_disp_distance_max As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_disp_distance_max = value

value = instance.Platoon_disp_distance_max
C#
public float Platoon_disp_distance_max {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_disp_distance_max();
public: __property void set_Platoon_disp_distance_max(
   float value
);
C++/CLI
public:
property float Platoon_disp_distance_max {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_distance_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_disp_distance_min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_disp_distance_min As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_disp_distance_min = value

value = instance.Platoon_disp_distance_min
C#
public float Platoon_disp_distance_min {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_disp_distance_min();
public: __property void set_Platoon_disp_distance_min(
   float value
);
C++/CLI
public:
property float Platoon_disp_distance_min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_factor_max Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_disp_factor_max Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_disp_factor_max As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_disp_factor_max = value

value = instance.Platoon_disp_factor_max
C#
public float Platoon_disp_factor_max {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_disp_factor_max();
public: __property void set_Platoon_disp_factor_max(
   float value
);
C++/CLI
public:
property float Platoon_disp_factor_max {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_factor_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_disp_factor_min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_disp_factor_min As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_disp_factor_min = value

value = instance.Platoon_disp_factor_min
C#
public float Platoon_disp_factor_min {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_disp_factor_min();
public: __property void set_Platoon_disp_factor_min(
   float value
);
C++/CLI
public:
property float Platoon_disp_factor_min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_n Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_disp_n Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_disp_n As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_disp_n = value

value = instance.Platoon_disp_n
C#
public float Platoon_disp_n {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_disp_n();
public: __property void set_Platoon_disp_n(
   float value
);
C++/CLI
public:
property float Platoon_disp_n {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_front_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Platoon_front_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Platoon_front_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Single

instance.Platoon_front_factor = value

value = instance.Platoon_front_factor
C#
public float Platoon_front_factor {get; set;}
Managed Extensions for C++
public: __property float get_Platoon_front_factor();
public: __property void set_Platoon_front_factor(
   float value
);
C++/CLI
public:
property float Platoon_front_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reduct_opposing_flow_rate_level Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Reduct_opposing_flow_rate_level Property

Glossary Item Box

Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)

Syntax

Visual Basic (Declaration)
Public Property Reduct_opposing_flow_rate_level As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Reduct_opposing_flow_rate_level = value

value = instance.Reduct_opposing_flow_rate_level
C#
public int Reduct_opposing_flow_rate_level {get; set;}
Managed Extensions for C++
public: __property int get_Reduct_opposing_flow_rate_level();
public: __property void set_Reduct_opposing_flow_rate_level(
   int value
);
C++/CLI
public:
property int Reduct_opposing_flow_rate_level {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_Capacity_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_Capacity_Model Property

Glossary Item Box

Roundabout Capacity Model

Syntax

Visual Basic (Declaration)
Public Property Rou_Capacity_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Rou_Capacity_Model = value

value = instance.Rou_Capacity_Model
C#
public int Rou_Capacity_Model {get; set;}
Managed Extensions for C++
public: __property int get_Rou_Capacity_Model();
public: __property void set_Rou_Capacity_Model(
   int value
);
C++/CLI
public:
property int Rou_Capacity_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Standard,
1 = HCM 2010,
2 = HCM 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_FHWA_2000_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_FHWA_2000_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_FHWA_2000_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_FHWA_2000_model_applied = value

value = instance.Rou_FHWA_2000_model_applied
C#
public bool Rou_FHWA_2000_model_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_FHWA_2000_model_applied();
public: __property void set_Rou_FHWA_2000_model_applied(
   bool value
);
C++/CLI
public:
property bool Rou_FHWA_2000_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_FHWA_2000_Urban_compact_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_FHWA_2000_Urban_compact_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_FHWA_2000_Urban_compact_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_FHWA_2000_Urban_compact_applied = value

value = instance.Rou_FHWA_2000_Urban_compact_applied
C#
public bool Rou_FHWA_2000_Urban_compact_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_FHWA_2000_Urban_compact_applied();
public: __property void set_Rou_FHWA_2000_Urban_compact_applied(
   bool value
);
C++/CLI
public:
property bool Rou_FHWA_2000_Urban_compact_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_2000_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_HCM_2000_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_HCM_2000_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_2000_model_applied = value

value = instance.Rou_HCM_2000_model_applied
C#
public bool Rou_HCM_2000_model_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_HCM_2000_model_applied();
public: __property void set_Rou_HCM_2000_model_applied(
   bool value
);
C++/CLI
public:
property bool Rou_HCM_2000_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_2010_OD_pattern_effects_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_HCM_2010_OD_pattern_effects_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_HCM_2010_OD_pattern_effects_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_2010_OD_pattern_effects_included = value

value = instance.Rou_HCM_2010_OD_pattern_effects_included
C#
public bool Rou_HCM_2010_OD_pattern_effects_included {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_HCM_2010_OD_pattern_effects_included();
public: __property void set_Rou_HCM_2010_OD_pattern_effects_included(
   bool value
);
C++/CLI
public:
property bool Rou_HCM_2010_OD_pattern_effects_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_6_OD_pattern_effects_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_HCM_6_OD_pattern_effects_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_HCM_6_OD_pattern_effects_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_6_OD_pattern_effects_included = value

value = instance.Rou_HCM_6_OD_pattern_effects_included
C#
public bool Rou_HCM_6_OD_pattern_effects_included {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_HCM_6_OD_pattern_effects_included();
public: __property void set_Rou_HCM_6_OD_pattern_effects_included(
   bool value
);
C++/CLI
public:
property bool Rou_HCM_6_OD_pattern_effects_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_LOS_Method Property

Glossary Item Box

Roundabout LOS Method

Syntax

Visual Basic (Declaration)
Public Property Rou_LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Integer

instance.Rou_LOS_Method = value

value = instance.Rou_LOS_Method
C#
public int Rou_LOS_Method {get; set;}
Managed Extensions for C++
public: __property int get_Rou_LOS_Method();
public: __property void set_Rou_LOS_Method(
   int value
);
C++/CLI
public:
property int Rou_LOS_Method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Roundabout LOS,
1 = Same as Signalised Intersections,
2 = Same as Sign Control.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_NAASRA_1986_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Rou_NAASRA_1986_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_NAASRA_1986_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Rou_NAASRA_1986_model_applied = value

value = instance.Rou_NAASRA_1986_model_applied
C#
public bool Rou_NAASRA_1986_model_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Rou_NAASRA_1986_model_applied();
public: __property void set_Rou_NAASRA_1986_model_applied(
   bool value
);
C++/CLI
public:
property bool Rou_NAASRA_1986_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_queue_storage_ratio_incl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIModelSetting Class : Shortlane_queue_storage_ratio_incl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Shortlane_queue_storage_ratio_incl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIModelSetting
Dim value As Boolean

instance.Shortlane_queue_storage_ratio_incl = value

value = instance.Shortlane_queue_storage_ratio_incl
C#
public bool Shortlane_queue_storage_ratio_incl {get; set;}
Managed Extensions for C++
public: __property bool get_Shortlane_queue_storage_ratio_incl();
public: __property void set_Shortlane_queue_storage_ratio_incl(
   bool value
);
C++/CLI
public:
property bool Shortlane_queue_storage_ratio_incl {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIModelSetting Class
SIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_ped Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_ped Class

Glossary Item Box

SIDRA INTERSECTION Pedestrian Movement wrapper class

Object Model

SIAPIMovement_ped ClassISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_ped
   Implements ISIAPIMovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
C#
public sealed class SIAPIMovement_ped : ISIAPIMovement_ped
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_ped : public ISIAPIMovement_ped
C++/CLI
public ref class SIAPIMovement_ped sealed : public ISIAPIMovement_ped

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_ped Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_ped Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_ped.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_ped Constructor |
Top

Public Properties

 | Name | Description
Public Property | Actuation_option |
Public Property | Actuation_percent |
Public Property | Approach_distance | Approach Travel Distance
Public Property | Clearance_time_overlap |
Public Property | Conflict_zone_length |
Public Property | Conflict_zone_length_user |
Public Property | Crossing_distance | Crossing Distance
Public Property | Crossing_distance_user | Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.
Public Property | Crossing_speed |
Public Property | Crosswalk_space |
Public Property | Display_id | Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.
Public Property | End_gain |
Public Property | Exists | Flag indicating whether this pedestrian movement "exists" (not banned) in the current site.
Public Property | Exit_distance | Exit (Downstream) Distance
Public Property | Flow_scale | Flow Scale (Constant)
Public Property | Growth_rate | Growth Rate (%/year)
Public Property | Is_high_priority | High Priority for Green Splits
Public Property | Is_walk_time_extended |
Public Property | Maximum_green_time |
Public Property | Maximum_green_time_user |
Public Property | Minimum_clearance_time |
Public Property | Minimum_green_time |
Public Property | Minimum_green_time_user |
Public Property | Minimum_walk_time |
Public Property | Opposing_ped_factor |
Public Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Public Property | Peak_flow_factor | Peak Flow Factor (%)
Public Property | Practical_degree_of_saturation | Practical degree of saturation
Public Property | Practical_degree_of_saturation_user | Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.
Public Property | Queue_space | Queue Space
Public Property | Saturation_flow_rate | Saturation Flow (ped/h)
Public Property | Site |
Public Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Public Property | Start_loss |
Public Property | Type | The type of a Pedestrian Movement
Public Property | Volume | Pedestrian Volume
Public Property | Walking_speed | Walking Speed (Average)
Top

See Also

Reference

SIAPIMovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_ped Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : SIAPIMovement_ped Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_ped()
C#
public SIAPIMovement_ped()
Managed Extensions for C++
public: SIAPIMovement_ped();
C++/CLI
public:
SIAPIMovement_ped();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_ped Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_ped Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_ped members.

Public Properties

 | Name | Description
Public Property | Actuation_option |
Public Property | Actuation_percent |
Public Property | Approach_distance | Approach Travel Distance
Public Property | Clearance_time_overlap |
Public Property | Conflict_zone_length |
Public Property | Conflict_zone_length_user |
Public Property | Crossing_distance | Crossing Distance
Public Property | Crossing_distance_user | Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.
Public Property | Crossing_speed |
Public Property | Crosswalk_space |
Public Property | Display_id | Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.
Public Property | End_gain |
Public Property | Exists | Flag indicating whether this pedestrian movement "exists" (not banned) in the current site.
Public Property | Exit_distance | Exit (Downstream) Distance
Public Property | Flow_scale | Flow Scale (Constant)
Public Property | Growth_rate | Growth Rate (%/year)
Public Property | Is_high_priority | High Priority for Green Splits
Public Property | Is_walk_time_extended |
Public Property | Maximum_green_time |
Public Property | Maximum_green_time_user |
Public Property | Minimum_clearance_time |
Public Property | Minimum_green_time |
Public Property | Minimum_green_time_user |
Public Property | Minimum_walk_time |
Public Property | Opposing_ped_factor |
Public Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Public Property | Peak_flow_factor | Peak Flow Factor (%)
Public Property | Practical_degree_of_saturation | Practical degree of saturation
Public Property | Practical_degree_of_saturation_user | Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.
Public Property | Queue_space | Queue Space
Public Property | Saturation_flow_rate | Saturation Flow (ped/h)
Public Property | Site |
Public Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Public Property | Start_loss |
Public Property | Type | The type of a Pedestrian Movement
Public Property | Volume | Pedestrian Volume
Public Property | Walking_speed | Walking Speed (Average)
Top

See Also

Reference

SIAPIMovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuation_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Actuation_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuation_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Actuation_option = value

value = instance.Actuation_option
C#
public int Actuation_option {get; set;}
Managed Extensions for C++
public: __property int get_Actuation_option();
public: __property void set_Actuation_option(
   int value
);
C++/CLI
public:
property int Actuation_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuation_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Actuation_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuation_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Actuation_percent = value

value = instance.Actuation_percent
C#
public float Actuation_percent {get; set;}
Managed Extensions for C++
public: __property float get_Actuation_percent();
public: __property void set_Actuation_percent(
   float value
);
C++/CLI
public:
property float Actuation_percent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Approach_distance Property

Glossary Item Box

Approach Travel Distance

Syntax

Visual Basic (Declaration)
Public Property Approach_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Approach_distance = value

value = instance.Approach_distance
C#
public float Approach_distance {get; set;}
Managed Extensions for C++
public: __property float get_Approach_distance();
public: __property void set_Approach_distance(
   float value
);
C++/CLI
public:
property float Approach_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Clearance_time_overlap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Clearance_time_overlap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Clearance_time_overlap As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Clearance_time_overlap = value

value = instance.Clearance_time_overlap
C#
public int Clearance_time_overlap {get; set;}
Managed Extensions for C++
public: __property int get_Clearance_time_overlap();
public: __property void set_Clearance_time_overlap(
   int value
);
C++/CLI
public:
property int Clearance_time_overlap {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Conflict_zone_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Conflict_zone_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Conflict_zone_length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Conflict_zone_length = value

value = instance.Conflict_zone_length
C#
public float Conflict_zone_length {get; set;}
Managed Extensions for C++
public: __property float get_Conflict_zone_length();
public: __property void set_Conflict_zone_length(
   float value
);
C++/CLI
public:
property float Conflict_zone_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Conflict_zone_length_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Conflict_zone_length_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Conflict_zone_length_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Conflict_zone_length_user = value

value = instance.Conflict_zone_length_user
C#
public bool Conflict_zone_length_user {get; set;}
Managed Extensions for C++
public: __property bool get_Conflict_zone_length_user();
public: __property void set_Conflict_zone_length_user(
   bool value
);
C++/CLI
public:
property bool Conflict_zone_length_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Crossing_distance Property

Glossary Item Box

Crossing Distance

Syntax

Visual Basic (Declaration)
Public Property Crossing_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Crossing_distance = value

value = instance.Crossing_distance
C#
public float Crossing_distance {get; set;}
Managed Extensions for C++
public: __property float get_Crossing_distance();
public: __property void set_Crossing_distance(
   float value
);
C++/CLI
public:
property float Crossing_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Crossing_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Public Property Crossing_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Crossing_distance_user = value

value = instance.Crossing_distance_user
C#
public bool Crossing_distance_user {get; set;}
Managed Extensions for C++
public: __property bool get_Crossing_distance_user();
public: __property void set_Crossing_distance_user(
   bool value
);
C++/CLI
public:
property bool Crossing_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Crossing_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Crossing_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Crossing_speed = value

value = instance.Crossing_speed
C#
public float Crossing_speed {get; set;}
Managed Extensions for C++
public: __property float get_Crossing_speed();
public: __property void set_Crossing_speed(
   float value
);
C++/CLI
public:
property float Crossing_speed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crosswalk_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Crosswalk_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Crosswalk_space As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Crosswalk_space = value

value = instance.Crosswalk_space
C#
public float Crosswalk_space {get; set;}
Managed Extensions for C++
public: __property float get_Crosswalk_space();
public: __property void set_Crosswalk_space(
   float value
);
C++/CLI
public:
property float Crosswalk_space {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Display_id Property

Glossary Item Box

Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.

Syntax

Visual Basic (Declaration)
Public Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
public string Display_id {get; set;}
Managed Extensions for C++
public: __property string* get_Display_id();
public: __property void set_Display_id(
   string* value
);
C++/CLI
public:
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : End_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property End_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.End_gain = value

value = instance.End_gain
C#
public int End_gain {get; set;}
Managed Extensions for C++
public: __property int get_End_gain();
public: __property void set_End_gain(
   int value
);
C++/CLI
public:
property int End_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Exists Property

Glossary Item Box

Flag indicating whether this pedestrian movement "exists" (not banned) in the current site.

Syntax

Visual Basic (Declaration)
Public Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
public bool Exists {get; set;}
Managed Extensions for C++
public: __property bool get_Exists();
public: __property void set_Exists(
   bool value
);
C++/CLI
public:
property bool Exists {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Exit_distance Property

Glossary Item Box

Exit (Downstream) Distance

Syntax

Visual Basic (Declaration)
Public Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
public float Exit_distance {get; set;}
Managed Extensions for C++
public: __property float get_Exit_distance();
public: __property void set_Exit_distance(
   float value
);
C++/CLI
public:
property float Exit_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Flow_scale Property

Glossary Item Box

Flow Scale (Constant)

Syntax

Visual Basic (Declaration)
Public Property Flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Flow_scale = value

value = instance.Flow_scale
C#
public float Flow_scale {get; set;}
Managed Extensions for C++
public: __property float get_Flow_scale();
public: __property void set_Flow_scale(
   float value
);
C++/CLI
public:
property float Flow_scale {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Growth_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Growth_rate Property

Glossary Item Box

Growth Rate (%/year)

Syntax

Visual Basic (Declaration)
Public Property Growth_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Growth_rate = value

value = instance.Growth_rate
C#
public float Growth_rate {get; set;}
Managed Extensions for C++
public: __property float get_Growth_rate();
public: __property void set_Growth_rate(
   float value
);
C++/CLI
public:
property float Growth_rate {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_high_priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Is_high_priority Property

Glossary Item Box

High Priority for Green Splits

Syntax

Visual Basic (Declaration)
Public Property Is_high_priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Is_high_priority = value

value = instance.Is_high_priority
C#
public bool Is_high_priority {get; set;}
Managed Extensions for C++
public: __property bool get_Is_high_priority();
public: __property void set_Is_high_priority(
   bool value
);
C++/CLI
public:
property bool Is_high_priority {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_walk_time_extended Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Is_walk_time_extended Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_walk_time_extended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Is_walk_time_extended = value

value = instance.Is_walk_time_extended
C#
public bool Is_walk_time_extended {get; set;}
Managed Extensions for C++
public: __property bool get_Is_walk_time_extended();
public: __property void set_Is_walk_time_extended(
   bool value
);
C++/CLI
public:
property bool Is_walk_time_extended {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Maximum_green_time = value

value = instance.Maximum_green_time
C#
public int Maximum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Maximum_green_time();
public: __property void set_Maximum_green_time(
   int value
);
C++/CLI
public:
property int Maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Maximum_green_time_user = value

value = instance.Maximum_green_time_user
C#
public bool Maximum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Maximum_green_time_user();
public: __property void set_Maximum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_clearance_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Minimum_clearance_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_clearance_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Minimum_clearance_time = value

value = instance.Minimum_clearance_time
C#
public int Minimum_clearance_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_clearance_time();
public: __property void set_Minimum_clearance_time(
   int value
);
C++/CLI
public:
property int Minimum_clearance_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Minimum_green_time = value

value = instance.Minimum_green_time
C#
public int Minimum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_green_time();
public: __property void set_Minimum_green_time(
   int value
);
C++/CLI
public:
property int Minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Minimum_green_time_user = value

value = instance.Minimum_green_time_user
C#
public bool Minimum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Minimum_green_time_user();
public: __property void set_Minimum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Minimum_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Minimum_walk_time = value

value = instance.Minimum_walk_time
C#
public int Minimum_walk_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_walk_time();
public: __property void set_Minimum_walk_time(
   int value
);
C++/CLI
public:
property int Minimum_walk_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Opposing_ped_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Opposing_ped_factor = value

value = instance.Opposing_ped_factor
C#
public float Opposing_ped_factor {get; set;}
Managed Extensions for C++
public: __property float get_Opposing_ped_factor();
public: __property void set_Opposing_ped_factor(
   float value
);
C++/CLI
public:
property float Opposing_ped_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Origin Property

Glossary Item Box

Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peak_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Peak_flow_factor Property

Glossary Item Box

Peak Flow Factor (%)

Syntax

Visual Basic (Declaration)
Public Property Peak_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Peak_flow_factor = value

value = instance.Peak_flow_factor
C#
public float Peak_flow_factor {get; set;}
Managed Extensions for C++
public: __property float get_Peak_flow_factor();
public: __property void set_Peak_flow_factor(
   float value
);
C++/CLI
public:
property float Peak_flow_factor {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Practical_degree_of_saturation Property

Glossary Item Box

Practical degree of saturation

Syntax

Visual Basic (Declaration)
Public Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Practical_degree_of_saturation = value

value = instance.Practical_degree_of_saturation
C#
public float Practical_degree_of_saturation {get; set;}
Managed Extensions for C++
public: __property float get_Practical_degree_of_saturation();
public: __property void set_Practical_degree_of_saturation(
   float value
);
C++/CLI
public:
property float Practical_degree_of_saturation {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Practical_degree_of_saturation_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Public Property Practical_degree_of_saturation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Boolean

instance.Practical_degree_of_saturation_user = value

value = instance.Practical_degree_of_saturation_user
C#
public bool Practical_degree_of_saturation_user {get; set;}
Managed Extensions for C++
public: __property bool get_Practical_degree_of_saturation_user();
public: __property void set_Practical_degree_of_saturation_user(
   bool value
);
C++/CLI
public:
property bool Practical_degree_of_saturation_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Queue_space Property

Glossary Item Box

Queue Space

Syntax

Visual Basic (Declaration)
Public Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Queue_space = value

value = instance.Queue_space
C#
public float Queue_space {get; set;}
Managed Extensions for C++
public: __property float get_Queue_space();
public: __property void set_Queue_space(
   float value
);
C++/CLI
public:
property float Queue_space {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_flow_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Saturation_flow_rate Property

Glossary Item Box

Saturation Flow (ped/h)

Syntax

Visual Basic (Declaration)
Public Property Saturation_flow_rate As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Saturation_flow_rate = value

value = instance.Saturation_flow_rate
C#
public int Saturation_flow_rate {get; set;}
Managed Extensions for C++
public: __property int get_Saturation_flow_rate();
public: __property void set_Saturation_flow_rate(
   int value
);
C++/CLI
public:
property int Saturation_flow_rate {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Stage Property

Glossary Item Box

Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

value = instance.Stage
C#
public int Stage {get;}
Managed Extensions for C++
public: __property int get_Stage();
C++/CLI
public:
property int Stage {
   int get();
}

Property Value

Type: System.Int32;

1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

instance.Start_loss = value

value = instance.Start_loss
C#
public int Start_loss {get; set;}
Managed Extensions for C++
public: __property int get_Start_loss();
public: __property void set_Start_loss(
   int value
);
C++/CLI
public:
property int Start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Type Property

Glossary Item Box

The type of a Pedestrian Movement

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Integer

value = instance.Type
C#
public int Type {get;}
Managed Extensions for C++
public: __property int get_Type();
C++/CLI
public:
property int Type {
   int get();
}

Property Value

Type: System.Int32;

1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Volume Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Volume Property

Glossary Item Box

Pedestrian Volume

Syntax

Visual Basic (Declaration)
Public Property Volume As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Volume = value

value = instance.Volume
C#
public float Volume {get; set;}
Managed Extensions for C++
public: __property float get_Volume();
public: __property void set_Volume(
   float value
);
C++/CLI
public:
property float Volume {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Walking_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_ped Class : Walking_speed Property

Glossary Item Box

Walking Speed (Average)

Syntax

Visual Basic (Declaration)
Public Property Walking_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_ped
Dim value As Single

instance.Walking_speed = value

value = instance.Walking_speed
C#
public float Walking_speed {get; set;}
Managed Extensions for C++
public: __property float get_Walking_speed();
public: __property void set_Walking_speed(
   float value
);
C++/CLI
public:
property float Walking_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_ped Class
SIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_peds Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_peds Class

Glossary Item Box

SIAPIMovement_ped collection

Object Model

SIAPIMovement_peds ClassISIAPIMovement_ped Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_peds
   Implements ISIAPIMovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_peds
C#
public sealed class SIAPIMovement_peds : ISIAPIMovement_peds
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_peds : public ISIAPIMovement_peds
C++/CLI
public ref class SIAPIMovement_peds sealed : public ISIAPIMovement_peds

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_peds Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_peds Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_peds.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_peds Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

SIAPIMovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_peds Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_peds Class : SIAPIMovement_peds Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_peds()
C#
public SIAPIMovement_peds()
Managed Extensions for C++
public: SIAPIMovement_peds();
C++/CLI
public:
SIAPIMovement_peds();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Class
SIAPIMovement_peds Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_peds Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_peds members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

SIAPIMovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_peds Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_peds
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Class
SIAPIMovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_peds Class : MovementExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Pedestrian Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.MovementExists(type, origin, stage)
C#
public bool MovementExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
public: bool MovementExists(
   int type,
   int origin,
   int stage
)
C++/CLI
public:
bool MovementExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Class
SIAPIMovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_peds Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_peds members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement.
Top

See Also

Reference

SIAPIMovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_peds Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_peds
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Class
SIAPIMovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_peds Class : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Pedestrian Movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIMovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIMovement_ped

value = instance.Item(type, origin, stage)
C#
public ISIAPIMovement_ped this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_ped* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
public:
property ISIAPIMovement_ped^ default [int,int,int] {
   ISIAPIMovement_ped^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Property Value

Return a Pedestrian Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_peds Class
SIAPIMovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od Class

Glossary Item Box

SIDRA INTERSECTION Vehicle OD Movement wrapper class

Object Model

SIAPIMovement_vehicle_od ClassISIAPIMovement_vehicle_od_mcs InterfaceISIAPIMovement_vehicle_od_mc InterfaceISIAPIOpposingmovement_peds InterfaceISIAPIOpposingmovement_ped InterfaceISIAPIOpposingmovement_vehicles InterfaceISIAPIOpposingmovement_vehicle InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_vehicle_od
   Implements ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
C#
public sealed class SIAPIMovement_vehicle_od : ISIAPIMovement_vehicle_od
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_vehicle_od : public ISIAPIMovement_vehicle_od
C++/CLI
public ref class SIAPIMovement_vehicle_od sealed : public ISIAPIMovement_vehicle_od

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_vehicle_od.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_vehicle_od Constructor |
Top

Public Properties

 | Name | Description
Public Property | Critical_gap |
Public Property | Destination | Movement Destination Leg
Public Property | Display_ltr_id |
Public Property | Display_od_id |
Public Property | End_departures |
Public Property | Exists | Flag indicating whether this OD movement "exists" (not banned) in the current site. The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.
Public Property | Exit_flow_effect |
Public Property | Followup_headway |
Public Property | Is_gap_acceptance_usergiven |
Public Property | Is_TWSC_adj_applied |
Public Property | IsPossible | Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.
Public Property | Minimum_departures |
Public Property | MovementVehicleODMCs |
Public Property | ODMovDesignation | OD Movement Designation
Public Property | Opposing_ped_effect_option | Opposing Pedestrian Effect Option
Public Property | Opposing_ped_effect_option_signals | Opposing Pedestrian Effect Option (Signalised)
Public Property | Opposing_ped_effect_start_loss |
Public Property | Opposing_ped_sliplane_critical_gap |
Public Property | Opposing_ped_sliplane_followup_headway |
Public Property | Opposing_ped_sliplane_gap_acceptance_option | Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)
Public Property | Opposing_ped_sliplane_minimum_departures |
Public Property | Opposingmovement_peds |
Public Property | Opposingmovement_vehicles |
Public Property | Origin | Movement Origin Leg
Public Property | Percent_opposed_by_nearest |
Public Property | Site |
Public Property | Turndesignation | Movement turn designation
Top

See Also

Reference

SIAPIMovement_vehicle_od Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : SIAPIMovement_vehicle_od Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_vehicle_od()
C#
public SIAPIMovement_vehicle_od()
Managed Extensions for C++
public: SIAPIMovement_vehicle_od();
C++/CLI
public:
SIAPIMovement_vehicle_od();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_od members.

Public Properties

 | Name | Description
Public Property | Critical_gap |
Public Property | Destination | Movement Destination Leg
Public Property | Display_ltr_id |
Public Property | Display_od_id |
Public Property | End_departures |
Public Property | Exists | Flag indicating whether this OD movement "exists" (not banned) in the current site. The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.
Public Property | Exit_flow_effect |
Public Property | Followup_headway |
Public Property | Is_gap_acceptance_usergiven |
Public Property | Is_TWSC_adj_applied |
Public Property | IsPossible | Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.
Public Property | Minimum_departures |
Public Property | MovementVehicleODMCs |
Public Property | ODMovDesignation | OD Movement Designation
Public Property | Opposing_ped_effect_option | Opposing Pedestrian Effect Option
Public Property | Opposing_ped_effect_option_signals | Opposing Pedestrian Effect Option (Signalised)
Public Property | Opposing_ped_effect_start_loss |
Public Property | Opposing_ped_sliplane_critical_gap |
Public Property | Opposing_ped_sliplane_followup_headway |
Public Property | Opposing_ped_sliplane_gap_acceptance_option | Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)
Public Property | Opposing_ped_sliplane_minimum_departures |
Public Property | Opposingmovement_peds |
Public Property | Opposingmovement_vehicles |
Public Property | Origin | Movement Origin Leg
Public Property | Percent_opposed_by_nearest |
Public Property | Site |
Public Property | Turndesignation | Movement turn designation
Top

See Also

Reference

SIAPIMovement_vehicle_od Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Critical_gap = value

value = instance.Critical_gap
C#
public float Critical_gap {get; set;}
Managed Extensions for C++
public: __property float get_Critical_gap();
public: __property void set_Critical_gap(
   float value
);
C++/CLI
public:
property float Critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_ltr_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Display_ltr_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Display_ltr_id As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As String

instance.Display_ltr_id = value

value = instance.Display_ltr_id
C#
public string Display_ltr_id {get; set;}
Managed Extensions for C++
public: __property string* get_Display_ltr_id();
public: __property void set_Display_ltr_id(
   string* value
);
C++/CLI
public:
property String^ Display_ltr_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_od_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Display_od_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Display_od_id As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As String

instance.Display_od_id = value

value = instance.Display_od_id
C#
public string Display_od_id {get; set;}
Managed Extensions for C++
public: __property string* get_Display_od_id();
public: __property void set_Display_od_id(
   string* value
);
C++/CLI
public:
property String^ Display_od_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : End_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property End_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.End_departures = value

value = instance.End_departures
C#
public float End_departures {get; set;}
Managed Extensions for C++
public: __property float get_End_departures();
public: __property void set_End_departures(
   float value
);
C++/CLI
public:
property float End_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Exists Property

Glossary Item Box

Flag indicating whether this OD movement "exists" (not banned) in the current site.

The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.

Syntax

Visual Basic (Declaration)
Public Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
public bool Exists {get; set;}
Managed Extensions for C++
public: __property bool get_Exists();
public: __property void set_Exists(
   bool value
);
C++/CLI
public:
property bool Exists {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_flow_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Exit_flow_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Exit_flow_effect As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Exit_flow_effect = value

value = instance.Exit_flow_effect
C#
public float Exit_flow_effect {get; set;}
Managed Extensions for C++
public: __property float get_Exit_flow_effect();
public: __property void set_Exit_flow_effect(
   float value
);
C++/CLI
public:
property float Exit_flow_effect {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Followup_headway = value

value = instance.Followup_headway
C#
public float Followup_headway {get; set;}
Managed Extensions for C++
public: __property float get_Followup_headway();
public: __property void set_Followup_headway(
   float value
);
C++/CLI
public:
property float Followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_gap_acceptance_usergiven Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Is_gap_acceptance_usergiven Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_gap_acceptance_usergiven As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Boolean

instance.Is_gap_acceptance_usergiven = value

value = instance.Is_gap_acceptance_usergiven
C#
public bool Is_gap_acceptance_usergiven {get; set;}
Managed Extensions for C++
public: __property bool get_Is_gap_acceptance_usergiven();
public: __property void set_Is_gap_acceptance_usergiven(
   bool value
);
C++/CLI
public:
property bool Is_gap_acceptance_usergiven {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_TWSC_adj_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Is_TWSC_adj_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_TWSC_adj_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Boolean

instance.Is_TWSC_adj_applied = value

value = instance.Is_TWSC_adj_applied
C#
public bool Is_TWSC_adj_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_TWSC_adj_applied();
public: __property void set_Is_TWSC_adj_applied(
   bool value
);
C++/CLI
public:
property bool Is_TWSC_adj_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsPossible Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : IsPossible Property

Glossary Item Box

Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsPossible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Boolean

value = instance.IsPossible
C#
public bool IsPossible {get;}
Managed Extensions for C++
public: __property bool get_IsPossible();
C++/CLI
public:
property bool IsPossible {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Minimum_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Minimum_departures = value

value = instance.Minimum_departures
C#
public float Minimum_departures {get; set;}
Managed Extensions for C++
public: __property float get_Minimum_departures();
public: __property void set_Minimum_departures(
   float value
);
C++/CLI
public:
property float Minimum_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementVehicleODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : MovementVehicleODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementVehicleODMCs As ISIAPIMovement_vehicle_od_mcs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As ISIAPIMovement_vehicle_od_mcs

value = instance.MovementVehicleODMCs
C#
public ISIAPIMovement_vehicle_od_mcs MovementVehicleODMCs {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od_mcs* get_MovementVehicleODMCs();
C++/CLI
public:
property ISIAPIMovement_vehicle_od_mcs^ MovementVehicleODMCs {
   ISIAPIMovement_vehicle_od_mcs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ODMovDesignation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : ODMovDesignation Property

Glossary Item Box

OD Movement Designation

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ODMovDesignation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

value = instance.ODMovDesignation
C#
public int ODMovDesignation {get;}
Managed Extensions for C++
public: __property int get_ODMovDesignation();
C++/CLI
public:
property int ODMovDesignation {
   int get();
}

Property Value

Type: System.Int32;

0 = U,
1 = L3,
2 = L2,
3 = L1,
4 = T1,
5 = R1,
6 = R2,
7 = R3.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_effect_option Property

Glossary Item Box

Opposing Pedestrian Effect Option

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_option = value

value = instance.Opposing_ped_effect_option
C#
public int Opposing_ped_effect_option {get; set;}
Managed Extensions for C++
public: __property int get_Opposing_ped_effect_option();
public: __property void set_Opposing_ped_effect_option(
   int value
);
C++/CLI
public:
property int Opposing_ped_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Program (Flow).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_option_signals Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_effect_option_signals Property

Glossary Item Box

Opposing Pedestrian Effect Option (Signalised)

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_effect_option_signals As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_option_signals = value

value = instance.Opposing_ped_effect_option_signals
C#
public int Opposing_ped_effect_option_signals {get; set;}
Managed Extensions for C++
public: __property int get_Opposing_ped_effect_option_signals();
public: __property void set_Opposing_ped_effect_option_signals(
   int value
);
C++/CLI
public:
property int Opposing_ped_effect_option_signals {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
4 = Start Loss (Program),
5 = Saturation Flow Adjustment,
6 = Start Loss (Input).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_effect_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_effect_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_start_loss = value

value = instance.Opposing_ped_effect_start_loss
C#
public int Opposing_ped_effect_start_loss {get; set;}
Managed Extensions for C++
public: __property int get_Opposing_ped_effect_start_loss();
public: __property void set_Opposing_ped_effect_start_loss(
   int value
);
C++/CLI
public:
property int Opposing_ped_effect_start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_sliplane_critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_sliplane_critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_critical_gap = value

value = instance.Opposing_ped_sliplane_critical_gap
C#
public float Opposing_ped_sliplane_critical_gap {get; set;}
Managed Extensions for C++
public: __property float get_Opposing_ped_sliplane_critical_gap();
public: __property void set_Opposing_ped_sliplane_critical_gap(
   float value
);
C++/CLI
public:
property float Opposing_ped_sliplane_critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_sliplane_followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_sliplane_followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_followup_headway = value

value = instance.Opposing_ped_sliplane_followup_headway
C#
public float Opposing_ped_sliplane_followup_headway {get; set;}
Managed Extensions for C++
public: __property float get_Opposing_ped_sliplane_followup_headway();
public: __property void set_Opposing_ped_sliplane_followup_headway(
   float value
);
C++/CLI
public:
property float Opposing_ped_sliplane_followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_gap_acceptance_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_sliplane_gap_acceptance_option Property

Glossary Item Box

Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_sliplane_gap_acceptance_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_sliplane_gap_acceptance_option = value

value = instance.Opposing_ped_sliplane_gap_acceptance_option
C#
public int Opposing_ped_sliplane_gap_acceptance_option {get; set;}
Managed Extensions for C++
public: __property int get_Opposing_ped_sliplane_gap_acceptance_option();
public: __property void set_Opposing_ped_sliplane_gap_acceptance_option(
   int value
);
C++/CLI
public:
property int Opposing_ped_sliplane_gap_acceptance_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Program,
2 = User Input.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_minimum_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposing_ped_sliplane_minimum_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_ped_sliplane_minimum_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_minimum_departures = value

value = instance.Opposing_ped_sliplane_minimum_departures
C#
public float Opposing_ped_sliplane_minimum_departures {get; set;}
Managed Extensions for C++
public: __property float get_Opposing_ped_sliplane_minimum_departures();
public: __property void set_Opposing_ped_sliplane_minimum_departures(
   float value
);
C++/CLI
public:
property float Opposing_ped_sliplane_minimum_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_peds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposingmovement_peds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_peds As ISIAPIOpposingmovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As ISIAPIOpposingmovement_peds

value = instance.Opposingmovement_peds
C#
public ISIAPIOpposingmovement_peds Opposingmovement_peds {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_peds* get_Opposingmovement_peds();
C++/CLI
public:
property ISIAPIOpposingmovement_peds^ Opposingmovement_peds {
   ISIAPIOpposingmovement_peds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicles Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Opposingmovement_vehicles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_vehicles As ISIAPIOpposingmovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As ISIAPIOpposingmovement_vehicles

value = instance.Opposingmovement_vehicles
C#
public ISIAPIOpposingmovement_vehicles Opposingmovement_vehicles {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_vehicles* get_Opposingmovement_vehicles();
C++/CLI
public:
property ISIAPIOpposingmovement_vehicles^ Opposingmovement_vehicles {
   ISIAPIOpposingmovement_vehicles^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_opposed_by_nearest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Percent_opposed_by_nearest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Percent_opposed_by_nearest As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Single

instance.Percent_opposed_by_nearest = value

value = instance.Percent_opposed_by_nearest
C#
public float Percent_opposed_by_nearest {get; set;}
Managed Extensions for C++
public: __property float get_Percent_opposed_by_nearest();
public: __property void set_Percent_opposed_by_nearest(
   float value
);
C++/CLI
public:
property float Percent_opposed_by_nearest {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turndesignation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od Class : Turndesignation Property

Glossary Item Box

Movement turn designation

Syntax

Visual Basic (Declaration)
Public Property Turndesignation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od
Dim value As Integer

instance.Turndesignation = value

value = instance.Turndesignation
C#
public int Turndesignation {get; set;}
Managed Extensions for C++
public: __property int get_Turndesignation();
public: __property void set_Turndesignation(
   int value
);
C++/CLI
public:
property int Turndesignation {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Left,
2 = Through,
3 = Right.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od Class
SIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mc Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mc Class

Glossary Item Box

SIDRA INTERSECTION Vehicle OD Movement (per Movement Class) wrapper class

Object Model

SIAPIMovement_vehicle_od_mc ClassISIAPIMovement_vehicle_od Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_vehicle_od_mc
   Implements ISIAPIMovement_vehicle_od_mc
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
C#
public sealed class SIAPIMovement_vehicle_od_mc : ISIAPIMovement_vehicle_od_mc
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_vehicle_od_mc : public ISIAPIMovement_vehicle_od_mc
C++/CLI
public ref class SIAPIMovement_vehicle_od_mc sealed : public ISIAPIMovement_vehicle_od_mc

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od_mc

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mc Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mc Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_vehicle_od_mc.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_vehicle_od_mc Constructor |
Top

Public Properties

 | Name | Description
Public Property | Approach_speed | Approach Cruise Speed
Public Property | Arrival_percentage |
Public Property | Arrival_type | Arrival Type
Public Property | Coordination_type | Signal Coordination
Public Property | Early_cutoff |
Public Property | End_gain |
Public Property | Exists | Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.
Public Property | Exit_distance | User given Exit distance (Downstream Distance). This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Exit_distance_user | Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.
Public Property | Exit_speed | Exit Cruise Speed
Public Property | Flow_scale | Flow Scale (Constant) (%)
Public Property | Gap_acceptance_factor |
Public Property | Growth_rate | Growth rate (%/year)
Public Property | Is_early_cutoff |
Public Property | Is_high_priority | High Priority for Green Splits
Public Property | Is_late_release |
Public Property | Late_release |
Public Property | Maximum_green_time |
Public Property | Maximum_green_time_user |
Public Property | MC_class | Movement Class Number
Public Property | Minimum_green_time |
Public Property | Minimum_green_time_user |
Public Property | Movement_vehicle_od |
Public Property | Negotiation_distance | User given Negotiation distance. This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_distance_user | Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.
Public Property | Negotiation_radius | User given Negotiation radius. This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_radius_option | User given Negotiation Radius option.
Public Property | Negotiation_speed | User given Negotiation speed. This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_speed_user | Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.
Public Property | Non_actuated |
Public Property | Occupancy | Vehicle Occupancy (persons/veh)
Public Property | Opposing_veh_factor |
Public Property | Peak_flow_factor | Peak Flow Factor (%)
Public Property | Phase_actuation_option |
Public Property | Phase_actuation_percent |
Public Property | Practical_degree_of_saturation |
Public Property | Practical_degree_of_saturation_user |
Public Property | Queue_space |
Public Property | Start_loss |
Public Property | Stopline_travel_time |
Public Property | Stopline_travel_time_user |
Public Property | Turn_on_red |
Public Property | Turn_radius |
Public Property | Turn_veh_effect_option | Turning Vehicle Effect
Public Property | Turning_veh_factor |
Public Property | Vehicle_length |
Public Property | Volume | Volume (veh)
Top

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mc Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : SIAPIMovement_vehicle_od_mc Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_vehicle_od_mc()
C#
public SIAPIMovement_vehicle_od_mc()
Managed Extensions for C++
public: SIAPIMovement_vehicle_od_mc();
C++/CLI
public:
SIAPIMovement_vehicle_od_mc();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mc Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mc Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_od_mc members.

Public Properties

 | Name | Description
Public Property | Approach_speed | Approach Cruise Speed
Public Property | Arrival_percentage |
Public Property | Arrival_type | Arrival Type
Public Property | Coordination_type | Signal Coordination
Public Property | Early_cutoff |
Public Property | End_gain |
Public Property | Exists | Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.
Public Property | Exit_distance | User given Exit distance (Downstream Distance). This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Exit_distance_user | Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.
Public Property | Exit_speed | Exit Cruise Speed
Public Property | Flow_scale | Flow Scale (Constant) (%)
Public Property | Gap_acceptance_factor |
Public Property | Growth_rate | Growth rate (%/year)
Public Property | Is_early_cutoff |
Public Property | Is_high_priority | High Priority for Green Splits
Public Property | Is_late_release |
Public Property | Late_release |
Public Property | Maximum_green_time |
Public Property | Maximum_green_time_user |
Public Property | MC_class | Movement Class Number
Public Property | Minimum_green_time |
Public Property | Minimum_green_time_user |
Public Property | Movement_vehicle_od |
Public Property | Negotiation_distance | User given Negotiation distance. This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_distance_user | Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.
Public Property | Negotiation_radius | User given Negotiation radius. This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_radius_option | User given Negotiation Radius option.
Public Property | Negotiation_speed | User given Negotiation speed. This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Public Property | Negotiation_speed_user | Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.
Public Property | Non_actuated |
Public Property | Occupancy | Vehicle Occupancy (persons/veh)
Public Property | Opposing_veh_factor |
Public Property | Peak_flow_factor | Peak Flow Factor (%)
Public Property | Phase_actuation_option |
Public Property | Phase_actuation_percent |
Public Property | Practical_degree_of_saturation |
Public Property | Practical_degree_of_saturation_user |
Public Property | Queue_space |
Public Property | Start_loss |
Public Property | Stopline_travel_time |
Public Property | Stopline_travel_time_user |
Public Property | Turn_on_red |
Public Property | Turn_radius |
Public Property | Turn_veh_effect_option | Turning Vehicle Effect
Public Property | Turning_veh_factor |
Public Property | Vehicle_length |
Public Property | Volume | Volume (veh)
Top

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Approach_speed Property

Glossary Item Box

Approach Cruise Speed

Syntax

Visual Basic (Declaration)
Public Property Approach_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Approach_speed = value

value = instance.Approach_speed
C#
public float Approach_speed {get; set;}
Managed Extensions for C++
public: __property float get_Approach_speed();
public: __property void set_Approach_speed(
   float value
);
C++/CLI
public:
property float Approach_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_percentage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Arrival_percentage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Arrival_percentage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Arrival_percentage = value

value = instance.Arrival_percentage
C#
public float Arrival_percentage {get; set;}
Managed Extensions for C++
public: __property float get_Arrival_percentage();
public: __property void set_Arrival_percentage(
   float value
);
C++/CLI
public:
property float Arrival_percentage {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Arrival_type Property

Glossary Item Box

Arrival Type

Syntax

Visual Basic (Declaration)
Public Property Arrival_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Arrival_type = value

value = instance.Arrival_type
C#
public int Arrival_type {get; set;}
Managed Extensions for C++
public: __property int get_Arrival_type();
public: __property void set_Arrival_type(
   int value
);
C++/CLI
public:
property int Arrival_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Very Poor,
2 = Non-favourable,
3 = Isolated (not coord),
4 = Favourable,
5 = Highly Favourable,
6 = Exceptional.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coordination_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Coordination_type Property

Glossary Item Box

Signal Coordination

Syntax

Visual Basic (Declaration)
Public Property Coordination_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Coordination_type = value

value = instance.Coordination_type
C#
public int Coordination_type {get; set;}
Managed Extensions for C++
public: __property int get_Coordination_type();
public: __property void set_Coordination_type(
   int value
);
C++/CLI
public:
property int Coordination_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Arrival Type,
2 = Arrivals % During Green,
3 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Early_cutoff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Early_cutoff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Early_cutoff As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Early_cutoff = value

value = instance.Early_cutoff
C#
public float Early_cutoff {get; set;}
Managed Extensions for C++
public: __property float get_Early_cutoff();
public: __property void set_Early_cutoff(
   float value
);
C++/CLI
public:
property float Early_cutoff {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : End_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property End_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.End_gain = value

value = instance.End_gain
C#
public int End_gain {get; set;}
Managed Extensions for C++
public: __property int get_End_gain();
public: __property void set_End_gain(
   int value
);
C++/CLI
public:
property int End_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Exists Property

Glossary Item Box

Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

value = instance.Exists
C#
public bool Exists {get;}
Managed Extensions for C++
public: __property bool get_Exists();
C++/CLI
public:
property bool Exists {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Exit_distance Property

Glossary Item Box

User given Exit distance (Downstream Distance).

This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Public Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
public float Exit_distance {get; set;}
Managed Extensions for C++
public: __property float get_Exit_distance();
public: __property void set_Exit_distance(
   float value
);
C++/CLI
public:
property float Exit_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Exit_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Public Property Exit_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Exit_distance_user = value

value = instance.Exit_distance_user
C#
public bool Exit_distance_user {get; set;}
Managed Extensions for C++
public: __property bool get_Exit_distance_user();
public: __property void set_Exit_distance_user(
   bool value
);
C++/CLI
public:
property bool Exit_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Exit_speed Property

Glossary Item Box

Exit Cruise Speed

Syntax

Visual Basic (Declaration)
Public Property Exit_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Exit_speed = value

value = instance.Exit_speed
C#
public float Exit_speed {get; set;}
Managed Extensions for C++
public: __property float get_Exit_speed();
public: __property void set_Exit_speed(
   float value
);
C++/CLI
public:
property float Exit_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Flow_scale Property

Glossary Item Box

Flow Scale (Constant) (%)

Syntax

Visual Basic (Declaration)
Public Property Flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Flow_scale = value

value = instance.Flow_scale
C#
public float Flow_scale {get; set;}
Managed Extensions for C++
public: __property float get_Flow_scale();
public: __property void set_Flow_scale(
   float value
);
C++/CLI
public:
property float Flow_scale {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_acceptance_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Gap_acceptance_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Gap_acceptance_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Gap_acceptance_factor = value

value = instance.Gap_acceptance_factor
C#
public float Gap_acceptance_factor {get; set;}
Managed Extensions for C++
public: __property float get_Gap_acceptance_factor();
public: __property void set_Gap_acceptance_factor(
   float value
);
C++/CLI
public:
property float Gap_acceptance_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Growth_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Growth_rate Property

Glossary Item Box

Growth rate (%/year)

Syntax

Visual Basic (Declaration)
Public Property Growth_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Growth_rate = value

value = instance.Growth_rate
C#
public float Growth_rate {get; set;}
Managed Extensions for C++
public: __property float get_Growth_rate();
public: __property void set_Growth_rate(
   float value
);
C++/CLI
public:
property float Growth_rate {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_early_cutoff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Is_early_cutoff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_early_cutoff As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_early_cutoff = value

value = instance.Is_early_cutoff
C#
public bool Is_early_cutoff {get; set;}
Managed Extensions for C++
public: __property bool get_Is_early_cutoff();
public: __property void set_Is_early_cutoff(
   bool value
);
C++/CLI
public:
property bool Is_early_cutoff {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_high_priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Is_high_priority Property

Glossary Item Box

High Priority for Green Splits

Syntax

Visual Basic (Declaration)
Public Property Is_high_priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_high_priority = value

value = instance.Is_high_priority
C#
public bool Is_high_priority {get; set;}
Managed Extensions for C++
public: __property bool get_Is_high_priority();
public: __property void set_Is_high_priority(
   bool value
);
C++/CLI
public:
property bool Is_high_priority {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_late_release Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Is_late_release Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_late_release As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_late_release = value

value = instance.Is_late_release
C#
public bool Is_late_release {get; set;}
Managed Extensions for C++
public: __property bool get_Is_late_release();
public: __property void set_Is_late_release(
   bool value
);
C++/CLI
public:
property bool Is_late_release {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Late_release Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Late_release Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Late_release As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Late_release = value

value = instance.Late_release
C#
public float Late_release {get; set;}
Managed Extensions for C++
public: __property float get_Late_release();
public: __property void set_Late_release(
   float value
);
C++/CLI
public:
property float Late_release {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Maximum_green_time = value

value = instance.Maximum_green_time
C#
public int Maximum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Maximum_green_time();
public: __property void set_Maximum_green_time(
   int value
);
C++/CLI
public:
property int Maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Maximum_green_time_user = value

value = instance.Maximum_green_time_user
C#
public bool Maximum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Maximum_green_time_user();
public: __property void set_Maximum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Minimum_green_time = value

value = instance.Minimum_green_time
C#
public int Minimum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_green_time();
public: __property void set_Minimum_green_time(
   int value
);
C++/CLI
public:
property int Minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Minimum_green_time_user = value

value = instance.Minimum_green_time_user
C#
public bool Minimum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Minimum_green_time_user();
public: __property void set_Minimum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
public ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
public:
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_distance Property

Glossary Item Box

User given Negotiation distance.

This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_distance = value

value = instance.Negotiation_distance
C#
public float Negotiation_distance {get; set;}
Managed Extensions for C++
public: __property float get_Negotiation_distance();
public: __property void set_Negotiation_distance(
   float value
);
C++/CLI
public:
property float Negotiation_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Negotiation_distance_user = value

value = instance.Negotiation_distance_user
C#
public bool Negotiation_distance_user {get; set;}
Managed Extensions for C++
public: __property bool get_Negotiation_distance_user();
public: __property void set_Negotiation_distance_user(
   bool value
);
C++/CLI
public:
property bool Negotiation_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_radius Property

Glossary Item Box

User given Negotiation radius.
This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_radius = value

value = instance.Negotiation_radius
C#
public float Negotiation_radius {get; set;}
Managed Extensions for C++
public: __property float get_Negotiation_radius();
public: __property void set_Negotiation_radius(
   float value
);
C++/CLI
public:
property float Negotiation_radius {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_radius_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_radius_option Property

Glossary Item Box

User given Negotiation Radius option.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_radius_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Negotiation_radius_option = value

value = instance.Negotiation_radius_option
C#
public int Negotiation_radius_option {get; set;}
Managed Extensions for C++
public: __property int get_Negotiation_radius_option();
public: __property void set_Negotiation_radius_option(
   int value
);
C++/CLI
public:
property int Negotiation_radius_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Program,
2 = Radius,
3 = Straight.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_speed Property

Glossary Item Box

User given Negotiation speed.

This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_speed = value

value = instance.Negotiation_speed
C#
public float Negotiation_speed {get; set;}
Managed Extensions for C++
public: __property float get_Negotiation_speed();
public: __property void set_Negotiation_speed(
   float value
);
C++/CLI
public:
property float Negotiation_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_speed_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Negotiation_speed_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Public Property Negotiation_speed_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Negotiation_speed_user = value

value = instance.Negotiation_speed_user
C#
public bool Negotiation_speed_user {get; set;}
Managed Extensions for C++
public: __property bool get_Negotiation_speed_user();
public: __property void set_Negotiation_speed_user(
   bool value
);
C++/CLI
public:
property bool Negotiation_speed_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Non_actuated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Non_actuated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Non_actuated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Non_actuated = value

value = instance.Non_actuated
C#
public bool Non_actuated {get; set;}
Managed Extensions for C++
public: __property bool get_Non_actuated();
public: __property void set_Non_actuated(
   bool value
);
C++/CLI
public:
property bool Non_actuated {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Occupancy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Occupancy Property

Glossary Item Box

Vehicle Occupancy (persons/veh)

Syntax

Visual Basic (Declaration)
Public Property Occupancy As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Occupancy = value

value = instance.Occupancy
C#
public float Occupancy {get; set;}
Managed Extensions for C++
public: __property float get_Occupancy();
public: __property void set_Occupancy(
   float value
);
C++/CLI
public:
property float Occupancy {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_veh_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Opposing_veh_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing_veh_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Opposing_veh_factor = value

value = instance.Opposing_veh_factor
C#
public float Opposing_veh_factor {get; set;}
Managed Extensions for C++
public: __property float get_Opposing_veh_factor();
public: __property void set_Opposing_veh_factor(
   float value
);
C++/CLI
public:
property float Opposing_veh_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peak_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Peak_flow_factor Property

Glossary Item Box

Peak Flow Factor (%)

Syntax

Visual Basic (Declaration)
Public Property Peak_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Peak_flow_factor = value

value = instance.Peak_flow_factor
C#
public float Peak_flow_factor {get; set;}
Managed Extensions for C++
public: __property float get_Peak_flow_factor();
public: __property void set_Peak_flow_factor(
   float value
);
C++/CLI
public:
property float Peak_flow_factor {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_actuation_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Phase_actuation_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_actuation_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Phase_actuation_option = value

value = instance.Phase_actuation_option
C#
public int Phase_actuation_option {get; set;}
Managed Extensions for C++
public: __property int get_Phase_actuation_option();
public: __property void set_Phase_actuation_option(
   int value
);
C++/CLI
public:
property int Phase_actuation_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_actuation_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Phase_actuation_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_actuation_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Phase_actuation_percent = value

value = instance.Phase_actuation_percent
C#
public float Phase_actuation_percent {get; set;}
Managed Extensions for C++
public: __property float get_Phase_actuation_percent();
public: __property void set_Phase_actuation_percent(
   float value
);
C++/CLI
public:
property float Phase_actuation_percent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Practical_degree_of_saturation = value

value = instance.Practical_degree_of_saturation
C#
public float Practical_degree_of_saturation {get; set;}
Managed Extensions for C++
public: __property float get_Practical_degree_of_saturation();
public: __property void set_Practical_degree_of_saturation(
   float value
);
C++/CLI
public:
property float Practical_degree_of_saturation {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Practical_degree_of_saturation_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_degree_of_saturation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Practical_degree_of_saturation_user = value

value = instance.Practical_degree_of_saturation_user
C#
public bool Practical_degree_of_saturation_user {get; set;}
Managed Extensions for C++
public: __property bool get_Practical_degree_of_saturation_user();
public: __property void set_Practical_degree_of_saturation_user(
   bool value
);
C++/CLI
public:
property bool Practical_degree_of_saturation_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Queue_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Queue_space = value

value = instance.Queue_space
C#
public float Queue_space {get; set;}
Managed Extensions for C++
public: __property float get_Queue_space();
public: __property void set_Queue_space(
   float value
);
C++/CLI
public:
property float Queue_space {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Start_loss = value

value = instance.Start_loss
C#
public int Start_loss {get; set;}
Managed Extensions for C++
public: __property int get_Start_loss();
public: __property void set_Start_loss(
   int value
);
C++/CLI
public:
property int Start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stopline_travel_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Stopline_travel_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Stopline_travel_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Stopline_travel_time = value

value = instance.Stopline_travel_time
C#
public float Stopline_travel_time {get; set;}
Managed Extensions for C++
public: __property float get_Stopline_travel_time();
public: __property void set_Stopline_travel_time(
   float value
);
C++/CLI
public:
property float Stopline_travel_time {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stopline_travel_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Stopline_travel_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Stopline_travel_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Stopline_travel_time_user = value

value = instance.Stopline_travel_time_user
C#
public bool Stopline_travel_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Stopline_travel_time_user();
public: __property void set_Stopline_travel_time_user(
   bool value
);
C++/CLI
public:
property bool Stopline_travel_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_on_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Turn_on_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Turn_on_red As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Turn_on_red = value

value = instance.Turn_on_red
C#
public bool Turn_on_red {get; set;}
Managed Extensions for C++
public: __property bool get_Turn_on_red();
public: __property void set_Turn_on_red(
   bool value
);
C++/CLI
public:
property bool Turn_on_red {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Turn_radius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Turn_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Turn_radius = value

value = instance.Turn_radius
C#
public float Turn_radius {get; set;}
Managed Extensions for C++
public: __property float get_Turn_radius();
public: __property void set_Turn_radius(
   float value
);
C++/CLI
public:
property float Turn_radius {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_veh_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Turn_veh_effect_option Property

Glossary Item Box

Turning Vehicle Effect

Syntax

Visual Basic (Declaration)
Public Property Turn_veh_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Turn_veh_effect_option = value

value = instance.Turn_veh_effect_option
C#
public int Turn_veh_effect_option {get; set;}
Managed Extensions for C++
public: __property int get_Turn_veh_effect_option();
public: __property void set_Turn_veh_effect_option(
   int value
);
C++/CLI
public:
property int Turn_veh_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Turning Vehicle Factor,
2 = Radius.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turning_veh_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Turning_veh_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Turning_veh_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Turning_veh_factor = value

value = instance.Turning_veh_factor
C#
public float Turning_veh_factor {get; set;}
Managed Extensions for C++
public: __property float get_Turning_veh_factor();
public: __property void set_Turning_veh_factor(
   float value
);
C++/CLI
public:
property float Turning_veh_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Vehicle_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Vehicle_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Vehicle_length As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Vehicle_length = value

value = instance.Vehicle_length
C#
public float Vehicle_length {get; set;}
Managed Extensions for C++
public: __property float get_Vehicle_length();
public: __property void set_Vehicle_length(
   float value
);
C++/CLI
public:
property float Vehicle_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Volume Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mc Class : Volume Property

Glossary Item Box

Volume (veh)

Syntax

Visual Basic (Declaration)
Public Property Volume As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Volume = value

value = instance.Volume
C#
public float Volume {get; set;}
Managed Extensions for C++
public: __property float get_Volume();
public: __property void set_Volume(
   float value
);
C++/CLI
public:
property float Volume {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mc Class
SIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mcs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mcs Class

Glossary Item Box

SIAPIMovement_vehicle_od_mc collection

Object Model

SIAPIMovement_vehicle_od_mcs ClassISIAPIMovement_vehicle_od_mc Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_vehicle_od_mcs
   Implements ISIAPIMovement_vehicle_od_mcs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mcs
C#
public sealed class SIAPIMovement_vehicle_od_mcs : ISIAPIMovement_vehicle_od_mcs
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_vehicle_od_mcs : public ISIAPIMovement_vehicle_od_mcs
C++/CLI
public ref class SIAPIMovement_vehicle_od_mcs sealed : public ISIAPIMovement_vehicle_od_mcs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_vehicle_od_mcs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mcs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mcs Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_vehicle_od_mcs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_vehicle_od_mcs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mcs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mcs Class : SIAPIMovement_vehicle_od_mcs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_vehicle_od_mcs()
C#
public SIAPIMovement_vehicle_od_mcs()
Managed Extensions for C++
public: SIAPIMovement_vehicle_od_mcs();
C++/CLI
public:
SIAPIMovement_vehicle_od_mcs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mcs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mcs Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_od_mcs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mcs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mcs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mcs Class : MovementClassExists Method

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mcs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_od_mcs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_od_mcs Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_od_mcs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mcs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mcs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_od_mcs Class : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIMovement_vehicle_od_mc
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_od_mcs
Dim mcClass As Integer
Dim value As ISIAPIMovement_vehicle_od_mc

value = instance.Item(mcClass)
C#
public ISIAPIMovement_vehicle_od_mc this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od_mc* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIMovement_vehicle_od_mc^ default [int] {
   ISIAPIMovement_vehicle_od_mc^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_od_mcs Class
SIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_ods Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_ods Class

Glossary Item Box

SIAPIMovement_vehicle_od collection

Object Model

SIAPIMovement_vehicle_ods ClassISIAPIMovement_vehicle_od Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovement_vehicle_ods
   Implements ISIAPIMovement_vehicle_ods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_ods
C#
public sealed class SIAPIMovement_vehicle_ods : ISIAPIMovement_vehicle_ods
Managed Extensions for C++
public __gc __sealed class SIAPIMovement_vehicle_ods : public ISIAPIMovement_vehicle_ods
C++/CLI
public ref class SIAPIMovement_vehicle_ods sealed : public ISIAPIMovement_vehicle_ods

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovement_vehicle_ods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_ods Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_ods Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovement_vehicle_ods.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovement_vehicle_ods Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Vehicle Movement data exists in the data structure.
Top

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_ods Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_ods Class : SIAPIMovement_vehicle_ods Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovement_vehicle_ods()
C#
public SIAPIMovement_vehicle_ods()
Managed Extensions for C++
public: SIAPIMovement_vehicle_ods();
C++/CLI
public:
SIAPIMovement_vehicle_ods();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIAPIMovement_vehicle_ods Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_ods Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_ods Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_ods members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Vehicle Movement data exists in the data structure.
Top

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_ods Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_ods
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIAPIMovement_vehicle_ods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_ods Class : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Vehicle Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_ods
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
public bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
public: bool MovementExists(
   int origin,
   int destination
)
C++/CLI
public:
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIAPIMovement_vehicle_ods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovement_vehicle_ods Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovement_vehicle_ods Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovement_vehicle_ods members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement.
Top

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_ods Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_ods
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIAPIMovement_vehicle_ods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovement_vehicle_ods Class : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Vehicle Movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovement_vehicle_ods
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIMovement_vehicle_od

value = instance.Item(origin, destination)
C#
public ISIAPIMovement_vehicle_od this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od* get_Item   int origin,
   int destination
;
C++/CLI
public:
property ISIAPIMovement_vehicle_od^ default [int,int] {
   ISIAPIMovement_vehicle_od^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Property Value

Return a Vehicle Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovement_vehicle_ods Class
SIAPIMovement_vehicle_ods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClass Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClass Class

Glossary Item Box

Object Model

SIAPIMovementClass ClassISIAPIMovementClassFuelEmissions InterfaceISIAPIMovementClassFuelEmission InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovementClass
   Implements ISIAPIMovementClass
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
C#
public sealed class SIAPIMovementClass : ISIAPIMovementClass
Managed Extensions for C++
public __gc __sealed class SIAPIMovementClass : public ISIAPIMovementClass
C++/CLI
public ref class SIAPIMovementClass sealed : public ISIAPIMovementClass

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovementClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClass Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClass Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovementClass.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovementClass Constructor |
Top

Public Properties

 | Name | Description
Public Property | Average_income |
Public Property | Base_class | The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Co2_to_fuel_ratio | CO2 to Fuel Consumption Rate
Public Property | Cost_method | Cost Method
Public Property | Display_id | Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Fuel_pump_price | Pump Price of Fuel
Public Property | Is_cost_included |
Public Property | Is_included | Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.
Public Property | Is_userclass |
Public Property | Mass |
Public Property | Max_power |
Public Property | MC_class | Movement Class Number
Public Property | Mode_designation | Model Designation
Public Property | MovementClassFuelEmissions |
Public Property | Name | Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Pc_equivalent | Passenger Car Equivalent
Public Property | Resource_cost_factor | Fuel Resource Cost Factor
Public Property | Run_cost_fuel_ratio | Ratio of Running Cost to Fuel Cost
Public Property | Site |
Public Property | Time_value_factor |
Top

See Also

Reference

SIAPIMovementClass Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClass Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : SIAPIMovementClass Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovementClass()
C#
public SIAPIMovementClass()
Managed Extensions for C++
public: SIAPIMovementClass();
C++/CLI
public:
SIAPIMovementClass();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClass Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClass Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClass members.

Public Properties

 | Name | Description
Public Property | Average_income |
Public Property | Base_class | The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Co2_to_fuel_ratio | CO2 to Fuel Consumption Rate
Public Property | Cost_method | Cost Method
Public Property | Display_id | Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Fuel_pump_price | Pump Price of Fuel
Public Property | Is_cost_included |
Public Property | Is_included | Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.
Public Property | Is_userclass |
Public Property | Mass |
Public Property | Max_power |
Public Property | MC_class | Movement Class Number
Public Property | Mode_designation | Model Designation
Public Property | MovementClassFuelEmissions |
Public Property | Name | Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Public Property | Pc_equivalent | Passenger Car Equivalent
Public Property | Resource_cost_factor | Fuel Resource Cost Factor
Public Property | Run_cost_fuel_ratio | Ratio of Running Cost to Fuel Cost
Public Property | Site |
Public Property | Time_value_factor |
Top

See Also

Reference

SIAPIMovementClass Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_income Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Average_income Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Average_income As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Average_income = value

value = instance.Average_income
C#
public float Average_income {get; set;}
Managed Extensions for C++
public: __property float get_Average_income();
public: __property void set_Average_income(
   float value
);
C++/CLI
public:
property float Average_income {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Base_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Base_class Property

Glossary Item Box

The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Public Property Base_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Integer

instance.Base_class = value

value = instance.Base_class
C#
public int Base_class {get; set;}
Managed Extensions for C++
public: __property int get_Base_class();
public: __property void set_Base_class(
   int value
);
C++/CLI
public:
property int Base_class {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Co2_to_fuel_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Co2_to_fuel_ratio Property

Glossary Item Box

CO2 to Fuel Consumption Rate

Syntax

Visual Basic (Declaration)
Public Property Co2_to_fuel_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Co2_to_fuel_ratio = value

value = instance.Co2_to_fuel_ratio
C#
public float Co2_to_fuel_ratio {get; set;}
Managed Extensions for C++
public: __property float get_Co2_to_fuel_ratio();
public: __property void set_Co2_to_fuel_ratio(
   float value
);
C++/CLI
public:
property float Co2_to_fuel_ratio {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cost_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Cost_method Property

Glossary Item Box

Cost Method

Syntax

Visual Basic (Declaration)
Public Property Cost_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Integer

instance.Cost_method = value

value = instance.Cost_method
C#
public int Cost_method {get; set;}
Managed Extensions for C++
public: __property int get_Cost_method();
public: __property void set_Cost_method(
   int value
);
C++/CLI
public:
property int Cost_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Operating Cost,
2 = User Cost.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Display_id Property

Glossary Item Box

Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Public Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
public string Display_id {get; set;}
Managed Extensions for C++
public: __property string* get_Display_id();
public: __property void set_Display_id(
   string* value
);
C++/CLI
public:
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_pump_price Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Fuel_pump_price Property

Glossary Item Box

Pump Price of Fuel

Syntax

Visual Basic (Declaration)
Public Property Fuel_pump_price As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Fuel_pump_price = value

value = instance.Fuel_pump_price
C#
public float Fuel_pump_price {get; set;}
Managed Extensions for C++
public: __property float get_Fuel_pump_price();
public: __property void set_Fuel_pump_price(
   float value
);
C++/CLI
public:
property float Fuel_pump_price {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_cost_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Is_cost_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Is_cost_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Boolean

value = instance.Is_cost_included
C#
public bool Is_cost_included {get;}
Managed Extensions for C++
public: __property bool get_Is_cost_included();
C++/CLI
public:
property bool Is_cost_included {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Is_included Property

Glossary Item Box

Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.

Syntax

Visual Basic (Declaration)
Public Property Is_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Boolean

instance.Is_included = value

value = instance.Is_included
C#
public bool Is_included {get; set;}
Managed Extensions for C++
public: __property bool get_Is_included();
public: __property void set_Is_included(
   bool value
);
C++/CLI
public:
property bool Is_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_userclass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Is_userclass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Is_userclass As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Boolean

value = instance.Is_userclass
C#
public bool Is_userclass {get;}
Managed Extensions for C++
public: __property bool get_Is_userclass();
C++/CLI
public:
property bool Is_userclass {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Mass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Mass As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Mass = value

value = instance.Mass
C#
public float Mass {get; set;}
Managed Extensions for C++
public: __property float get_Mass();
public: __property void set_Mass(
   float value
);
C++/CLI
public:
property float Mass {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_power Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Max_power Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Max_power As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Max_power = value

value = instance.Max_power
C#
public float Max_power {get; set;}
Managed Extensions for C++
public: __property float get_Max_power();
public: __property void set_Max_power(
   float value
);
C++/CLI
public:
property float Max_power {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2,
9 = User Class 3,
10 = User Class 4,
11 = User Class 5,
12 = User Class 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mode_designation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Mode_designation Property

Glossary Item Box

Model Designation

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mode_designation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Integer

value = instance.Mode_designation
C#
public int Mode_designation {get;}
Managed Extensions for C++
public: __property int get_Mode_designation();
C++/CLI
public:
property int Mode_designation {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicle,
2 = Heavy Vehicle.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassFuelEmissions Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : MovementClassFuelEmissions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementClassFuelEmissions As ISIAPIMovementClassFuelEmissions
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As ISIAPIMovementClassFuelEmissions

value = instance.MovementClassFuelEmissions
C#
public ISIAPIMovementClassFuelEmissions MovementClassFuelEmissions {get;}
Managed Extensions for C++
public: __property ISIAPIMovementClassFuelEmissions* get_MovementClassFuelEmissions();
C++/CLI
public:
property ISIAPIMovementClassFuelEmissions^ MovementClassFuelEmissions {
   ISIAPIMovementClassFuelEmissions^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Name Property

Glossary Item Box

Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Pc_equivalent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Pc_equivalent Property

Glossary Item Box

Passenger Car Equivalent

Syntax

Visual Basic (Declaration)
Public Property Pc_equivalent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Pc_equivalent = value

value = instance.Pc_equivalent
C#
public float Pc_equivalent {get; set;}
Managed Extensions for C++
public: __property float get_Pc_equivalent();
public: __property void set_Pc_equivalent(
   float value
);
C++/CLI
public:
property float Pc_equivalent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Resource_cost_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Resource_cost_factor Property

Glossary Item Box

Fuel Resource Cost Factor

Syntax

Visual Basic (Declaration)
Public Property Resource_cost_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Resource_cost_factor = value

value = instance.Resource_cost_factor
C#
public float Resource_cost_factor {get; set;}
Managed Extensions for C++
public: __property float get_Resource_cost_factor();
public: __property void set_Resource_cost_factor(
   float value
);
C++/CLI
public:
property float Resource_cost_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Run_cost_fuel_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Run_cost_fuel_ratio Property

Glossary Item Box

Ratio of Running Cost to Fuel Cost

Syntax

Visual Basic (Declaration)
Public Property Run_cost_fuel_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Run_cost_fuel_ratio = value

value = instance.Run_cost_fuel_ratio
C#
public float Run_cost_fuel_ratio {get; set;}
Managed Extensions for C++
public: __property float get_Run_cost_fuel_ratio();
public: __property void set_Run_cost_fuel_ratio(
   float value
);
C++/CLI
public:
property float Run_cost_fuel_ratio {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Time_value_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClass Class : Time_value_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Time_value_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClass
Dim value As Single

instance.Time_value_factor = value

value = instance.Time_value_factor
C#
public float Time_value_factor {get; set;}
Managed Extensions for C++
public: __property float get_Time_value_factor();
public: __property void set_Time_value_factor(
   float value
);
C++/CLI
public:
property float Time_value_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClass Class
SIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClasses Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClasses Class

Glossary Item Box

Object Model

SIAPIMovementClasses ClassISIAPIMovementClass Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovementClasses
   Implements ISIAPIMovementClasses
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClasses
C#
public sealed class SIAPIMovementClasses : ISIAPIMovementClasses
Managed Extensions for C++
public __gc __sealed class SIAPIMovementClasses : public ISIAPIMovementClasses
C++/CLI
public ref class SIAPIMovementClasses sealed : public ISIAPIMovementClasses

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovementClasses

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClasses Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClasses Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovementClasses.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovementClasses Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Class Object. Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists | Get a value indicating whether a Movement Class data exists in the data structure.
Top

See Also

Reference

SIAPIMovementClasses Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClasses Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClasses Class : SIAPIMovementClasses Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovementClasses()
C#
public SIAPIMovementClasses()
Managed Extensions for C++
public: SIAPIMovementClasses();
C++/CLI
public:
SIAPIMovementClasses();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Class
SIAPIMovementClasses Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClasses Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClasses Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClasses members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists | Get a value indicating whether a Movement Class data exists in the data structure.
Top

See Also

Reference

SIAPIMovementClasses Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClasses Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClasses
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Class
SIAPIMovementClasses Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClasses Class : MovementClassExists Method

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a value indicating whether a Movement Class data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClasses
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Return Value

true if the data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Class
SIAPIMovementClasses Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClasses Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClasses Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClasses members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Class Object. Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIMovementClasses Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClasses Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClasses
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Class
SIAPIMovementClasses Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClasses Class : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a Movement Class Object.
Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIMovementClass
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClasses
Dim mcClass As Integer
Dim value As ISIAPIMovementClass

value = instance.Item(mcClass)
C#
public ISIAPIMovementClass this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIMovementClass* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIMovementClass^ default [int] {
   ISIAPIMovementClass^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClasses Class
SIAPIMovementClasses Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmission Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmission Class

Glossary Item Box

Object Model

SIAPIMovementClassFuelEmission Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovementClassFuelEmission
   Implements ISIAPIMovementClassFuelEmission
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
C#
public sealed class SIAPIMovementClassFuelEmission : ISIAPIMovementClassFuelEmission
Managed Extensions for C++
public __gc __sealed class SIAPIMovementClassFuelEmission : public ISIAPIMovementClassFuelEmission
C++/CLI
public ref class SIAPIMovementClassFuelEmission sealed : public ISIAPIMovementClassFuelEmission

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovementClassFuelEmission

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmission Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmission Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovementClassFuelEmission.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovementClassFuelEmission Constructor |
Top

Public Properties

 | Name | Description
Public Property | A |
Public Property | B |
Public Property | Beta1 |
Public Property | Emission_class | Emission Class
Public Property | Idle |
Top

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmission Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : SIAPIMovementClassFuelEmission Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovementClassFuelEmission()
C#
public SIAPIMovementClassFuelEmission()
Managed Extensions for C++
public: SIAPIMovementClassFuelEmission();
C++/CLI
public:
SIAPIMovementClassFuelEmission();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmission Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmission Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClassFuelEmission members.

Public Properties

 | Name | Description
Public Property | A |
Public Property | B |
Public Property | Beta1 |
Public Property | Emission_class | Emission Class
Public Property | Idle |
Top

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
A Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : A Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property A As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
Dim value As Single

instance.A = value

value = instance.A
C#
public float A {get; set;}
Managed Extensions for C++
public: __property float get_A();
public: __property void set_A(
   float value
);
C++/CLI
public:
property float A {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
B Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : B Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property B As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
Dim value As Single

instance.B = value

value = instance.B
C#
public float B {get; set;}
Managed Extensions for C++
public: __property float get_B();
public: __property void set_B(
   float value
);
C++/CLI
public:
property float B {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Beta1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : Beta1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Beta1 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
Dim value As Single

instance.Beta1 = value

value = instance.Beta1
C#
public float Beta1 {get; set;}
Managed Extensions for C++
public: __property float get_Beta1();
public: __property void set_Beta1(
   float value
);
C++/CLI
public:
property float Beta1 {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Emission_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : Emission_class Property

Glossary Item Box

Emission Class

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Emission_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
Dim value As Integer

value = instance.Emission_class
C#
public int Emission_class {get;}
Managed Extensions for C++
public: __property int get_Emission_class();
C++/CLI
public:
property int Emission_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmission Class : Idle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Idle As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmission
Dim value As Single

instance.Idle = value

value = instance.Idle
C#
public float Idle {get; set;}
Managed Extensions for C++
public: __property float get_Idle();
public: __property void set_Idle(
   float value
);
C++/CLI
public:
property float Idle {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmission Class
SIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmissions Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmissions Class

Glossary Item Box

Object Model

SIAPIMovementClassFuelEmissions ClassISIAPIMovementClassFuelEmission Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIMovementClassFuelEmissions
   Implements ISIAPIMovementClassFuelEmissions
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmissions
C#
public sealed class SIAPIMovementClassFuelEmissions : ISIAPIMovementClassFuelEmissions
Managed Extensions for C++
public __gc __sealed class SIAPIMovementClassFuelEmissions : public ISIAPIMovementClassFuelEmissions
C++/CLI
public ref class SIAPIMovementClassFuelEmissions sealed : public ISIAPIMovementClassFuelEmissions

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIMovementClassFuelEmissions

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmissions Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmissions Class

Glossary Item Box

The following tables list the members exposed by SIAPIMovementClassFuelEmissions.

Public Constructors

 | Name | Description
Public Constructor | SIAPIMovementClassFuelEmissions Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Class Fuel Emission Object. Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmissions Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmissions Class : SIAPIMovementClassFuelEmissions Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIMovementClassFuelEmissions()
C#
public SIAPIMovementClassFuelEmissions()
Managed Extensions for C++
public: SIAPIMovementClassFuelEmissions();
C++/CLI
public:
SIAPIMovementClassFuelEmissions();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIAPIMovementClassFuelEmissions Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmissions Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmissions Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClassFuelEmissions members.

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmissions Class : Exists Method

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Glossary Item Box

Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal emissionClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmissions
Dim emissionClass As Integer
Dim value As Boolean

value = instance.Exists(emissionClass)
C#
public bool Exists(
   int emissionClass
)
Managed Extensions for C++
public: bool Exists(
   int emissionClass
)
C++/CLI
public:
bool Exists(
   int emissionClass
)

Parameters

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Return Value

true if the data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIAPIMovementClassFuelEmissions Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmissions Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmissions
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIAPIMovementClassFuelEmissions Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIMovementClassFuelEmissions Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIMovementClassFuelEmissions Class

Glossary Item Box

For a list of all members of this type, see SIAPIMovementClassFuelEmissions members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Class Fuel Emission Object. Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmissions Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmissions
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIAPIMovementClassFuelEmissions Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIMovementClassFuelEmissions Class : Item Property

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Glossary Item Box

Get a Movement Class Fuel Emission Object.
Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal emissionClass As Integer _
) As ISIAPIMovementClassFuelEmission
Visual Basic (Usage) Copy Code
Dim instance As SIAPIMovementClassFuelEmissions
Dim emissionClass As Integer
Dim value As ISIAPIMovementClassFuelEmission

value = instance.Item(emissionClass)
C#
public ISIAPIMovementClassFuelEmission this[
   int emissionClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIMovementClassFuelEmission* get_Item   int emissionClass
;
C++/CLI
public:
property ISIAPIMovementClassFuelEmission^ default [int] {
   ISIAPIMovementClassFuelEmission^ get(int emissionClass);
}

Parameters

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIMovementClassFuelEmissions Class
SIAPIMovementClassFuelEmissions Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetwork Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetwork Class

Glossary Item Box

Object Model

SIAPINetwork ClassISIAPINetworkDemandSensitivity InterfaceISIAPIDiagnosticMsgs InterfaceISIAPIDiagnosticMsg InterfaceISIAPINetworkCCGs InterfaceISIAPINetworkCCG InterfaceISIAPINetworkLegConnections InterfaceISIAPINetworkLegConnection InterfaceISIAPINetworkSites InterfaceISIAPINetworkSite InterfaceISIAPIOutputNetwork InterfaceISIAPIOutputNetwork InterfaceISIAPIProject InterfaceISIAPIRoutes InterfaceISIAPIRoute Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetwork
   Implements ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
C#
public sealed class SIAPINetwork : ISIAPINetwork
Managed Extensions for C++
public __gc __sealed class SIAPINetwork : public ISIAPINetwork
C++/CLI
public ref class SIAPINetwork sealed : public ISIAPINetwork

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetwork

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetwork Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetwork Class

Glossary Item Box

The following tables list the members exposed by SIAPINetwork.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetwork Constructor |
Top

Public Properties

 | Name | Description
Public Property | Category | Network Category
Public Property | CostUnit |
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | DemandSensitivity |
Public Property | Description |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod | Desired Speed Method
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | DriveOnLeft |
Public Property | Green_split_priority_option | Green Split Priority
Public Property | HoursPerYear |
Public Property | Is_timing_optimised_for_selected_result |
Public Property | IsIncludedInProjectSummary |
Public Property | IsPlatoonDispersionApplied |
Public Property | IsShortlaneQueueStorageRatioIncl | Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio
Public Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Public Property | LastErrorMessage |
Public Property | LOSMethod | Network Level of Service Method
Public Property | LOSTarget | Network Level of Service Target
Public Property | LowerLimitOfSpeedEfficiency |
Public Property | MaxIterations |
Public Property | ModelName |
Public Property | ModelSignature |
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | MultiRoutesSummaryOption | Network Output by Routes Option
Public Property | Name |
Public Property | Network_id | The database row unique ID of the Network.
Public Property | NetworkCCGs | Collection of Common Control Group (CCG) in the Network
Public Property | NetworkCycleTime |
Public Property | NetworkID | Network ID in the Network Data dialog and reports.
Public Property | NetworkLegConnections | Collection of Leg Connections between the Sites in the Network
Public Property | NetworkSites | Collection of Sites in the Network
Public Property | OffsetDefinition | Signal Offset Definition
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | OutputNetwork | Network Output Data for the summary of the Whole Network
Public Property | OutputNetworkByRoutes | Network Output Data for the statistics summary of the selected Routes
Public Property | Peakflowperiod |
Public Property | Percentile_queue |
Public Property | Percentile_queue_option |
Public Property | Performance_measure |
Public Property | Position | The Network Position in the Project's Networks collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | ProcessingError | Error nessage after a failed call to Process
Public Property | Project |
Public Property | Routes | Collection of Routes in the Network
Public Property | SignalOffsetOption | Signal Offset Option
Public Property | Site_los_method |
Public Property | SitePhaseTimesOption | Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.
Public Property | StoppingDxPercent |
Public Property | Title |
Public Property | Units | General unit system used for data within the Network
Public Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Public Method | AddNetworkCCG | Add a new Common Control Group (CCG) into the Network.
Public Method | AddNetworkLegConnection |
Public Method | AddNetworkSite | Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.
Public Method | AddRoute | Add a new Route into the Network.
Public Method | CloneRoute | Clone a Route.
Public Method | CreateLayoutPngData |
Public Method | CreateLayoutPngFile |
Public Method | MoveNetworkCCGTo | Move a Common Control Group (CCG) to a new position.
Public Method | MoveRouteTo | Move a Route to a new position.
Public Method | Process | Processes the Whole Network This method generates the OutputNetwork data.
Public Method | ProcessByRoutes | Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated. If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again. If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics. This method generates the OutputNetworkByRoutes data.
Public Method | RemoveNetworkCCG | Remove a Common Control Group (CCG) from the Network.
Public Method | RemoveNetworkLegConnection |
Public Method | RemoveNetworkSite | Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.
Public Method | RemoveRoute | Remove a Route from the Network.
Public Method | ResetRouteSignalOffsetPriority | Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPINetwork Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetwork Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : SIAPINetwork Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetwork()
C#
public SIAPINetwork()
Managed Extensions for C++
public: SIAPINetwork();
C++/CLI
public:
SIAPINetwork();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetwork Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetwork Class

Glossary Item Box

For a list of all members of this type, see SIAPINetwork members.

Public Methods

 | Name | Description
Public Method | AddNetworkCCG | Add a new Common Control Group (CCG) into the Network.
Public Method | AddNetworkLegConnection |
Public Method | AddNetworkSite | Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.
Public Method | AddRoute | Add a new Route into the Network.
Public Method | CloneRoute | Clone a Route.
Public Method | CreateLayoutPngData |
Public Method | CreateLayoutPngFile |
Public Method | MoveNetworkCCGTo | Move a Common Control Group (CCG) to a new position.
Public Method | MoveRouteTo | Move a Route to a new position.
Public Method | Process | Processes the Whole Network This method generates the OutputNetwork data.
Public Method | ProcessByRoutes | Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated. If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again. If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics. This method generates the OutputNetworkByRoutes data.
Public Method | RemoveNetworkCCG | Remove a Common Control Group (CCG) from the Network.
Public Method | RemoveNetworkLegConnection |
Public Method | RemoveNetworkSite | Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.
Public Method | RemoveRoute | Remove a Route from the Network.
Public Method | ResetRouteSignalOffsetPriority | Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPINetwork Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkCCG Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : AddNetworkCCG Method

Glossary Item Box

Add a new Common Control Group (CCG) into the Network.

Syntax

Visual Basic (Declaration)
Public Function AddNetworkCCG() As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPINetworkCCG

value = instance.AddNetworkCCG()
C#
public ISIAPINetworkCCG AddNetworkCCG()
Managed Extensions for C++
public: ISIAPINetworkCCG* AddNetworkCCG();
C++/CLI
public:
ISIAPINetworkCCG^ AddNetworkCCG();

Return Value

The new added Common Control Group (CCG).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkLegConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : AddNetworkLegConnection Method

nwSite1
legOrientation1
nwSite2
legOrientation2

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function AddNetworkLegConnection( _
   ByVal nwSite1 As ISIAPINetworkSite, _
   ByVal legOrientation1 As Integer, _
   ByVal nwSite2 As ISIAPINetworkSite, _
   ByVal legOrientation2 As Integer _
) As ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim nwSite1 As ISIAPINetworkSite
Dim legOrientation1 As Integer
Dim nwSite2 As ISIAPINetworkSite
Dim legOrientation2 As Integer
Dim value As ISIAPINetworkLegConnection

value = instance.AddNetworkLegConnection(nwSite1, legOrientation1, nwSite2, legOrientation2)
C#
public ISIAPINetworkLegConnection AddNetworkLegConnection(
   ISIAPINetworkSite nwSite1,
   int legOrientation1,
   ISIAPINetworkSite nwSite2,
   int legOrientation2
)
Managed Extensions for C++
public: ISIAPINetworkLegConnection* AddNetworkLegConnection(
   ISIAPINetworkSite* nwSite1,
   int legOrientation1,
   ISIAPINetworkSite* nwSite2,
   int legOrientation2
)
C++/CLI
public:
ISIAPINetworkLegConnection^ AddNetworkLegConnection(
   ISIAPINetworkSite^ nwSite1,
   int legOrientation1,
   ISIAPINetworkSite^ nwSite2,
   int legOrientation2
)

Parameters

nwSite1
legOrientation1
nwSite2
legOrientation2

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : AddNetworkSite Method

site
The Site to add.
layoutX
The X-coordinate value of the Site position in the Network Configuration Layout.
layoutY
The Y-coordinate value of the Site position in the Network Configuration Layout.

Glossary Item Box

Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.

Syntax

Visual Basic (Declaration)
Public Function AddNetworkSite( _
   ByVal site As ISIAPISite, _
   ByVal layoutX As Single, _
   ByVal layoutY As Single _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim site As ISIAPISite
Dim layoutX As Single
Dim layoutY As Single
Dim value As ISIAPINetworkSite

value = instance.AddNetworkSite(site, layoutX, layoutY)
C#
public ISIAPINetworkSite AddNetworkSite(
   ISIAPISite site,
   float layoutX,
   float layoutY
)
Managed Extensions for C++
public: ISIAPINetworkSite* AddNetworkSite(
   ISIAPISite* site,
   float layoutX,
   float layoutY
)
C++/CLI
public:
ISIAPINetworkSite^ AddNetworkSite(
   ISIAPISite^ site,
   float layoutX,
   float layoutY
)

Parameters

site
The Site to add.
layoutX
The X-coordinate value of the Site position in the Network Configuration Layout.
layoutY
The Y-coordinate value of the Site position in the Network Configuration Layout.

Return Value

The new added NetworkSite.

Remarks

The Network Configuration Layout is used in the Network Configuration Dialog in the SIDRA INTERSECTION program. The dimension of any Site in the Network Configuration Layout is 200 x 200 pixels. In the Network Configuration Dialog, the start point of view is (5000, 5000). So the NetworkSites created through this dialog are usually located around the point (5000, 5000). For example, Site1 (5200, 5100), Site2 (5550, 5100). The Sites' positions in the detailed Network Layout Display are based on the relative ratio of the Sites' positions in the Network Configuration Layout.

We suggest the layoutX and layoutY values to be around 5000, and between 0 and 10000.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : AddRoute Method

Glossary Item Box

Add a new Route into the Network.

Syntax

Visual Basic (Declaration)
Public Function AddRoute() As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIRoute

value = instance.AddRoute()
C#
public ISIAPIRoute AddRoute()
Managed Extensions for C++
public: ISIAPIRoute* AddRoute();
C++/CLI
public:
ISIAPIRoute^ AddRoute();

Return Value

The new added Route

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : CloneRoute Method

route
The Route to be cloned.

Glossary Item Box

Clone a Route.

Syntax

Visual Basic (Declaration)
Public Function CloneRoute( _
   ByVal route As ISIAPIRoute _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim route As ISIAPIRoute
Dim value As ISIAPIRoute

value = instance.CloneRoute(route)
C#
public ISIAPIRoute CloneRoute(
   ISIAPIRoute route
)
Managed Extensions for C++
public: ISIAPIRoute* CloneRoute(
   ISIAPIRoute* route
)
C++/CLI
public:
ISIAPIRoute^ CloneRoute(
   ISIAPIRoute^ route
)

Parameters

route
The Route to be cloned.

Return Value

The new cloned Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : CreateLayoutPngData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateLayoutPngData() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value() As Byte

value = instance.CreateLayoutPngData()
C#
public byte[] CreateLayoutPngData()
Managed Extensions for C++
public: byte[]* CreateLayoutPngData();
C++/CLI
public:
array<byte>^ CreateLayoutPngData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngFile Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : CreateLayoutPngFile Method

filename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateLayoutPngFile( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim filename As String
Dim value As Boolean

value = instance.CreateLayoutPngFile(filename)
C#
public bool CreateLayoutPngFile(
   string filename
)
Managed Extensions for C++
public: bool CreateLayoutPngFile(
   string* filename
)
C++/CLI
public:
bool CreateLayoutPngFile(
   String^ filename
)

Parameters

filename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveNetworkCCGTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : MoveNetworkCCGTo Method

ccg
The Common Control Group to move.
newPosition
The zero-based position that the CCG should be moved to.

Glossary Item Box

Move a Common Control Group (CCG) to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveNetworkCCGTo( _
   ByVal ccg As ISIAPINetworkCCG, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim ccg As ISIAPINetworkCCG
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveNetworkCCGTo(ccg, newPosition)
C#
public bool MoveNetworkCCGTo(
   ISIAPINetworkCCG ccg,
   int newPosition
)
Managed Extensions for C++
public: bool MoveNetworkCCGTo(
   ISIAPINetworkCCG* ccg,
   int newPosition
)
C++/CLI
public:
bool MoveNetworkCCGTo(
   ISIAPINetworkCCG^ ccg,
   int newPosition
)

Parameters

ccg
The Common Control Group to move.
newPosition
The zero-based position that the CCG should be moved to.

Return Value

true if the CCG is successfully moved; otherwise, false. This method also returns false if the CCG was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveRouteTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : MoveRouteTo Method

route
The Route to move.
newPosition
The zero-based position that the Route should be moved to.

Glossary Item Box

Move a Route to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveRouteTo( _
   ByVal route As ISIAPIRoute, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim route As ISIAPIRoute
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveRouteTo(route, newPosition)
C#
public bool MoveRouteTo(
   ISIAPIRoute route,
   int newPosition
)
Managed Extensions for C++
public: bool MoveRouteTo(
   ISIAPIRoute* route,
   int newPosition
)
C++/CLI
public:
bool MoveRouteTo(
   ISIAPIRoute^ route,
   int newPosition
)

Parameters

route
The Route to move.
newPosition
The zero-based position that the Route should be moved to.

Return Value

true if the Route is successfully moved; otherwise, false. This method also returns false if the Route was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Process Method

Glossary Item Box

Processes the Whole Network

This method generates the OutputNetwork data.

Syntax

Visual Basic (Declaration)
Public Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

value = instance.Process()
C#
public bool Process()
Managed Extensions for C++
public: bool Process();
C++/CLI
public:
bool Process();

Return Value

Type: System.Boolean.

True, if processing was successful. False, if errors were generated during processing - check ProcessingError for details.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessByRoutes Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : ProcessByRoutes Method

Glossary Item Box

Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated.
If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again.
If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics.

This method generates the OutputNetworkByRoutes data.

Syntax

Visual Basic (Declaration)
Public Function ProcessByRoutes() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

value = instance.ProcessByRoutes()
C#
public bool ProcessByRoutes()
Managed Extensions for C++
public: bool ProcessByRoutes();
C++/CLI
public:
bool ProcessByRoutes();

Return Value

true if this is processed successfully.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkCCG Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : RemoveNetworkCCG Method

ccg
The Common Control Group (CCG) to remove.

Glossary Item Box

Remove a Common Control Group (CCG) from the Network.

Syntax

Visual Basic (Declaration)
Public Function RemoveNetworkCCG( _
   ByVal ccg As ISIAPINetworkCCG _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim ccg As ISIAPINetworkCCG
Dim value As Boolean

value = instance.RemoveNetworkCCG(ccg)
C#
public bool RemoveNetworkCCG(
   ISIAPINetworkCCG ccg
)
Managed Extensions for C++
public: bool RemoveNetworkCCG(
   ISIAPINetworkCCG* ccg
)
C++/CLI
public:
bool RemoveNetworkCCG(
   ISIAPINetworkCCG^ ccg
)

Parameters

ccg
The Common Control Group (CCG) to remove.

Return Value

true if the Common Control Group (CCG) is successfully removed; otherwise, false. This method also returns false if the CCG was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkLegConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : RemoveNetworkLegConnection Method

nwLegConn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RemoveNetworkLegConnection( _
   ByVal nwLegConn As ISIAPINetworkLegConnection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim nwLegConn As ISIAPINetworkLegConnection
Dim value As Boolean

value = instance.RemoveNetworkLegConnection(nwLegConn)
C#
public bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection nwLegConn
)
Managed Extensions for C++
public: bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection* nwLegConn
)
C++/CLI
public:
bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection^ nwLegConn
)

Parameters

nwLegConn

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : RemoveNetworkSite Method

networkSite
The NetworkSite to remove.

Glossary Item Box

Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.

Syntax

Visual Basic (Declaration)
Public Function RemoveNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.RemoveNetworkSite(networkSite)
C#
public bool RemoveNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
public: bool RemoveNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
public:
bool RemoveNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The NetworkSite to remove.

Return Value

true if the NetworkSite is successfully removed; otherwise, false. This method also returns false if the NetworkSite was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : RemoveRoute Method

route
The Route to remove.

Glossary Item Box

Remove a Route from the Network.

Syntax

Visual Basic (Declaration)
Public Function RemoveRoute( _
   ByVal route As ISIAPIRoute _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim route As ISIAPIRoute
Dim value As Boolean

value = instance.RemoveRoute(route)
C#
public bool RemoveRoute(
   ISIAPIRoute route
)
Managed Extensions for C++
public: bool RemoveRoute(
   ISIAPIRoute* route
)
C++/CLI
public:
bool RemoveRoute(
   ISIAPIRoute^ route
)

Parameters

route
The Route to remove.

Return Value

true if the Route is successfully removed; otherwise, false. This method also returns false if the Route was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetRouteSignalOffsetPriority Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : ResetRouteSignalOffsetPriority Method

Glossary Item Box

Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.

Syntax

Visual Basic (Declaration)
Public Function ResetRouteSignalOffsetPriority() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

value = instance.ResetRouteSignalOffsetPriority()
C#
public bool ResetRouteSignalOffsetPriority()
Managed Extensions for C++
public: bool ResetRouteSignalOffsetPriority();
C++/CLI
public:
bool ResetRouteSignalOffsetPriority();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Public Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
public bool UpdateModifiedInfo()
Managed Extensions for C++
public: bool UpdateModifiedInfo();
C++/CLI
public:
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetwork Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetwork Class

Glossary Item Box

For a list of all members of this type, see SIAPINetwork members.

Public Properties

 | Name | Description
Public Property | Category | Network Category
Public Property | CostUnit |
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | DemandSensitivity |
Public Property | Description |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod | Desired Speed Method
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | DriveOnLeft |
Public Property | Green_split_priority_option | Green Split Priority
Public Property | HoursPerYear |
Public Property | Is_timing_optimised_for_selected_result |
Public Property | IsIncludedInProjectSummary |
Public Property | IsPlatoonDispersionApplied |
Public Property | IsShortlaneQueueStorageRatioIncl | Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio
Public Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Public Property | LastErrorMessage |
Public Property | LOSMethod | Network Level of Service Method
Public Property | LOSTarget | Network Level of Service Target
Public Property | LowerLimitOfSpeedEfficiency |
Public Property | MaxIterations |
Public Property | ModelName |
Public Property | ModelSignature |
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | MultiRoutesSummaryOption | Network Output by Routes Option
Public Property | Name |
Public Property | Network_id | The database row unique ID of the Network.
Public Property | NetworkCCGs | Collection of Common Control Group (CCG) in the Network
Public Property | NetworkCycleTime |
Public Property | NetworkID | Network ID in the Network Data dialog and reports.
Public Property | NetworkLegConnections | Collection of Leg Connections between the Sites in the Network
Public Property | NetworkSites | Collection of Sites in the Network
Public Property | OffsetDefinition | Signal Offset Definition
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | OutputNetwork | Network Output Data for the summary of the Whole Network
Public Property | OutputNetworkByRoutes | Network Output Data for the statistics summary of the selected Routes
Public Property | Peakflowperiod |
Public Property | Percentile_queue |
Public Property | Percentile_queue_option |
Public Property | Performance_measure |
Public Property | Position | The Network Position in the Project's Networks collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | ProcessingError | Error nessage after a failed call to Process
Public Property | Project |
Public Property | Routes | Collection of Routes in the Network
Public Property | SignalOffsetOption | Signal Offset Option
Public Property | Site_los_method |
Public Property | SitePhaseTimesOption | Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.
Public Property | StoppingDxPercent |
Public Property | Title |
Public Property | Units | General unit system used for data within the Network
Public Property | Variable_phasing_perf_measure |
Top

See Also

Reference

SIAPINetwork Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Category Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Category Property

Glossary Item Box

Network Category

Syntax

Visual Basic (Declaration)
Public Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.Category = value

value = instance.Category
C#
public string Category {get; set;}
Managed Extensions for C++
public: __property string* get_Category();
public: __property void set_Category(
   string* value
);
C++/CLI
public:
property String^ Category {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Network Category, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CostUnit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : CostUnit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property CostUnit As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.CostUnit = value

value = instance.CostUnit
C#
public string CostUnit {get; set;}
Managed Extensions for C++
public: __property string* get_CostUnit();
public: __property void set_CostUnit(
   string* value
);
C++/CLI
public:
property String^ CostUnit {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Created_by
C#
public string Created_by {get;}
Managed Extensions for C++
public: __property string* get_Created_by();
C++/CLI
public:
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Created_by_company
C#
public string Created_by_company {get;}
Managed Extensions for C++
public: __property string* get_Created_by_company();
C++/CLI
public:
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Date

value = instance.Created_date
C#
public DateTime Created_date {get;}
Managed Extensions for C++
public: __property DateTime get_Created_date();
C++/CLI
public:
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Created_version
C#
public string Created_version {get;}
Managed Extensions for C++
public: __property string* get_Created_version();
C++/CLI
public:
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Public Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
public int Cycle_time_option {get; set;}
Managed Extensions for C++
public: __property int get_Cycle_time_option();
public: __property void set_Cycle_time_option(
   int value
);
C++/CLI
public:
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Cycle Time,
1 = Optimum Cycle Time,
2 = User-Given Cycle Time.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandSensitivity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DemandSensitivity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DemandSensitivity As ISIAPINetworkDemandSensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPINetworkDemandSensitivity

value = instance.DemandSensitivity
C#
public ISIAPINetworkDemandSensitivity DemandSensitivity {get;}
Managed Extensions for C++
public: __property ISIAPINetworkDemandSensitivity* get_DemandSensitivity();
C++/CLI
public:
property ISIAPINetworkDemandSensitivity^ DemandSensitivity {
   ISIAPINetworkDemandSensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Description Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Description Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Single

instance.DesiredSpeed = value

value = instance.DesiredSpeed
C#
public float DesiredSpeed {get; set;}
Managed Extensions for C++
public: __property float get_DesiredSpeed();
public: __property void set_DesiredSpeed(
   float value
);
C++/CLI
public:
property float DesiredSpeed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DesiredSpeedMethod Property

Glossary Item Box

Desired Speed Method

Syntax

Visual Basic (Declaration)
Public Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.DesiredSpeedMethod = value

value = instance.DesiredSpeedMethod
C#
public int DesiredSpeedMethod {get; set;}
Managed Extensions for C++
public: __property int get_DesiredSpeedMethod();
public: __property void set_DesiredSpeedMethod(
   int value
);
C++/CLI
public:
property int DesiredSpeedMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = User Input,
1 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
public ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
public: __property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
public:
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

value = instance.DiagnosticStatus
C#
public int DiagnosticStatus {get;}
Managed Extensions for C++
public: __property int get_DiagnosticStatus();
C++/CLI
public:
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DriveOnLeft Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : DriveOnLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DriveOnLeft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

value = instance.DriveOnLeft
C#
public bool DriveOnLeft {get;}
Managed Extensions for C++
public: __property bool get_DriveOnLeft();
C++/CLI
public:
property bool DriveOnLeft {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Green_split_priority_option Property

Glossary Item Box

Green Split Priority

Syntax

Visual Basic (Declaration)
Public Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
public int Green_split_priority_option {get; set;}
Managed Extensions for C++
public: __property int get_Green_split_priority_option();
public: __property void set_Green_split_priority_option(
   int value
);
C++/CLI
public:
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Coordinated Movements,
2 = User-Specified Movements.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HoursPerYear Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : HoursPerYear Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property HoursPerYear As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.HoursPerYear = value

value = instance.HoursPerYear
C#
public int HoursPerYear {get; set;}
Managed Extensions for C++
public: __property int get_HoursPerYear();
public: __property void set_HoursPerYear(
   int value
);
C++/CLI
public:
property int HoursPerYear {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_timing_optimised_for_selected_result Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Is_timing_optimised_for_selected_result Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_timing_optimised_for_selected_result As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

instance.Is_timing_optimised_for_selected_result = value

value = instance.Is_timing_optimised_for_selected_result
C#
public bool Is_timing_optimised_for_selected_result {get; set;}
Managed Extensions for C++
public: __property bool get_Is_timing_optimised_for_selected_result();
public: __property void set_Is_timing_optimised_for_selected_result(
   bool value
);
C++/CLI
public:
property bool Is_timing_optimised_for_selected_result {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
public bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInProjectSummary();
public: __property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
public:
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsPlatoonDispersionApplied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : IsPlatoonDispersionApplied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsPlatoonDispersionApplied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

instance.IsPlatoonDispersionApplied = value

value = instance.IsPlatoonDispersionApplied
C#
public bool IsPlatoonDispersionApplied {get; set;}
Managed Extensions for C++
public: __property bool get_IsPlatoonDispersionApplied();
public: __property void set_IsPlatoonDispersionApplied(
   bool value
);
C++/CLI
public:
property bool IsPlatoonDispersionApplied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsShortlaneQueueStorageRatioIncl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : IsShortlaneQueueStorageRatioIncl Property

Glossary Item Box

Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio

Syntax

Visual Basic (Declaration)
Public Property IsShortlaneQueueStorageRatioIncl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

instance.IsShortlaneQueueStorageRatioIncl = value

value = instance.IsShortlaneQueueStorageRatioIncl
C#
public bool IsShortlaneQueueStorageRatioIncl {get; set;}
Managed Extensions for C++
public: __property bool get_IsShortlaneQueueStorageRatioIncl();
public: __property void set_IsShortlaneQueueStorageRatioIncl(
   bool value
);
C++/CLI
public:
property bool IsShortlaneQueueStorageRatioIncl {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Lane_blockage_effect_option Property

Glossary Item Box

Lane Blockage Effect Option:
In Network analysis, include Lane Blockage effects in determining Phase Times.

Syntax

Visual Basic (Declaration)
Public Property Lane_blockage_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Lane_blockage_effect_option = value

value = instance.Lane_blockage_effect_option
C#
public int Lane_blockage_effect_option {get; set;}
Managed Extensions for C++
public: __property int get_Lane_blockage_effect_option();
public: __property void set_Lane_blockage_effect_option(
   int value
);
C++/CLI
public:
property int Lane_blockage_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Without Lane Blockage Effects,
1 = With Lane Blockage Effects.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : LOSMethod Property

Glossary Item Box

Network Level of Service Method

Syntax

Visual Basic (Declaration)
Public Property LOSMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.LOSMethod = value

value = instance.LOSMethod
C#
public int LOSMethod {get; set;}
Managed Extensions for C++
public: __property int get_LOSMethod();
public: __property void set_LOSMethod(
   int value
);
C++/CLI
public:
property int LOSMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = SIDRA Speed Efficiency,
2 = HCM 2010 Speed Efficiency,
3 = HCM 6 Speed Efficiency.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSTarget Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : LOSTarget Property

Glossary Item Box

Network Level of Service Target

Syntax

Visual Basic (Declaration)
Public Property LOSTarget As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.LOSTarget = value

value = instance.LOSTarget
C#
public int LOSTarget {get; set;}
Managed Extensions for C++
public: __property int get_LOSTarget();
public: __property void set_LOSTarget(
   int value
);
C++/CLI
public:
property int LOSTarget {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LowerLimitOfSpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : LowerLimitOfSpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LowerLimitOfSpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Single

instance.LowerLimitOfSpeedEfficiency = value

value = instance.LowerLimitOfSpeedEfficiency
C#
public float LowerLimitOfSpeedEfficiency {get; set;}
Managed Extensions for C++
public: __property float get_LowerLimitOfSpeedEfficiency();
public: __property void set_LowerLimitOfSpeedEfficiency(
   float value
);
C++/CLI
public:
property float LowerLimitOfSpeedEfficiency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MaxIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : MaxIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MaxIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.MaxIterations = value

value = instance.MaxIterations
C#
public int MaxIterations {get; set;}
Managed Extensions for C++
public: __property int get_MaxIterations();
public: __property void set_MaxIterations(
   int value
);
C++/CLI
public:
property int MaxIterations {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : ModelName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModelName As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.ModelName
C#
public string ModelName {get;}
Managed Extensions for C++
public: __property string* get_ModelName();
C++/CLI
public:
property String^ ModelName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelSignature Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : ModelSignature Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModelSignature As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.ModelSignature
C#
public string ModelSignature {get;}
Managed Extensions for C++
public: __property string* get_ModelSignature();
C++/CLI
public:
property String^ ModelSignature {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Modified_by
C#
public string Modified_by {get;}
Managed Extensions for C++
public: __property string* get_Modified_by();
C++/CLI
public:
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Modified_by_company
C#
public string Modified_by_company {get;}
Managed Extensions for C++
public: __property string* get_Modified_by_company();
C++/CLI
public:
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Date

value = instance.Modified_date
C#
public DateTime Modified_date {get;}
Managed Extensions for C++
public: __property DateTime get_Modified_date();
C++/CLI
public:
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.Modified_version
C#
public string Modified_version {get;}
Managed Extensions for C++
public: __property string* get_Modified_version();
C++/CLI
public:
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MultiRoutesSummaryOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : MultiRoutesSummaryOption Property

Glossary Item Box

Network Output by Routes Option

Syntax

Visual Basic (Declaration)
Public Property MultiRoutesSummaryOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.MultiRoutesSummaryOption = value

value = instance.MultiRoutesSummaryOption
C#
public int MultiRoutesSummaryOption {get; set;}
Managed Extensions for C++
public: __property int get_MultiRoutesSummaryOption();
public: __property void set_MultiRoutesSummaryOption(
   int value
);
C++/CLI
public:
property int MultiRoutesSummaryOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

2 = Approaches,
3 = Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Network_id Property

Glossary Item Box

The database row unique ID of the Network.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

value = instance.Network_id
C#
public int Network_id {get;}
Managed Extensions for C++
public: __property int get_Network_id();
C++/CLI
public:
property int Network_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : NetworkCCGs Property

Glossary Item Box

Collection of Common Control Group (CCG) in the Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkCCGs As ISIAPINetworkCCGs
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPINetworkCCGs

value = instance.NetworkCCGs
C#
public ISIAPINetworkCCGs NetworkCCGs {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGs* get_NetworkCCGs();
C++/CLI
public:
property ISIAPINetworkCCGs^ NetworkCCGs {
   ISIAPINetworkCCGs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCycleTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : NetworkCycleTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property NetworkCycleTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.NetworkCycleTime = value

value = instance.NetworkCycleTime
C#
public int NetworkCycleTime {get; set;}
Managed Extensions for C++
public: __property int get_NetworkCycleTime();
public: __property void set_NetworkCycleTime(
   int value
);
C++/CLI
public:
property int NetworkCycleTime {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : NetworkID Property

Glossary Item Box

Network ID in the Network Data dialog and reports.

Syntax

Visual Basic (Declaration)
Public Property NetworkID As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.NetworkID = value

value = instance.NetworkID
C#
public string NetworkID {get; set;}
Managed Extensions for C++
public: __property string* get_NetworkID();
public: __property void set_NetworkID(
   string* value
);
C++/CLI
public:
property String^ NetworkID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkLegConnections Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : NetworkLegConnections Property

Glossary Item Box

Collection of Leg Connections between the Sites in the Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkLegConnections As ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPINetworkLegConnections

value = instance.NetworkLegConnections
C#
public ISIAPINetworkLegConnections NetworkLegConnections {get;}
Managed Extensions for C++
public: __property ISIAPINetworkLegConnections* get_NetworkLegConnections();
C++/CLI
public:
property ISIAPINetworkLegConnections^ NetworkLegConnections {
   ISIAPINetworkLegConnections^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : NetworkSites Property

Glossary Item Box

Collection of Sites in the Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSites As ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPINetworkSites

value = instance.NetworkSites
C#
public ISIAPINetworkSites NetworkSites {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSites* get_NetworkSites();
C++/CLI
public:
property ISIAPINetworkSites^ NetworkSites {
   ISIAPINetworkSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OffsetDefinition Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : OffsetDefinition Property

Glossary Item Box

Signal Offset Definition

Syntax

Visual Basic (Declaration)
Public Property OffsetDefinition As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.OffsetDefinition = value

value = instance.OffsetDefinition
C#
public int OffsetDefinition {get; set;}
Managed Extensions for C++
public: __property int get_OffsetDefinition();
public: __property void set_OffsetDefinition(
   int value
);
C++/CLI
public:
property int OffsetDefinition {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Offsets (Phase Start),
1 = Offsets (Green Start).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
public int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_increment();
public: __property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
public int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_lower();
public: __property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
public bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
public: __property bool get_Optimum_cycle_time_lower_user();
public: __property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
public:
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
public int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_optim_method();
public: __property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
public int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_perf_measure();
public: __property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
public int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_upper();
public: __property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
public int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_optim_method();
public: __property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
public int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_increment();
public: __property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
public int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_lower();
public: __property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
public int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_upper();
public: __property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
public int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_perf_measure();
public: __property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetwork Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : OutputNetwork Property

Glossary Item Box

Network Output Data for the summary of the Whole Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetwork As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIOutputNetwork

value = instance.OutputNetwork
C#
public ISIAPIOutputNetwork OutputNetwork {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetwork* get_OutputNetwork();
C++/CLI
public:
property ISIAPIOutputNetwork^ OutputNetwork {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkByRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : OutputNetworkByRoutes Property

Glossary Item Box

Network Output Data for the statistics summary of the selected Routes

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetworkByRoutes As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIOutputNetwork

value = instance.OutputNetworkByRoutes
C#
public ISIAPIOutputNetwork OutputNetworkByRoutes {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetwork* get_OutputNetworkByRoutes();
C++/CLI
public:
property ISIAPIOutputNetwork^ OutputNetworkByRoutes {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peakflowperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Peakflowperiod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Peakflowperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Peakflowperiod = value

value = instance.Peakflowperiod
C#
public int Peakflowperiod {get; set;}
Managed Extensions for C++
public: __property int get_Peakflowperiod();
public: __property void set_Peakflowperiod(
   int value
);
C++/CLI
public:
property int Peakflowperiod {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Percentile_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Percentile_queue As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Percentile_queue = value

value = instance.Percentile_queue
C#
public int Percentile_queue {get; set;}
Managed Extensions for C++
public: __property int get_Percentile_queue();
public: __property void set_Percentile_queue(
   int value
);
C++/CLI
public:
property int Percentile_queue {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Percentile_queue_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Percentile_queue_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Percentile_queue_option = value

value = instance.Percentile_queue_option
C#
public int Percentile_queue_option {get; set;}
Managed Extensions for C++
public: __property int get_Percentile_queue_option();
public: __property void set_Percentile_queue_option(
   int value
);
C++/CLI
public:
property int Percentile_queue_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Performance_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Performance_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Performance_measure = value

value = instance.Performance_measure
C#
public int Performance_measure {get; set;}
Managed Extensions for C++
public: __property int get_Performance_measure();
public: __property void set_Performance_measure(
   int value
);
C++/CLI
public:
property int Performance_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Position Property

Glossary Item Box

The Network Position in the Project's Networks collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
public int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
public: __property int get_Practical_cycle_rounding();
public: __property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
public:
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
public int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
public: __property int get_Practical_max_cycle_time();
public: __property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
public:
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingError Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : ProcessingError Property

Glossary Item Box

Error nessage after a failed call to Process

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProcessingError As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

value = instance.ProcessingError
C#
public string ProcessingError {get;}
Managed Extensions for C++
public: __property string* get_ProcessingError();
C++/CLI
public:
property String^ ProcessingError {
   String^ get();
}

Property Value

Type: System.String.

Error message

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Project Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIProject

value = instance.Project
C#
public ISIAPIProject Project {get;}
Managed Extensions for C++
public: __property ISIAPIProject* get_Project();
C++/CLI
public:
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Routes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Routes Property

Glossary Item Box

Collection of Routes in the Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Routes As ISIAPIRoutes
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As ISIAPIRoutes

value = instance.Routes
C#
public ISIAPIRoutes Routes {get;}
Managed Extensions for C++
public: __property ISIAPIRoutes* get_Routes();
C++/CLI
public:
property ISIAPIRoutes^ Routes {
   ISIAPIRoutes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : SignalOffsetOption Property

Glossary Item Box

Signal Offset Option

Syntax

Visual Basic (Declaration)
Public Property SignalOffsetOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.SignalOffsetOption = value

value = instance.SignalOffsetOption
C#
public int SignalOffsetOption {get; set;}
Managed Extensions for C++
public: __property int get_SignalOffsetOption();
public: __property void set_SignalOffsetOption(
   int value
);
C++/CLI
public:
property int SignalOffsetOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Program,
1 = User-Given.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site_los_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Site_los_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Site_los_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Site_los_method = value

value = instance.Site_los_method
C#
public int Site_los_method {get; set;}
Managed Extensions for C++
public: __property int get_Site_los_method();
public: __property void set_Site_los_method(
   int value
);
C++/CLI
public:
property int Site_los_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SitePhaseTimesOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : SitePhaseTimesOption Property

Glossary Item Box

Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.

Syntax

Visual Basic (Declaration)
Public Property SitePhaseTimesOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.SitePhaseTimesOption = value

value = instance.SitePhaseTimesOption
C#
public int SitePhaseTimesOption {get; set;}
Managed Extensions for C++
public: __property int get_SitePhaseTimesOption();
public: __property void set_SitePhaseTimesOption(
   int value
);
C++/CLI
public:
property int SitePhaseTimesOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Program,
1 = User-Given.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StoppingDxPercent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : StoppingDxPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property StoppingDxPercent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Single

instance.StoppingDxPercent = value

value = instance.StoppingDxPercent
C#
public float StoppingDxPercent {get; set;}
Managed Extensions for C++
public: __property float get_StoppingDxPercent();
public: __property void set_StoppingDxPercent(
   float value
);
C++/CLI
public:
property float StoppingDxPercent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Units Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Units Property

Glossary Item Box

General unit system used for data within the Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Units As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

value = instance.Units
C#
public int Units {get;}
Managed Extensions for C++
public: __property int get_Units();
C++/CLI
public:
property int Units {
   int get();
}

Property Value

Type: System.Int32.

0 = Metric,
1 = US Units.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetwork Class : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetwork
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
public int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Variable_phasing_perf_measure();
public: __property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
public:
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetwork Class
SIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCG Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCG Class

Glossary Item Box

Wrapper class for a Common Control Group (CCG) in a particular Network

Object Model

SIAPINetworkCCG ClassISIAPINetworkCCGSequences InterfaceISIAPINetworkCCGSequence InterfaceISIAPINetwork InterfaceISIAPINetworkSites InterfaceISIAPINetworkSite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCG
   Implements ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
C#
public sealed class SIAPINetworkCCG : ISIAPINetworkCCG
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCG : public ISIAPINetworkCCG
C++/CLI
public ref class SIAPINetworkCCG sealed : public ISIAPINetworkCCG

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCG

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCG Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCG Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCG.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCG Constructor |
Top

Public Properties

 | Name | Description
Public Property | CCGSequences |
Public Property | CoordinatedOption | Coordinated Option
Public Property | IsReference |
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | Network |
Public Property | NetworkCCGID | Network Common Control Group (CCG) ID for displaying in reports.
Public Property | NetworkSites |
Public Property | Offset |
Public Property | Position | The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.
Public Property | Signal_analysis_method | Signalised analysis method, applied to the Sites in this Common Control Group (CCG).
Top

Public Methods

 | Name | Description
Public Method | AddCCGSequence | Add a Sequence. A new Sequence is created and added to this Network CCG.
Public Method | AddNetworkSite | Add a Network Site into this Network CCG.
Public Method | CloneCCGSequence | Clone a Sequence.
Public Method | MoveCCGSequenceTo | Move a Sequence to a new position.
Public Method | RemoveCCGSequence | Remove a Sequence from this Network CCG.
Public Method | RemoveNetworkSite | Remove a Network Site from this Network CCG.
Top

See Also

Reference

SIAPINetworkCCG Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCG Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : SIAPINetworkCCG Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCG()
C#
public SIAPINetworkCCG()
Managed Extensions for C++
public: SIAPINetworkCCG();
C++/CLI
public:
SIAPINetworkCCG();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCG Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCG Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCG members.

Public Methods

 | Name | Description
Public Method | AddCCGSequence | Add a Sequence. A new Sequence is created and added to this Network CCG.
Public Method | AddNetworkSite | Add a Network Site into this Network CCG.
Public Method | CloneCCGSequence | Clone a Sequence.
Public Method | MoveCCGSequenceTo | Move a Sequence to a new position.
Public Method | RemoveCCGSequence | Remove a Sequence from this Network CCG.
Public Method | RemoveNetworkSite | Remove a Network Site from this Network CCG.
Top

See Also

Reference

SIAPINetworkCCG Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : AddCCGSequence Method

name
The name of the new Sequence.

Glossary Item Box

Add a Sequence. A new Sequence is created and added to this Network CCG.

Syntax

Visual Basic (Declaration)
Public Function AddCCGSequence( _
   ByVal name As String _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim name As String
Dim value As ISIAPINetworkCCGSequence

value = instance.AddCCGSequence(name)
C#
public ISIAPINetworkCCGSequence AddCCGSequence(
   string name
)
Managed Extensions for C++
public: ISIAPINetworkCCGSequence* AddCCGSequence(
   string* name
)
C++/CLI
public:
ISIAPINetworkCCGSequence^ AddCCGSequence(
   String^ name
)

Parameters

name
The name of the new Sequence.

Return Value

The new Sequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : AddNetworkSite Method

networkSite
The Network Site to add.

Glossary Item Box

Add a Network Site into this Network CCG.

Syntax

Visual Basic (Declaration)
Public Function AddNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.AddNetworkSite(networkSite)
C#
public bool AddNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
public: bool AddNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
public:
bool AddNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The Network Site to add.

Return Value

true if the Network Site is successfully added; otherwise, false.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : CloneCCGSequence Method

ccgSequence
The Sequence to be cloned.

Glossary Item Box

Clone a Sequence.

Syntax

Visual Basic (Declaration)
Public Function CloneCCGSequence( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCGSequence

value = instance.CloneCCGSequence(ccgSequence)
C#
public ISIAPINetworkCCGSequence CloneCCGSequence(
   ISIAPINetworkCCGSequence ccgSequence
)
Managed Extensions for C++
public: ISIAPINetworkCCGSequence* CloneCCGSequence(
   ISIAPINetworkCCGSequence* ccgSequence
)
C++/CLI
public:
ISIAPINetworkCCGSequence^ CloneCCGSequence(
   ISIAPINetworkCCGSequence^ ccgSequence
)

Parameters

ccgSequence
The Sequence to be cloned.

Return Value

The new cloned Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveCCGSequenceTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : MoveCCGSequenceTo Method

ccgSequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Glossary Item Box

Move a Sequence to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveCCGSequenceTo( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveCCGSequenceTo(ccgSequence, newPosition)
C#
public bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence ccgSequence,
   int newPosition
)
Managed Extensions for C++
public: bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence* ccgSequence,
   int newPosition
)
C++/CLI
public:
bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence^ ccgSequence,
   int newPosition
)

Parameters

ccgSequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Return Value

true if the Sequence is successfully moved; otherwise, false. This method also returns false if the Sequence was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : RemoveCCGSequence Method

ccgSequence
The Sequence to remove.

Glossary Item Box

Remove a Sequence from this Network CCG.

Syntax

Visual Basic (Declaration)
Public Function RemoveCCGSequence( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim value As Boolean

value = instance.RemoveCCGSequence(ccgSequence)
C#
public bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence ccgSequence
)
Managed Extensions for C++
public: bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence* ccgSequence
)
C++/CLI
public:
bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence^ ccgSequence
)

Parameters

ccgSequence
The Sequence to remove.

Return Value

true if the Sequence is successfully removed; otherwise, false. This method also returns false if the Sequence was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : RemoveNetworkSite Method

networkSite
The Network Site to remove.

Glossary Item Box

Remove a Network Site from this Network CCG.

Syntax

Visual Basic (Declaration)
Public Function RemoveNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.RemoveNetworkSite(networkSite)
C#
public bool RemoveNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
public: bool RemoveNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
public:
bool RemoveNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The Network Site to remove.

Return Value

true if the Network Site is successfully removed; otherwise, false. This method also returns false if the Network Site was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCG Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCG Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCG members.

Public Properties

 | Name | Description
Public Property | CCGSequences |
Public Property | CoordinatedOption | Coordinated Option
Public Property | IsReference |
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | Network |
Public Property | NetworkCCGID | Network Common Control Group (CCG) ID for displaying in reports.
Public Property | NetworkSites |
Public Property | Offset |
Public Property | Position | The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.
Public Property | Signal_analysis_method | Signalised analysis method, applied to the Sites in this Common Control Group (CCG).
Top

See Also

Reference

SIAPINetworkCCG Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGSequences Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : CCGSequences Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CCGSequences As ISIAPINetworkCCGSequences
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As ISIAPINetworkCCGSequences

value = instance.CCGSequences
C#
public ISIAPINetworkCCGSequences CCGSequences {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGSequences* get_CCGSequences();
C++/CLI
public:
property ISIAPINetworkCCGSequences^ CCGSequences {
   ISIAPINetworkCCGSequences^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CoordinatedOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : CoordinatedOption Property

Glossary Item Box

Coordinated Option

Syntax

Visual Basic (Declaration)
Public Property CoordinatedOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As Integer

instance.CoordinatedOption = value

value = instance.CoordinatedOption
C#
public int CoordinatedOption {get; set;}
Managed Extensions for C++
public: __property int get_CoordinatedOption();
public: __property void set_CoordinatedOption(
   int value
);
C++/CLI
public:
property int CoordinatedOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = NA,
1 = Yes,
2 = No.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReference Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : IsReference Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsReference As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As Boolean

instance.IsReference = value

value = instance.IsReference
C#
public bool IsReference {get; set;}
Managed Extensions for C++
public: __property bool get_IsReference();
public: __property void set_IsReference(
   bool value
);
C++/CLI
public:
property bool IsReference {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : NetworkCCGID Property

Glossary Item Box

Network Common Control Group (CCG) ID for displaying in reports.

Syntax

Visual Basic (Declaration)
Public Property NetworkCCGID As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As String

instance.NetworkCCGID = value

value = instance.NetworkCCGID
C#
public string NetworkCCGID {get; set;}
Managed Extensions for C++
public: __property string* get_NetworkCCGID();
public: __property void set_NetworkCCGID(
   string* value
);
C++/CLI
public:
property String^ NetworkCCGID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : NetworkSites Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSites As ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As ISIAPINetworkSites

value = instance.NetworkSites
C#
public ISIAPINetworkSites NetworkSites {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSites* get_NetworkSites();
C++/CLI
public:
property ISIAPINetworkSites^ NetworkSites {
   ISIAPINetworkSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As Integer

instance.Offset = value

value = instance.Offset
C#
public int Offset {get; set;}
Managed Extensions for C++
public: __property int get_Offset();
public: __property void set_Offset(
   int value
);
C++/CLI
public:
property int Offset {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : Position Property

Glossary Item Box

The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCG Class : Signal_analysis_method Property

Glossary Item Box

Signalised analysis method, applied to the Sites in this Common Control Group (CCG).

Syntax

Visual Basic (Declaration)
Public Property Signal_analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCG
Dim value As Integer

instance.Signal_analysis_method = value

value = instance.Signal_analysis_method
C#
public int Signal_analysis_method {get; set;}
Managed Extensions for C++
public: __property int get_Signal_analysis_method();
public: __property void set_Signal_analysis_method(
   int value
);
C++/CLI
public:
property int Signal_analysis_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Fixed-Time/Pretimed,
1 = Actuated.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCG Class
SIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhase Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhase Class

Glossary Item Box

Object Model

SIAPINetworkCCGPhase ClassISIAPINetworkCCGSequence Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCGPhase
   Implements ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
C#
public sealed class SIAPINetworkCCGPhase : ISIAPINetworkCCGPhase
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCGPhase : public ISIAPINetworkCCGPhase
C++/CLI
public ref class SIAPINetworkCCGPhase sealed : public ISIAPINetworkCCGPhase

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCGPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhase Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhase Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCGPhase.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCGPhase Constructor |
Top

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | CCGSequence |
Public Property | Dummy_maximum_green_time |
Public Property | Dummy_maximum_green_time_user |
Public Property | Dummy_minimum_green_time |
Public Property | Dummy_minimum_green_time_user |
Public Property | Has_dummy |
Public Property | Is_variable |
Public Property | IsReferencePhase |
Public Property | Minimum_time |
Public Property | Name |
Public Property | Phase_frequency |
Public Property | Phase_frequency_user |
Public Property | Phase_time |
Public Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Public Property | Yellow_time |
Top

Public Methods

 | Name | Description
Public Method | GetPhasemovementPedsByNetworkSite |
Public Method | GetPhasemovementVehiclesByNetworkSite |
Top

See Also

Reference

SIAPINetworkCCGPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhase Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : SIAPINetworkCCGPhase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCGPhase()
C#
public SIAPINetworkCCGPhase()
Managed Extensions for C++
public: SIAPINetworkCCGPhase();
C++/CLI
public:
SIAPINetworkCCGPhase();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhase Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhase Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGPhase members.

Public Methods

 | Name | Description
Public Method | GetPhasemovementPedsByNetworkSite |
Public Method | GetPhasemovementVehiclesByNetworkSite |
Top

See Also

Reference

SIAPINetworkCCGPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhasemovementPedsByNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : GetPhasemovementPedsByNetworkSite Method

networkSite

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPhasemovementPedsByNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim networkSite As ISIAPINetworkSite
Dim value As ISIAPIPhasemovement_peds

value = instance.GetPhasemovementPedsByNetworkSite(networkSite)
C#
public ISIAPIPhasemovement_peds GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
public: ISIAPIPhasemovement_peds* GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
public:
ISIAPIPhasemovement_peds^ GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhasemovementVehiclesByNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : GetPhasemovementVehiclesByNetworkSite Method

networkSite

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPhasemovementVehiclesByNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim networkSite As ISIAPINetworkSite
Dim value As ISIAPIPhasemovement_vehicles

value = instance.GetPhasemovementVehiclesByNetworkSite(networkSite)
C#
public ISIAPIPhasemovement_vehicles GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
public: ISIAPIPhasemovement_vehicles* GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
public:
ISIAPIPhasemovement_vehicles^ GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhase Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhase Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGPhase members.

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | CCGSequence |
Public Property | Dummy_maximum_green_time |
Public Property | Dummy_maximum_green_time_user |
Public Property | Dummy_minimum_green_time |
Public Property | Dummy_minimum_green_time_user |
Public Property | Has_dummy |
Public Property | Is_variable |
Public Property | IsReferencePhase |
Public Property | Minimum_time |
Public Property | Name |
Public Property | Phase_frequency |
Public Property | Phase_frequency_user |
Public Property | Phase_time |
Public Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Public Property | Yellow_time |
Top

See Also

Reference

SIAPINetworkCCGPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.All_red_time = value

value = instance.All_red_time
C#
public int All_red_time {get; set;}
Managed Extensions for C++
public: __property int get_All_red_time();
public: __property void set_All_red_time(
   int value
);
C++/CLI
public:
property int All_red_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : CCGSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CCGSequence As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As ISIAPINetworkCCGSequence

value = instance.CCGSequence
C#
public ISIAPINetworkCCGSequence CCGSequence {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGSequence* get_CCGSequence();
C++/CLI
public:
property ISIAPINetworkCCGSequence^ CCGSequence {
   ISIAPINetworkCCGSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Dummy_maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.Dummy_maximum_green_time = value

value = instance.Dummy_maximum_green_time
C#
public int Dummy_maximum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Dummy_maximum_green_time();
public: __property void set_Dummy_maximum_green_time(
   int value
);
C++/CLI
public:
property int Dummy_maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Dummy_maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.Dummy_maximum_green_time_user = value

value = instance.Dummy_maximum_green_time_user
C#
public bool Dummy_maximum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Dummy_maximum_green_time_user();
public: __property void set_Dummy_maximum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Dummy_maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Dummy_minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.Dummy_minimum_green_time = value

value = instance.Dummy_minimum_green_time
C#
public int Dummy_minimum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Dummy_minimum_green_time();
public: __property void set_Dummy_minimum_green_time(
   int value
);
C++/CLI
public:
property int Dummy_minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Dummy_minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.Dummy_minimum_green_time_user = value

value = instance.Dummy_minimum_green_time_user
C#
public bool Dummy_minimum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Dummy_minimum_green_time_user();
public: __property void set_Dummy_minimum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Dummy_minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.Has_dummy = value

value = instance.Has_dummy
C#
public bool Has_dummy {get; set;}
Managed Extensions for C++
public: __property bool get_Has_dummy();
public: __property void set_Has_dummy(
   bool value
);
C++/CLI
public:
property bool Has_dummy {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_variable Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Is_variable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_variable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.Is_variable = value

value = instance.Is_variable
C#
public bool Is_variable {get; set;}
Managed Extensions for C++
public: __property bool get_Is_variable();
public: __property void set_Is_variable(
   bool value
);
C++/CLI
public:
property bool Is_variable {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.IsReferencePhase = value

value = instance.IsReferencePhase
C#
public bool IsReferencePhase {get; set;}
Managed Extensions for C++
public: __property bool get_IsReferencePhase();
public: __property void set_IsReferencePhase(
   bool value
);
C++/CLI
public:
property bool IsReferencePhase {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Minimum_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.Minimum_time = value

value = instance.Minimum_time
C#
public int Minimum_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_time();
public: __property void set_Minimum_time(
   int value
);
C++/CLI
public:
property int Minimum_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Phase_frequency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_frequency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Single

instance.Phase_frequency = value

value = instance.Phase_frequency
C#
public float Phase_frequency {get; set;}
Managed Extensions for C++
public: __property float get_Phase_frequency();
public: __property void set_Phase_frequency(
   float value
);
C++/CLI
public:
property float Phase_frequency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Phase_frequency_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_frequency_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Boolean

instance.Phase_frequency_user = value

value = instance.Phase_frequency_user
C#
public bool Phase_frequency_user {get; set;}
Managed Extensions for C++
public: __property bool get_Phase_frequency_user();
public: __property void set_Phase_frequency_user(
   bool value
);
C++/CLI
public:
property bool Phase_frequency_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.Phase_time = value

value = instance.Phase_time
C#
public int Phase_time {get; set;}
Managed Extensions for C++
public: __property int get_Phase_time();
public: __property void set_Phase_time(
   int value
);
C++/CLI
public:
property int Phase_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Position Property

Glossary Item Box

The Phase Position in the Sequence's Phases collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhase Class : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhase
Dim value As Integer

instance.Yellow_time = value

value = instance.Yellow_time
C#
public int Yellow_time {get; set;}
Managed Extensions for C++
public: __property int get_Yellow_time();
public: __property void set_Yellow_time(
   int value
);
C++/CLI
public:
property int Yellow_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhase Class
SIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhases Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhases Class

Glossary Item Box

Object Model

SIAPINetworkCCGPhases ClassISIAPINetworkCCGPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCGPhases
   Implements ISIAPINetworkCCGPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
C#
public sealed class SIAPINetworkCCGPhases : ISIAPINetworkCCGPhases
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCGPhases : public ISIAPINetworkCCGPhases
C++/CLI
public ref class SIAPINetworkCCGPhases sealed : public ISIAPINetworkCCGPhases

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCGPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhases Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhases Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCGPhases.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCGPhases Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhaseExists |
Top

See Also

Reference

SIAPINetworkCCGPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhases Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class : SIAPINetworkCCGPhases Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCGPhases()
C#
public SIAPINetworkCCGPhases()
Managed Extensions for C++
public: SIAPINetworkCCGPhases();
C++/CLI
public:
SIAPINetworkCCGPhases();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhases Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGPhases members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhaseExists |
Top

See Also

Reference

SIAPINetworkCCGPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhaseExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class : PhaseExists Method

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PhaseExists( _
   ByVal phasename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
Dim phasename As String
Dim value As Boolean

value = instance.PhaseExists(phasename)
C#
public bool PhaseExists(
   string phasename
)
Managed Extensions for C++
public: bool PhaseExists(
   string* phasename
)
C++/CLI
public:
bool PhaseExists(
   String^ phasename
)

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGPhases Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGPhases members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPINetworkCCGPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class > Item Property : Item(String) Property

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal phasename As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
Dim phasename As String
Dim value As ISIAPINetworkCCGPhase

value = instance.Item(phasename)
C#
public ISIAPINetworkCCGPhase Item(
   string phasename
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGPhase* get_Item(
   string* phasename
);
C++/CLI
public:
property ISIAPINetworkCCGPhase^ Item {
   ISIAPINetworkCCGPhase^ get(String^ phasename);
}

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGPhases Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGPhases
Dim index As Integer
Dim value As ISIAPINetworkCCGPhase

value = instance.Item(index)
C#
public ISIAPINetworkCCGPhase Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGPhase* get_Item(
   int index
);
C++/CLI
public:
property ISIAPINetworkCCGPhase^ Item {
   ISIAPINetworkCCGPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGPhases Class
SIAPINetworkCCGPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGs Class

Glossary Item Box

Object Model

SIAPINetworkCCGs ClassISIAPINetworkCCG Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCGs
   Implements ISIAPINetworkCCGs
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
C#
public sealed class SIAPINetworkCCGs : ISIAPINetworkCCGs
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCGs : public ISIAPINetworkCCGs
C++/CLI
public ref class SIAPINetworkCCGs sealed : public ISIAPINetworkCCGs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCGs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGs Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCGs.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCGs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | NetworkCCGExists | Queries whether a particular Network Common Control Group (CCG) exists in the collection
Top

See Also

Reference

SIAPINetworkCCGs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class : SIAPINetworkCCGs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCGs()
C#
public SIAPINetworkCCGs()
Managed Extensions for C++
public: SIAPINetworkCCGs();
C++/CLI
public:
SIAPINetworkCCGs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGs Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | NetworkCCGExists | Queries whether a particular Network Common Control Group (CCG) exists in the collection
Top

See Also

Reference

SIAPINetworkCCGs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class : NetworkCCGExists Method

ccgName
CCG name to query

Glossary Item Box

Queries whether a particular Network Common Control Group (CCG) exists in the collection

Syntax

Visual Basic (Declaration)
Public Function NetworkCCGExists( _
   ByVal ccgName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
Dim ccgName As String
Dim value As Boolean

value = instance.NetworkCCGExists(ccgName)
C#
public bool NetworkCCGExists(
   string ccgName
)
Managed Extensions for C++
public: bool NetworkCCGExists(
   string* ccgName
)
C++/CLI
public:
bool NetworkCCGExists(
   String^ ccgName
)

Parameters

ccgName
CCG name to query

Return Value

Type: System.Bool

True, if a Network CCG with the given CCG name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGs Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPINetworkCCGs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class > Item Property : Item(String) Property

ccgName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal ccgName As String _
) As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
Dim ccgName As String
Dim value As ISIAPINetworkCCG

value = instance.Item(ccgName)
C#
public ISIAPINetworkCCG Item(
   string ccgName
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCG* get_Item(
   string* ccgName
);
C++/CLI
public:
property ISIAPINetworkCCG^ Item {
   ISIAPINetworkCCG^ get(String^ ccgName);
}

Parameters

ccgName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGs Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGs
Dim index As Integer
Dim value As ISIAPINetworkCCG

value = instance.Item(index)
C#
public ISIAPINetworkCCG Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCG* get_Item(
   int index
);
C++/CLI
public:
property ISIAPINetworkCCG^ Item {
   ISIAPINetworkCCG^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGs Class
SIAPINetworkCCGs Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequence Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequence Class

Glossary Item Box

Object Model

SIAPINetworkCCGSequence ClassISIAPINetworkCCGPhases InterfaceISIAPINetworkCCGPhase InterfaceISIAPINetworkCCG Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCGSequence
   Implements ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
C#
public sealed class SIAPINetworkCCGSequence : ISIAPINetworkCCGSequence
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCGSequence : public ISIAPINetworkCCGSequence
C++/CLI
public ref class SIAPINetworkCCGSequence sealed : public ISIAPINetworkCCGSequence

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCGSequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequence Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequence Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCGSequence.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCGSequence Constructor |
Top

Public Properties

 | Name | Description
Public Property | Actuated_gap_major_mov |
Public Property | Actuated_gap_minor_mov |
Public Property | Actuated_max_green_major_mov |
Public Property | Actuated_max_green_minor_mov |
Public Property | CCGPhases |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | Eff_det_zone_len_major_mov |
Public Property | Eff_det_zone_len_minor_mov |
Public Property | Green_split_priority_option |
Public Property | Is_selected |
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | NetworkCCG |
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | Position | The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | Usergiven_cycle_time |
Public Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Public Method | AddCCGPhase | Add a new Phase to the end of this Sequence.
Public Method | CloneCCGPhase | Clone a Phase.
Public Method | InsertCCGPhase | Insert a new Phase into this Sequence at the specified position.
Public Method | MoveCCGPhaseTo | Move a Phase to a new position.
Public Method | RemoveCCGPhase | Remove a Phase from this Sequence.
Top

See Also

Reference

SIAPINetworkCCGSequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequence Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : SIAPINetworkCCGSequence Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCGSequence()
C#
public SIAPINetworkCCGSequence()
Managed Extensions for C++
public: SIAPINetworkCCGSequence();
C++/CLI
public:
SIAPINetworkCCGSequence();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequence Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequence Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGSequence members.

Public Methods

 | Name | Description
Public Method | AddCCGPhase | Add a new Phase to the end of this Sequence.
Public Method | CloneCCGPhase | Clone a Phase.
Public Method | InsertCCGPhase | Insert a new Phase into this Sequence at the specified position.
Public Method | MoveCCGPhaseTo | Move a Phase to a new position.
Public Method | RemoveCCGPhase | Remove a Phase from this Sequence.
Top

See Also

Reference

SIAPINetworkCCGSequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : AddCCGPhase Method

name
The name of the new Phase.

Glossary Item Box

Add a new Phase to the end of this Sequence.

Syntax

Visual Basic (Declaration)
Public Function AddCCGPhase( _
   ByVal name As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim name As String
Dim value As ISIAPINetworkCCGPhase

value = instance.AddCCGPhase(name)
C#
public ISIAPINetworkCCGPhase AddCCGPhase(
   string name
)
Managed Extensions for C++
public: ISIAPINetworkCCGPhase* AddCCGPhase(
   string* name
)
C++/CLI
public:
ISIAPINetworkCCGPhase^ AddCCGPhase(
   String^ name
)

Parameters

name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : CloneCCGPhase Method

ccgPhase
The Phase to clone.

Glossary Item Box

Clone a Phase.

Syntax

Visual Basic (Declaration)
Public Function CloneCCGPhase( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim value As ISIAPINetworkCCGPhase

value = instance.CloneCCGPhase(ccgPhase)
C#
public ISIAPINetworkCCGPhase CloneCCGPhase(
   ISIAPINetworkCCGPhase ccgPhase
)
Managed Extensions for C++
public: ISIAPINetworkCCGPhase* CloneCCGPhase(
   ISIAPINetworkCCGPhase* ccgPhase
)
C++/CLI
public:
ISIAPINetworkCCGPhase^ CloneCCGPhase(
   ISIAPINetworkCCGPhase^ ccgPhase
)

Parameters

ccgPhase
The Phase to clone.

Return Value

The new cloned Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : InsertCCGPhase Method

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Glossary Item Box

Insert a new Phase into this Sequence at the specified position.

Syntax

Visual Basic (Declaration)
Public Function InsertCCGPhase( _
   ByVal position As Integer, _
   ByVal name As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim position As Integer
Dim name As String
Dim value As ISIAPINetworkCCGPhase

value = instance.InsertCCGPhase(position, name)
C#
public ISIAPINetworkCCGPhase InsertCCGPhase(
   int position,
   string name
)
Managed Extensions for C++
public: ISIAPINetworkCCGPhase* InsertCCGPhase(
   int position,
   string* name
)
C++/CLI
public:
ISIAPINetworkCCGPhase^ InsertCCGPhase(
   int position,
   String^ name
)

Parameters

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveCCGPhaseTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : MoveCCGPhaseTo Method

ccgPhase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Glossary Item Box

Move a Phase to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveCCGPhaseTo( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveCCGPhaseTo(ccgPhase, newPosition)
C#
public bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase ccgPhase,
   int newPosition
)
Managed Extensions for C++
public: bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase* ccgPhase,
   int newPosition
)
C++/CLI
public:
bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase^ ccgPhase,
   int newPosition
)

Parameters

ccgPhase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Return Value

true if the Phase is successfully moved; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : RemoveCCGPhase Method

ccgPhase
The Phase to remove.

Glossary Item Box

Remove a Phase from this Sequence.

Syntax

Visual Basic (Declaration)
Public Function RemoveCCGPhase( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim value As Boolean

value = instance.RemoveCCGPhase(ccgPhase)
C#
public bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase ccgPhase
)
Managed Extensions for C++
public: bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase* ccgPhase
)
C++/CLI
public:
bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase^ ccgPhase
)

Parameters

ccgPhase
The Phase to remove.

Return Value

true if the Phase is successfully removed; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequence Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequence Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGSequence members.

Public Properties

 | Name | Description
Public Property | Actuated_gap_major_mov |
Public Property | Actuated_gap_minor_mov |
Public Property | Actuated_max_green_major_mov |
Public Property | Actuated_max_green_minor_mov |
Public Property | CCGPhases |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | Eff_det_zone_len_major_mov |
Public Property | Eff_det_zone_len_minor_mov |
Public Property | Green_split_priority_option |
Public Property | Is_selected |
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | NetworkCCG |
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | Position | The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | Usergiven_cycle_time |
Public Property | Variable_phasing_perf_measure |
Top

See Also

Reference

SIAPINetworkCCGSequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Actuated_gap_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_gap_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_gap_major_mov = value

value = instance.Actuated_gap_major_mov
C#
public float Actuated_gap_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_gap_major_mov();
public: __property void set_Actuated_gap_major_mov(
   float value
);
C++/CLI
public:
property float Actuated_gap_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Actuated_gap_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_gap_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_gap_minor_mov = value

value = instance.Actuated_gap_minor_mov
C#
public float Actuated_gap_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_gap_minor_mov();
public: __property void set_Actuated_gap_minor_mov(
   float value
);
C++/CLI
public:
property float Actuated_gap_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Actuated_max_green_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_max_green_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_max_green_major_mov = value

value = instance.Actuated_max_green_major_mov
C#
public float Actuated_max_green_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_max_green_major_mov();
public: __property void set_Actuated_max_green_major_mov(
   float value
);
C++/CLI
public:
property float Actuated_max_green_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Actuated_max_green_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_max_green_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_max_green_minor_mov = value

value = instance.Actuated_max_green_minor_mov
C#
public float Actuated_max_green_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_max_green_minor_mov();
public: __property void set_Actuated_max_green_minor_mov(
   float value
);
C++/CLI
public:
property float Actuated_max_green_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGPhases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : CCGPhases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CCGPhases As ISIAPINetworkCCGPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCGPhases

value = instance.CCGPhases
C#
public ISIAPINetworkCCGPhases CCGPhases {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGPhases* get_CCGPhases();
C++/CLI
public:
property ISIAPINetworkCCGPhases^ CCGPhases {
   ISIAPINetworkCCGPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Public Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
public int Cycle_time_option {get; set;}
Managed Extensions for C++
public: __property int get_Cycle_time_option();
public: __property void set_Cycle_time_option(
   int value
);
C++/CLI
public:
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Cycle Time,
1 = Optimum Cycle Time,
2 = User-Given Cycle Time,
3 = User-Given Phase Time,
4 = Optimum Maximum Green Settings.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Eff_det_zone_len_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Eff_det_zone_len_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Eff_det_zone_len_major_mov = value

value = instance.Eff_det_zone_len_major_mov
C#
public float Eff_det_zone_len_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Eff_det_zone_len_major_mov();
public: __property void set_Eff_det_zone_len_major_mov(
   float value
);
C++/CLI
public:
property float Eff_det_zone_len_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Eff_det_zone_len_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Eff_det_zone_len_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Single

instance.Eff_det_zone_len_minor_mov = value

value = instance.Eff_det_zone_len_minor_mov
C#
public float Eff_det_zone_len_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Eff_det_zone_len_minor_mov();
public: __property void set_Eff_det_zone_len_minor_mov(
   float value
);
C++/CLI
public:
property float Eff_det_zone_len_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Green_split_priority_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
public int Green_split_priority_option {get; set;}
Managed Extensions for C++
public: __property int get_Green_split_priority_option();
public: __property void set_Green_split_priority_option(
   int value
);
C++/CLI
public:
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_selected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Is_selected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Boolean

instance.Is_selected = value

value = instance.Is_selected
C#
public bool Is_selected {get; set;}
Managed Extensions for C++
public: __property bool get_Is_selected();
public: __property void set_Is_selected(
   bool value
);
C++/CLI
public:
property bool Is_selected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCG Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : NetworkCCG Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkCCG As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCG

value = instance.NetworkCCG
C#
public ISIAPINetworkCCG NetworkCCG {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCG* get_NetworkCCG();
C++/CLI
public:
property ISIAPINetworkCCG^ NetworkCCG {
   ISIAPINetworkCCG^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
public int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_increment();
public: __property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
public int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_lower();
public: __property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
public bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
public: __property bool get_Optimum_cycle_time_lower_user();
public: __property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
public:
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
public int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_optim_method();
public: __property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
public int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_perf_measure();
public: __property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
public int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_upper();
public: __property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
public int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_optim_method();
public: __property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
public int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_increment();
public: __property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
public int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_lower();
public: __property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
public int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_upper();
public: __property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
public int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_perf_measure();
public: __property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Position Property

Glossary Item Box

The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
public int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
public: __property int get_Practical_cycle_rounding();
public: __property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
public:
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
public int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
public: __property int get_Practical_max_cycle_time();
public: __property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
public:
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Usergiven_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Usergiven_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Usergiven_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Usergiven_cycle_time = value

value = instance.Usergiven_cycle_time
C#
public int Usergiven_cycle_time {get; set;}
Managed Extensions for C++
public: __property int get_Usergiven_cycle_time();
public: __property void set_Usergiven_cycle_time(
   int value
);
C++/CLI
public:
property int Usergiven_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequence Class : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequence
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
public int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Variable_phasing_perf_measure();
public: __property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
public:
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequence Class
SIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequences Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequences Class

Glossary Item Box

Object Model

SIAPINetworkCCGSequences ClassISIAPINetworkCCGSequence Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkCCGSequences
   Implements ISIAPINetworkCCGSequences
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
C#
public sealed class SIAPINetworkCCGSequences : ISIAPINetworkCCGSequences
Managed Extensions for C++
public __gc __sealed class SIAPINetworkCCGSequences : public ISIAPINetworkCCGSequences
C++/CLI
public ref class SIAPINetworkCCGSequences sealed : public ISIAPINetworkCCGSequences

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkCCGSequences

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequences Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequences Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkCCGSequences.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkCCGSequences Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Public Property | SelectedSequence |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | SequenceExists |
Top

See Also

Reference

SIAPINetworkCCGSequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequences Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : SIAPINetworkCCGSequences Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkCCGSequences()
C#
public SIAPINetworkCCGSequences()
Managed Extensions for C++
public: SIAPINetworkCCGSequences();
C++/CLI
public:
SIAPINetworkCCGSequences();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequences Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequences Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGSequences members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | SequenceExists |
Top

See Also

Reference

SIAPINetworkCCGSequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SequenceExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : SequenceExists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SequenceExists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim name As String
Dim value As Boolean

value = instance.SequenceExists(name)
C#
public bool SequenceExists(
   string name
)
Managed Extensions for C++
public: bool SequenceExists(
   string* name
)
C++/CLI
public:
bool SequenceExists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkCCGSequences Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkCCGSequences Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkCCGSequences members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Public Property | SelectedSequence |
Top

See Also

Reference

SIAPINetworkCCGSequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class > Item Property : Item(String) Property

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim name As String
Dim value As ISIAPINetworkCCGSequence

value = instance.Item(name)
C#
public ISIAPINetworkCCGSequence Item(
   string name
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGSequence* get_Item(
   string* name
);
C++/CLI
public:
property ISIAPINetworkCCGSequence^ Item {
   ISIAPINetworkCCGSequence^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim index As Integer
Dim value As ISIAPINetworkCCGSequence

value = instance.Item(index)
C#
public ISIAPINetworkCCGSequence Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGSequence* get_Item(
   int index
);
C++/CLI
public:
property ISIAPINetworkCCGSequence^ Item {
   ISIAPINetworkCCGSequence^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SelectedSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkCCGSequences Class : SelectedSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedSequence As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkCCGSequences
Dim value As ISIAPINetworkCCGSequence

value = instance.SelectedSequence
C#
public ISIAPINetworkCCGSequence SelectedSequence {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCGSequence* get_SelectedSequence();
C++/CLI
public:
property ISIAPINetworkCCGSequence^ SelectedSequence {
   ISIAPINetworkCCGSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkCCGSequences Class
SIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkDemandSensitivity Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkDemandSensitivity Class

Glossary Item Box

Object Model

SIAPINetworkDemandSensitivity ClassISIAPINetwork InterfaceISIAPISensitivity Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkDemandSensitivity
   Implements ISIAPINetworkDemandSensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
C#
public sealed class SIAPINetworkDemandSensitivity : ISIAPINetworkDemandSensitivity
Managed Extensions for C++
public __gc __sealed class SIAPINetworkDemandSensitivity : public ISIAPINetworkDemandSensitivity
C++/CLI
public ref class SIAPINetworkDemandSensitivity sealed : public ISIAPINetworkDemandSensitivity

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkDemandSensitivity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkDemandSensitivity Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkDemandSensitivity Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkDemandSensitivity.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkDemandSensitivity Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis_option | Analysis Option
Public Property | Design_Life_Constant_num_years |
Public Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Public Property | Design_Life_Is_constant_num_years_applied |
Public Property | Design_Life_Objective | Design Life Analysis Objective
Public Property | Design_Life_Years |
Public Property | Flow_Scale_Constant_factor |
Public Property | Flow_Scale_Is_constant_factor_applied |
Public Property | Flow_Scale_Lower |
Public Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Public Property | Flow_Scale_Upper |
Public Property | Network |
Public Property | Result_option | Results For
Public Property | SensitivityGeneralParameterGroup |
Top

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkDemandSensitivity Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : SIAPINetworkDemandSensitivity Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkDemandSensitivity()
C#
public SIAPINetworkDemandSensitivity()
Managed Extensions for C++
public: SIAPINetworkDemandSensitivity();
C++/CLI
public:
SIAPINetworkDemandSensitivity();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkDemandSensitivity Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkDemandSensitivity Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkDemandSensitivity members.

Public Properties

 | Name | Description
Public Property | Analysis_option | Analysis Option
Public Property | Design_Life_Constant_num_years |
Public Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Public Property | Design_Life_Is_constant_num_years_applied |
Public Property | Design_Life_Objective | Design Life Analysis Objective
Public Property | Design_Life_Years |
Public Property | Flow_Scale_Constant_factor |
Public Property | Flow_Scale_Is_constant_factor_applied |
Public Property | Flow_Scale_Lower |
Public Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Public Property | Flow_Scale_Upper |
Public Property | Network |
Public Property | Result_option | Results For
Public Property | SensitivityGeneralParameterGroup |
Top

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Analysis_option Property

Glossary Item Box

Analysis Option

Syntax

Visual Basic (Declaration)
Public Property Analysis_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Analysis_option = value

value = instance.Analysis_option
C#
public int Analysis_option {get; set;}
Managed Extensions for C++
public: __property int get_Analysis_option();
public: __property void set_Analysis_option(
   int value
);
C++/CLI
public:
property int Analysis_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Sensitivity,
2 = Design Life,
3 = Flow Scale.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Constant_num_years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Design_Life_Constant_num_years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Constant_num_years As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Constant_num_years = value

value = instance.Design_Life_Constant_num_years
C#
public int Design_Life_Constant_num_years {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Constant_num_years();
public: __property void set_Design_Life_Constant_num_years(
   int value
);
C++/CLI
public:
property int Design_Life_Constant_num_years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Growth_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Design_Life_Growth_Model Property

Glossary Item Box

Design Life Analysis Growth Model

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Growth_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Growth_Model = value

value = instance.Design_Life_Growth_Model
C#
public int Design_Life_Growth_Model {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Growth_Model();
public: __property void set_Design_Life_Growth_Model(
   int value
);
C++/CLI
public:
property int Design_Life_Growth_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Uniform,
1 = Compound.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Is_constant_num_years_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Design_Life_Is_constant_num_years_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Is_constant_num_years_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Boolean

instance.Design_Life_Is_constant_num_years_applied = value

value = instance.Design_Life_Is_constant_num_years_applied
C#
public bool Design_Life_Is_constant_num_years_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Design_Life_Is_constant_num_years_applied();
public: __property void set_Design_Life_Is_constant_num_years_applied(
   bool value
);
C++/CLI
public:
property bool Design_Life_Is_constant_num_years_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Design_Life_Objective Property

Glossary Item Box

Design Life Analysis Objective

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Objective = value

value = instance.Design_Life_Objective
C#
public int Design_Life_Objective {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Objective();
public: __property void set_Design_Life_Objective(
   int value
);
C++/CLI
public:
property int Design_Life_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
4 = Final Year,
5 = Network Level of Service Target.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Design_Life_Years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Design_Life_Years As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Years = value

value = instance.Design_Life_Years
C#
public int Design_Life_Years {get; set;}
Managed Extensions for C++
public: __property int get_Design_Life_Years();
public: __property void set_Design_Life_Years(
   int value
);
C++/CLI
public:
property int Design_Life_Years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Flow_Scale_Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Constant_factor = value

value = instance.Flow_Scale_Constant_factor
C#
public float Flow_Scale_Constant_factor {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Constant_factor();
public: __property void set_Flow_Scale_Constant_factor(
   float value
);
C++/CLI
public:
property float Flow_Scale_Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Flow_Scale_Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Boolean

instance.Flow_Scale_Is_constant_factor_applied = value

value = instance.Flow_Scale_Is_constant_factor_applied
C#
public bool Flow_Scale_Is_constant_factor_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Flow_Scale_Is_constant_factor_applied();
public: __property void set_Flow_Scale_Is_constant_factor_applied(
   bool value
);
C++/CLI
public:
property bool Flow_Scale_Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Flow_Scale_Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Lower = value

value = instance.Flow_Scale_Lower
C#
public float Flow_Scale_Lower {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Lower();
public: __property void set_Flow_Scale_Lower(
   float value
);
C++/CLI
public:
property float Flow_Scale_Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Flow_Scale_Objective Property

Glossary Item Box

Flow Scale Analysis Objective

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Flow_Scale_Objective = value

value = instance.Flow_Scale_Objective
C#
public int Flow_Scale_Objective {get; set;}
Managed Extensions for C++
public: __property int get_Flow_Scale_Objective();
public: __property void set_Flow_Scale_Objective(
   int value
);
C++/CLI
public:
property int Flow_Scale_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
4 = Final Year,
5 = Network Level of Service Target.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Flow_Scale_Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Flow_Scale_Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Upper = value

value = instance.Flow_Scale_Upper
C#
public float Flow_Scale_Upper {get; set;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Upper();
public: __property void set_Flow_Scale_Upper(
   float value
);
C++/CLI
public:
property float Flow_Scale_Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : Result_option Property

Glossary Item Box

Results For

Syntax

Visual Basic (Declaration)
Public Property Result_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As Integer

instance.Result_option = value

value = instance.Result_option
C#
public int Result_option {get; set;}
Managed Extensions for C++
public: __property int get_Result_option();
public: __property void set_Result_option(
   int value
);
C++/CLI
public:
property int Result_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Network (Vehicles),
2 = Network (Pedestrians),
3 = Network (Persons).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityGeneralParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkDemandSensitivity Class : SensitivityGeneralParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SensitivityGeneralParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkDemandSensitivity
Dim value As ISIAPISensitivity

value = instance.SensitivityGeneralParameterGroup
C#
public ISIAPISensitivity SensitivityGeneralParameterGroup {get;}
Managed Extensions for C++
public: __property ISIAPISensitivity* get_SensitivityGeneralParameterGroup();
C++/CLI
public:
property ISIAPISensitivity^ SensitivityGeneralParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkDemandSensitivity Class
SIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnection Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnection Class

Glossary Item Box

Object Model

SIAPINetworkLegConnection ClassISIAPINetwork InterfaceISIAPINetworkSite InterfaceISIAPINetworkSite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkLegConnection
   Implements ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
C#
public sealed class SIAPINetworkLegConnection : ISIAPINetworkLegConnection
Managed Extensions for C++
public __gc __sealed class SIAPINetworkLegConnection : public ISIAPINetworkLegConnection
C++/CLI
public ref class SIAPINetworkLegConnection sealed : public ISIAPINetworkLegConnection

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkLegConnection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnection Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnection Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkLegConnection.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkLegConnection Constructor |
Top

Public Properties

 | Name | Description
Public Property | ConnectionType |
Public Property | Leg1_Orientation |
Public Property | Leg2_Orientation |
Public Property | Network |
Public Property | NetworkSite1 |
Public Property | NetworkSite2 |
Public Property | Site1_Name |
Public Property | Site2_Name |
Public Property | ZIndex |
Top

See Also

Reference

SIAPINetworkLegConnection Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnection Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : SIAPINetworkLegConnection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkLegConnection()
C#
public SIAPINetworkLegConnection()
Managed Extensions for C++
public: SIAPINetworkLegConnection();
C++/CLI
public:
SIAPINetworkLegConnection();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnection Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnection Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkLegConnection members.

Public Properties

 | Name | Description
Public Property | ConnectionType |
Public Property | Leg1_Orientation |
Public Property | Leg2_Orientation |
Public Property | Network |
Public Property | NetworkSite1 |
Public Property | NetworkSite2 |
Public Property | Site1_Name |
Public Property | Site2_Name |
Public Property | ZIndex |
Top

See Also

Reference

SIAPINetworkLegConnection Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ConnectionType Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : ConnectionType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ConnectionType As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As Integer

instance.ConnectionType = value

value = instance.ConnectionType
C#
public int ConnectionType {get; set;}
Managed Extensions for C++
public: __property int get_ConnectionType();
public: __property void set_ConnectionType(
   int value
);
C++/CLI
public:
property int ConnectionType {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg1_Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : Leg1_Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg1_Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As Integer

value = instance.Leg1_Orientation
C#
public int Leg1_Orientation {get;}
Managed Extensions for C++
public: __property int get_Leg1_Orientation();
C++/CLI
public:
property int Leg1_Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg2_Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : Leg2_Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Leg2_Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As Integer

value = instance.Leg2_Orientation
C#
public int Leg2_Orientation {get;}
Managed Extensions for C++
public: __property int get_Leg2_Orientation();
C++/CLI
public:
property int Leg2_Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : NetworkSite1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSite1 As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As ISIAPINetworkSite

value = instance.NetworkSite1
C#
public ISIAPINetworkSite NetworkSite1 {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_NetworkSite1();
C++/CLI
public:
property ISIAPINetworkSite^ NetworkSite1 {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : NetworkSite2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSite2 As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As ISIAPINetworkSite

value = instance.NetworkSite2
C#
public ISIAPINetworkSite NetworkSite2 {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_NetworkSite2();
C++/CLI
public:
property ISIAPINetworkSite^ NetworkSite2 {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site1_Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : Site1_Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site1_Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As String

value = instance.Site1_Name
C#
public string Site1_Name {get;}
Managed Extensions for C++
public: __property string* get_Site1_Name();
C++/CLI
public:
property String^ Site1_Name {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site2_Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : Site2_Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site2_Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As String

value = instance.Site2_Name
C#
public string Site2_Name {get;}
Managed Extensions for C++
public: __property string* get_Site2_Name();
C++/CLI
public:
property String^ Site2_Name {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ZIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnection Class : ZIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ZIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnection
Dim value As Integer

instance.ZIndex = value

value = instance.ZIndex
C#
public int ZIndex {get; set;}
Managed Extensions for C++
public: __property int get_ZIndex();
public: __property void set_ZIndex(
   int value
);
C++/CLI
public:
property int ZIndex {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnection Class
SIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnections Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnections Class

Glossary Item Box

Object Model

SIAPINetworkLegConnections ClassISIAPINetworkLegConnection Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkLegConnections
   Implements ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnections
C#
public sealed class SIAPINetworkLegConnections : ISIAPINetworkLegConnections
Managed Extensions for C++
public __gc __sealed class SIAPINetworkLegConnections : public ISIAPINetworkLegConnections
C++/CLI
public ref class SIAPINetworkLegConnections sealed : public ISIAPINetworkLegConnections

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkLegConnections

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnections Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnections Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnections Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkLegConnections.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkLegConnections Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | Item | Gets the element at the specified index.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPINetworkLegConnections Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnections Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnections Class : SIAPINetworkLegConnections Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkLegConnections()
C#
public SIAPINetworkLegConnections()
Managed Extensions for C++
public: SIAPINetworkLegConnections();
C++/CLI
public:
SIAPINetworkLegConnections();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnections Class
SIAPINetworkLegConnections Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnections Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnections Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkLegConnections members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPINetworkLegConnections Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnections Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnections
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnections Class
SIAPINetworkLegConnections Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkLegConnections Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkLegConnections Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkLegConnections members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of elements contained in the collection.
Public Property | Item | Gets the element at the specified index.
Top

See Also

Reference

SIAPINetworkLegConnections Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnections Class : Count Property

Glossary Item Box

Gets the number of elements contained in the collection.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnections
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnections Class
SIAPINetworkLegConnections Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkLegConnections Class : Item Property

index

Type: System.Int32;
The zero-based index of the element to get.

Glossary Item Box

Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkLegConnections
Dim index As Integer
Dim value As ISIAPINetworkLegConnection

value = instance.Item(index)
C#
public ISIAPINetworkLegConnection this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPINetworkLegConnection* get_Item   int index
;
C++/CLI
public:
property ISIAPINetworkLegConnection^ default [int] {
   ISIAPINetworkLegConnection^ get(int index);
}

Parameters

index

Type: System.Int32;
The zero-based index of the element to get.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkLegConnections Class
SIAPINetworkLegConnections Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworks Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworks Class

Glossary Item Box

Object Model

SIAPINetworks ClassISIAPINetwork Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworks
   Implements ISIAPINetworks
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
C#
public sealed class SIAPINetworks : ISIAPINetworks
Managed Extensions for C++
public __gc __sealed class SIAPINetworks : public ISIAPINetworks
C++/CLI
public ref class SIAPINetworks sealed : public ISIAPINetworks

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworks

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworks Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworks Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworks.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworks Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an IEnumerator object for the collection
Public Method | GetNetworkByID | Get the Network by the database row unique ID.
Public Method | NetworkExists | Queries whether a particular Network exists in the collection
Top

See Also

Reference

SIAPINetworks Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworks Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : SIAPINetworks Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworks()
C#
public SIAPINetworks()
Managed Extensions for C++
public: SIAPINetworks();
C++/CLI
public:
SIAPINetworks();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworks Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworks Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworks members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an IEnumerator object for the collection
Public Method | GetNetworkByID | Get the Network by the database row unique ID.
Public Method | NetworkExists | Queries whether a particular Network exists in the collection
Top

See Also

Reference

SIAPINetworks Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : GetEnumerator Method

Glossary Item Box

Returns an IEnumerator object for the collection

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

Type: IEnumerator

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetNetworkByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : GetNetworkByID Method

network_id

Type: System.Int32;
The database row unique ID of the Network.
This is different from the "Network ID" in the Network Data dialog which can be accessed through ISIAPINetwork.NetworkID.

Glossary Item Box

Get the Network by the database row unique ID.

Syntax

Visual Basic (Declaration)
Public Function GetNetworkByID( _
   ByVal network_id As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim network_id As Integer
Dim value As ISIAPINetwork

value = instance.GetNetworkByID(network_id)
C#
public ISIAPINetwork GetNetworkByID(
   int network_id
)
Managed Extensions for C++
public: ISIAPINetwork* GetNetworkByID(
   int network_id
)
C++/CLI
public:
ISIAPINetwork^ GetNetworkByID(
   int network_id
)

Parameters

network_id

Type: System.Int32;
The database row unique ID of the Network.
This is different from the "Network ID" in the Network Data dialog which can be accessed through ISIAPINetwork.NetworkID.

Remarks

Use ISIAPINetworks.Item[] to get a Network by its name or its position in the Network List. In C++, use ISIAPINetworks->get_Item() to get a Network by its name or get_Item_2() by its position.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : NetworkExists Method

networkname
Network name to query

Glossary Item Box

Queries whether a particular Network exists in the collection

Syntax

Visual Basic (Declaration)
Public Function NetworkExists( _
   ByVal networkname As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim networkname As String
Dim value As Boolean

value = instance.NetworkExists(networkname)
C#
public bool NetworkExists(
   string networkname
)
Managed Extensions for C++
public: bool NetworkExists(
   string* networkname
)
C++/CLI
public:
bool NetworkExists(
   String^ networkname
)

Parameters

networkname
Network name to query

Return Value

Type: System.Bool

True, if a Network with the given name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworks Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworks Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworks members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPINetworks Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Property Value

Number of items in collection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class > Item Property : Item(String) Property

networkname

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal networkname As String _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim networkname As String
Dim value As ISIAPINetwork

value = instance.Item(networkname)
C#
public ISIAPINetwork Item(
   string networkname
) {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Item(
   string* networkname
);
C++/CLI
public:
property ISIAPINetwork^ Item {
   ISIAPINetwork^ get(String^ networkname);
}

Parameters

networkname

Property Value

Type: ISIAPINetwork

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworks Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworks
Dim index As Integer
Dim value As ISIAPINetwork

value = instance.Item(index)
C#
public ISIAPINetwork Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Item(
   int index
);
C++/CLI
public:
property ISIAPINetwork^ Item {
   ISIAPINetwork^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworks Class
SIAPINetworks Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSite Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSite Class

Glossary Item Box

Wrapper class for the Site in a particular Network

Object Model

SIAPINetworkSite ClassISIAPIDiagnosticMsgs InterfaceISIAPIDiagnosticMsg InterfaceISIAPINetwork InterfaceISIAPINetworkCCG InterfaceISIAPINetworkLegConnections InterfaceISIAPINetworkLegConnection InterfaceISIAPISite InterfaceISIAPIOutputset Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkSite
   Implements ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
C#
public sealed class SIAPINetworkSite : ISIAPINetworkSite
Managed Extensions for C++
public __gc __sealed class SIAPINetworkSite : public ISIAPINetworkSite
C++/CLI
public ref class SIAPINetworkSite sealed : public ISIAPINetworkSite

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSite Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSite Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkSite.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkSite Constructor |
Top

Public Properties

 | Name | Description
Public Property | CoordinatedOption | Coordinated Option
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | IsIncludedInProjectSummary |
Public Property | IsReference |
Public Property | LayoutX |
Public Property | LayoutY |
Public Property | Network |
Public Property | NetworkCCG |
Public Property | NetworkLegConnections |
Public Property | NetworkSite_id | The database row unique ID of the NetworkSite.
Public Property | Offset |
Public Property | Site |
Public Property | SiteName |
Public Property | SiteOutputset | Site output data of this Site in the particular Network
Top

See Also

Reference

SIAPINetworkSite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSite Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : SIAPINetworkSite Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkSite()
C#
public SIAPINetworkSite()
Managed Extensions for C++
public: SIAPINetworkSite();
C++/CLI
public:
SIAPINetworkSite();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSite Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSite Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkSite members.

Public Properties

 | Name | Description
Public Property | CoordinatedOption | Coordinated Option
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | IsIncludedInProjectSummary |
Public Property | IsReference |
Public Property | LayoutX |
Public Property | LayoutY |
Public Property | Network |
Public Property | NetworkCCG |
Public Property | NetworkLegConnections |
Public Property | NetworkSite_id | The database row unique ID of the NetworkSite.
Public Property | Offset |
Public Property | Site |
Public Property | SiteName |
Public Property | SiteOutputset | Site output data of this Site in the particular Network
Top

See Also

Reference

SIAPINetworkSite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CoordinatedOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : CoordinatedOption Property

Glossary Item Box

Coordinated Option

Syntax

Visual Basic (Declaration)
Public Property CoordinatedOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Integer

instance.CoordinatedOption = value

value = instance.CoordinatedOption
C#
public int CoordinatedOption {get; set;}
Managed Extensions for C++
public: __property int get_CoordinatedOption();
public: __property void set_CoordinatedOption(
   int value
);
C++/CLI
public:
property int CoordinatedOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = NA,
1 = Yes,
2 = No.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
public ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
public: __property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
public:
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Integer

value = instance.DiagnosticStatus
C#
public int DiagnosticStatus {get;}
Managed Extensions for C++
public: __property int get_DiagnosticStatus();
C++/CLI
public:
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
public bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInProjectSummary();
public: __property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
public:
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReference Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : IsReference Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsReference As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Boolean

instance.IsReference = value

value = instance.IsReference
C#
public bool IsReference {get; set;}
Managed Extensions for C++
public: __property bool get_IsReference();
public: __property void set_IsReference(
   bool value
);
C++/CLI
public:
property bool IsReference {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LayoutX Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : LayoutX Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LayoutX As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Single

instance.LayoutX = value

value = instance.LayoutX
C#
public float LayoutX {get; set;}
Managed Extensions for C++
public: __property float get_LayoutX();
public: __property void set_LayoutX(
   float value
);
C++/CLI
public:
property float LayoutX {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LayoutY Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : LayoutY Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LayoutY As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Single

instance.LayoutY = value

value = instance.LayoutY
C#
public float LayoutY {get; set;}
Managed Extensions for C++
public: __property float get_LayoutY();
public: __property void set_LayoutY(
   float value
);
C++/CLI
public:
property float LayoutY {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCG Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : NetworkCCG Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkCCG As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPINetworkCCG

value = instance.NetworkCCG
C#
public ISIAPINetworkCCG NetworkCCG {get;}
Managed Extensions for C++
public: __property ISIAPINetworkCCG* get_NetworkCCG();
C++/CLI
public:
property ISIAPINetworkCCG^ NetworkCCG {
   ISIAPINetworkCCG^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkLegConnections Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : NetworkLegConnections Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkLegConnections As ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPINetworkLegConnections

value = instance.NetworkLegConnections
C#
public ISIAPINetworkLegConnections NetworkLegConnections {get;}
Managed Extensions for C++
public: __property ISIAPINetworkLegConnections* get_NetworkLegConnections();
C++/CLI
public:
property ISIAPINetworkLegConnections^ NetworkLegConnections {
   ISIAPINetworkLegConnections^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : NetworkSite_id Property

Glossary Item Box

The database row unique ID of the NetworkSite.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSite_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Integer

value = instance.NetworkSite_id
C#
public int NetworkSite_id {get;}
Managed Extensions for C++
public: __property int get_NetworkSite_id();
C++/CLI
public:
property int NetworkSite_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As Integer

instance.Offset = value

value = instance.Offset
C#
public int Offset {get; set;}
Managed Extensions for C++
public: __property int get_Offset();
public: __property void set_Offset(
   int value
);
C++/CLI
public:
property int Offset {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : SiteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteName As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As String

value = instance.SiteName
C#
public string SiteName {get;}
Managed Extensions for C++
public: __property string* get_SiteName();
C++/CLI
public:
property String^ SiteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteOutputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSite Class : SiteOutputset Property

Glossary Item Box

Site output data of this Site in the particular Network

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteOutputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSite
Dim value As ISIAPIOutputset

value = instance.SiteOutputset
C#
public ISIAPIOutputset SiteOutputset {get;}
Managed Extensions for C++
public: __property ISIAPIOutputset* get_SiteOutputset();
C++/CLI
public:
property ISIAPIOutputset^ SiteOutputset {
   ISIAPIOutputset^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSite Class
SIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSites Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSites Class

Glossary Item Box

Object Model

SIAPINetworkSites ClassISIAPINetworkSite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPINetworkSites
   Implements ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
C#
public sealed class SIAPINetworkSites : ISIAPINetworkSites
Managed Extensions for C++
public __gc __sealed class SIAPINetworkSites : public ISIAPINetworkSites
C++/CLI
public ref class SIAPINetworkSites sealed : public ISIAPINetworkSites

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPINetworkSites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSites Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSites Class

Glossary Item Box

The following tables list the members exposed by SIAPINetworkSites.

Public Constructors

 | Name | Description
Public Constructor | SIAPINetworkSites Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | NetworkSiteExists | Queries whether a particular Network Site exists in the collection
Top

See Also

Reference

SIAPINetworkSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSites Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class : SIAPINetworkSites Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPINetworkSites()
C#
public SIAPINetworkSites()
Managed Extensions for C++
public: SIAPINetworkSites();
C++/CLI
public:
SIAPINetworkSites();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSites Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSites Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkSites members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | NetworkSiteExists | Queries whether a particular Network Site exists in the collection
Top

See Also

Reference

SIAPINetworkSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class : NetworkSiteExists Method

sitename
Site name to query

Glossary Item Box

Queries whether a particular Network Site exists in the collection

Syntax

Visual Basic (Declaration)
Public Function NetworkSiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
Dim sitename As String
Dim value As Boolean

value = instance.NetworkSiteExists(sitename)
C#
public bool NetworkSiteExists(
   string sitename
)
Managed Extensions for C++
public: bool NetworkSiteExists(
   string* sitename
)
C++/CLI
public:
bool NetworkSiteExists(
   String^ sitename
)

Parameters

sitename
Site name to query

Return Value

Type: System.Bool

True, if a Network Site with the given Site name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPINetworkSites Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPINetworkSites Class

Glossary Item Box

For a list of all members of this type, see SIAPINetworkSites members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPINetworkSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class > Item Property : Item(String) Property

sitename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
Dim sitename As String
Dim value As ISIAPINetworkSite

value = instance.Item(sitename)
C#
public ISIAPINetworkSite Item(
   string sitename
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_Item(
   string* sitename
);
C++/CLI
public:
property ISIAPINetworkSite^ Item {
   ISIAPINetworkSite^ get(String^ sitename);
}

Parameters

sitename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPINetworkSites Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPINetworkSites
Dim index As Integer
Dim value As ISIAPINetworkSite

value = instance.Item(index)
C#
public ISIAPINetworkSite Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_Item(
   int index
);
C++/CLI
public:
property ISIAPINetworkSite^ Item {
   ISIAPINetworkSite^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPINetworkSites Class
SIAPINetworkSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_ped Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_ped Class

Glossary Item Box

Object Model

SIAPIOpposingmovement_ped ClassISIAPIMovement_vehicle_od Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOpposingmovement_ped
   Implements ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
C#
public sealed class SIAPIOpposingmovement_ped : ISIAPIOpposingmovement_ped
Managed Extensions for C++
public __gc __sealed class SIAPIOpposingmovement_ped : public ISIAPIOpposingmovement_ped
C++/CLI
public ref class SIAPIOpposingmovement_ped sealed : public ISIAPIOpposingmovement_ped

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOpposingmovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_ped Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_ped Class

Glossary Item Box

The following tables list the members exposed by SIAPIOpposingmovement_ped.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOpposingmovement_ped Constructor |
Top

Public Properties

 | Name | Description
Public Property | Movement_vehicle_od |
Public Property | Opposing |
Public Property | Opposingmovement_ped_origin |
Public Property | Opposingmovement_ped_stage |
Public Property | Opposingmovement_ped_type |
Top

See Also

Reference

SIAPIOpposingmovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_ped Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : SIAPIOpposingmovement_ped Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOpposingmovement_ped()
C#
public SIAPIOpposingmovement_ped()
Managed Extensions for C++
public: SIAPIOpposingmovement_ped();
C++/CLI
public:
SIAPIOpposingmovement_ped();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_ped Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_ped Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_ped members.

Public Properties

 | Name | Description
Public Property | Movement_vehicle_od |
Public Property | Opposing |
Public Property | Opposingmovement_ped_origin |
Public Property | Opposingmovement_ped_stage |
Public Property | Opposingmovement_ped_type |
Top

See Also

Reference

SIAPIOpposingmovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
public ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
public:
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : Opposing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
Dim value As Boolean

instance.Opposing = value

value = instance.Opposing
C#
public bool Opposing {get; set;}
Managed Extensions for C++
public: __property bool get_Opposing();
public: __property void set_Opposing(
   bool value
);
C++/CLI
public:
property bool Opposing {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : Opposingmovement_ped_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_ped_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_origin
C#
public int Opposingmovement_ped_origin {get;}
Managed Extensions for C++
public: __property int get_Opposingmovement_ped_origin();
C++/CLI
public:
property int Opposingmovement_ped_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : Opposingmovement_ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_stage
C#
public int Opposingmovement_ped_stage {get;}
Managed Extensions for C++
public: __property int get_Opposingmovement_ped_stage();
C++/CLI
public:
property int Opposingmovement_ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_ped Class : Opposingmovement_ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_type
C#
public int Opposingmovement_ped_type {get;}
Managed Extensions for C++
public: __property int get_Opposingmovement_ped_type();
C++/CLI
public:
property int Opposingmovement_ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_ped Class
SIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_peds Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_peds Class

Glossary Item Box

Object Model

SIAPIOpposingmovement_peds ClassISIAPIOpposingmovement_ped Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOpposingmovement_peds
   Implements ISIAPIOpposingmovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
C#
public sealed class SIAPIOpposingmovement_peds : ISIAPIOpposingmovement_peds
Managed Extensions for C++
public __gc __sealed class SIAPIOpposingmovement_peds : public ISIAPIOpposingmovement_peds
C++/CLI
public ref class SIAPIOpposingmovement_peds sealed : public ISIAPIOpposingmovement_peds

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOpposingmovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_peds Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_peds Class

Glossary Item Box

The following tables list the members exposed by SIAPIOpposingmovement_peds.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOpposingmovement_peds Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | OpposingmovementPedExists |
Top

See Also

Reference

SIAPIOpposingmovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_peds Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class : SIAPIOpposingmovement_peds Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOpposingmovement_peds()
C#
public SIAPIOpposingmovement_peds()
Managed Extensions for C++
public: SIAPIOpposingmovement_peds();
C++/CLI
public:
SIAPIOpposingmovement_peds();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_peds Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_peds members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | OpposingmovementPedExists |
Top

See Also

Reference

SIAPIOpposingmovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpposingmovementPedExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class : OpposingmovementPedExists Method

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function OpposingmovementPedExists( _
   ByVal opposing_ped_type As Integer, _
   ByVal opposing_ped_origin As Integer, _
   ByVal opposin_ped_stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
Dim opposing_ped_type As Integer
Dim opposing_ped_origin As Integer
Dim opposin_ped_stage As Integer
Dim value As Boolean

value = instance.OpposingmovementPedExists(opposing_ped_type, opposing_ped_origin, opposin_ped_stage)
C#
public bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)
Managed Extensions for C++
public: bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)
C++/CLI
public:
bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)

Parameters

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_peds Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_peds members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIOpposingmovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(Int32,Int32,Int32) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32,Int32,Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class > Item Property : Item(Int32,Int32,Int32) Property

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal opposing_ped_type As Integer, _
   ByVal opposing_ped_origin As Integer, _
   ByVal opposin_ped_stage As Integer _
) As ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
Dim opposing_ped_type As Integer
Dim opposing_ped_origin As Integer
Dim opposin_ped_stage As Integer
Dim value As ISIAPIOpposingmovement_ped

value = instance.Item(opposing_ped_type, opposing_ped_origin, opposin_ped_stage)
C#
public ISIAPIOpposingmovement_ped Item(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
) {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_ped* get_Item(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
);
C++/CLI
public:
property ISIAPIOpposingmovement_ped^ Item {
   ISIAPIOpposingmovement_ped^ get(int opposing_ped_type, int opposing_ped_origin, int opposin_ped_stage);
}

Parameters

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_peds Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_peds
Dim index As Integer
Dim value As ISIAPIOpposingmovement_ped

value = instance.Item(index)
C#
public ISIAPIOpposingmovement_ped Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_ped* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIOpposingmovement_ped^ Item {
   ISIAPIOpposingmovement_ped^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_peds Class
SIAPIOpposingmovement_peds Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicle Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicle Class

Glossary Item Box

Object Model

SIAPIOpposingmovement_vehicle ClassISIAPIMovement_vehicle_od Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOpposingmovement_vehicle
   Implements ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicle
C#
public sealed class SIAPIOpposingmovement_vehicle : ISIAPIOpposingmovement_vehicle
Managed Extensions for C++
public __gc __sealed class SIAPIOpposingmovement_vehicle : public ISIAPIOpposingmovement_vehicle
C++/CLI
public ref class SIAPIOpposingmovement_vehicle sealed : public ISIAPIOpposingmovement_vehicle

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOpposingmovement_vehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicle Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicle Class

Glossary Item Box

The following tables list the members exposed by SIAPIOpposingmovement_vehicle.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOpposingmovement_vehicle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Movement_vehicle_od |
Public Property | Opposing |
Public Property | Opposingmovement_vehicle_destination |
Public Property | Opposingmovement_vehicle_origin |
Top

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicle Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicle Class : SIAPIOpposingmovement_vehicle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOpposingmovement_vehicle()
C#
public SIAPIOpposingmovement_vehicle()
Managed Extensions for C++
public: SIAPIOpposingmovement_vehicle();
C++/CLI
public:
SIAPIOpposingmovement_vehicle();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIAPIOpposingmovement_vehicle Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicle Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicle Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_vehicle members.

Public Properties

 | Name | Description
Public Property | Movement_vehicle_od |
Public Property | Opposing |
Public Property | Opposingmovement_vehicle_destination |
Public Property | Opposingmovement_vehicle_origin |
Top

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicle Class : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicle
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
public ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
public:
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicle Class : Opposing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Opposing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicle
Dim value As Boolean

instance.Opposing = value

value = instance.Opposing
C#
public bool Opposing {get; set;}
Managed Extensions for C++
public: __property bool get_Opposing();
public: __property void set_Opposing(
   bool value
);
C++/CLI
public:
property bool Opposing {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicle_destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicle Class : Opposingmovement_vehicle_destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_vehicle_destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicle
Dim value As Integer

value = instance.Opposingmovement_vehicle_destination
C#
public int Opposingmovement_vehicle_destination {get;}
Managed Extensions for C++
public: __property int get_Opposingmovement_vehicle_destination();
C++/CLI
public:
property int Opposingmovement_vehicle_destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicle_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicle Class : Opposingmovement_vehicle_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposingmovement_vehicle_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicle
Dim value As Integer

value = instance.Opposingmovement_vehicle_origin
C#
public int Opposingmovement_vehicle_origin {get;}
Managed Extensions for C++
public: __property int get_Opposingmovement_vehicle_origin();
C++/CLI
public:
property int Opposingmovement_vehicle_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicle Class
SIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicles Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicles Class

Glossary Item Box

Object Model

SIAPIOpposingmovement_vehicles ClassISIAPIOpposingmovement_vehicle Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOpposingmovement_vehicles
   Implements ISIAPIOpposingmovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
C#
public sealed class SIAPIOpposingmovement_vehicles : ISIAPIOpposingmovement_vehicles
Managed Extensions for C++
public __gc __sealed class SIAPIOpposingmovement_vehicles : public ISIAPIOpposingmovement_vehicles
C++/CLI
public ref class SIAPIOpposingmovement_vehicles sealed : public ISIAPIOpposingmovement_vehicles

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOpposingmovement_vehicles

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicles Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicles Class

Glossary Item Box

The following tables list the members exposed by SIAPIOpposingmovement_vehicles.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOpposingmovement_vehicles Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | OpposingmovementVehicleExists |
Top

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicles Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class : SIAPIOpposingmovement_vehicles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOpposingmovement_vehicles()
C#
public SIAPIOpposingmovement_vehicles()
Managed Extensions for C++
public: SIAPIOpposingmovement_vehicles();
C++/CLI
public:
SIAPIOpposingmovement_vehicles();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicles Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicles Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_vehicles members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | OpposingmovementVehicleExists |
Top

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpposingmovementVehicleExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class : OpposingmovementVehicleExists Method

opposing_veh_origin
opposing_veh_destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function OpposingmovementVehicleExists( _
   ByVal opposing_veh_origin As Integer, _
   ByVal opposing_veh_destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
Dim opposing_veh_origin As Integer
Dim opposing_veh_destination As Integer
Dim value As Boolean

value = instance.OpposingmovementVehicleExists(opposing_veh_origin, opposing_veh_destination)
C#
public bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)
Managed Extensions for C++
public: bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)
C++/CLI
public:
bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)

Parameters

opposing_veh_origin
opposing_veh_destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOpposingmovement_vehicles Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOpposingmovement_vehicles Class

Glossary Item Box

For a list of all members of this type, see SIAPIOpposingmovement_vehicles members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(Int32,Int32) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32,Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class > Item Property : Item(Int32,Int32) Property

opposing_veh_origin
opposing_veh_destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal opposing_veh_origin As Integer, _
   ByVal opposing_veh_destination As Integer _
) As ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
Dim opposing_veh_origin As Integer
Dim opposing_veh_destination As Integer
Dim value As ISIAPIOpposingmovement_vehicle

value = instance.Item(opposing_veh_origin, opposing_veh_destination)
C#
public ISIAPIOpposingmovement_vehicle Item(
   int opposing_veh_origin,
   int opposing_veh_destination
) {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_vehicle* get_Item(
   int opposing_veh_origin,
   int opposing_veh_destination
);
C++/CLI
public:
property ISIAPIOpposingmovement_vehicle^ Item {
   ISIAPIOpposingmovement_vehicle^ get(int opposing_veh_origin, int opposing_veh_destination);
}

Parameters

opposing_veh_origin
opposing_veh_destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOpposingmovement_vehicles Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOpposingmovement_vehicles
Dim index As Integer
Dim value As ISIAPIOpposingmovement_vehicle

value = instance.Item(index)
C#
public ISIAPIOpposingmovement_vehicle Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIOpposingmovement_vehicle* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIOpposingmovement_vehicle^ Item {
   ISIAPIOpposingmovement_vehicle^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOpposingmovement_vehicles Class
SIAPIOpposingmovement_vehicles Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputAnalysis Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputAnalysis Class

Glossary Item Box

Object Model

SIAPIOutputAnalysis Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputAnalysis
   Implements ISIAPIOutputAnalysis
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
C#
public sealed class SIAPIOutputAnalysis : ISIAPIOutputAnalysis
Managed Extensions for C++
public __gc __sealed class SIAPIOutputAnalysis : public ISIAPIOutputAnalysis
C++/CLI
public ref class SIAPIOutputAnalysis sealed : public ISIAPIOutputAnalysis

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputAnalysis

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputAnalysis Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputAnalysis Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputAnalysis.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputAnalysis Constructor |
Top

Public Properties

 | Name | Description
Public Property | Design_Life_Analysis_status |
Public Property | Design_Life_Selected_future_year |
Public Property | Flow_Scale_Analysis_status |
Public Property | Flow_Scale_Largest_movement_flow_scale |
Public Property | Sensitivity_Analysis_status |
Public Property | Sensitivity_Selected_parameter_scale |
Top

See Also

Reference

SIAPIOutputAnalysis Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputAnalysis Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : SIAPIOutputAnalysis Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputAnalysis()
C#
public SIAPIOutputAnalysis()
Managed Extensions for C++
public: SIAPIOutputAnalysis();
C++/CLI
public:
SIAPIOutputAnalysis();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputAnalysis Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputAnalysis Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputAnalysis members.

Public Properties

 | Name | Description
Public Property | Design_Life_Analysis_status |
Public Property | Design_Life_Selected_future_year |
Public Property | Flow_Scale_Analysis_status |
Public Property | Flow_Scale_Largest_movement_flow_scale |
Public Property | Sensitivity_Analysis_status |
Public Property | Sensitivity_Selected_parameter_scale |
Top

See Also

Reference

SIAPIOutputAnalysis Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Design_Life_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Design_Life_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Integer

value = instance.Design_Life_Analysis_status
C#
public int Design_Life_Analysis_status {get;}
Managed Extensions for C++
public: __property int get_Design_Life_Analysis_status();
C++/CLI
public:
property int Design_Life_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Selected_future_year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Design_Life_Selected_future_year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Design_Life_Selected_future_year As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Integer

value = instance.Design_Life_Selected_future_year
C#
public int Design_Life_Selected_future_year {get;}
Managed Extensions for C++
public: __property int get_Design_Life_Selected_future_year();
C++/CLI
public:
property int Design_Life_Selected_future_year {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Flow_Scale_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_Scale_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Integer

value = instance.Flow_Scale_Analysis_status
C#
public int Flow_Scale_Analysis_status {get;}
Managed Extensions for C++
public: __property int get_Flow_Scale_Analysis_status();
C++/CLI
public:
property int Flow_Scale_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Largest_movement_flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Flow_Scale_Largest_movement_flow_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_Scale_Largest_movement_flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Single

value = instance.Flow_Scale_Largest_movement_flow_scale
C#
public float Flow_Scale_Largest_movement_flow_scale {get;}
Managed Extensions for C++
public: __property float get_Flow_Scale_Largest_movement_flow_scale();
C++/CLI
public:
property float Flow_Scale_Largest_movement_flow_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sensitivity_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Sensitivity_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sensitivity_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Integer

value = instance.Sensitivity_Analysis_status
C#
public int Sensitivity_Analysis_status {get;}
Managed Extensions for C++
public: __property int get_Sensitivity_Analysis_status();
C++/CLI
public:
property int Sensitivity_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sensitivity_Selected_parameter_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputAnalysis Class : Sensitivity_Selected_parameter_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sensitivity_Selected_parameter_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputAnalysis
Dim value As Single

value = instance.Sensitivity_Selected_parameter_scale
C#
public float Sensitivity_Selected_parameter_scale {get;}
Managed Extensions for C++
public: __property float get_Sensitivity_Selected_parameter_scale();
C++/CLI
public:
property float Sensitivity_Selected_parameter_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputAnalysis Class
SIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLane Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLane Class

Glossary Item Box

Object Model

SIAPIOutputCirculatingLane ClassISIAPIOutputLeg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputCirculatingLane
   Implements ISIAPIOutputCirculatingLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
C#
public sealed class SIAPIOutputCirculatingLane : ISIAPIOutputCirculatingLane
Managed Extensions for C++
public __gc __sealed class SIAPIOutputCirculatingLane : public ISIAPIOutputCirculatingLane
C++/CLI
public ref class SIAPIOutputCirculatingLane sealed : public ISIAPIOutputCirculatingLane

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputCirculatingLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLane Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLane Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputCirculatingLane.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputCirculatingLane Constructor |
Top

Public Properties

 | Name | Description
Public Property | Laneno |
Public Property | Orientation |
Public Property | OutputLeg |
Public Property | Roucircf_pcu |
Public Property | Roucircf_percent |
Public Property | Roucircf_veh |
Top

See Also

Reference

SIAPIOutputCirculatingLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLane Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : SIAPIOutputCirculatingLane Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputCirculatingLane()
C#
public SIAPIOutputCirculatingLane()
Managed Extensions for C++
public: SIAPIOutputCirculatingLane();
C++/CLI
public:
SIAPIOutputCirculatingLane();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLane Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLane Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputCirculatingLane members.

Public Properties

 | Name | Description
Public Property | Laneno |
Public Property | Orientation |
Public Property | OutputLeg |
Public Property | Roucircf_pcu |
Public Property | Roucircf_percent |
Public Property | Roucircf_veh |
Top

See Also

Reference

SIAPIOutputCirculatingLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : Laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As Integer

value = instance.Laneno
C#
public int Laneno {get;}
Managed Extensions for C++
public: __property int get_Laneno();
C++/CLI
public:
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As Integer

value = instance.Orientation
C#
public int Orientation {get;}
Managed Extensions for C++
public: __property int get_Orientation();
C++/CLI
public:
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
public ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
public:
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : Roucircf_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Roucircf_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_pcu
C#
public float Roucircf_pcu {get;}
Managed Extensions for C++
public: __property float get_Roucircf_pcu();
C++/CLI
public:
property float Roucircf_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : Roucircf_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Roucircf_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_percent
C#
public float Roucircf_percent {get;}
Managed Extensions for C++
public: __property float get_Roucircf_percent();
C++/CLI
public:
property float Roucircf_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLane Class : Roucircf_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Roucircf_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_veh
C#
public float Roucircf_veh {get;}
Managed Extensions for C++
public: __property float get_Roucircf_veh();
C++/CLI
public:
property float Roucircf_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLane Class
SIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLanes Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLanes Class

Glossary Item Box

Object Model

SIAPIOutputCirculatingLanes ClassISIAPIOutputCirculatingLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputCirculatingLanes
   Implements ISIAPIOutputCirculatingLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLanes
C#
public sealed class SIAPIOutputCirculatingLanes : ISIAPIOutputCirculatingLanes
Managed Extensions for C++
public __gc __sealed class SIAPIOutputCirculatingLanes : public ISIAPIOutputCirculatingLanes
C++/CLI
public ref class SIAPIOutputCirculatingLanes sealed : public ISIAPIOutputCirculatingLanes

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputCirculatingLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLanes Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLanes Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputCirculatingLanes.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputCirculatingLanes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneExists |
Top

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLanes Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLanes Class : SIAPIOutputCirculatingLanes Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputCirculatingLanes()
C#
public SIAPIOutputCirculatingLanes()
Managed Extensions for C++
public: SIAPIOutputCirculatingLanes();
C++/CLI
public:
SIAPIOutputCirculatingLanes();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIAPIOutputCirculatingLanes Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLanes Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputCirculatingLanes members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneExists |
Top

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLanes Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLanes
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIAPIOutputCirculatingLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLanes Class : LaneExists Method

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLanes
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExists(laneno)
C#
public bool LaneExists(
   int laneno
)
Managed Extensions for C++
public: bool LaneExists(
   int laneno
)
C++/CLI
public:
bool LaneExists(
   int laneno
)

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIAPIOutputCirculatingLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputCirculatingLanes Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputCirculatingLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputCirculatingLanes members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLanes Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLanes
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIAPIOutputCirculatingLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputCirculatingLanes Class : Item Property

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPIOutputCirculatingLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputCirculatingLanes
Dim laneno As Integer
Dim value As ISIAPIOutputCirculatingLane

value = instance.Item(laneno)
C#
public ISIAPIOutputCirculatingLane this[
   int laneno
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputCirculatingLane* get_Item   int laneno
;
C++/CLI
public:
property ISIAPIOutputCirculatingLane^ default [int] {
   ISIAPIOutputCirculatingLane^ get(int laneno);
}

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputCirculatingLanes Class
SIAPIOutputCirculatingLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuple Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuple Class

Glossary Item Box

Object Model

SIAPIOutputGraphTuple Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputGraphTuple
   Implements ISIAPIOutputGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
C#
public sealed class SIAPIOutputGraphTuple : ISIAPIOutputGraphTuple
Managed Extensions for C++
public __gc __sealed class SIAPIOutputGraphTuple : public ISIAPIOutputGraphTuple
C++/CLI
public ref class SIAPIOutputGraphTuple sealed : public ISIAPIOutputGraphTuple

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputGraphTuple

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuple Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuple Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputGraphTuple.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputGraphTuple Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Arrival_flow_total_person |
Public Property | Capacity_effective |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_total |
Public Property | Cycle_time |
Public Property | Deg_satn |
Public Property | Deg_satn_ped |
Public Property | Delay_control_average |
Public Property | Delay_control_average_ped |
Public Property | Delay_control_average_veh |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_average_worstmov_ped |
Public Property | Delay_control_average_worstmov_person |
Public Property | Delay_control_total_ped |
Public Property | Delay_control_total_person |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Demand_flow_total |
Public Property | Demand_flow_total_ped |
Public Property | Demand_flow_total_person |
Public Property | Fuel_consumption_total |
Public Property | Hydrocarbons_total |
Public Property | Level_of_service |
Public Property | Level_of_service_ped |
Public Property | Level_of_service_veh |
Public Property | Nox_total |
Public Property | Operating_cost_total |
Public Property | Operating_cost_total_ped |
Public Property | Operating_cost_total_veh |
Public Property | Perc_heavy_veh |
Public Property | Performance_index |
Public Property | Performance_index_ped |
Public Property | Performance_index_veh |
Public Property | Practical_spare_capacity |
Public Property | Prop_queued_ped |
Public Property | Prop_queued_person |
Public Property | Prop_queued_veh |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_maxback_percentile |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stop_rate_ped |
Public Property | Stop_rate_veh |
Public Property | Total_stops_ped |
Public Property | Total_stops_person |
Public Property | Total_stops_veh |
Public Property | Travel_dist_av_ped |
Public Property | Travel_dist_av_person |
Public Property | Travel_dist_av_veh |
Public Property | Travel_dist_total_ped |
Public Property | Travel_dist_total_person |
Public Property | Travel_dist_total_veh |
Public Property | Travel_speed |
Public Property | Travel_speed_ped |
Public Property | Travel_speed_person |
Public Property | Travel_time_av_ped |
Public Property | Travel_time_av_person |
Public Property | Travel_time_av_veh |
Public Property | Travel_time_total_ped |
Public Property | Travel_time_total_person |
Public Property | Travel_time_total_veh |
Public Property | Unsettled |
Public Property | X_value |
Top

See Also

Reference

SIAPIOutputGraphTuple Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuple Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : SIAPIOutputGraphTuple Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputGraphTuple()
C#
public SIAPIOutputGraphTuple()
Managed Extensions for C++
public: SIAPIOutputGraphTuple();
C++/CLI
public:
SIAPIOutputGraphTuple();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuple Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuple Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputGraphTuple members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Arrival_flow_total_person |
Public Property | Capacity_effective |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_total |
Public Property | Cycle_time |
Public Property | Deg_satn |
Public Property | Deg_satn_ped |
Public Property | Delay_control_average |
Public Property | Delay_control_average_ped |
Public Property | Delay_control_average_veh |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_average_worstmov_ped |
Public Property | Delay_control_average_worstmov_person |
Public Property | Delay_control_total_ped |
Public Property | Delay_control_total_person |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Demand_flow_total |
Public Property | Demand_flow_total_ped |
Public Property | Demand_flow_total_person |
Public Property | Fuel_consumption_total |
Public Property | Hydrocarbons_total |
Public Property | Level_of_service |
Public Property | Level_of_service_ped |
Public Property | Level_of_service_veh |
Public Property | Nox_total |
Public Property | Operating_cost_total |
Public Property | Operating_cost_total_ped |
Public Property | Operating_cost_total_veh |
Public Property | Perc_heavy_veh |
Public Property | Performance_index |
Public Property | Performance_index_ped |
Public Property | Performance_index_veh |
Public Property | Practical_spare_capacity |
Public Property | Prop_queued_ped |
Public Property | Prop_queued_person |
Public Property | Prop_queued_veh |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_maxback_percentile |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stop_rate_ped |
Public Property | Stop_rate_veh |
Public Property | Total_stops_ped |
Public Property | Total_stops_person |
Public Property | Total_stops_veh |
Public Property | Travel_dist_av_ped |
Public Property | Travel_dist_av_person |
Public Property | Travel_dist_av_veh |
Public Property | Travel_dist_total_ped |
Public Property | Travel_dist_total_person |
Public Property | Travel_dist_total_veh |
Public Property | Travel_speed |
Public Property | Travel_speed_ped |
Public Property | Travel_speed_person |
Public Property | Travel_time_av_ped |
Public Property | Travel_time_av_person |
Public Property | Travel_time_av_veh |
Public Property | Travel_time_total_ped |
Public Property | Travel_time_total_person |
Public Property | Travel_time_total_veh |
Public Property | Unsettled |
Public Property | X_value |
Top

See Also

Reference

SIAPIOutputGraphTuple Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Arrival_flow_total
C#
public float Arrival_flow_total {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total();
C++/CLI
public:
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Arrival_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Arrival_flow_total_person
C#
public float Arrival_flow_total_person {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total_person();
C++/CLI
public:
property float Arrival_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Capacity_effective
C#
public float Capacity_effective {get;}
Managed Extensions for C++
public: __property float get_Capacity_effective();
C++/CLI
public:
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Cycle_time
C#
public float Cycle_time {get;}
Managed Extensions for C++
public: __property float get_Cycle_time();
C++/CLI
public:
property float Cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Deg_satn_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Deg_satn_ped
C#
public float Deg_satn_ped {get;}
Managed Extensions for C++
public: __property float get_Deg_satn_ped();
C++/CLI
public:
property float Deg_satn_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_ped
C#
public float Delay_control_average_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_ped();
C++/CLI
public:
property float Delay_control_average_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_veh
C#
public float Delay_control_average_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_veh();
C++/CLI
public:
property float Delay_control_average_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
public float Delay_control_average_worstlane {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstlane();
C++/CLI
public:
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_worstmov_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_ped
C#
public float Delay_control_average_worstmov_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov_ped();
C++/CLI
public:
property float Delay_control_average_worstmov_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_average_worstmov_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_person
C#
public float Delay_control_average_worstmov_person {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov_person();
C++/CLI
public:
property float Delay_control_average_worstmov_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_ped
C#
public float Delay_control_total_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_ped();
C++/CLI
public:
property float Delay_control_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_person
C#
public float Delay_control_total_person {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_person();
C++/CLI
public:
property float Delay_control_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_veh
C#
public float Delay_control_total_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_veh();
C++/CLI
public:
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_geometric_average
C#
public float Delay_geometric_average {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric_average();
C++/CLI
public:
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Demand_flow_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total_ped
C#
public float Demand_flow_total_ped {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total_ped();
C++/CLI
public:
property float Demand_flow_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Demand_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total_person
C#
public float Demand_flow_total_person {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total_person();
C++/CLI
public:
property float Demand_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service
C#
public int Level_of_service {get;}
Managed Extensions for C++
public: __property int get_Level_of_service();
C++/CLI
public:
property int Level_of_service {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Level_of_service_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_ped As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service_ped
C#
public int Level_of_service_ped {get;}
Managed Extensions for C++
public: __property int get_Level_of_service_ped();
C++/CLI
public:
property int Level_of_service_ped {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Level_of_service_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_veh As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service_veh
C#
public int Level_of_service_veh {get;}
Managed Extensions for C++
public: __property int get_Level_of_service_veh();
C++/CLI
public:
property int Level_of_service_veh {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Operating_cost_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total_ped
C#
public float Operating_cost_total_ped {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total_ped();
C++/CLI
public:
property float Operating_cost_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Operating_cost_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total_veh
C#
public float Operating_cost_total_veh {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total_veh();
C++/CLI
public:
property float Operating_cost_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_heavy_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Perc_heavy_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Perc_heavy_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Perc_heavy_veh
C#
public float Perc_heavy_veh {get;}
Managed Extensions for C++
public: __property float get_Perc_heavy_veh();
C++/CLI
public:
property float Perc_heavy_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Performance_index_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index_ped
C#
public float Performance_index_ped {get;}
Managed Extensions for C++
public: __property float get_Performance_index_ped();
C++/CLI
public:
property float Performance_index_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Performance_index_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index_veh
C#
public float Performance_index_veh {get;}
Managed Extensions for C++
public: __property float get_Performance_index_veh();
C++/CLI
public:
property float Performance_index_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Prop_queued_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_ped
C#
public float Prop_queued_ped {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_ped();
C++/CLI
public:
property float Prop_queued_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Prop_queued_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_person
C#
public float Prop_queued_person {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_person();
C++/CLI
public:
property float Prop_queued_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Prop_queued_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_veh
C#
public float Prop_queued_veh {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_veh();
C++/CLI
public:
property float Prop_queued_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Stop_rate_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate_ped
C#
public float Stop_rate_ped {get;}
Managed Extensions for C++
public: __property float get_Stop_rate_ped();
C++/CLI
public:
property float Stop_rate_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Stop_rate_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate_veh
C#
public float Stop_rate_veh {get;}
Managed Extensions for C++
public: __property float get_Stop_rate_veh();
C++/CLI
public:
property float Stop_rate_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Total_stops_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_ped
C#
public float Total_stops_ped {get;}
Managed Extensions for C++
public: __property float get_Total_stops_ped();
C++/CLI
public:
property float Total_stops_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Total_stops_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_person
C#
public float Total_stops_person {get;}
Managed Extensions for C++
public: __property float get_Total_stops_person();
C++/CLI
public:
property float Total_stops_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Total_stops_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_veh
C#
public float Total_stops_veh {get;}
Managed Extensions for C++
public: __property float get_Total_stops_veh();
C++/CLI
public:
property float Total_stops_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_ped
C#
public float Travel_dist_av_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_ped();
C++/CLI
public:
property float Travel_dist_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_person
C#
public float Travel_dist_av_person {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_person();
C++/CLI
public:
property float Travel_dist_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_veh
C#
public float Travel_dist_av_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_veh();
C++/CLI
public:
property float Travel_dist_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_ped
C#
public float Travel_dist_total_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_ped();
C++/CLI
public:
property float Travel_dist_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_person
C#
public float Travel_dist_total_person {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_person();
C++/CLI
public:
property float Travel_dist_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_dist_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_veh
C#
public float Travel_dist_total_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_veh();
C++/CLI
public:
property float Travel_dist_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_speed_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed_ped
C#
public float Travel_speed_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_speed_ped();
C++/CLI
public:
property float Travel_speed_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_speed_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed_person
C#
public float Travel_speed_person {get;}
Managed Extensions for C++
public: __property float get_Travel_speed_person();
C++/CLI
public:
property float Travel_speed_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_ped
C#
public float Travel_time_av_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_ped();
C++/CLI
public:
property float Travel_time_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_person
C#
public float Travel_time_av_person {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_person();
C++/CLI
public:
property float Travel_time_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_veh
C#
public float Travel_time_av_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_veh();
C++/CLI
public:
property float Travel_time_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_ped
C#
public float Travel_time_total_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_ped();
C++/CLI
public:
property float Travel_time_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_person
C#
public float Travel_time_total_person {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_person();
C++/CLI
public:
property float Travel_time_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Travel_time_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_veh
C#
public float Travel_time_total_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_veh();
C++/CLI
public:
property float Travel_time_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unsettled Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : Unsettled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unsettled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Boolean

value = instance.Unsettled
C#
public bool Unsettled {get;}
Managed Extensions for C++
public: __property bool get_Unsettled();
C++/CLI
public:
property bool Unsettled {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X_value Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuple Class : X_value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X_value As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuple
Dim value As Single

value = instance.X_value
C#
public float X_value {get;}
Managed Extensions for C++
public: __property float get_X_value();
C++/CLI
public:
property float X_value {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuple Class
SIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuples Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuples Class

Glossary Item Box

Object Model

SIAPIOutputGraphTuples ClassISIAPIOutputGraphTuple Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputGraphTuples
   Implements ISIAPIOutputGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuples
C#
public sealed class SIAPIOutputGraphTuples : ISIAPIOutputGraphTuples
Managed Extensions for C++
public __gc __sealed class SIAPIOutputGraphTuples : public ISIAPIOutputGraphTuples
C++/CLI
public ref class SIAPIOutputGraphTuples sealed : public ISIAPIOutputGraphTuples

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputGraphTuples

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuples Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuples Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuples Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputGraphTuples.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputGraphTuples Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuples Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuples Class : SIAPIOutputGraphTuples Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputGraphTuples()
C#
public SIAPIOutputGraphTuples()
Managed Extensions for C++
public: SIAPIOutputGraphTuples();
C++/CLI
public:
SIAPIOutputGraphTuples();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuples Class
SIAPIOutputGraphTuples Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuples Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuples Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputGraphTuples members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuples Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuples
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuples Class
SIAPIOutputGraphTuples Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputGraphTuples Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputGraphTuples Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputGraphTuples members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuples Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuples
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuples Class
SIAPIOutputGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputGraphTuples Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputGraphTuples
Dim index As Integer
Dim value As ISIAPIOutputGraphTuple

value = instance.Item(index)
C#
public ISIAPIOutputGraphTuple this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputGraphTuple* get_Item   int index
;
C++/CLI
public:
property ISIAPIOutputGraphTuple^ default [int] {
   ISIAPIOutputGraphTuple^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputGraphTuples Class
SIAPIOutputGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLane Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLane Class

Glossary Item Box

SIDRA INTERSECTION Output Lane wrapper class

Object Model

SIAPIOutputLane ClassISIAPIOutputLaneGreenPeriods InterfaceISIAPIOutputLaneGreenPeriod InterfaceISIAPIOutputLaneMCs InterfaceISIAPIOutputLaneMC InterfaceISIAPIOutputLaneODs InterfaceISIAPIOutputLaneOD InterfaceISIAPIOutputLeg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLane
   Implements ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
C#
public sealed class SIAPIOutputLane : ISIAPIOutputLane
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLane : public ISIAPIOutputLane
C++/CLI
public ref class SIAPIOutputLane sealed : public ISIAPIOutputLane

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLane Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLane Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLane.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLane Constructor |
Top

Public Properties

 | Name | Description
Public Property | Adjfactor_buses |
Public Property | Adjfactor_flowscale |
Public Property | Adjfactor_grade |
Public Property | Adjfactor_lanewidth |
Public Property | Adjfactor_parking |
Public Property | Adjfactor_trafficflow |
Public Property | Arrival_flow_flag |
Public Property | Average_queue_space |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Calc_mf_flag |
Public Property | Capacity | Capacity (veh/h) total for both green periods.
Public Property | Capacity_adj |
Public Property | Capacity_adj_flag |
Public Property | Capacity_end_deps | Capacity (veh/h) due to "end departures" (Signals only).
Public Property | Capacity_min | Minimum Capacity (veh/h) (Roundabouts/Sign Control only).
Public Property | Capacity_shortlane_affected | Flag indicating if short lane affects capacity.
Public Property | Contlane_affect_by_adjshortlane |
Public Property | Control_type |
Public Property | Deg_satn |
Public Property | Delay_acc_dec_dn |
Public Property | Delay_ctrl | Average control delay (sec/veh).
Public Property | Delay_geo | Geometric delay (sec/veh).
Public Property | Delay_idle | Idle delay (sec/veh).
Public Property | Delay_model_1 | Model delay (sec/veh) 1st term.
Public Property | Delay_model_2 | Model delay (sec/veh) 2nd term.
Public Property | Delay_n | Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.
Public Property | Delay_q | "Queuing" ("stopped") delay.
Public Property | Delay_queue_moveup |
Public Property | Driver_response_time |
Public Property | Equivalent_AT |
Public Property | Flag_na |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Headway_scats_mf |
Public Property | Initial_demand_vol |
Public Property | Initial_demand_vol_clear_time |
Public Property | Is_dominant |
Public Property | Is_nw_connected |
Public Property | Lane_block_adj |
Public Property | Lane_change_from_left |
Public Property | Lane_change_from_right |
Public Property | Lane_change_to_left |
Public Property | Lane_change_to_right |
Public Property | Laneno |
Public Property | Level_of_service | Lane LOS.
Public Property | Minimum_delay |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | Occupancy_scats_mf |
Public Property | Opposing_ped_factor |
Public Property | Orientation |
Public Property | OutputLaneGreenPeriods |
Public Property | OutputLaneMCs |
Public Property | OutputLaneODs |
Public Property | OutputLeg |
Public Property | Oversatn_duration |
Public Property | Perc_arriving_during_green |
Public Property | Platoon_ratio |
Public Property | Prob_blockage | Probability of blockage.
Public Property | Prob_shortlane_overflow |
Public Property | Progression_factor_delay |
Public Property | Progression_factor_queue |
Public Property | Prop_queued | Proportion queued.
Public Property | Queue_constraint_flag |
Public Property | Queue_cycav_1 | Cycle-average queue (veh), 1st term.
Public Property | Queue_cycav_2 | Cycle-average queue (veh), 2nd term.
Public Property | Queue_cycav_mean | Cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_1 | Maximum back of queue (veh), 1st term.
Public Property | Queue_maxback_2 | Maximum back of queue (veh), 2nd term.
Public Property | Queue_maxback_mean | Maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Maximum back of queue (veh), user-specified percentile.
Public Property | Queue_overflow | Overflow queue (veh).
Public Property | Queue_space | Queue space averaged over LV & HV in the lane.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | Residual_demand_vol |
Public Property | Residual_demand_vol_clear_time |
Public Property | Satflow_basic | "Adjusted Basic" saturation flow (tcu).
Public Property | Satflow_basic_adj |
Public Property | Satflow_scats | "SCATS" saturation flow.
Public Property | Satflow_scats_mf | "SCATS" MF.
Public Property | Satn_flow |
Public Property | Satn_headway |
Public Property | Satn_spacing |
Public Property | Satn_speed |
Public Property | Shortlane_flow_moved | Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.
Public Property | Space_scats_mf |
Public Property | Stop_rate |
Public Property | Stoprate_1 | Stop rate 1st term.
Public Property | Stoprate_2 | Stop rate 2nd term.
Public Property | Stoprate_geo | "Geometric" stop rate.
Public Property | Stoprate_overall | Overall Stop Rate.
Public Property | Stoprate_qmovup | Queue move up rate (sum of both green periods).
Public Property | T2_reduced | Flag indicating if second terms reduced due to short lane effects.
Public Property | Total_stops |
Public Property | Unblocked_time_ratio |
Public Property | Underutil_flag | Reason for lane underutilisation.
Public Property | Upstr_flow_after_exit_sl |
Public Property | Util_factor | Utilisation factor determined by the program.
Public Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

SIAPIOutputLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLane Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : SIAPIOutputLane Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLane()
C#
public SIAPIOutputLane()
Managed Extensions for C++
public: SIAPIOutputLane();
C++/CLI
public:
SIAPIOutputLane();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLane Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLane Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLane members.

Public Properties

 | Name | Description
Public Property | Adjfactor_buses |
Public Property | Adjfactor_flowscale |
Public Property | Adjfactor_grade |
Public Property | Adjfactor_lanewidth |
Public Property | Adjfactor_parking |
Public Property | Adjfactor_trafficflow |
Public Property | Arrival_flow_flag |
Public Property | Average_queue_space |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Calc_mf_flag |
Public Property | Capacity | Capacity (veh/h) total for both green periods.
Public Property | Capacity_adj |
Public Property | Capacity_adj_flag |
Public Property | Capacity_end_deps | Capacity (veh/h) due to "end departures" (Signals only).
Public Property | Capacity_min | Minimum Capacity (veh/h) (Roundabouts/Sign Control only).
Public Property | Capacity_shortlane_affected | Flag indicating if short lane affects capacity.
Public Property | Contlane_affect_by_adjshortlane |
Public Property | Control_type |
Public Property | Deg_satn |
Public Property | Delay_acc_dec_dn |
Public Property | Delay_ctrl | Average control delay (sec/veh).
Public Property | Delay_geo | Geometric delay (sec/veh).
Public Property | Delay_idle | Idle delay (sec/veh).
Public Property | Delay_model_1 | Model delay (sec/veh) 1st term.
Public Property | Delay_model_2 | Model delay (sec/veh) 2nd term.
Public Property | Delay_n | Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.
Public Property | Delay_q | "Queuing" ("stopped") delay.
Public Property | Delay_queue_moveup |
Public Property | Driver_response_time |
Public Property | Equivalent_AT |
Public Property | Flag_na |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Headway_scats_mf |
Public Property | Initial_demand_vol |
Public Property | Initial_demand_vol_clear_time |
Public Property | Is_dominant |
Public Property | Is_nw_connected |
Public Property | Lane_block_adj |
Public Property | Lane_change_from_left |
Public Property | Lane_change_from_right |
Public Property | Lane_change_to_left |
Public Property | Lane_change_to_right |
Public Property | Laneno |
Public Property | Level_of_service | Lane LOS.
Public Property | Minimum_delay |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | Occupancy_scats_mf |
Public Property | Opposing_ped_factor |
Public Property | Orientation |
Public Property | OutputLaneGreenPeriods |
Public Property | OutputLaneMCs |
Public Property | OutputLaneODs |
Public Property | OutputLeg |
Public Property | Oversatn_duration |
Public Property | Perc_arriving_during_green |
Public Property | Platoon_ratio |
Public Property | Prob_blockage | Probability of blockage.
Public Property | Prob_shortlane_overflow |
Public Property | Progression_factor_delay |
Public Property | Progression_factor_queue |
Public Property | Prop_queued | Proportion queued.
Public Property | Queue_constraint_flag |
Public Property | Queue_cycav_1 | Cycle-average queue (veh), 1st term.
Public Property | Queue_cycav_2 | Cycle-average queue (veh), 2nd term.
Public Property | Queue_cycav_mean | Cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_1 | Maximum back of queue (veh), 1st term.
Public Property | Queue_maxback_2 | Maximum back of queue (veh), 2nd term.
Public Property | Queue_maxback_mean | Maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Maximum back of queue (veh), user-specified percentile.
Public Property | Queue_overflow | Overflow queue (veh).
Public Property | Queue_space | Queue space averaged over LV & HV in the lane.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | Residual_demand_vol |
Public Property | Residual_demand_vol_clear_time |
Public Property | Satflow_basic | "Adjusted Basic" saturation flow (tcu).
Public Property | Satflow_basic_adj |
Public Property | Satflow_scats | "SCATS" saturation flow.
Public Property | Satflow_scats_mf | "SCATS" MF.
Public Property | Satn_flow |
Public Property | Satn_headway |
Public Property | Satn_spacing |
Public Property | Satn_speed |
Public Property | Shortlane_flow_moved | Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.
Public Property | Space_scats_mf |
Public Property | Stop_rate |
Public Property | Stoprate_1 | Stop rate 1st term.
Public Property | Stoprate_2 | Stop rate 2nd term.
Public Property | Stoprate_geo | "Geometric" stop rate.
Public Property | Stoprate_overall | Overall Stop Rate.
Public Property | Stoprate_qmovup | Queue move up rate (sum of both green periods).
Public Property | T2_reduced | Flag indicating if second terms reduced due to short lane effects.
Public Property | Total_stops |
Public Property | Unblocked_time_ratio |
Public Property | Underutil_flag | Reason for lane underutilisation.
Public Property | Upstr_flow_after_exit_sl |
Public Property | Util_factor | Utilisation factor determined by the program.
Public Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

SIAPIOutputLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_buses Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_buses Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_buses As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_buses
C#
public float Adjfactor_buses {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_buses();
C++/CLI
public:
property float Adjfactor_buses {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_flowscale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_flowscale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_flowscale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_flowscale
C#
public float Adjfactor_flowscale {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_flowscale();
C++/CLI
public:
property float Adjfactor_flowscale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_grade As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_grade
C#
public float Adjfactor_grade {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_grade();
C++/CLI
public:
property float Adjfactor_grade {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_lanewidth Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_lanewidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_lanewidth As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_lanewidth
C#
public float Adjfactor_lanewidth {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_lanewidth();
C++/CLI
public:
property float Adjfactor_lanewidth {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_parking Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_parking Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_parking As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_parking
C#
public float Adjfactor_parking {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_parking();
C++/CLI
public:
property float Adjfactor_parking {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_trafficflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Adjfactor_trafficflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjfactor_trafficflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_trafficflow
C#
public float Adjfactor_trafficflow {get;}
Managed Extensions for C++
public: __property float get_Adjfactor_trafficflow();
C++/CLI
public:
property float Adjfactor_trafficflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Average_queue_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Average_queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Average_queue_space
C#
public float Average_queue_space {get;}
Managed Extensions for C++
public: __property float get_Average_queue_space();
C++/CLI
public:
property float Average_queue_space {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
public float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
public: __property float get_Avg_num_of_cycles_to_depart();
C++/CLI
public:
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_mf_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Calc_mf_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Calc_mf_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Calc_mf_flag
C#
public int Calc_mf_flag {get;}
Managed Extensions for C++
public: __property int get_Calc_mf_flag();
C++/CLI
public:
property int Calc_mf_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity Property

Glossary Item Box

Capacity (veh/h) total for both green periods.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Capacity
C#
public float Capacity {get;}
Managed Extensions for C++
public: __property float get_Capacity();
C++/CLI
public:
property float Capacity {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Capacity_adj
C#
public float Capacity_adj {get;}
Managed Extensions for C++
public: __property float get_Capacity_adj();
C++/CLI
public:
property float Capacity_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity_adj_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Capacity_adj_flag
C#
public int Capacity_adj_flag {get;}
Managed Extensions for C++
public: __property int get_Capacity_adj_flag();
C++/CLI
public:
property int Capacity_adj_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_end_deps Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity_end_deps Property

Glossary Item Box

Capacity (veh/h) due to "end departures" (Signals only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_end_deps As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Capacity_end_deps
C#
public float Capacity_end_deps {get;}
Managed Extensions for C++
public: __property float get_Capacity_end_deps();
C++/CLI
public:
property float Capacity_end_deps {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity_min Property

Glossary Item Box

Minimum Capacity (veh/h) (Roundabouts/Sign Control only).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_min As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Capacity_min
C#
public float Capacity_min {get;}
Managed Extensions for C++
public: __property float get_Capacity_min();
C++/CLI
public:
property float Capacity_min {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_shortlane_affected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Capacity_shortlane_affected Property

Glossary Item Box

Flag indicating if short lane affects capacity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_shortlane_affected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Boolean

value = instance.Capacity_shortlane_affected
C#
public bool Capacity_shortlane_affected {get;}
Managed Extensions for C++
public: __property bool get_Capacity_shortlane_affected();
C++/CLI
public:
property bool Capacity_shortlane_affected {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Contlane_affect_by_adjshortlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Contlane_affect_by_adjshortlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Contlane_affect_by_adjshortlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Contlane_affect_by_adjshortlane
C#
public int Contlane_affect_by_adjshortlane {get;}
Managed Extensions for C++
public: __property int get_Contlane_affect_by_adjshortlane();
C++/CLI
public:
property int Contlane_affect_by_adjshortlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Control_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Control_type
C#
public int Control_type {get;}
Managed Extensions for C++
public: __property int get_Control_type();
C++/CLI
public:
property int Control_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_acc_dec_dn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_acc_dec_dn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_acc_dec_dn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_acc_dec_dn
C#
public float Delay_acc_dec_dn {get;}
Managed Extensions for C++
public: __property float get_Delay_acc_dec_dn();
C++/CLI
public:
property float Delay_acc_dec_dn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_ctrl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_ctrl Property

Glossary Item Box

Average control delay (sec/veh).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_ctrl As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_ctrl
C#
public float Delay_ctrl {get;}
Managed Extensions for C++
public: __property float get_Delay_ctrl();
C++/CLI
public:
property float Delay_ctrl {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geo Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_geo Property

Glossary Item Box

Geometric delay (sec/veh).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geo As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_geo
C#
public float Delay_geo {get;}
Managed Extensions for C++
public: __property float get_Delay_geo();
C++/CLI
public:
property float Delay_geo {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_idle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_idle Property

Glossary Item Box

Idle delay (sec/veh).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_idle As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_idle
C#
public float Delay_idle {get;}
Managed Extensions for C++
public: __property float get_Delay_idle();
C++/CLI
public:
property float Delay_idle {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_model_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_model_1 Property

Glossary Item Box

Model delay (sec/veh) 1st term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_model_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_model_1
C#
public float Delay_model_1 {get;}
Managed Extensions for C++
public: __property float get_Delay_model_1();
C++/CLI
public:
property float Delay_model_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_model_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_model_2 Property

Glossary Item Box

Model delay (sec/veh) 2nd term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_model_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_model_2
C#
public float Delay_model_2 {get;}
Managed Extensions for C++
public: __property float get_Delay_model_2();
C++/CLI
public:
property float Delay_model_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_n Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_n Property

Glossary Item Box

Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_n As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_n
C#
public float Delay_n {get;}
Managed Extensions for C++
public: __property float get_Delay_n();
C++/CLI
public:
property float Delay_n {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_q Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_q Property

Glossary Item Box

"Queuing" ("stopped") delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_q As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_q
C#
public float Delay_q {get;}
Managed Extensions for C++
public: __property float get_Delay_q();
C++/CLI
public:
property float Delay_q {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_queue_moveup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Delay_queue_moveup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_queue_moveup As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Delay_queue_moveup
C#
public float Delay_queue_moveup {get;}
Managed Extensions for C++
public: __property float get_Delay_queue_moveup();
C++/CLI
public:
property float Delay_queue_moveup {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Driver_response_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Driver_response_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Driver_response_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Driver_response_time
C#
public float Driver_response_time {get;}
Managed Extensions for C++
public: __property float get_Driver_response_time();
C++/CLI
public:
property float Driver_response_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Equivalent_AT
C#
public int Equivalent_AT {get;}
Managed Extensions for C++
public: __property int get_Equivalent_AT();
C++/CLI
public:
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flag_na Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flag_na Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flag_na As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Flag_na
C#
public int Flag_na {get;}
Managed Extensions for C++
public: __property int get_Flag_na();
C++/CLI
public:
property int Flag_na {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_HV
C#
public float Flow_HV {get;}
Managed Extensions for C++
public: __property float get_Flow_HV();
C++/CLI
public:
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_capconstr
C#
public float Flow_HV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_capconstr();
C++/CLI
public:
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_HV_pct Property

Glossary Item Box

Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_pct
C#
public float Flow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct();
C++/CLI
public:
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
public float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct_capconstr();
C++/CLI
public:
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_LV
C#
public float Flow_LV {get;}
Managed Extensions for C++
public: __property float get_Flow_LV();
C++/CLI
public:
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_LV_capconstr
C#
public float Flow_LV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_LV_capconstr();
C++/CLI
public:
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_total
C#
public float Flow_total {get;}
Managed Extensions for C++
public: __property float get_Flow_total();
C++/CLI
public:
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Flow_total_capconstr
C#
public float Flow_total_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_total_capconstr();
C++/CLI
public:
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
public float Gap_accept_blocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_blocked_time();
C++/CLI
public:
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
public float Gap_accept_cycle_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_cycle_time();
C++/CLI
public:
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
public float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_unblocked_time();
C++/CLI
public:
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Green_periods
C#
public int Green_periods {get;}
Managed Extensions for C++
public: __property int get_Green_periods();
C++/CLI
public:
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Headway_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Headway_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Headway_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Headway_scats_mf
C#
public float Headway_scats_mf {get;}
Managed Extensions for C++
public: __property float get_Headway_scats_mf();
C++/CLI
public:
property float Headway_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Initial_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Initial_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Initial_demand_vol
C#
public float Initial_demand_vol {get;}
Managed Extensions for C++
public: __property float get_Initial_demand_vol();
C++/CLI
public:
property float Initial_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Initial_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Initial_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Initial_demand_vol_clear_time
C#
public float Initial_demand_vol_clear_time {get;}
Managed Extensions for C++
public: __property float get_Initial_demand_vol_clear_time();
C++/CLI
public:
property float Initial_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_dominant Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Is_dominant Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Is_dominant As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Boolean

value = instance.Is_dominant
C#
public bool Is_dominant {get;}
Managed Extensions for C++
public: __property bool get_Is_dominant();
C++/CLI
public:
property bool Is_dominant {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_nw_connected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Is_nw_connected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Is_nw_connected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Boolean

value = instance.Is_nw_connected
C#
public bool Is_nw_connected {get;}
Managed Extensions for C++
public: __property bool get_Is_nw_connected();
C++/CLI
public:
property bool Is_nw_connected {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_block_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Lane_block_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_block_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Lane_block_adj
C#
public float Lane_block_adj {get;}
Managed Extensions for C++
public: __property float get_Lane_block_adj();
C++/CLI
public:
property float Lane_block_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Lane_change_from_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_from_left As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Lane_change_from_left
C#
public float Lane_change_from_left {get;}
Managed Extensions for C++
public: __property float get_Lane_change_from_left();
C++/CLI
public:
property float Lane_change_from_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Lane_change_from_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_from_right As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Lane_change_from_right
C#
public float Lane_change_from_right {get;}
Managed Extensions for C++
public: __property float get_Lane_change_from_right();
C++/CLI
public:
property float Lane_change_from_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Lane_change_to_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Lane_change_to_left
C#
public float Lane_change_to_left {get;}
Managed Extensions for C++
public: __property float get_Lane_change_to_left();
C++/CLI
public:
property float Lane_change_to_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Lane_change_to_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Lane_change_to_right
C#
public float Lane_change_to_right {get;}
Managed Extensions for C++
public: __property float get_Lane_change_to_right();
C++/CLI
public:
property float Lane_change_to_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Laneno
C#
public int Laneno {get;}
Managed Extensions for C++
public: __property int get_Laneno();
C++/CLI
public:
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Level_of_service Property

Glossary Item Box

Lane LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Minimum_delay
C#
public float Minimum_delay {get;}
Managed Extensions for C++
public: __property float get_Minimum_delay();
C++/CLI
public:
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Net_inflow
C#
public float Net_inflow {get;}
Managed Extensions for C++
public: __property float get_Net_inflow();
C++/CLI
public:
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Net_inflow_capconstr
C#
public float Net_inflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_inflow_capconstr();
C++/CLI
public:
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Net_outflow
C#
public float Net_outflow {get;}
Managed Extensions for C++
public: __property float get_Net_outflow();
C++/CLI
public:
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Net_outflow_capconstr
C#
public float Net_outflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_outflow_capconstr();
C++/CLI
public:
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Occupancy_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Occupancy_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Occupancy_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Occupancy_scats_mf
C#
public float Occupancy_scats_mf {get;}
Managed Extensions for C++
public: __property float get_Occupancy_scats_mf();
C++/CLI
public:
property float Occupancy_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Opposing_ped_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_ped_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Opposing_ped_factor
C#
public float Opposing_ped_factor {get;}
Managed Extensions for C++
public: __property float get_Opposing_ped_factor();
C++/CLI
public:
property float Opposing_ped_factor {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Orientation
C#
public int Orientation {get;}
Managed Extensions for C++
public: __property int get_Orientation();
C++/CLI
public:
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneGreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : OutputLaneGreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLaneGreenPeriods As ISIAPIOutputLaneGreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As ISIAPIOutputLaneGreenPeriods

value = instance.OutputLaneGreenPeriods
C#
public ISIAPIOutputLaneGreenPeriods OutputLaneGreenPeriods {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneGreenPeriods* get_OutputLaneGreenPeriods();
C++/CLI
public:
property ISIAPIOutputLaneGreenPeriods^ OutputLaneGreenPeriods {
   ISIAPIOutputLaneGreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : OutputLaneMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLaneMCs As ISIAPIOutputLaneMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As ISIAPIOutputLaneMCs

value = instance.OutputLaneMCs
C#
public ISIAPIOutputLaneMCs OutputLaneMCs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneMCs* get_OutputLaneMCs();
C++/CLI
public:
property ISIAPIOutputLaneMCs^ OutputLaneMCs {
   ISIAPIOutputLaneMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : OutputLaneODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLaneODs As ISIAPIOutputLaneODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As ISIAPIOutputLaneODs

value = instance.OutputLaneODs
C#
public ISIAPIOutputLaneODs OutputLaneODs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneODs* get_OutputLaneODs();
C++/CLI
public:
property ISIAPIOutputLaneODs^ OutputLaneODs {
   ISIAPIOutputLaneODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
public ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
public:
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Oversatn_duration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Oversatn_duration Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Oversatn_duration As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Oversatn_duration
C#
public float Oversatn_duration {get;}
Managed Extensions for C++
public: __property float get_Oversatn_duration();
C++/CLI
public:
property float Oversatn_duration {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Perc_arriving_during_green
C#
public float Perc_arriving_during_green {get;}
Managed Extensions for C++
public: __property float get_Perc_arriving_during_green();
C++/CLI
public:
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Platoon_ratio
C#
public float Platoon_ratio {get;}
Managed Extensions for C++
public: __property float get_Platoon_ratio();
C++/CLI
public:
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prob_blockage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Prob_blockage Property

Glossary Item Box

Probability of blockage.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prob_blockage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Prob_blockage
C#
public float Prob_blockage {get;}
Managed Extensions for C++
public: __property float get_Prob_blockage();
C++/CLI
public:
property float Prob_blockage {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prob_shortlane_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Prob_shortlane_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prob_shortlane_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Prob_shortlane_overflow
C#
public float Prob_shortlane_overflow {get;}
Managed Extensions for C++
public: __property float get_Prob_shortlane_overflow();
C++/CLI
public:
property float Prob_shortlane_overflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Progression_factor_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Progression_factor_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Progression_factor_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Progression_factor_delay
C#
public float Progression_factor_delay {get;}
Managed Extensions for C++
public: __property float get_Progression_factor_delay();
C++/CLI
public:
property float Progression_factor_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Progression_factor_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Progression_factor_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Progression_factor_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Progression_factor_queue
C#
public float Progression_factor_queue {get;}
Managed Extensions for C++
public: __property float get_Progression_factor_queue();
C++/CLI
public:
property float Progression_factor_queue {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Prop_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Prop_queued
C#
public float Prop_queued {get;}
Managed Extensions for C++
public: __property float get_Prop_queued();
C++/CLI
public:
property float Prop_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_constraint_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_constraint_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_constraint_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Queue_constraint_flag
C#
public int Queue_constraint_flag {get;}
Managed Extensions for C++
public: __property int get_Queue_constraint_flag();
C++/CLI
public:
property int Queue_constraint_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_cycav_1 Property

Glossary Item Box

Cycle-average queue (veh), 1st term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_1
C#
public float Queue_cycav_1 {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_1();
C++/CLI
public:
property float Queue_cycav_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_cycav_2 Property

Glossary Item Box

Cycle-average queue (veh), 2nd term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_2
C#
public float Queue_cycav_2 {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_2();
C++/CLI
public:
property float Queue_cycav_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_cycav_mean Property

Glossary Item Box

Cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_mean
C#
public float Queue_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_mean();
C++/CLI
public:
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_cycav_percentile Property

Glossary Item Box

Cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_percentile
C#
public float Queue_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_percentile();
C++/CLI
public:
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
public float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_mean();
C++/CLI
public:
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
public float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_percentile();
C++/CLI
public:
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
public float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_mean();
C++/CLI
public:
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
public float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_percentile();
C++/CLI
public:
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_maxback_mean Property

Glossary Item Box

Maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_greenstart_mean
C#
public float Queue_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_mean();
C++/CLI
public:
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
public float Queue_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_percentile();
C++/CLI
public:
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_maxback_1 Property

Glossary Item Box

Maximum back of queue (veh), 1st term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_1
C#
public float Queue_maxback_1 {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_1();
C++/CLI
public:
property float Queue_maxback_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_maxback_2 Property

Glossary Item Box

Maximum back of queue (veh), 2nd term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_2
C#
public float Queue_maxback_2 {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_2();
C++/CLI
public:
property float Queue_maxback_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_maxback_mean Property

Glossary Item Box

Maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_maxback_percentile Property

Glossary Item Box

Maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_overflow Property

Glossary Item Box

Overflow queue (veh).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_overflow
C#
public float Queue_overflow {get;}
Managed Extensions for C++
public: __property float get_Queue_overflow();
C++/CLI
public:
property float Queue_overflow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_space Property

Glossary Item Box

Queue space averaged over LV & HV in the lane.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_space
C#
public float Queue_space {get;}
Managed Extensions for C++
public: __property float get_Queue_space();
C++/CLI
public:
property float Queue_space {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
public float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_avg();
C++/CLI
public:
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
public float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_percentile();
C++/CLI
public:
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Residual_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Residual_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Residual_demand_vol
C#
public float Residual_demand_vol {get;}
Managed Extensions for C++
public: __property float get_Residual_demand_vol();
C++/CLI
public:
property float Residual_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Residual_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Residual_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Residual_demand_vol_clear_time
C#
public float Residual_demand_vol_clear_time {get;}
Managed Extensions for C++
public: __property float get_Residual_demand_vol_clear_time();
C++/CLI
public:
property float Residual_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_basic Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satflow_basic Property

Glossary Item Box

"Adjusted Basic" saturation flow (tcu).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_basic As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satflow_basic
C#
public float Satflow_basic {get;}
Managed Extensions for C++
public: __property float get_Satflow_basic();
C++/CLI
public:
property float Satflow_basic {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_basic_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satflow_basic_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_basic_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satflow_basic_adj
C#
public float Satflow_basic_adj {get;}
Managed Extensions for C++
public: __property float get_Satflow_basic_adj();
C++/CLI
public:
property float Satflow_basic_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_scats Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satflow_scats Property

Glossary Item Box

"SCATS" saturation flow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_scats As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satflow_scats
C#
public float Satflow_scats {get;}
Managed Extensions for C++
public: __property float get_Satflow_scats();
C++/CLI
public:
property float Satflow_scats {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satflow_scats_mf Property

Glossary Item Box

"SCATS" MF.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satflow_scats_mf
C#
public float Satflow_scats_mf {get;}
Managed Extensions for C++
public: __property float get_Satflow_scats_mf();
C++/CLI
public:
property float Satflow_scats_mf {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satn_flow
C#
public float Satn_flow {get;}
Managed Extensions for C++
public: __property float get_Satn_flow();
C++/CLI
public:
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satn_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satn_headway
C#
public float Satn_headway {get;}
Managed Extensions for C++
public: __property float get_Satn_headway();
C++/CLI
public:
property float Satn_headway {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_spacing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satn_spacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_spacing As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satn_spacing
C#
public float Satn_spacing {get;}
Managed Extensions for C++
public: __property float get_Satn_spacing();
C++/CLI
public:
property float Satn_spacing {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Satn_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Satn_speed
C#
public float Satn_speed {get;}
Managed Extensions for C++
public: __property float get_Satn_speed();
C++/CLI
public:
property float Satn_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_flow_moved Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Shortlane_flow_moved Property

Glossary Item Box

Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shortlane_flow_moved As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Boolean

value = instance.Shortlane_flow_moved
C#
public bool Shortlane_flow_moved {get;}
Managed Extensions for C++
public: __property bool get_Shortlane_flow_moved();
C++/CLI
public:
property bool Shortlane_flow_moved {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Space_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Space_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Space_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Space_scats_mf
C#
public float Space_scats_mf {get;}
Managed Extensions for C++
public: __property float get_Space_scats_mf();
C++/CLI
public:
property float Space_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stoprate_1 Property

Glossary Item Box

Stop rate 1st term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stoprate_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stoprate_1
C#
public float Stoprate_1 {get;}
Managed Extensions for C++
public: __property float get_Stoprate_1();
C++/CLI
public:
property float Stoprate_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stoprate_2 Property

Glossary Item Box

Stop rate 2nd term.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stoprate_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stoprate_2
C#
public float Stoprate_2 {get;}
Managed Extensions for C++
public: __property float get_Stoprate_2();
C++/CLI
public:
property float Stoprate_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_geo Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stoprate_geo Property

Glossary Item Box

"Geometric" stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stoprate_geo As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stoprate_geo
C#
public float Stoprate_geo {get;}
Managed Extensions for C++
public: __property float get_Stoprate_geo();
C++/CLI
public:
property float Stoprate_geo {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_overall Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stoprate_overall Property

Glossary Item Box

Overall Stop Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stoprate_overall As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stoprate_overall
C#
public float Stoprate_overall {get;}
Managed Extensions for C++
public: __property float get_Stoprate_overall();
C++/CLI
public:
property float Stoprate_overall {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_qmovup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Stoprate_qmovup Property

Glossary Item Box

Queue move up rate (sum of both green periods).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stoprate_qmovup As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Stoprate_qmovup
C#
public float Stoprate_qmovup {get;}
Managed Extensions for C++
public: __property float get_Stoprate_qmovup();
C++/CLI
public:
property float Stoprate_qmovup {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
T2_reduced Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : T2_reduced Property

Glossary Item Box

Flag indicating if second terms reduced due to short lane effects.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property T2_reduced As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Boolean

value = instance.T2_reduced
C#
public bool T2_reduced {get;}
Managed Extensions for C++
public: __property bool get_T2_reduced();
C++/CLI
public:
property bool T2_reduced {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Total_stops Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Total_stops
C#
public float Total_stops {get;}
Managed Extensions for C++
public: __property float get_Total_stops();
C++/CLI
public:
property float Total_stops {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Unblocked_time_ratio
C#
public float Unblocked_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Unblocked_time_ratio();
C++/CLI
public:
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Underutil_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Underutil_flag Property

Glossary Item Box

Reason for lane underutilisation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Underutil_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.Underutil_flag
C#
public int Underutil_flag {get;}
Managed Extensions for C++
public: __property int get_Underutil_flag();
C++/CLI
public:
property int Underutil_flag {
   int get();
}

Property Value

Type: System.Int32

0 = not underutilised
1 = program
2 = downstream
3 = user-specified

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upstr_flow_after_exit_sl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Upstr_flow_after_exit_sl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Upstr_flow_after_exit_sl As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Upstr_flow_after_exit_sl
C#
public float Upstr_flow_after_exit_sl {get;}
Managed Extensions for C++
public: __property float get_Upstr_flow_after_exit_sl();
C++/CLI
public:
property float Upstr_flow_after_exit_sl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Util_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : Util_factor Property

Glossary Item Box

Utilisation factor determined by the program.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Util_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Single

value = instance.Util_factor
C#
public float Util_factor {get;}
Managed Extensions for C++
public: __property float get_Util_factor();
C++/CLI
public:
property float Util_factor {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLane Class : X1_flag Property

Glossary Item Box

Degree of saturation = 1 flag.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLane
Dim value As Integer

value = instance.X1_flag
C#
public int X1_flag {get;}
Managed Extensions for C++
public: __property int get_X1_flag();
C++/CLI
public:
property int X1_flag {
   int get();
}

Property Value

Type: System.Int32

0 = x != 1
1 = x = 1 due to short lane
2 = x = 1 due to minimum capacity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLane Class
SIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriod Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriod Class

Glossary Item Box

Object Model

SIAPIOutputLaneGreenPeriod ClassISIAPIOutputLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneGreenPeriod
   Implements ISIAPIOutputLaneGreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
C#
public sealed class SIAPIOutputLaneGreenPeriod : ISIAPIOutputLaneGreenPeriod
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneGreenPeriod : public ISIAPIOutputLaneGreenPeriod
C++/CLI
public ref class SIAPIOutputLaneGreenPeriod sealed : public ISIAPIOutputLaneGreenPeriod

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneGreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriod Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriod Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneGreenPeriod.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneGreenPeriod Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity |
Public Property | Depflow_gt_adjsatn |
Public Property | Eff_green_end |
Public Property | Eff_green_start |
Public Property | End_sat_green |
Public Property | Flow_ratio |
Public Property | Green_end_time |
Public Property | Green_ratio |
Public Property | Green_satn_time |
Public Property | Green_start_time |
Public Property | GreenPeriod | Green Period value is a one-based integer.
Public Property | OutputLane |
Public Property | Queclearance_time |
Public Property | Queue_discharge_rate |
Public Property | Residual_queue |
Public Property | Satflow_full |
Public Property | Satflow_laneblock_adj |
Public Property | Satflow_queuecleartime_adj |
Public Property | Satflow_reduced |
Public Property | Shortlane_effect |
Public Property | Subcycle |
Top

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriod Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : SIAPIOutputLaneGreenPeriod Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneGreenPeriod()
C#
public SIAPIOutputLaneGreenPeriod()
Managed Extensions for C++
public: SIAPIOutputLaneGreenPeriod();
C++/CLI
public:
SIAPIOutputLaneGreenPeriod();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriod Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriod Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneGreenPeriod members.

Public Properties

 | Name | Description
Public Property | Capacity |
Public Property | Depflow_gt_adjsatn |
Public Property | Eff_green_end |
Public Property | Eff_green_start |
Public Property | End_sat_green |
Public Property | Flow_ratio |
Public Property | Green_end_time |
Public Property | Green_ratio |
Public Property | Green_satn_time |
Public Property | Green_start_time |
Public Property | GreenPeriod | Green Period value is a one-based integer.
Public Property | OutputLane |
Public Property | Queclearance_time |
Public Property | Queue_discharge_rate |
Public Property | Residual_queue |
Public Property | Satflow_full |
Public Property | Satflow_laneblock_adj |
Public Property | Satflow_queuecleartime_adj |
Public Property | Satflow_reduced |
Public Property | Shortlane_effect |
Public Property | Subcycle |
Top

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Capacity
C#
public float Capacity {get;}
Managed Extensions for C++
public: __property float get_Capacity();
C++/CLI
public:
property float Capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Depflow_gt_adjsatn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Depflow_gt_adjsatn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Depflow_gt_adjsatn As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Depflow_gt_adjsatn
C#
public int Depflow_gt_adjsatn {get;}
Managed Extensions for C++
public: __property int get_Depflow_gt_adjsatn();
C++/CLI
public:
property int Depflow_gt_adjsatn {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green_end Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Eff_green_end Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_green_end As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Eff_green_end
C#
public int Eff_green_end {get;}
Managed Extensions for C++
public: __property int get_Eff_green_end();
C++/CLI
public:
property int Eff_green_end {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green_start Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Eff_green_start Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_green_start As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Eff_green_start
C#
public int Eff_green_start {get;}
Managed Extensions for C++
public: __property int get_Eff_green_start();
C++/CLI
public:
property int Eff_green_start {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_sat_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : End_sat_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property End_sat_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.End_sat_green
C#
public int End_sat_green {get;}
Managed Extensions for C++
public: __property int get_End_sat_green();
C++/CLI
public:
property int End_sat_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
public float Flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Flow_ratio();
C++/CLI
public:
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Green_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Green_end_time
C#
public int Green_end_time {get;}
Managed Extensions for C++
public: __property int get_Green_end_time();
C++/CLI
public:
property int Green_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Green_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Green_ratio
C#
public float Green_ratio {get;}
Managed Extensions for C++
public: __property float get_Green_ratio();
C++/CLI
public:
property float Green_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_satn_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Green_satn_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_satn_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Green_satn_time
C#
public float Green_satn_time {get;}
Managed Extensions for C++
public: __property float get_Green_satn_time();
C++/CLI
public:
property float Green_satn_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Green_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Green_start_time
C#
public int Green_start_time {get;}
Managed Extensions for C++
public: __property int get_Green_start_time();
C++/CLI
public:
property int Green_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : GreenPeriod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GreenPeriod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.GreenPeriod
C#
public int GreenPeriod {get;}
Managed Extensions for C++
public: __property int get_GreenPeriod();
C++/CLI
public:
property int GreenPeriod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
public ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLane* get_OutputLane();
C++/CLI
public:
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queclearance_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Queclearance_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queclearance_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Queclearance_time
C#
public float Queclearance_time {get;}
Managed Extensions for C++
public: __property float get_Queclearance_time();
C++/CLI
public:
property float Queclearance_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_discharge_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Queue_discharge_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_discharge_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Queue_discharge_rate
C#
public float Queue_discharge_rate {get;}
Managed Extensions for C++
public: __property float get_Queue_discharge_rate();
C++/CLI
public:
property float Queue_discharge_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Residual_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Residual_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Residual_queue
C#
public float Residual_queue {get;}
Managed Extensions for C++
public: __property float get_Residual_queue();
C++/CLI
public:
property float Residual_queue {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_full Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Satflow_full Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_full As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_full
C#
public float Satflow_full {get;}
Managed Extensions for C++
public: __property float get_Satflow_full();
C++/CLI
public:
property float Satflow_full {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_laneblock_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Satflow_laneblock_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_laneblock_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_laneblock_adj
C#
public float Satflow_laneblock_adj {get;}
Managed Extensions for C++
public: __property float get_Satflow_laneblock_adj();
C++/CLI
public:
property float Satflow_laneblock_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_queuecleartime_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Satflow_queuecleartime_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_queuecleartime_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_queuecleartime_adj
C#
public float Satflow_queuecleartime_adj {get;}
Managed Extensions for C++
public: __property float get_Satflow_queuecleartime_adj();
C++/CLI
public:
property float Satflow_queuecleartime_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_reduced Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Satflow_reduced Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satflow_reduced As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_reduced
C#
public float Satflow_reduced {get;}
Managed Extensions for C++
public: __property float get_Satflow_reduced();
C++/CLI
public:
property float Satflow_reduced {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Shortlane_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shortlane_effect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Boolean

value = instance.Shortlane_effect
C#
public bool Shortlane_effect {get;}
Managed Extensions for C++
public: __property bool get_Shortlane_effect();
C++/CLI
public:
property bool Shortlane_effect {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Subcycle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriod Class : Subcycle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subcycle As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Subcycle
C#
public int Subcycle {get;}
Managed Extensions for C++
public: __property int get_Subcycle();
C++/CLI
public:
property int Subcycle {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriod Class
SIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriods Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriods Class

Glossary Item Box

Object Model

SIAPIOutputLaneGreenPeriods ClassISIAPIOutputLaneGreenPeriod Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneGreenPeriods
   Implements ISIAPIOutputLaneGreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriods
C#
public sealed class SIAPIOutputLaneGreenPeriods : ISIAPIOutputLaneGreenPeriods
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneGreenPeriods : public ISIAPIOutputLaneGreenPeriods
C++/CLI
public ref class SIAPIOutputLaneGreenPeriods sealed : public ISIAPIOutputLaneGreenPeriods

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneGreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriods Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriods Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneGreenPeriods.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneGreenPeriods Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an Approach Lane Output Green Period Data. Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriods Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriods Class : SIAPIOutputLaneGreenPeriods Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneGreenPeriods()
C#
public SIAPIOutputLaneGreenPeriods()
Managed Extensions for C++
public: SIAPIOutputLaneGreenPeriods();
C++/CLI
public:
SIAPIOutputLaneGreenPeriods();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriods Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneGreenPeriods members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriods Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriods
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriods Class : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
public bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
public: bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
public:
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneGreenPeriods Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneGreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneGreenPeriods members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an Approach Lane Output Green Period Data. Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriods Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriods
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneGreenPeriods Class : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get an Approach Lane Output Green Period Data.
Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputLaneGreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneGreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputLaneGreenPeriod

value = instance.Item(greenperiod)
C#
public ISIAPIOutputLaneGreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneGreenPeriod* get_Item   int greenperiod
;
C++/CLI
public:
property ISIAPIOutputLaneGreenPeriod^ default [int] {
   ISIAPIOutputLaneGreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneGreenPeriods Class
SIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMC Class

Glossary Item Box

Object Model

SIAPIOutputLaneMC ClassISIAPIOutputLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneMC
   Implements ISIAPIOutputLaneMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
C#
public sealed class SIAPIOutputLaneMC : ISIAPIOutputLaneMC
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneMC : public ISIAPIOutputLaneMC
C++/CLI
public ref class SIAPIOutputLaneMC sealed : public ISIAPIOutputLaneMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMC Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Calc_exists |
Public Property | Exist_in_nw_upstream_only |
Public Property | Flow_total |
Public Property | Flow_total_capconstr |
Public Property | Lane_change_from_left |
Public Property | Lane_change_from_right |
Public Property | Lane_change_to_left |
Public Property | Lane_change_to_right |
Public Property | MC_class |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | OutputLane |
Public Property | Upstr_flow_after_exit_sl |
Top

See Also

Reference

SIAPIOutputLaneMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : SIAPIOutputLaneMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneMC()
C#
public SIAPIOutputLaneMC()
Managed Extensions for C++
public: SIAPIOutputLaneMC();
C++/CLI
public:
SIAPIOutputLaneMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMC Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneMC members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Calc_exists |
Public Property | Exist_in_nw_upstream_only |
Public Property | Flow_total |
Public Property | Flow_total_capconstr |
Public Property | Lane_change_from_left |
Public Property | Lane_change_from_right |
Public Property | Lane_change_to_left |
Public Property | Lane_change_to_right |
Public Property | MC_class |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | OutputLane |
Public Property | Upstr_flow_after_exit_sl |
Top

See Also

Reference

SIAPIOutputLaneMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Boolean

value = instance.Calc_exists
C#
public bool Calc_exists {get;}
Managed Extensions for C++
public: __property bool get_Calc_exists();
C++/CLI
public:
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exist_in_nw_upstream_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Exist_in_nw_upstream_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exist_in_nw_upstream_only As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Boolean

value = instance.Exist_in_nw_upstream_only
C#
public bool Exist_in_nw_upstream_only {get;}
Managed Extensions for C++
public: __property bool get_Exist_in_nw_upstream_only();
C++/CLI
public:
property bool Exist_in_nw_upstream_only {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Flow_total
C#
public float Flow_total {get;}
Managed Extensions for C++
public: __property float get_Flow_total();
C++/CLI
public:
property float Flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Flow_total_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Flow_total_capconstr
C#
public float Flow_total_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_total_capconstr();
C++/CLI
public:
property float Flow_total_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Lane_change_from_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_from_left As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_from_left
C#
public float Lane_change_from_left {get;}
Managed Extensions for C++
public: __property float get_Lane_change_from_left();
C++/CLI
public:
property float Lane_change_from_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Lane_change_from_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_from_right As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_from_right
C#
public float Lane_change_from_right {get;}
Managed Extensions for C++
public: __property float get_Lane_change_from_right();
C++/CLI
public:
property float Lane_change_from_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Lane_change_to_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_to_left
C#
public float Lane_change_to_left {get;}
Managed Extensions for C++
public: __property float get_Lane_change_to_left();
C++/CLI
public:
property float Lane_change_to_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Lane_change_to_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_to_right
C#
public float Lane_change_to_right {get;}
Managed Extensions for C++
public: __property float get_Lane_change_to_right();
C++/CLI
public:
property float Lane_change_to_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Net_inflow
C#
public float Net_inflow {get;}
Managed Extensions for C++
public: __property float get_Net_inflow();
C++/CLI
public:
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Net_inflow_capconstr
C#
public float Net_inflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_inflow_capconstr();
C++/CLI
public:
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
public ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLane* get_OutputLane();
C++/CLI
public:
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upstr_flow_after_exit_sl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMC Class : Upstr_flow_after_exit_sl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Upstr_flow_after_exit_sl As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMC
Dim value As Single

value = instance.Upstr_flow_after_exit_sl
C#
public float Upstr_flow_after_exit_sl {get;}
Managed Extensions for C++
public: __property float get_Upstr_flow_after_exit_sl();
C++/CLI
public:
property float Upstr_flow_after_exit_sl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMC Class
SIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMCs Class

Glossary Item Box

Object Model

SIAPIOutputLaneMCs ClassISIAPIOutputLaneMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneMCs
   Implements ISIAPIOutputLaneMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMCs
C#
public sealed class SIAPIOutputLaneMCs : ISIAPIOutputLaneMCs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneMCs : public ISIAPIOutputLaneMCs
C++/CLI
public ref class SIAPIOutputLaneMCs sealed : public ISIAPIOutputLaneMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLaneMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMCs Class : SIAPIOutputLaneMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneMCs()
C#
public SIAPIOutputLaneMCs()
Managed Extensions for C++
public: SIAPIOutputLaneMCs();
C++/CLI
public:
SIAPIOutputLaneMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Class
SIAPIOutputLaneMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLaneMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Class
SIAPIOutputLaneMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMCs Class : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Class
SIAPIOutputLaneMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLaneMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Class
SIAPIOutputLaneMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneMCs Class : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLaneMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLaneMC

value = instance.Item(mcClass)
C#
public ISIAPIOutputLaneMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIOutputLaneMC^ default [int] {
   ISIAPIOutputLaneMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneMCs Class
SIAPIOutputLaneMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneOD Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneOD Class

Glossary Item Box

Object Model

SIAPIOutputLaneOD ClassISIAPIOutputLane InterfaceISIAPIOutputLaneODMCs InterfaceISIAPIOutputLaneODMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneOD
   Implements ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
C#
public sealed class SIAPIOutputLaneOD : ISIAPIOutputLaneOD
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneOD : public ISIAPIOutputLaneOD
C++/CLI
public ref class SIAPIOutputLaneOD sealed : public ISIAPIOutputLaneOD

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneOD Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneOD Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneOD.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneOD Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Average_speed |
Public Property | Average_speed_flag |
Public Property | Calc_exists |
Public Property | Cap_constraint_effect |
Public Property | Crit_gap |
Public Property | Crit_gap_flag |
Public Property | Critical_spacing |
Public Property | Destination |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Foll_up_hdwy |
Public Property | Foll_up_hdwy_flag |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | HVE_for_entry |
Public Property | HVE_pcu |
Public Property | Intrabunch_headway |
Public Property | Intrabunch_headway_flag |
Public Property | Lane_output_type |
Public Property | Minimum_delay |
Public Property | OD_factor |
Public Property | OD_factor_flag |
Public Property | Opposing_flow |
Public Property | Opposing_flow_flag |
Public Property | Opposing_flow_pcu |
Public Property | Opposing_flow_ped |
Public Property | Opposing_flow_ped_flag |
Public Property | OutputLane |
Public Property | OutputLaneODMCs |
Public Property | Percent_exit_flow_incl |
Public Property | Percent_nearest_lane_only |
Public Property | Priority_sharing_flag |
Public Property | Proportion_bunched |
Public Property | Proportion_bunched_flag |
Public Property | Subdom_eq_dom |
Public Property | Unblocked_time_ratio |
Top

See Also

Reference

SIAPIOutputLaneOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneOD Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : SIAPIOutputLaneOD Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneOD()
C#
public SIAPIOutputLaneOD()
Managed Extensions for C++
public: SIAPIOutputLaneOD();
C++/CLI
public:
SIAPIOutputLaneOD();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneOD Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneOD Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneOD members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Average_speed |
Public Property | Average_speed_flag |
Public Property | Calc_exists |
Public Property | Cap_constraint_effect |
Public Property | Crit_gap |
Public Property | Crit_gap_flag |
Public Property | Critical_spacing |
Public Property | Destination |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Foll_up_hdwy |
Public Property | Foll_up_hdwy_flag |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | HVE_for_entry |
Public Property | HVE_pcu |
Public Property | Intrabunch_headway |
Public Property | Intrabunch_headway_flag |
Public Property | Lane_output_type |
Public Property | Minimum_delay |
Public Property | OD_factor |
Public Property | OD_factor_flag |
Public Property | Opposing_flow |
Public Property | Opposing_flow_flag |
Public Property | Opposing_flow_pcu |
Public Property | Opposing_flow_ped |
Public Property | Opposing_flow_ped_flag |
Public Property | OutputLane |
Public Property | OutputLaneODMCs |
Public Property | Percent_exit_flow_incl |
Public Property | Percent_nearest_lane_only |
Public Property | Priority_sharing_flag |
Public Property | Proportion_bunched |
Public Property | Proportion_bunched_flag |
Public Property | Subdom_eq_dom |
Public Property | Unblocked_time_ratio |
Top

See Also

Reference

SIAPIOutputLaneOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Average_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Average_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Average_speed
C#
public float Average_speed {get;}
Managed Extensions for C++
public: __property float get_Average_speed();
C++/CLI
public:
property float Average_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_speed_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Average_speed_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Average_speed_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Average_speed_flag
C#
public int Average_speed_flag {get;}
Managed Extensions for C++
public: __property int get_Average_speed_flag();
C++/CLI
public:
property int Average_speed_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Boolean

value = instance.Calc_exists
C#
public bool Calc_exists {get;}
Managed Extensions for C++
public: __property bool get_Calc_exists();
C++/CLI
public:
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cap_constraint_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Cap_constraint_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cap_constraint_effect As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Cap_constraint_effect
C#
public int Cap_constraint_effect {get;}
Managed Extensions for C++
public: __property int get_Cap_constraint_effect();
C++/CLI
public:
property int Cap_constraint_effect {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crit_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Crit_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Crit_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Crit_gap
C#
public float Crit_gap {get;}
Managed Extensions for C++
public: __property float get_Crit_gap();
C++/CLI
public:
property float Crit_gap {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crit_gap_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Crit_gap_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Crit_gap_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Crit_gap_flag
C#
public int Crit_gap_flag {get;}
Managed Extensions for C++
public: __property int get_Crit_gap_flag();
C++/CLI
public:
property int Crit_gap_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_spacing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Critical_spacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_spacing As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Critical_spacing
C#
public float Critical_spacing {get;}
Managed Extensions for C++
public: __property float get_Critical_spacing();
C++/CLI
public:
property float Critical_spacing {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Flow
C#
public float Flow {get;}
Managed Extensions for C++
public: __property float get_Flow();
C++/CLI
public:
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Flow_capconstr
C#
public float Flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_capconstr();
C++/CLI
public:
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Foll_up_hdwy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Foll_up_hdwy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Foll_up_hdwy As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Foll_up_hdwy
C#
public float Foll_up_hdwy {get;}
Managed Extensions for C++
public: __property float get_Foll_up_hdwy();
C++/CLI
public:
property float Foll_up_hdwy {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Foll_up_hdwy_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Foll_up_hdwy_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Foll_up_hdwy_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Foll_up_hdwy_flag
C#
public int Foll_up_hdwy_flag {get;}
Managed Extensions for C++
public: __property int get_Foll_up_hdwy_flag();
C++/CLI
public:
property int Foll_up_hdwy_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
public float Gap_accept_blocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_blocked_time();
C++/CLI
public:
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
public float Gap_accept_cycle_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_cycle_time();
C++/CLI
public:
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
public float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_unblocked_time();
C++/CLI
public:
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HVE_for_entry Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : HVE_for_entry Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HVE_for_entry As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.HVE_for_entry
C#
public float HVE_for_entry {get;}
Managed Extensions for C++
public: __property float get_HVE_for_entry();
C++/CLI
public:
property float HVE_for_entry {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HVE_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : HVE_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HVE_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.HVE_pcu
C#
public float HVE_pcu {get;}
Managed Extensions for C++
public: __property float get_HVE_pcu();
C++/CLI
public:
property float HVE_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intrabunch_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Intrabunch_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Intrabunch_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Intrabunch_headway
C#
public float Intrabunch_headway {get;}
Managed Extensions for C++
public: __property float get_Intrabunch_headway();
C++/CLI
public:
property float Intrabunch_headway {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intrabunch_headway_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Intrabunch_headway_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Intrabunch_headway_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Intrabunch_headway_flag
C#
public int Intrabunch_headway_flag {get;}
Managed Extensions for C++
public: __property int get_Intrabunch_headway_flag();
C++/CLI
public:
property int Intrabunch_headway_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_output_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Lane_output_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lane_output_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Lane_output_type
C#
public int Lane_output_type {get;}
Managed Extensions for C++
public: __property int get_Lane_output_type();
C++/CLI
public:
property int Lane_output_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Minimum_delay
C#
public float Minimum_delay {get;}
Managed Extensions for C++
public: __property float get_Minimum_delay();
C++/CLI
public:
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OD_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : OD_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OD_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.OD_factor
C#
public float OD_factor {get;}
Managed Extensions for C++
public: __property float get_OD_factor();
C++/CLI
public:
property float OD_factor {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OD_factor_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : OD_factor_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OD_factor_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.OD_factor_flag
C#
public int OD_factor_flag {get;}
Managed Extensions for C++
public: __property int get_OD_factor_flag();
C++/CLI
public:
property int OD_factor_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Opposing_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow
C#
public float Opposing_flow {get;}
Managed Extensions for C++
public: __property float get_Opposing_flow();
C++/CLI
public:
property float Opposing_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Opposing_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Opposing_flow_flag
C#
public int Opposing_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Opposing_flow_flag();
C++/CLI
public:
property int Opposing_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Opposing_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow_pcu
C#
public float Opposing_flow_pcu {get;}
Managed Extensions for C++
public: __property float get_Opposing_flow_pcu();
C++/CLI
public:
property float Opposing_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Opposing_flow_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_flow_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow_ped
C#
public float Opposing_flow_ped {get;}
Managed Extensions for C++
public: __property float get_Opposing_flow_ped();
C++/CLI
public:
property float Opposing_flow_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_ped_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Opposing_flow_ped_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposing_flow_ped_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Opposing_flow_ped_flag
C#
public int Opposing_flow_ped_flag {get;}
Managed Extensions for C++
public: __property int get_Opposing_flow_ped_flag();
C++/CLI
public:
property int Opposing_flow_ped_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
public ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLane* get_OutputLane();
C++/CLI
public:
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : OutputLaneODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLaneODMCs As ISIAPIOutputLaneODMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As ISIAPIOutputLaneODMCs

value = instance.OutputLaneODMCs
C#
public ISIAPIOutputLaneODMCs OutputLaneODMCs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneODMCs* get_OutputLaneODMCs();
C++/CLI
public:
property ISIAPIOutputLaneODMCs^ OutputLaneODMCs {
   ISIAPIOutputLaneODMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_exit_flow_incl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Percent_exit_flow_incl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Percent_exit_flow_incl As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Percent_exit_flow_incl
C#
public float Percent_exit_flow_incl {get;}
Managed Extensions for C++
public: __property float get_Percent_exit_flow_incl();
C++/CLI
public:
property float Percent_exit_flow_incl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_nearest_lane_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Percent_nearest_lane_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Percent_nearest_lane_only As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Percent_nearest_lane_only
C#
public float Percent_nearest_lane_only {get;}
Managed Extensions for C++
public: __property float get_Percent_nearest_lane_only();
C++/CLI
public:
property float Percent_nearest_lane_only {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority_sharing_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Priority_sharing_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Priority_sharing_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Priority_sharing_flag
C#
public int Priority_sharing_flag {get;}
Managed Extensions for C++
public: __property int get_Priority_sharing_flag();
C++/CLI
public:
property int Priority_sharing_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_bunched Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Proportion_bunched Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_bunched As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Proportion_bunched
C#
public float Proportion_bunched {get;}
Managed Extensions for C++
public: __property float get_Proportion_bunched();
C++/CLI
public:
property float Proportion_bunched {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_bunched_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Proportion_bunched_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_bunched_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Integer

value = instance.Proportion_bunched_flag
C#
public int Proportion_bunched_flag {get;}
Managed Extensions for C++
public: __property int get_Proportion_bunched_flag();
C++/CLI
public:
property int Proportion_bunched_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Subdom_eq_dom Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Subdom_eq_dom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subdom_eq_dom As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Boolean

value = instance.Subdom_eq_dom
C#
public bool Subdom_eq_dom {get;}
Managed Extensions for C++
public: __property bool get_Subdom_eq_dom();
C++/CLI
public:
property bool Subdom_eq_dom {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneOD Class : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneOD
Dim value As Single

value = instance.Unblocked_time_ratio
C#
public float Unblocked_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Unblocked_time_ratio();
C++/CLI
public:
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneOD Class
SIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMC Class

Glossary Item Box

Object Model

SIAPIOutputLaneODMC ClassISIAPIOutputLaneOD Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneODMC
   Implements ISIAPIOutputLaneODMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
C#
public sealed class SIAPIOutputLaneODMC : ISIAPIOutputLaneODMC
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneODMC : public ISIAPIOutputLaneODMC
C++/CLI
public ref class SIAPIOutputLaneODMC sealed : public ISIAPIOutputLaneODMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneODMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMC Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneODMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneODMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Calc_exists |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | MC_class |
Public Property | Minimum_delay |
Public Property | OutputLaneOD |
Public Property | Shortlane_overflow |
Public Property | Sl_overflow |
Public Property | Unblocked_time_ratio |
Top

See Also

Reference

SIAPIOutputLaneODMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : SIAPIOutputLaneODMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneODMC()
C#
public SIAPIOutputLaneODMC()
Managed Extensions for C++
public: SIAPIOutputLaneODMC();
C++/CLI
public:
SIAPIOutputLaneODMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMC Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneODMC members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Calc_exists |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | MC_class |
Public Property | Minimum_delay |
Public Property | OutputLaneOD |
Public Property | Shortlane_overflow |
Public Property | Sl_overflow |
Public Property | Unblocked_time_ratio |
Top

See Also

Reference

SIAPIOutputLaneODMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Boolean

value = instance.Calc_exists
C#
public bool Calc_exists {get;}
Managed Extensions for C++
public: __property bool get_Calc_exists();
C++/CLI
public:
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Flow
C#
public float Flow {get;}
Managed Extensions for C++
public: __property float get_Flow();
C++/CLI
public:
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Flow_capconstr
C#
public float Flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_capconstr();
C++/CLI
public:
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
public float Gap_accept_blocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_blocked_time();
C++/CLI
public:
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
public float Gap_accept_cycle_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_cycle_time();
C++/CLI
public:
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
public float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_unblocked_time();
C++/CLI
public:
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Minimum_delay
C#
public float Minimum_delay {get;}
Managed Extensions for C++
public: __property float get_Minimum_delay();
C++/CLI
public:
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneOD Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : OutputLaneOD Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLaneOD As ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As ISIAPIOutputLaneOD

value = instance.OutputLaneOD
C#
public ISIAPIOutputLaneOD OutputLaneOD {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneOD* get_OutputLaneOD();
C++/CLI
public:
property ISIAPIOutputLaneOD^ OutputLaneOD {
   ISIAPIOutputLaneOD^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Shortlane_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Shortlane_overflow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Boolean

value = instance.Shortlane_overflow
C#
public bool Shortlane_overflow {get;}
Managed Extensions for C++
public: __property bool get_Shortlane_overflow();
C++/CLI
public:
property bool Shortlane_overflow {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sl_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Sl_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sl_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Sl_overflow
C#
public float Sl_overflow {get;}
Managed Extensions for C++
public: __property float get_Sl_overflow();
C++/CLI
public:
property float Sl_overflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMC Class : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMC
Dim value As Single

value = instance.Unblocked_time_ratio
C#
public float Unblocked_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Unblocked_time_ratio();
C++/CLI
public:
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMC Class
SIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMCs Class

Glossary Item Box

Object Model

SIAPIOutputLaneODMCs ClassISIAPIOutputLaneODMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneODMCs
   Implements ISIAPIOutputLaneODMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMCs
C#
public sealed class SIAPIOutputLaneODMCs : ISIAPIOutputLaneODMCs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneODMCs : public ISIAPIOutputLaneODMCs
C++/CLI
public ref class SIAPIOutputLaneODMCs sealed : public ISIAPIOutputLaneODMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneODMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneODMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneODMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLaneODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMCs Class : SIAPIOutputLaneODMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneODMCs()
C#
public SIAPIOutputLaneODMCs()
Managed Extensions for C++
public: SIAPIOutputLaneODMCs();
C++/CLI
public:
SIAPIOutputLaneODMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Class
SIAPIOutputLaneODMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneODMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLaneODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Class
SIAPIOutputLaneODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMCs Class : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Class
SIAPIOutputLaneODMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneODMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLaneODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Class
SIAPIOutputLaneODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODMCs Class : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLaneODMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLaneODMC

value = instance.Item(mcClass)
C#
public ISIAPIOutputLaneODMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneODMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIOutputLaneODMC^ default [int] {
   ISIAPIOutputLaneODMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODMCs Class
SIAPIOutputLaneODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODs Class

Glossary Item Box

Object Model

SIAPIOutputLaneODs ClassISIAPIOutputLaneOD Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLaneODs
   Implements ISIAPIOutputLaneODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODs
C#
public sealed class SIAPIOutputLaneODs : ISIAPIOutputLaneODs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLaneODs : public ISIAPIOutputLaneODs
C++/CLI
public ref class SIAPIOutputLaneODs sealed : public ISIAPIOutputLaneODs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLaneODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLaneODs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLaneODs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneODExists |
Top

See Also

Reference

SIAPIOutputLaneODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODs Class : SIAPIOutputLaneODs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLaneODs()
C#
public SIAPIOutputLaneODs()
Managed Extensions for C++
public: SIAPIOutputLaneODs();
C++/CLI
public:
SIAPIOutputLaneODs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Class
SIAPIOutputLaneODs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneODs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneODExists |
Top

See Also

Reference

SIAPIOutputLaneODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Class
SIAPIOutputLaneODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneODExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODs Class : LaneODExists Method

destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneODExists( _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODs
Dim destination As Integer
Dim value As Boolean

value = instance.LaneODExists(destination)
C#
public bool LaneODExists(
   int destination
)
Managed Extensions for C++
public: bool LaneODExists(
   int destination
)
C++/CLI
public:
bool LaneODExists(
   int destination
)

Parameters

destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Class
SIAPIOutputLaneODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLaneODs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLaneODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLaneODs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLaneODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Class
SIAPIOutputLaneODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLaneODs Class : Item Property

destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal destination As Integer _
) As ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLaneODs
Dim destination As Integer
Dim value As ISIAPIOutputLaneOD

value = instance.Item(destination)
C#
public ISIAPIOutputLaneOD this[
   int destination
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLaneOD* get_Item   int destination
;
C++/CLI
public:
property ISIAPIOutputLaneOD^ default [int] {
   ISIAPIOutputLaneOD^ get(int destination);
}

Parameters

destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLaneODs Class
SIAPIOutputLaneODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLanes Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLanes Class

Glossary Item Box

SIAPIOutputLane collection

Object Model

SIAPIOutputLanes ClassISIAPIOutputLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLanes
   Implements ISIAPIOutputLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLanes
C#
public sealed class SIAPIOutputLanes : ISIAPIOutputLanes
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLanes : public ISIAPIOutputLanes
C++/CLI
public ref class SIAPIOutputLanes sealed : public ISIAPIOutputLanes

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLanes Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLanes Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLanes.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLanes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneExists |
Top

See Also

Reference

SIAPIOutputLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLanes Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLanes Class : SIAPIOutputLanes Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLanes()
C#
public SIAPIOutputLanes()
Managed Extensions for C++
public: SIAPIOutputLanes();
C++/CLI
public:
SIAPIOutputLanes();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Class
SIAPIOutputLanes Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLanes Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLanes members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LaneExists |
Top

See Also

Reference

SIAPIOutputLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLanes Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLanes
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Class
SIAPIOutputLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLanes Class : LaneExists Method

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LaneExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLanes
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExists(laneno)
C#
public bool LaneExists(
   int laneno
)
Managed Extensions for C++
public: bool LaneExists(
   int laneno
)
C++/CLI
public:
bool LaneExists(
   int laneno
)

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Class
SIAPIOutputLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLanes Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLanes members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLanes Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLanes
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Class
SIAPIOutputLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLanes Class : Item Property

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLanes
Dim laneno As Integer
Dim value As ISIAPIOutputLane

value = instance.Item(laneno)
C#
public ISIAPIOutputLane this[
   int laneno
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLane* get_Item   int laneno
;
C++/CLI
public:
property ISIAPIOutputLane^ default [int] {
   ISIAPIOutputLane^ get(int laneno);
}

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLanes Class
SIAPIOutputLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLeg Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLeg Class

Glossary Item Box

SIDRA INTERSECTION Output Leg wrapper class

Object Model

SIAPIOutputLeg ClassISIAPIOutputCirculatingLanes InterfaceISIAPIOutputCirculatingLane InterfaceISIAPIOutputLanes InterfaceISIAPIOutputLane InterfaceISIAPIOutputLegMCs InterfaceISIAPIOutputLegMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLeg
   Implements ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
C#
public sealed class SIAPIOutputLeg : ISIAPIOutputLeg
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLeg : public ISIAPIOutputLeg
C++/CLI
public ref class SIAPIOutputLeg sealed : public ISIAPIOutputLeg

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLeg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLeg Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLeg Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLeg.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLeg Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Average_entry_lane_width |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_effective | Effective intersection capacity.
Public Property | Capacity_lane_total | Sum of all lane capacities.
Public Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Public Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Public Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Public Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Public Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Public Property | Circulating_flow | Flow circulating in front of leg (veh) (roundabouts).
Public Property | Circulating_flow_pcu |
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total | Total control delay.
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Exiting_flow | Flow exiting to leg (veh).
Public Property | Exiting_flow_capconstr |
Public Property | Extra_bunching |
Public Property | Extra_bunching_flag |
Public Property | FHWA_capacity_zero_circ_flow |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate | Fuel consumption rate.
Public Property | Fuel_consumption_total | Total fuel consumption.
Public Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Public Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Public Property | Idling_time_average |
Public Property | Inscribed_diameter |
Public Property | Level_of_service | Approach LOS.
Public Property | Level_of_service_worstlane | Worst lane LOS on approach.
Public Property | Level_of_service_worstmov | Worst movement LOS on approach.
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | Nox_rate | NOX emission rate (g/km).
Public Property | Nox_total | Total NOX emissions (kg/h).
Public Property | Num_entry_lanes |
Public Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Public Property | Operating_cost_total | Total operating cost (cost unit/h).
Public Property | Orientation |
Public Property | OutputCirculatingLanes |
Public Property | OutputLanes |
Public Property | OutputLegMCs |
Public Property | Performance_index | Performance index.
Public Property | Platoonmode_type |
Public Property | Prop_queued_upstr_signal |
Public Property | Prop_queued_upstr_signal_flag |
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Public Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | SpeedEfficiency |
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Total_lane_changes |
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time.
Public Property | Travel_time_total | Total travel time.
Public Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

SIAPIOutputLeg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLeg Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : SIAPIOutputLeg Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLeg()
C#
public SIAPIOutputLeg()
Managed Extensions for C++
public: SIAPIOutputLeg();
C++/CLI
public:
SIAPIOutputLeg();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLeg Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLeg Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLeg members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Average_entry_lane_width |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_effective | Effective intersection capacity.
Public Property | Capacity_lane_total | Sum of all lane capacities.
Public Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Public Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Public Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Public Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Public Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Public Property | Circulating_flow | Flow circulating in front of leg (veh) (roundabouts).
Public Property | Circulating_flow_pcu |
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total | Total control delay.
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Exiting_flow | Flow exiting to leg (veh).
Public Property | Exiting_flow_capconstr |
Public Property | Extra_bunching |
Public Property | Extra_bunching_flag |
Public Property | FHWA_capacity_zero_circ_flow |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate | Fuel consumption rate.
Public Property | Fuel_consumption_total | Total fuel consumption.
Public Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Public Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Public Property | Idling_time_average |
Public Property | Inscribed_diameter |
Public Property | Level_of_service | Approach LOS.
Public Property | Level_of_service_worstlane | Worst lane LOS on approach.
Public Property | Level_of_service_worstmov | Worst movement LOS on approach.
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | Nox_rate | NOX emission rate (g/km).
Public Property | Nox_total | Total NOX emissions (kg/h).
Public Property | Num_entry_lanes |
Public Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Public Property | Operating_cost_total | Total operating cost (cost unit/h).
Public Property | Orientation |
Public Property | OutputCirculatingLanes |
Public Property | OutputLanes |
Public Property | OutputLegMCs |
Public Property | Performance_index | Performance index.
Public Property | Platoonmode_type |
Public Property | Prop_queued_upstr_signal |
Public Property | Prop_queued_upstr_signal_flag |
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Public Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | SpeedEfficiency |
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Total_lane_changes |
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time.
Public Property | Travel_time_total | Total travel time.
Public Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

SIAPIOutputLeg Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_entry_lane_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Average_entry_lane_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Average_entry_lane_width As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Average_entry_lane_width
C#
public float Average_entry_lane_width {get;}
Managed Extensions for C++
public: __property float get_Average_entry_lane_width();
C++/CLI
public:
property float Average_entry_lane_width {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
public float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
public: __property float get_Avg_num_of_cycles_to_depart();
C++/CLI
public:
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
public int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
public: __property int get_Capacity_adj_flag_worstlane();
C++/CLI
public:
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
public float Capacity_adj_worstlane {get;}
Managed Extensions for C++
public: __property float get_Capacity_adj_worstlane();
C++/CLI
public:
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Capacity_effective Property

Glossary Item Box

Effective intersection capacity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Capacity_effective
C#
public float Capacity_effective {get;}
Managed Extensions for C++
public: __property float get_Capacity_effective();
C++/CLI
public:
property float Capacity_effective {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_lane_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Capacity_lane_total Property

Glossary Item Box

Sum of all lane capacities.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_lane_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Capacity_lane_total
C#
public float Capacity_lane_total {get;}
Managed Extensions for C++
public: __property float get_Capacity_lane_total();
C++/CLI
public:
property float Capacity_lane_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Capacity_mov_total Property

Glossary Item Box

Sum of movement capacities (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_mov_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Capacity_mov_total
C#
public float Capacity_mov_total {get;}
Managed Extensions for C++
public: __property float get_Capacity_mov_total();
C++/CLI
public:
property float Capacity_mov_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Carbon_dioxide_rate Property

Glossary Item Box

Carbon Dioxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
public float Carbon_dioxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_rate();
C++/CLI
public:
property float Carbon_dioxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Carbon_dioxide_total Property

Glossary Item Box

Total Carbon Dioxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Carbon_monoxide_rate Property

Glossary Item Box

Carbon Monoxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
public float Carbon_monoxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_rate();
C++/CLI
public:
property float Carbon_monoxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Carbon_monoxide_total Property

Glossary Item Box

Total Carbon Monoxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Circulating_flow Property

Glossary Item Box

Flow circulating in front of leg (veh) (roundabouts).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Circulating_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Circulating_flow
C#
public float Circulating_flow {get;}
Managed Extensions for C++
public: __property float get_Circulating_flow();
C++/CLI
public:
property float Circulating_flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Circulating_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Circulating_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Circulating_flow_pcu
C#
public float Circulating_flow_pcu {get;}
Managed Extensions for C++
public: __property float get_Circulating_flow_pcu();
C++/CLI
public:
property float Circulating_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
public float Delay_control_average_worstlane {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstlane();
C++/CLI
public:
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_geometric
C#
public float Delay_geometric {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric();
C++/CLI
public:
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Exiting_flow Property

Glossary Item Box

Flow exiting to leg (veh).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exiting_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Exiting_flow
C#
public float Exiting_flow {get;}
Managed Extensions for C++
public: __property float get_Exiting_flow();
C++/CLI
public:
property float Exiting_flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Exiting_flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exiting_flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Exiting_flow_capconstr
C#
public float Exiting_flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Exiting_flow_capconstr();
C++/CLI
public:
property float Exiting_flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Extra_bunching Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Extra_bunching As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Extra_bunching
C#
public float Extra_bunching {get;}
Managed Extensions for C++
public: __property float get_Extra_bunching();
C++/CLI
public:
property float Extra_bunching {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Extra_bunching_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Extra_bunching_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Extra_bunching_flag
C#
public int Extra_bunching_flag {get;}
Managed Extensions for C++
public: __property int get_Extra_bunching_flag();
C++/CLI
public:
property int Extra_bunching_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FHWA_capacity_zero_circ_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : FHWA_capacity_zero_circ_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FHWA_capacity_zero_circ_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.FHWA_capacity_zero_circ_flow
C#
public float FHWA_capacity_zero_circ_flow {get;}
Managed Extensions for C++
public: __property float get_FHWA_capacity_zero_circ_flow();
C++/CLI
public:
property float FHWA_capacity_zero_circ_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV
C#
public float Flow_HV {get;}
Managed Extensions for C++
public: __property float get_Flow_HV();
C++/CLI
public:
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_capconstr
C#
public float Flow_HV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_capconstr();
C++/CLI
public:
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_HV_pct Property

Glossary Item Box

Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_pct
C#
public float Flow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct();
C++/CLI
public:
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
public float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct_capconstr();
C++/CLI
public:
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_LV
C#
public float Flow_LV {get;}
Managed Extensions for C++
public: __property float get_Flow_LV();
C++/CLI
public:
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_LV_capconstr
C#
public float Flow_LV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_LV_capconstr();
C++/CLI
public:
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_total
C#
public float Flow_total {get;}
Managed Extensions for C++
public: __property float get_Flow_total();
C++/CLI
public:
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Flow_total_capconstr
C#
public float Flow_total_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_total_capconstr();
C++/CLI
public:
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Fuel_consumption_rate Property

Glossary Item Box

Fuel consumption rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Fuel_consumption_rate
C#
public float Fuel_consumption_rate {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_rate();
C++/CLI
public:
property float Fuel_consumption_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Fuel_consumption_total Property

Glossary Item Box

Total fuel consumption.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Hydrocarbons_rate Property

Glossary Item Box

Hydrocarbon emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Hydrocarbons_rate
C#
public float Hydrocarbons_rate {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_rate();
C++/CLI
public:
property float Hydrocarbons_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Hydrocarbons_total Property

Glossary Item Box

Total Hydrocarbon emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Idling_time_average
C#
public float Idling_time_average {get;}
Managed Extensions for C++
public: __property float get_Idling_time_average();
C++/CLI
public:
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Inscribed_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Inscribed_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Inscribed_diameter
C#
public float Inscribed_diameter {get;}
Managed Extensions for C++
public: __property float get_Inscribed_diameter();
C++/CLI
public:
property float Inscribed_diameter {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Level_of_service Property

Glossary Item Box

Approach LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Level_of_service_worstlane Property

Glossary Item Box

Worst lane LOS on approach.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_worstlane As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As String

value = instance.Level_of_service_worstlane
C#
public string Level_of_service_worstlane {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_worstlane();
C++/CLI
public:
property String^ Level_of_service_worstlane {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Level_of_service_worstmov Property

Glossary Item Box

Worst movement LOS on approach.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As String

value = instance.Level_of_service_worstmov
C#
public string Level_of_service_worstmov {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_worstmov();
C++/CLI
public:
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Net_inflow
C#
public float Net_inflow {get;}
Managed Extensions for C++
public: __property float get_Net_inflow();
C++/CLI
public:
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Net_inflow_capconstr
C#
public float Net_inflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_inflow_capconstr();
C++/CLI
public:
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Net_outflow
C#
public float Net_outflow {get;}
Managed Extensions for C++
public: __property float get_Net_outflow();
C++/CLI
public:
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Net_outflow_capconstr
C#
public float Net_outflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_outflow_capconstr();
C++/CLI
public:
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Nox_rate Property

Glossary Item Box

NOX emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Nox_rate
C#
public float Nox_rate {get;}
Managed Extensions for C++
public: __property float get_Nox_rate();
C++/CLI
public:
property float Nox_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Nox_total Property

Glossary Item Box

Total NOX emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_entry_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Num_entry_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Num_entry_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Num_entry_lanes
C#
public int Num_entry_lanes {get;}
Managed Extensions for C++
public: __property int get_Num_entry_lanes();
C++/CLI
public:
property int Num_entry_lanes {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Operating_cost_rate Property

Glossary Item Box

Operating cost rate (cost unit/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Operating_cost_rate
C#
public float Operating_cost_rate {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_rate();
C++/CLI
public:
property float Operating_cost_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Orientation
C#
public int Orientation {get;}
Managed Extensions for C++
public: __property int get_Orientation();
C++/CLI
public:
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputCirculatingLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : OutputCirculatingLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputCirculatingLanes As ISIAPIOutputCirculatingLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As ISIAPIOutputCirculatingLanes

value = instance.OutputCirculatingLanes
C#
public ISIAPIOutputCirculatingLanes OutputCirculatingLanes {get;}
Managed Extensions for C++
public: __property ISIAPIOutputCirculatingLanes* get_OutputCirculatingLanes();
C++/CLI
public:
property ISIAPIOutputCirculatingLanes^ OutputCirculatingLanes {
   ISIAPIOutputCirculatingLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : OutputLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLanes As ISIAPIOutputLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As ISIAPIOutputLanes

value = instance.OutputLanes
C#
public ISIAPIOutputLanes OutputLanes {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLanes* get_OutputLanes();
C++/CLI
public:
property ISIAPIOutputLanes^ OutputLanes {
   ISIAPIOutputLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : OutputLegMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLegMCs As ISIAPIOutputLegMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As ISIAPIOutputLegMCs

value = instance.OutputLegMCs
C#
public ISIAPIOutputLegMCs OutputLegMCs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLegMCs* get_OutputLegMCs();
C++/CLI
public:
property ISIAPIOutputLegMCs^ OutputLegMCs {
   ISIAPIOutputLegMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoonmode_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Platoonmode_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Platoonmode_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Platoonmode_type
C#
public int Platoonmode_type {get;}
Managed Extensions for C++
public: __property int get_Platoonmode_type();
C++/CLI
public:
property int Platoonmode_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_upstr_signal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Prop_queued_upstr_signal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_upstr_signal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Prop_queued_upstr_signal
C#
public float Prop_queued_upstr_signal {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_upstr_signal();
C++/CLI
public:
property float Prop_queued_upstr_signal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_upstr_signal_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Prop_queued_upstr_signal_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_upstr_signal_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.Prop_queued_upstr_signal_flag
C#
public int Prop_queued_upstr_signal_flag {get;}
Managed Extensions for C++
public: __property int get_Prop_queued_upstr_signal_flag();
C++/CLI
public:
property int Prop_queued_upstr_signal_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_cycav_mean
C#
public float Queue_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_mean();
C++/CLI
public:
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_cycav_percentile
C#
public float Queue_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_percentile();
C++/CLI
public:
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
public float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_mean();
C++/CLI
public:
property float Queue_dist_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
public float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_percentile();
C++/CLI
public:
property float Queue_dist_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
public float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_mean();
C++/CLI
public:
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
public float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_percentile();
C++/CLI
public:
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_greenstart_mean
C#
public float Queue_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_mean();
C++/CLI
public:
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
public float Queue_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_percentile();
C++/CLI
public:
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
public float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_avg();
C++/CLI
public:
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
public float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_percentile();
C++/CLI
public:
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_lane_changes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Total_lane_changes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_lane_changes As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Total_lane_changes
C#
public float Total_lane_changes {get;}
Managed Extensions for C++
public: __property float get_Total_lane_changes();
C++/CLI
public:
property float Total_lane_changes {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Travel_time_average Property

Glossary Item Box

Average travel time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : Travel_time_total Property

Glossary Item Box

Total travel time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLeg Class : X1_flag Property

Glossary Item Box

Degree of saturation = 1 flag.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLeg
Dim value As Integer

value = instance.X1_flag
C#
public int X1_flag {get;}
Managed Extensions for C++
public: __property int get_X1_flag();
C++/CLI
public:
property int X1_flag {
   int get();
}

Property Value

Type: System.Int32

0 = x != 1
1 = x = 1 due to short lane
2 = x = 1 due to minimum capacity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLeg Class
SIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMC Class

Glossary Item Box

Object Model

SIAPIOutputLegMC ClassISIAPIOutputLeg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLegMC
   Implements ISIAPIOutputLegMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
C#
public sealed class SIAPIOutputLegMC : ISIAPIOutputLegMC
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLegMC : public ISIAPIOutputLegMC
C++/CLI
public ref class SIAPIOutputLegMC sealed : public ISIAPIOutputLegMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLegMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMC Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLegMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLegMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Circulating_flow |
Public Property | Circulating_flow_pcu |
Public Property | Exist_in_nw_upstream_only |
Public Property | Exiting_flow |
Public Property | Exiting_flow_capconstr |
Public Property | Flow | Demand Flow Rate.
Public Property | Flow_capconstr | Arrival Flow Rate.
Public Property | MC_class |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | OutputLeg |
Public Property | Total_lane_changes |
Top

See Also

Reference

SIAPIOutputLegMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : SIAPIOutputLegMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLegMC()
C#
public SIAPIOutputLegMC()
Managed Extensions for C++
public: SIAPIOutputLegMC();
C++/CLI
public:
SIAPIOutputLegMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMC Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegMC members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_flag |
Public Property | Circulating_flow |
Public Property | Circulating_flow_pcu |
Public Property | Exist_in_nw_upstream_only |
Public Property | Exiting_flow |
Public Property | Exiting_flow_capconstr |
Public Property | Flow | Demand Flow Rate.
Public Property | Flow_capconstr | Arrival Flow Rate.
Public Property | MC_class |
Public Property | Net_inflow |
Public Property | Net_inflow_capconstr |
Public Property | Net_outflow |
Public Property | Net_outflow_capconstr |
Public Property | OutputLeg |
Public Property | Total_lane_changes |
Top

See Also

Reference

SIAPIOutputLegMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Circulating_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Circulating_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Circulating_flow
C#
public float Circulating_flow {get;}
Managed Extensions for C++
public: __property float get_Circulating_flow();
C++/CLI
public:
property float Circulating_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Circulating_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Circulating_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Circulating_flow_pcu
C#
public float Circulating_flow_pcu {get;}
Managed Extensions for C++
public: __property float get_Circulating_flow_pcu();
C++/CLI
public:
property float Circulating_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exist_in_nw_upstream_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Exist_in_nw_upstream_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exist_in_nw_upstream_only As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Boolean

value = instance.Exist_in_nw_upstream_only
C#
public bool Exist_in_nw_upstream_only {get;}
Managed Extensions for C++
public: __property bool get_Exist_in_nw_upstream_only();
C++/CLI
public:
property bool Exist_in_nw_upstream_only {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Exiting_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exiting_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Exiting_flow
C#
public float Exiting_flow {get;}
Managed Extensions for C++
public: __property float get_Exiting_flow();
C++/CLI
public:
property float Exiting_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Exiting_flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exiting_flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Exiting_flow_capconstr
C#
public float Exiting_flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Exiting_flow_capconstr();
C++/CLI
public:
property float Exiting_flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Flow Property

Glossary Item Box

Demand Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Flow
C#
public float Flow {get;}
Managed Extensions for C++
public: __property float get_Flow();
C++/CLI
public:
property float Flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Flow_capconstr Property

Glossary Item Box

Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Flow_capconstr
C#
public float Flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_capconstr();
C++/CLI
public:
property float Flow_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Net_inflow
C#
public float Net_inflow {get;}
Managed Extensions for C++
public: __property float get_Net_inflow();
C++/CLI
public:
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Net_inflow_capconstr
C#
public float Net_inflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_inflow_capconstr();
C++/CLI
public:
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Net_outflow
C#
public float Net_outflow {get;}
Managed Extensions for C++
public: __property float get_Net_outflow();
C++/CLI
public:
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Net_outflow_capconstr
C#
public float Net_outflow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Net_outflow_capconstr();
C++/CLI
public:
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
public ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
public:
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_lane_changes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMC Class : Total_lane_changes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_lane_changes As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMC
Dim value As Single

value = instance.Total_lane_changes
C#
public float Total_lane_changes {get;}
Managed Extensions for C++
public: __property float get_Total_lane_changes();
C++/CLI
public:
property float Total_lane_changes {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMC Class
SIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMCs Class

Glossary Item Box

Object Model

SIAPIOutputLegMCs ClassISIAPIOutputLegMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLegMCs
   Implements ISIAPIOutputLegMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMCs
C#
public sealed class SIAPIOutputLegMCs : ISIAPIOutputLegMCs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLegMCs : public ISIAPIOutputLegMCs
C++/CLI
public ref class SIAPIOutputLegMCs sealed : public ISIAPIOutputLegMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLegMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLegMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLegMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLegMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMCs Class : SIAPIOutputLegMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLegMCs()
C#
public SIAPIOutputLegMCs()
Managed Extensions for C++
public: SIAPIOutputLegMCs();
C++/CLI
public:
SIAPIOutputLegMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Class
SIAPIOutputLegMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputLegMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Class
SIAPIOutputLegMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMCs Class : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Class
SIAPIOutputLegMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLegMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Class
SIAPIOutputLegMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegMCs Class : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLegMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLegMC

value = instance.Item(mcClass)
C#
public ISIAPIOutputLegMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLegMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIOutputLegMC^ default [int] {
   ISIAPIOutputLegMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegMCs Class
SIAPIOutputLegMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPerson Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPerson Class

Glossary Item Box

Object Model

SIAPIOutputLegPerson Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLegPerson
   Implements ISIAPIOutputLegPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
C#
public sealed class SIAPIOutputLegPerson : ISIAPIOutputLegPerson
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLegPerson : public ISIAPIOutputLegPerson
C++/CLI
public ref class SIAPIOutputLegPerson sealed : public ISIAPIOutputLegPerson

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLegPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPerson Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPerson Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLegPerson.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLegPerson Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total |
Public Property | Demand_flow_total |
Public Property | Operating_cost_total |
Public Property | Orientation |
Public Property | Performance_index |
Public Property | Proportion_queued |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_total |
Top

See Also

Reference

SIAPIOutputLegPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPerson Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : SIAPIOutputLegPerson Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLegPerson()
C#
public SIAPIOutputLegPerson()
Managed Extensions for C++
public: SIAPIOutputLegPerson();
C++/CLI
public:
SIAPIOutputLegPerson();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPerson Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPerson Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegPerson members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total |
Public Property | Demand_flow_total |
Public Property | Operating_cost_total |
Public Property | Orientation |
Public Property | Performance_index |
Public Property | Proportion_queued |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_total |
Top

See Also

Reference

SIAPIOutputLegPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Arrival_flow_total
C#
public float Arrival_flow_total {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total();
C++/CLI
public:
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Delay_control_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Integer

value = instance.Orientation
C#
public int Orientation {get;}
Managed Extensions for C++
public: __property int get_Orientation();
C++/CLI
public:
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPerson Class : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPerson Class
SIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPersons Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPersons Class

Glossary Item Box

Object Model

SIAPIOutputLegPersons ClassISIAPIOutputLegPerson Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLegPersons
   Implements ISIAPIOutputLegPersons
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPersons
C#
public sealed class SIAPIOutputLegPersons : ISIAPIOutputLegPersons
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLegPersons : public ISIAPIOutputLegPersons
C++/CLI
public ref class SIAPIOutputLegPersons sealed : public ISIAPIOutputLegPersons

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLegPersons

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPersons Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPersons Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLegPersons.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLegPersons Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegPersonExists |
Top

See Also

Reference

SIAPIOutputLegPersons Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPersons Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPersons Class : SIAPIOutputLegPersons Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLegPersons()
C#
public SIAPIOutputLegPersons()
Managed Extensions for C++
public: SIAPIOutputLegPersons();
C++/CLI
public:
SIAPIOutputLegPersons();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Class
SIAPIOutputLegPersons Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPersons Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPersons Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegPersons members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegPersonExists |
Top

See Also

Reference

SIAPIOutputLegPersons Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPersons Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPersons
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Class
SIAPIOutputLegPersons Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegPersonExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPersons Class : LegPersonExists Method

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LegPersonExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPersons
Dim orientation As Integer
Dim value As Boolean

value = instance.LegPersonExists(orientation)
C#
public bool LegPersonExists(
   int orientation
)
Managed Extensions for C++
public: bool LegPersonExists(
   int orientation
)
C++/CLI
public:
bool LegPersonExists(
   int orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Class
SIAPIOutputLegPersons Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegPersons Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegPersons Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegPersons members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLegPersons Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPersons Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPersons
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Class
SIAPIOutputLegPersons Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegPersons Class : Item Property

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPIOutputLegPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegPersons
Dim orientation As Integer
Dim value As ISIAPIOutputLegPerson

value = instance.Item(orientation)
C#
public ISIAPIOutputLegPerson this[
   int orientation
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLegPerson* get_Item   int orientation
;
C++/CLI
public:
property ISIAPIOutputLegPerson^ default [int] {
   ISIAPIOutputLegPerson^ get(int orientation);
}

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegPersons Class
SIAPIOutputLegPersons Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegs Class

Glossary Item Box

Object Model

SIAPIOutputLegs ClassISIAPIOutputLeg Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputLegs
   Implements ISIAPIOutputLegs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegs
C#
public sealed class SIAPIOutputLegs : ISIAPIOutputLegs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputLegs : public ISIAPIOutputLegs
C++/CLI
public ref class SIAPIOutputLegs sealed : public ISIAPIOutputLegs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputLegs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputLegs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputLegs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegExists |
Top

See Also

Reference

SIAPIOutputLegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegs Class : SIAPIOutputLegs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputLegs()
C#
public SIAPIOutputLegs()
Managed Extensions for C++
public: SIAPIOutputLegs();
C++/CLI
public:
SIAPIOutputLegs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Class
SIAPIOutputLegs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | LegExists |
Top

See Also

Reference

SIAPIOutputLegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Class
SIAPIOutputLegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegs Class : LegExists Method

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function LegExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegs
Dim orientation As Integer
Dim value As Boolean

value = instance.LegExists(orientation)
C#
public bool LegExists(
   int orientation
)
Managed Extensions for C++
public: bool LegExists(
   int orientation
)
C++/CLI
public:
bool LegExists(
   int orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Class
SIAPIOutputLegs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputLegs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputLegs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputLegs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputLegs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Class
SIAPIOutputLegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputLegs Class : Item Property

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputLegs
Dim orientation As Integer
Dim value As ISIAPIOutputLeg

value = instance.Item(orientation)
C#
public ISIAPIOutputLeg this[
   int orientation
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLeg* get_Item   int orientation
;
C++/CLI
public:
property ISIAPIOutputLeg^ default [int] {
   ISIAPIOutputLeg^ get(int orientation);
}

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputLegs Class
SIAPIOutputLegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMeteredRoundabout Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMeteredRoundabout Class

Glossary Item Box

Object Model

SIAPIOutputMeteredRoundabout Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMeteredRoundabout
   Implements ISIAPIOutputMeteredRoundabout
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
C#
public sealed class SIAPIOutputMeteredRoundabout : ISIAPIOutputMeteredRoundabout
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMeteredRoundabout : public ISIAPIOutputMeteredRoundabout
C++/CLI
public ref class SIAPIOutputMeteredRoundabout sealed : public ISIAPIOutputMeteredRoundabout

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMeteredRoundabout

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMeteredRoundabout Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMeteredRoundabout Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMeteredRoundabout.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMeteredRoundabout Constructor |
Top

Public Properties

 | Name | Description
Public Property | Blank_time_ratio |
Public Property | Controlling_queue_detection_probability |
Public Property | Metered_displayed_blank |
Public Property | Metered_displayed_red |
Public Property | Metered_effective_blank |
Public Property | Metered_effective_red |
Top

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMeteredRoundabout Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : SIAPIOutputMeteredRoundabout Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMeteredRoundabout()
C#
public SIAPIOutputMeteredRoundabout()
Managed Extensions for C++
public: SIAPIOutputMeteredRoundabout();
C++/CLI
public:
SIAPIOutputMeteredRoundabout();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMeteredRoundabout Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMeteredRoundabout Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMeteredRoundabout members.

Public Properties

 | Name | Description
Public Property | Blank_time_ratio |
Public Property | Controlling_queue_detection_probability |
Public Property | Metered_displayed_blank |
Public Property | Metered_displayed_red |
Public Property | Metered_effective_blank |
Public Property | Metered_effective_red |
Top

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Blank_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Blank_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Blank_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Single

value = instance.Blank_time_ratio
C#
public float Blank_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Blank_time_ratio();
C++/CLI
public:
property float Blank_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Controlling_queue_detection_probability Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Controlling_queue_detection_probability Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Controlling_queue_detection_probability As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Single

value = instance.Controlling_queue_detection_probability
C#
public float Controlling_queue_detection_probability {get;}
Managed Extensions for C++
public: __property float get_Controlling_queue_detection_probability();
C++/CLI
public:
property float Controlling_queue_detection_probability {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_displayed_blank Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Metered_displayed_blank Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metered_displayed_blank As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_displayed_blank
C#
public int Metered_displayed_blank {get;}
Managed Extensions for C++
public: __property int get_Metered_displayed_blank();
C++/CLI
public:
property int Metered_displayed_blank {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_displayed_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Metered_displayed_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metered_displayed_red As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_displayed_red
C#
public int Metered_displayed_red {get;}
Managed Extensions for C++
public: __property int get_Metered_displayed_red();
C++/CLI
public:
property int Metered_displayed_red {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_effective_blank Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Metered_effective_blank Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metered_effective_blank As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_effective_blank
C#
public int Metered_effective_blank {get;}
Managed Extensions for C++
public: __property int get_Metered_effective_blank();
C++/CLI
public:
property int Metered_effective_blank {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_effective_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMeteredRoundabout Class : Metered_effective_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Metered_effective_red As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_effective_red
C#
public int Metered_effective_red {get;}
Managed Extensions for C++
public: __property int get_Metered_effective_red();
C++/CLI
public:
property int Metered_effective_red {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMeteredRoundabout Class
SIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed Class

Glossary Item Box

SIDRA INTERSECTION Pedestrian movement output wrapper class

Object Model

SIAPIOutputMovementPed ClassISIAPIOutputMovementPed_GreenPeriods InterfaceISIAPIOutputMovementPed_GreenPeriod Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPed
   Implements ISIAPIOutputMovementPed
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
C#
public sealed class SIAPIOutputMovementPed : ISIAPIOutputMovementPed
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPed : public ISIAPIOutputMovementPed
C++/CLI
public ref class SIAPIOutputMovementPed sealed : public ISIAPIOutputMovementPed

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPed

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPed.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPed Constructor |
Top

Public Properties

 | Name | Description
Public Property | Capacity_mov | Movement capacity (includes effect of lane underutilisation within movement).
Public Property | Deg_satn | Movement degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_total | Total control delay (veh-h/h).
Public Property | Demand_flow_total | Movement total demand flow.
Public Property | Green_periods | Number of green periods for movement.
Public Property | Level_of_service | Level of service.
Public Property | Operating_cost_total | Total operating cost (cost unit/h).
Public Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Public Property | OutputMovementPed_GreenPeriods |
Public Property | Performance_index | Performance index.
Public Property | Practical_degree_of_saturation |
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel time (secs).
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Public Property | Type | The type of a Pedestrian Movement Type: System.Int32; 1 = Full Crossing, 2 = Slip Lane, 3 = Staged, 4 = Diagonal.
Top

See Also

Reference

SIAPIOutputMovementPed Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : SIAPIOutputMovementPed Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPed()
C#
public SIAPIOutputMovementPed()
Managed Extensions for C++
public: SIAPIOutputMovementPed();
C++/CLI
public:
SIAPIOutputMovementPed();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPed members.

Public Properties

 | Name | Description
Public Property | Capacity_mov | Movement capacity (includes effect of lane underutilisation within movement).
Public Property | Deg_satn | Movement degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_total | Total control delay (veh-h/h).
Public Property | Demand_flow_total | Movement total demand flow.
Public Property | Green_periods | Number of green periods for movement.
Public Property | Level_of_service | Level of service.
Public Property | Operating_cost_total | Total operating cost (cost unit/h).
Public Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Public Property | OutputMovementPed_GreenPeriods |
Public Property | Performance_index | Performance index.
Public Property | Practical_degree_of_saturation |
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel time (secs).
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Public Property | Type | The type of a Pedestrian Movement Type: System.Int32; 1 = Full Crossing, 2 = Slip Lane, 3 = Staged, 4 = Diagonal.
Top

See Also

Reference

SIAPIOutputMovementPed Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Capacity_mov Property

Glossary Item Box

Movement capacity (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Capacity_mov
C#
public float Capacity_mov {get;}
Managed Extensions for C++
public: __property float get_Capacity_mov();
C++/CLI
public:
property float Capacity_mov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Deg_satn Property

Glossary Item Box

Movement degree of saturation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Delay_control_total Property

Glossary Item Box

Total control delay (veh-h/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Demand_flow_total Property

Glossary Item Box

Movement total demand flow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Green_periods Property

Glossary Item Box

Number of green periods for movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Integer

value = instance.Green_periods
C#
public int Green_periods {get;}
Managed Extensions for C++
public: __property int get_Green_periods();
C++/CLI
public:
property int Green_periods {
   int get();
}

Property Value

Type: System.Int32

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Level_of_service Property

Glossary Item Box

Level of service.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Origin Property

Glossary Item Box

Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPed_GreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : OutputMovementPed_GreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementPed_GreenPeriods As ISIAPIOutputMovementPed_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As ISIAPIOutputMovementPed_GreenPeriods

value = instance.OutputMovementPed_GreenPeriods
C#
public ISIAPIOutputMovementPed_GreenPeriods OutputMovementPed_GreenPeriods {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPed_GreenPeriods* get_OutputMovementPed_GreenPeriods();
C++/CLI
public:
property ISIAPIOutputMovementPed_GreenPeriods^ OutputMovementPed_GreenPeriods {
   ISIAPIOutputMovementPed_GreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Practical_degree_of_saturation
C#
public float Practical_degree_of_saturation {get;}
Managed Extensions for C++
public: __property float get_Practical_degree_of_saturation();
C++/CLI
public:
property float Practical_degree_of_saturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Stage Property

Glossary Item Box

Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Integer

value = instance.Stage
C#
public int Stage {get;}
Managed Extensions for C++
public: __property int get_Stage();
C++/CLI
public:
property int Stage {
   int get();
}

Property Value

Type: System.Int32;

1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Travel_speed Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed Class : Type Property

Glossary Item Box

The type of a Pedestrian Movement

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed
Dim value As Integer

value = instance.Type
C#
public int Type {get;}
Managed Extensions for C++
public: __property int get_Type();
C++/CLI
public:
property int Type {
   int get();
}

Property Value

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed Class
SIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriod Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriod Class

Glossary Item Box

Object Model

SIAPIOutputMovementPed_GreenPeriod Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPed_GreenPeriod
   Implements ISIAPIOutputMovementPed_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
C#
public sealed class SIAPIOutputMovementPed_GreenPeriod : ISIAPIOutputMovementPed_GreenPeriod
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPed_GreenPeriod : public ISIAPIOutputMovementPed_GreenPeriod
C++/CLI
public ref class SIAPIOutputMovementPed_GreenPeriod sealed : public ISIAPIOutputMovementPed_GreenPeriod

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPed_GreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriod Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriod Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPed_GreenPeriod.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPed_GreenPeriod Constructor |
Top

Public Properties

 | Name | Description
Public Property | Actual_walk_time |
Public Property | Adjusted_flow_ratio |
Public Property | Adjusted_lost_time |
Public Property | Critical_mov |
Public Property | Displayed_end_time |
Public Property | Displayed_start_time |
Public Property | Eff_end_gain |
Public Property | Eff_end_time |
Public Property | Eff_green |
Public Property | Eff_start_loss |
Public Property | Eff_start_time |
Public Property | End_phase |
Public Property | Flow_ratio |
Public Property | Greenperiod | Green Period value is a one-based integer.
Public Property | Lost_time |
Public Property | Min_max_flag |
Public Property | Min_walk_time |
Public Property | No_arrival |
Public Property | Priority |
Public Property | Reqd_green_time_ratio |
Public Property | Reqd_time |
Public Property | Satn_flow |
Public Property | Start_phase |
Public Property | Tmax |
Public Property | Tmin |
Top

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriod Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : SIAPIOutputMovementPed_GreenPeriod Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPed_GreenPeriod()
C#
public SIAPIOutputMovementPed_GreenPeriod()
Managed Extensions for C++
public: SIAPIOutputMovementPed_GreenPeriod();
C++/CLI
public:
SIAPIOutputMovementPed_GreenPeriod();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriod Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriod Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPed_GreenPeriod members.

Public Properties

 | Name | Description
Public Property | Actual_walk_time |
Public Property | Adjusted_flow_ratio |
Public Property | Adjusted_lost_time |
Public Property | Critical_mov |
Public Property | Displayed_end_time |
Public Property | Displayed_start_time |
Public Property | Eff_end_gain |
Public Property | Eff_end_time |
Public Property | Eff_green |
Public Property | Eff_start_loss |
Public Property | Eff_start_time |
Public Property | End_phase |
Public Property | Flow_ratio |
Public Property | Greenperiod | Green Period value is a one-based integer.
Public Property | Lost_time |
Public Property | Min_max_flag |
Public Property | Min_walk_time |
Public Property | No_arrival |
Public Property | Priority |
Public Property | Reqd_green_time_ratio |
Public Property | Reqd_time |
Public Property | Satn_flow |
Public Property | Start_phase |
Public Property | Tmax |
Public Property | Tmin |
Top

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actual_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Actual_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Actual_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Actual_walk_time
C#
public int Actual_walk_time {get;}
Managed Extensions for C++
public: __property int get_Actual_walk_time();
C++/CLI
public:
property int Actual_walk_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Adjusted_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Adjusted_flow_ratio
C#
public float Adjusted_flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Adjusted_flow_ratio();
C++/CLI
public:
property float Adjusted_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Adjusted_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Adjusted_lost_time
C#
public int Adjusted_lost_time {get;}
Managed Extensions for C++
public: __property int get_Adjusted_lost_time();
C++/CLI
public:
property int Adjusted_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Critical_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.Critical_mov
C#
public bool Critical_mov {get;}
Managed Extensions for C++
public: __property bool get_Critical_mov();
C++/CLI
public:
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Displayed_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Displayed_end_time
C#
public int Displayed_end_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_end_time();
C++/CLI
public:
property int Displayed_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Displayed_start_time
C#
public int Displayed_start_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_start_time();
C++/CLI
public:
property int Displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Eff_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_end_gain
C#
public int Eff_end_gain {get;}
Managed Extensions for C++
public: __property int get_Eff_end_gain();
C++/CLI
public:
property int Eff_end_gain {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Eff_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_end_time
C#
public int Eff_end_time {get;}
Managed Extensions for C++
public: __property int get_Eff_end_time();
C++/CLI
public:
property int Eff_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_green
C#
public int Eff_green {get;}
Managed Extensions for C++
public: __property int get_Eff_green();
C++/CLI
public:
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Eff_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_start_loss
C#
public int Eff_start_loss {get;}
Managed Extensions for C++
public: __property int get_Eff_start_loss();
C++/CLI
public:
property int Eff_start_loss {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_start_time
C#
public int Eff_start_time {get;}
Managed Extensions for C++
public: __property int get_Eff_start_time();
C++/CLI
public:
property int Eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : End_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.End_phase
C#
public int End_phase {get;}
Managed Extensions for C++
public: __property int get_End_phase();
C++/CLI
public:
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
public float Flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Flow_ratio();
C++/CLI
public:
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Greenperiod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Greenperiod
C#
public int Greenperiod {get;}
Managed Extensions for C++
public: __property int get_Greenperiod();
C++/CLI
public:
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Lost_time
C#
public int Lost_time {get;}
Managed Extensions for C++
public: __property int get_Lost_time();
C++/CLI
public:
property int Lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Min_max_flag
C#
public int Min_max_flag {get;}
Managed Extensions for C++
public: __property int get_Min_max_flag();
C++/CLI
public:
property int Min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Min_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Min_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Min_walk_time
C#
public int Min_walk_time {get;}
Managed Extensions for C++
public: __property int get_Min_walk_time();
C++/CLI
public:
property int Min_walk_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
No_arrival Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : No_arrival Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property No_arrival As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.No_arrival
C#
public bool No_arrival {get;}
Managed Extensions for C++
public: __property bool get_No_arrival();
C++/CLI
public:
property bool No_arrival {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Priority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.Priority
C#
public bool Priority {get;}
Managed Extensions for C++
public: __property bool get_Priority();
C++/CLI
public:
property bool Priority {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Reqd_green_time_ratio
C#
public float Reqd_green_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Reqd_green_time_ratio();
C++/CLI
public:
property float Reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Reqd_time
C#
public float Reqd_time {get;}
Managed Extensions for C++
public: __property float get_Reqd_time();
C++/CLI
public:
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Satn_flow
C#
public float Satn_flow {get;}
Managed Extensions for C++
public: __property float get_Satn_flow();
C++/CLI
public:
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Start_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Start_phase
C#
public int Start_phase {get;}
Managed Extensions for C++
public: __property int get_Start_phase();
C++/CLI
public:
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Tmax
C#
public float Tmax {get;}
Managed Extensions for C++
public: __property float get_Tmax();
C++/CLI
public:
property float Tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriod Class : Tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Tmin
C#
public float Tmin {get;}
Managed Extensions for C++
public: __property float get_Tmin();
C++/CLI
public:
property float Tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriod Class
SIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriods Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriods Class

Glossary Item Box

Object Model

SIAPIOutputMovementPed_GreenPeriods ClassISIAPIOutputMovementPed_GreenPeriod Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPed_GreenPeriods
   Implements ISIAPIOutputMovementPed_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriods
C#
public sealed class SIAPIOutputMovementPed_GreenPeriods : ISIAPIOutputMovementPed_GreenPeriods
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPed_GreenPeriods : public ISIAPIOutputMovementPed_GreenPeriods
C++/CLI
public ref class SIAPIOutputMovementPed_GreenPeriods sealed : public ISIAPIOutputMovementPed_GreenPeriods

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPed_GreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriods Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriods Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPed_GreenPeriods.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPed_GreenPeriods Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement Output Green Period Data. Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriods Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriods Class : SIAPIOutputMovementPed_GreenPeriods Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPed_GreenPeriods()
C#
public SIAPIOutputMovementPed_GreenPeriods()
Managed Extensions for C++
public: SIAPIOutputMovementPed_GreenPeriods();
C++/CLI
public:
SIAPIOutputMovementPed_GreenPeriods();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriods Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPed_GreenPeriods members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriods Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriods
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriods Class : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
public bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
public: bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
public:
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPed_GreenPeriods Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPed_GreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPed_GreenPeriods members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement Output Green Period Data. Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriods Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriods
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPed_GreenPeriods Class : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a Pedestrian Movement Output Green Period Data.
Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputMovementPed_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPed_GreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputMovementPed_GreenPeriod

value = instance.Item(greenperiod)
C#
public ISIAPIOutputMovementPed_GreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPed_GreenPeriod* get_Item   int greenperiod
;
C++/CLI
public:
property ISIAPIOutputMovementPed_GreenPeriod^ default [int] {
   ISIAPIOutputMovementPed_GreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPed_GreenPeriods Class
SIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPeds Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPeds Class

Glossary Item Box

SIAPIOutputMovementPed collection

Object Model

SIAPIOutputMovementPeds ClassISIAPIOutputMovementPed Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPeds
   Implements ISIAPIOutputMovementPeds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPeds
C#
public sealed class SIAPIOutputMovementPeds : ISIAPIOutputMovementPeds
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPeds : public ISIAPIOutputMovementPeds
C++/CLI
public ref class SIAPIOutputMovementPeds sealed : public ISIAPIOutputMovementPeds

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPeds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPeds Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPeds Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPeds.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPeds Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement Output Data Object. Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPeds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPeds Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPeds Class : SIAPIOutputMovementPeds Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPeds()
C#
public SIAPIOutputMovementPeds()
Managed Extensions for C++
public: SIAPIOutputMovementPeds();
C++/CLI
public:
SIAPIOutputMovementPeds();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Class
SIAPIOutputMovementPeds Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPeds Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPeds Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPeds members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPeds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPeds Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPeds
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Class
SIAPIOutputMovementPeds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPeds Class : MovementExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPeds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.MovementExists(type, origin, stage)
C#
public bool MovementExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
public: bool MovementExists(
   int type,
   int origin,
   int stage
)
C++/CLI
public:
bool MovementExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Class
SIAPIOutputMovementPeds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPeds Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPeds Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPeds members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Pedestrian Movement Output Data Object. Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputMovementPeds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPeds Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPeds
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Class
SIAPIOutputMovementPeds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPeds Class : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Pedestrian Movement Output Data Object.
Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIOutputMovementPed
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPeds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIOutputMovementPed

value = instance.Item(type, origin, stage)
C#
public ISIAPIOutputMovementPed this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPed* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
public:
property ISIAPIOutputMovementPed^ default [int,int,int] {
   ISIAPIOutputMovementPed^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPeds Class
SIAPIOutputMovementPeds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonOD Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonOD Class

Glossary Item Box

Object Model

SIAPIOutputMovementPersonOD Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPersonOD
   Implements ISIAPIOutputMovementPersonOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
C#
public sealed class SIAPIOutputMovementPersonOD : ISIAPIOutputMovementPersonOD
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPersonOD : public ISIAPIOutputMovementPersonOD
C++/CLI
public ref class SIAPIOutputMovementPersonOD sealed : public ISIAPIOutputMovementPersonOD

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPersonOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonOD Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonOD Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPersonOD.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPersonOD Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total |
Public Property | Demand_flow_total |
Public Property | Destination | Movement Destination Leg
Public Property | Operating_cost_total |
Public Property | Origin | Movement Origin Leg
Public Property | Performance_index |
Public Property | Proportion_queued |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_total |
Top

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonOD Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : SIAPIOutputMovementPersonOD Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPersonOD()
C#
public SIAPIOutputMovementPersonOD()
Managed Extensions for C++
public: SIAPIOutputMovementPersonOD();
C++/CLI
public:
SIAPIOutputMovementPersonOD();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonOD Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonOD Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPersonOD members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total |
Public Property | Demand_flow_total |
Public Property | Destination | Movement Destination Leg
Public Property | Operating_cost_total |
Public Property | Origin | Movement Origin Leg
Public Property | Performance_index |
Public Property | Proportion_queued |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_total |
Top

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Arrival_flow_total
C#
public float Arrival_flow_total {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total();
C++/CLI
public:
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Delay_control_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonOD Class : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonOD Class
SIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonODs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonODs Class

Glossary Item Box

Object Model

SIAPIOutputMovementPersonODs ClassISIAPIOutputMovementPersonOD Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementPersonODs
   Implements ISIAPIOutputMovementPersonODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonODs
C#
public sealed class SIAPIOutputMovementPersonODs : ISIAPIOutputMovementPersonODs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementPersonODs : public ISIAPIOutputMovementPersonODs
C++/CLI
public ref class SIAPIOutputMovementPersonODs sealed : public ISIAPIOutputMovementPersonODs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementPersonODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonODs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonODs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementPersonODs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementPersonODs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Output Person Data Object. Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Movement Output Person Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonODs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonODs Class : SIAPIOutputMovementPersonODs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementPersonODs()
C#
public SIAPIOutputMovementPersonODs()
Managed Extensions for C++
public: SIAPIOutputMovementPersonODs();
C++/CLI
public:
SIAPIOutputMovementPersonODs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIAPIOutputMovementPersonODs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonODs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPersonODs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Movement Output Person Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonODs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonODs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIAPIOutputMovementPersonODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonODs Class : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Movement Output Person Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonODs
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
public bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
public: bool MovementExists(
   int origin,
   int destination
)
C++/CLI
public:
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIAPIOutputMovementPersonODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementPersonODs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementPersonODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementPersonODs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Movement Output Person Data Object. Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonODs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonODs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIAPIOutputMovementPersonODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementPersonODs Class : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Movement Output Person Data Object.
Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIOutputMovementPersonOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementPersonODs
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIOutputMovementPersonOD

value = instance.Item(origin, destination)
C#
public ISIAPIOutputMovementPersonOD this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPersonOD* get_Item   int origin,
   int destination
;
C++/CLI
public:
property ISIAPIOutputMovementPersonOD^ default [int,int] {
   ISIAPIOutputMovementPersonOD^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementPersonODs Class
SIAPIOutputMovementPersonODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleOD Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleOD Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleOD ClassISIAPIOutputMovementVehicleODMCs InterfaceISIAPIOutputMovementVehicleODMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleOD
   Implements ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
C#
public sealed class SIAPIOutputMovementVehicleOD : ISIAPIOutputMovementVehicleOD
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleOD : public ISIAPIOutputMovementVehicleOD
C++/CLI
public ref class SIAPIOutputMovementVehicleOD sealed : public ISIAPIOutputMovementVehicleOD

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleOD Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleOD Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleOD.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleOD Constructor |
Top

Public Properties

 | Name | Description
Public Property | Approach_negotiation_speed |
Public Property | Arrival_flow_flag |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_data_type |
Public Property | Capacity_mov |
Public Property | Carbon_dioxide_rate |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_rate |
Public Property | Carbon_monoxide_total |
Public Property | Cruise_speed |
Public Property | Deg_satn |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total_persons |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Destination | Movement Destination Leg
Public Property | Effective_control |
Public Property | Equivalent_AT |
Public Property | Exit_cruise_speed |
Public Property | Exit_negotiation_speed |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate |
Public Property | Fuel_consumption_total |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Has_continuous_control |
Public Property | Has_giveway_control |
Public Property | Has_highangle_slip |
Public Property | Has_lowangle_slip |
Public Property | Has_signals_control |
Public Property | Has_stop_control |
Public Property | Hydrocarbons_rate |
Public Property | Hydrocarbons_total |
Public Property | Idling_time_average |
Public Property | Level_of_service |
Public Property | Minimum_delay |
Public Property | Nox_rate |
Public Property | Nox_total |
Public Property | Operating_cost_rate |
Public Property | Operating_cost_total |
Public Property | Origin | Movement Origin Leg
Public Property | OutputMovementVehicleODMCs |
Public Property | Perc_arriving_during_green |
Public Property | Performance_index |
Public Property | Platoon_ratio |
Public Property | Practical_spare_capacity |
Public Property | Proportion_queued |
Public Property | Queue_cycav_mean |
Public Property | Queue_cycav_percentile |
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean |
Public Property | Queue_maxback_percentile |
Public Property | Queue_storage_ratio_avg |
Public Property | Queue_storage_ratio_percentile |
Public Property | Running_speed |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_stopline_average |
Public Property | Travel_distance_stopline_total |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_stopline_average |
Public Property | Travel_time_stopline_total |
Public Property | Travel_time_total |
Public Property | Unblocked_time_ratio |
Public Property | X1_flag |
Top

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleOD Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : SIAPIOutputMovementVehicleOD Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleOD()
C#
public SIAPIOutputMovementVehicleOD()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleOD();
C++/CLI
public:
SIAPIOutputMovementVehicleOD();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleOD Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleOD Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleOD members.

Public Properties

 | Name | Description
Public Property | Approach_negotiation_speed |
Public Property | Arrival_flow_flag |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_data_type |
Public Property | Capacity_mov |
Public Property | Carbon_dioxide_rate |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_rate |
Public Property | Carbon_monoxide_total |
Public Property | Cruise_speed |
Public Property | Deg_satn |
Public Property | Delay_control_average |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_total_persons |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Destination | Movement Destination Leg
Public Property | Effective_control |
Public Property | Equivalent_AT |
Public Property | Exit_cruise_speed |
Public Property | Exit_negotiation_speed |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate |
Public Property | Fuel_consumption_total |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Has_continuous_control |
Public Property | Has_giveway_control |
Public Property | Has_highangle_slip |
Public Property | Has_lowangle_slip |
Public Property | Has_signals_control |
Public Property | Has_stop_control |
Public Property | Hydrocarbons_rate |
Public Property | Hydrocarbons_total |
Public Property | Idling_time_average |
Public Property | Level_of_service |
Public Property | Minimum_delay |
Public Property | Nox_rate |
Public Property | Nox_total |
Public Property | Operating_cost_rate |
Public Property | Operating_cost_total |
Public Property | Origin | Movement Origin Leg
Public Property | OutputMovementVehicleODMCs |
Public Property | Perc_arriving_during_green |
Public Property | Performance_index |
Public Property | Platoon_ratio |
Public Property | Practical_spare_capacity |
Public Property | Proportion_queued |
Public Property | Queue_cycav_mean |
Public Property | Queue_cycav_percentile |
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean |
Public Property | Queue_maxback_percentile |
Public Property | Queue_storage_ratio_avg |
Public Property | Queue_storage_ratio_percentile |
Public Property | Running_speed |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_stopline_average |
Public Property | Travel_distance_stopline_total |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_stopline_average |
Public Property | Travel_time_stopline_total |
Public Property | Travel_time_total |
Public Property | Unblocked_time_ratio |
Public Property | X1_flag |
Top

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Approach_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Approach_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Approach_negotiation_speed
C#
public float Approach_negotiation_speed {get;}
Managed Extensions for C++
public: __property float get_Approach_negotiation_speed();
C++/CLI
public:
property float Approach_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
public float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
public: __property float get_Avg_num_of_cycles_to_depart();
C++/CLI
public:
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
public int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
public: __property int get_Capacity_adj_flag_worstlane();
C++/CLI
public:
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
public float Capacity_adj_worstlane {get;}
Managed Extensions for C++
public: __property float get_Capacity_adj_worstlane();
C++/CLI
public:
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_data_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Capacity_data_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_data_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Capacity_data_type
C#
public int Capacity_data_type {get;}
Managed Extensions for C++
public: __property int get_Capacity_data_type();
C++/CLI
public:
property int Capacity_data_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Capacity_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Capacity_mov
C#
public float Capacity_mov {get;}
Managed Extensions for C++
public: __property float get_Capacity_mov();
C++/CLI
public:
property float Capacity_mov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Carbon_dioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
public float Carbon_dioxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_rate();
C++/CLI
public:
property float Carbon_dioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Carbon_monoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
public float Carbon_monoxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_rate();
C++/CLI
public:
property float Carbon_monoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Cruise_speed
C#
public float Cruise_speed {get;}
Managed Extensions for C++
public: __property float get_Cruise_speed();
C++/CLI
public:
property float Cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
public float Delay_control_average_worstlane {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstlane();
C++/CLI
public:
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_persons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_control_total_persons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_persons As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_total_persons
C#
public float Delay_control_total_persons {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_persons();
C++/CLI
public:
property float Delay_control_total_persons {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_total_veh
C#
public float Delay_control_total_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_veh();
C++/CLI
public:
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_geometric
C#
public float Delay_geometric {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric();
C++/CLI
public:
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Effective_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Effective_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Effective_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Effective_control
C#
public int Effective_control {get;}
Managed Extensions for C++
public: __property int get_Effective_control();
C++/CLI
public:
property int Effective_control {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Equivalent_AT
C#
public int Equivalent_AT {get;}
Managed Extensions for C++
public: __property int get_Equivalent_AT();
C++/CLI
public:
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Exit_cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exit_cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Exit_cruise_speed
C#
public float Exit_cruise_speed {get;}
Managed Extensions for C++
public: __property float get_Exit_cruise_speed();
C++/CLI
public:
property float Exit_cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Exit_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exit_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Exit_negotiation_speed
C#
public float Exit_negotiation_speed {get;}
Managed Extensions for C++
public: __property float get_Exit_negotiation_speed();
C++/CLI
public:
property float Exit_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV
C#
public float Flow_HV {get;}
Managed Extensions for C++
public: __property float get_Flow_HV();
C++/CLI
public:
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_capconstr
C#
public float Flow_HV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_capconstr();
C++/CLI
public:
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_HV_pct Property

Glossary Item Box

Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_pct
C#
public float Flow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct();
C++/CLI
public:
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
public float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct_capconstr();
C++/CLI
public:
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_LV
C#
public float Flow_LV {get;}
Managed Extensions for C++
public: __property float get_Flow_LV();
C++/CLI
public:
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_LV_capconstr
C#
public float Flow_LV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_LV_capconstr();
C++/CLI
public:
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_total
C#
public float Flow_total {get;}
Managed Extensions for C++
public: __property float get_Flow_total();
C++/CLI
public:
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_total_capconstr
C#
public float Flow_total_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_total_capconstr();
C++/CLI
public:
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Fuel_consumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Fuel_consumption_rate
C#
public float Fuel_consumption_rate {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_rate();
C++/CLI
public:
property float Fuel_consumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
public float Gap_accept_blocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_blocked_time();
C++/CLI
public:
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
public float Gap_accept_cycle_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_cycle_time();
C++/CLI
public:
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
public float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_unblocked_time();
C++/CLI
public:
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Green_periods
C#
public int Green_periods {get;}
Managed Extensions for C++
public: __property int get_Green_periods();
C++/CLI
public:
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_continuous_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_continuous_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_continuous_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_continuous_control
C#
public bool Has_continuous_control {get;}
Managed Extensions for C++
public: __property bool get_Has_continuous_control();
C++/CLI
public:
property bool Has_continuous_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_giveway_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_giveway_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_giveway_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_giveway_control
C#
public bool Has_giveway_control {get;}
Managed Extensions for C++
public: __property bool get_Has_giveway_control();
C++/CLI
public:
property bool Has_giveway_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_highangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_highangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_highangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_highangle_slip
C#
public bool Has_highangle_slip {get;}
Managed Extensions for C++
public: __property bool get_Has_highangle_slip();
C++/CLI
public:
property bool Has_highangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_lowangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_lowangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_lowangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_lowangle_slip
C#
public bool Has_lowangle_slip {get;}
Managed Extensions for C++
public: __property bool get_Has_lowangle_slip();
C++/CLI
public:
property bool Has_lowangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_signals_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_signals_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_signals_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_signals_control
C#
public bool Has_signals_control {get;}
Managed Extensions for C++
public: __property bool get_Has_signals_control();
C++/CLI
public:
property bool Has_signals_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_stop_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Has_stop_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_stop_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_stop_control
C#
public bool Has_stop_control {get;}
Managed Extensions for C++
public: __property bool get_Has_stop_control();
C++/CLI
public:
property bool Has_stop_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Hydrocarbons_rate
C#
public float Hydrocarbons_rate {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_rate();
C++/CLI
public:
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Idling_time_average
C#
public float Idling_time_average {get;}
Managed Extensions for C++
public: __property float get_Idling_time_average();
C++/CLI
public:
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Minimum_delay
C#
public float Minimum_delay {get;}
Managed Extensions for C++
public: __property float get_Minimum_delay();
C++/CLI
public:
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Nox_rate
C#
public float Nox_rate {get;}
Managed Extensions for C++
public: __property float get_Nox_rate();
C++/CLI
public:
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Operating_cost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Operating_cost_rate
C#
public float Operating_cost_rate {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_rate();
C++/CLI
public:
property float Operating_cost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : OutputMovementVehicleODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementVehicleODMCs As ISIAPIOutputMovementVehicleODMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As ISIAPIOutputMovementVehicleODMCs

value = instance.OutputMovementVehicleODMCs
C#
public ISIAPIOutputMovementVehicleODMCs OutputMovementVehicleODMCs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleODMCs* get_OutputMovementVehicleODMCs();
C++/CLI
public:
property ISIAPIOutputMovementVehicleODMCs^ OutputMovementVehicleODMCs {
   ISIAPIOutputMovementVehicleODMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Perc_arriving_during_green
C#
public float Perc_arriving_during_green {get;}
Managed Extensions for C++
public: __property float get_Perc_arriving_during_green();
C++/CLI
public:
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Platoon_ratio
C#
public float Platoon_ratio {get;}
Managed Extensions for C++
public: __property float get_Platoon_ratio();
C++/CLI
public:
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_cycav_mean
C#
public float Queue_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_mean();
C++/CLI
public:
property float Queue_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_cycav_percentile
C#
public float Queue_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_percentile();
C++/CLI
public:
property float Queue_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
public float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_mean();
C++/CLI
public:
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
public float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_percentile();
C++/CLI
public:
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
public float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_mean();
C++/CLI
public:
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
public float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_percentile();
C++/CLI
public:
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_greenstart_mean
C#
public float Queue_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_mean();
C++/CLI
public:
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
public float Queue_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_percentile();
C++/CLI
public:
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_storage_ratio_avg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
public float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_avg();
C++/CLI
public:
property float Queue_storage_ratio_avg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Queue_storage_ratio_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
public float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_percentile();
C++/CLI
public:
property float Queue_storage_ratio_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Running_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Running_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Running_speed
C#
public float Running_speed {get;}
Managed Extensions for C++
public: __property float get_Running_speed();
C++/CLI
public:
property float Running_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_distance_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_stopline_average
C#
public float Travel_distance_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_stopline_average();
C++/CLI
public:
property float Travel_distance_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_distance_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_stopline_total
C#
public float Travel_distance_stopline_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_stopline_total();
C++/CLI
public:
property float Travel_distance_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_time_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_stopline_average
C#
public float Travel_time_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_stopline_average();
C++/CLI
public:
property float Travel_time_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_time_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_stopline_total
C#
public float Travel_time_stopline_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_stopline_total();
C++/CLI
public:
property float Travel_time_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Unblocked_time_ratio
C#
public float Unblocked_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Unblocked_time_ratio();
C++/CLI
public:
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleOD Class : X1_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.X1_flag
C#
public int X1_flag {get;}
Managed Extensions for C++
public: __property int get_X1_flag();
C++/CLI
public:
property int X1_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleOD Class
SIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleODMC ClassISIAPIOutputMovementVehicleOD InterfaceISIAPIOutputMovementVehicleODMC_GreenPeriods InterfaceISIAPIOutputMovementVehicleODMC_GreenPeriod Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleODMC
   Implements ISIAPIOutputMovementVehicleODMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
C#
public sealed class SIAPIOutputMovementVehicleODMC : ISIAPIOutputMovementVehicleODMC
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleODMC : public ISIAPIOutputMovementVehicleODMC
C++/CLI
public ref class SIAPIOutputMovementVehicleODMC sealed : public ISIAPIOutputMovementVehicleODMC

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleODMC.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleODMC Constructor |
Top

Public Properties

 | Name | Description
Public Property | Approach_negotiation_speed |
Public Property | Arrival_flow_flag |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Calc_exists |
Public Property | Capacity_mov |
Public Property | Carbon_dioxide_rate |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_rate |
Public Property | Carbon_monoxide_total |
Public Property | Cruise_speed |
Public Property | Deg_satn |
Public Property | Delay_control_average |
Public Property | Delay_control_total_persons |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Destination |
Public Property | Effective_control |
Public Property | Equivalent_AT |
Public Property | Exit_cruise_speed |
Public Property | Exit_negotiation_speed |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Fuel_consumption_rate |
Public Property | Fuel_consumption_total |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Green_time_ratio |
Public Property | Has_continuous_control |
Public Property | Has_giveway_control |
Public Property | Has_highangle_slip |
Public Property | Has_lowangle_slip |
Public Property | Has_signals_control |
Public Property | Has_stop_control |
Public Property | Hydrocarbons_rate |
Public Property | Hydrocarbons_total |
Public Property | Initial_demand_vol |
Public Property | Level_of_service |
Public Property | MC_class |
Public Property | Minimum_delay |
Public Property | Negotiation_distance |
Public Property | Non_actuated |
Public Property | Nox_rate |
Public Property | Nox_total |
Public Property | Operating_cost_rate |
Public Property | Operating_cost_total |
Public Property | Origin |
Public Property | OutputMovementVehicleOD |
Public Property | OutputMovementVehicleODMC_GreenPeriods |
Public Property | Oversatn_duration |
Public Property | Perc_arriving_during_green |
Public Property | Performance_index |
Public Property | Platoon_ratio |
Public Property | Practical_degree_of_saturation |
Public Property | Practical_spare_capacity |
Public Property | Proportion_queued |
Public Property | Queue_cycav_mean |
Public Property | Queue_cycav_percentile |
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean |
Public Property | Queue_maxback_percentile |
Public Property | Queue_storage_ratio_avg |
Public Property | Queue_storage_ratio_percentile |
Public Property | Residual_demand_vol |
Public Property | Residual_demand_vol_clear_time |
Public Property | Running_speed |
Public Property | Signal_coordination |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_stopline_average |
Public Property | Travel_distance_stopline_total |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_stopline_average |
Public Property | Travel_time_stopline_total |
Public Property | Travel_time_total |
Public Property | Unblocked_time_ratio |
Public Property | X1_flag |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : SIAPIOutputMovementVehicleODMC Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleODMC()
C#
public SIAPIOutputMovementVehicleODMC()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleODMC();
C++/CLI
public:
SIAPIOutputMovementVehicleODMC();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMC members.

Public Properties

 | Name | Description
Public Property | Approach_negotiation_speed |
Public Property | Arrival_flow_flag |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Calc_exists |
Public Property | Capacity_mov |
Public Property | Carbon_dioxide_rate |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_rate |
Public Property | Carbon_monoxide_total |
Public Property | Cruise_speed |
Public Property | Deg_satn |
Public Property | Delay_control_average |
Public Property | Delay_control_total_persons |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric |
Public Property | Delay_stopline_average |
Public Property | Destination |
Public Property | Effective_control |
Public Property | Equivalent_AT |
Public Property | Exit_cruise_speed |
Public Property | Exit_negotiation_speed |
Public Property | Flow |
Public Property | Flow_capconstr |
Public Property | Fuel_consumption_rate |
Public Property | Fuel_consumption_total |
Public Property | Gap_accept_blocked_time |
Public Property | Gap_accept_cycle_time |
Public Property | Gap_accept_unblocked_time |
Public Property | Green_periods |
Public Property | Green_time_ratio |
Public Property | Has_continuous_control |
Public Property | Has_giveway_control |
Public Property | Has_highangle_slip |
Public Property | Has_lowangle_slip |
Public Property | Has_signals_control |
Public Property | Has_stop_control |
Public Property | Hydrocarbons_rate |
Public Property | Hydrocarbons_total |
Public Property | Initial_demand_vol |
Public Property | Level_of_service |
Public Property | MC_class |
Public Property | Minimum_delay |
Public Property | Negotiation_distance |
Public Property | Non_actuated |
Public Property | Nox_rate |
Public Property | Nox_total |
Public Property | Operating_cost_rate |
Public Property | Operating_cost_total |
Public Property | Origin |
Public Property | OutputMovementVehicleOD |
Public Property | OutputMovementVehicleODMC_GreenPeriods |
Public Property | Oversatn_duration |
Public Property | Perc_arriving_during_green |
Public Property | Performance_index |
Public Property | Platoon_ratio |
Public Property | Practical_degree_of_saturation |
Public Property | Practical_spare_capacity |
Public Property | Proportion_queued |
Public Property | Queue_cycav_mean |
Public Property | Queue_cycav_percentile |
Public Property | Queue_dist_cycav_mean |
Public Property | Queue_dist_cycav_percentile |
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean |
Public Property | Queue_maxback_percentile |
Public Property | Queue_storage_ratio_avg |
Public Property | Queue_storage_ratio_percentile |
Public Property | Residual_demand_vol |
Public Property | Residual_demand_vol_clear_time |
Public Property | Running_speed |
Public Property | Signal_coordination |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stops_total |
Public Property | Travel_distance_average |
Public Property | Travel_distance_stopline_average |
Public Property | Travel_distance_stopline_total |
Public Property | Travel_distance_total |
Public Property | Travel_speed |
Public Property | Travel_time_average |
Public Property | Travel_time_stopline_average |
Public Property | Travel_time_stopline_total |
Public Property | Travel_time_total |
Public Property | Unblocked_time_ratio |
Public Property | X1_flag |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Approach_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Approach_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Approach_negotiation_speed
C#
public float Approach_negotiation_speed {get;}
Managed Extensions for C++
public: __property float get_Approach_negotiation_speed();
C++/CLI
public:
property float Approach_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
public int Arrival_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Arrival_flow_flag();
C++/CLI
public:
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
public float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
public: __property float get_Avg_num_of_cycles_to_depart();
C++/CLI
public:
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Calc_exists
C#
public bool Calc_exists {get;}
Managed Extensions for C++
public: __property bool get_Calc_exists();
C++/CLI
public:
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Capacity_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Capacity_mov
C#
public float Capacity_mov {get;}
Managed Extensions for C++
public: __property float get_Capacity_mov();
C++/CLI
public:
property float Capacity_mov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Carbon_dioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
public float Carbon_dioxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_rate();
C++/CLI
public:
property float Carbon_dioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Carbon_monoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
public float Carbon_monoxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_rate();
C++/CLI
public:
property float Carbon_monoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Cruise_speed
C#
public float Cruise_speed {get;}
Managed Extensions for C++
public: __property float get_Cruise_speed();
C++/CLI
public:
property float Cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_persons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Delay_control_total_persons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_persons As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_total_persons
C#
public float Delay_control_total_persons {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_persons();
C++/CLI
public:
property float Delay_control_total_persons {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_total_veh
C#
public float Delay_control_total_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_veh();
C++/CLI
public:
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_geometric
C#
public float Delay_geometric {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric();
C++/CLI
public:
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Effective_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Effective_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Effective_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Effective_control
C#
public int Effective_control {get;}
Managed Extensions for C++
public: __property int get_Effective_control();
C++/CLI
public:
property int Effective_control {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Equivalent_AT
C#
public int Equivalent_AT {get;}
Managed Extensions for C++
public: __property int get_Equivalent_AT();
C++/CLI
public:
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Exit_cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exit_cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Exit_cruise_speed
C#
public float Exit_cruise_speed {get;}
Managed Extensions for C++
public: __property float get_Exit_cruise_speed();
C++/CLI
public:
property float Exit_cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Exit_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exit_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Exit_negotiation_speed
C#
public float Exit_negotiation_speed {get;}
Managed Extensions for C++
public: __property float get_Exit_negotiation_speed();
C++/CLI
public:
property float Exit_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Flow
C#
public float Flow {get;}
Managed Extensions for C++
public: __property float get_Flow();
C++/CLI
public:
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Flow_capconstr
C#
public float Flow_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_capconstr();
C++/CLI
public:
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Fuel_consumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Fuel_consumption_rate
C#
public float Fuel_consumption_rate {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_rate();
C++/CLI
public:
property float Fuel_consumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
public float Gap_accept_blocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_blocked_time();
C++/CLI
public:
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
public float Gap_accept_cycle_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_cycle_time();
C++/CLI
public:
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
public float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
public: __property float get_Gap_accept_unblocked_time();
C++/CLI
public:
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Green_periods
C#
public int Green_periods {get;}
Managed Extensions for C++
public: __property int get_Green_periods();
C++/CLI
public:
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Green_time_ratio
C#
public float Green_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Green_time_ratio();
C++/CLI
public:
property float Green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_continuous_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_continuous_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_continuous_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_continuous_control
C#
public bool Has_continuous_control {get;}
Managed Extensions for C++
public: __property bool get_Has_continuous_control();
C++/CLI
public:
property bool Has_continuous_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_giveway_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_giveway_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_giveway_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_giveway_control
C#
public bool Has_giveway_control {get;}
Managed Extensions for C++
public: __property bool get_Has_giveway_control();
C++/CLI
public:
property bool Has_giveway_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_highangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_highangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_highangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_highangle_slip
C#
public bool Has_highangle_slip {get;}
Managed Extensions for C++
public: __property bool get_Has_highangle_slip();
C++/CLI
public:
property bool Has_highangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_lowangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_lowangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_lowangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_lowangle_slip
C#
public bool Has_lowangle_slip {get;}
Managed Extensions for C++
public: __property bool get_Has_lowangle_slip();
C++/CLI
public:
property bool Has_lowangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_signals_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_signals_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_signals_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_signals_control
C#
public bool Has_signals_control {get;}
Managed Extensions for C++
public: __property bool get_Has_signals_control();
C++/CLI
public:
property bool Has_signals_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_stop_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Has_stop_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_stop_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_stop_control
C#
public bool Has_stop_control {get;}
Managed Extensions for C++
public: __property bool get_Has_stop_control();
C++/CLI
public:
property bool Has_stop_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Hydrocarbons_rate
C#
public float Hydrocarbons_rate {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_rate();
C++/CLI
public:
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Initial_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Initial_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Initial_demand_vol
C#
public float Initial_demand_vol {get;}
Managed Extensions for C++
public: __property float get_Initial_demand_vol();
C++/CLI
public:
property float Initial_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Minimum_delay
C#
public float Minimum_delay {get;}
Managed Extensions for C++
public: __property float get_Minimum_delay();
C++/CLI
public:
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Negotiation_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Negotiation_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Negotiation_distance
C#
public float Negotiation_distance {get;}
Managed Extensions for C++
public: __property float get_Negotiation_distance();
C++/CLI
public:
property float Negotiation_distance {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Non_actuated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Non_actuated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Non_actuated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Non_actuated
C#
public bool Non_actuated {get;}
Managed Extensions for C++
public: __property bool get_Non_actuated();
C++/CLI
public:
property bool Non_actuated {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Nox_rate
C#
public float Nox_rate {get;}
Managed Extensions for C++
public: __property float get_Nox_rate();
C++/CLI
public:
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Operating_cost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Operating_cost_rate
C#
public float Operating_cost_rate {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_rate();
C++/CLI
public:
property float Operating_cost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleOD Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : OutputMovementVehicleOD Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementVehicleOD As ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As ISIAPIOutputMovementVehicleOD

value = instance.OutputMovementVehicleOD
C#
public ISIAPIOutputMovementVehicleOD OutputMovementVehicleOD {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleOD* get_OutputMovementVehicleOD();
C++/CLI
public:
property ISIAPIOutputMovementVehicleOD^ OutputMovementVehicleOD {
   ISIAPIOutputMovementVehicleOD^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODMC_GreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : OutputMovementVehicleODMC_GreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementVehicleODMC_GreenPeriods As ISIAPIOutputMovementVehicleODMC_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As ISIAPIOutputMovementVehicleODMC_GreenPeriods

value = instance.OutputMovementVehicleODMC_GreenPeriods
C#
public ISIAPIOutputMovementVehicleODMC_GreenPeriods OutputMovementVehicleODMC_GreenPeriods {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleODMC_GreenPeriods* get_OutputMovementVehicleODMC_GreenPeriods();
C++/CLI
public:
property ISIAPIOutputMovementVehicleODMC_GreenPeriods^ OutputMovementVehicleODMC_GreenPeriods {
   ISIAPIOutputMovementVehicleODMC_GreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Oversatn_duration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Oversatn_duration Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Oversatn_duration As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Oversatn_duration
C#
public float Oversatn_duration {get;}
Managed Extensions for C++
public: __property float get_Oversatn_duration();
C++/CLI
public:
property float Oversatn_duration {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Perc_arriving_during_green
C#
public float Perc_arriving_during_green {get;}
Managed Extensions for C++
public: __property float get_Perc_arriving_during_green();
C++/CLI
public:
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Platoon_ratio
C#
public float Platoon_ratio {get;}
Managed Extensions for C++
public: __property float get_Platoon_ratio();
C++/CLI
public:
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Practical_degree_of_saturation
C#
public float Practical_degree_of_saturation {get;}
Managed Extensions for C++
public: __property float get_Practical_degree_of_saturation();
C++/CLI
public:
property float Practical_degree_of_saturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_cycav_mean
C#
public float Queue_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_mean();
C++/CLI
public:
property float Queue_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_cycav_percentile
C#
public float Queue_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_percentile();
C++/CLI
public:
property float Queue_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
public float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_mean();
C++/CLI
public:
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
public float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_percentile();
C++/CLI
public:
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
public float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_mean();
C++/CLI
public:
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
public float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_percentile();
C++/CLI
public:
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_greenstart_mean
C#
public float Queue_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_mean();
C++/CLI
public:
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
public float Queue_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_percentile();
C++/CLI
public:
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_storage_ratio_avg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
public float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_avg();
C++/CLI
public:
property float Queue_storage_ratio_avg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Queue_storage_ratio_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
public float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_percentile();
C++/CLI
public:
property float Queue_storage_ratio_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Residual_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Residual_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Residual_demand_vol
C#
public float Residual_demand_vol {get;}
Managed Extensions for C++
public: __property float get_Residual_demand_vol();
C++/CLI
public:
property float Residual_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Residual_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Residual_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Residual_demand_vol_clear_time
C#
public float Residual_demand_vol_clear_time {get;}
Managed Extensions for C++
public: __property float get_Residual_demand_vol_clear_time();
C++/CLI
public:
property float Residual_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Running_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Running_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Running_speed
C#
public float Running_speed {get;}
Managed Extensions for C++
public: __property float get_Running_speed();
C++/CLI
public:
property float Running_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_coordination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Signal_coordination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Signal_coordination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Signal_coordination
C#
public int Signal_coordination {get;}
Managed Extensions for C++
public: __property int get_Signal_coordination();
C++/CLI
public:
property int Signal_coordination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_distance_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_stopline_average
C#
public float Travel_distance_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_stopline_average();
C++/CLI
public:
property float Travel_distance_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_distance_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_stopline_total
C#
public float Travel_distance_stopline_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_stopline_total();
C++/CLI
public:
property float Travel_distance_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_time_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_stopline_average
C#
public float Travel_time_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_stopline_average();
C++/CLI
public:
property float Travel_time_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_time_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_stopline_total
C#
public float Travel_time_stopline_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_stopline_total();
C++/CLI
public:
property float Travel_time_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Unblocked_time_ratio
C#
public float Unblocked_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Unblocked_time_ratio();
C++/CLI
public:
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC Class : X1_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.X1_flag
C#
public int X1_flag {get;}
Managed Extensions for C++
public: __property int get_X1_flag();
C++/CLI
public:
property int X1_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC Class
SIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriod Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriod Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleODMC_GreenPeriod Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleODMC_GreenPeriod
   Implements ISIAPIOutputMovementVehicleODMC_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
C#
public sealed class SIAPIOutputMovementVehicleODMC_GreenPeriod : ISIAPIOutputMovementVehicleODMC_GreenPeriod
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleODMC_GreenPeriod : public ISIAPIOutputMovementVehicleODMC_GreenPeriod
C++/CLI
public ref class SIAPIOutputMovementVehicleODMC_GreenPeriod sealed : public ISIAPIOutputMovementVehicleODMC_GreenPeriod

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC_GreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriod Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriod Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleODMC_GreenPeriod.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleODMC_GreenPeriod Constructor |
Top

Public Properties

 | Name | Description
Public Property | Adjusted_flow_ratio |
Public Property | Adjusted_lost_time |
Public Property | Coord_mov_runs |
Public Property | Critical_mov |
Public Property | Displayed_end_time |
Public Property | Displayed_green_time |
Public Property | Displayed_start_time |
Public Property | Eff_end_gain |
Public Property | Eff_end_time |
Public Property | Eff_green |
Public Property | Eff_start_loss |
Public Property | Eff_start_time |
Public Property | End_phase |
Public Property | Flow_ratio |
Public Property | Greenperiod | Green Period value is a one-based integer.
Public Property | Lost_time |
Public Property | Min_max_flag |
Public Property | No_arrival |
Public Property | Opposed |
Public Property | Priority |
Public Property | Queue_move_up_speed |
Public Property | Reqd_green_time_ratio |
Public Property | Reqd_time |
Public Property | Satn_flow |
Public Property | Satn_flow_flag |
Public Property | Start_phase |
Public Property | Timing_data_type |
Public Property | Tmax |
Public Property | Tmin |
Public Property | Undetected |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriod Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : SIAPIOutputMovementVehicleODMC_GreenPeriod Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleODMC_GreenPeriod()
C#
public SIAPIOutputMovementVehicleODMC_GreenPeriod()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleODMC_GreenPeriod();
C++/CLI
public:
SIAPIOutputMovementVehicleODMC_GreenPeriod();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriod Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriod Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMC_GreenPeriod members.

Public Properties

 | Name | Description
Public Property | Adjusted_flow_ratio |
Public Property | Adjusted_lost_time |
Public Property | Coord_mov_runs |
Public Property | Critical_mov |
Public Property | Displayed_end_time |
Public Property | Displayed_green_time |
Public Property | Displayed_start_time |
Public Property | Eff_end_gain |
Public Property | Eff_end_time |
Public Property | Eff_green |
Public Property | Eff_start_loss |
Public Property | Eff_start_time |
Public Property | End_phase |
Public Property | Flow_ratio |
Public Property | Greenperiod | Green Period value is a one-based integer.
Public Property | Lost_time |
Public Property | Min_max_flag |
Public Property | No_arrival |
Public Property | Opposed |
Public Property | Priority |
Public Property | Queue_move_up_speed |
Public Property | Reqd_green_time_ratio |
Public Property | Reqd_time |
Public Property | Satn_flow |
Public Property | Satn_flow_flag |
Public Property | Start_phase |
Public Property | Timing_data_type |
Public Property | Tmax |
Public Property | Tmin |
Public Property | Undetected |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Adjusted_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Adjusted_flow_ratio
C#
public float Adjusted_flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Adjusted_flow_ratio();
C++/CLI
public:
property float Adjusted_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Adjusted_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Adjusted_lost_time
C#
public int Adjusted_lost_time {get;}
Managed Extensions for C++
public: __property int get_Adjusted_lost_time();
C++/CLI
public:
property int Adjusted_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_runs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Coord_mov_runs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_runs As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Coord_mov_runs
C#
public bool Coord_mov_runs {get;}
Managed Extensions for C++
public: __property bool get_Coord_mov_runs();
C++/CLI
public:
property bool Coord_mov_runs {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Critical_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Critical_mov
C#
public bool Critical_mov {get;}
Managed Extensions for C++
public: __property bool get_Critical_mov();
C++/CLI
public:
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Displayed_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_end_time
C#
public int Displayed_end_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_end_time();
C++/CLI
public:
property int Displayed_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_green_time
C#
public int Displayed_green_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_green_time();
C++/CLI
public:
property int Displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_start_time
C#
public int Displayed_start_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_start_time();
C++/CLI
public:
property int Displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Eff_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_end_gain
C#
public int Eff_end_gain {get;}
Managed Extensions for C++
public: __property int get_Eff_end_gain();
C++/CLI
public:
property int Eff_end_gain {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Eff_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_end_time
C#
public int Eff_end_time {get;}
Managed Extensions for C++
public: __property int get_Eff_end_time();
C++/CLI
public:
property int Eff_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_green
C#
public int Eff_green {get;}
Managed Extensions for C++
public: __property int get_Eff_green();
C++/CLI
public:
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Eff_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_start_loss
C#
public int Eff_start_loss {get;}
Managed Extensions for C++
public: __property int get_Eff_start_loss();
C++/CLI
public:
property int Eff_start_loss {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_start_time
C#
public int Eff_start_time {get;}
Managed Extensions for C++
public: __property int get_Eff_start_time();
C++/CLI
public:
property int Eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : End_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.End_phase
C#
public int End_phase {get;}
Managed Extensions for C++
public: __property int get_End_phase();
C++/CLI
public:
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
public float Flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Flow_ratio();
C++/CLI
public:
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Greenperiod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Greenperiod
C#
public int Greenperiod {get;}
Managed Extensions for C++
public: __property int get_Greenperiod();
C++/CLI
public:
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Lost_time
C#
public int Lost_time {get;}
Managed Extensions for C++
public: __property int get_Lost_time();
C++/CLI
public:
property int Lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Min_max_flag
C#
public int Min_max_flag {get;}
Managed Extensions for C++
public: __property int get_Min_max_flag();
C++/CLI
public:
property int Min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
No_arrival Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : No_arrival Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property No_arrival As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.No_arrival
C#
public bool No_arrival {get;}
Managed Extensions for C++
public: __property bool get_No_arrival();
C++/CLI
public:
property bool No_arrival {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Opposed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Opposed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Opposed
C#
public bool Opposed {get;}
Managed Extensions for C++
public: __property bool get_Opposed();
C++/CLI
public:
property bool Opposed {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Priority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Priority
C#
public bool Priority {get;}
Managed Extensions for C++
public: __property bool get_Priority();
C++/CLI
public:
property bool Priority {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_move_up_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Queue_move_up_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_move_up_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Queue_move_up_speed
C#
public float Queue_move_up_speed {get;}
Managed Extensions for C++
public: __property float get_Queue_move_up_speed();
C++/CLI
public:
property float Queue_move_up_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Reqd_green_time_ratio
C#
public float Reqd_green_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Reqd_green_time_ratio();
C++/CLI
public:
property float Reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Reqd_time
C#
public float Reqd_time {get;}
Managed Extensions for C++
public: __property float get_Reqd_time();
C++/CLI
public:
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Satn_flow
C#
public float Satn_flow {get;}
Managed Extensions for C++
public: __property float get_Satn_flow();
C++/CLI
public:
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Satn_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Satn_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Satn_flow_flag
C#
public int Satn_flow_flag {get;}
Managed Extensions for C++
public: __property int get_Satn_flow_flag();
C++/CLI
public:
property int Satn_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Start_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Start_phase
C#
public int Start_phase {get;}
Managed Extensions for C++
public: __property int get_Start_phase();
C++/CLI
public:
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Timing_data_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Timing_data_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Timing_data_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Timing_data_type
C#
public int Timing_data_type {get;}
Managed Extensions for C++
public: __property int get_Timing_data_type();
C++/CLI
public:
property int Timing_data_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Tmax
C#
public float Tmax {get;}
Managed Extensions for C++
public: __property float get_Tmax();
C++/CLI
public:
property float Tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Tmin
C#
public float Tmin {get;}
Managed Extensions for C++
public: __property float get_Tmin();
C++/CLI
public:
property float Tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriod Class : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Undetected
C#
public bool Undetected {get;}
Managed Extensions for C++
public: __property bool get_Undetected();
C++/CLI
public:
property bool Undetected {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriod Class
SIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriods Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriods Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleODMC_GreenPeriods ClassISIAPIOutputMovementVehicleODMC_GreenPeriod Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleODMC_GreenPeriods
   Implements ISIAPIOutputMovementVehicleODMC_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriods
C#
public sealed class SIAPIOutputMovementVehicleODMC_GreenPeriods : ISIAPIOutputMovementVehicleODMC_GreenPeriods
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleODMC_GreenPeriods : public ISIAPIOutputMovementVehicleODMC_GreenPeriods
C++/CLI
public ref class SIAPIOutputMovementVehicleODMC_GreenPeriods sealed : public ISIAPIOutputMovementVehicleODMC_GreenPeriods

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMC_GreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriods Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriods Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleODMC_GreenPeriods.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleODMC_GreenPeriods Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement Output Green Period Data. Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriods Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriods Class : SIAPIOutputMovementVehicleODMC_GreenPeriods Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleODMC_GreenPeriods()
C#
public SIAPIOutputMovementVehicleODMC_GreenPeriods()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleODMC_GreenPeriods();
C++/CLI
public:
SIAPIOutputMovementVehicleODMC_GreenPeriods();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriods Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMC_GreenPeriods members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GreenPeriodExists | Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriods Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriods
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriods Class : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
public bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
public: bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
public:
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMC_GreenPeriods Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMC_GreenPeriods Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMC_GreenPeriods members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement Output Green Period Data. Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriods Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriods
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMC_GreenPeriods Class : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a Vehicle Movement Output Green Period Data.
Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMC_GreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputMovementVehicleODMC_GreenPeriod

value = instance.Item(greenperiod)
C#
public ISIAPIOutputMovementVehicleODMC_GreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleODMC_GreenPeriod* get_Item   int greenperiod
;
C++/CLI
public:
property ISIAPIOutputMovementVehicleODMC_GreenPeriod^ default [int] {
   ISIAPIOutputMovementVehicleODMC_GreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMC_GreenPeriods Class
SIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMCs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMCs Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleODMCs ClassISIAPIOutputMovementVehicleODMC Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleODMCs
   Implements ISIAPIOutputMovementVehicleODMCs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMCs
C#
public sealed class SIAPIOutputMovementVehicleODMCs : ISIAPIOutputMovementVehicleODMCs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleODMCs : public ISIAPIOutputMovementVehicleODMCs
C++/CLI
public ref class SIAPIOutputMovementVehicleODMCs sealed : public ISIAPIOutputMovementVehicleODMCs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMCs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMCs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleODMCs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleODMCs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMCs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMCs Class : SIAPIOutputMovementVehicleODMCs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleODMCs()
C#
public SIAPIOutputMovementVehicleODMCs()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleODMCs();
C++/CLI
public:
SIAPIOutputMovementVehicleODMCs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMCs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMCs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementClassExists |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMCs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMCs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMCs Class : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
public bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
public: bool MovementClassExists(
   int mcClass
)
C++/CLI
public:
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODMCs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODMCs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODMCs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMCs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMCs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODMCs Class : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputMovementVehicleODMC
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputMovementVehicleODMC

value = instance.Item(mcClass)
C#
public ISIAPIOutputMovementVehicleODMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleODMC* get_Item   int mcClass
;
C++/CLI
public:
property ISIAPIOutputMovementVehicleODMC^ default [int] {
   ISIAPIOutputMovementVehicleODMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODMCs Class
SIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODs Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODs Class

Glossary Item Box

Object Model

SIAPIOutputMovementVehicleODs ClassISIAPIOutputMovementVehicleOD Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputMovementVehicleODs
   Implements ISIAPIOutputMovementVehicleODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODs
C#
public sealed class SIAPIOutputMovementVehicleODs : ISIAPIOutputMovementVehicleODs
Managed Extensions for C++
public __gc __sealed class SIAPIOutputMovementVehicleODs : public ISIAPIOutputMovementVehicleODs
C++/CLI
public ref class SIAPIOutputMovementVehicleODs sealed : public ISIAPIOutputMovementVehicleODs

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputMovementVehicleODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODs Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODs Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputMovementVehicleODs.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputMovementVehicleODs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement Output Data Object. Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODs Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODs Class : SIAPIOutputMovementVehicleODs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputMovementVehicleODs()
C#
public SIAPIOutputMovementVehicleODs()
Managed Extensions for C++
public: SIAPIOutputMovementVehicleODs();
C++/CLI
public:
SIAPIOutputMovementVehicleODs();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIAPIOutputMovementVehicleODs Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODs Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODs members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | MovementExists | Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.
Top

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODs Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODs
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIAPIOutputMovementVehicleODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODs Class : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODs
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
public bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
public: bool MovementExists(
   int origin,
   int destination
)
C++/CLI
public:
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIAPIOutputMovementVehicleODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputMovementVehicleODs Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputMovementVehicleODs Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputMovementVehicleODs members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Vehicle Movement Output Data Object. Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODs Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODs
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIAPIOutputMovementVehicleODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputMovementVehicleODs Class : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Vehicle Movement Output Data Object.
Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputMovementVehicleODs
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIOutputMovementVehicleOD

value = instance.Item(origin, destination)
C#
public ISIAPIOutputMovementVehicleOD this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleOD* get_Item   int origin,
   int destination
;
C++/CLI
public:
property ISIAPIOutputMovementVehicleOD^ default [int,int] {
   ISIAPIOutputMovementVehicleOD^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputMovementVehicleODs Class
SIAPIOutputMovementVehicleODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetwork Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetwork Class

Glossary Item Box

Object Model

SIAPIOutputNetwork ClassISIAPINetwork InterfaceISIAPIOutputNetworkGraphTuples InterfaceISIAPIOutputNetworkGraphTuple InterfaceISIAPIOutputNetworkPedestrian InterfaceISIAPIOutputNetworkPerson InterfaceISIAPIOutputNetworkVehicle InterfaceISIAPIOutputRouteMovementBasedPerson InterfaceISIAPIOutputRouteMovementBasedVehicle InterfaceISIAPIRoute Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetwork
   Implements ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
C#
public sealed class SIAPIOutputNetwork : ISIAPIOutputNetwork
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetwork : public ISIAPIOutputNetwork
C++/CLI
public ref class SIAPIOutputNetwork sealed : public ISIAPIOutputNetwork

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetwork

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetwork Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetwork Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetwork.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetwork Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Analysis_method_flag |
Public Property | Analysis_status |
Public Property | Cycle_time_option |
Public Property | GeneratedByVersion |
Public Property | GeneratedTime |
Public Property | IterationsCount | The number of iterations that have been run to get this network output result
Public Property | Largest_movement_flow_scale |
Public Property | Network |
Public Property | NetworkCycleTime |
Public Property | NetworkSummaryType | Network Summary Type, the summary type of this SIAPIOutputNetwork.
Public Property | OutputNetworkGraphTuples |
Public Property | OutputNetworkPedestrian |
Public Property | OutputNetworkPerson |
Public Property | OutputNetworkVehicle |
Public Property | OutputRouteMovementBasedPerson |
Public Property | OutputRouteMovementBasedVehicle |
Public Property | Route |
Public Property | Selected_future_year |
Public Property | Selected_parameter_scale |
Public Property | Single_ccg |
Top

See Also

Reference

SIAPIOutputNetwork Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetwork Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : SIAPIOutputNetwork Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetwork()
C#
public SIAPIOutputNetwork()
Managed Extensions for C++
public: SIAPIOutputNetwork();
C++/CLI
public:
SIAPIOutputNetwork();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetwork Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetwork Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetwork members.

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Analysis_method_flag |
Public Property | Analysis_status |
Public Property | Cycle_time_option |
Public Property | GeneratedByVersion |
Public Property | GeneratedTime |
Public Property | IterationsCount | The number of iterations that have been run to get this network output result
Public Property | Largest_movement_flow_scale |
Public Property | Network |
Public Property | NetworkCycleTime |
Public Property | NetworkSummaryType | Network Summary Type, the summary type of this SIAPIOutputNetwork.
Public Property | OutputNetworkGraphTuples |
Public Property | OutputNetworkPedestrian |
Public Property | OutputNetworkPerson |
Public Property | OutputNetworkVehicle |
Public Property | OutputRouteMovementBasedPerson |
Public Property | OutputRouteMovementBasedVehicle |
Public Property | Route |
Public Property | Selected_future_year |
Public Property | Selected_parameter_scale |
Public Property | Single_ccg |
Top

See Also

Reference

SIAPIOutputNetwork Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_method
C#
public int Analysis_method {get;}
Managed Extensions for C++
public: __property int get_Analysis_method();
C++/CLI
public:
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Analysis_method_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_method_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_method_flag
C#
public int Analysis_method_flag {get;}
Managed Extensions for C++
public: __property int get_Analysis_method_flag();
C++/CLI
public:
property int Analysis_method_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_status
C#
public int Analysis_status {get;}
Managed Extensions for C++
public: __property int get_Analysis_status();
C++/CLI
public:
property int Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Cycle_time_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Cycle_time_option
C#
public int Cycle_time_option {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_option();
C++/CLI
public:
property int Cycle_time_option {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedByVersion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : GeneratedByVersion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GeneratedByVersion As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As String

value = instance.GeneratedByVersion
C#
public string GeneratedByVersion {get;}
Managed Extensions for C++
public: __property string* get_GeneratedByVersion();
C++/CLI
public:
property String^ GeneratedByVersion {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : GeneratedTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GeneratedTime As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Date

value = instance.GeneratedTime
C#
public DateTime GeneratedTime {get;}
Managed Extensions for C++
public: __property DateTime get_GeneratedTime();
C++/CLI
public:
property DateTime GeneratedTime {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : IterationsCount Property

Glossary Item Box

The number of iterations that have been run to get this network output result

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.IterationsCount
C#
public int IterationsCount {get;}
Managed Extensions for C++
public: __property int get_IterationsCount();
C++/CLI
public:
property int IterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Largest_movement_flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Largest_movement_flow_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Largest_movement_flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Single

value = instance.Largest_movement_flow_scale
C#
public float Largest_movement_flow_scale {get;}
Managed Extensions for C++
public: __property float get_Largest_movement_flow_scale();
C++/CLI
public:
property float Largest_movement_flow_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCycleTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : NetworkCycleTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkCycleTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.NetworkCycleTime
C#
public int NetworkCycleTime {get;}
Managed Extensions for C++
public: __property int get_NetworkCycleTime();
C++/CLI
public:
property int NetworkCycleTime {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSummaryType Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : NetworkSummaryType Property

Glossary Item Box

Network Summary Type, the summary type of this SIAPIOutputNetwork.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSummaryType As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.NetworkSummaryType
C#
public int NetworkSummaryType {get;}
Managed Extensions for C++
public: __property int get_NetworkSummaryType();
C++/CLI
public:
property int NetworkSummaryType {
   int get();
}

Property Value

Type: System.Int32;

1 = Whole Network,
2 = Summary for selected Routes,
3 = Summary for a particular Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkGraphTuples Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputNetworkGraphTuples Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetworkGraphTuples As ISIAPIOutputNetworkGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkGraphTuples

value = instance.OutputNetworkGraphTuples
C#
public ISIAPIOutputNetworkGraphTuples OutputNetworkGraphTuples {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetworkGraphTuples* get_OutputNetworkGraphTuples();
C++/CLI
public:
property ISIAPIOutputNetworkGraphTuples^ OutputNetworkGraphTuples {
   ISIAPIOutputNetworkGraphTuples^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkPedestrian Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputNetworkPedestrian Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetworkPedestrian As ISIAPIOutputNetworkPedestrian
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkPedestrian

value = instance.OutputNetworkPedestrian
C#
public ISIAPIOutputNetworkPedestrian OutputNetworkPedestrian {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetworkPedestrian* get_OutputNetworkPedestrian();
C++/CLI
public:
property ISIAPIOutputNetworkPedestrian^ OutputNetworkPedestrian {
   ISIAPIOutputNetworkPedestrian^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkPerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputNetworkPerson Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetworkPerson As ISIAPIOutputNetworkPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkPerson

value = instance.OutputNetworkPerson
C#
public ISIAPIOutputNetworkPerson OutputNetworkPerson {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetworkPerson* get_OutputNetworkPerson();
C++/CLI
public:
property ISIAPIOutputNetworkPerson^ OutputNetworkPerson {
   ISIAPIOutputNetworkPerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputNetworkVehicle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputNetworkVehicle As ISIAPIOutputNetworkVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkVehicle

value = instance.OutputNetworkVehicle
C#
public ISIAPIOutputNetworkVehicle OutputNetworkVehicle {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetworkVehicle* get_OutputNetworkVehicle();
C++/CLI
public:
property ISIAPIOutputNetworkVehicle^ OutputNetworkVehicle {
   ISIAPIOutputNetworkVehicle^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRouteMovementBasedPerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputRouteMovementBasedPerson Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputRouteMovementBasedPerson As ISIAPIOutputRouteMovementBasedPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputRouteMovementBasedPerson

value = instance.OutputRouteMovementBasedPerson
C#
public ISIAPIOutputRouteMovementBasedPerson OutputRouteMovementBasedPerson {get;}
Managed Extensions for C++
public: __property ISIAPIOutputRouteMovementBasedPerson* get_OutputRouteMovementBasedPerson();
C++/CLI
public:
property ISIAPIOutputRouteMovementBasedPerson^ OutputRouteMovementBasedPerson {
   ISIAPIOutputRouteMovementBasedPerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRouteMovementBasedVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : OutputRouteMovementBasedVehicle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputRouteMovementBasedVehicle As ISIAPIOutputRouteMovementBasedVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIOutputRouteMovementBasedVehicle

value = instance.OutputRouteMovementBasedVehicle
C#
public ISIAPIOutputRouteMovementBasedVehicle OutputRouteMovementBasedVehicle {get;}
Managed Extensions for C++
public: __property ISIAPIOutputRouteMovementBasedVehicle* get_OutputRouteMovementBasedVehicle();
C++/CLI
public:
property ISIAPIOutputRouteMovementBasedVehicle^ OutputRouteMovementBasedVehicle {
   ISIAPIOutputRouteMovementBasedVehicle^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Route Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Route As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As ISIAPIRoute

value = instance.Route
C#
public ISIAPIRoute Route {get;}
Managed Extensions for C++
public: __property ISIAPIRoute* get_Route();
C++/CLI
public:
property ISIAPIRoute^ Route {
   ISIAPIRoute^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_future_year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Selected_future_year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selected_future_year As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Selected_future_year
C#
public int Selected_future_year {get;}
Managed Extensions for C++
public: __property int get_Selected_future_year();
C++/CLI
public:
property int Selected_future_year {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_parameter_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Selected_parameter_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Selected_parameter_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Single

value = instance.Selected_parameter_scale
C#
public float Selected_parameter_scale {get;}
Managed Extensions for C++
public: __property float get_Selected_parameter_scale();
C++/CLI
public:
property float Selected_parameter_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_ccg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetwork Class : Single_ccg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Single_ccg As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetwork
Dim value As Integer

value = instance.Single_ccg
C#
public int Single_ccg {get;}
Managed Extensions for C++
public: __property int get_Single_ccg();
C++/CLI
public:
property int Single_ccg {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetwork Class
SIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuple Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuple Class

Glossary Item Box

Object Model

SIAPIOutputNetworkGraphTuple Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetworkGraphTuple
   Implements ISIAPIOutputNetworkGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
C#
public sealed class SIAPIOutputNetworkGraphTuple : ISIAPIOutputNetworkGraphTuple
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetworkGraphTuple : public ISIAPIOutputNetworkGraphTuple
C++/CLI
public ref class SIAPIOutputNetworkGraphTuple sealed : public ISIAPIOutputNetworkGraphTuple

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetworkGraphTuple

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuple Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuple Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetworkGraphTuple.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetworkGraphTuple Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Arrival_flow_total_person |
Public Property | Capacity_effective |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_total |
Public Property | Cycle_time |
Public Property | Deg_satn |
Public Property | Deg_satn_ped |
Public Property | Delay_control_average |
Public Property | Delay_control_average_ped |
Public Property | Delay_control_average_veh |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_average_worstmov_ped |
Public Property | Delay_control_average_worstmov_person |
Public Property | Delay_control_total_ped |
Public Property | Delay_control_total_person |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Demand_flow_total |
Public Property | Demand_flow_total_ped |
Public Property | Demand_flow_total_person |
Public Property | Fuel_consumption_total |
Public Property | Hydrocarbons_total |
Public Property | Level_of_service |
Public Property | Level_of_service_ped |
Public Property | Level_of_service_veh |
Public Property | Nox_total |
Public Property | Operating_cost_total |
Public Property | Operating_cost_total_ped |
Public Property | Operating_cost_total_veh |
Public Property | Perc_heavy_veh |
Public Property | Performance_index |
Public Property | Performance_index_ped |
Public Property | Performance_index_veh |
Public Property | Practical_spare_capacity |
Public Property | Prop_queued_ped |
Public Property | Prop_queued_person |
Public Property | Prop_queued_veh |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_maxback_percentile |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stop_rate_ped |
Public Property | Stop_rate_veh |
Public Property | Total_stops_ped |
Public Property | Total_stops_person |
Public Property | Total_stops_veh |
Public Property | Travel_dist_av_ped |
Public Property | Travel_dist_av_person |
Public Property | Travel_dist_av_veh |
Public Property | Travel_dist_total_ped |
Public Property | Travel_dist_total_person |
Public Property | Travel_dist_total_veh |
Public Property | Travel_speed |
Public Property | Travel_speed_ped |
Public Property | Travel_speed_person |
Public Property | Travel_time_av_ped |
Public Property | Travel_time_av_person |
Public Property | Travel_time_av_veh |
Public Property | Travel_time_total_ped |
Public Property | Travel_time_total_person |
Public Property | Travel_time_total_veh |
Public Property | Unsettled |
Public Property | X_value |
Top

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuple Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : SIAPIOutputNetworkGraphTuple Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetworkGraphTuple()
C#
public SIAPIOutputNetworkGraphTuple()
Managed Extensions for C++
public: SIAPIOutputNetworkGraphTuple();
C++/CLI
public:
SIAPIOutputNetworkGraphTuple();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuple Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuple Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkGraphTuple members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_total |
Public Property | Arrival_flow_total_person |
Public Property | Capacity_effective |
Public Property | Carbon_dioxide_total |
Public Property | Carbon_monoxide_total |
Public Property | Cycle_time |
Public Property | Deg_satn |
Public Property | Deg_satn_ped |
Public Property | Delay_control_average |
Public Property | Delay_control_average_ped |
Public Property | Delay_control_average_veh |
Public Property | Delay_control_average_worstlane |
Public Property | Delay_control_average_worstmov |
Public Property | Delay_control_average_worstmov_ped |
Public Property | Delay_control_average_worstmov_person |
Public Property | Delay_control_total_ped |
Public Property | Delay_control_total_person |
Public Property | Delay_control_total_veh |
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Demand_flow_total |
Public Property | Demand_flow_total_ped |
Public Property | Demand_flow_total_person |
Public Property | Fuel_consumption_total |
Public Property | Hydrocarbons_total |
Public Property | Level_of_service |
Public Property | Level_of_service_ped |
Public Property | Level_of_service_veh |
Public Property | Nox_total |
Public Property | Operating_cost_total |
Public Property | Operating_cost_total_ped |
Public Property | Operating_cost_total_veh |
Public Property | Perc_heavy_veh |
Public Property | Performance_index |
Public Property | Performance_index_ped |
Public Property | Performance_index_veh |
Public Property | Practical_spare_capacity |
Public Property | Prop_queued_ped |
Public Property | Prop_queued_person |
Public Property | Prop_queued_veh |
Public Property | Queue_dist_maxback_percentile |
Public Property | Queue_maxback_percentile |
Public Property | SpeedEfficiency |
Public Property | Stop_rate |
Public Property | Stop_rate_ped |
Public Property | Stop_rate_veh |
Public Property | Total_stops_ped |
Public Property | Total_stops_person |
Public Property | Total_stops_veh |
Public Property | Travel_dist_av_ped |
Public Property | Travel_dist_av_person |
Public Property | Travel_dist_av_veh |
Public Property | Travel_dist_total_ped |
Public Property | Travel_dist_total_person |
Public Property | Travel_dist_total_veh |
Public Property | Travel_speed |
Public Property | Travel_speed_ped |
Public Property | Travel_speed_person |
Public Property | Travel_time_av_ped |
Public Property | Travel_time_av_person |
Public Property | Travel_time_av_veh |
Public Property | Travel_time_total_ped |
Public Property | Travel_time_total_person |
Public Property | Travel_time_total_veh |
Public Property | Unsettled |
Public Property | X_value |
Top

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Arrival_flow_total
C#
public float Arrival_flow_total {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total();
C++/CLI
public:
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Arrival_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Arrival_flow_total_person
C#
public float Arrival_flow_total_person {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total_person();
C++/CLI
public:
property float Arrival_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Capacity_effective
C#
public float Capacity_effective {get;}
Managed Extensions for C++
public: __property float get_Capacity_effective();
C++/CLI
public:
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Cycle_time
C#
public float Cycle_time {get;}
Managed Extensions for C++
public: __property float get_Cycle_time();
C++/CLI
public:
property float Cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Deg_satn_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Deg_satn_ped
C#
public float Deg_satn_ped {get;}
Managed Extensions for C++
public: __property float get_Deg_satn_ped();
C++/CLI
public:
property float Deg_satn_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_ped
C#
public float Delay_control_average_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_ped();
C++/CLI
public:
property float Delay_control_average_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_veh
C#
public float Delay_control_average_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_veh();
C++/CLI
public:
property float Delay_control_average_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
public float Delay_control_average_worstlane {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstlane();
C++/CLI
public:
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_worstmov_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_ped
C#
public float Delay_control_average_worstmov_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov_ped();
C++/CLI
public:
property float Delay_control_average_worstmov_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_average_worstmov_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_person
C#
public float Delay_control_average_worstmov_person {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov_person();
C++/CLI
public:
property float Delay_control_average_worstmov_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_ped
C#
public float Delay_control_total_ped {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_ped();
C++/CLI
public:
property float Delay_control_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_person
C#
public float Delay_control_total_person {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_person();
C++/CLI
public:
property float Delay_control_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_veh
C#
public float Delay_control_total_veh {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total_veh();
C++/CLI
public:
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_geometric_average
C#
public float Delay_geometric_average {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric_average();
C++/CLI
public:
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Demand_flow_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total_ped
C#
public float Demand_flow_total_ped {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total_ped();
C++/CLI
public:
property float Demand_flow_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Demand_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total_person
C#
public float Demand_flow_total_person {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total_person();
C++/CLI
public:
property float Demand_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service
C#
public int Level_of_service {get;}
Managed Extensions for C++
public: __property int get_Level_of_service();
C++/CLI
public:
property int Level_of_service {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Level_of_service_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_ped As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service_ped
C#
public int Level_of_service_ped {get;}
Managed Extensions for C++
public: __property int get_Level_of_service_ped();
C++/CLI
public:
property int Level_of_service_ped {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Level_of_service_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_veh As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service_veh
C#
public int Level_of_service_veh {get;}
Managed Extensions for C++
public: __property int get_Level_of_service_veh();
C++/CLI
public:
property int Level_of_service_veh {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Operating_cost_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total_ped
C#
public float Operating_cost_total_ped {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total_ped();
C++/CLI
public:
property float Operating_cost_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Operating_cost_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total_veh
C#
public float Operating_cost_total_veh {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total_veh();
C++/CLI
public:
property float Operating_cost_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_heavy_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Perc_heavy_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Perc_heavy_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Perc_heavy_veh
C#
public float Perc_heavy_veh {get;}
Managed Extensions for C++
public: __property float get_Perc_heavy_veh();
C++/CLI
public:
property float Perc_heavy_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Performance_index_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index_ped
C#
public float Performance_index_ped {get;}
Managed Extensions for C++
public: __property float get_Performance_index_ped();
C++/CLI
public:
property float Performance_index_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Performance_index_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index_veh
C#
public float Performance_index_veh {get;}
Managed Extensions for C++
public: __property float get_Performance_index_veh();
C++/CLI
public:
property float Performance_index_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Prop_queued_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_ped
C#
public float Prop_queued_ped {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_ped();
C++/CLI
public:
property float Prop_queued_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Prop_queued_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_person
C#
public float Prop_queued_person {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_person();
C++/CLI
public:
property float Prop_queued_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Prop_queued_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prop_queued_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_veh
C#
public float Prop_queued_veh {get;}
Managed Extensions for C++
public: __property float get_Prop_queued_veh();
C++/CLI
public:
property float Prop_queued_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Stop_rate_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate_ped
C#
public float Stop_rate_ped {get;}
Managed Extensions for C++
public: __property float get_Stop_rate_ped();
C++/CLI
public:
property float Stop_rate_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Stop_rate_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate_veh
C#
public float Stop_rate_veh {get;}
Managed Extensions for C++
public: __property float get_Stop_rate_veh();
C++/CLI
public:
property float Stop_rate_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Total_stops_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_ped
C#
public float Total_stops_ped {get;}
Managed Extensions for C++
public: __property float get_Total_stops_ped();
C++/CLI
public:
property float Total_stops_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Total_stops_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_person
C#
public float Total_stops_person {get;}
Managed Extensions for C++
public: __property float get_Total_stops_person();
C++/CLI
public:
property float Total_stops_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Total_stops_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Total_stops_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_veh
C#
public float Total_stops_veh {get;}
Managed Extensions for C++
public: __property float get_Total_stops_veh();
C++/CLI
public:
property float Total_stops_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_ped
C#
public float Travel_dist_av_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_ped();
C++/CLI
public:
property float Travel_dist_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_person
C#
public float Travel_dist_av_person {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_person();
C++/CLI
public:
property float Travel_dist_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_veh
C#
public float Travel_dist_av_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_av_veh();
C++/CLI
public:
property float Travel_dist_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_ped
C#
public float Travel_dist_total_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_ped();
C++/CLI
public:
property float Travel_dist_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_person
C#
public float Travel_dist_total_person {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_person();
C++/CLI
public:
property float Travel_dist_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_dist_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_dist_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_veh
C#
public float Travel_dist_total_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_dist_total_veh();
C++/CLI
public:
property float Travel_dist_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_speed_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed_ped
C#
public float Travel_speed_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_speed_ped();
C++/CLI
public:
property float Travel_speed_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_speed_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed_person
C#
public float Travel_speed_person {get;}
Managed Extensions for C++
public: __property float get_Travel_speed_person();
C++/CLI
public:
property float Travel_speed_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_ped
C#
public float Travel_time_av_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_ped();
C++/CLI
public:
property float Travel_time_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_person
C#
public float Travel_time_av_person {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_person();
C++/CLI
public:
property float Travel_time_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_veh
C#
public float Travel_time_av_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_time_av_veh();
C++/CLI
public:
property float Travel_time_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_ped
C#
public float Travel_time_total_ped {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_ped();
C++/CLI
public:
property float Travel_time_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_person
C#
public float Travel_time_total_person {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_person();
C++/CLI
public:
property float Travel_time_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Travel_time_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_veh
C#
public float Travel_time_total_veh {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total_veh();
C++/CLI
public:
property float Travel_time_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unsettled Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : Unsettled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Unsettled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Boolean

value = instance.Unsettled
C#
public bool Unsettled {get;}
Managed Extensions for C++
public: __property bool get_Unsettled();
C++/CLI
public:
property bool Unsettled {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X_value Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuple Class : X_value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X_value As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.X_value
C#
public float X_value {get;}
Managed Extensions for C++
public: __property float get_X_value();
C++/CLI
public:
property float X_value {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuple Class
SIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuples Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuples Class

Glossary Item Box

Object Model

SIAPIOutputNetworkGraphTuples ClassISIAPIOutputNetworkGraphTuple Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetworkGraphTuples
   Implements ISIAPIOutputNetworkGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuples
C#
public sealed class SIAPIOutputNetworkGraphTuples : ISIAPIOutputNetworkGraphTuples
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetworkGraphTuples : public ISIAPIOutputNetworkGraphTuples
C++/CLI
public ref class SIAPIOutputNetworkGraphTuples sealed : public ISIAPIOutputNetworkGraphTuples

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetworkGraphTuples

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuples Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuples Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuples Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetworkGraphTuples.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetworkGraphTuples Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuples Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuples Class : SIAPIOutputNetworkGraphTuples Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetworkGraphTuples()
C#
public SIAPIOutputNetworkGraphTuples()
Managed Extensions for C++
public: SIAPIOutputNetworkGraphTuples();
C++/CLI
public:
SIAPIOutputNetworkGraphTuples();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuples Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuples Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkGraphTuples members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuples Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuples
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkGraphTuples Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkGraphTuples Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkGraphTuples members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuples Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuples
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkGraphTuples Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputNetworkGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkGraphTuples
Dim index As Integer
Dim value As ISIAPIOutputNetworkGraphTuple

value = instance.Item(index)
C#
public ISIAPIOutputNetworkGraphTuple this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetworkGraphTuple* get_Item   int index
;
C++/CLI
public:
property ISIAPIOutputNetworkGraphTuple^ default [int] {
   ISIAPIOutputNetworkGraphTuple^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkGraphTuples Class
SIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPedestrian Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPedestrian Class

Glossary Item Box

Object Model

SIAPIOutputNetworkPedestrian Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetworkPedestrian
   Implements ISIAPIOutputNetworkPedestrian
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
C#
public sealed class SIAPIOutputNetworkPedestrian : ISIAPIOutputNetworkPedestrian
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetworkPedestrian : public ISIAPIOutputNetworkPedestrian
C++/CLI
public ref class SIAPIOutputNetworkPedestrian sealed : public ISIAPIOutputNetworkPedestrian

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetworkPedestrian

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPedestrian Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPedestrian Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetworkPedestrian.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetworkPedestrian Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrivalFlowTotal |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DemandFlowTotal |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | ProportionQueued |
Public Property | StopRate |
Public Property | StopsTotal |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPedestrian Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : SIAPIOutputNetworkPedestrian Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetworkPedestrian()
C#
public SIAPIOutputNetworkPedestrian()
Managed Extensions for C++
public: SIAPIOutputNetworkPedestrian();
C++/CLI
public:
SIAPIOutputNetworkPedestrian();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPedestrian Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPedestrian Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkPedestrian members.

Public Properties

 | Name | Description
Public Property | ArrivalFlowTotal |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DemandFlowTotal |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | ProportionQueued |
Public Property | StopRate |
Public Property | StopsTotal |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.ArrivalFlowTotal
C#
public float ArrivalFlowTotal {get;}
Managed Extensions for C++
public: __property float get_ArrivalFlowTotal();
C++/CLI
public:
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlAverage
C#
public float DelayControlAverage {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverage();
C++/CLI
public:
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
public float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverageWorstMovement();
C++/CLI
public:
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlTotal
C#
public float DelayControlTotal {get;}
Managed Extensions for C++
public: __property float get_DelayControlTotal();
C++/CLI
public:
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DemandFlowTotal
C#
public float DemandFlowTotal {get;}
Managed Extensions for C++
public: __property float get_DemandFlowTotal();
C++/CLI
public:
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.OperatingCostTotal
C#
public float OperatingCostTotal {get;}
Managed Extensions for C++
public: __property float get_OperatingCostTotal();
C++/CLI
public:
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.PerformanceIndex
C#
public float PerformanceIndex {get;}
Managed Extensions for C++
public: __property float get_PerformanceIndex();
C++/CLI
public:
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.ProportionQueued
C#
public float ProportionQueued {get;}
Managed Extensions for C++
public: __property float get_ProportionQueued();
C++/CLI
public:
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.StopRate
C#
public float StopRate {get;}
Managed Extensions for C++
public: __property float get_StopRate();
C++/CLI
public:
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.StopsTotal
C#
public float StopsTotal {get;}
Managed Extensions for C++
public: __property float get_StopsTotal();
C++/CLI
public:
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelDistanceAverage
C#
public float TravelDistanceAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceAverage();
C++/CLI
public:
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelDistanceTotal
C#
public float TravelDistanceTotal {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceTotal();
C++/CLI
public:
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelSpeed
C#
public float TravelSpeed {get;}
Managed Extensions for C++
public: __property float get_TravelSpeed();
C++/CLI
public:
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelTimeAverage
C#
public float TravelTimeAverage {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage();
C++/CLI
public:
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPedestrian Class : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelTimeTotal
C#
public float TravelTimeTotal {get;}
Managed Extensions for C++
public: __property float get_TravelTimeTotal();
C++/CLI
public:
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPedestrian Class
SIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPerson Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPerson Class

Glossary Item Box

Object Model

SIAPIOutputNetworkPerson Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetworkPerson
   Implements ISIAPIOutputNetworkPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
C#
public sealed class SIAPIOutputNetworkPerson : ISIAPIOutputNetworkPerson
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetworkPerson : public ISIAPIOutputNetworkPerson
C++/CLI
public ref class SIAPIOutputNetworkPerson sealed : public ISIAPIOutputNetworkPerson

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetworkPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPerson Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPerson Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetworkPerson.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetworkPerson Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrivalFlowTotal |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DemandFlowTotal |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | ProportionQueued |
Public Property | StopRate |
Public Property | StopsTotal |
Public Property | TravelDelay |
Public Property | TravelDelayAverage |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPerson Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : SIAPIOutputNetworkPerson Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetworkPerson()
C#
public SIAPIOutputNetworkPerson()
Managed Extensions for C++
public: SIAPIOutputNetworkPerson();
C++/CLI
public:
SIAPIOutputNetworkPerson();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkPerson Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkPerson Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkPerson members.

Public Properties

 | Name | Description
Public Property | ArrivalFlowTotal |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DemandFlowTotal |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | ProportionQueued |
Public Property | StopRate |
Public Property | StopsTotal |
Public Property | TravelDelay |
Public Property | TravelDelayAverage |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.ArrivalFlowTotal
C#
public float ArrivalFlowTotal {get;}
Managed Extensions for C++
public: __property float get_ArrivalFlowTotal();
C++/CLI
public:
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlAverage
C#
public float DelayControlAverage {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverage();
C++/CLI
public:
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
public float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverageWorstMovement();
C++/CLI
public:
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlTotal
C#
public float DelayControlTotal {get;}
Managed Extensions for C++
public: __property float get_DelayControlTotal();
C++/CLI
public:
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.DemandFlowTotal
C#
public float DemandFlowTotal {get;}
Managed Extensions for C++
public: __property float get_DemandFlowTotal();
C++/CLI
public:
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.OperatingCostTotal
C#
public float OperatingCostTotal {get;}
Managed Extensions for C++
public: __property float get_OperatingCostTotal();
C++/CLI
public:
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.PerformanceIndex
C#
public float PerformanceIndex {get;}
Managed Extensions for C++
public: __property float get_PerformanceIndex();
C++/CLI
public:
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.ProportionQueued
C#
public float ProportionQueued {get;}
Managed Extensions for C++
public: __property float get_ProportionQueued();
C++/CLI
public:
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.StopRate
C#
public float StopRate {get;}
Managed Extensions for C++
public: __property float get_StopRate();
C++/CLI
public:
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.StopsTotal
C#
public float StopsTotal {get;}
Managed Extensions for C++
public: __property float get_StopsTotal();
C++/CLI
public:
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDelay
C#
public float TravelDelay {get;}
Managed Extensions for C++
public: __property float get_TravelDelay();
C++/CLI
public:
property float TravelDelay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDelayAverage
C#
public float TravelDelayAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage();
C++/CLI
public:
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDistanceAverage
C#
public float TravelDistanceAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceAverage();
C++/CLI
public:
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDistanceTotal
C#
public float TravelDistanceTotal {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceTotal();
C++/CLI
public:
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelSpeed
C#
public float TravelSpeed {get;}
Managed Extensions for C++
public: __property float get_TravelSpeed();
C++/CLI
public:
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelTimeAverage
C#
public float TravelTimeAverage {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage();
C++/CLI
public:
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkPerson Class : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelTimeTotal
C#
public float TravelTimeTotal {get;}
Managed Extensions for C++
public: __property float get_TravelTimeTotal();
C++/CLI
public:
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkPerson Class
SIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkVehicle Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkVehicle Class

Glossary Item Box

Object Model

SIAPIOutputNetworkVehicle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputNetworkVehicle
   Implements ISIAPIOutputNetworkVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
C#
public sealed class SIAPIOutputNetworkVehicle : ISIAPIOutputNetworkVehicle
Managed Extensions for C++
public __gc __sealed class SIAPIOutputNetworkVehicle : public ISIAPIOutputNetworkVehicle
C++/CLI
public ref class SIAPIOutputNetworkVehicle sealed : public ISIAPIOutputNetworkVehicle

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputNetworkVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkVehicle Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkVehicle Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputNetworkVehicle.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputNetworkVehicle Constructor |
Top

Public Properties

 | Name | Description
Public Property | ArrivalFlow_HV_pct |
Public Property | ArrivalFlowTotal |
Public Property | Capacity_effective |
Public Property | CarbonDioxide_rate |
Public Property | CarbonDioxideTotal |
Public Property | CarbonMonoxide_rate |
Public Property | CarbonMonoxideTotal |
Public Property | CongestionCoefficient |
Public Property | DegreeSaturation |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstLane |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DelayGeometricAverage |
Public Property | DelayStoplineAverage |
Public Property | DemandFlow_HV_pct |
Public Property | DemandFlowTotal |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod |
Public Property | DesiredTripTime |
Public Property | DesiredTripTime_rate |
Public Property | FuelConsumption_rate |
Public Property | FuelConsumptionTotal |
Public Property | FuelEconomy |
Public Property | Hydrocarbons_rate |
Public Property | HydrocarbonsTotal |
Public Property | IdlingTimeAvg |
Public Property | IdlingTimeAvgerage_pct |
Public Property | IdlingTimeAvgerage_rate |
Public Property | LevelOfService |
Public Property | Max_dx_percent |
Public Property | Max_dx_percent_prev |
Public Property | Max_dx_percent_prev2 |
Public Property | Min_dx_percent |
Public Property | Nox_rate |
Public Property | NoxTotal |
Public Property | NwModel_vari_index |
Public Property | OperatingCost_rate |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | Practical_spare_capacity |
Public Property | ProportionQueued |
Public Property | QueueStorageRatioAverage |
Public Property | QueueStorageRatioMaximum |
Public Property | RunningTimeAvg |
Public Property | RunningTimeAvgerage_pct |
Public Property | RunningTimeAvgerage_rate |
Public Property | SpeedEfficiency |
Public Property | StopRate |
Public Property | StopRate_rate |
Public Property | StopsTotal |
Public Property | TravelDelay |
Public Property | TravelDelay_pct |
Public Property | TravelDelay_rate |
Public Property | TravelDelayAverage |
Public Property | TravelDelayAverage_rate |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeAverage_rate |
Public Property | TravelTimeIndex |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkVehicle Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : SIAPIOutputNetworkVehicle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputNetworkVehicle()
C#
public SIAPIOutputNetworkVehicle()
Managed Extensions for C++
public: SIAPIOutputNetworkVehicle();
C++/CLI
public:
SIAPIOutputNetworkVehicle();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputNetworkVehicle Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputNetworkVehicle Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputNetworkVehicle members.

Public Properties

 | Name | Description
Public Property | ArrivalFlow_HV_pct |
Public Property | ArrivalFlowTotal |
Public Property | Capacity_effective |
Public Property | CarbonDioxide_rate |
Public Property | CarbonDioxideTotal |
Public Property | CarbonMonoxide_rate |
Public Property | CarbonMonoxideTotal |
Public Property | CongestionCoefficient |
Public Property | DegreeSaturation |
Public Property | DelayControlAverage |
Public Property | DelayControlAverageWorstLane |
Public Property | DelayControlAverageWorstMovement |
Public Property | DelayControlTotal |
Public Property | DelayGeometricAverage |
Public Property | DelayStoplineAverage |
Public Property | DemandFlow_HV_pct |
Public Property | DemandFlowTotal |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod |
Public Property | DesiredTripTime |
Public Property | DesiredTripTime_rate |
Public Property | FuelConsumption_rate |
Public Property | FuelConsumptionTotal |
Public Property | FuelEconomy |
Public Property | Hydrocarbons_rate |
Public Property | HydrocarbonsTotal |
Public Property | IdlingTimeAvg |
Public Property | IdlingTimeAvgerage_pct |
Public Property | IdlingTimeAvgerage_rate |
Public Property | LevelOfService |
Public Property | Max_dx_percent |
Public Property | Max_dx_percent_prev |
Public Property | Max_dx_percent_prev2 |
Public Property | Min_dx_percent |
Public Property | Nox_rate |
Public Property | NoxTotal |
Public Property | NwModel_vari_index |
Public Property | OperatingCost_rate |
Public Property | OperatingCostTotal |
Public Property | PerformanceIndex |
Public Property | Practical_spare_capacity |
Public Property | ProportionQueued |
Public Property | QueueStorageRatioAverage |
Public Property | QueueStorageRatioMaximum |
Public Property | RunningTimeAvg |
Public Property | RunningTimeAvgerage_pct |
Public Property | RunningTimeAvgerage_rate |
Public Property | SpeedEfficiency |
Public Property | StopRate |
Public Property | StopRate_rate |
Public Property | StopsTotal |
Public Property | TravelDelay |
Public Property | TravelDelay_pct |
Public Property | TravelDelay_rate |
Public Property | TravelDelayAverage |
Public Property | TravelDelayAverage_rate |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeAverage_rate |
Public Property | TravelTimeIndex |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : ArrivalFlow_HV_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrivalFlow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ArrivalFlow_HV_pct
C#
public float ArrivalFlow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_ArrivalFlow_HV_pct();
C++/CLI
public:
property float ArrivalFlow_HV_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ArrivalFlowTotal
C#
public float ArrivalFlowTotal {get;}
Managed Extensions for C++
public: __property float get_ArrivalFlowTotal();
C++/CLI
public:
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Capacity_effective
C#
public float Capacity_effective {get;}
Managed Extensions for C++
public: __property float get_Capacity_effective();
C++/CLI
public:
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonDioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : CarbonDioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CarbonDioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonDioxide_rate
C#
public float CarbonDioxide_rate {get;}
Managed Extensions for C++
public: __property float get_CarbonDioxide_rate();
C++/CLI
public:
property float CarbonDioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonDioxideTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : CarbonDioxideTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CarbonDioxideTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonDioxideTotal
C#
public float CarbonDioxideTotal {get;}
Managed Extensions for C++
public: __property float get_CarbonDioxideTotal();
C++/CLI
public:
property float CarbonDioxideTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonMonoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : CarbonMonoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CarbonMonoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonMonoxide_rate
C#
public float CarbonMonoxide_rate {get;}
Managed Extensions for C++
public: __property float get_CarbonMonoxide_rate();
C++/CLI
public:
property float CarbonMonoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonMonoxideTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : CarbonMonoxideTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CarbonMonoxideTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonMonoxideTotal
C#
public float CarbonMonoxideTotal {get;}
Managed Extensions for C++
public: __property float get_CarbonMonoxideTotal();
C++/CLI
public:
property float CarbonMonoxideTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CongestionCoefficient Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : CongestionCoefficient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CongestionCoefficient As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CongestionCoefficient
C#
public float CongestionCoefficient {get;}
Managed Extensions for C++
public: __property float get_CongestionCoefficient();
C++/CLI
public:
property float CongestionCoefficient {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DegreeSaturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DegreeSaturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DegreeSaturation As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DegreeSaturation
C#
public float DegreeSaturation {get;}
Managed Extensions for C++
public: __property float get_DegreeSaturation();
C++/CLI
public:
property float DegreeSaturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverage
C#
public float DelayControlAverage {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverage();
C++/CLI
public:
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayControlAverageWorstLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverageWorstLane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverageWorstLane
C#
public float DelayControlAverageWorstLane {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverageWorstLane();
C++/CLI
public:
property float DelayControlAverageWorstLane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
public float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
public: __property float get_DelayControlAverageWorstMovement();
C++/CLI
public:
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlTotal
C#
public float DelayControlTotal {get;}
Managed Extensions for C++
public: __property float get_DelayControlTotal();
C++/CLI
public:
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayGeometricAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayGeometricAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayGeometricAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayGeometricAverage
C#
public float DelayGeometricAverage {get;}
Managed Extensions for C++
public: __property float get_DelayGeometricAverage();
C++/CLI
public:
property float DelayGeometricAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayStoplineAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DelayStoplineAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DelayStoplineAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayStoplineAverage
C#
public float DelayStoplineAverage {get;}
Managed Extensions for C++
public: __property float get_DelayStoplineAverage();
C++/CLI
public:
property float DelayStoplineAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DemandFlow_HV_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DemandFlow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DemandFlow_HV_pct
C#
public float DemandFlow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_DemandFlow_HV_pct();
C++/CLI
public:
property float DemandFlow_HV_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DemandFlowTotal
C#
public float DemandFlowTotal {get;}
Managed Extensions for C++
public: __property float get_DemandFlowTotal();
C++/CLI
public:
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredSpeed
C#
public float DesiredSpeed {get;}
Managed Extensions for C++
public: __property float get_DesiredSpeed();
C++/CLI
public:
property float DesiredSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
public int DesiredSpeedMethod {get;}
Managed Extensions for C++
public: __property int get_DesiredSpeedMethod();
C++/CLI
public:
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredTripTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DesiredTripTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredTripTime As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredTripTime
C#
public float DesiredTripTime {get;}
Managed Extensions for C++
public: __property float get_DesiredTripTime();
C++/CLI
public:
property float DesiredTripTime {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredTripTime_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : DesiredTripTime_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredTripTime_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredTripTime_rate
C#
public float DesiredTripTime_rate {get;}
Managed Extensions for C++
public: __property float get_DesiredTripTime_rate();
C++/CLI
public:
property float DesiredTripTime_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelConsumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : FuelConsumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FuelConsumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelConsumption_rate
C#
public float FuelConsumption_rate {get;}
Managed Extensions for C++
public: __property float get_FuelConsumption_rate();
C++/CLI
public:
property float FuelConsumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelConsumptionTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : FuelConsumptionTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FuelConsumptionTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelConsumptionTotal
C#
public float FuelConsumptionTotal {get;}
Managed Extensions for C++
public: __property float get_FuelConsumptionTotal();
C++/CLI
public:
property float FuelConsumptionTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelEconomy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : FuelEconomy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FuelEconomy As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelEconomy
C#
public float FuelEconomy {get;}
Managed Extensions for C++
public: __property float get_FuelEconomy();
C++/CLI
public:
property float FuelEconomy {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Hydrocarbons_rate
C#
public float Hydrocarbons_rate {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_rate();
C++/CLI
public:
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HydrocarbonsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : HydrocarbonsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HydrocarbonsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.HydrocarbonsTotal
C#
public float HydrocarbonsTotal {get;}
Managed Extensions for C++
public: __property float get_HydrocarbonsTotal();
C++/CLI
public:
property float HydrocarbonsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : IdlingTimeAvg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IdlingTimeAvg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvg
C#
public float IdlingTimeAvg {get;}
Managed Extensions for C++
public: __property float get_IdlingTimeAvg();
C++/CLI
public:
property float IdlingTimeAvg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvgerage_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : IdlingTimeAvgerage_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IdlingTimeAvgerage_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvgerage_pct
C#
public float IdlingTimeAvgerage_pct {get;}
Managed Extensions for C++
public: __property float get_IdlingTimeAvgerage_pct();
C++/CLI
public:
property float IdlingTimeAvgerage_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvgerage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : IdlingTimeAvgerage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IdlingTimeAvgerage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvgerage_rate
C#
public float IdlingTimeAvgerage_rate {get;}
Managed Extensions for C++
public: __property float get_IdlingTimeAvgerage_rate();
C++/CLI
public:
property float IdlingTimeAvgerage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LevelOfService Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : LevelOfService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LevelOfService As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As String

value = instance.LevelOfService
C#
public string LevelOfService {get;}
Managed Extensions for C++
public: __property string* get_LevelOfService();
C++/CLI
public:
property String^ LevelOfService {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Max_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent
C#
public float Max_dx_percent {get;}
Managed Extensions for C++
public: __property float get_Max_dx_percent();
C++/CLI
public:
property float Max_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Max_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent_prev
C#
public float Max_dx_percent_prev {get;}
Managed Extensions for C++
public: __property float get_Max_dx_percent_prev();
C++/CLI
public:
property float Max_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Max_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent_prev2
C#
public float Max_dx_percent_prev2 {get;}
Managed Extensions for C++
public: __property float get_Max_dx_percent_prev2();
C++/CLI
public:
property float Max_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Min_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Min_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Min_dx_percent
C#
public float Min_dx_percent {get;}
Managed Extensions for C++
public: __property float get_Min_dx_percent();
C++/CLI
public:
property float Min_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Nox_rate
C#
public float Nox_rate {get;}
Managed Extensions for C++
public: __property float get_Nox_rate();
C++/CLI
public:
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NoxTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : NoxTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NoxTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.NoxTotal
C#
public float NoxTotal {get;}
Managed Extensions for C++
public: __property float get_NoxTotal();
C++/CLI
public:
property float NoxTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwModel_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : NwModel_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NwModel_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.NwModel_vari_index
C#
public float NwModel_vari_index {get;}
Managed Extensions for C++
public: __property float get_NwModel_vari_index();
C++/CLI
public:
property float NwModel_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : OperatingCost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperatingCost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.OperatingCost_rate
C#
public float OperatingCost_rate {get;}
Managed Extensions for C++
public: __property float get_OperatingCost_rate();
C++/CLI
public:
property float OperatingCost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.OperatingCostTotal
C#
public float OperatingCostTotal {get;}
Managed Extensions for C++
public: __property float get_OperatingCostTotal();
C++/CLI
public:
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.PerformanceIndex
C#
public float PerformanceIndex {get;}
Managed Extensions for C++
public: __property float get_PerformanceIndex();
C++/CLI
public:
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ProportionQueued
C#
public float ProportionQueued {get;}
Managed Extensions for C++
public: __property float get_ProportionQueued();
C++/CLI
public:
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
QueueStorageRatioAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : QueueStorageRatioAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueueStorageRatioAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.QueueStorageRatioAverage
C#
public float QueueStorageRatioAverage {get;}
Managed Extensions for C++
public: __property float get_QueueStorageRatioAverage();
C++/CLI
public:
property float QueueStorageRatioAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
QueueStorageRatioMaximum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : QueueStorageRatioMaximum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property QueueStorageRatioMaximum As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.QueueStorageRatioMaximum
C#
public float QueueStorageRatioMaximum {get;}
Managed Extensions for C++
public: __property float get_QueueStorageRatioMaximum();
C++/CLI
public:
property float QueueStorageRatioMaximum {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : RunningTimeAvg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RunningTimeAvg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvg
C#
public float RunningTimeAvg {get;}
Managed Extensions for C++
public: __property float get_RunningTimeAvg();
C++/CLI
public:
property float RunningTimeAvg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvgerage_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : RunningTimeAvgerage_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RunningTimeAvgerage_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvgerage_pct
C#
public float RunningTimeAvgerage_pct {get;}
Managed Extensions for C++
public: __property float get_RunningTimeAvgerage_pct();
C++/CLI
public:
property float RunningTimeAvgerage_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvgerage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : RunningTimeAvgerage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RunningTimeAvgerage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvgerage_rate
C#
public float RunningTimeAvgerage_rate {get;}
Managed Extensions for C++
public: __property float get_RunningTimeAvgerage_rate();
C++/CLI
public:
property float RunningTimeAvgerage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopRate
C#
public float StopRate {get;}
Managed Extensions for C++
public: __property float get_StopRate();
C++/CLI
public:
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : StopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopRate_rate
C#
public float StopRate_rate {get;}
Managed Extensions for C++
public: __property float get_StopRate_rate();
C++/CLI
public:
property float StopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopsTotal
C#
public float StopsTotal {get;}
Managed Extensions for C++
public: __property float get_StopsTotal();
C++/CLI
public:
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelay As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay
C#
public float TravelDelay {get;}
Managed Extensions for C++
public: __property float get_TravelDelay();
C++/CLI
public:
property float TravelDelay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDelay_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelay_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay_pct
C#
public float TravelDelay_pct {get;}
Managed Extensions for C++
public: __property float get_TravelDelay_pct();
C++/CLI
public:
property float TravelDelay_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDelay_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelay_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay_rate
C#
public float TravelDelay_rate {get;}
Managed Extensions for C++
public: __property float get_TravelDelay_rate();
C++/CLI
public:
property float TravelDelay_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelayAverage
C#
public float TravelDelayAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage();
C++/CLI
public:
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDelayAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelayAverage_rate
C#
public float TravelDelayAverage_rate {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage_rate();
C++/CLI
public:
property float TravelDelayAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDistanceAverage
C#
public float TravelDistanceAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceAverage();
C++/CLI
public:
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDistanceTotal
C#
public float TravelDistanceTotal {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceTotal();
C++/CLI
public:
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelSpeed
C#
public float TravelSpeed {get;}
Managed Extensions for C++
public: __property float get_TravelSpeed();
C++/CLI
public:
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeAverage
C#
public float TravelTimeAverage {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage();
C++/CLI
public:
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelTimeAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeAverage_rate
C#
public float TravelTimeAverage_rate {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage_rate();
C++/CLI
public:
property float TravelTimeAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelTimeIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeIndex
C#
public float TravelTimeIndex {get;}
Managed Extensions for C++
public: __property float get_TravelTimeIndex();
C++/CLI
public:
property float TravelTimeIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputNetworkVehicle Class : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeTotal
C#
public float TravelTimeTotal {get;}
Managed Extensions for C++
public: __property float get_TravelTimeTotal();
C++/CLI
public:
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputNetworkVehicle Class
SIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhase Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhase Class

Glossary Item Box

Object Model

SIAPIOutputPhase Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhase
   Implements ISIAPIOutputPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
C#
public sealed class SIAPIOutputPhase : ISIAPIOutputPhase
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhase : public ISIAPIOutputPhase
C++/CLI
public ref class SIAPIOutputPhase sealed : public ISIAPIOutputPhase

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhase Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhase Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhase.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhase Constructor |
Top

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | Change_time |
Public Property | Critical_dummy_mov_flag |
Public Property | Displayed_green_time |
Public Property | Dummy_adj_flow_ratio |
Public Property | Dummy_adj_lost_time |
Public Property | Dummy_eff_green |
Public Property | Dummy_lost_time |
Public Property | Dummy_min_max_flag |
Public Property | Dummy_reqd_green_time_ratio |
Public Property | Dummy_reqd_time |
Public Property | Dummy_tmax |
Public Property | Dummy_tmin |
Public Property | Green_end |
Public Property | Green_start |
Public Property | Has_dummy |
Public Property | IsReferencePhase |
Public Property | Offset_change_time |
Public Property | Phase_split_percent |
Public Property | Phase_time |
Public Property | Position |
Public Property | Start_intergreen |
Public Property | Terminating_intergreen |
Public Property | Yellow_time |
Top

See Also

Reference

SIAPIOutputPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhase Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : SIAPIOutputPhase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhase()
C#
public SIAPIOutputPhase()
Managed Extensions for C++
public: SIAPIOutputPhase();
C++/CLI
public:
SIAPIOutputPhase();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhase Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhase Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhase members.

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | Change_time |
Public Property | Critical_dummy_mov_flag |
Public Property | Displayed_green_time |
Public Property | Dummy_adj_flow_ratio |
Public Property | Dummy_adj_lost_time |
Public Property | Dummy_eff_green |
Public Property | Dummy_lost_time |
Public Property | Dummy_min_max_flag |
Public Property | Dummy_reqd_green_time_ratio |
Public Property | Dummy_reqd_time |
Public Property | Dummy_tmax |
Public Property | Dummy_tmin |
Public Property | Green_end |
Public Property | Green_start |
Public Property | Has_dummy |
Public Property | IsReferencePhase |
Public Property | Offset_change_time |
Public Property | Phase_split_percent |
Public Property | Phase_time |
Public Property | Position |
Public Property | Start_intergreen |
Public Property | Terminating_intergreen |
Public Property | Yellow_time |
Top

See Also

Reference

SIAPIOutputPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.All_red_time
C#
public int All_red_time {get;}
Managed Extensions for C++
public: __property int get_All_red_time();
C++/CLI
public:
property int All_red_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Change_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Change_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Change_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Change_time
C#
public int Change_time {get;}
Managed Extensions for C++
public: __property int get_Change_time();
C++/CLI
public:
property int Change_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_dummy_mov_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Critical_dummy_mov_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_dummy_mov_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Critical_dummy_mov_flag
C#
public int Critical_dummy_mov_flag {get;}
Managed Extensions for C++
public: __property int get_Critical_dummy_mov_flag();
C++/CLI
public:
property int Critical_dummy_mov_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Displayed_green_time
C#
public int Displayed_green_time {get;}
Managed Extensions for C++
public: __property int get_Displayed_green_time();
C++/CLI
public:
property int Displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_adj_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_adj_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_adj_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_adj_flow_ratio
C#
public float Dummy_adj_flow_ratio {get;}
Managed Extensions for C++
public: __property float get_Dummy_adj_flow_ratio();
C++/CLI
public:
property float Dummy_adj_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_adj_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_adj_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_adj_lost_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_adj_lost_time
C#
public float Dummy_adj_lost_time {get;}
Managed Extensions for C++
public: __property float get_Dummy_adj_lost_time();
C++/CLI
public:
property float Dummy_adj_lost_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_eff_green
C#
public int Dummy_eff_green {get;}
Managed Extensions for C++
public: __property int get_Dummy_eff_green();
C++/CLI
public:
property int Dummy_eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_lost_time
C#
public int Dummy_lost_time {get;}
Managed Extensions for C++
public: __property int get_Dummy_lost_time();
C++/CLI
public:
property int Dummy_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_min_max_flag
C#
public int Dummy_min_max_flag {get;}
Managed Extensions for C++
public: __property int get_Dummy_min_max_flag();
C++/CLI
public:
property int Dummy_min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_reqd_green_time_ratio
C#
public float Dummy_reqd_green_time_ratio {get;}
Managed Extensions for C++
public: __property float get_Dummy_reqd_green_time_ratio();
C++/CLI
public:
property float Dummy_reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_reqd_time
C#
public float Dummy_reqd_time {get;}
Managed Extensions for C++
public: __property float get_Dummy_reqd_time();
C++/CLI
public:
property float Dummy_reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_tmax
C#
public float Dummy_tmax {get;}
Managed Extensions for C++
public: __property float get_Dummy_tmax();
C++/CLI
public:
property float Dummy_tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Dummy_tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Dummy_tmin
C#
public float Dummy_tmin {get;}
Managed Extensions for C++
public: __property float get_Dummy_tmin();
C++/CLI
public:
property float Dummy_tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_end Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Green_end Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_end As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Green_end
C#
public int Green_end {get;}
Managed Extensions for C++
public: __property int get_Green_end();
C++/CLI
public:
property int Green_end {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_start Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Green_start Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_start As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Green_start
C#
public int Green_start {get;}
Managed Extensions for C++
public: __property int get_Green_start();
C++/CLI
public:
property int Green_start {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Boolean

value = instance.Has_dummy
C#
public bool Has_dummy {get;}
Managed Extensions for C++
public: __property bool get_Has_dummy();
C++/CLI
public:
property bool Has_dummy {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Boolean

value = instance.IsReferencePhase
C#
public bool IsReferencePhase {get;}
Managed Extensions for C++
public: __property bool get_IsReferencePhase();
C++/CLI
public:
property bool IsReferencePhase {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset_change_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Offset_change_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Offset_change_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Offset_change_time
C#
public int Offset_change_time {get;}
Managed Extensions for C++
public: __property int get_Offset_change_time();
C++/CLI
public:
property int Offset_change_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_split_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Phase_split_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phase_split_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Single

value = instance.Phase_split_percent
C#
public float Phase_split_percent {get;}
Managed Extensions for C++
public: __property float get_Phase_split_percent();
C++/CLI
public:
property float Phase_split_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Phase_time
C#
public int Phase_time {get;}
Managed Extensions for C++
public: __property int get_Phase_time();
C++/CLI
public:
property int Phase_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_intergreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Start_intergreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Start_intergreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Start_intergreen
C#
public int Start_intergreen {get;}
Managed Extensions for C++
public: __property int get_Start_intergreen();
C++/CLI
public:
property int Start_intergreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminating_intergreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Terminating_intergreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Terminating_intergreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Terminating_intergreen
C#
public int Terminating_intergreen {get;}
Managed Extensions for C++
public: __property int get_Terminating_intergreen();
C++/CLI
public:
property int Terminating_intergreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhase Class : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhase
Dim value As Integer

value = instance.Yellow_time
C#
public int Yellow_time {get;}
Managed Extensions for C++
public: __property int get_Yellow_time();
C++/CLI
public:
property int Yellow_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhase Class
SIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPath Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPath Class

Glossary Item Box

Object Model

SIAPIOutputPhaseMovTimingPath ClassISIAPIOutputPhaseMovTimingPathMovements InterfaceISIAPIOutputPhaseMovTimingPathMovement InterfaceISIAPIOutputset Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhaseMovTimingPath
   Implements ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPath
C#
public sealed class SIAPIOutputPhaseMovTimingPath : ISIAPIOutputPhaseMovTimingPath
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhaseMovTimingPath : public ISIAPIOutputPhaseMovTimingPath
C++/CLI
public ref class SIAPIOutputPhaseMovTimingPath sealed : public ISIAPIOutputPhaseMovTimingPath

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPath

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPath Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPath Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPath Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhaseMovTimingPath.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhaseMovTimingPath Constructor |
Top

Public Properties

 | Name | Description
Public Property | OutputPhaseMovTimingPathMovements |
Public Property | Outputset |
Public Property | Position |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPath Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPath Class : SIAPIOutputPhaseMovTimingPath Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhaseMovTimingPath()
C#
public SIAPIOutputPhaseMovTimingPath()
Managed Extensions for C++
public: SIAPIOutputPhaseMovTimingPath();
C++/CLI
public:
SIAPIOutputPhaseMovTimingPath();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPath Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPath Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPath members.

Public Properties

 | Name | Description
Public Property | OutputPhaseMovTimingPathMovements |
Public Property | Outputset |
Public Property | Position |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPathMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPath Class : OutputPhaseMovTimingPathMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputPhaseMovTimingPathMovements As ISIAPIOutputPhaseMovTimingPathMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPath
Dim value As ISIAPIOutputPhaseMovTimingPathMovements

value = instance.OutputPhaseMovTimingPathMovements
C#
public ISIAPIOutputPhaseMovTimingPathMovements OutputPhaseMovTimingPathMovements {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhaseMovTimingPathMovements* get_OutputPhaseMovTimingPathMovements();
C++/CLI
public:
property ISIAPIOutputPhaseMovTimingPathMovements^ OutputPhaseMovTimingPathMovements {
   ISIAPIOutputPhaseMovTimingPathMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Outputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPath Class : Outputset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPath
Dim value As ISIAPIOutputset

value = instance.Outputset
C#
public ISIAPIOutputset Outputset {get;}
Managed Extensions for C++
public: __property ISIAPIOutputset* get_Outputset();
C++/CLI
public:
property ISIAPIOutputset^ Outputset {
   ISIAPIOutputset^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPath Class : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPath
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPath Class
SIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovement Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovement Class

Glossary Item Box

Object Model

SIAPIOutputPhaseMovTimingPathMovement ClassISIAPIOutputPhaseMovTimingPath Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhaseMovTimingPathMovement
   Implements ISIAPIOutputPhaseMovTimingPathMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
C#
public sealed class SIAPIOutputPhaseMovTimingPathMovement : ISIAPIOutputPhaseMovTimingPathMovement
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhaseMovTimingPathMovement : public ISIAPIOutputPhaseMovTimingPathMovement
C++/CLI
public ref class SIAPIOutputPhaseMovTimingPathMovement sealed : public ISIAPIOutputPhaseMovTimingPathMovement

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPathMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovement Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovement Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhaseMovTimingPathMovement.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhaseMovTimingPathMovement Constructor |
Top

Public Properties

 | Name | Description
Public Property | Critical_mov | Flag indicating this Movement is a critical movement or not.
Public Property | Destination |
Public Property | Dummy_phase_original_position |
Public Property | Eff_green |
Public Property | End_phase | The position / index of the Phase that this Movement finishes at.
Public Property | Green_time |
Public Property | Greenperiod |
Public Property | MaxGreenPeriod |
Public Property | MC_class |
Public Property | Mov_type | Movement Type
Public Property | MovementDisplayID |
Public Property | Origin |
Public Property | OutputPhaseMovTimingPath |
Public Property | Ped_stage |
Public Property | Ped_type |
Public Property | Position | The index of this Movement in the Timing Path. It is a zero-base integer.
Public Property | Reqd_time |
Public Property | SiteDisplayID |
Public Property | Start_phase | The position / index of the Phase that this Movement starts from
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovement Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : SIAPIOutputPhaseMovTimingPathMovement Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhaseMovTimingPathMovement()
C#
public SIAPIOutputPhaseMovTimingPathMovement()
Managed Extensions for C++
public: SIAPIOutputPhaseMovTimingPathMovement();
C++/CLI
public:
SIAPIOutputPhaseMovTimingPathMovement();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovement Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovement Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPathMovement members.

Public Properties

 | Name | Description
Public Property | Critical_mov | Flag indicating this Movement is a critical movement or not.
Public Property | Destination |
Public Property | Dummy_phase_original_position |
Public Property | Eff_green |
Public Property | End_phase | The position / index of the Phase that this Movement finishes at.
Public Property | Green_time |
Public Property | Greenperiod |
Public Property | MaxGreenPeriod |
Public Property | MC_class |
Public Property | Mov_type | Movement Type
Public Property | MovementDisplayID |
Public Property | Origin |
Public Property | OutputPhaseMovTimingPath |
Public Property | Ped_stage |
Public Property | Ped_type |
Public Property | Position | The index of this Movement in the Timing Path. It is a zero-base integer.
Public Property | Reqd_time |
Public Property | SiteDisplayID |
Public Property | Start_phase | The position / index of the Phase that this Movement starts from
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Critical_mov Property

Glossary Item Box

Flag indicating this Movement is a critical movement or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Boolean

value = instance.Critical_mov
C#
public bool Critical_mov {get;}
Managed Extensions for C++
public: __property bool get_Critical_mov();
C++/CLI
public:
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_phase_original_position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Dummy_phase_original_position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Dummy_phase_original_position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Dummy_phase_original_position
C#
public int Dummy_phase_original_position {get;}
Managed Extensions for C++
public: __property int get_Dummy_phase_original_position();
C++/CLI
public:
property int Dummy_phase_original_position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Eff_green
C#
public int Eff_green {get;}
Managed Extensions for C++
public: __property int get_Eff_green();
C++/CLI
public:
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : End_phase Property

Glossary Item Box

The position / index of the Phase that this Movement finishes at.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.End_phase
C#
public int End_phase {get;}
Managed Extensions for C++
public: __property int get_End_phase();
C++/CLI
public:
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Green_time
C#
public int Green_time {get;}
Managed Extensions for C++
public: __property int get_Green_time();
C++/CLI
public:
property int Green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Greenperiod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Greenperiod
C#
public int Greenperiod {get;}
Managed Extensions for C++
public: __property int get_Greenperiod();
C++/CLI
public:
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MaxGreenPeriod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : MaxGreenPeriod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxGreenPeriod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.MaxGreenPeriod
C#
public int MaxGreenPeriod {get;}
Managed Extensions for C++
public: __property int get_MaxGreenPeriod();
C++/CLI
public:
property int MaxGreenPeriod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mov_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Mov_type Property

Glossary Item Box

Movement Type

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Mov_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Mov_type
C#
public int Mov_type {get;}
Managed Extensions for C++
public: __property int get_Mov_type();
C++/CLI
public:
property int Mov_type {
   int get();
}

Property Value

Type: System.Int32;

1 = Vehicle OD Movement,
2 = Pedestrian Movement,
3 = Dummy Movement in a Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementDisplayID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : MovementDisplayID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementDisplayID As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As String

value = instance.MovementDisplayID
C#
public string MovementDisplayID {get;}
Managed Extensions for C++
public: __property string* get_MovementDisplayID();
C++/CLI
public:
property String^ MovementDisplayID {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPath Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : OutputPhaseMovTimingPath Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputPhaseMovTimingPath As ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As ISIAPIOutputPhaseMovTimingPath

value = instance.OutputPhaseMovTimingPath
C#
public ISIAPIOutputPhaseMovTimingPath OutputPhaseMovTimingPath {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhaseMovTimingPath* get_OutputPhaseMovTimingPath();
C++/CLI
public:
property ISIAPIOutputPhaseMovTimingPath^ OutputPhaseMovTimingPath {
   ISIAPIOutputPhaseMovTimingPath^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Ped_stage
C#
public int Ped_stage {get;}
Managed Extensions for C++
public: __property int get_Ped_stage();
C++/CLI
public:
property int Ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Ped_type
C#
public int Ped_type {get;}
Managed Extensions for C++
public: __property int get_Ped_type();
C++/CLI
public:
property int Ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Position Property

Glossary Item Box

The index of this Movement in the Timing Path. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Single

value = instance.Reqd_time
C#
public float Reqd_time {get;}
Managed Extensions for C++
public: __property float get_Reqd_time();
C++/CLI
public:
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteDisplayID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : SiteDisplayID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteDisplayID As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As String

value = instance.SiteDisplayID
C#
public string SiteDisplayID {get;}
Managed Extensions for C++
public: __property string* get_SiteDisplayID();
C++/CLI
public:
property String^ SiteDisplayID {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovement Class : Start_phase Property

Glossary Item Box

The position / index of the Phase that this Movement starts from

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Start_phase
C#
public int Start_phase {get;}
Managed Extensions for C++
public: __property int get_Start_phase();
C++/CLI
public:
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovement Class
SIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovements Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovements Class

Glossary Item Box

Object Model

SIAPIOutputPhaseMovTimingPathMovements ClassISIAPIOutputPhaseMovTimingPathMovement Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhaseMovTimingPathMovements
   Implements ISIAPIOutputPhaseMovTimingPathMovements
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovements
C#
public sealed class SIAPIOutputPhaseMovTimingPathMovements : ISIAPIOutputPhaseMovTimingPathMovements
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhaseMovTimingPathMovements : public ISIAPIOutputPhaseMovTimingPathMovements
C++/CLI
public ref class SIAPIOutputPhaseMovTimingPathMovements sealed : public ISIAPIOutputPhaseMovTimingPathMovements

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPathMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovements Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovements Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhaseMovTimingPathMovements.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhaseMovTimingPathMovements Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovements Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovements Class : SIAPIOutputPhaseMovTimingPathMovements Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhaseMovTimingPathMovements()
C#
public SIAPIOutputPhaseMovTimingPathMovements()
Managed Extensions for C++
public: SIAPIOutputPhaseMovTimingPathMovements();
C++/CLI
public:
SIAPIOutputPhaseMovTimingPathMovements();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovements Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPathMovements members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovements Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovements
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPathMovements Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPathMovements Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPathMovements members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovements Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovements
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPathMovements Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhaseMovTimingPathMovement
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPathMovements
Dim index As Integer
Dim value As ISIAPIOutputPhaseMovTimingPathMovement

value = instance.Item(index)
C#
public ISIAPIOutputPhaseMovTimingPathMovement this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhaseMovTimingPathMovement* get_Item   int index
;
C++/CLI
public:
property ISIAPIOutputPhaseMovTimingPathMovement^ default [int] {
   ISIAPIOutputPhaseMovTimingPathMovement^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPathMovements Class
SIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPaths Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPaths Class

Glossary Item Box

Object Model

SIAPIOutputPhaseMovTimingPaths ClassISIAPIOutputPhaseMovTimingPath Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhaseMovTimingPaths
   Implements ISIAPIOutputPhaseMovTimingPaths
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPaths
C#
public sealed class SIAPIOutputPhaseMovTimingPaths : ISIAPIOutputPhaseMovTimingPaths
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhaseMovTimingPaths : public ISIAPIOutputPhaseMovTimingPaths
C++/CLI
public ref class SIAPIOutputPhaseMovTimingPaths sealed : public ISIAPIOutputPhaseMovTimingPaths

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhaseMovTimingPaths

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPaths Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPaths Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhaseMovTimingPaths.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhaseMovTimingPaths Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPaths Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPaths Class : SIAPIOutputPhaseMovTimingPaths Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhaseMovTimingPaths()
C#
public SIAPIOutputPhaseMovTimingPaths()
Managed Extensions for C++
public: SIAPIOutputPhaseMovTimingPaths();
C++/CLI
public:
SIAPIOutputPhaseMovTimingPaths();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPaths Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPaths Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPaths members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPaths Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPaths
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhaseMovTimingPaths Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhaseMovTimingPaths Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhaseMovTimingPaths members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPaths Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPaths
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhaseMovTimingPaths Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhaseMovTimingPaths
Dim index As Integer
Dim value As ISIAPIOutputPhaseMovTimingPath

value = instance.Item(index)
C#
public ISIAPIOutputPhaseMovTimingPath this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhaseMovTimingPath* get_Item   int index
;
C++/CLI
public:
property ISIAPIOutputPhaseMovTimingPath^ default [int] {
   ISIAPIOutputPhaseMovTimingPath^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhaseMovTimingPaths Class
SIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhases Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhases Class

Glossary Item Box

Object Model

SIAPIOutputPhases ClassISIAPIOutputPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputPhases
   Implements ISIAPIOutputPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhases
C#
public sealed class SIAPIOutputPhases : ISIAPIOutputPhases
Managed Extensions for C++
public __gc __sealed class SIAPIOutputPhases : public ISIAPIOutputPhases
C++/CLI
public ref class SIAPIOutputPhases sealed : public ISIAPIOutputPhases

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhases Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhases Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputPhases.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputPhases Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhases Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhases Class : SIAPIOutputPhases Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputPhases()
C#
public SIAPIOutputPhases()
Managed Extensions for C++
public: SIAPIOutputPhases();
C++/CLI
public:
SIAPIOutputPhases();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhases Class
SIAPIOutputPhases Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhases Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhases members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhases Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhases
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhases Class
SIAPIOutputPhases Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputPhases Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputPhases members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item |
Top

See Also

Reference

SIAPIOutputPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhases Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhases
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhases Class
SIAPIOutputPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputPhases Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputPhases
Dim index As Integer
Dim value As ISIAPIOutputPhase

value = instance.Item(index)
C#
public ISIAPIOutputPhase this[
   int index
]; {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhase* get_Item   int index
;
C++/CLI
public:
property ISIAPIOutputPhase^ default [int] {
   ISIAPIOutputPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputPhases Class
SIAPIOutputPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedPerson Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedPerson Class

Glossary Item Box

Object Model

SIAPIOutputRouteMovementBasedPerson Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputRouteMovementBasedPerson
   Implements ISIAPIOutputRouteMovementBasedPerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
C#
public sealed class SIAPIOutputRouteMovementBasedPerson : ISIAPIOutputRouteMovementBasedPerson
Managed Extensions for C++
public __gc __sealed class SIAPIOutputRouteMovementBasedPerson : public ISIAPIOutputRouteMovementBasedPerson
C++/CLI
public ref class SIAPIOutputRouteMovementBasedPerson sealed : public ISIAPIOutputRouteMovementBasedPerson

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputRouteMovementBasedPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedPerson Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedPerson Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputRouteMovementBasedPerson.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputRouteMovementBasedPerson Constructor |
Top

Public Properties

 | Name | Description
Public Property | DesiredSpeedMethod |
Public Property | RouteStopRate |
Public Property | RouteStopRate_rate |
Public Property | TravelDelayAverage |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedPerson Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : SIAPIOutputRouteMovementBasedPerson Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputRouteMovementBasedPerson()
C#
public SIAPIOutputRouteMovementBasedPerson()
Managed Extensions for C++
public: SIAPIOutputRouteMovementBasedPerson();
C++/CLI
public:
SIAPIOutputRouteMovementBasedPerson();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedPerson Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedPerson Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputRouteMovementBasedPerson members.

Public Properties

 | Name | Description
Public Property | DesiredSpeedMethod |
Public Property | RouteStopRate |
Public Property | RouteStopRate_rate |
Public Property | TravelDelayAverage |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
public int DesiredSpeedMethod {get;}
Managed Extensions for C++
public: __property int get_DesiredSpeedMethod();
C++/CLI
public:
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : RouteStopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteStopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.RouteStopRate
C#
public float RouteStopRate {get;}
Managed Extensions for C++
public: __property float get_RouteStopRate();
C++/CLI
public:
property float RouteStopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : RouteStopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteStopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.RouteStopRate_rate
C#
public float RouteStopRate_rate {get;}
Managed Extensions for C++
public: __property float get_RouteStopRate_rate();
C++/CLI
public:
property float RouteStopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDelayAverage
C#
public float TravelDelayAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage();
C++/CLI
public:
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDistanceAverage
C#
public float TravelDistanceAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceAverage();
C++/CLI
public:
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDistanceTotal
C#
public float TravelDistanceTotal {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceTotal();
C++/CLI
public:
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelSpeed
C#
public float TravelSpeed {get;}
Managed Extensions for C++
public: __property float get_TravelSpeed();
C++/CLI
public:
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelTimeAverage
C#
public float TravelTimeAverage {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage();
C++/CLI
public:
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedPerson Class : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelTimeTotal
C#
public float TravelTimeTotal {get;}
Managed Extensions for C++
public: __property float get_TravelTimeTotal();
C++/CLI
public:
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedPerson Class
SIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedVehicle Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedVehicle Class

Glossary Item Box

Object Model

SIAPIOutputRouteMovementBasedVehicle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputRouteMovementBasedVehicle
   Implements ISIAPIOutputRouteMovementBasedVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
C#
public sealed class SIAPIOutputRouteMovementBasedVehicle : ISIAPIOutputRouteMovementBasedVehicle
Managed Extensions for C++
public __gc __sealed class SIAPIOutputRouteMovementBasedVehicle : public ISIAPIOutputRouteMovementBasedVehicle
C++/CLI
public ref class SIAPIOutputRouteMovementBasedVehicle sealed : public ISIAPIOutputRouteMovementBasedVehicle

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputRouteMovementBasedVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedVehicle Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedVehicle Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputRouteMovementBasedVehicle.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputRouteMovementBasedVehicle Constructor |
Top

Public Properties

 | Name | Description
Public Property | CongestionCoefficient |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod |
Public Property | LevelOfService |
Public Property | RouteStopRate |
Public Property | RouteStopRate_rate |
Public Property | SpeedEfficiency |
Public Property | TravelDelayAverage |
Public Property | TravelDelayAverage_rate |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeAverage_rate |
Public Property | TravelTimeIndex |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedVehicle Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : SIAPIOutputRouteMovementBasedVehicle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputRouteMovementBasedVehicle()
C#
public SIAPIOutputRouteMovementBasedVehicle()
Managed Extensions for C++
public: SIAPIOutputRouteMovementBasedVehicle();
C++/CLI
public:
SIAPIOutputRouteMovementBasedVehicle();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputRouteMovementBasedVehicle Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputRouteMovementBasedVehicle Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputRouteMovementBasedVehicle members.

Public Properties

 | Name | Description
Public Property | CongestionCoefficient |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod |
Public Property | LevelOfService |
Public Property | RouteStopRate |
Public Property | RouteStopRate_rate |
Public Property | SpeedEfficiency |
Public Property | TravelDelayAverage |
Public Property | TravelDelayAverage_rate |
Public Property | TravelDistanceAverage |
Public Property | TravelDistanceTotal |
Public Property | TravelSpeed |
Public Property | TravelTimeAverage |
Public Property | TravelTimeAverage_rate |
Public Property | TravelTimeIndex |
Public Property | TravelTimeTotal |
Top

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CongestionCoefficient Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : CongestionCoefficient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CongestionCoefficient As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.CongestionCoefficient
C#
public float CongestionCoefficient {get;}
Managed Extensions for C++
public: __property float get_CongestionCoefficient();
C++/CLI
public:
property float CongestionCoefficient {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.DesiredSpeed
C#
public float DesiredSpeed {get;}
Managed Extensions for C++
public: __property float get_DesiredSpeed();
C++/CLI
public:
property float DesiredSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
public int DesiredSpeedMethod {get;}
Managed Extensions for C++
public: __property int get_DesiredSpeedMethod();
C++/CLI
public:
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LevelOfService Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : LevelOfService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LevelOfService As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Integer

value = instance.LevelOfService
C#
public int LevelOfService {get;}
Managed Extensions for C++
public: __property int get_LevelOfService();
C++/CLI
public:
property int LevelOfService {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : RouteStopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteStopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.RouteStopRate
C#
public float RouteStopRate {get;}
Managed Extensions for C++
public: __property float get_RouteStopRate();
C++/CLI
public:
property float RouteStopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : RouteStopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteStopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.RouteStopRate_rate
C#
public float RouteStopRate_rate {get;}
Managed Extensions for C++
public: __property float get_RouteStopRate_rate();
C++/CLI
public:
property float RouteStopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDelayAverage
C#
public float TravelDelayAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage();
C++/CLI
public:
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelDelayAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDelayAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDelayAverage_rate
C#
public float TravelDelayAverage_rate {get;}
Managed Extensions for C++
public: __property float get_TravelDelayAverage_rate();
C++/CLI
public:
property float TravelDelayAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDistanceAverage
C#
public float TravelDistanceAverage {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceAverage();
C++/CLI
public:
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDistanceTotal
C#
public float TravelDistanceTotal {get;}
Managed Extensions for C++
public: __property float get_TravelDistanceTotal();
C++/CLI
public:
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelSpeed
C#
public float TravelSpeed {get;}
Managed Extensions for C++
public: __property float get_TravelSpeed();
C++/CLI
public:
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeAverage
C#
public float TravelTimeAverage {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage();
C++/CLI
public:
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelTimeAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeAverage_rate
C#
public float TravelTimeAverage_rate {get;}
Managed Extensions for C++
public: __property float get_TravelTimeAverage_rate();
C++/CLI
public:
property float TravelTimeAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelTimeIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeIndex
C#
public float TravelTimeIndex {get;}
Managed Extensions for C++
public: __property float get_TravelTimeIndex();
C++/CLI
public:
property float TravelTimeIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputRouteMovementBasedVehicle Class : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeTotal
C#
public float TravelTimeTotal {get;}
Managed Extensions for C++
public: __property float get_TravelTimeTotal();
C++/CLI
public:
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputRouteMovementBasedVehicle Class
SIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSequence Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSequence Class

Glossary Item Box

Object Model

SIAPIOutputSequence ClassISIAPIOutputPhases InterfaceISIAPIOutputPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSequence
   Implements ISIAPIOutputSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
C#
public sealed class SIAPIOutputSequence : ISIAPIOutputSequence
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSequence : public ISIAPIOutputSequence
C++/CLI
public ref class SIAPIOutputSequence sealed : public ISIAPIOutputSequence

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSequence Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSequence Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSequence.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSequence Constructor |
Top

Public Properties

 | Name | Description
Public Property | Adjusted_flow_ratio_total |
Public Property | Adjusted_lost_time_total |
Public Property | Cmaxsl_flag |
Public Property | Critical_in_network |
Public Property | Cycle_time |
Public Property | Cycle_time_maximum |
Public Property | Cycle_time_maximum_flag |
Public Property | Cycle_time_minimum |
Public Property | Cycle_time_minimum_flag |
Public Property | Cycle_time_option |
Public Property | Cycle_time_option_flag |
Public Property | Cycle_time_practical |
Public Property | Largeyu_flag |
Public Property | Max_green_percent |
Public Property | Phases |
Public Property | Reqd_green_time_ratio_total |
Public Property | Reqd_movement_time_total |
Public Property | Warning_flag |
Top

See Also

Reference

SIAPIOutputSequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSequence Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : SIAPIOutputSequence Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSequence()
C#
public SIAPIOutputSequence()
Managed Extensions for C++
public: SIAPIOutputSequence();
C++/CLI
public:
SIAPIOutputSequence();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSequence Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSequence Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSequence members.

Public Properties

 | Name | Description
Public Property | Adjusted_flow_ratio_total |
Public Property | Adjusted_lost_time_total |
Public Property | Cmaxsl_flag |
Public Property | Critical_in_network |
Public Property | Cycle_time |
Public Property | Cycle_time_maximum |
Public Property | Cycle_time_maximum_flag |
Public Property | Cycle_time_minimum |
Public Property | Cycle_time_minimum_flag |
Public Property | Cycle_time_option |
Public Property | Cycle_time_option_flag |
Public Property | Cycle_time_practical |
Public Property | Largeyu_flag |
Public Property | Max_green_percent |
Public Property | Phases |
Public Property | Reqd_green_time_ratio_total |
Public Property | Reqd_movement_time_total |
Public Property | Warning_flag |
Top

See Also

Reference

SIAPIOutputSequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Adjusted_flow_ratio_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_flow_ratio_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Single

value = instance.Adjusted_flow_ratio_total
C#
public float Adjusted_flow_ratio_total {get;}
Managed Extensions for C++
public: __property float get_Adjusted_flow_ratio_total();
C++/CLI
public:
property float Adjusted_flow_ratio_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Adjusted_lost_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Adjusted_lost_time_total As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Adjusted_lost_time_total
C#
public int Adjusted_lost_time_total {get;}
Managed Extensions for C++
public: __property int get_Adjusted_lost_time_total();
C++/CLI
public:
property int Adjusted_lost_time_total {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cmaxsl_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cmaxsl_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cmaxsl_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cmaxsl_flag
C#
public int Cmaxsl_flag {get;}
Managed Extensions for C++
public: __property int get_Cmaxsl_flag();
C++/CLI
public:
property int Cmaxsl_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_in_network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Critical_in_network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Critical_in_network As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Critical_in_network
C#
public int Critical_in_network {get;}
Managed Extensions for C++
public: __property int get_Critical_in_network();
C++/CLI
public:
property int Critical_in_network {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time
C#
public int Cycle_time {get;}
Managed Extensions for C++
public: __property int get_Cycle_time();
C++/CLI
public:
property int Cycle_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_maximum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_maximum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_maximum As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_maximum
C#
public int Cycle_time_maximum {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_maximum();
C++/CLI
public:
property int Cycle_time_maximum {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_maximum_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_maximum_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_maximum_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_maximum_flag
C#
public int Cycle_time_maximum_flag {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_maximum_flag();
C++/CLI
public:
property int Cycle_time_maximum_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_minimum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_minimum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_minimum As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_minimum
C#
public int Cycle_time_minimum {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_minimum();
C++/CLI
public:
property int Cycle_time_minimum {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_minimum_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_minimum_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_minimum_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_minimum_flag
C#
public int Cycle_time_minimum_flag {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_minimum_flag();
C++/CLI
public:
property int Cycle_time_minimum_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_option
C#
public int Cycle_time_option {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_option();
C++/CLI
public:
property int Cycle_time_option {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_option_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_option_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_option_flag
C#
public int Cycle_time_option_flag {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_option_flag();
C++/CLI
public:
property int Cycle_time_option_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_practical Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Cycle_time_practical Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cycle_time_practical As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_practical
C#
public int Cycle_time_practical {get;}
Managed Extensions for C++
public: __property int get_Cycle_time_practical();
C++/CLI
public:
property int Cycle_time_practical {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Largeyu_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Largeyu_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Largeyu_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Largeyu_flag
C#
public int Largeyu_flag {get;}
Managed Extensions for C++
public: __property int get_Largeyu_flag();
C++/CLI
public:
property int Largeyu_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_green_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Max_green_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_green_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Single

value = instance.Max_green_percent
C#
public float Max_green_percent {get;}
Managed Extensions for C++
public: __property float get_Max_green_percent();
C++/CLI
public:
property float Max_green_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Phases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phases As ISIAPIOutputPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As ISIAPIOutputPhases

value = instance.Phases
C#
public ISIAPIOutputPhases Phases {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhases* get_Phases();
C++/CLI
public:
property ISIAPIOutputPhases^ Phases {
   ISIAPIOutputPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Reqd_green_time_ratio_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_green_time_ratio_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Single

value = instance.Reqd_green_time_ratio_total
C#
public float Reqd_green_time_ratio_total {get;}
Managed Extensions for C++
public: __property float get_Reqd_green_time_ratio_total();
C++/CLI
public:
property float Reqd_green_time_ratio_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_movement_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Reqd_movement_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Reqd_movement_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Single

value = instance.Reqd_movement_time_total
C#
public float Reqd_movement_time_total {get;}
Managed Extensions for C++
public: __property float get_Reqd_movement_time_total();
C++/CLI
public:
property float Reqd_movement_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Warning_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSequence Class : Warning_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Warning_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSequence
Dim value As Integer

value = instance.Warning_flag
C#
public int Warning_flag {get;}
Managed Extensions for C++
public: __property int get_Warning_flag();
C++/CLI
public:
property int Warning_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSequence Class
SIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputset Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputset Class

Glossary Item Box

SIDRA INTERSECTION Outputset wrapper class

Object Model

SIAPIOutputset ClassISIAPINetworkSite InterfaceISIAPIOutputAnalysis InterfaceISIAPIOutputGraphTuples InterfaceISIAPIOutputGraphTuple InterfaceISIAPIOutputLegPersons InterfaceISIAPIOutputLegPerson InterfaceISIAPIOutputLegs InterfaceISIAPIOutputLeg InterfaceISIAPIOutputMeteredRoundabout InterfaceISIAPIOutputMovementPeds InterfaceISIAPIOutputMovementPed InterfaceISIAPIOutputMovementPersonODs InterfaceISIAPIOutputMovementPersonOD InterfaceISIAPIOutputMovementVehicleODs InterfaceISIAPIOutputMovementVehicleOD InterfaceISIAPIOutputPhaseMovTimingPaths InterfaceISIAPIOutputPhaseMovTimingPath InterfaceISIAPIOutputSequence InterfaceISIAPIOutputSitePedestrian InterfaceISIAPIOutputSitePerson InterfaceISIAPIOutputSiteRoutes InterfaceISIAPIOutputSiteRoute InterfaceISIAPIOutputSiteVehicle InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputset
   Implements ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
C#
public sealed class SIAPIOutputset : ISIAPIOutputset
Managed Extensions for C++
public __gc __sealed class SIAPIOutputset : public ISIAPIOutputset
C++/CLI
public ref class SIAPIOutputset sealed : public ISIAPIOutputset

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputset

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputset Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputset Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputset.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputset Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Analysis_method_flag |
Public Property | Generated |
Public Property | GeneratedByVersion |
Public Property | NetworkSite |
Public Property | NwSite_SignalPlatoonMode |
Public Property | NwSiteOffset |
Public Property | OutputAnalysis |
Public Property | OutputGraphTuples |
Public Property | OutputLegPersons |
Public Property | OutputLegs |
Public Property | OutputMeteredRoundabout |
Public Property | OutputMovementPeds |
Public Property | OutputMovementPersonODs |
Public Property | OutputMovementVehicleODs |
Public Property | OutputPhaseMovTimingPaths |
Public Property | OutputSequence |
Public Property | OutputSitePedestrian |
Public Property | OutputSitePerson |
Public Property | OutputSiteRoutes |
Public Property | OutputSiteVehicle |
Public Property | Site |
Public Property | TWSC_calib_adjusted |
Top

See Also

Reference

SIAPIOutputset Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputset Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : SIAPIOutputset Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputset()
C#
public SIAPIOutputset()
Managed Extensions for C++
public: SIAPIOutputset();
C++/CLI
public:
SIAPIOutputset();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputset Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputset Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputset members.

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Analysis_method_flag |
Public Property | Generated |
Public Property | GeneratedByVersion |
Public Property | NetworkSite |
Public Property | NwSite_SignalPlatoonMode |
Public Property | NwSiteOffset |
Public Property | OutputAnalysis |
Public Property | OutputGraphTuples |
Public Property | OutputLegPersons |
Public Property | OutputLegs |
Public Property | OutputMeteredRoundabout |
Public Property | OutputMovementPeds |
Public Property | OutputMovementPersonODs |
Public Property | OutputMovementVehicleODs |
Public Property | OutputPhaseMovTimingPaths |
Public Property | OutputSequence |
Public Property | OutputSitePedestrian |
Public Property | OutputSitePerson |
Public Property | OutputSiteRoutes |
Public Property | OutputSiteVehicle |
Public Property | Site |
Public Property | TWSC_calib_adjusted |
Top

See Also

Reference

SIAPIOutputset Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Integer

value = instance.Analysis_method
C#
public int Analysis_method {get;}
Managed Extensions for C++
public: __property int get_Analysis_method();
C++/CLI
public:
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : Analysis_method_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_method_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Integer

value = instance.Analysis_method_flag
C#
public int Analysis_method_flag {get;}
Managed Extensions for C++
public: __property int get_Analysis_method_flag();
C++/CLI
public:
property int Analysis_method_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Generated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : Generated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Generated As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Date

value = instance.Generated
C#
public DateTime Generated {get;}
Managed Extensions for C++
public: __property DateTime get_Generated();
C++/CLI
public:
property DateTime Generated {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedByVersion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : GeneratedByVersion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GeneratedByVersion As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As String

value = instance.GeneratedByVersion
C#
public string GeneratedByVersion {get;}
Managed Extensions for C++
public: __property string* get_GeneratedByVersion();
C++/CLI
public:
property String^ GeneratedByVersion {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : NetworkSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSite As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPINetworkSite

value = instance.NetworkSite
C#
public ISIAPINetworkSite NetworkSite {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_NetworkSite();
C++/CLI
public:
property ISIAPINetworkSite^ NetworkSite {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwSite_SignalPlatoonMode Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : NwSite_SignalPlatoonMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NwSite_SignalPlatoonMode As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Integer

value = instance.NwSite_SignalPlatoonMode
C#
public int NwSite_SignalPlatoonMode {get;}
Managed Extensions for C++
public: __property int get_NwSite_SignalPlatoonMode();
C++/CLI
public:
property int NwSite_SignalPlatoonMode {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwSiteOffset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : NwSiteOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NwSiteOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Integer

value = instance.NwSiteOffset
C#
public int NwSiteOffset {get;}
Managed Extensions for C++
public: __property int get_NwSiteOffset();
C++/CLI
public:
property int NwSiteOffset {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputAnalysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputAnalysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputAnalysis As ISIAPIOutputAnalysis
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputAnalysis

value = instance.OutputAnalysis
C#
public ISIAPIOutputAnalysis OutputAnalysis {get;}
Managed Extensions for C++
public: __property ISIAPIOutputAnalysis* get_OutputAnalysis();
C++/CLI
public:
property ISIAPIOutputAnalysis^ OutputAnalysis {
   ISIAPIOutputAnalysis^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputGraphTuples Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputGraphTuples Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputGraphTuples As ISIAPIOutputGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputGraphTuples

value = instance.OutputGraphTuples
C#
public ISIAPIOutputGraphTuples OutputGraphTuples {get;}
Managed Extensions for C++
public: __property ISIAPIOutputGraphTuples* get_OutputGraphTuples();
C++/CLI
public:
property ISIAPIOutputGraphTuples^ OutputGraphTuples {
   ISIAPIOutputGraphTuples^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegPersons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputLegPersons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLegPersons As ISIAPIOutputLegPersons
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputLegPersons

value = instance.OutputLegPersons
C#
public ISIAPIOutputLegPersons OutputLegPersons {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLegPersons* get_OutputLegPersons();
C++/CLI
public:
property ISIAPIOutputLegPersons^ OutputLegPersons {
   ISIAPIOutputLegPersons^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputLegs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputLegs As ISIAPIOutputLegs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputLegs

value = instance.OutputLegs
C#
public ISIAPIOutputLegs OutputLegs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputLegs* get_OutputLegs();
C++/CLI
public:
property ISIAPIOutputLegs^ OutputLegs {
   ISIAPIOutputLegs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMeteredRoundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputMeteredRoundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMeteredRoundabout As ISIAPIOutputMeteredRoundabout
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputMeteredRoundabout

value = instance.OutputMeteredRoundabout
C#
public ISIAPIOutputMeteredRoundabout OutputMeteredRoundabout {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMeteredRoundabout* get_OutputMeteredRoundabout();
C++/CLI
public:
property ISIAPIOutputMeteredRoundabout^ OutputMeteredRoundabout {
   ISIAPIOutputMeteredRoundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPeds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputMovementPeds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementPeds As ISIAPIOutputMovementPeds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputMovementPeds

value = instance.OutputMovementPeds
C#
public ISIAPIOutputMovementPeds OutputMovementPeds {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPeds* get_OutputMovementPeds();
C++/CLI
public:
property ISIAPIOutputMovementPeds^ OutputMovementPeds {
   ISIAPIOutputMovementPeds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPersonODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputMovementPersonODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementPersonODs As ISIAPIOutputMovementPersonODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputMovementPersonODs

value = instance.OutputMovementPersonODs
C#
public ISIAPIOutputMovementPersonODs OutputMovementPersonODs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementPersonODs* get_OutputMovementPersonODs();
C++/CLI
public:
property ISIAPIOutputMovementPersonODs^ OutputMovementPersonODs {
   ISIAPIOutputMovementPersonODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputMovementVehicleODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputMovementVehicleODs As ISIAPIOutputMovementVehicleODs
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputMovementVehicleODs

value = instance.OutputMovementVehicleODs
C#
public ISIAPIOutputMovementVehicleODs OutputMovementVehicleODs {get;}
Managed Extensions for C++
public: __property ISIAPIOutputMovementVehicleODs* get_OutputMovementVehicleODs();
C++/CLI
public:
property ISIAPIOutputMovementVehicleODs^ OutputMovementVehicleODs {
   ISIAPIOutputMovementVehicleODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPaths Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputPhaseMovTimingPaths Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputPhaseMovTimingPaths As ISIAPIOutputPhaseMovTimingPaths
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputPhaseMovTimingPaths

value = instance.OutputPhaseMovTimingPaths
C#
public ISIAPIOutputPhaseMovTimingPaths OutputPhaseMovTimingPaths {get;}
Managed Extensions for C++
public: __property ISIAPIOutputPhaseMovTimingPaths* get_OutputPhaseMovTimingPaths();
C++/CLI
public:
property ISIAPIOutputPhaseMovTimingPaths^ OutputPhaseMovTimingPaths {
   ISIAPIOutputPhaseMovTimingPaths^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputSequence As ISIAPIOutputSequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputSequence

value = instance.OutputSequence
C#
public ISIAPIOutputSequence OutputSequence {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSequence* get_OutputSequence();
C++/CLI
public:
property ISIAPIOutputSequence^ OutputSequence {
   ISIAPIOutputSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSitePedestrian Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputSitePedestrian Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputSitePedestrian As ISIAPIOutputSitePedestrian
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputSitePedestrian

value = instance.OutputSitePedestrian
C#
public ISIAPIOutputSitePedestrian OutputSitePedestrian {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSitePedestrian* get_OutputSitePedestrian();
C++/CLI
public:
property ISIAPIOutputSitePedestrian^ OutputSitePedestrian {
   ISIAPIOutputSitePedestrian^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSitePerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputSitePerson Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputSitePerson As ISIAPIOutputSitePerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputSitePerson

value = instance.OutputSitePerson
C#
public ISIAPIOutputSitePerson OutputSitePerson {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSitePerson* get_OutputSitePerson();
C++/CLI
public:
property ISIAPIOutputSitePerson^ OutputSitePerson {
   ISIAPIOutputSitePerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSiteRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputSiteRoutes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputSiteRoutes As ISIAPIOutputSiteRoutes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputSiteRoutes

value = instance.OutputSiteRoutes
C#
public ISIAPIOutputSiteRoutes OutputSiteRoutes {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSiteRoutes* get_OutputSiteRoutes();
C++/CLI
public:
property ISIAPIOutputSiteRoutes^ OutputSiteRoutes {
   ISIAPIOutputSiteRoutes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSiteVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : OutputSiteVehicle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputSiteVehicle As ISIAPIOutputSiteVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPIOutputSiteVehicle

value = instance.OutputSiteVehicle
C#
public ISIAPIOutputSiteVehicle OutputSiteVehicle {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSiteVehicle* get_OutputSiteVehicle();
C++/CLI
public:
property ISIAPIOutputSiteVehicle^ OutputSiteVehicle {
   ISIAPIOutputSiteVehicle^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TWSC_calib_adjusted Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputset Class : TWSC_calib_adjusted Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TWSC_calib_adjusted As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputset
Dim value As Integer

value = instance.TWSC_calib_adjusted
C#
public int TWSC_calib_adjusted {get;}
Managed Extensions for C++
public: __property int get_TWSC_calib_adjusted();
C++/CLI
public:
property int TWSC_calib_adjusted {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputset Class
SIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePedestrian Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePedestrian Class

Glossary Item Box

SIDRA INTERSECTION Output Site Pedestrian wrapper class.

Object Model

SIAPIOutputSitePedestrian Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSitePedestrian
   Implements ISIAPIOutputSitePedestrian
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
C#
public sealed class SIAPIOutputSitePedestrian : ISIAPIOutputSitePedestrian
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSitePedestrian : public ISIAPIOutputSitePedestrian
C++/CLI
public ref class SIAPIOutputSitePedestrian sealed : public ISIAPIOutputSitePedestrian

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSitePedestrian

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePedestrian Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePedestrian Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSitePedestrian.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSitePedestrian Constructor |
Top

Public Properties

 | Name | Description
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Demand_flow_total | Total pedestrian demand flow.
Public Property | Level_of_service | Intersection pedestrian LOS.
Public Property | Level_of_service_worstmov | Worst pedestrian movement LOS.
Public Property | Operating_cost_total | Total operating cost.
Public Property | Performance_index | Performance index.
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_dist_maxback_mean | Longest pedestrian queue (distance), mean.
Public Property | Queue_maxback_mean | Pedestrian queue (peds), mean.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

SIAPIOutputSitePedestrian Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePedestrian Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : SIAPIOutputSitePedestrian Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSitePedestrian()
C#
public SIAPIOutputSitePedestrian()
Managed Extensions for C++
public: SIAPIOutputSitePedestrian();
C++/CLI
public:
SIAPIOutputSitePedestrian();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePedestrian Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePedestrian Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSitePedestrian members.

Public Properties

 | Name | Description
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Demand_flow_total | Total pedestrian demand flow.
Public Property | Level_of_service | Intersection pedestrian LOS.
Public Property | Level_of_service_worstmov | Worst pedestrian movement LOS.
Public Property | Operating_cost_total | Total operating cost.
Public Property | Performance_index | Performance index.
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_dist_maxback_mean | Longest pedestrian queue (distance), mean.
Public Property | Queue_maxback_mean | Pedestrian queue (peds), mean.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

SIAPIOutputSitePedestrian Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst pedestrian movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Demand_flow_total Property

Glossary Item Box

Total pedestrian demand flow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Level_of_service Property

Glossary Item Box

Intersection pedestrian LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Level_of_service_worstmov Property

Glossary Item Box

Worst pedestrian movement LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As String

value = instance.Level_of_service_worstmov
C#
public string Level_of_service_worstmov {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_worstmov();
C++/CLI
public:
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Operating_cost_total Property

Glossary Item Box

Total operating cost.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Queue_dist_maxback_mean Property

Glossary Item Box

Longest pedestrian queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Queue_maxback_mean Property

Glossary Item Box

Pedestrian queue (peds), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePedestrian Class : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePedestrian Class
SIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePerson Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePerson Class

Glossary Item Box

SIDRA INTERSECTION Person specific site output wrapper class.

Object Model

SIAPIOutputSitePerson Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSitePerson
   Implements ISIAPIOutputSitePerson
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
C#
public sealed class SIAPIOutputSitePerson : ISIAPIOutputSitePerson
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSitePerson : public ISIAPIOutputSitePerson
C++/CLI
public ref class SIAPIOutputSitePerson sealed : public ISIAPIOutputSitePerson

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSitePerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePerson Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePerson Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSitePerson.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSitePerson Constructor |
Top

Public Properties

 | Name | Description
Public Property | Arrival_flow_total | Total person Arrival Flow.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Demand_flow_total | Total person Demand Flow.
Public Property | Operating_cost_total | Total operating cost.
Public Property | Performance_index | Performance index.
Public Property | Proportion_queued | Proportion queued.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

SIAPIOutputSitePerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePerson Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : SIAPIOutputSitePerson Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSitePerson()
C#
public SIAPIOutputSitePerson()
Managed Extensions for C++
public: SIAPIOutputSitePerson();
C++/CLI
public:
SIAPIOutputSitePerson();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSitePerson Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSitePerson Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSitePerson members.

Public Properties

 | Name | Description
Public Property | Arrival_flow_total | Total person Arrival Flow.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Demand_flow_total | Total person Demand Flow.
Public Property | Operating_cost_total | Total operating cost.
Public Property | Performance_index | Performance index.
Public Property | Proportion_queued | Proportion queued.
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time (secs).
Public Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

SIAPIOutputSitePerson Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Arrival_flow_total Property

Glossary Item Box

Total person Arrival Flow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Arrival_flow_total
C#
public float Arrival_flow_total {get;}
Managed Extensions for C++
public: __property float get_Arrival_flow_total();
C++/CLI
public:
property float Arrival_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst pedestrian movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Demand_flow_total Property

Glossary Item Box

Total person Demand Flow.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Demand_flow_total
C#
public float Demand_flow_total {get;}
Managed Extensions for C++
public: __property float get_Demand_flow_total();
C++/CLI
public:
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Operating_cost_total Property

Glossary Item Box

Total operating cost.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSitePerson Class : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSitePerson Class
SIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoute Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoute Class

Glossary Item Box

Object Model

SIAPIOutputSiteRoute Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSiteRoute
   Implements ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
C#
public sealed class SIAPIOutputSiteRoute : ISIAPIOutputSiteRoute
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSiteRoute : public ISIAPIOutputSiteRoute
C++/CLI
public ref class SIAPIOutputSiteRoute sealed : public ISIAPIOutputSiteRoute

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSiteRoute

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoute Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoute Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSiteRoute.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSiteRoute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Coord_mov_displayed_green_time |
Public Property | Coord_mov_displayed_start_time |
Public Property | Coord_mov_eff_start_time |
Public Property | Coord_mov_effgreen |
Public Property | Coord_mov_phasetime |
Public Property | Route_id |
Public Property | RouteName |
Public Property | RouteSignalOffsetPriority |
Top

See Also

Reference

SIAPIOutputSiteRoute Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoute Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : SIAPIOutputSiteRoute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSiteRoute()
C#
public SIAPIOutputSiteRoute()
Managed Extensions for C++
public: SIAPIOutputSiteRoute();
C++/CLI
public:
SIAPIOutputSiteRoute();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoute Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoute Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSiteRoute members.

Public Properties

 | Name | Description
Public Property | Coord_mov_displayed_green_time |
Public Property | Coord_mov_displayed_start_time |
Public Property | Coord_mov_eff_start_time |
Public Property | Coord_mov_effgreen |
Public Property | Coord_mov_phasetime |
Public Property | Route_id |
Public Property | RouteName |
Public Property | RouteSignalOffsetPriority |
Top

See Also

Reference

SIAPIOutputSiteRoute Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Coord_mov_displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_displayed_green_time
C#
public int Coord_mov_displayed_green_time {get;}
Managed Extensions for C++
public: __property int get_Coord_mov_displayed_green_time();
C++/CLI
public:
property int Coord_mov_displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Coord_mov_displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_displayed_start_time
C#
public int Coord_mov_displayed_start_time {get;}
Managed Extensions for C++
public: __property int get_Coord_mov_displayed_start_time();
C++/CLI
public:
property int Coord_mov_displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Coord_mov_eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_eff_start_time
C#
public int Coord_mov_eff_start_time {get;}
Managed Extensions for C++
public: __property int get_Coord_mov_eff_start_time();
C++/CLI
public:
property int Coord_mov_eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_effgreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Coord_mov_effgreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_effgreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_effgreen
C#
public int Coord_mov_effgreen {get;}
Managed Extensions for C++
public: __property int get_Coord_mov_effgreen();
C++/CLI
public:
property int Coord_mov_effgreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_phasetime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Coord_mov_phasetime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Coord_mov_phasetime As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_phasetime
C#
public int Coord_mov_phasetime {get;}
Managed Extensions for C++
public: __property int get_Coord_mov_phasetime();
C++/CLI
public:
property int Coord_mov_phasetime {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : Route_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Route_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.Route_id
C#
public int Route_id {get;}
Managed Extensions for C++
public: __property int get_Route_id();
C++/CLI
public:
property int Route_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : RouteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteName As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As String

value = instance.RouteName
C#
public string RouteName {get;}
Managed Extensions for C++
public: __property string* get_RouteName();
C++/CLI
public:
property String^ RouteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteSignalOffsetPriority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoute Class : RouteSignalOffsetPriority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteSignalOffsetPriority As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoute
Dim value As Integer

value = instance.RouteSignalOffsetPriority
C#
public int RouteSignalOffsetPriority {get;}
Managed Extensions for C++
public: __property int get_RouteSignalOffsetPriority();
C++/CLI
public:
property int RouteSignalOffsetPriority {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoute Class
SIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoutes Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoutes Class

Glossary Item Box

Object Model

SIAPIOutputSiteRoutes ClassISIAPIOutputSiteRoute Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSiteRoutes
   Implements ISIAPIOutputSiteRoutes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
C#
public sealed class SIAPIOutputSiteRoutes : ISIAPIOutputSiteRoutes
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSiteRoutes : public ISIAPIOutputSiteRoutes
C++/CLI
public ref class SIAPIOutputSiteRoutes sealed : public ISIAPIOutputSiteRoutes

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSiteRoutes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoutes Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoutes Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSiteRoutes.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSiteRoutes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | Exists |
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputSiteRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoutes Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class : SIAPIOutputSiteRoutes Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSiteRoutes()
C#
public SIAPIOutputSiteRoutes()
Managed Extensions for C++
public: SIAPIOutputSiteRoutes();
C++/CLI
public:
SIAPIOutputSiteRoutes();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoutes Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoutes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSiteRoutes members.

Public Methods

 | Name | Description
Public Method | Exists |
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPIOutputSiteRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class : Exists Method

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal routeName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
Dim routeName As String
Dim value As Boolean

value = instance.Exists(routeName)
C#
public bool Exists(
   string routeName
)
Managed Extensions for C++
public: bool Exists(
   string* routeName
)
C++/CLI
public:
bool Exists(
   String^ routeName
)

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteRoutes Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteRoutes Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSiteRoutes members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIOutputSiteRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class > Item Property : Item(String) Property

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal routeName As String _
) As ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
Dim routeName As String
Dim value As ISIAPIOutputSiteRoute

value = instance.Item(routeName)
C#
public ISIAPIOutputSiteRoute Item(
   string routeName
) {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSiteRoute* get_Item(
   string* routeName
);
C++/CLI
public:
property ISIAPIOutputSiteRoute^ Item {
   ISIAPIOutputSiteRoute^ get(String^ routeName);
}

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteRoutes Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteRoutes
Dim index As Integer
Dim value As ISIAPIOutputSiteRoute

value = instance.Item(index)
C#
public ISIAPIOutputSiteRoute Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIOutputSiteRoute* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIOutputSiteRoute^ Item {
   ISIAPIOutputSiteRoute^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteRoutes Class
SIAPIOutputSiteRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteVehicle Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteVehicle Class

Glossary Item Box

SIDRA INTERSECTION Output Site Vehicle wrapper class

Object Model

SIAPIOutputSiteVehicle Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIOutputSiteVehicle
   Implements ISIAPIOutputSiteVehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
C#
public sealed class SIAPIOutputSiteVehicle : ISIAPIOutputSiteVehicle
Managed Extensions for C++
public __gc __sealed class SIAPIOutputSiteVehicle : public ISIAPIOutputSiteVehicle
C++/CLI
public ref class SIAPIOutputSiteVehicle sealed : public ISIAPIOutputSiteVehicle

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIOutputSiteVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteVehicle Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteVehicle Class

Glossary Item Box

The following tables list the members exposed by SIAPIOutputSiteVehicle.

Public Constructors

 | Name | Description
Public Constructor | SIAPIOutputSiteVehicle Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_effective | Effective intersection capacity.
Public Property | Capacity_lane_total | Sum of all lane capacities.
Public Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Public Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Public Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Public Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Public Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstlane | Average control delay for worst lane.
Public Property | Delay_control_average_worstmov | Average control delay for worst movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate | Fuel consumption rate.
Public Property | Fuel_consumption_total | Total fuel consumption.
Public Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Public Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Public Property | Idling_time_average |
Public Property | Level_of_service | Intersection LOS.
Public Property | Level_of_service_av_int_delay | Average intersection delay LOS.
Public Property | Level_of_service_worstlane | Worst lane LOS.
Public Property | Level_of_service_worstmov | Worst movement LOS.
Public Property | Max_subit_capacity_diff |
Public Property | Max_subit_capacity_percent |
Public Property | Max_subit_dx_percent |
Public Property | Max_subit_dx_percent_prev |
Public Property | Max_subit_dx_percent_prev2 |
Public Property | Max_SubIterations |
Public Property | Max_timit_dx_percent |
Public Property | Max_timit_dx_percent_prev |
Public Property | Max_timit_dx_percent_prev2 |
Public Property | Max_TimIterations |
Public Property | Model_flowcap_vari_index |
Public Property | Model_timing_vari_index |
Public Property | Nox_rate | NOX emission rate (g/km).
Public Property | Nox_total | Total NOX emissions (kg/h).
Public Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Public Property | Operating_cost_total | Total operating cost (cost unit/h)
Public Property | Performance_index | Performance index.
Public Property | Practical_spare_capacity | Lowest practical degree of saturation.
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Public Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | SpeedEfficiency |
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | SubIterationsCount |
Public Property | TimIterationsCount |
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time.
Public Property | Travel_time_total | Total travel time.
Top

See Also

Reference

SIAPIOutputSiteVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteVehicle Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : SIAPIOutputSiteVehicle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIOutputSiteVehicle()
C#
public SIAPIOutputSiteVehicle()
Managed Extensions for C++
public: SIAPIOutputSiteVehicle();
C++/CLI
public:
SIAPIOutputSiteVehicle();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIOutputSiteVehicle Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIOutputSiteVehicle Class

Glossary Item Box

For a list of all members of this type, see SIAPIOutputSiteVehicle members.

Public Properties

 | Name | Description
Public Property | Analysis_method |
Public Property | Avg_num_of_cycles_to_depart |
Public Property | Capacity_adj_flag_worstlane |
Public Property | Capacity_adj_worstlane |
Public Property | Capacity_effective | Effective intersection capacity.
Public Property | Capacity_lane_total | Sum of all lane capacities.
Public Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Public Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Public Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Public Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Public Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Public Property | Deg_satn | Intersection degree of saturation.
Public Property | Delay_control_average | Average control delay.
Public Property | Delay_control_average_worstlane | Average control delay for worst lane.
Public Property | Delay_control_average_worstmov | Average control delay for worst movement.
Public Property | Delay_control_total | Total control delay.
Public Property | Delay_geometric_average |
Public Property | Delay_stopline_average |
Public Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct | Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Public Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Public Property | Flow_total | Total Demand Flow Rate.
Public Property | Flow_total_capconstr | Total Arrival Flow Rate.
Public Property | Fuel_consumption_rate | Fuel consumption rate.
Public Property | Fuel_consumption_total | Total fuel consumption.
Public Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Public Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Public Property | Idling_time_average |
Public Property | Level_of_service | Intersection LOS.
Public Property | Level_of_service_av_int_delay | Average intersection delay LOS.
Public Property | Level_of_service_worstlane | Worst lane LOS.
Public Property | Level_of_service_worstmov | Worst movement LOS.
Public Property | Max_subit_capacity_diff |
Public Property | Max_subit_capacity_percent |
Public Property | Max_subit_dx_percent |
Public Property | Max_subit_dx_percent_prev |
Public Property | Max_subit_dx_percent_prev2 |
Public Property | Max_SubIterations |
Public Property | Max_timit_dx_percent |
Public Property | Max_timit_dx_percent_prev |
Public Property | Max_timit_dx_percent_prev2 |
Public Property | Max_TimIterations |
Public Property | Model_flowcap_vari_index |
Public Property | Model_timing_vari_index |
Public Property | Nox_rate | NOX emission rate (g/km).
Public Property | Nox_total | Total NOX emissions (kg/h).
Public Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Public Property | Operating_cost_total | Total operating cost (cost unit/h)
Public Property | Performance_index | Performance index.
Public Property | Practical_spare_capacity | Lowest practical degree of saturation.
Public Property | Proportion_queued | Proportion queued.
Public Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Public Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Public Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Public Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Public Property | Queue_dist_greenstart_mean |
Public Property | Queue_dist_greenstart_percentile |
Public Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Public Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Public Property | Queue_greenstart_mean |
Public Property | Queue_greenstart_percentile |
Public Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Public Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Public Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Public Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Public Property | SpeedEfficiency |
Public Property | Stop_rate | Effective stop rate.
Public Property | Stops_total | Total effective stops.
Public Property | SubIterationsCount |
Public Property | TimIterationsCount |
Public Property | Travel_distance_average | Average travel distance.
Public Property | Travel_distance_total | Total travel distance.
Public Property | Travel_speed | Average travel speed.
Public Property | Travel_time_average | Average travel time.
Public Property | Travel_time_total | Total travel time.
Top

See Also

Reference

SIAPIOutputSiteVehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Analysis_method
C#
public int Analysis_method {get;}
Managed Extensions for C++
public: __property int get_Analysis_method();
C++/CLI
public:
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
public float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
public: __property float get_Avg_num_of_cycles_to_depart();
C++/CLI
public:
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
public int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
public: __property int get_Capacity_adj_flag_worstlane();
C++/CLI
public:
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
public float Capacity_adj_worstlane {get;}
Managed Extensions for C++
public: __property float get_Capacity_adj_worstlane();
C++/CLI
public:
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Capacity_effective Property

Glossary Item Box

Effective intersection capacity.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_effective
C#
public float Capacity_effective {get;}
Managed Extensions for C++
public: __property float get_Capacity_effective();
C++/CLI
public:
property float Capacity_effective {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_lane_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Capacity_lane_total Property

Glossary Item Box

Sum of all lane capacities.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_lane_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_lane_total
C#
public float Capacity_lane_total {get;}
Managed Extensions for C++
public: __property float get_Capacity_lane_total();
C++/CLI
public:
property float Capacity_lane_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Capacity_mov_total Property

Glossary Item Box

Sum of movement capacities (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Capacity_mov_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_mov_total
C#
public float Capacity_mov_total {get;}
Managed Extensions for C++
public: __property float get_Capacity_mov_total();
C++/CLI
public:
property float Capacity_mov_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Carbon_dioxide_rate Property

Glossary Item Box

Carbon Dioxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
public float Carbon_dioxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_rate();
C++/CLI
public:
property float Carbon_dioxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Carbon_dioxide_total Property

Glossary Item Box

Total Carbon Dioxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_dioxide_total
C#
public float Carbon_dioxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_dioxide_total();
C++/CLI
public:
property float Carbon_dioxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Carbon_monoxide_rate Property

Glossary Item Box

Carbon Monoxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
public float Carbon_monoxide_rate {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_rate();
C++/CLI
public:
property float Carbon_monoxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Carbon_monoxide_total Property

Glossary Item Box

Total Carbon Monoxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_monoxide_total
C#
public float Carbon_monoxide_total {get;}
Managed Extensions for C++
public: __property float get_Carbon_monoxide_total();
C++/CLI
public:
property float Carbon_monoxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Deg_satn
C#
public float Deg_satn {get;}
Managed Extensions for C++
public: __property float get_Deg_satn();
C++/CLI
public:
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average
C#
public float Delay_control_average {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average();
C++/CLI
public:
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_control_average_worstlane Property

Glossary Item Box

Average control delay for worst lane.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
public float Delay_control_average_worstlane {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstlane();
C++/CLI
public:
property float Delay_control_average_worstlane {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
public float Delay_control_average_worstmov {get;}
Managed Extensions for C++
public: __property float get_Delay_control_average_worstmov();
C++/CLI
public:
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_total
C#
public float Delay_control_total {get;}
Managed Extensions for C++
public: __property float get_Delay_control_total();
C++/CLI
public:
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_geometric_average
C#
public float Delay_geometric_average {get;}
Managed Extensions for C++
public: __property float get_Delay_geometric_average();
C++/CLI
public:
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_stopline_average
C#
public float Delay_stopline_average {get;}
Managed Extensions for C++
public: __property float get_Delay_stopline_average();
C++/CLI
public:
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV
C#
public float Flow_HV {get;}
Managed Extensions for C++
public: __property float get_Flow_HV();
C++/CLI
public:
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_capconstr
C#
public float Flow_HV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_capconstr();
C++/CLI
public:
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_HV_pct Property

Glossary Item Box

Demand Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_pct
C#
public float Flow_HV_pct {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct();
C++/CLI
public:
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
public float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_HV_pct_capconstr();
C++/CLI
public:
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_LV
C#
public float Flow_LV {get;}
Managed Extensions for C++
public: __property float get_Flow_LV();
C++/CLI
public:
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_LV_capconstr
C#
public float Flow_LV_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_LV_capconstr();
C++/CLI
public:
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_total
C#
public float Flow_total {get;}
Managed Extensions for C++
public: __property float get_Flow_total();
C++/CLI
public:
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_total_capconstr
C#
public float Flow_total_capconstr {get;}
Managed Extensions for C++
public: __property float get_Flow_total_capconstr();
C++/CLI
public:
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Fuel_consumption_rate Property

Glossary Item Box

Fuel consumption rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Fuel_consumption_rate
C#
public float Fuel_consumption_rate {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_rate();
C++/CLI
public:
property float Fuel_consumption_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Fuel_consumption_total Property

Glossary Item Box

Total fuel consumption.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Fuel_consumption_total
C#
public float Fuel_consumption_total {get;}
Managed Extensions for C++
public: __property float get_Fuel_consumption_total();
C++/CLI
public:
property float Fuel_consumption_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Hydrocarbons_rate Property

Glossary Item Box

Hydrocarbon emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Hydrocarbons_rate
C#
public float Hydrocarbons_rate {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_rate();
C++/CLI
public:
property float Hydrocarbons_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Hydrocarbons_total Property

Glossary Item Box

Total Hydrocarbon emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Hydrocarbons_total
C#
public float Hydrocarbons_total {get;}
Managed Extensions for C++
public: __property float get_Hydrocarbons_total();
C++/CLI
public:
property float Hydrocarbons_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Idling_time_average
C#
public float Idling_time_average {get;}
Managed Extensions for C++
public: __property float get_Idling_time_average();
C++/CLI
public:
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Level_of_service Property

Glossary Item Box

Intersection LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service
C#
public string Level_of_service {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service();
C++/CLI
public:
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_av_int_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Level_of_service_av_int_delay Property

Glossary Item Box

Average intersection delay LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_av_int_delay As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_av_int_delay
C#
public string Level_of_service_av_int_delay {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_av_int_delay();
C++/CLI
public:
property String^ Level_of_service_av_int_delay {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Level_of_service_worstlane Property

Glossary Item Box

Worst lane LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_worstlane As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_worstlane
C#
public string Level_of_service_worstlane {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_worstlane();
C++/CLI
public:
property String^ Level_of_service_worstlane {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Level_of_service_worstmov Property

Glossary Item Box

Worst movement LOS.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_worstmov
C#
public string Level_of_service_worstmov {get;}
Managed Extensions for C++
public: __property string* get_Level_of_service_worstmov();
C++/CLI
public:
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_capacity_diff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_subit_capacity_diff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_subit_capacity_diff As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_capacity_diff
C#
public float Max_subit_capacity_diff {get;}
Managed Extensions for C++
public: __property float get_Max_subit_capacity_diff();
C++/CLI
public:
property float Max_subit_capacity_diff {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_capacity_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_subit_capacity_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_subit_capacity_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_capacity_percent
C#
public float Max_subit_capacity_percent {get;}
Managed Extensions for C++
public: __property float get_Max_subit_capacity_percent();
C++/CLI
public:
property float Max_subit_capacity_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_subit_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_subit_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent
C#
public float Max_subit_dx_percent {get;}
Managed Extensions for C++
public: __property float get_Max_subit_dx_percent();
C++/CLI
public:
property float Max_subit_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_subit_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_subit_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent_prev
C#
public float Max_subit_dx_percent_prev {get;}
Managed Extensions for C++
public: __property float get_Max_subit_dx_percent_prev();
C++/CLI
public:
property float Max_subit_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_subit_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_subit_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent_prev2
C#
public float Max_subit_dx_percent_prev2 {get;}
Managed Extensions for C++
public: __property float get_Max_subit_dx_percent_prev2();
C++/CLI
public:
property float Max_subit_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_SubIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_SubIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_SubIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Max_SubIterations
C#
public int Max_SubIterations {get;}
Managed Extensions for C++
public: __property int get_Max_SubIterations();
C++/CLI
public:
property int Max_SubIterations {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_timit_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_timit_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent
C#
public float Max_timit_dx_percent {get;}
Managed Extensions for C++
public: __property float get_Max_timit_dx_percent();
C++/CLI
public:
property float Max_timit_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_timit_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_timit_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent_prev
C#
public float Max_timit_dx_percent_prev {get;}
Managed Extensions for C++
public: __property float get_Max_timit_dx_percent_prev();
C++/CLI
public:
property float Max_timit_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_timit_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_timit_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent_prev2
C#
public float Max_timit_dx_percent_prev2 {get;}
Managed Extensions for C++
public: __property float get_Max_timit_dx_percent_prev2();
C++/CLI
public:
property float Max_timit_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_TimIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Max_TimIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Max_TimIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Max_TimIterations
C#
public int Max_TimIterations {get;}
Managed Extensions for C++
public: __property int get_Max_TimIterations();
C++/CLI
public:
property int Max_TimIterations {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_flowcap_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Model_flowcap_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Model_flowcap_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Model_flowcap_vari_index
C#
public float Model_flowcap_vari_index {get;}
Managed Extensions for C++
public: __property float get_Model_flowcap_vari_index();
C++/CLI
public:
property float Model_flowcap_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_timing_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Model_timing_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Model_timing_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Model_timing_vari_index
C#
public float Model_timing_vari_index {get;}
Managed Extensions for C++
public: __property float get_Model_timing_vari_index();
C++/CLI
public:
property float Model_timing_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Nox_rate Property

Glossary Item Box

NOX emission rate (g/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Nox_rate
C#
public float Nox_rate {get;}
Managed Extensions for C++
public: __property float get_Nox_rate();
C++/CLI
public:
property float Nox_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Nox_total Property

Glossary Item Box

Total NOX emissions (kg/h).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Nox_total
C#
public float Nox_total {get;}
Managed Extensions for C++
public: __property float get_Nox_total();
C++/CLI
public:
property float Nox_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Operating_cost_rate Property

Glossary Item Box

Operating cost rate (cost unit/km).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Operating_cost_rate
C#
public float Operating_cost_rate {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_rate();
C++/CLI
public:
property float Operating_cost_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h)

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Operating_cost_total
C#
public float Operating_cost_total {get;}
Managed Extensions for C++
public: __property float get_Operating_cost_total();
C++/CLI
public:
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Performance_index
C#
public float Performance_index {get;}
Managed Extensions for C++
public: __property float get_Performance_index();
C++/CLI
public:
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Practical_spare_capacity Property

Glossary Item Box

Lowest practical degree of saturation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Practical_spare_capacity
C#
public float Practical_spare_capacity {get;}
Managed Extensions for C++
public: __property float get_Practical_spare_capacity();
C++/CLI
public:
property float Practical_spare_capacity {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Proportion_queued
C#
public float Proportion_queued {get;}
Managed Extensions for C++
public: __property float get_Proportion_queued();
C++/CLI
public:
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_cycav_mean
C#
public float Queue_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_mean();
C++/CLI
public:
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_cycav_percentile
C#
public float Queue_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_cycav_percentile();
C++/CLI
public:
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
public float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_mean();
C++/CLI
public:
property float Queue_dist_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
public float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_cycav_percentile();
C++/CLI
public:
property float Queue_dist_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
public float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_mean();
C++/CLI
public:
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
public float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_greenstart_percentile();
C++/CLI
public:
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
public float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_mean();
C++/CLI
public:
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_dist_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
public float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_dist_maxback_percentile();
C++/CLI
public:
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_greenstart_mean
C#
public float Queue_greenstart_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_mean();
C++/CLI
public:
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
public float Queue_greenstart_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_greenstart_percentile();
C++/CLI
public:
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_maxback_mean
C#
public float Queue_maxback_mean {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_mean();
C++/CLI
public:
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_maxback_percentile
C#
public float Queue_maxback_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_maxback_percentile();
C++/CLI
public:
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
public float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_avg();
C++/CLI
public:
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
public float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
public: __property float get_Queue_storage_ratio_percentile();
C++/CLI
public:
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
public float SpeedEfficiency {get;}
Managed Extensions for C++
public: __property float get_SpeedEfficiency();
C++/CLI
public:
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Stop_rate
C#
public float Stop_rate {get;}
Managed Extensions for C++
public: __property float get_Stop_rate();
C++/CLI
public:
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Stops_total
C#
public float Stops_total {get;}
Managed Extensions for C++
public: __property float get_Stops_total();
C++/CLI
public:
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SubIterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : SubIterationsCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SubIterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.SubIterationsCount
C#
public int SubIterationsCount {get;}
Managed Extensions for C++
public: __property int get_SubIterationsCount();
C++/CLI
public:
property int SubIterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TimIterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : TimIterationsCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TimIterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Integer

value = instance.TimIterationsCount
C#
public int TimIterationsCount {get;}
Managed Extensions for C++
public: __property int get_TimIterationsCount();
C++/CLI
public:
property int TimIterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_distance_average
C#
public float Travel_distance_average {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_average();
C++/CLI
public:
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_distance_total
C#
public float Travel_distance_total {get;}
Managed Extensions for C++
public: __property float get_Travel_distance_total();
C++/CLI
public:
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_speed
C#
public float Travel_speed {get;}
Managed Extensions for C++
public: __property float get_Travel_speed();
C++/CLI
public:
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Travel_time_average Property

Glossary Item Box

Average travel time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_time_average
C#
public float Travel_time_average {get;}
Managed Extensions for C++
public: __property float get_Travel_time_average();
C++/CLI
public:
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIOutputSiteVehicle Class : Travel_time_total Property

Glossary Item Box

Total travel time.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_time_total
C#
public float Travel_time_total {get;}
Managed Extensions for C++
public: __property float get_Travel_time_total();
C++/CLI
public:
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIOutputSiteVehicle Class
SIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhase Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhase Class

Glossary Item Box

Object Model

SIAPIPhase ClassISIAPIPhasemovement_peds InterfaceISIAPIPhasemovement_ped InterfaceISIAPIPhasemovement_vehicles InterfaceISIAPIPhasemovement_vehicle InterfaceISIAPISequence Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhase
   Implements ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
C#
public sealed class SIAPIPhase : ISIAPIPhase
Managed Extensions for C++
public __gc __sealed class SIAPIPhase : public ISIAPIPhase
C++/CLI
public ref class SIAPIPhase sealed : public ISIAPIPhase

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhase Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhase Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhase.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhase Constructor |
Top

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | Dummy_maximum_green_time |
Public Property | Dummy_maximum_green_time_user |
Public Property | Dummy_minimum_green_time |
Public Property | Dummy_minimum_green_time_user |
Public Property | Has_dummy |
Public Property | Is_variable |
Public Property | IsReferencePhase |
Public Property | Minimum_time |
Public Property | Name |
Public Property | Phase_frequency |
Public Property | Phase_frequency_user |
Public Property | Phase_id | The database row unique ID of the Phase.
Public Property | Phase_time |
Public Property | Phasemovement_peds |
Public Property | Phasemovement_vehicles |
Public Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Public Property | Sequence |
Public Property | Yellow_time |
Top

See Also

Reference

SIAPIPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhase Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : SIAPIPhase Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhase()
C#
public SIAPIPhase()
Managed Extensions for C++
public: SIAPIPhase();
C++/CLI
public:
SIAPIPhase();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhase Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhase Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhase members.

Public Properties

 | Name | Description
Public Property | All_red_time |
Public Property | Dummy_maximum_green_time |
Public Property | Dummy_maximum_green_time_user |
Public Property | Dummy_minimum_green_time |
Public Property | Dummy_minimum_green_time_user |
Public Property | Has_dummy |
Public Property | Is_variable |
Public Property | IsReferencePhase |
Public Property | Minimum_time |
Public Property | Name |
Public Property | Phase_frequency |
Public Property | Phase_frequency_user |
Public Property | Phase_id | The database row unique ID of the Phase.
Public Property | Phase_time |
Public Property | Phasemovement_peds |
Public Property | Phasemovement_vehicles |
Public Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Public Property | Sequence |
Public Property | Yellow_time |
Top

See Also

Reference

SIAPIPhase Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.All_red_time = value

value = instance.All_red_time
C#
public int All_red_time {get; set;}
Managed Extensions for C++
public: __property int get_All_red_time();
public: __property void set_All_red_time(
   int value
);
C++/CLI
public:
property int All_red_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Dummy_maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.Dummy_maximum_green_time = value

value = instance.Dummy_maximum_green_time
C#
public int Dummy_maximum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Dummy_maximum_green_time();
public: __property void set_Dummy_maximum_green_time(
   int value
);
C++/CLI
public:
property int Dummy_maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Dummy_maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.Dummy_maximum_green_time_user = value

value = instance.Dummy_maximum_green_time_user
C#
public bool Dummy_maximum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Dummy_maximum_green_time_user();
public: __property void set_Dummy_maximum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Dummy_maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Dummy_minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.Dummy_minimum_green_time = value

value = instance.Dummy_minimum_green_time
C#
public int Dummy_minimum_green_time {get; set;}
Managed Extensions for C++
public: __property int get_Dummy_minimum_green_time();
public: __property void set_Dummy_minimum_green_time(
   int value
);
C++/CLI
public:
property int Dummy_minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Dummy_minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Dummy_minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.Dummy_minimum_green_time_user = value

value = instance.Dummy_minimum_green_time_user
C#
public bool Dummy_minimum_green_time_user {get; set;}
Managed Extensions for C++
public: __property bool get_Dummy_minimum_green_time_user();
public: __property void set_Dummy_minimum_green_time_user(
   bool value
);
C++/CLI
public:
property bool Dummy_minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.Has_dummy = value

value = instance.Has_dummy
C#
public bool Has_dummy {get; set;}
Managed Extensions for C++
public: __property bool get_Has_dummy();
public: __property void set_Has_dummy(
   bool value
);
C++/CLI
public:
property bool Has_dummy {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_variable Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Is_variable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_variable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.Is_variable = value

value = instance.Is_variable
C#
public bool Is_variable {get; set;}
Managed Extensions for C++
public: __property bool get_Is_variable();
public: __property void set_Is_variable(
   bool value
);
C++/CLI
public:
property bool Is_variable {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.IsReferencePhase = value

value = instance.IsReferencePhase
C#
public bool IsReferencePhase {get; set;}
Managed Extensions for C++
public: __property bool get_IsReferencePhase();
public: __property void set_IsReferencePhase(
   bool value
);
C++/CLI
public:
property bool IsReferencePhase {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Minimum_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Minimum_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.Minimum_time = value

value = instance.Minimum_time
C#
public int Minimum_time {get; set;}
Managed Extensions for C++
public: __property int get_Minimum_time();
public: __property void set_Minimum_time(
   int value
);
C++/CLI
public:
property int Minimum_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phase_frequency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_frequency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Single

instance.Phase_frequency = value

value = instance.Phase_frequency
C#
public float Phase_frequency {get; set;}
Managed Extensions for C++
public: __property float get_Phase_frequency();
public: __property void set_Phase_frequency(
   float value
);
C++/CLI
public:
property float Phase_frequency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phase_frequency_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_frequency_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Boolean

instance.Phase_frequency_user = value

value = instance.Phase_frequency_user
C#
public bool Phase_frequency_user {get; set;}
Managed Extensions for C++
public: __property bool get_Phase_frequency_user();
public: __property void set_Phase_frequency_user(
   bool value
);
C++/CLI
public:
property bool Phase_frequency_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phase_id Property

Glossary Item Box

The database row unique ID of the Phase.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phase_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

value = instance.Phase_id
C#
public int Phase_id {get;}
Managed Extensions for C++
public: __property int get_Phase_id();
C++/CLI
public:
property int Phase_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.Phase_time = value

value = instance.Phase_time
C#
public int Phase_time {get; set;}
Managed Extensions for C++
public: __property int get_Phase_time();
public: __property void set_Phase_time(
   int value
);
C++/CLI
public:
property int Phase_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phasemovement_peds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phasemovement_peds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phasemovement_peds As ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As ISIAPIPhasemovement_peds

value = instance.Phasemovement_peds
C#
public ISIAPIPhasemovement_peds Phasemovement_peds {get;}
Managed Extensions for C++
public: __property ISIAPIPhasemovement_peds* get_Phasemovement_peds();
C++/CLI
public:
property ISIAPIPhasemovement_peds^ Phasemovement_peds {
   ISIAPIPhasemovement_peds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phasemovement_vehicles Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Phasemovement_vehicles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phasemovement_vehicles As ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As ISIAPIPhasemovement_vehicles

value = instance.Phasemovement_vehicles
C#
public ISIAPIPhasemovement_vehicles Phasemovement_vehicles {get;}
Managed Extensions for C++
public: __property ISIAPIPhasemovement_vehicles* get_Phasemovement_vehicles();
C++/CLI
public:
property ISIAPIPhasemovement_vehicles^ Phasemovement_vehicles {
   ISIAPIPhasemovement_vehicles^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Position Property

Glossary Item Box

The Phase Position in the Sequence's Phases collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Sequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sequence As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As ISIAPISequence

value = instance.Sequence
C#
public ISIAPISequence Sequence {get;}
Managed Extensions for C++
public: __property ISIAPISequence* get_Sequence();
C++/CLI
public:
property ISIAPISequence^ Sequence {
   ISIAPISequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhase Class : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhase
Dim value As Integer

instance.Yellow_time = value

value = instance.Yellow_time
C#
public int Yellow_time {get; set;}
Managed Extensions for C++
public: __property int get_Yellow_time();
public: __property void set_Yellow_time(
   int value
);
C++/CLI
public:
property int Yellow_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhase Class
SIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_ped Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_ped Class

Glossary Item Box

Object Model

SIAPIPhasemovement_ped ClassISIAPIPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhasemovement_ped
   Implements ISIAPIPhasemovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
C#
public sealed class SIAPIPhasemovement_ped : ISIAPIPhasemovement_ped
Managed Extensions for C++
public __gc __sealed class SIAPIPhasemovement_ped : public ISIAPIPhasemovement_ped
C++/CLI
public ref class SIAPIPhasemovement_ped sealed : public ISIAPIPhasemovement_ped

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhasemovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_ped Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_ped Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhasemovement_ped.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhasemovement_ped Constructor |
Top

Public Properties

 | Name | Description
Public Property | Movement_ped_origin |
Public Property | Movement_ped_stage |
Public Property | Movement_ped_type |
Public Property | Phase |
Public Property | Running |
Public Property | Terminates |
Public Property | Undetected |
Top

See Also

Reference

SIAPIPhasemovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_ped Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : SIAPIPhasemovement_ped Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhasemovement_ped()
C#
public SIAPIPhasemovement_ped()
Managed Extensions for C++
public: SIAPIPhasemovement_ped();
C++/CLI
public:
SIAPIPhasemovement_ped();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_ped Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_ped Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_ped members.

Public Properties

 | Name | Description
Public Property | Movement_ped_origin |
Public Property | Movement_ped_stage |
Public Property | Movement_ped_type |
Public Property | Phase |
Public Property | Running |
Public Property | Terminates |
Public Property | Undetected |
Top

See Also

Reference

SIAPIPhasemovement_ped Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Movement_ped_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_ped_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_origin
C#
public int Movement_ped_origin {get;}
Managed Extensions for C++
public: __property int get_Movement_ped_origin();
C++/CLI
public:
property int Movement_ped_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Movement_ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_stage
C#
public int Movement_ped_stage {get;}
Managed Extensions for C++
public: __property int get_Movement_ped_stage();
C++/CLI
public:
property int Movement_ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Movement_ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_type
C#
public int Movement_ped_type {get;}
Managed Extensions for C++
public: __property int get_Movement_ped_type();
C++/CLI
public:
property int Movement_ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phase As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As ISIAPIPhase

value = instance.Phase
C#
public ISIAPIPhase Phase {get;}
Managed Extensions for C++
public: __property ISIAPIPhase* get_Phase();
C++/CLI
public:
property ISIAPIPhase^ Phase {
   ISIAPIPhase^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Running Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Running As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Boolean

instance.Running = value

value = instance.Running
C#
public bool Running {get; set;}
Managed Extensions for C++
public: __property bool get_Running();
public: __property void set_Running(
   bool value
);
C++/CLI
public:
property bool Running {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminates Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Terminates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Terminates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Boolean

instance.Terminates = value

value = instance.Terminates
C#
public bool Terminates {get; set;}
Managed Extensions for C++
public: __property bool get_Terminates();
public: __property void set_Terminates(
   bool value
);
C++/CLI
public:
property bool Terminates {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_ped Class : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_ped
Dim value As Boolean

instance.Undetected = value

value = instance.Undetected
C#
public bool Undetected {get; set;}
Managed Extensions for C++
public: __property bool get_Undetected();
public: __property void set_Undetected(
   bool value
);
C++/CLI
public:
property bool Undetected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_ped Class
SIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_peds Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_peds Class

Glossary Item Box

Object Model

SIAPIPhasemovement_peds ClassISIAPIPhasemovement_ped Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhasemovement_peds
   Implements ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_peds
C#
public sealed class SIAPIPhasemovement_peds : ISIAPIPhasemovement_peds
Managed Extensions for C++
public __gc __sealed class SIAPIPhasemovement_peds : public ISIAPIPhasemovement_peds
C++/CLI
public ref class SIAPIPhasemovement_peds sealed : public ISIAPIPhasemovement_peds

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhasemovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_peds Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_peds Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhasemovement_peds.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhasemovement_peds Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Phase's Pedestrian Movement.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhasemovementPedExists | Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

SIAPIPhasemovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_peds Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_peds Class : SIAPIPhasemovement_peds Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhasemovement_peds()
C#
public SIAPIPhasemovement_peds()
Managed Extensions for C++
public: SIAPIPhasemovement_peds();
C++/CLI
public:
SIAPIPhasemovement_peds();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Class
SIAPIPhasemovement_peds Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_peds Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_peds members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhasemovementPedExists | Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

SIAPIPhasemovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_peds Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_peds
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Class
SIAPIPhasemovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhasemovementPedExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_peds Class : PhasemovementPedExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function PhasemovementPedExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.PhasemovementPedExists(type, origin, stage)
C#
public bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
public: bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)
C++/CLI
public:
bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Class
SIAPIPhasemovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_peds Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_peds Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_peds members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Phase's Pedestrian Movement.
Top

See Also

Reference

SIAPIPhasemovement_peds Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_peds Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_peds
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Class
SIAPIPhasemovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_peds Class : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Phase's Pedestrian Movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIPhasemovement_ped
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIPhasemovement_ped

value = instance.Item(type, origin, stage)
C#
public ISIAPIPhasemovement_ped this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
public: __property ISIAPIPhasemovement_ped* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
public:
property ISIAPIPhasemovement_ped^ default [int,int,int] {
   ISIAPIPhasemovement_ped^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Property Value

Return a Phase's Pedestrian Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_peds Class
SIAPIPhasemovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicle Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicle Class

Glossary Item Box

Object Model

SIAPIPhasemovement_vehicle ClassISIAPIPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhasemovement_vehicle
   Implements ISIAPIPhasemovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
C#
public sealed class SIAPIPhasemovement_vehicle : ISIAPIPhasemovement_vehicle
Managed Extensions for C++
public __gc __sealed class SIAPIPhasemovement_vehicle : public ISIAPIPhasemovement_vehicle
C++/CLI
public ref class SIAPIPhasemovement_vehicle sealed : public ISIAPIPhasemovement_vehicle

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhasemovement_vehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicle Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicle Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhasemovement_vehicle.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhasemovement_vehicle Constructor |
Top

Public Properties

 | Name | Description
Public Property | MC_class |
Public Property | Movement_vehicle_destination |
Public Property | Movement_vehicle_origin |
Public Property | Phase |
Public Property | Running |
Public Property | Terminates |
Public Property | Undetected |
Top

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicle Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : SIAPIPhasemovement_vehicle Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhasemovement_vehicle()
C#
public SIAPIPhasemovement_vehicle()
Managed Extensions for C++
public: SIAPIPhasemovement_vehicle();
C++/CLI
public:
SIAPIPhasemovement_vehicle();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicle Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicle Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_vehicle members.

Public Properties

 | Name | Description
Public Property | MC_class |
Public Property | Movement_vehicle_destination |
Public Property | Movement_vehicle_origin |
Public Property | Phase |
Public Property | Running |
Public Property | Terminates |
Public Property | Undetected |
Top

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.MC_class
C#
public int MC_class {get;}
Managed Extensions for C++
public: __property int get_MC_class();
C++/CLI
public:
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Movement_vehicle_destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_vehicle_destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.Movement_vehicle_destination
C#
public int Movement_vehicle_destination {get;}
Managed Extensions for C++
public: __property int get_Movement_vehicle_destination();
C++/CLI
public:
property int Movement_vehicle_destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Movement_vehicle_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_vehicle_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.Movement_vehicle_origin
C#
public int Movement_vehicle_origin {get;}
Managed Extensions for C++
public: __property int get_Movement_vehicle_origin();
C++/CLI
public:
property int Movement_vehicle_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phase As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As ISIAPIPhase

value = instance.Phase
C#
public ISIAPIPhase Phase {get;}
Managed Extensions for C++
public: __property ISIAPIPhase* get_Phase();
C++/CLI
public:
property ISIAPIPhase^ Phase {
   ISIAPIPhase^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Running Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Running As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Running = value

value = instance.Running
C#
public bool Running {get; set;}
Managed Extensions for C++
public: __property bool get_Running();
public: __property void set_Running(
   bool value
);
C++/CLI
public:
property bool Running {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminates Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Terminates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Terminates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Terminates = value

value = instance.Terminates
C#
public bool Terminates {get; set;}
Managed Extensions for C++
public: __property bool get_Terminates();
public: __property void set_Terminates(
   bool value
);
C++/CLI
public:
property bool Terminates {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicle Class : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Undetected = value

value = instance.Undetected
C#
public bool Undetected {get; set;}
Managed Extensions for C++
public: __property bool get_Undetected();
public: __property void set_Undetected(
   bool value
);
C++/CLI
public:
property bool Undetected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicle Class
SIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicles Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicles Class

Glossary Item Box

Object Model

SIAPIPhasemovement_vehicles ClassISIAPIPhasemovement_vehicle Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhasemovement_vehicles
   Implements ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicles
C#
public sealed class SIAPIPhasemovement_vehicles : ISIAPIPhasemovement_vehicles
Managed Extensions for C++
public __gc __sealed class SIAPIPhasemovement_vehicles : public ISIAPIPhasemovement_vehicles
C++/CLI
public ref class SIAPIPhasemovement_vehicles sealed : public ISIAPIPhasemovement_vehicles

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhasemovement_vehicles

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicles Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicles Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhasemovement_vehicles.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhasemovement_vehicles Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Phase's Vehicle Movement.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhasemovementVehicleExists | Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.
Top

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicles Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicles Class : SIAPIPhasemovement_vehicles Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhasemovement_vehicles()
C#
public SIAPIPhasemovement_vehicles()
Managed Extensions for C++
public: SIAPIPhasemovement_vehicles();
C++/CLI
public:
SIAPIPhasemovement_vehicles();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIAPIPhasemovement_vehicles Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicles Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicles Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_vehicles members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | PhasemovementVehicleExists | Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.
Top

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicles Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicles
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIAPIPhasemovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhasemovementVehicleExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicles Class : PhasemovementVehicleExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function PhasemovementVehicleExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer, _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicles
Dim origin As Integer
Dim destination As Integer
Dim mcClass As Integer
Dim value As Boolean

value = instance.PhasemovementVehicleExists(origin, destination, mcClass)
C#
public bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)
Managed Extensions for C++
public: bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)
C++/CLI
public:
bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIAPIPhasemovement_vehicles Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhasemovement_vehicles Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhasemovement_vehicles Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhasemovement_vehicles members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get a Phase's Vehicle Movement.
Top

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicles Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicles
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIAPIPhasemovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhasemovement_vehicles Class : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a Phase's Vehicle Movement.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer, _
   ByVal mcClass As Integer _
) As ISIAPIPhasemovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhasemovement_vehicles
Dim origin As Integer
Dim destination As Integer
Dim mcClass As Integer
Dim value As ISIAPIPhasemovement_vehicle

value = instance.Item(origin, destination, mcClass)
C#
public ISIAPIPhasemovement_vehicle this[
   int origin,
   int destination,
   int mcClass
]; {get;}
Managed Extensions for C++
public: __property ISIAPIPhasemovement_vehicle* get_Item   int origin,
   int destination,
   int mcClass
;
C++/CLI
public:
property ISIAPIPhasemovement_vehicle^ default [int,int,int] {
   ISIAPIPhasemovement_vehicle^ get(int origin, int destination, int mcClass);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Property Value

Return a Phase's Vehicle Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhasemovement_vehicles Class
SIAPIPhasemovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhases Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhases Class

Glossary Item Box

Object Model

SIAPIPhases ClassISIAPIPhase Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIPhases
   Implements ISIAPIPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
C#
public sealed class SIAPIPhases : ISIAPIPhases
Managed Extensions for C++
public __gc __sealed class SIAPIPhases : public ISIAPIPhases
C++/CLI
public ref class SIAPIPhases sealed : public ISIAPIPhases

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhases Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhases Class

Glossary Item Box

The following tables list the members exposed by SIAPIPhases.

Public Constructors

 | Name | Description
Public Constructor | SIAPIPhases Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GetPhaseByID |
Public Method | PhaseExists |
Top

See Also

Reference

SIAPIPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhases Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : SIAPIPhases Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIPhases()
C#
public SIAPIPhases()
Managed Extensions for C++
public: SIAPIPhases();
C++/CLI
public:
SIAPIPhases();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhases Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhases members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GetPhaseByID |
Public Method | PhaseExists |
Top

See Also

Reference

SIAPIPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhaseByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : GetPhaseByID Method

phase_id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPhaseByID( _
   ByVal phase_id As Integer _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim phase_id As Integer
Dim value As ISIAPIPhase

value = instance.GetPhaseByID(phase_id)
C#
public ISIAPIPhase GetPhaseByID(
   int phase_id
)
Managed Extensions for C++
public: ISIAPIPhase* GetPhaseByID(
   int phase_id
)
C++/CLI
public:
ISIAPIPhase^ GetPhaseByID(
   int phase_id
)

Parameters

phase_id

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhaseExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : PhaseExists Method

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PhaseExists( _
   ByVal phasename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim phasename As String
Dim value As Boolean

value = instance.PhaseExists(phasename)
C#
public bool PhaseExists(
   string phasename
)
Managed Extensions for C++
public: bool PhaseExists(
   string* phasename
)
C++/CLI
public:
bool PhaseExists(
   String^ phasename
)

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIPhases Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIPhases Class

Glossary Item Box

For a list of all members of this type, see SIAPIPhases members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIPhases Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class > Item Property : Item(String) Property

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal phasename As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim phasename As String
Dim value As ISIAPIPhase

value = instance.Item(phasename)
C#
public ISIAPIPhase Item(
   string phasename
) {get;}
Managed Extensions for C++
public: __property ISIAPIPhase* get_Item(
   string* phasename
);
C++/CLI
public:
property ISIAPIPhase^ Item {
   ISIAPIPhase^ get(String^ phasename);
}

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIPhases Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPIPhases
Dim index As Integer
Dim value As ISIAPIPhase

value = instance.Item(index)
C#
public ISIAPIPhase Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIPhase* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIPhase^ Item {
   ISIAPIPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIPhases Class
SIAPIPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIProject Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIProject Class

Glossary Item Box

SIDRA INTERSECTION Project wrapper class

Object Model

SIAPIProject ClassISIAPINetworks InterfaceISIAPINetwork InterfaceISIAPISites InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIProject
   Implements ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
C#
public sealed class SIAPIProject : ISIAPIProject
Managed Extensions for C++
public __gc __sealed class SIAPIProject : public ISIAPIProject
C++/CLI
public ref class SIAPIProject sealed : public ISIAPIProject

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIProject

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIProject Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIProject Class

Glossary Item Box

The following tables list the members exposed by SIAPIProject.

Public Constructors

 | Name | Description
Public Constructor | SIAPIProject Constructor |
Top

Public Properties

 | Name | Description
Public Property | LastErrorMessage |
Public Property | Name | Project name
Public Property | Networks | Collection of Networks in the current Project
Public Property | Sites | Collection of Sites in the current Project
Top

Public Methods

 | Name | Description
Public Method | AddNetwork | Overloaded. Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
Public Method | AddSite | Overloaded. Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
Public Method | AddSiteWithGeometry | Overloaded. Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
Public Method | CloneNetwork | Clone a Network.
Public Method | CloneNetworkWithSites | Clone a Network with its Sites.
Public Method | CloneSite | Clone a Site.
Public Method | ImportNetworksFromProject | Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.
Public Method | ImportSitesFromProject | Import Site(s) from another Project file into this Project file.
Public Method | MoveNetworkTo | Move a Network to a new position.
Public Method | MoveSiteTo | Move a Site to a new position.
Public Method | RemoveNetwork | Remove a Network from the Project.
Public Method | RemoveSite | Remove a Site from the Project.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPIProject Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIProject Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : SIAPIProject Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIProject()
C#
public SIAPIProject()
Managed Extensions for C++
public: SIAPIProject();
C++/CLI
public:
SIAPIProject();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIProject Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIProject Class

Glossary Item Box

For a list of all members of this type, see SIAPIProject members.

Public Methods

 | Name | Description
Public Method | AddNetwork | Overloaded. Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
Public Method | AddSite | Overloaded. Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
Public Method | AddSiteWithGeometry | Overloaded. Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
Public Method | CloneNetwork | Clone a Network.
Public Method | CloneNetworkWithSites | Clone a Network with its Sites.
Public Method | CloneSite | Clone a Site.
Public Method | ImportNetworksFromProject | Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.
Public Method | ImportSitesFromProject | Import Site(s) from another Project file into this Project file.
Public Method | MoveNetworkTo | Move a Network to a new position.
Public Method | MoveSiteTo | Move a Site to a new position.
Public Method | RemoveNetwork | Remove a Network from the Project.
Public Method | RemoveSite | Remove a Site from the Project.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPIProject Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : AddNetwork Method

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.

Overload List

Overload | Description
AddNetwork(Int32) | Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
AddNetwork(String) | Add a new Network into the Project. The new Network does not include any Sites. It is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork(Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddNetwork Method : AddNetwork(Int32) Method

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Network.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddNetwork( _
   ByVal softwareSetup As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim softwareSetup As Integer
Dim value As ISIAPINetwork

value = instance.AddNetwork(softwareSetup)
C#
public ISIAPINetwork AddNetwork(
   int softwareSetup
)
Managed Extensions for C++
public: ISIAPINetwork* AddNetwork(
   int softwareSetup
)
C++/CLI
public:
ISIAPINetwork^ AddNetwork(
   int softwareSetup
)

Parameters

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Network.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Return Value

The new added Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork(String) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddNetwork Method : AddNetwork(String) Method

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddNetwork( _
   ByVal softwareSetupSignature As String _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim softwareSetupSignature As String
Dim value As ISIAPINetwork

value = instance.AddNetwork(softwareSetupSignature)
C#
public ISIAPINetwork AddNetwork(
   string softwareSetupSignature
)
Managed Extensions for C++
public: ISIAPINetwork* AddNetwork(
   string* softwareSetupSignature
)
C++/CLI
public:
ISIAPINetwork^ AddNetwork(
   String^ softwareSetupSignature
)

Parameters

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Return Value

The new added Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : AddSite Method

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a Standard Software Setup.

Overload List

Overload | Description
AddSite(Int32,Int32) | Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
AddSite(Int32,String) | Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite(Int32,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddSite Method : AddSite(Int32,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddSite( _
   ByVal siteType As Integer, _
   ByVal softwareSetup As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim siteType As Integer
Dim softwareSetup As Integer
Dim value As ISIAPISite

value = instance.AddSite(siteType, softwareSetup)
C#
public ISIAPISite AddSite(
   int siteType,
   int softwareSetup
)
Managed Extensions for C++
public: ISIAPISite* AddSite(
   int siteType,
   int softwareSetup
)
C++/CLI
public:
ISIAPISite^ AddSite(
   int siteType,
   int softwareSetup
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Return Value

The new added Site.

Remarks

"Single Point Interchange" or "Pedestrian Crossing" Site cannot be created by this method. Use the method AddSiteWithGeometry() to add these Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite(Int32,String) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddSite Method : AddSite(Int32,String) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddSite( _
   ByVal siteType As Integer, _
   ByVal softwareSetupSignature As String _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim siteType As Integer
Dim softwareSetupSignature As String
Dim value As ISIAPISite

value = instance.AddSite(siteType, softwareSetupSignature)
C#
public ISIAPISite AddSite(
   int siteType,
   string softwareSetupSignature
)
Managed Extensions for C++
public: ISIAPISite* AddSite(
   int siteType,
   string* softwareSetupSignature
)
C++/CLI
public:
ISIAPISite^ AddSite(
   int siteType,
   String^ softwareSetupSignature
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Return Value

The new added Site.

Remarks

"Single Point Interchange" or "Pedestrian Crossing" Site cannot be created by this method. Use the method AddSiteWithGeometry() to add these Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : AddSiteWithGeometry Method

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a Standard Software Setup.

Overload List

Overload | Description
AddSiteWithGeometry(Int32,Int32,Int32) | Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
AddSiteWithGeometry(Int32,String,Int32) | Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry(Int32,Int32,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddSiteWithGeometry Method : AddSiteWithGeometry(Int32,Int32,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddSiteWithGeometry( _
   ByVal siteType As Integer, _
   ByVal softwareSetup As Integer, _
   ByVal majorRoadOrientation As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim siteType As Integer
Dim softwareSetup As Integer
Dim majorRoadOrientation As Integer
Dim value As ISIAPISite

value = instance.AddSiteWithGeometry(siteType, softwareSetup, majorRoadOrientation)
C#
public ISIAPISite AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)
Managed Extensions for C++
public: ISIAPISite* AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)
C++/CLI
public:
ISIAPISite^ AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Return Value

The new added Site.

Remarks

If the default Legs do not match the actual Geometry Layout, they can be changed by rotating the Site, removing Leg(s) or adding Leg(s) to the Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry(Int32,String,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class > AddSiteWithGeometry Method : AddSiteWithGeometry(Int32,String,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Public Overloads Function AddSiteWithGeometry( _
   ByVal siteType As Integer, _
   ByVal softwareSetupSignature As String, _
   ByVal majorRoadOrientation As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim siteType As Integer
Dim softwareSetupSignature As String
Dim majorRoadOrientation As Integer
Dim value As ISIAPISite

value = instance.AddSiteWithGeometry(siteType, softwareSetupSignature, majorRoadOrientation)
C#
public ISIAPISite AddSiteWithGeometry(
   int siteType,
   string softwareSetupSignature,
   int majorRoadOrientation
)
Managed Extensions for C++
public: ISIAPISite* AddSiteWithGeometry(
   int siteType,
   string* softwareSetupSignature,
   int majorRoadOrientation
)
C++/CLI
public:
ISIAPISite^ AddSiteWithGeometry(
   int siteType,
   String^ softwareSetupSignature,
   int majorRoadOrientation
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Return Value

The new added Site.

Remarks

If the default Legs do not match the actual Geometry Layout, they can be changed by rotating the Site, removing Leg(s) or adding Leg(s) to the Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : CloneNetwork Method

network
The Network to be cloned.

Glossary Item Box

Clone a Network.

Syntax

Visual Basic (Declaration)
Public Function CloneNetwork( _
   ByVal network As ISIAPINetwork _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim network As ISIAPINetwork
Dim value As ISIAPINetwork

value = instance.CloneNetwork(network)
C#
public ISIAPINetwork CloneNetwork(
   ISIAPINetwork network
)
Managed Extensions for C++
public: ISIAPINetwork* CloneNetwork(
   ISIAPINetwork* network
)
C++/CLI
public:
ISIAPINetwork^ CloneNetwork(
   ISIAPINetwork^ network
)

Parameters

network
The Network to be cloned.

Return Value

The new cloned Network.

Remarks

This funciton will create a new Network with the same Sites as those in the original Network, i.e. the Sites will not be cloned.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneNetworkWithSites Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : CloneNetworkWithSites Method

network
The Network to be cloned.

Glossary Item Box

Clone a Network with its Sites.

Syntax

Visual Basic (Declaration)
Public Function CloneNetworkWithSites( _
   ByVal network As ISIAPINetwork _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim network As ISIAPINetwork
Dim value As ISIAPINetwork

value = instance.CloneNetworkWithSites(network)
C#
public ISIAPINetwork CloneNetworkWithSites(
   ISIAPINetwork network
)
Managed Extensions for C++
public: ISIAPINetwork* CloneNetworkWithSites(
   ISIAPINetwork* network
)
C++/CLI
public:
ISIAPINetwork^ CloneNetworkWithSites(
   ISIAPINetwork^ network
)

Parameters

network
The Network to be cloned.

Return Value

The new cloned Network.

Remarks

This function will clone the Network and its Sites as well, i.e. there will be new cloned Sites in the new cloned Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : CloneSite Method

site
The Site to be cloned.

Glossary Item Box

Clone a Site.

Syntax

Visual Basic (Declaration)
Public Function CloneSite( _
   ByVal site As ISIAPISite _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim site As ISIAPISite
Dim value As ISIAPISite

value = instance.CloneSite(site)
C#
public ISIAPISite CloneSite(
   ISIAPISite site
)
Managed Extensions for C++
public: ISIAPISite* CloneSite(
   ISIAPISite* site
)
C++/CLI
public:
ISIAPISite^ CloneSite(
   ISIAPISite^ site
)

Parameters

site
The Site to be cloned.

Return Value

The new cloned Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ImportNetworksFromProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : ImportNetworksFromProject Method

projectFilePath
The file path of the other Project file.
networkNames

The name(s) of the Network(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Network 1"
  • "Network 1;Network 2"
  • "Network 1;Network 2;Network;; Test"

Glossary Item Box

Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.

Syntax

Visual Basic (Declaration)
Public Function ImportNetworksFromProject( _
   ByVal projectFilePath As String, _
   ByVal networkNames As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim projectFilePath As String
Dim networkNames As String
Dim value As Integer

value = instance.ImportNetworksFromProject(projectFilePath, networkNames)
C#
public int ImportNetworksFromProject(
   string projectFilePath,
   string networkNames
)
Managed Extensions for C++
public: int ImportNetworksFromProject(
   string* projectFilePath,
   string* networkNames
)
C++/CLI
public:
int ImportNetworksFromProject(
   String^ projectFilePath,
   String^ networkNames
)

Parameters

projectFilePath
The file path of the other Project file.
networkNames

The name(s) of the Network(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Network 1"
  • "Network 1;Network 2"
  • "Network 1;Network 2;Network;; Test"

Return Value

The number of successfully imported Networks

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ImportSitesFromProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : ImportSitesFromProject Method

projectFilePath
The file path of the other Project file.
siteNames

The name(s) of the Site(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Site 1"
  • "Site 1;Site 2"
  • "Site 1;Site 2;Site;; Test"

Glossary Item Box

Import Site(s) from another Project file into this Project file.

Syntax

Visual Basic (Declaration)
Public Function ImportSitesFromProject( _
   ByVal projectFilePath As String, _
   ByVal siteNames As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim projectFilePath As String
Dim siteNames As String
Dim value As Integer

value = instance.ImportSitesFromProject(projectFilePath, siteNames)
C#
public int ImportSitesFromProject(
   string projectFilePath,
   string siteNames
)
Managed Extensions for C++
public: int ImportSitesFromProject(
   string* projectFilePath,
   string* siteNames
)
C++/CLI
public:
int ImportSitesFromProject(
   String^ projectFilePath,
   String^ siteNames
)

Parameters

projectFilePath
The file path of the other Project file.
siteNames

The name(s) of the Site(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Site 1"
  • "Site 1;Site 2"
  • "Site 1;Site 2;Site;; Test"

Return Value

The number of successfully imported Sites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveNetworkTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : MoveNetworkTo Method

network
The Network to move.
newPosition
The zero-based position that the Network should be moved to.

Glossary Item Box

Move a Network to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveNetworkTo( _
   ByVal network As ISIAPINetwork, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim network As ISIAPINetwork
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveNetworkTo(network, newPosition)
C#
public bool MoveNetworkTo(
   ISIAPINetwork network,
   int newPosition
)
Managed Extensions for C++
public: bool MoveNetworkTo(
   ISIAPINetwork* network,
   int newPosition
)
C++/CLI
public:
bool MoveNetworkTo(
   ISIAPINetwork^ network,
   int newPosition
)

Parameters

network
The Network to move.
newPosition
The zero-based position that the Network should be moved to.

Return Value

true if the Network is successfully moved; otherwise, false. This method also returns false if the Network was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveSiteTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : MoveSiteTo Method

site
The Site to move.
newPosition
The zero-based position that the Site should be moved to.

Glossary Item Box

Move a Site to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveSiteTo( _
   ByVal site As ISIAPISite, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim site As ISIAPISite
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveSiteTo(site, newPosition)
C#
public bool MoveSiteTo(
   ISIAPISite site,
   int newPosition
)
Managed Extensions for C++
public: bool MoveSiteTo(
   ISIAPISite* site,
   int newPosition
)
C++/CLI
public:
bool MoveSiteTo(
   ISIAPISite^ site,
   int newPosition
)

Parameters

site
The Site to move.
newPosition
The zero-based position that the Site should be moved to.

Return Value

true if the Site is successfully moved; otherwise, false. This method also returns false if the Site was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : RemoveNetwork Method

network
The Network to remove.

Glossary Item Box

Remove a Network from the Project.

Syntax

Visual Basic (Declaration)
Public Function RemoveNetwork( _
   ByVal network As ISIAPINetwork _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim network As ISIAPINetwork
Dim value As Boolean

value = instance.RemoveNetwork(network)
C#
public bool RemoveNetwork(
   ISIAPINetwork network
)
Managed Extensions for C++
public: bool RemoveNetwork(
   ISIAPINetwork* network
)
C++/CLI
public:
bool RemoveNetwork(
   ISIAPINetwork^ network
)

Parameters

network
The Network to remove.

Return Value

true if the Network is successfully removed; otherwise, false. This method also returns false if the Network was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : RemoveSite Method

site
The Site to remove.

Glossary Item Box

Remove a Site from the Project.

Syntax

Visual Basic (Declaration)
Public Function RemoveSite( _
   ByVal site As ISIAPISite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim site As ISIAPISite
Dim value As Boolean

value = instance.RemoveSite(site)
C#
public bool RemoveSite(
   ISIAPISite site
)
Managed Extensions for C++
public: bool RemoveSite(
   ISIAPISite* site
)
C++/CLI
public:
bool RemoveSite(
   ISIAPISite^ site
)

Parameters

site
The Site to remove.

Return Value

true if the Site is successfully removed; otherwise, false. This method also returns false if the Site was not found in the Project.

Remarks

The Site cannot be used in any Networks.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Public Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
public bool UpdateModifiedInfo()
Managed Extensions for C++
public: bool UpdateModifiedInfo();
C++/CLI
public:
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIProject Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIProject Class

Glossary Item Box

For a list of all members of this type, see SIAPIProject members.

Public Properties

 | Name | Description
Public Property | LastErrorMessage |
Public Property | Name | Project name
Public Property | Networks | Collection of Networks in the current Project
Public Property | Sites | Collection of Sites in the current Project
Top

See Also

Reference

SIAPIProject Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : Name Property

Glossary Item Box

Project name

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim value As String

value = instance.Name
C#
public string Name {get;}
Managed Extensions for C++
public: __property string* get_Name();
C++/CLI
public:
property String^ Name {
   String^ get();
}

Property Value

Type: System.String

Project name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Networks Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : Networks Property

Glossary Item Box

Collection of Networks in the current Project

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Networks As ISIAPINetworks
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim value As ISIAPINetworks

value = instance.Networks
C#
public ISIAPINetworks Networks {get;}
Managed Extensions for C++
public: __property ISIAPINetworks* get_Networks();
C++/CLI
public:
property ISIAPINetworks^ Networks {
   ISIAPINetworks^ get();
}

Property Value

Type: ISIAPINetworks

Networks collection

Remarks

Configuring, processing and viewing output for a Network with more than two Sites requires a NETWORK version of the SIDRA INTERSECTION licence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIProject Class : Sites Property

Glossary Item Box

Collection of Sites in the current Project

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sites As ISIAPISites
Visual Basic (Usage) Copy Code
Dim instance As SIAPIProject
Dim value As ISIAPISites

value = instance.Sites
C#
public ISIAPISites Sites {get;}
Managed Extensions for C++
public: __property ISIAPISites* get_Sites();
C++/CLI
public:
property ISIAPISites^ Sites {
   ISIAPISites^ get();
}

Property Value

Type: ISIAPISites

Sites collection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIProject Class
SIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoute Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoute Class

Glossary Item Box

Object Model

SIAPIRoute ClassISIAPINetwork InterfaceISIAPIOutputNetwork InterfaceISIAPIRouteNwSites InterfaceISIAPIRouteNwSite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIRoute
   Implements ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
C#
public sealed class SIAPIRoute : ISIAPIRoute
Managed Extensions for C++
public __gc __sealed class SIAPIRoute : public ISIAPIRoute
C++/CLI
public ref class SIAPIRoute sealed : public ISIAPIRoute

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIRoute

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoute Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoute Class

Glossary Item Box

The following tables list the members exposed by SIAPIRoute.

Public Constructors

 | Name | Description
Public Constructor | SIAPIRoute Constructor |
Top

Public Properties

 | Name | Description
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod | Desired Speed Method
Public Property | IsIncludedInOutputNetworkByRoutes |
Public Property | IsIncludedInProjectSummary |
Public Property | IsIncludedInSignalOffsetCal |
Public Property | LastErrorMessage |
Public Property | LOSMethod | Network Level of Service Method
Public Property | LowerLimitOfSpeedEfficiency |
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | Name |
Public Property | Network |
Public Property | OutputRoute | Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.
Public Property | Position | The Route Position in the Network's Routes collection. It is a zero-base integer.
Public Property | RouteID |
Public Property | RouteNwSites | Collection of Network Sites in the Route
Public Property | RouteSummaryOption | Route Summary Output Option
Public Property | SignalOffsetCalMCClass | Movement Class in this Route for the program calculation of Signal Offsets
Public Property | SignalOffsetMethod | The method of this Route for the program calculation of Signal Offsets
Public Property | SignalOffsetPriority | The zero-based priority of the Route in the Signal Offset Calculation.
Public Property | Title |
Top

Public Methods

 | Name | Description
Public Method | AddRouteNwSite | Add a Network Site to the Route to build the path of the Route.
Public Method | CheckIsValidForSignalOffsetCalc |
Public Method | Process | Process this Route. The Network needs to be processed before Route statistics can be calculated. If the Network has not been processed, process the Network. The Routes in the Network will be processed as well. If the Route is created after the Network is processed, call this method to process this Route only.
Public Method | RemoveRouteNwSite | Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPIRoute Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoute Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : SIAPIRoute Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIRoute()
C#
public SIAPIRoute()
Managed Extensions for C++
public: SIAPIRoute();
C++/CLI
public:
SIAPIRoute();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoute Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoute Class

Glossary Item Box

For a list of all members of this type, see SIAPIRoute members.

Public Methods

 | Name | Description
Public Method | AddRouteNwSite | Add a Network Site to the Route to build the path of the Route.
Public Method | CheckIsValidForSignalOffsetCalc |
Public Method | Process | Process this Route. The Network needs to be processed before Route statistics can be calculated. If the Network has not been processed, process the Network. The Routes in the Network will be processed as well. If the Route is created after the Network is processed, call this method to process this Route only.
Public Method | RemoveRouteNwSite | Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPIRoute Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddRouteNwSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : AddRouteNwSite Method

networkSite
The Network Site to add into the Route
origin
The origin of the vehicle movement on the Network Site that will be added into the Route
destination
The destination of the vehicle movement on the Network Site that will be added into the Route

Glossary Item Box

Add a Network Site to the Route to build the path of the Route.

Syntax

Visual Basic (Declaration)
Public Function AddRouteNwSite( _
   ByVal networkSite As ISIAPINetworkSite, _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim networkSite As ISIAPINetworkSite
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIRouteNwSite

value = instance.AddRouteNwSite(networkSite, origin, destination)
C#
public ISIAPIRouteNwSite AddRouteNwSite(
   ISIAPINetworkSite networkSite,
   int origin,
   int destination
)
Managed Extensions for C++
public: ISIAPIRouteNwSite* AddRouteNwSite(
   ISIAPINetworkSite* networkSite,
   int origin,
   int destination
)
C++/CLI
public:
ISIAPIRouteNwSite^ AddRouteNwSite(
   ISIAPINetworkSite^ networkSite,
   int origin,
   int destination
)

Parameters

networkSite
The Network Site to add into the Route
origin
The origin of the vehicle movement on the Network Site that will be added into the Route
destination
The destination of the vehicle movement on the Network Site that will be added into the Route

Return Value

A new added RouteNwSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CheckIsValidForSignalOffsetCalc Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : CheckIsValidForSignalOffsetCalc Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CheckIsValidForSignalOffsetCalc() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

value = instance.CheckIsValidForSignalOffsetCalc()
C#
public bool CheckIsValidForSignalOffsetCalc()
Managed Extensions for C++
public: bool CheckIsValidForSignalOffsetCalc();
C++/CLI
public:
bool CheckIsValidForSignalOffsetCalc();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Process Method

Glossary Item Box

Process this Route. The Network needs to be processed before Route statistics can be calculated.
If the Network has not been processed, process the Network. The Routes in the Network will be processed as well.
If the Route is created after the Network is processed, call this method to process this Route only.

Syntax

Visual Basic (Declaration)
Public Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

value = instance.Process()
C#
public bool Process()
Managed Extensions for C++
public: bool Process();
C++/CLI
public:
bool Process();

Return Value

true if this Route is processed successfully.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveRouteNwSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : RemoveRouteNwSite Method

routeNwSite
The Network Site to remove.

Glossary Item Box

Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.

Syntax

Visual Basic (Declaration)
Public Function RemoveRouteNwSite( _
   ByVal routeNwSite As ISIAPIRouteNwSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim routeNwSite As ISIAPIRouteNwSite
Dim value As Boolean

value = instance.RemoveRouteNwSite(routeNwSite)
C#
public bool RemoveRouteNwSite(
   ISIAPIRouteNwSite routeNwSite
)
Managed Extensions for C++
public: bool RemoveRouteNwSite(
   ISIAPIRouteNwSite* routeNwSite
)
C++/CLI
public:
bool RemoveRouteNwSite(
   ISIAPIRouteNwSite^ routeNwSite
)

Parameters

routeNwSite
The Network Site to remove.

Return Value

true if the Network Site is successfully removed; otherwise, false. This method also returns false if the Network Site was not found in this Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Public Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
public bool UpdateModifiedInfo()
Managed Extensions for C++
public: bool UpdateModifiedInfo();
C++/CLI
public:
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoute Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoute Class

Glossary Item Box

For a list of all members of this type, see SIAPIRoute members.

Public Properties

 | Name | Description
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | DesiredSpeed |
Public Property | DesiredSpeedMethod | Desired Speed Method
Public Property | IsIncludedInOutputNetworkByRoutes |
Public Property | IsIncludedInProjectSummary |
Public Property | IsIncludedInSignalOffsetCal |
Public Property | LastErrorMessage |
Public Property | LOSMethod | Network Level of Service Method
Public Property | LowerLimitOfSpeedEfficiency |
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | Name |
Public Property | Network |
Public Property | OutputRoute | Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.
Public Property | Position | The Route Position in the Network's Routes collection. It is a zero-base integer.
Public Property | RouteID |
Public Property | RouteNwSites | Collection of Network Sites in the Route
Public Property | RouteSummaryOption | Route Summary Output Option
Public Property | SignalOffsetCalMCClass | Movement Class in this Route for the program calculation of Signal Offsets
Public Property | SignalOffsetMethod | The method of this Route for the program calculation of Signal Offsets
Public Property | SignalOffsetPriority | The zero-based priority of the Route in the Signal Offset Calculation.
Public Property | Title |
Top

See Also

Reference

SIAPIRoute Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Created_by
C#
public string Created_by {get;}
Managed Extensions for C++
public: __property string* get_Created_by();
C++/CLI
public:
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Created_by_company
C#
public string Created_by_company {get;}
Managed Extensions for C++
public: __property string* get_Created_by_company();
C++/CLI
public:
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Date

value = instance.Created_date
C#
public DateTime Created_date {get;}
Managed Extensions for C++
public: __property DateTime get_Created_date();
C++/CLI
public:
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Created_version
C#
public string Created_version {get;}
Managed Extensions for C++
public: __property string* get_Created_version();
C++/CLI
public:
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Single

instance.DesiredSpeed = value

value = instance.DesiredSpeed
C#
public float DesiredSpeed {get; set;}
Managed Extensions for C++
public: __property float get_DesiredSpeed();
public: __property void set_DesiredSpeed(
   float value
);
C++/CLI
public:
property float DesiredSpeed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : DesiredSpeedMethod Property

Glossary Item Box

Desired Speed Method

Syntax

Visual Basic (Declaration)
Public Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.DesiredSpeedMethod = value

value = instance.DesiredSpeedMethod
C#
public int DesiredSpeedMethod {get; set;}
Managed Extensions for C++
public: __property int get_DesiredSpeedMethod();
public: __property void set_DesiredSpeedMethod(
   int value
);
C++/CLI
public:
property int DesiredSpeedMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = User Input,
1 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInOutputNetworkByRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : IsIncludedInOutputNetworkByRoutes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInOutputNetworkByRoutes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

instance.IsIncludedInOutputNetworkByRoutes = value

value = instance.IsIncludedInOutputNetworkByRoutes
C#
public bool IsIncludedInOutputNetworkByRoutes {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInOutputNetworkByRoutes();
public: __property void set_IsIncludedInOutputNetworkByRoutes(
   bool value
);
C++/CLI
public:
property bool IsIncludedInOutputNetworkByRoutes {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
public bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInProjectSummary();
public: __property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
public:
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInSignalOffsetCal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : IsIncludedInSignalOffsetCal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInSignalOffsetCal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Boolean

instance.IsIncludedInSignalOffsetCal = value

value = instance.IsIncludedInSignalOffsetCal
C#
public bool IsIncludedInSignalOffsetCal {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInSignalOffsetCal();
public: __property void set_IsIncludedInSignalOffsetCal(
   bool value
);
C++/CLI
public:
property bool IsIncludedInSignalOffsetCal {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : LOSMethod Property

Glossary Item Box

Network Level of Service Method

Syntax

Visual Basic (Declaration)
Public Property LOSMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.LOSMethod = value

value = instance.LOSMethod
C#
public int LOSMethod {get; set;}
Managed Extensions for C++
public: __property int get_LOSMethod();
public: __property void set_LOSMethod(
   int value
);
C++/CLI
public:
property int LOSMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = SIDRA Speed Efficiency,
2 = HCM 2010 Speed Efficiency,
3 = HCM 6 Speed Efficiency.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LowerLimitOfSpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : LowerLimitOfSpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property LowerLimitOfSpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Single

instance.LowerLimitOfSpeedEfficiency = value

value = instance.LowerLimitOfSpeedEfficiency
C#
public float LowerLimitOfSpeedEfficiency {get; set;}
Managed Extensions for C++
public: __property float get_LowerLimitOfSpeedEfficiency();
public: __property void set_LowerLimitOfSpeedEfficiency(
   float value
);
C++/CLI
public:
property float LowerLimitOfSpeedEfficiency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Modified_by
C#
public string Modified_by {get;}
Managed Extensions for C++
public: __property string* get_Modified_by();
C++/CLI
public:
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Modified_by_company
C#
public string Modified_by_company {get;}
Managed Extensions for C++
public: __property string* get_Modified_by_company();
C++/CLI
public:
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Date

value = instance.Modified_date
C#
public DateTime Modified_date {get;}
Managed Extensions for C++
public: __property DateTime get_Modified_date();
C++/CLI
public:
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

value = instance.Modified_version
C#
public string Modified_version {get;}
Managed Extensions for C++
public: __property string* get_Modified_version();
C++/CLI
public:
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As ISIAPINetwork

value = instance.Network
C#
public ISIAPINetwork Network {get;}
Managed Extensions for C++
public: __property ISIAPINetwork* get_Network();
C++/CLI
public:
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRoute Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : OutputRoute Property

Glossary Item Box

Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputRoute As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As ISIAPIOutputNetwork

value = instance.OutputRoute
C#
public ISIAPIOutputNetwork OutputRoute {get;}
Managed Extensions for C++
public: __property ISIAPIOutputNetwork* get_OutputRoute();
C++/CLI
public:
property ISIAPIOutputNetwork^ OutputRoute {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Position Property

Glossary Item Box

The Route Position in the Network's Routes collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : RouteID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RouteID As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

instance.RouteID = value

value = instance.RouteID
C#
public string RouteID {get; set;}
Managed Extensions for C++
public: __property string* get_RouteID();
public: __property void set_RouteID(
   string* value
);
C++/CLI
public:
property String^ RouteID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteNwSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : RouteNwSites Property

Glossary Item Box

Collection of Network Sites in the Route

Syntax

Visual Basic (Declaration)
Public ReadOnly Property RouteNwSites As ISIAPIRouteNwSites
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As ISIAPIRouteNwSites

value = instance.RouteNwSites
C#
public ISIAPIRouteNwSites RouteNwSites {get;}
Managed Extensions for C++
public: __property ISIAPIRouteNwSites* get_RouteNwSites();
C++/CLI
public:
property ISIAPIRouteNwSites^ RouteNwSites {
   ISIAPIRouteNwSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteSummaryOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : RouteSummaryOption Property

Glossary Item Box

Route Summary Output Option

Syntax

Visual Basic (Declaration)
Public Property RouteSummaryOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.RouteSummaryOption = value

value = instance.RouteSummaryOption
C#
public int RouteSummaryOption {get; set;}
Managed Extensions for C++
public: __property int get_RouteSummaryOption();
public: __property void set_RouteSummaryOption(
   int value
);
C++/CLI
public:
property int RouteSummaryOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Movements,
2 = Approaches,
3 = Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetCalMCClass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : SignalOffsetCalMCClass Property

Glossary Item Box

Movement Class in this Route for the program calculation of Signal Offsets

Syntax

Visual Basic (Declaration)
Public Property SignalOffsetCalMCClass As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.SignalOffsetCalMCClass = value

value = instance.SignalOffsetCalMCClass
C#
public int SignalOffsetCalMCClass {get; set;}
Managed Extensions for C++
public: __property int get_SignalOffsetCalMCClass();
public: __property void set_SignalOffsetCalMCClass(
   int value
);
C++/CLI
public:
property int SignalOffsetCalMCClass {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : SignalOffsetMethod Property

Glossary Item Box

The method of this Route for the program calculation of Signal Offsets

Syntax

Visual Basic (Declaration)
Public Property SignalOffsetMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.SignalOffsetMethod = value

value = instance.SignalOffsetMethod
C#
public int SignalOffsetMethod {get; set;}
Managed Extensions for C++
public: __property int get_SignalOffsetMethod();
public: __property void set_SignalOffsetMethod(
   int value
);
C++/CLI
public:
property int SignalOffsetMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Start of Green (Leading),
2 = End of Green (Trailing),
3 = Middle of Green,
4 = Simultaneous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetPriority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : SignalOffsetPriority Property

Glossary Item Box

The zero-based priority of the Route in the Signal Offset Calculation.

Syntax

Visual Basic (Declaration)
Public Property SignalOffsetPriority As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As Integer

instance.SignalOffsetPriority = value

value = instance.SignalOffsetPriority
C#
public int SignalOffsetPriority {get; set;}
Managed Extensions for C++
public: __property int get_SignalOffsetPriority();
public: __property void set_SignalOffsetPriority(
   int value
);
C++/CLI
public:
property int SignalOffsetPriority {
   int get();
   void set (    int value);
}

Remarks

When Network Signal Offset Option is set to Program, i.e. SIAPINetwork.SignalOffsetOption = 0, the program will use selected Signal valid Routes to calculate the Signals Offsets. Call SIAPIRoute.CheckIsValidForSignalOffsetCalc() method to determine if the Route is valid for Signal Offset Calculation. This method will initialise the SignalOffsetPriority value. Set SIAPIRoute.IsIncludedInSignalOffsetCal = true to include the Route into the program calculation of Signal Offsets.

If the Route is not valid for the program calculation of Signals Offsets, its SignalOffsetPriority will be larger than 1000 and cannot be changed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoute Class : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoute
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoute Class
SIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSite Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSite Class

Glossary Item Box

Object Model

SIAPIRouteNwSite ClassISIAPINetworkSite InterfaceISIAPIRoute Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIRouteNwSite
   Implements ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
C#
public sealed class SIAPIRouteNwSite : ISIAPIRouteNwSite
Managed Extensions for C++
public __gc __sealed class SIAPIRouteNwSite : public ISIAPIRouteNwSite
C++/CLI
public ref class SIAPIRouteNwSite sealed : public ISIAPIRouteNwSite

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIRouteNwSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSite Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSite Class

Glossary Item Box

The following tables list the members exposed by SIAPIRouteNwSite.

Public Constructors

 | Name | Description
Public Constructor | SIAPIRouteNwSite Constructor |
Top

Public Properties

 | Name | Description
Public Property | Destination |
Public Property | NetworkSite |
Public Property | Origin |
Public Property | Position | The RouteNwSite position in the Route. It is a zero-base integer.
Public Property | Route |
Public Property | SiteName |
Top

See Also

Reference

SIAPIRouteNwSite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSite Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : SIAPIRouteNwSite Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIRouteNwSite()
C#
public SIAPIRouteNwSite()
Managed Extensions for C++
public: SIAPIRouteNwSite();
C++/CLI
public:
SIAPIRouteNwSite();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSite Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSite Class

Glossary Item Box

For a list of all members of this type, see SIAPIRouteNwSite members.

Public Properties

 | Name | Description
Public Property | Destination |
Public Property | NetworkSite |
Public Property | Origin |
Public Property | Position | The RouteNwSite position in the Route. It is a zero-base integer.
Public Property | Route |
Public Property | SiteName |
Top

See Also

Reference

SIAPIRouteNwSite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As Integer

value = instance.Destination
C#
public int Destination {get;}
Managed Extensions for C++
public: __property int get_Destination();
C++/CLI
public:
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : NetworkSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property NetworkSite As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As ISIAPINetworkSite

value = instance.NetworkSite
C#
public ISIAPINetworkSite NetworkSite {get;}
Managed Extensions for C++
public: __property ISIAPINetworkSite* get_NetworkSite();
C++/CLI
public:
property ISIAPINetworkSite^ NetworkSite {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As Integer

value = instance.Origin
C#
public int Origin {get;}
Managed Extensions for C++
public: __property int get_Origin();
C++/CLI
public:
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : Position Property

Glossary Item Box

The RouteNwSite position in the Route. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : Route Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Route As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As ISIAPIRoute

value = instance.Route
C#
public ISIAPIRoute Route {get;}
Managed Extensions for C++
public: __property ISIAPIRoute* get_Route();
C++/CLI
public:
property ISIAPIRoute^ Route {
   ISIAPIRoute^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSite Class : SiteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SiteName As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSite
Dim value As String

value = instance.SiteName
C#
public string SiteName {get;}
Managed Extensions for C++
public: __property string* get_SiteName();
C++/CLI
public:
property String^ SiteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSite Class
SIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSites Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSites Class

Glossary Item Box

Object Model

SIAPIRouteNwSites ClassISIAPIRouteNwSite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIRouteNwSites
   Implements ISIAPIRouteNwSites
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
C#
public sealed class SIAPIRouteNwSites : ISIAPIRouteNwSites
Managed Extensions for C++
public __gc __sealed class SIAPIRouteNwSites : public ISIAPIRouteNwSites
C++/CLI
public ref class SIAPIRouteNwSites sealed : public ISIAPIRouteNwSites

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIRouteNwSites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSites Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSites Class

Glossary Item Box

The following tables list the members exposed by SIAPIRouteNwSites.

Public Constructors

 | Name | Description
Public Constructor | SIAPIRouteNwSites Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | RouteNwSiteExists |
Top

See Also

Reference

SIAPIRouteNwSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSites Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class : SIAPIRouteNwSites Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIRouteNwSites()
C#
public SIAPIRouteNwSites()
Managed Extensions for C++
public: SIAPIRouteNwSites();
C++/CLI
public:
SIAPIRouteNwSites();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSites Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSites Class

Glossary Item Box

For a list of all members of this type, see SIAPIRouteNwSites members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | RouteNwSiteExists |
Top

See Also

Reference

SIAPIRouteNwSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteNwSiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class : RouteNwSiteExists Method

sitename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RouteNwSiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
Dim sitename As String
Dim value As Boolean

value = instance.RouteNwSiteExists(sitename)
C#
public bool RouteNwSiteExists(
   string sitename
)
Managed Extensions for C++
public: bool RouteNwSiteExists(
   string* sitename
)
C++/CLI
public:
bool RouteNwSiteExists(
   String^ sitename
)

Parameters

sitename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRouteNwSites Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRouteNwSites Class

Glossary Item Box

For a list of all members of this type, see SIAPIRouteNwSites members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIRouteNwSites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class > Item Property : Item(String) Property

sitename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
Dim sitename As String
Dim value As ISIAPIRouteNwSite

value = instance.Item(sitename)
C#
public ISIAPIRouteNwSite Item(
   string sitename
) {get;}
Managed Extensions for C++
public: __property ISIAPIRouteNwSite* get_Item(
   string* sitename
);
C++/CLI
public:
property ISIAPIRouteNwSite^ Item {
   ISIAPIRouteNwSite^ get(String^ sitename);
}

Parameters

sitename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRouteNwSites Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRouteNwSites
Dim index As Integer
Dim value As ISIAPIRouteNwSite

value = instance.Item(index)
C#
public ISIAPIRouteNwSite Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIRouteNwSite* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIRouteNwSite^ Item {
   ISIAPIRouteNwSite^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRouteNwSites Class
SIAPIRouteNwSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoutes Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoutes Class

Glossary Item Box

Object Model

SIAPIRoutes ClassISIAPIRoute Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPIRoutes
   Implements ISIAPIRoutes
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
C#
public sealed class SIAPIRoutes : ISIAPIRoutes
Managed Extensions for C++
public __gc __sealed class SIAPIRoutes : public ISIAPIRoutes
C++/CLI
public ref class SIAPIRoutes sealed : public ISIAPIRoutes

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPIRoutes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoutes Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoutes Class

Glossary Item Box

The following tables list the members exposed by SIAPIRoutes.

Public Constructors

 | Name | Description
Public Constructor | SIAPIRoutes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | RouteExists |
Top

See Also

Reference

SIAPIRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoutes Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class : SIAPIRoutes Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPIRoutes()
C#
public SIAPIRoutes()
Managed Extensions for C++
public: SIAPIRoutes();
C++/CLI
public:
SIAPIRoutes();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoutes Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoutes Class

Glossary Item Box

For a list of all members of this type, see SIAPIRoutes members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | RouteExists |
Top

See Also

Reference

SIAPIRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class : RouteExists Method

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RouteExists( _
   ByVal routeName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
Dim routeName As String
Dim value As Boolean

value = instance.RouteExists(routeName)
C#
public bool RouteExists(
   string routeName
)
Managed Extensions for C++
public: bool RouteExists(
   string* routeName
)
C++/CLI
public:
bool RouteExists(
   String^ routeName
)

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPIRoutes Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPIRoutes Class

Glossary Item Box

For a list of all members of this type, see SIAPIRoutes members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Top

See Also

Reference

SIAPIRoutes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class > Item Property : Item(String) Property

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal routeName As String _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
Dim routeName As String
Dim value As ISIAPIRoute

value = instance.Item(routeName)
C#
public ISIAPIRoute Item(
   string routeName
) {get;}
Managed Extensions for C++
public: __property ISIAPIRoute* get_Item(
   string* routeName
);
C++/CLI
public:
property ISIAPIRoute^ Item {
   ISIAPIRoute^ get(String^ routeName);
}

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPIRoutes Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As SIAPIRoutes
Dim index As Integer
Dim value As ISIAPIRoute

value = instance.Item(index)
C#
public ISIAPIRoute Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPIRoute* get_Item(
   int index
);
C++/CLI
public:
property ISIAPIRoute^ Item {
   ISIAPIRoute^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPIRoutes Class
SIAPIRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISensitivity Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISensitivity Class

Glossary Item Box

Object Model

SIAPISensitivity Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPISensitivity
   Implements ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
C#
public sealed class SIAPISensitivity : ISIAPISensitivity
Managed Extensions for C++
public __gc __sealed class SIAPISensitivity : public ISIAPISensitivity
C++/CLI
public ref class SIAPISensitivity sealed : public ISIAPISensitivity

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPISensitivity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISensitivity Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISensitivity Class

Glossary Item Box

The following tables list the members exposed by SIAPISensitivity.

Public Constructors

 | Name | Description
Public Constructor | SIAPISensitivity Constructor |
Top

Public Properties

 | Name | Description
Public Property | Constant_factor |
Public Property | Groupno | Sensitivity Parameter Group Number
Public Property | Increment |
Public Property | Is_constant_factor_applied |
Public Property | Lower |
Public Property | Selected_parameter | Selected Sensitivity Parameter
Public Property | Upper |
Top

See Also

Reference

SIAPISensitivity Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISensitivity Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : SIAPISensitivity Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPISensitivity()
C#
public SIAPISensitivity()
Managed Extensions for C++
public: SIAPISensitivity();
C++/CLI
public:
SIAPISensitivity();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISensitivity Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISensitivity Class

Glossary Item Box

For a list of all members of this type, see SIAPISensitivity members.

Public Properties

 | Name | Description
Public Property | Constant_factor |
Public Property | Groupno | Sensitivity Parameter Group Number
Public Property | Increment |
Public Property | Is_constant_factor_applied |
Public Property | Lower |
Public Property | Selected_parameter | Selected Sensitivity Parameter
Public Property | Upper |
Top

See Also

Reference

SIAPISensitivity Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Single

instance.Constant_factor = value

value = instance.Constant_factor
C#
public float Constant_factor {get; set;}
Managed Extensions for C++
public: __property float get_Constant_factor();
public: __property void set_Constant_factor(
   float value
);
C++/CLI
public:
property float Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Groupno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Groupno Property

Glossary Item Box

Sensitivity Parameter Group Number

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Groupno As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Integer

value = instance.Groupno
C#
public int Groupno {get;}
Managed Extensions for C++
public: __property int get_Groupno();
C++/CLI
public:
property int Groupno {
   int get();
}

Property Value

Type: System.Int32;

0 = General Parameter Group,
1 = Roundabout Parameter Group.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Increment As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Single

instance.Increment = value

value = instance.Increment
C#
public float Increment {get; set;}
Managed Extensions for C++
public: __property float get_Increment();
public: __property void set_Increment(
   float value
);
C++/CLI
public:
property float Increment {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Boolean

instance.Is_constant_factor_applied = value

value = instance.Is_constant_factor_applied
C#
public bool Is_constant_factor_applied {get; set;}
Managed Extensions for C++
public: __property bool get_Is_constant_factor_applied();
public: __property void set_Is_constant_factor_applied(
   bool value
);
C++/CLI
public:
property bool Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Single

instance.Lower = value

value = instance.Lower
C#
public float Lower {get; set;}
Managed Extensions for C++
public: __property float get_Lower();
public: __property void set_Lower(
   float value
);
C++/CLI
public:
property float Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_parameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Selected_parameter Property

Glossary Item Box

Selected Sensitivity Parameter

Syntax

Visual Basic (Declaration)
Public Property Selected_parameter As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Integer

instance.Selected_parameter = value

value = instance.Selected_parameter
C#
public int Selected_parameter {get; set;}
Managed Extensions for C++
public: __property int get_Selected_parameter();
public: __property void set_Selected_parameter(
   int value
);
C++/CLI
public:
property int Selected_parameter {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Critical Gap Follow-up Headway,
2 = Basic Saturation Flow,
3 = Lane Width,
4 = Lane Utilisation Ratio,
5 = Cruise Speed,
6 = Vehicle Queue Space,
7 = Inscribed Diameter,
8 = Entry Angle,
9 = Entry Radius.

Remarks

Values 1 - 6 are only available in General Parameter Group (Group No. = 0). Values 7 - 9 are only available in Roundabout Parameter Group (Group No. = 1)

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISensitivity Class : Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISensitivity
Dim value As Single

instance.Upper = value

value = instance.Upper
C#
public float Upper {get; set;}
Managed Extensions for C++
public: __property float get_Upper();
public: __property void set_Upper(
   float value
);
C++/CLI
public:
property float Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISensitivity Class
SIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequence Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequence Class

Glossary Item Box

Object Model

SIAPISequence ClassISIAPIPhases InterfaceISIAPIPhase InterfaceISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPISequence
   Implements ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
C#
public sealed class SIAPISequence : ISIAPISequence
Managed Extensions for C++
public __gc __sealed class SIAPISequence : public ISIAPISequence
C++/CLI
public ref class SIAPISequence sealed : public ISIAPISequence

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPISequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequence Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequence Class

Glossary Item Box

The following tables list the members exposed by SIAPISequence.

Public Constructors

 | Name | Description
Public Constructor | SIAPISequence Constructor |
Top

Public Properties

 | Name | Description
Public Property | Actuated_gap_major_mov |
Public Property | Actuated_gap_minor_mov |
Public Property | Actuated_max_green_major_mov |
Public Property | Actuated_max_green_minor_mov |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | Eff_det_zone_len_major_mov |
Public Property | Eff_det_zone_len_minor_mov |
Public Property | Green_split_priority_option | Green Split Priority
Public Property | Is_selected |
Public Property | Is_timing_optimised_for_selected_result |
Public Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | Phases |
Public Property | Position | The Sequence Position in the Site's Sequences collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | Sequence_id | The database row unique ID of the Sequence.
Public Property | Site |
Public Property | Usergiven_cycle_time |
Public Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Public Method | AddPhase | Add a new Phase to the end of this Sequence.
Public Method | ClonePhase | Clone a Phase.
Public Method | InsertPhase | Insert a new Phase into this Sequence at the specified position.
Public Method | MovePhaseTo | Move a Phase to a new position.
Public Method | RemovePhase | Remove a Phase from this Sequence.
Top

See Also

Reference

SIAPISequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequence Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : SIAPISequence Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPISequence()
C#
public SIAPISequence()
Managed Extensions for C++
public: SIAPISequence();
C++/CLI
public:
SIAPISequence();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequence Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequence Class

Glossary Item Box

For a list of all members of this type, see SIAPISequence members.

Public Methods

 | Name | Description
Public Method | AddPhase | Add a new Phase to the end of this Sequence.
Public Method | ClonePhase | Clone a Phase.
Public Method | InsertPhase | Insert a new Phase into this Sequence at the specified position.
Public Method | MovePhaseTo | Move a Phase to a new position.
Public Method | RemovePhase | Remove a Phase from this Sequence.
Top

See Also

Reference

SIAPISequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : AddPhase Method

name
The name of the new Phase.

Glossary Item Box

Add a new Phase to the end of this Sequence.

Syntax

Visual Basic (Declaration)
Public Function AddPhase( _
   ByVal name As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim name As String
Dim value As ISIAPIPhase

value = instance.AddPhase(name)
C#
public ISIAPIPhase AddPhase(
   string name
)
Managed Extensions for C++
public: ISIAPIPhase* AddPhase(
   string* name
)
C++/CLI
public:
ISIAPIPhase^ AddPhase(
   String^ name
)

Parameters

name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ClonePhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : ClonePhase Method

phase
The Phase to clone.

Glossary Item Box

Clone a Phase.

Syntax

Visual Basic (Declaration)
Public Function ClonePhase( _
   ByVal phase As ISIAPIPhase _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim phase As ISIAPIPhase
Dim value As ISIAPIPhase

value = instance.ClonePhase(phase)
C#
public ISIAPIPhase ClonePhase(
   ISIAPIPhase phase
)
Managed Extensions for C++
public: ISIAPIPhase* ClonePhase(
   ISIAPIPhase* phase
)
C++/CLI
public:
ISIAPIPhase^ ClonePhase(
   ISIAPIPhase^ phase
)

Parameters

phase
The Phase to clone.

Return Value

The new cloned Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : InsertPhase Method

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Glossary Item Box

Insert a new Phase into this Sequence at the specified position.

Syntax

Visual Basic (Declaration)
Public Function InsertPhase( _
   ByVal position As Integer, _
   ByVal name As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim position As Integer
Dim name As String
Dim value As ISIAPIPhase

value = instance.InsertPhase(position, name)
C#
public ISIAPIPhase InsertPhase(
   int position,
   string name
)
Managed Extensions for C++
public: ISIAPIPhase* InsertPhase(
   int position,
   string* name
)
C++/CLI
public:
ISIAPIPhase^ InsertPhase(
   int position,
   String^ name
)

Parameters

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovePhaseTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : MovePhaseTo Method

phase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Glossary Item Box

Move a Phase to a new position.

Syntax

Visual Basic (Declaration)
Public Function MovePhaseTo( _
   ByVal phase As ISIAPIPhase, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim phase As ISIAPIPhase
Dim newPosition As Integer
Dim value As Boolean

value = instance.MovePhaseTo(phase, newPosition)
C#
public bool MovePhaseTo(
   ISIAPIPhase phase,
   int newPosition
)
Managed Extensions for C++
public: bool MovePhaseTo(
   ISIAPIPhase* phase,
   int newPosition
)
C++/CLI
public:
bool MovePhaseTo(
   ISIAPIPhase^ phase,
   int newPosition
)

Parameters

phase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Return Value

true if the Phase is successfully moved; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemovePhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : RemovePhase Method

phase
The Phase to remove.

Glossary Item Box

Remove a Phase from this Sequence.

Syntax

Visual Basic (Declaration)
Public Function RemovePhase( _
   ByVal phase As ISIAPIPhase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim phase As ISIAPIPhase
Dim value As Boolean

value = instance.RemovePhase(phase)
C#
public bool RemovePhase(
   ISIAPIPhase phase
)
Managed Extensions for C++
public: bool RemovePhase(
   ISIAPIPhase* phase
)
C++/CLI
public:
bool RemovePhase(
   ISIAPIPhase^ phase
)

Parameters

phase
The Phase to remove.

Return Value

true if the Phase is successfully removed; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequence Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequence Class

Glossary Item Box

For a list of all members of this type, see SIAPISequence members.

Public Properties

 | Name | Description
Public Property | Actuated_gap_major_mov |
Public Property | Actuated_gap_minor_mov |
Public Property | Actuated_max_green_major_mov |
Public Property | Actuated_max_green_minor_mov |
Public Property | Cycle_time_option | Cycle Time Option
Public Property | Eff_det_zone_len_major_mov |
Public Property | Eff_det_zone_len_minor_mov |
Public Property | Green_split_priority_option | Green Split Priority
Public Property | Is_selected |
Public Property | Is_timing_optimised_for_selected_result |
Public Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Public Property | LastErrorMessage |
Public Property | Name |
Public Property | Optimum_cycle_time_increment |
Public Property | Optimum_cycle_time_lower |
Public Property | Optimum_cycle_time_lower_user |
Public Property | Optimum_cycle_time_optim_method |
Public Property | Optimum_cycle_time_perf_measure |
Public Property | Optimum_cycle_time_upper |
Public Property | Optimum_max_green_optim_method |
Public Property | Optimum_max_green_percent_increment |
Public Property | Optimum_max_green_percent_lower |
Public Property | Optimum_max_green_percent_upper |
Public Property | Optimum_max_green_perf_measure |
Public Property | Phases |
Public Property | Position | The Sequence Position in the Site's Sequences collection. It is a zero-base integer.
Public Property | Practical_cycle_rounding |
Public Property | Practical_max_cycle_time |
Public Property | Sequence_id | The database row unique ID of the Sequence.
Public Property | Site |
Public Property | Usergiven_cycle_time |
Public Property | Variable_phasing_perf_measure |
Top

See Also

Reference

SIAPISequence Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Actuated_gap_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_gap_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Actuated_gap_major_mov = value

value = instance.Actuated_gap_major_mov
C#
public float Actuated_gap_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_gap_major_mov();
public: __property void set_Actuated_gap_major_mov(
   float value
);
C++/CLI
public:
property float Actuated_gap_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Actuated_gap_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_gap_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Actuated_gap_minor_mov = value

value = instance.Actuated_gap_minor_mov
C#
public float Actuated_gap_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_gap_minor_mov();
public: __property void set_Actuated_gap_minor_mov(
   float value
);
C++/CLI
public:
property float Actuated_gap_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Actuated_max_green_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_max_green_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Actuated_max_green_major_mov = value

value = instance.Actuated_max_green_major_mov
C#
public float Actuated_max_green_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_max_green_major_mov();
public: __property void set_Actuated_max_green_major_mov(
   float value
);
C++/CLI
public:
property float Actuated_max_green_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Actuated_max_green_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Actuated_max_green_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Actuated_max_green_minor_mov = value

value = instance.Actuated_max_green_minor_mov
C#
public float Actuated_max_green_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Actuated_max_green_minor_mov();
public: __property void set_Actuated_max_green_minor_mov(
   float value
);
C++/CLI
public:
property float Actuated_max_green_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Public Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
public int Cycle_time_option {get; set;}
Managed Extensions for C++
public: __property int get_Cycle_time_option();
public: __property void set_Cycle_time_option(
   int value
);
C++/CLI
public:
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Cycle Time,
1 = Optimum Cycle Time,
2 = User-Given Cycle Time,
3 = User-Given Phase Time,
4 = Optimum Maximum Green Settings.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Eff_det_zone_len_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Eff_det_zone_len_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Eff_det_zone_len_major_mov = value

value = instance.Eff_det_zone_len_major_mov
C#
public float Eff_det_zone_len_major_mov {get; set;}
Managed Extensions for C++
public: __property float get_Eff_det_zone_len_major_mov();
public: __property void set_Eff_det_zone_len_major_mov(
   float value
);
C++/CLI
public:
property float Eff_det_zone_len_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Eff_det_zone_len_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Eff_det_zone_len_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Single

instance.Eff_det_zone_len_minor_mov = value

value = instance.Eff_det_zone_len_minor_mov
C#
public float Eff_det_zone_len_minor_mov {get; set;}
Managed Extensions for C++
public: __property float get_Eff_det_zone_len_minor_mov();
public: __property void set_Eff_det_zone_len_minor_mov(
   float value
);
C++/CLI
public:
property float Eff_det_zone_len_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Green_split_priority_option Property

Glossary Item Box

Green Split Priority

Syntax

Visual Basic (Declaration)
Public Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
public int Green_split_priority_option {get; set;}
Managed Extensions for C++
public: __property int get_Green_split_priority_option();
public: __property void set_Green_split_priority_option(
   int value
);
C++/CLI
public:
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Coordinated Movements,
2 = User-Specified Movements.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_selected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Is_selected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Boolean

instance.Is_selected = value

value = instance.Is_selected
C#
public bool Is_selected {get; set;}
Managed Extensions for C++
public: __property bool get_Is_selected();
public: __property void set_Is_selected(
   bool value
);
C++/CLI
public:
property bool Is_selected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_timing_optimised_for_selected_result Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Is_timing_optimised_for_selected_result Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Is_timing_optimised_for_selected_result As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Boolean

instance.Is_timing_optimised_for_selected_result = value

value = instance.Is_timing_optimised_for_selected_result
C#
public bool Is_timing_optimised_for_selected_result {get; set;}
Managed Extensions for C++
public: __property bool get_Is_timing_optimised_for_selected_result();
public: __property void set_Is_timing_optimised_for_selected_result(
   bool value
);
C++/CLI
public:
property bool Is_timing_optimised_for_selected_result {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Lane_blockage_effect_option Property

Glossary Item Box

Lane Blockage Effect Option:
In Network analysis, include Lane Blockage effects in determining Phase Times.

Syntax

Visual Basic (Declaration)
Public Property Lane_blockage_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Lane_blockage_effect_option = value

value = instance.Lane_blockage_effect_option
C#
public int Lane_blockage_effect_option {get; set;}
Managed Extensions for C++
public: __property int get_Lane_blockage_effect_option();
public: __property void set_Lane_blockage_effect_option(
   int value
);
C++/CLI
public:
property int Lane_blockage_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Without Lane Blockage Effects,
1 = With Lane Blockage Effects.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
public int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_increment();
public: __property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
public int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_lower();
public: __property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
public bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
public: __property bool get_Optimum_cycle_time_lower_user();
public: __property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
public:
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
public int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_optim_method();
public: __property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
public int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_perf_measure();
public: __property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
public int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_cycle_time_upper();
public: __property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
public:
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
public int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_optim_method();
public: __property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
public:
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
public int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_increment();
public: __property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
public int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_lower();
public: __property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
public int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_percent_upper();
public: __property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
public:
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
public int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Optimum_max_green_perf_measure();
public: __property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
public:
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Phases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Phases As ISIAPIPhases
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As ISIAPIPhases

value = instance.Phases
C#
public ISIAPIPhases Phases {get;}
Managed Extensions for C++
public: __property ISIAPIPhases* get_Phases();
C++/CLI
public:
property ISIAPIPhases^ Phases {
   ISIAPIPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Position Property

Glossary Item Box

The Sequence Position in the Site's Sequences collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
public int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
public: __property int get_Practical_cycle_rounding();
public: __property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
public:
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
public int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
public: __property int get_Practical_max_cycle_time();
public: __property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
public:
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequence_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Sequence_id Property

Glossary Item Box

The database row unique ID of the Sequence.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sequence_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

value = instance.Sequence_id
C#
public int Sequence_id {get;}
Managed Extensions for C++
public: __property int get_Sequence_id();
C++/CLI
public:
property int Sequence_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As ISIAPISite

value = instance.Site
C#
public ISIAPISite Site {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Site();
C++/CLI
public:
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Usergiven_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Usergiven_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Usergiven_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Usergiven_cycle_time = value

value = instance.Usergiven_cycle_time
C#
public int Usergiven_cycle_time {get; set;}
Managed Extensions for C++
public: __property int get_Usergiven_cycle_time();
public: __property void set_Usergiven_cycle_time(
   int value
);
C++/CLI
public:
property int Usergiven_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequence Class : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequence
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
public int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
public: __property int get_Variable_phasing_perf_measure();
public: __property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
public:
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequence Class
SIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequences Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequences Class

Glossary Item Box

Object Model

SIAPISequences ClassISIAPISequence Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPISequences
   Implements ISIAPISequences
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
C#
public sealed class SIAPISequences : ISIAPISequences
Managed Extensions for C++
public __gc __sealed class SIAPISequences : public ISIAPISequences
C++/CLI
public ref class SIAPISequences sealed : public ISIAPISequences

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPISequences

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequences Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequences Class

Glossary Item Box

The following tables list the members exposed by SIAPISequences.

Public Constructors

 | Name | Description
Public Constructor | SIAPISequences Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Public Property | SelectedSequence |
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GetSequenceByID | Get a Sequence from the collection by the database row unique ID of the Sequence.
Public Method | Select_Sequence | Select a Sequence for analysis.
Public Method | SequenceExists |
Top

See Also

Reference

SIAPISequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequences Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : SIAPISequences Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPISequences()
C#
public SIAPISequences()
Managed Extensions for C++
public: SIAPISequences();
C++/CLI
public:
SIAPISequences();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequences Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequences Class

Glossary Item Box

For a list of all members of this type, see SIAPISequences members.

Public Methods

 | Name | Description
Public Method | GetEnumerator |
Public Method | GetSequenceByID | Get a Sequence from the collection by the database row unique ID of the Sequence.
Public Method | Select_Sequence | Select a Sequence for analysis.
Public Method | SequenceExists |
Top

See Also

Reference

SIAPISequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetSequenceByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : GetSequenceByID Method

sequence_id
The database row unique ID of the Sequence.

Glossary Item Box

Get a Sequence from the collection by the database row unique ID of the Sequence.

Syntax

Visual Basic (Declaration)
Public Function GetSequenceByID( _
   ByVal sequence_id As Integer _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim sequence_id As Integer
Dim value As ISIAPISequence

value = instance.GetSequenceByID(sequence_id)
C#
public ISIAPISequence GetSequenceByID(
   int sequence_id
)
Managed Extensions for C++
public: ISIAPISequence* GetSequenceByID(
   int sequence_id
)
C++/CLI
public:
ISIAPISequence^ GetSequenceByID(
   int sequence_id
)

Parameters

sequence_id
The database row unique ID of the Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Select_Sequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : Select_Sequence Method

sequence_id
The database row unique ID of the Sequence.

Glossary Item Box

Select a Sequence for analysis.

Syntax

Visual Basic (Declaration)
Public Sub Select_Sequence( _
   ByVal sequence_id As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim sequence_id As Integer

instance.Select_Sequence(sequence_id)
C#
public void Select_Sequence(
   int sequence_id
)
Managed Extensions for C++
public: void Select_Sequence(
   int sequence_id
)
C++/CLI
public:
void Select_Sequence(
   int sequence_id
)

Parameters

sequence_id
The database row unique ID of the Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SequenceExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : SequenceExists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SequenceExists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim name As String
Dim value As Boolean

value = instance.SequenceExists(name)
C#
public bool SequenceExists(
   string name
)
Managed Extensions for C++
public: bool SequenceExists(
   string* name
)
C++/CLI
public:
bool SequenceExists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISequences Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISequences Class

Glossary Item Box

For a list of all members of this type, see SIAPISequences members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded.
Public Property | SelectedSequence |
Top

See Also

Reference

SIAPISequences Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class > Item Property : Item(String) Property

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim name As String
Dim value As ISIAPISequence

value = instance.Item(name)
C#
public ISIAPISequence Item(
   string name
) {get;}
Managed Extensions for C++
public: __property ISIAPISequence* get_Item(
   string* name
);
C++/CLI
public:
property ISIAPISequence^ Item {
   ISIAPISequence^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim index As Integer
Dim value As ISIAPISequence

value = instance.Item(index)
C#
public ISIAPISequence Item(
   int index
) {get;}
Managed Extensions for C++
public: __property ISIAPISequence* get_Item(
   int index
);
C++/CLI
public:
property ISIAPISequence^ Item {
   ISIAPISequence^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SelectedSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISequences Class : SelectedSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedSequence As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISequences
Dim value As ISIAPISequence

value = instance.SelectedSequence
C#
public ISIAPISequence SelectedSequence {get;}
Managed Extensions for C++
public: __property ISIAPISequence* get_SelectedSequence();
C++/CLI
public:
property ISIAPISequence^ SelectedSequence {
   ISIAPISequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISequences Class
SIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISite Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISite Class

Glossary Item Box

SIDRA INTERSECTION Site wrapper class

Object Model

SIAPISite ClassISIAPIAnalysis InterfaceISIAPIDiagnosticMsgs InterfaceISIAPIDiagnosticMsg InterfaceISIAPIGapAcceptanceSpecificApp InterfaceISIAPILegs InterfaceISIAPILeg InterfaceISIAPIModelSetting InterfaceISIAPIMovementClasses InterfaceISIAPIMovementClass InterfaceISIAPIMovement_peds InterfaceISIAPIMovement_ped InterfaceISIAPIMovement_vehicle_ods InterfaceISIAPIMovement_vehicle_od InterfaceISIAPIOutputset InterfaceISIAPIProject InterfaceISIAPISequences InterfaceISIAPISequence InterfaceISIAPITwoWaySignControlAdjGeometryControls InterfaceISIAPITwoWaySignControlAdjGeometryControl InterfaceISIAPITwoWaySignControlAdjMajorNumLanes InterfaceISIAPITwoWaySignControlAdjMajorNumLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPISite
   Implements ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
C#
public sealed class SIAPISite : ISIAPISite
Managed Extensions for C++
public __gc __sealed class SIAPISite : public ISIAPISite
C++/CLI
public ref class SIAPISite sealed : public ISIAPISite

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPISite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISite Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISite Class

Glossary Item Box

The following tables list the members exposed by SIAPISite.

Public Constructors

 | Name | Description
Public Constructor | SIAPISite Constructor |
Top

Public Properties

 | Name | Description
Public Property | Analysis |
Public Property | Category | Site Category
Public Property | Costunit |
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | Description | Site description
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | Driveonleft | Flag indicating the "Drive Rule" of the site
Public Property | Freeway_orientation |
Public Property | GapAcceptanceTurnOnRed |
Public Property | HasWarnings | Flag indicating whether warnings were generated during a call to Process
Public Property | Hcm | Flag indicating whether the site uses HCM
Public Property | Intersectionid | Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.
Public Property | IsIncludedInProjectSummary |
Public Property | LastErrorMessage |
Public Property | Legs |
Public Property | ModelName | The internal SIDRA INTERSECTION Software Setup name
Public Property | ModelSetting |
Public Property | Modelsignature | The internal SIDRA INTERSECTION Software Setup signature GUID used by this site
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | MovementClasses |
Public Property | MovementPeds | Collection of the Site's Pedestrian Movements
Public Property | MovementVehicleODs | Collection of the Site's Vehicle OD Movements
Public Property | Name | Site name
Public Property | Outputset | Site output data
Public Property | Peakflowperiod | Peak flow period
Public Property | Position | The Site Position in the Project's Sites collection. It is a zero-base integer.
Public Property | ProcessingError | Error message after a failed call to Process
Public Property | ProcessingWarnings | Processing warnings generated during a call to Process
Public Property | Project |
Public Property | Rou_controlling_detector_setback_dist |
Public Property | Rou_controlling_leg_orientation |
Public Property | Rou_metered_end_gain |
Public Property | Rou_metered_leg_orientation |
Public Property | Rou_metered_start_loss |
Public Property | Rou_stopline_setback_dist |
Public Property | Sequences |
Public Property | Signal_analysis_method | Signalised Site analysis method
Public Property | Site_id | The database row unique ID of the Site.
Public Property | Sitecontroltype | Control method used at site
Public Property | Sitetype | Site Intersection type
Public Property | Title | Site title
Public Property | TwoWaySignControlAdjGeometryControls |
Public Property | TwoWaySignControlAdjMajorNumLanes |
Public Property | Units | General unit system used for data within the site
Public Property | Unittimeforvolumes | Unit time for traffic volumes in minutes
Top

Public Methods

 | Name | Description
Public Method | AddLeg | Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.
Public Method | AddLegWithLanes | Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.
Public Method | AddSequence | Add a Sequence. A new Sequence is created and added to this Site.
Public Method | CloneSequence | Clone a Sequence.
Public Method | CreateLayoutPngData |
Public Method | CreateLayoutPngFile |
Public Method | MoveSequenceTo | Move a Sequence to a new position.
Public Method | Process | Processes the Site
Public Method | RemoveLeg | Remove a Leg from the Site.
Public Method | RemoveSequence | Remove a Sequence from the Site.
Public Method | ResetLaneMovements | Reset the Lane Movements to the default vaules
Public Method | ResetMovementVehicleODMCExists | Reset all SIAPIMovement_vehicle_od_mc.Exists values according to the SIAPILaneApproachMovementMC.Exists values (i.e. Lane Disciplines)
Public Method | ResetSitePrioritiesData | Reset Priority Data to the default vaules
Public Method | Rotate | Rotate the Site.
Public Method | UpdateGeometryData | Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPISite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISite Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : SIAPISite Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPISite()
C#
public SIAPISite()
Managed Extensions for C++
public: SIAPISite();
C++/CLI
public:
SIAPISite();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISite Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISite Class

Glossary Item Box

For a list of all members of this type, see SIAPISite members.

Public Methods

 | Name | Description
Public Method | AddLeg | Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.
Public Method | AddLegWithLanes | Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.
Public Method | AddSequence | Add a Sequence. A new Sequence is created and added to this Site.
Public Method | CloneSequence | Clone a Sequence.
Public Method | CreateLayoutPngData |
Public Method | CreateLayoutPngFile |
Public Method | MoveSequenceTo | Move a Sequence to a new position.
Public Method | Process | Processes the Site
Public Method | RemoveLeg | Remove a Leg from the Site.
Public Method | RemoveSequence | Remove a Sequence from the Site.
Public Method | ResetLaneMovements | Reset the Lane Movements to the default vaules
Public Method | ResetMovementVehicleODMCExists | Reset all SIAPIMovement_vehicle_od_mc.Exists values according to the SIAPILaneApproachMovementMC.Exists values (i.e. Lane Disciplines)
Public Method | ResetSitePrioritiesData | Reset Priority Data to the default vaules
Public Method | Rotate | Rotate the Site.
Public Method | UpdateGeometryData | Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.
Public Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

SIAPISite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLeg Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : AddLeg Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.

Syntax

Visual Basic (Declaration)
Public Function AddLeg( _
   ByVal orientation As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim orientation As Integer
Dim value As ISIAPILeg

value = instance.AddLeg(orientation)
C#
public ISIAPILeg AddLeg(
   int orientation
)
Managed Extensions for C++
public: ISIAPILeg* AddLeg(
   int orientation
)
C++/CLI
public:
ISIAPILeg^ AddLeg(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

The new added Leg

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLegWithLanes Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : AddLegWithLanes Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

legGeometry

Type: System.Int32;
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Glossary Item Box

Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.

Syntax

Visual Basic (Declaration)
Public Function AddLegWithLanes( _
   ByVal orientation As Integer, _
   ByVal legGeometry As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim orientation As Integer
Dim legGeometry As Integer
Dim value As ISIAPILeg

value = instance.AddLegWithLanes(orientation, legGeometry)
C#
public ISIAPILeg AddLegWithLanes(
   int orientation,
   int legGeometry
)
Managed Extensions for C++
public: ISIAPILeg* AddLegWithLanes(
   int orientation,
   int legGeometry
)
C++/CLI
public:
ISIAPILeg^ AddLegWithLanes(
   int orientation,
   int legGeometry
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

legGeometry

Type: System.Int32;
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Return Value

The new added Leg

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : AddSequence Method

name
The name of the new Sequence.

Glossary Item Box

Add a Sequence. A new Sequence is created and added to this Site.

Syntax

Visual Basic (Declaration)
Public Function AddSequence( _
   ByVal name As String _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim name As String
Dim value As ISIAPISequence

value = instance.AddSequence(name)
C#
public ISIAPISequence AddSequence(
   string name
)
Managed Extensions for C++
public: ISIAPISequence* AddSequence(
   string* name
)
C++/CLI
public:
ISIAPISequence^ AddSequence(
   String^ name
)

Parameters

name
The name of the new Sequence.

Return Value

The new Sequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : CloneSequence Method

sequence
The Sequence to be cloned.

Glossary Item Box

Clone a Sequence.

Syntax

Visual Basic (Declaration)
Public Function CloneSequence( _
   ByVal sequence As ISIAPISequence _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim sequence As ISIAPISequence
Dim value As ISIAPISequence

value = instance.CloneSequence(sequence)
C#
public ISIAPISequence CloneSequence(
   ISIAPISequence sequence
)
Managed Extensions for C++
public: ISIAPISequence* CloneSequence(
   ISIAPISequence* sequence
)
C++/CLI
public:
ISIAPISequence^ CloneSequence(
   ISIAPISequence^ sequence
)

Parameters

sequence
The Sequence to be cloned.

Return Value

The new cloned Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : CreateLayoutPngData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateLayoutPngData() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value() As Byte

value = instance.CreateLayoutPngData()
C#
public byte[] CreateLayoutPngData()
Managed Extensions for C++
public: byte[]* CreateLayoutPngData();
C++/CLI
public:
array<byte>^ CreateLayoutPngData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngFile Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : CreateLayoutPngFile Method

filename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateLayoutPngFile( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim filename As String
Dim value As Boolean

value = instance.CreateLayoutPngFile(filename)
C#
public bool CreateLayoutPngFile(
   string filename
)
Managed Extensions for C++
public: bool CreateLayoutPngFile(
   string* filename
)
C++/CLI
public:
bool CreateLayoutPngFile(
   String^ filename
)

Parameters

filename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveSequenceTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : MoveSequenceTo Method

sequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Glossary Item Box

Move a Sequence to a new position.

Syntax

Visual Basic (Declaration)
Public Function MoveSequenceTo( _
   ByVal sequence As ISIAPISequence, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim sequence As ISIAPISequence
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveSequenceTo(sequence, newPosition)
C#
public bool MoveSequenceTo(
   ISIAPISequence sequence,
   int newPosition
)
Managed Extensions for C++
public: bool MoveSequenceTo(
   ISIAPISequence* sequence,
   int newPosition
)
C++/CLI
public:
bool MoveSequenceTo(
   ISIAPISequence^ sequence,
   int newPosition
)

Parameters

sequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Return Value

true if the Sequence is successfully moved; otherwise, false. This method also returns false if the Sequence was not found in this Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Process Method

Glossary Item Box

Processes the Site

Syntax

Visual Basic (Declaration)
Public Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.Process()
C#
public bool Process()
Managed Extensions for C++
public: bool Process();
C++/CLI
public:
bool Process();

Return Value

Type: System.Boolean.

True, if processing was successful. False, if errors were generated during processing - check ProcessingError for details.

Note: The HasWarnings property should always be checked after processing in case warnings were generated. Warnings may occur even if processing was successful.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLeg Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : RemoveLeg Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Remove a Leg from the Site.

Syntax

Visual Basic (Declaration)
Public Function RemoveLeg( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim orientation As Integer
Dim value As Boolean

value = instance.RemoveLeg(orientation)
C#
public bool RemoveLeg(
   int orientation
)
Managed Extensions for C++
public: bool RemoveLeg(
   int orientation
)
C++/CLI
public:
bool RemoveLeg(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

true if the Leg is successfully removed. This method returns false if the Leg was not found.

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : RemoveSequence Method

sequence
The Sequence to remove.

Glossary Item Box

Remove a Sequence from the Site.

Syntax

Visual Basic (Declaration)
Public Function RemoveSequence( _
   ByVal sequence As ISIAPISequence _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim sequence As ISIAPISequence
Dim value As Boolean

value = instance.RemoveSequence(sequence)
C#
public bool RemoveSequence(
   ISIAPISequence sequence
)
Managed Extensions for C++
public: bool RemoveSequence(
   ISIAPISequence* sequence
)
C++/CLI
public:
bool RemoveSequence(
   ISIAPISequence^ sequence
)

Parameters

sequence
The Sequence to remove.

Return Value

true if the Sequence is successfully removed; otherwise, false. This method also returns false if the Sequence was not found in this Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetLaneMovements Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ResetLaneMovements Method

Glossary Item Box

Reset the Lane Movements to the default vaules

Syntax

Visual Basic (Declaration)
Public Function ResetLaneMovements() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.ResetLaneMovements()
C#
public bool ResetLaneMovements()
Managed Extensions for C++
public: bool ResetLaneMovements();
C++/CLI
public:
bool ResetLaneMovements();

Remarks

This needs to be called manually after Approach / Exit Lanes are added or removed, or after SIAPILaneApproachMovementMC.Exists (i.e. Lane Discipline) values are changed.

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetMovementVehicleODMCExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ResetMovementVehicleODMCExists Method

Glossary Item Box

Reset all SIAPIMovement_vehicle_od_mc.Exists values according to the SIAPILaneApproachMovementMC.Exists values (i.e. Lane Disciplines)

Syntax

Visual Basic (Declaration)
Public Function ResetMovementVehicleODMCExists() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.ResetMovementVehicleODMCExists()
C#
public bool ResetMovementVehicleODMCExists()
Managed Extensions for C++
public: bool ResetMovementVehicleODMCExists();
C++/CLI
public:
bool ResetMovementVehicleODMCExists();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetSitePrioritiesData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ResetSitePrioritiesData Method

Glossary Item Box

Reset Priority Data to the default vaules

Syntax

Visual Basic (Declaration)
Public Function ResetSitePrioritiesData() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.ResetSitePrioritiesData()
C#
public bool ResetSitePrioritiesData()
Managed Extensions for C++
public: bool ResetSitePrioritiesData();
C++/CLI
public:
bool ResetSitePrioritiesData();

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rotate Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rotate Method

step

Type: System.Int32;

If step is a positive integer, rotate the Site clockwise. If step is a negative integer, rotate the Site anti-clockwise. One step equals 45 degrees.

Glossary Item Box

Rotate the Site.

Syntax

Visual Basic (Declaration)
Public Function Rotate( _
   ByVal step As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim step As Integer
Dim value As Boolean

value = instance.Rotate(step)
C#
public bool Rotate(
   int step
)
Managed Extensions for C++
public: bool Rotate(
   int step
)
C++/CLI
public:
bool Rotate(
   int step
)

Parameters

step

Type: System.Int32;

If step is a positive integer, rotate the Site clockwise. If step is a negative integer, rotate the Site anti-clockwise. One step equals 45 degrees.

Remarks

If the Site Geometry has been changed, e.g. a Leg or Lane has been added or removed, call the method UpdateGeometryData() to update the Geometry Data before calling this.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateGeometryData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : UpdateGeometryData Method

Glossary Item Box

Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.

Syntax

Visual Basic (Declaration)
Public Function UpdateGeometryData() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.UpdateGeometryData()
C#
public bool UpdateGeometryData()
Managed Extensions for C++
public: bool UpdateGeometryData();
C++/CLI
public:
bool UpdateGeometryData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Public Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
public bool UpdateModifiedInfo()
Managed Extensions for C++
public: bool UpdateModifiedInfo();
C++/CLI
public:
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISite Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISite Class

Glossary Item Box

For a list of all members of this type, see SIAPISite members.

Public Properties

 | Name | Description
Public Property | Analysis |
Public Property | Category | Site Category
Public Property | Costunit |
Public Property | Created_by |
Public Property | Created_by_company |
Public Property | Created_date |
Public Property | Created_version |
Public Property | Description | Site description
Public Property | DiagnosticMsgs |
Public Property | DiagnosticStatus | Diagnostic Status
Public Property | Driveonleft | Flag indicating the "Drive Rule" of the site
Public Property | Freeway_orientation |
Public Property | GapAcceptanceTurnOnRed |
Public Property | HasWarnings | Flag indicating whether warnings were generated during a call to Process
Public Property | Hcm | Flag indicating whether the site uses HCM
Public Property | Intersectionid | Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.
Public Property | IsIncludedInProjectSummary |
Public Property | LastErrorMessage |
Public Property | Legs |
Public Property | ModelName | The internal SIDRA INTERSECTION Software Setup name
Public Property | ModelSetting |
Public Property | Modelsignature | The internal SIDRA INTERSECTION Software Setup signature GUID used by this site
Public Property | Modified_by |
Public Property | Modified_by_company |
Public Property | Modified_date |
Public Property | Modified_version |
Public Property | MovementClasses |
Public Property | MovementPeds | Collection of the Site's Pedestrian Movements
Public Property | MovementVehicleODs | Collection of the Site's Vehicle OD Movements
Public Property | Name | Site name
Public Property | Outputset | Site output data
Public Property | Peakflowperiod | Peak flow period
Public Property | Position | The Site Position in the Project's Sites collection. It is a zero-base integer.
Public Property | ProcessingError | Error message after a failed call to Process
Public Property | ProcessingWarnings | Processing warnings generated during a call to Process
Public Property | Project |
Public Property | Rou_controlling_detector_setback_dist |
Public Property | Rou_controlling_leg_orientation |
Public Property | Rou_metered_end_gain |
Public Property | Rou_metered_leg_orientation |
Public Property | Rou_metered_start_loss |
Public Property | Rou_stopline_setback_dist |
Public Property | Sequences |
Public Property | Signal_analysis_method | Signalised Site analysis method
Public Property | Site_id | The database row unique ID of the Site.
Public Property | Sitecontroltype | Control method used at site
Public Property | Sitetype | Site Intersection type
Public Property | Title | Site title
Public Property | TwoWaySignControlAdjGeometryControls |
Public Property | TwoWaySignControlAdjMajorNumLanes |
Public Property | Units | General unit system used for data within the site
Public Property | Unittimeforvolumes | Unit time for traffic volumes in minutes
Top

See Also

Reference

SIAPISite Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Analysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Analysis As ISIAPIAnalysis
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIAnalysis

value = instance.Analysis
C#
public ISIAPIAnalysis Analysis {get;}
Managed Extensions for C++
public: __property ISIAPIAnalysis* get_Analysis();
C++/CLI
public:
property ISIAPIAnalysis^ Analysis {
   ISIAPIAnalysis^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Category Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Category Property

Glossary Item Box

Site Category

Syntax

Visual Basic (Declaration)
Public Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Category = value

value = instance.Category
C#
public string Category {get; set;}
Managed Extensions for C++
public: __property string* get_Category();
public: __property void set_Category(
   string* value
);
C++/CLI
public:
property String^ Category {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site Category, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Costunit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Costunit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Costunit As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Costunit = value

value = instance.Costunit
C#
public string Costunit {get; set;}
Managed Extensions for C++
public: __property string* get_Costunit();
public: __property void set_Costunit(
   string* value
);
C++/CLI
public:
property String^ Costunit {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Created_by
C#
public string Created_by {get;}
Managed Extensions for C++
public: __property string* get_Created_by();
C++/CLI
public:
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Created_by_company
C#
public string Created_by_company {get;}
Managed Extensions for C++
public: __property string* get_Created_by_company();
C++/CLI
public:
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Date

value = instance.Created_date
C#
public DateTime Created_date {get;}
Managed Extensions for C++
public: __property DateTime get_Created_date();
C++/CLI
public:
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Created_version
C#
public string Created_version {get;}
Managed Extensions for C++
public: __property string* get_Created_version();
C++/CLI
public:
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Description Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Description Property

Glossary Item Box

Site description

Syntax

Visual Basic (Declaration)
Public Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Description = value

value = instance.Description
C#
public string Description {get; set;}
Managed Extensions for C++
public: __property string* get_Description();
public: __property void set_Description(
   string* value
);
C++/CLI
public:
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site description, max length = 500.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
public ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
public: __property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
public:
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.DiagnosticStatus
C#
public int DiagnosticStatus {get;}
Managed Extensions for C++
public: __property int get_DiagnosticStatus();
C++/CLI
public:
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Driveonleft Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Driveonleft Property

Glossary Item Box

Flag indicating the "Drive Rule" of the site

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Driveonleft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.Driveonleft
C#
public bool Driveonleft {get;}
Managed Extensions for C++
public: __property bool get_Driveonleft();
C++/CLI
public:
property bool Driveonleft {
   bool get();
}

Property Value

Type: System.Boolean.

True if driving on the left. False if driving on the right.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Freeway_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Freeway_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Freeway_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Freeway_orientation
C#
public int Freeway_orientation {get;}
Managed Extensions for C++
public: __property int get_Freeway_orientation();
C++/CLI
public:
property int Freeway_orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GapAcceptanceTurnOnRed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : GapAcceptanceTurnOnRed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property GapAcceptanceTurnOnRed As ISIAPIGapAcceptanceSpecificApp
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIGapAcceptanceSpecificApp

value = instance.GapAcceptanceTurnOnRed
C#
public ISIAPIGapAcceptanceSpecificApp GapAcceptanceTurnOnRed {get;}
Managed Extensions for C++
public: __property ISIAPIGapAcceptanceSpecificApp* get_GapAcceptanceTurnOnRed();
C++/CLI
public:
property ISIAPIGapAcceptanceSpecificApp^ GapAcceptanceTurnOnRed {
   ISIAPIGapAcceptanceSpecificApp^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HasWarnings Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : HasWarnings Property

Glossary Item Box

Flag indicating whether warnings were generated during a call to Process

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HasWarnings As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.HasWarnings
C#
public bool HasWarnings {get;}
Managed Extensions for C++
public: __property bool get_HasWarnings();
C++/CLI
public:
property bool HasWarnings {
   bool get();
}

Property Value

Type: System.Boolean.

True if warnings were generated. False otherwise.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hcm Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Hcm Property

Glossary Item Box

Flag indicating whether the site uses HCM

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Hcm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

value = instance.Hcm
C#
public bool Hcm {get;}
Managed Extensions for C++
public: __property bool get_Hcm();
C++/CLI
public:
property bool Hcm {
   bool get();
}

Property Value

Type: System.Bool.

True, if site uses HCM, False otherwise.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intersectionid Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Intersectionid Property

Glossary Item Box

Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.

Syntax

Visual Basic (Declaration)
Public Property Intersectionid As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Intersectionid = value

value = instance.Intersectionid
C#
public string Intersectionid {get; set;}
Managed Extensions for C++
public: __property string* get_Intersectionid();
public: __property void set_Intersectionid(
   string* value
);
C++/CLI
public:
property String^ Intersectionid {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site ID, max length = 10.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
public bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
public: __property bool get_IsIncludedInProjectSummary();
public: __property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
public:
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.LastErrorMessage
C#
public string LastErrorMessage {get;}
Managed Extensions for C++
public: __property string* get_LastErrorMessage();
C++/CLI
public:
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Legs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Legs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legs As ISIAPILegs
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPILegs

value = instance.Legs
C#
public ISIAPILegs Legs {get;}
Managed Extensions for C++
public: __property ISIAPILegs* get_Legs();
C++/CLI
public:
property ISIAPILegs^ Legs {
   ISIAPILegs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ModelName Property

Glossary Item Box

The internal SIDRA INTERSECTION Software Setup name

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModelName As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.ModelName
C#
public string ModelName {get;}
Managed Extensions for C++
public: __property string* get_ModelName();
C++/CLI
public:
property String^ ModelName {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelSetting Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ModelSetting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ModelSetting As ISIAPIModelSetting
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIModelSetting

value = instance.ModelSetting
C#
public ISIAPIModelSetting ModelSetting {get;}
Managed Extensions for C++
public: __property ISIAPIModelSetting* get_ModelSetting();
C++/CLI
public:
property ISIAPIModelSetting^ ModelSetting {
   ISIAPIModelSetting^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modelsignature Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Modelsignature Property

Glossary Item Box

The internal SIDRA INTERSECTION Software Setup signature GUID used by this site

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modelsignature As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Modelsignature
C#
public string Modelsignature {get;}
Managed Extensions for C++
public: __property string* get_Modelsignature();
C++/CLI
public:
property String^ Modelsignature {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Modified_by
C#
public string Modified_by {get;}
Managed Extensions for C++
public: __property string* get_Modified_by();
C++/CLI
public:
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Modified_by_company
C#
public string Modified_by_company {get;}
Managed Extensions for C++
public: __property string* get_Modified_by_company();
C++/CLI
public:
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Date

value = instance.Modified_date
C#
public DateTime Modified_date {get;}
Managed Extensions for C++
public: __property DateTime get_Modified_date();
C++/CLI
public:
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.Modified_version
C#
public string Modified_version {get;}
Managed Extensions for C++
public: __property string* get_Modified_version();
C++/CLI
public:
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClasses Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : MovementClasses Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementClasses As ISIAPIMovementClasses
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIMovementClasses

value = instance.MovementClasses
C#
public ISIAPIMovementClasses MovementClasses {get;}
Managed Extensions for C++
public: __property ISIAPIMovementClasses* get_MovementClasses();
C++/CLI
public:
property ISIAPIMovementClasses^ MovementClasses {
   ISIAPIMovementClasses^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementPeds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : MovementPeds Property

Glossary Item Box

Collection of the Site's Pedestrian Movements

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementPeds As ISIAPIMovement_peds
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIMovement_peds

value = instance.MovementPeds
C#
public ISIAPIMovement_peds MovementPeds {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_peds* get_MovementPeds();
C++/CLI
public:
property ISIAPIMovement_peds^ MovementPeds {
   ISIAPIMovement_peds^ get();
}

Property Value

Type: ISIAPIMovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementVehicleODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : MovementVehicleODs Property

Glossary Item Box

Collection of the Site's Vehicle OD Movements

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MovementVehicleODs As ISIAPIMovement_vehicle_ods
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIMovement_vehicle_ods

value = instance.MovementVehicleODs
C#
public ISIAPIMovement_vehicle_ods MovementVehicleODs {get;}
Managed Extensions for C++
public: __property ISIAPIMovement_vehicle_ods* get_MovementVehicleODs();
C++/CLI
public:
property ISIAPIMovement_vehicle_ods^ MovementVehicleODs {
   ISIAPIMovement_vehicle_ods^ get();
}

Property Value

Type: ISIAPIMovement_vehicle_ods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Name Property

Glossary Item Box

Site name

Syntax

Visual Basic (Declaration)
Public Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Name = value

value = instance.Name
C#
public string Name {get; set;}
Managed Extensions for C++
public: __property string* get_Name();
public: __property void set_Name(
   string* value
);
C++/CLI
public:
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

The site name, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Outputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Outputset Property

Glossary Item Box

Site output data

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Outputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIOutputset

value = instance.Outputset
C#
public ISIAPIOutputset Outputset {get;}
Managed Extensions for C++
public: __property ISIAPIOutputset* get_Outputset();
C++/CLI
public:
property ISIAPIOutputset^ Outputset {
   ISIAPIOutputset^ get();
}

Property Value

Type: ISIAPIOutputset

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peakflowperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Peakflowperiod Property

Glossary Item Box

Peak flow period

Syntax

Visual Basic (Declaration)
Public Property Peakflowperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Peakflowperiod = value

value = instance.Peakflowperiod
C#
public int Peakflowperiod {get; set;}
Managed Extensions for C++
public: __property int get_Peakflowperiod();
public: __property void set_Peakflowperiod(
   int value
);
C++/CLI
public:
property int Peakflowperiod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Position Property

Glossary Item Box

The Site Position in the Project's Sites collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Position
C#
public int Position {get;}
Managed Extensions for C++
public: __property int get_Position();
C++/CLI
public:
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingError Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ProcessingError Property

Glossary Item Box

Error message after a failed call to Process

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProcessingError As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.ProcessingError
C#
public string ProcessingError {get;}
Managed Extensions for C++
public: __property string* get_ProcessingError();
C++/CLI
public:
property String^ ProcessingError {
   String^ get();
}

Property Value

Type: System.String.

Error message

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingWarnings Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : ProcessingWarnings Property

Glossary Item Box

Processing warnings generated during a call to Process

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ProcessingWarnings As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

value = instance.ProcessingWarnings
C#
public string ProcessingWarnings {get;}
Managed Extensions for C++
public: __property string* get_ProcessingWarnings();
C++/CLI
public:
property String^ ProcessingWarnings {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Project Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPIProject

value = instance.Project
C#
public ISIAPIProject Project {get;}
Managed Extensions for C++
public: __property ISIAPIProject* get_Project();
C++/CLI
public:
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_controlling_detector_setback_dist Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_controlling_detector_setback_dist Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_controlling_detector_setback_dist As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Single

instance.Rou_controlling_detector_setback_dist = value

value = instance.Rou_controlling_detector_setback_dist
C#
public float Rou_controlling_detector_setback_dist {get; set;}
Managed Extensions for C++
public: __property float get_Rou_controlling_detector_setback_dist();
public: __property void set_Rou_controlling_detector_setback_dist(
   float value
);
C++/CLI
public:
property float Rou_controlling_detector_setback_dist {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_controlling_leg_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_controlling_leg_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_controlling_leg_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Rou_controlling_leg_orientation = value

value = instance.Rou_controlling_leg_orientation
C#
public int Rou_controlling_leg_orientation {get; set;}
Managed Extensions for C++
public: __property int get_Rou_controlling_leg_orientation();
public: __property void set_Rou_controlling_leg_orientation(
   int value
);
C++/CLI
public:
property int Rou_controlling_leg_orientation {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_metered_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_metered_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Rou_metered_end_gain = value

value = instance.Rou_metered_end_gain
C#
public int Rou_metered_end_gain {get; set;}
Managed Extensions for C++
public: __property int get_Rou_metered_end_gain();
public: __property void set_Rou_metered_end_gain(
   int value
);
C++/CLI
public:
property int Rou_metered_end_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_leg_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_metered_leg_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_metered_leg_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Rou_metered_leg_orientation = value

value = instance.Rou_metered_leg_orientation
C#
public int Rou_metered_leg_orientation {get; set;}
Managed Extensions for C++
public: __property int get_Rou_metered_leg_orientation();
public: __property void set_Rou_metered_leg_orientation(
   int value
);
C++/CLI
public:
property int Rou_metered_leg_orientation {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_metered_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_metered_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Rou_metered_start_loss = value

value = instance.Rou_metered_start_loss
C#
public int Rou_metered_start_loss {get; set;}
Managed Extensions for C++
public: __property int get_Rou_metered_start_loss();
public: __property void set_Rou_metered_start_loss(
   int value
);
C++/CLI
public:
property int Rou_metered_start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_stopline_setback_dist Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Rou_stopline_setback_dist Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Rou_stopline_setback_dist As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Single

instance.Rou_stopline_setback_dist = value

value = instance.Rou_stopline_setback_dist
C#
public float Rou_stopline_setback_dist {get; set;}
Managed Extensions for C++
public: __property float get_Rou_stopline_setback_dist();
public: __property void set_Rou_stopline_setback_dist(
   float value
);
C++/CLI
public:
property float Rou_stopline_setback_dist {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequences Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Sequences Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sequences As ISIAPISequences
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPISequences

value = instance.Sequences
C#
public ISIAPISequences Sequences {get;}
Managed Extensions for C++
public: __property ISIAPISequences* get_Sequences();
C++/CLI
public:
property ISIAPISequences^ Sequences {
   ISIAPISequences^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Signal_analysis_method Property

Glossary Item Box

Signalised Site analysis method

Syntax

Visual Basic (Declaration)
Public Property Signal_analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Signal_analysis_method = value

value = instance.Signal_analysis_method
C#
public int Signal_analysis_method {get; set;}
Managed Extensions for C++
public: __property int get_Signal_analysis_method();
public: __property void set_Signal_analysis_method(
   int value
);
C++/CLI
public:
property int Signal_analysis_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Fixed-Time/Pretimed,
1 = Actuated.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Site_id Property

Glossary Item Box

The database row unique ID of the Site.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Site_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Site_id
C#
public int Site_id {get;}
Managed Extensions for C++
public: __property int get_Site_id();
C++/CLI
public:
property int Site_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sitecontroltype Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Sitecontroltype Property

Glossary Item Box

Control method used at site

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sitecontroltype As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Sitecontroltype
C#
public int Sitecontroltype {get;}
Managed Extensions for C++
public: __property int get_Sitecontroltype();
C++/CLI
public:
property int Sitecontroltype {
   int get();
}

Property Value

Type: System.Int32;

0 = Signals,
1 = Roundabout,
2 = Sign Control,
3 = All Way Stop.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sitetype Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Sitetype Property

Glossary Item Box

Site Intersection type

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Sitetype As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Sitetype
C#
public int Sitetype {get;}
Managed Extensions for C++
public: __property int get_Sitetype();
C++/CLI
public:
property int Sitetype {
   int get();
}

Property Value

Type: System.Int32;

0 = Signalised,
1 = Roundabout,
2 = Giveway/Yield,
3 = Stop (Two-Way),
4 = All-way Stop (AWSC),
5 = Single Point Urban Interchange (SPUI),
6 = Pedestrian Crossing,
7 = Metered Roundabout.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Title Property

Glossary Item Box

Site title

Syntax

Visual Basic (Declaration)
Public Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As String

instance.Title = value

value = instance.Title
C#
public string Title {get; set;}
Managed Extensions for C++
public: __property string* get_Title();
public: __property void set_Title(
   string* value
);
C++/CLI
public:
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site title, max length = 500.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TwoWaySignControlAdjGeometryControls Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : TwoWaySignControlAdjGeometryControls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TwoWaySignControlAdjGeometryControls As ISIAPITwoWaySignControlAdjGeometryControls
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPITwoWaySignControlAdjGeometryControls

value = instance.TwoWaySignControlAdjGeometryControls
C#
public ISIAPITwoWaySignControlAdjGeometryControls TwoWaySignControlAdjGeometryControls {get;}
Managed Extensions for C++
public: __property ISIAPITwoWaySignControlAdjGeometryControls* get_TwoWaySignControlAdjGeometryControls();
C++/CLI
public:
property ISIAPITwoWaySignControlAdjGeometryControls^ TwoWaySignControlAdjGeometryControls {
   ISIAPITwoWaySignControlAdjGeometryControls^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TwoWaySignControlAdjMajorNumLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : TwoWaySignControlAdjMajorNumLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TwoWaySignControlAdjMajorNumLanes As ISIAPITwoWaySignControlAdjMajorNumLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As ISIAPITwoWaySignControlAdjMajorNumLanes

value = instance.TwoWaySignControlAdjMajorNumLanes
C#
public ISIAPITwoWaySignControlAdjMajorNumLanes TwoWaySignControlAdjMajorNumLanes {get;}
Managed Extensions for C++
public: __property ISIAPITwoWaySignControlAdjMajorNumLanes* get_TwoWaySignControlAdjMajorNumLanes();
C++/CLI
public:
property ISIAPITwoWaySignControlAdjMajorNumLanes^ TwoWaySignControlAdjMajorNumLanes {
   ISIAPITwoWaySignControlAdjMajorNumLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Units Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Units Property

Glossary Item Box

General unit system used for data within the site

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Units As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

value = instance.Units
C#
public int Units {get;}
Managed Extensions for C++
public: __property int get_Units();
C++/CLI
public:
property int Units {
   int get();
}

Property Value

Type: System.Int32.

0 = Metric,
1 = US Units.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unittimeforvolumes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISite Class : Unittimeforvolumes Property

Glossary Item Box

Unit time for traffic volumes in minutes

Syntax

Visual Basic (Declaration)
Public Property Unittimeforvolumes As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISite
Dim value As Integer

instance.Unittimeforvolumes = value

value = instance.Unittimeforvolumes
C#
public int Unittimeforvolumes {get; set;}
Managed Extensions for C++
public: __property int get_Unittimeforvolumes();
public: __property void set_Unittimeforvolumes(
   int value
);
C++/CLI
public:
property int Unittimeforvolumes {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISite Class
SIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISites Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISites Class

Glossary Item Box

SIAPISite collection

Object Model

SIAPISites ClassISIAPISite Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPISites
   Implements ISIAPISites
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
C#
public sealed class SIAPISites : ISIAPISites
Managed Extensions for C++
public __gc __sealed class SIAPISites : public ISIAPISites
C++/CLI
public ref class SIAPISites sealed : public ISIAPISites

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPISites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISites Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISites Class

Glossary Item Box

The following tables list the members exposed by SIAPISites.

Public Constructors

 | Name | Description
Public Constructor | SIAPISites Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded. Get a Site from the collection by the Site name.
Top

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an IEnumerator object for the collection
Public Method | GetSiteByID | Get the Site by the database row unique ID.
Public Method | SiteExists | Queries whether a particular Site exists in the collection
Top

See Also

Reference

SIAPISites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISites Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : SIAPISites Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPISites()
C#
public SIAPISites()
Managed Extensions for C++
public: SIAPISites();
C++/CLI
public:
SIAPISites();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISites Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISites Class

Glossary Item Box

For a list of all members of this type, see SIAPISites members.

Public Methods

 | Name | Description
Public Method | GetEnumerator | Returns an IEnumerator object for the collection
Public Method | GetSiteByID | Get the Site by the database row unique ID.
Public Method | SiteExists | Queries whether a particular Site exists in the collection
Top

See Also

Reference

SIAPISites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : GetEnumerator Method

Glossary Item Box

Returns an IEnumerator object for the collection

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Return Value

Type: IEnumerator

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetSiteByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : GetSiteByID Method

site_id

Type: System.Int32;
The database row unique ID of the Site.
This is different from the "Site ID" in the Intersection dialog which can be accessed through ISIAPISite.Intersectionid.

Glossary Item Box

Get the Site by the database row unique ID.

Syntax

Visual Basic (Declaration)
Public Function GetSiteByID( _
   ByVal site_id As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim site_id As Integer
Dim value As ISIAPISite

value = instance.GetSiteByID(site_id)
C#
public ISIAPISite GetSiteByID(
   int site_id
)
Managed Extensions for C++
public: ISIAPISite* GetSiteByID(
   int site_id
)
C++/CLI
public:
ISIAPISite^ GetSiteByID(
   int site_id
)

Parameters

site_id

Type: System.Int32;
The database row unique ID of the Site.
This is different from the "Site ID" in the Intersection dialog which can be accessed through ISIAPISite.Intersectionid.

Remarks

Use ISIAPISites.Item[] to get a Site by its name or its position in the Site List. In C++, use ISIAPISites->get_Item() to get a Site by its name or get_Item_2() by its position.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : SiteExists Method

sitename
Site name to query

Glossary Item Box

Queries whether a particular Site exists in the collection

Syntax

Visual Basic (Declaration)
Public Function SiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim sitename As String
Dim value As Boolean

value = instance.SiteExists(sitename)
C#
public bool SiteExists(
   string sitename
)
Managed Extensions for C++
public: bool SiteExists(
   string* sitename
)
C++/CLI
public:
bool SiteExists(
   String^ sitename
)

Parameters

sitename
Site name to query

Return Value

Type: System.Bool

True, if a Site with the given site name exists in the collection. False otherwise

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPISites Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPISites Class

Glossary Item Box

For a list of all members of this type, see SIAPISites members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Overloaded. Get a Site from the collection by the Site name.
Top

See Also

Reference

SIAPISites Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Property Value

Number of items in collection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class : Item Property

Glossary Item Box

Get a Site from the collection by the Site name.

Overload List

Overload | Description
Item(String) | Get a Site from the collection by the Site name.
Item(Int32) | Get the Site at the specified index.

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class > Item Property : Item(String) Property

sitename
Site name

Glossary Item Box

Get a Site from the collection by the Site name.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim sitename As String
Dim value As ISIAPISite

value = instance.Item(sitename)
C#
public ISIAPISite Item(
   string sitename
) {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Item(
   string* sitename
);
C++/CLI
public:
property ISIAPISite^ Item {
   ISIAPISite^ get(String^ sitename);
}

Parameters

sitename
Site name

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPISites Class > Item Property : Item(Int32) Property

siteindex

Type: System.Int32;
The zero-based index of the Site to get.

Glossary Item Box

Get the Site at the specified index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal siteindex As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As SIAPISites
Dim siteindex As Integer
Dim value As ISIAPISite

value = instance.Item(siteindex)
C#
public ISIAPISite Item(
   int siteindex
) {get;}
Managed Extensions for C++
public: __property ISIAPISite* get_Item(
   int siteindex
);
C++/CLI
public:
property ISIAPISite^ Item {
   ISIAPISite^ get(int siteindex);
}

Parameters

siteindex

Type: System.Int32;
The zero-based index of the Site to get.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPISites Class
SIAPISites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControl Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControl Class

Glossary Item Box

Object Model

SIAPITwoWaySignControlAdjGeometryControl Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPITwoWaySignControlAdjGeometryControl
   Implements ISIAPITwoWaySignControlAdjGeometryControl
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControl
C#
public sealed class SIAPITwoWaySignControlAdjGeometryControl : ISIAPITwoWaySignControlAdjGeometryControl
Managed Extensions for C++
public __gc __sealed class SIAPITwoWaySignControlAdjGeometryControl : public ISIAPITwoWaySignControlAdjGeometryControl
C++/CLI
public ref class SIAPITwoWaySignControlAdjGeometryControl sealed : public ISIAPITwoWaySignControlAdjGeometryControl

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjGeometryControl

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControl Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControl Class

Glossary Item Box

The following tables list the members exposed by SIAPITwoWaySignControlAdjGeometryControl.

Public Constructors

 | Name | Description
Public Constructor | SIAPITwoWaySignControlAdjGeometryControl Constructor |
Top

Public Properties

 | Name | Description
Public Property | Critical_gap_adj |
Public Property | Followup_headway_adj |
Public Property | Type | The type of adjustment
Top

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControl Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControl Class : SIAPITwoWaySignControlAdjGeometryControl Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPITwoWaySignControlAdjGeometryControl()
C#
public SIAPITwoWaySignControlAdjGeometryControl()
Managed Extensions for C++
public: SIAPITwoWaySignControlAdjGeometryControl();
C++/CLI
public:
SIAPITwoWaySignControlAdjGeometryControl();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControl Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControl Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjGeometryControl members.

Public Properties

 | Name | Description
Public Property | Critical_gap_adj |
Public Property | Followup_headway_adj |
Public Property | Type | The type of adjustment
Top

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControl Class : Critical_gap_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Critical_gap_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControl
Dim value As Single

instance.Critical_gap_adj = value

value = instance.Critical_gap_adj
C#
public float Critical_gap_adj {get; set;}
Managed Extensions for C++
public: __property float get_Critical_gap_adj();
public: __property void set_Critical_gap_adj(
   float value
);
C++/CLI
public:
property float Critical_gap_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControl Class : Followup_headway_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Followup_headway_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControl
Dim value As Single

instance.Followup_headway_adj = value

value = instance.Followup_headway_adj
C#
public float Followup_headway_adj {get; set;}
Managed Extensions for C++
public: __property float get_Followup_headway_adj();
public: __property void set_Followup_headway_adj(
   float value
);
C++/CLI
public:
property float Followup_headway_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControl Class : Type Property

Glossary Item Box

The type of adjustment

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControl
Dim value As Integer

value = instance.Type
C#
public int Type {get;}
Managed Extensions for C++
public: __property int get_Type();
C++/CLI
public:
property int Type {
   int get();
}

Property Value

Type: System.Int32;

1 = Giveway/Yield Sign Control,
2 = One-Way Major Road,
3 = T-Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControl Class
SIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControls Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControls Class

Glossary Item Box

Object Model

SIAPITwoWaySignControlAdjGeometryControls ClassISIAPITwoWaySignControlAdjGeometryControl Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPITwoWaySignControlAdjGeometryControls
   Implements ISIAPITwoWaySignControlAdjGeometryControls
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControls
C#
public sealed class SIAPITwoWaySignControlAdjGeometryControls : ISIAPITwoWaySignControlAdjGeometryControls
Managed Extensions for C++
public __gc __sealed class SIAPITwoWaySignControlAdjGeometryControls : public ISIAPITwoWaySignControlAdjGeometryControls
C++/CLI
public ref class SIAPITwoWaySignControlAdjGeometryControls sealed : public ISIAPITwoWaySignControlAdjGeometryControls

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjGeometryControls

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControls Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControls Class

Glossary Item Box

The following tables list the members exposed by SIAPITwoWaySignControlAdjGeometryControls.

Public Constructors

 | Name | Description
Public Constructor | SIAPITwoWaySignControlAdjGeometryControls Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an entry of the data for the specified Type of Geometry and Control. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether the data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControls Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControls Class : SIAPITwoWaySignControlAdjGeometryControls Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPITwoWaySignControlAdjGeometryControls()
C#
public SIAPITwoWaySignControlAdjGeometryControls()
Managed Extensions for C++
public: SIAPITwoWaySignControlAdjGeometryControls();
C++/CLI
public:
SIAPITwoWaySignControlAdjGeometryControls();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControls Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControls Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjGeometryControls members.

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether the data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControls Class : Exists Method

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Glossary Item Box

Get a value indicating whether the data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal geoControlType As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControls
Dim geoControlType As Integer
Dim value As Boolean

value = instance.Exists(geoControlType)
C#
public bool Exists(
   int geoControlType
)
Managed Extensions for C++
public: bool Exists(
   int geoControlType
)
C++/CLI
public:
bool Exists(
   int geoControlType
)

Parameters

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControls Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControls
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjGeometryControls Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjGeometryControls Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjGeometryControls members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an entry of the data for the specified Type of Geometry and Control. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControls Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControls
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjGeometryControls Class : Item Property

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Glossary Item Box

Get an entry of the data for the specified Type of Geometry and Control.
Return an object if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal geoControlType As Integer _
) As ISIAPITwoWaySignControlAdjGeometryControl
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjGeometryControls
Dim geoControlType As Integer
Dim value As ISIAPITwoWaySignControlAdjGeometryControl

value = instance.Item(geoControlType)
C#
public ISIAPITwoWaySignControlAdjGeometryControl this[
   int geoControlType
]; {get;}
Managed Extensions for C++
public: __property ISIAPITwoWaySignControlAdjGeometryControl* get_Item   int geoControlType
;
C++/CLI
public:
property ISIAPITwoWaySignControlAdjGeometryControl^ default [int] {
   ISIAPITwoWaySignControlAdjGeometryControl^ get(int geoControlType);
}

Parameters

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjGeometryControls Class
SIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLane Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLane Class

Glossary Item Box

Object Model

SIAPITwoWaySignControlAdjMajorNumLane Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPITwoWaySignControlAdjMajorNumLane
   Implements ISIAPITwoWaySignControlAdjMajorNumLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLane
C#
public sealed class SIAPITwoWaySignControlAdjMajorNumLane : ISIAPITwoWaySignControlAdjMajorNumLane
Managed Extensions for C++
public __gc __sealed class SIAPITwoWaySignControlAdjMajorNumLane : public ISIAPITwoWaySignControlAdjMajorNumLane
C++/CLI
public ref class SIAPITwoWaySignControlAdjMajorNumLane sealed : public ISIAPITwoWaySignControlAdjMajorNumLane

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjMajorNumLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLane Class Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLane Class

Glossary Item Box

The following tables list the members exposed by SIAPITwoWaySignControlAdjMajorNumLane.

Public Constructors

 | Name | Description
Public Constructor | SIAPITwoWaySignControlAdjMajorNumLane Constructor |
Top

Public Properties

 | Name | Description
Public Property | Critical_gap_adj |
Public Property | Followup_headway_adj |
Public Property | Major_num_lane | Major Road Number of Lanes
Public Property | Movement_type | Movement Type
Top

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLane Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLane Class : SIAPITwoWaySignControlAdjMajorNumLane Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPITwoWaySignControlAdjMajorNumLane()
C#
public SIAPITwoWaySignControlAdjMajorNumLane()
Managed Extensions for C++
public: SIAPITwoWaySignControlAdjMajorNumLane();
C++/CLI
public:
SIAPITwoWaySignControlAdjMajorNumLane();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLane Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLane Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjMajorNumLane members.

Public Properties

 | Name | Description
Public Property | Critical_gap_adj |
Public Property | Followup_headway_adj |
Public Property | Major_num_lane | Major Road Number of Lanes
Public Property | Movement_type | Movement Type
Top

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLane Class : Critical_gap_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Critical_gap_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLane
Dim value As Single

instance.Critical_gap_adj = value

value = instance.Critical_gap_adj
C#
public float Critical_gap_adj {get; set;}
Managed Extensions for C++
public: __property float get_Critical_gap_adj();
public: __property void set_Critical_gap_adj(
   float value
);
C++/CLI
public:
property float Critical_gap_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLane Class : Followup_headway_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Followup_headway_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLane
Dim value As Single

instance.Followup_headway_adj = value

value = instance.Followup_headway_adj
C#
public float Followup_headway_adj {get; set;}
Managed Extensions for C++
public: __property float get_Followup_headway_adj();
public: __property void set_Followup_headway_adj(
   float value
);
C++/CLI
public:
property float Followup_headway_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Major_num_lane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLane Class : Major_num_lane Property

Glossary Item Box

Major Road Number of Lanes

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Major_num_lane As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLane
Dim value As Integer

value = instance.Major_num_lane
C#
public int Major_num_lane {get;}
Managed Extensions for C++
public: __property int get_Major_num_lane();
C++/CLI
public:
property int Major_num_lane {
   int get();
}

Property Value

Type: System.Int32;

Can be 2, 3, 5, 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLane Class : Movement_type Property

Glossary Item Box

Movement Type

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Movement_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLane
Dim value As Integer

value = instance.Movement_type
C#
public int Movement_type {get;}
Managed Extensions for C++
public: __property int get_Movement_type();
C++/CLI
public:
property int Movement_type {
   int get();
}

Property Value

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLane Class
SIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLanes Class
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLanes Class

Glossary Item Box

Object Model

SIAPITwoWaySignControlAdjMajorNumLanes ClassISIAPITwoWaySignControlAdjMajorNumLane Interface

Syntax

Visual Basic (Declaration)
Public NotInheritable Class SIAPITwoWaySignControlAdjMajorNumLanes
   Implements ISIAPITwoWaySignControlAdjMajorNumLanes
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLanes
C#
public sealed class SIAPITwoWaySignControlAdjMajorNumLanes : ISIAPITwoWaySignControlAdjMajorNumLanes
Managed Extensions for C++
public __gc __sealed class SIAPITwoWaySignControlAdjMajorNumLanes : public ISIAPITwoWaySignControlAdjMajorNumLanes
C++/CLI
public ref class SIAPITwoWaySignControlAdjMajorNumLanes sealed : public ISIAPITwoWaySignControlAdjMajorNumLanes

Inheritance Hierarchy

System.Object
SIDRASolutions.SI.API.SIAPITwoWaySignControlAdjMajorNumLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLanes Class Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLanes Class

Glossary Item Box

The following tables list the members exposed by SIAPITwoWaySignControlAdjMajorNumLanes.

Public Constructors

 | Name | Description
Public Constructor | SIAPITwoWaySignControlAdjMajorNumLanes Constructor |
Top

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether the data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLanes Constructor
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLanes Class : SIAPITwoWaySignControlAdjMajorNumLanes Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SIAPITwoWaySignControlAdjMajorNumLanes()
C#
public SIAPITwoWaySignControlAdjMajorNumLanes()
Managed Extensions for C++
public: SIAPITwoWaySignControlAdjMajorNumLanes();
C++/CLI
public:
SIAPITwoWaySignControlAdjMajorNumLanes();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLanes Class Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjMajorNumLanes members.

Public Methods

 | Name | Description
Public Method | Exists | Get a value indicating whether the data exists in the data structure.
Public Method | GetEnumerator |
Top

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLanes Class : Exists Method

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Glossary Item Box

Get a value indicating whether the data exists in the data structure.

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal majorRoadNumOfLane As Integer, _
   ByVal movType As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLanes
Dim majorRoadNumOfLane As Integer
Dim movType As Integer
Dim value As Boolean

value = instance.Exists(majorRoadNumOfLane, movType)
C#
public bool Exists(
   int majorRoadNumOfLane,
   int movType
)
Managed Extensions for C++
public: bool Exists(
   int majorRoadNumOfLane,
   int movType
)
C++/CLI
public:
bool Exists(
   int majorRoadNumOfLane,
   int movType
)

Parameters

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetEnumerator Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLanes Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLanes
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public IEnumerator GetEnumerator()
Managed Extensions for C++
public: IEnumerator* GetEnumerator();
C++/CLI
public:
IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SIAPITwoWaySignControlAdjMajorNumLanes Class Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : SIAPITwoWaySignControlAdjMajorNumLanes Class

Glossary Item Box

For a list of all members of this type, see SIAPITwoWaySignControlAdjMajorNumLanes members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | Item | Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLanes Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLanes
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > SIAPITwoWaySignControlAdjMajorNumLanes Class : Item Property

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Glossary Item Box

Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type.
Return an object if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal majorRoadNumOfLane As Integer, _
   ByVal movType As Integer _
) As ISIAPITwoWaySignControlAdjMajorNumLane
Visual Basic (Usage) Copy Code
Dim instance As SIAPITwoWaySignControlAdjMajorNumLanes
Dim majorRoadNumOfLane As Integer
Dim movType As Integer
Dim value As ISIAPITwoWaySignControlAdjMajorNumLane

value = instance.Item(majorRoadNumOfLane, movType)
C#
public ISIAPITwoWaySignControlAdjMajorNumLane this[
   int majorRoadNumOfLane,
   int movType
]; {get;}
Managed Extensions for C++
public: __property ISIAPITwoWaySignControlAdjMajorNumLane* get_Item   int majorRoadNumOfLane,
   int movType
;
C++/CLI
public:
property ISIAPITwoWaySignControlAdjMajorNumLane^ default [int,int] {
   ISIAPITwoWaySignControlAdjMajorNumLane^ get(int majorRoadNumOfLane, int movType);
}

Parameters

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

SIAPITwoWaySignControlAdjMajorNumLanes Class
SIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPI Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPI Interface

Glossary Item Box

SIDRA INTERSECTION API wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPI
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
C#
public interface ISIAPI
Managed Extensions for C++
public __gc __interface ISIAPI
C++/CLI
public interface class ISIAPI

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPI Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPI Interface

Glossary Item Box

The following tables list the members exposed by ISIAPI.

Public Properties

 | Name | Description
Property | DbConnection | Current DataContext.Connection
Property | IntPtrSize |
Property | IsLicensed | Indicates whether the installed version of SIDRA INTERSECTION is licensed.
Property | LastErrorMessage |
Property | Project | Current open SIDRA INTERSECTION project.
Top

Public Methods

 | Name | Description
Method | Close |
Method | CloseDbConnection | Closes the connection to the database (i.e. the project file)
Method | CloseProject | Closes a SIDRA INTERSECTION Project.
Method | CreateAndOpenProject | Creates and opens a SIDRA INTERSECTION Project.
Method | OpenDbConnection | Opens the connection to the database (i.e. the project file)
Method | OpenProject | Opens a SIDRA INTERSECTION Project.
Method | SubmitDataChanges | Submits data changes to the database (i.e. the project file).
Top

See Also

Reference

ISIAPI Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPI Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPI Interface

Glossary Item Box

For a list of all members of this type, see ISIAPI members.

Public Methods

 | Name | Description
Method | Close |
Method | CloseDbConnection | Closes the connection to the database (i.e. the project file)
Method | CloseProject | Closes a SIDRA INTERSECTION Project.
Method | CreateAndOpenProject | Creates and opens a SIDRA INTERSECTION Project.
Method | OpenDbConnection | Opens the connection to the database (i.e. the project file)
Method | OpenProject | Opens a SIDRA INTERSECTION Project.
Method | SubmitDataChanges | Submits data changes to the database (i.e. the project file).
Top

See Also

Reference

ISIAPI Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Close Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function Close() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.Close()
C#
bool Close()
Managed Extensions for C++
bool Close();
C++/CLI
bool Close();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloseDbConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : CloseDbConnection Method

Glossary Item Box

Closes the connection to the database (i.e. the project file)

Syntax

Visual Basic (Declaration)
Function CloseDbConnection() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.CloseDbConnection()
C#
bool CloseDbConnection()
Managed Extensions for C++
bool CloseDbConnection();
C++/CLI
bool CloseDbConnection();

Remarks

If the program is connecting to a temporary copy of the original project file, one thing needs to be considered. The submitted data changes might have not been saved to the temporary project file because there is a time interval before all submitted changes are flushed to disk. When the temporary project file is copied back to the original project file, some changes might not be included.

Call the CloseDbConnection() method to close the database connection to force all submitted changes to be flushed to disk. Call the OpenDbConnection() method to open the database connection again for later operations.

After all the changes are flushed to disk, the temporary project file includes all the submitted changes and is ready to be copied back to the original project file.

If the program is connecting to the original project file directly, the call to CloseDbConnection() is not required. All submitted changes will be flushed to disk every few seconds or when the project is closed at the end.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloseProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : CloseProject Method

Glossary Item Box

Closes a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Function CloseProject() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.CloseProject()
C#
bool CloseProject()
Managed Extensions for C++
bool CloseProject();
C++/CLI
bool CloseProject();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateAndOpenProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : CreateAndOpenProject Method

filename
Path of the SIDRA INTERSECTION Project file to open
newProjectName
The Project name

Glossary Item Box

Creates and opens a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Function CreateAndOpenProject( _
   ByVal filename As String, _
   ByVal newProjectName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim filename As String
Dim newProjectName As String
Dim value As Boolean

value = instance.CreateAndOpenProject(filename, newProjectName)
C#
bool CreateAndOpenProject(
   string filename,
   string newProjectName
)
Managed Extensions for C++
bool CreateAndOpenProject(
   string* filename,
   string* newProjectName
)
C++/CLI
bool CreateAndOpenProject(
   String^ filename,
   String^ newProjectName
)

Parameters

filename
Path of the SIDRA INTERSECTION Project file to open
newProjectName
The Project name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpenDbConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : OpenDbConnection Method

Glossary Item Box

Opens the connection to the database (i.e. the project file)

Syntax

Visual Basic (Declaration)
Function OpenDbConnection() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.OpenDbConnection()
C#
bool OpenDbConnection()
Managed Extensions for C++
bool OpenDbConnection();
C++/CLI
bool OpenDbConnection();

Remarks

If the program is connecting to a temporary copy of the original project file, one thing needs to be considered. The submitted data changes might have not been saved to the temporary project file because there is a time interval before all submitted changes are flushed to disk. When the temporary project file is copied back to the original project file, some changes might not be included.

Call the CloseDbConnection() method to close the database connection to force all submitted changes to be flushed to disk. Call the OpenDbConnection() method to open the database connection again for later operations.

After all the changes are flushed to disk, the temporary project file includes all the submitted changes and is ready to be copied back to the original project file.

If the program is connecting to the original project file directly, the call to CloseDbConnection() is not required. All submitted changes will be flushed to disk every few seconds or when the project is closed at the end.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpenProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : OpenProject Method

filename
Path of the SIDRA INTERSECTION Project file to open

Glossary Item Box

Opens a SIDRA INTERSECTION Project.

Syntax

Visual Basic (Declaration)
Function OpenProject( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim filename As String
Dim value As Boolean

value = instance.OpenProject(filename)
C#
bool OpenProject(
   string filename
)
Managed Extensions for C++
bool OpenProject(
   string* filename
)
C++/CLI
bool OpenProject(
   String^ filename
)

Parameters

filename
Path of the SIDRA INTERSECTION Project file to open

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SubmitDataChanges Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : SubmitDataChanges Method

Glossary Item Box

Submits data changes to the database (i.e. the project file).

Syntax

Visual Basic (Declaration)
Function SubmitDataChanges() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.SubmitDataChanges()
C#
bool SubmitDataChanges()
Managed Extensions for C++
bool SubmitDataChanges();
C++/CLI
bool SubmitDataChanges();

Remarks

This method calls the underlying DataContext.SubmitChanges() method.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPI Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPI Interface

Glossary Item Box

For a list of all members of this type, see ISIAPI members.

Public Properties

 | Name | Description
Property | DbConnection | Current DataContext.Connection
Property | IntPtrSize |
Property | IsLicensed | Indicates whether the installed version of SIDRA INTERSECTION is licensed.
Property | LastErrorMessage |
Property | Project | Current open SIDRA INTERSECTION project.
Top

See Also

Reference

ISIAPI Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DbConnection Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : DbConnection Property

Glossary Item Box

Current DataContext.Connection

Syntax

Visual Basic (Declaration)
ReadOnly Property DbConnection As DbConnection
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As DbConnection

value = instance.DbConnection
C#
DbConnection DbConnection {get;}
Managed Extensions for C++
__property DbConnection* get_DbConnection();
C++/CLI
property DbConnection^ DbConnection {
   DbConnection^ get();
}

Property Value

Type: System.Data.Common.DbConnection

If no project is open, NULL is returned.

Remarks

This property does not exist in COM Interface.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IntPtrSize Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : IntPtrSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IntPtrSize As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Integer

value = instance.IntPtrSize
C#
int IntPtrSize {get;}
Managed Extensions for C++
__property int get_IntPtrSize();
C++/CLI
property int IntPtrSize {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsLicensed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : IsLicensed Property

Glossary Item Box

Indicates whether the installed version of SIDRA INTERSECTION is licensed.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsLicensed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As Boolean

value = instance.IsLicensed
C#
bool IsLicensed {get;}
Managed Extensions for C++
__property bool get_IsLicensed();
C++/CLI
property bool IsLicensed {
   bool get();
}

Property Value

Type: System.Boolean

True if licensed. False if unlicensed or in Trial Mode.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPI Interface : Project Property

Glossary Item Box

Current open SIDRA INTERSECTION project.

Syntax

Visual Basic (Declaration)
ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As ISIAPI
Dim value As ISIAPIProject

value = instance.Project
C#
ISIAPIProject Project {get;}
Managed Extensions for C++
__property ISIAPIProject* get_Project();
C++/CLI
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Property Value

Type: ISIAPIProject

If no project is open NULL is returned.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPI Interface
ISIAPI Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIAnalysis Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIAnalysis Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIAnalysis
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
C#
public interface ISIAPIAnalysis
Managed Extensions for C++
public __gc __interface ISIAPIAnalysis
C++/CLI
public interface class ISIAPIAnalysis

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIAnalysis Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIAnalysis Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIAnalysis.

Public Properties

 | Name | Description
Property | Analysis_option | Analysis Option
Property | Design_Life_Constant_num_years |
Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Property | Design_Life_Is_constant_num_years_applied |
Property | Design_Life_Objective | Design Life Analysis Objective
Property | Design_Life_Years |
Property | Flow_Scale_Constant_factor |
Property | Flow_Scale_Is_constant_factor_applied |
Property | Flow_Scale_Lower |
Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Property | Flow_Scale_Upper |
Property | Result_lane_origin |
Property | Result_laneno |
Property | Result_leg_origin |
Property | Result_mc_class |
Property | Result_option | Results For
Property | Result_pedmov_option | Pedestrian Movement Results Option
Property | Result_pedmov_origin |
Property | Result_pedmov_stage_no |
Property | Result_pedmov_type |
Property | Result_vehmov_dest |
Property | Result_vehmov_origin |
Property | Selected_sensitivity_groupno | Selected Sensitivity Parameter Group Number
Property | SensitivityGeneralParameterGroup |
Property | SensitivityRoundaboutParameterGroup |
Property | Site |
Top

See Also

Reference

ISIAPIAnalysis Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIAnalysis Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIAnalysis Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIAnalysis members.

Public Properties

 | Name | Description
Property | Analysis_option | Analysis Option
Property | Design_Life_Constant_num_years |
Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Property | Design_Life_Is_constant_num_years_applied |
Property | Design_Life_Objective | Design Life Analysis Objective
Property | Design_Life_Years |
Property | Flow_Scale_Constant_factor |
Property | Flow_Scale_Is_constant_factor_applied |
Property | Flow_Scale_Lower |
Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Property | Flow_Scale_Upper |
Property | Result_lane_origin |
Property | Result_laneno |
Property | Result_leg_origin |
Property | Result_mc_class |
Property | Result_option | Results For
Property | Result_pedmov_option | Pedestrian Movement Results Option
Property | Result_pedmov_origin |
Property | Result_pedmov_stage_no |
Property | Result_pedmov_type |
Property | Result_vehmov_dest |
Property | Result_vehmov_origin |
Property | Selected_sensitivity_groupno | Selected Sensitivity Parameter Group Number
Property | SensitivityGeneralParameterGroup |
Property | SensitivityRoundaboutParameterGroup |
Property | Site |
Top

See Also

Reference

ISIAPIAnalysis Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Analysis_option Property

Glossary Item Box

Analysis Option

Syntax

Visual Basic (Declaration)
Property Analysis_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Analysis_option = value

value = instance.Analysis_option
C#
int Analysis_option {get; set;}
Managed Extensions for C++
__property int get_Analysis_option();
__property void set_Analysis_option(
   int value
);
C++/CLI
property int Analysis_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Sensitivity,
2 = Design Life,
3 = Flow Scale.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Constant_num_years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Design_Life_Constant_num_years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Constant_num_years As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Design_Life_Constant_num_years = value

value = instance.Design_Life_Constant_num_years
C#
int Design_Life_Constant_num_years {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Constant_num_years();
__property void set_Design_Life_Constant_num_years(
   int value
);
C++/CLI
property int Design_Life_Constant_num_years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Growth_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Design_Life_Growth_Model Property

Glossary Item Box

Design Life Analysis Growth Model

Syntax

Visual Basic (Declaration)
Property Design_Life_Growth_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Design_Life_Growth_Model = value

value = instance.Design_Life_Growth_Model
C#
int Design_Life_Growth_Model {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Growth_Model();
__property void set_Design_Life_Growth_Model(
   int value
);
C++/CLI
property int Design_Life_Growth_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Uniform,
1 = Compound.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Is_constant_num_years_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Design_Life_Is_constant_num_years_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Is_constant_num_years_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Boolean

instance.Design_Life_Is_constant_num_years_applied = value

value = instance.Design_Life_Is_constant_num_years_applied
C#
bool Design_Life_Is_constant_num_years_applied {get; set;}
Managed Extensions for C++
__property bool get_Design_Life_Is_constant_num_years_applied();
__property void set_Design_Life_Is_constant_num_years_applied(
   bool value
);
C++/CLI
property bool Design_Life_Is_constant_num_years_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Design_Life_Objective Property

Glossary Item Box

Design Life Analysis Objective

Syntax

Visual Basic (Declaration)
Property Design_Life_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Design_Life_Objective = value

value = instance.Design_Life_Objective
C#
int Design_Life_Objective {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Objective();
__property void set_Design_Life_Objective(
   int value
);
C++/CLI
property int Design_Life_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
2 = Worst Lane Level of Service Target,
3 = Worst Movement Level of Service Target,
4 = Final Year.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Design_Life_Years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Years As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Design_Life_Years = value

value = instance.Design_Life_Years
C#
int Design_Life_Years {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Years();
__property void set_Design_Life_Years(
   int value
);
C++/CLI
property int Design_Life_Years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Flow_Scale_Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Constant_factor = value

value = instance.Flow_Scale_Constant_factor
C#
float Flow_Scale_Constant_factor {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Constant_factor();
__property void set_Flow_Scale_Constant_factor(
   float value
);
C++/CLI
property float Flow_Scale_Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Flow_Scale_Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Boolean

instance.Flow_Scale_Is_constant_factor_applied = value

value = instance.Flow_Scale_Is_constant_factor_applied
C#
bool Flow_Scale_Is_constant_factor_applied {get; set;}
Managed Extensions for C++
__property bool get_Flow_Scale_Is_constant_factor_applied();
__property void set_Flow_Scale_Is_constant_factor_applied(
   bool value
);
C++/CLI
property bool Flow_Scale_Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Flow_Scale_Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Lower = value

value = instance.Flow_Scale_Lower
C#
float Flow_Scale_Lower {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Lower();
__property void set_Flow_Scale_Lower(
   float value
);
C++/CLI
property float Flow_Scale_Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Flow_Scale_Objective Property

Glossary Item Box

Flow Scale Analysis Objective

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Flow_Scale_Objective = value

value = instance.Flow_Scale_Objective
C#
int Flow_Scale_Objective {get; set;}
Managed Extensions for C++
__property int get_Flow_Scale_Objective();
__property void set_Flow_Scale_Objective(
   int value
);
C++/CLI
property int Flow_Scale_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
2 = Worst Lane Level of Service Target,
3 = Worst Movement Level of Service Target,
4 = Upper Limit.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Flow_Scale_Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Single

instance.Flow_Scale_Upper = value

value = instance.Flow_Scale_Upper
C#
float Flow_Scale_Upper {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Upper();
__property void set_Flow_Scale_Upper(
   float value
);
C++/CLI
property float Flow_Scale_Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_lane_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_lane_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_lane_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_lane_origin = value

value = instance.Result_lane_origin
C#
int Result_lane_origin {get; set;}
Managed Extensions for C++
__property int get_Result_lane_origin();
__property void set_Result_lane_origin(
   int value
);
C++/CLI
property int Result_lane_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_laneno = value

value = instance.Result_laneno
C#
int Result_laneno {get; set;}
Managed Extensions for C++
__property int get_Result_laneno();
__property void set_Result_laneno(
   int value
);
C++/CLI
property int Result_laneno {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_leg_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_leg_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_leg_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_leg_origin = value

value = instance.Result_leg_origin
C#
int Result_leg_origin {get; set;}
Managed Extensions for C++
__property int get_Result_leg_origin();
__property void set_Result_leg_origin(
   int value
);
C++/CLI
property int Result_leg_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_mc_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_mc_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_mc_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_mc_class = value

value = instance.Result_mc_class
C#
int Result_mc_class {get; set;}
Managed Extensions for C++
__property int get_Result_mc_class();
__property void set_Result_mc_class(
   int value
);
C++/CLI
property int Result_mc_class {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_option Property

Glossary Item Box

Results For

Syntax

Visual Basic (Declaration)
Property Result_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_option = value

value = instance.Result_option
C#
int Result_option {get; set;}
Managed Extensions for C++
__property int get_Result_option();
__property void set_Result_option(
   int value
);
C++/CLI
property int Result_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Intersection - Vehicles,
2 = Intersection - Pedestrians,
3 = Intersection - Persons,
4 = Lane,
5 = Vehicle OD Movement,
6 = Pedestrian Movement,
7 = Approach (All Movements / All Lanes).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_pedmov_option Property

Glossary Item Box

Pedestrian Movement Results Option

Syntax

Visual Basic (Declaration)
Property Result_pedmov_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_option = value

value = instance.Result_pedmov_option
C#
int Result_pedmov_option {get; set;}
Managed Extensions for C++
__property int get_Result_pedmov_option();
__property void set_Result_pedmov_option(
   int value
);
C++/CLI
property int Result_pedmov_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Movement in front of an Approach,
2 = Diagonal Crossing Movement.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_pedmov_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_pedmov_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_origin = value

value = instance.Result_pedmov_origin
C#
int Result_pedmov_origin {get; set;}
Managed Extensions for C++
__property int get_Result_pedmov_origin();
__property void set_Result_pedmov_origin(
   int value
);
C++/CLI
property int Result_pedmov_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_stage_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_pedmov_stage_no Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_pedmov_stage_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_stage_no = value

value = instance.Result_pedmov_stage_no
C#
int Result_pedmov_stage_no {get; set;}
Managed Extensions for C++
__property int get_Result_pedmov_stage_no();
__property void set_Result_pedmov_stage_no(
   int value
);
C++/CLI
property int Result_pedmov_stage_no {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_pedmov_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_pedmov_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_pedmov_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_pedmov_type = value

value = instance.Result_pedmov_type
C#
int Result_pedmov_type {get; set;}
Managed Extensions for C++
__property int get_Result_pedmov_type();
__property void set_Result_pedmov_type(
   int value
);
C++/CLI
property int Result_pedmov_type {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_vehmov_dest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_vehmov_dest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_vehmov_dest As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_vehmov_dest = value

value = instance.Result_vehmov_dest
C#
int Result_vehmov_dest {get; set;}
Managed Extensions for C++
__property int get_Result_vehmov_dest();
__property void set_Result_vehmov_dest(
   int value
);
C++/CLI
property int Result_vehmov_dest {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_vehmov_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Result_vehmov_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Result_vehmov_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Result_vehmov_origin = value

value = instance.Result_vehmov_origin
C#
int Result_vehmov_origin {get; set;}
Managed Extensions for C++
__property int get_Result_vehmov_origin();
__property void set_Result_vehmov_origin(
   int value
);
C++/CLI
property int Result_vehmov_origin {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_sensitivity_groupno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Selected_sensitivity_groupno Property

Glossary Item Box

Selected Sensitivity Parameter Group Number

Syntax

Visual Basic (Declaration)
Property Selected_sensitivity_groupno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As Integer

instance.Selected_sensitivity_groupno = value

value = instance.Selected_sensitivity_groupno
C#
int Selected_sensitivity_groupno {get; set;}
Managed Extensions for C++
__property int get_Selected_sensitivity_groupno();
__property void set_Selected_sensitivity_groupno(
   int value
);
C++/CLI
property int Selected_sensitivity_groupno {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = General Parameter Group,
1 = Roundabout Parameter Group.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityGeneralParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : SensitivityGeneralParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SensitivityGeneralParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As ISIAPISensitivity

value = instance.SensitivityGeneralParameterGroup
C#
ISIAPISensitivity SensitivityGeneralParameterGroup {get;}
Managed Extensions for C++
__property ISIAPISensitivity* get_SensitivityGeneralParameterGroup();
C++/CLI
property ISIAPISensitivity^ SensitivityGeneralParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityRoundaboutParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : SensitivityRoundaboutParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SensitivityRoundaboutParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As ISIAPISensitivity

value = instance.SensitivityRoundaboutParameterGroup
C#
ISIAPISensitivity SensitivityRoundaboutParameterGroup {get;}
Managed Extensions for C++
__property ISIAPISensitivity* get_SensitivityRoundaboutParameterGroup();
C++/CLI
property ISIAPISensitivity^ SensitivityRoundaboutParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIAnalysis Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIAnalysis
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIAnalysis Interface
ISIAPIAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsg Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsg Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIDiagnosticMsg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsg
C#
public interface ISIAPIDiagnosticMsg
Managed Extensions for C++
public __gc __interface ISIAPIDiagnosticMsg
C++/CLI
public interface class ISIAPIDiagnosticMsg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsg Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsg Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIDiagnosticMsg.

Public Properties

 | Name | Description
Property | Log_time |
Property | Message |
Property | Message_type | Message Type
Top

See Also

Reference

ISIAPIDiagnosticMsg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsg Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsg Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIDiagnosticMsg members.

Public Properties

 | Name | Description
Property | Log_time |
Property | Message |
Property | Message_type | Message Type
Top

See Also

Reference

ISIAPIDiagnosticMsg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Log_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIDiagnosticMsg Interface : Log_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Log_time As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsg
Dim value As Date

value = instance.Log_time
C#
DateTime Log_time {get;}
Managed Extensions for C++
__property DateTime get_Log_time();
C++/CLI
property DateTime Log_time {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsg Interface
ISIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Message Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIDiagnosticMsg Interface : Message Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsg
Dim value As String

value = instance.Message
C#
string Message {get;}
Managed Extensions for C++
__property string* get_Message();
C++/CLI
property String^ Message {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsg Interface
ISIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Message_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIDiagnosticMsg Interface : Message_type Property

Glossary Item Box

Message Type

Syntax

Visual Basic (Declaration)
ReadOnly Property Message_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsg
Dim value As Integer

value = instance.Message_type
C#
int Message_type {get;}
Managed Extensions for C++
__property int get_Message_type();
C++/CLI
property int Message_type {
   int get();
}

Property Value

Type: System.Int32;

0 = Information,
1 = Warning,
2 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsg Interface
ISIAPIDiagnosticMsg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsgs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsgs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsgs
C#
public interface ISIAPIDiagnosticMsgs
Managed Extensions for C++
public __gc __interface ISIAPIDiagnosticMsgs
C++/CLI
public interface class ISIAPIDiagnosticMsgs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsgs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsgs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsgs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIDiagnosticMsgs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIDiagnosticMsgs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsgs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsgs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIDiagnosticMsgs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIDiagnosticMsgs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIDiagnosticMsgs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsgs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsgs Interface
ISIAPIDiagnosticMsgs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIDiagnosticMsgs Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIDiagnosticMsg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIDiagnosticMsgs
Dim index As Integer
Dim value As ISIAPIDiagnosticMsg

value = instance.Item(index)
C#
ISIAPIDiagnosticMsg this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIDiagnosticMsg* get_Item   int index
;
C++/CLI
property ISIAPIDiagnosticMsg^ default [int] {
   ISIAPIDiagnosticMsg^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIDiagnosticMsgs Interface
ISIAPIDiagnosticMsgs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIGapAcceptanceSpecificApp Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIGapAcceptanceSpecificApp Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIGapAcceptanceSpecificApp
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
C#
public interface ISIAPIGapAcceptanceSpecificApp
Managed Extensions for C++
public __gc __interface ISIAPIGapAcceptanceSpecificApp
C++/CLI
public interface class ISIAPIGapAcceptanceSpecificApp

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIGapAcceptanceSpecificApp Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIGapAcceptanceSpecificApp Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIGapAcceptanceSpecificApp.

Public Properties

 | Name | Description
Property | Critical_gap |
Property | End_departures |
Property | Exit_flow_effect |
Property | Followup_headway |
Property | Percent_opposed_by_nearest |
Top

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIGapAcceptanceSpecificApp Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIGapAcceptanceSpecificApp Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIGapAcceptanceSpecificApp members.

Public Properties

 | Name | Description
Property | Critical_gap |
Property | End_departures |
Property | Exit_flow_effect |
Property | Followup_headway |
Property | Percent_opposed_by_nearest |
Top

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIGapAcceptanceSpecificApp Interface : Critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Critical_gap = value

value = instance.Critical_gap
C#
float Critical_gap {get; set;}
Managed Extensions for C++
__property float get_Critical_gap();
__property void set_Critical_gap(
   float value
);
C++/CLI
property float Critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
ISIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIGapAcceptanceSpecificApp Interface : End_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property End_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.End_departures = value

value = instance.End_departures
C#
float End_departures {get; set;}
Managed Extensions for C++
__property float get_End_departures();
__property void set_End_departures(
   float value
);
C++/CLI
property float End_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
ISIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_flow_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIGapAcceptanceSpecificApp Interface : Exit_flow_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Exit_flow_effect As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Exit_flow_effect = value

value = instance.Exit_flow_effect
C#
float Exit_flow_effect {get; set;}
Managed Extensions for C++
__property float get_Exit_flow_effect();
__property void set_Exit_flow_effect(
   float value
);
C++/CLI
property float Exit_flow_effect {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
ISIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIGapAcceptanceSpecificApp Interface : Followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Followup_headway = value

value = instance.Followup_headway
C#
float Followup_headway {get; set;}
Managed Extensions for C++
__property float get_Followup_headway();
__property void set_Followup_headway(
   float value
);
C++/CLI
property float Followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
ISIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_opposed_by_nearest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIGapAcceptanceSpecificApp Interface : Percent_opposed_by_nearest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Percent_opposed_by_nearest As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIGapAcceptanceSpecificApp
Dim value As Single

instance.Percent_opposed_by_nearest = value

value = instance.Percent_opposed_by_nearest
C#
float Percent_opposed_by_nearest {get; set;}
Managed Extensions for C++
__property float get_Percent_opposed_by_nearest();
__property void set_Percent_opposed_by_nearest(
   float value
);
C++/CLI
property float Percent_opposed_by_nearest {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIGapAcceptanceSpecificApp Interface
ISIAPIGapAcceptanceSpecificApp Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIsland Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIsland Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
C#
public interface ISIAPIIsland
Managed Extensions for C++
public __gc __interface ISIAPIIsland
C++/CLI
public interface class ISIAPIIsland

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIsland Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIsland Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIIsland.

Public Properties

 | Name | Description
Property | Fill_style | Island Fill Style
Property | Is_pedstage_separator |
Property | Is_rou_splitter |
Property | Island_no | Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Width | Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.
Property | Width_back | Island's Back Width
Top

See Also

Reference

ISIAPIIsland Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIsland Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIsland Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIIsland members.

Public Properties

 | Name | Description
Property | Fill_style | Island Fill Style
Property | Is_pedstage_separator |
Property | Is_rou_splitter |
Property | Island_no | Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Width | Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.
Property | Width_back | Island's Back Width
Top

See Also

Reference

ISIAPIIsland Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fill_style Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Fill_style Property

Glossary Item Box

Island Fill Style

Syntax

Visual Basic (Declaration)
Property Fill_style As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Integer

instance.Fill_style = value

value = instance.Fill_style
C#
int Fill_style {get; set;}
Managed Extensions for C++
__property int get_Fill_style();
__property void set_Fill_style(
   int value
);
C++/CLI
property int Fill_style {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Solid,
2 = Hatched,
3 = Chevron,
4 = Parking Strip.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_pedstage_separator Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Is_pedstage_separator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_pedstage_separator As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Boolean

instance.Is_pedstage_separator = value

value = instance.Is_pedstage_separator
C#
bool Is_pedstage_separator {get; set;}
Managed Extensions for C++
__property bool get_Is_pedstage_separator();
__property void set_Is_pedstage_separator(
   bool value
);
C++/CLI
property bool Is_pedstage_separator {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_rou_splitter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Is_rou_splitter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Is_rou_splitter As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Boolean

value = instance.Is_rou_splitter
C#
bool Is_rou_splitter {get;}
Managed Extensions for C++
__property bool get_Is_rou_splitter();
C++/CLI
property bool Is_rou_splitter {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Island_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Island_no Property

Glossary Item Box

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Island_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Integer

value = instance.Island_no
C#
int Island_no {get;}
Managed Extensions for C++
__property int get_Island_no();
C++/CLI
property int Island_no {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Width Property

Glossary Item Box

Island's Front Width. If this is a Roundabout Splitter Island, the Front Width value is ignore.

Syntax

Visual Basic (Declaration)
Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Single

instance.Width = value

value = instance.Width
C#
float Width {get; set;}
Managed Extensions for C++
__property float get_Width();
__property void set_Width(
   float value
);
C++/CLI
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width_back Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIsland Interface : Width_back Property

Glossary Item Box

Island's Back Width

Syntax

Visual Basic (Declaration)
Property Width_back As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIsland
Dim value As Single

instance.Width_back = value

value = instance.Width_back
C#
float Width_back {get; set;}
Managed Extensions for C++
__property float get_Width_back();
__property void set_Width_back(
   float value
);
C++/CLI
property float Width_back {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIsland Interface
ISIAPIIsland Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIslands Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIslands Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIIslands
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIslands
C#
public interface ISIAPIIslands
Managed Extensions for C++
public __gc __interface ISIAPIIslands
C++/CLI
public interface class ISIAPIIslands

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIslands Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIslands Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIslands Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIIslands.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | IslandExists |
Top

See Also

Reference

ISIAPIIslands Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIslands Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIslands Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIIslands members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | IslandExists |
Top

See Also

Reference

ISIAPIIslands Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IslandExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIslands Interface : IslandExists Method

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function IslandExists( _
   ByVal island_no As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIslands
Dim island_no As Integer
Dim value As Boolean

value = instance.IslandExists(island_no)
C#
bool IslandExists(
   int island_no
)
Managed Extensions for C++
bool IslandExists(
   int island_no
)
C++/CLI
bool IslandExists(
   int island_no
)

Parameters

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIslands Interface
ISIAPIIslands Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIIslands Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIIslands Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIIslands members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIIslands Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIslands Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIslands
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIslands Interface
ISIAPIIslands Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIIslands Interface : Item Property

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal island_no As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIIslands
Dim island_no As Integer
Dim value As ISIAPIIsland

value = instance.Item(island_no)
C#
ISIAPIIsland this[
   int island_no
]; {get;}
Managed Extensions for C++
__property ISIAPIIsland* get_Item   int island_no
;
C++/CLI
property ISIAPIIsland^ default [int] {
   ISIAPIIsland^ get(int island_no);
}

Parameters

island_no

Island Number, a one-based integer, counts Islands only from left to right looking to the centre of the Intersection.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIIslands Interface
ISIAPIIslands Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproach Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproach Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
C#
public interface ISIAPILaneApproach
Managed Extensions for C++
public __gc __interface ISIAPILaneApproach
C++/CLI
public interface class ISIAPILaneApproach

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproach Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproach Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproach.

Public Properties

 | Name | Description
Property | Basic_saturation_flow |
Property | Buses_stopping |
Property | Buses_stopping_user |
Property | Capacity_adjustment |
Property | Configuration | Lane Configuration
Property | Control_type | Lane Control Type
Property | Departure_headway_awsc |
Property | Grade |
Property | Is_capacity_adj_for_network |
Property | Is_departure_headway_awsc_applied |
Property | Is_dominant_lane |
Property | Is_sliplane_excluded_from_signal_analysis |
Property | Is_sliplane_included_in_entry_lane_count |
Property | LaneApproachMovements | Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).
Property | LaneMovements |
Property | Laneno | Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.
Property | LastErrorMessage |
Property | Leg |
Property | Length | Lane Length
Property | Parking_manoeuvres |
Property | Parking_manoeuvres_user |
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Saturation_speed |
Property | Saturation_speed_user |
Property | Segment1 | Lane Segement 1
Property | Segment2 | Lane Segement 2
Property | Slip_control_type | Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.
Property | Type | Lane Type
Property | Utilisation |
Property | Utilisation_user |
Property | Width |
Top

Public Methods

 | Name | Description
Method | RemoveDisciplines | Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).
Top

See Also

Reference

ISIAPILaneApproach Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproach Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproach Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproach members.

Public Methods

 | Name | Description
Method | RemoveDisciplines | Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).
Top

See Also

Reference

ISIAPILaneApproach Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveDisciplines Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : RemoveDisciplines Method

Glossary Item Box

Clear all Disciplines on this Approach Lane, i.e. all ISIAPILaneApproachMovementMC data of this Approach Lane are set to not existing (ISIAPILaneApproachMovementMC.Exists = false).

Syntax

Visual Basic (Declaration)
Function RemoveDisciplines() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

value = instance.RemoveDisciplines()
C#
bool RemoveDisciplines()
Managed Extensions for C++
bool RemoveDisciplines();
C++/CLI
bool RemoveDisciplines();

Return Value

true if all Disciplines are removed successfully; otherwise, false.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproach Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproach Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproach members.

Public Properties

 | Name | Description
Property | Basic_saturation_flow |
Property | Buses_stopping |
Property | Buses_stopping_user |
Property | Capacity_adjustment |
Property | Configuration | Lane Configuration
Property | Control_type | Lane Control Type
Property | Departure_headway_awsc |
Property | Grade |
Property | Is_capacity_adj_for_network |
Property | Is_departure_headway_awsc_applied |
Property | Is_dominant_lane |
Property | Is_sliplane_excluded_from_signal_analysis |
Property | Is_sliplane_included_in_entry_lane_count |
Property | LaneApproachMovements | Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).
Property | LaneMovements |
Property | Laneno | Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.
Property | LastErrorMessage |
Property | Leg |
Property | Length | Lane Length
Property | Parking_manoeuvres |
Property | Parking_manoeuvres_user |
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Saturation_speed |
Property | Saturation_speed_user |
Property | Segment1 | Lane Segement 1
Property | Segment2 | Lane Segement 2
Property | Slip_control_type | Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.
Property | Type | Lane Type
Property | Utilisation |
Property | Utilisation_user |
Property | Width |
Top

See Also

Reference

ISIAPILaneApproach Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Basic_saturation_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Basic_saturation_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Basic_saturation_flow As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Basic_saturation_flow = value

value = instance.Basic_saturation_flow
C#
int Basic_saturation_flow {get; set;}
Managed Extensions for C++
__property int get_Basic_saturation_flow();
__property void set_Basic_saturation_flow(
   int value
);
C++/CLI
property int Basic_saturation_flow {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Buses_stopping Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Buses_stopping Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Buses_stopping As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Buses_stopping = value

value = instance.Buses_stopping
C#
int Buses_stopping {get; set;}
Managed Extensions for C++
__property int get_Buses_stopping();
__property void set_Buses_stopping(
   int value
);
C++/CLI
property int Buses_stopping {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Buses_stopping_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Buses_stopping_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Buses_stopping_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Buses_stopping_user = value

value = instance.Buses_stopping_user
C#
bool Buses_stopping_user {get; set;}
Managed Extensions for C++
__property bool get_Buses_stopping_user();
__property void set_Buses_stopping_user(
   bool value
);
C++/CLI
property bool Buses_stopping_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adjustment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Capacity_adjustment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Capacity_adjustment As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Capacity_adjustment = value

value = instance.Capacity_adjustment
C#
float Capacity_adjustment {get; set;}
Managed Extensions for C++
__property float get_Capacity_adjustment();
__property void set_Capacity_adjustment(
   float value
);
C++/CLI
property float Capacity_adjustment {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Configuration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Configuration Property

Glossary Item Box

Lane Configuration

Syntax

Visual Basic (Declaration)
Property Configuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Configuration = value

value = instance.Configuration
C#
int Configuration {get; set;}
Managed Extensions for C++
__property int get_Configuration();
__property void set_Configuration(
   int value
);
C++/CLI
property int Configuration {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Full-Length Lane,
2 = Short Lane,
3 = Short Lane with Parking,
4 = Two-Segment Lane.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Control_type Property

Glossary Item Box

Lane Control Type

Syntax

Visual Basic (Declaration)
Property Control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Control_type = value

value = instance.Control_type
C#
int Control_type {get; set;}
Managed Extensions for C++
__property int get_Control_type();
__property void set_Control_type(
   int value
);
C++/CLI
property int Control_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Signals,
2 = Giveway/Yield,
3 = Stop,
4 = Continuous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Departure_headway_awsc Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Departure_headway_awsc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Departure_headway_awsc As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Departure_headway_awsc = value

value = instance.Departure_headway_awsc
C#
float Departure_headway_awsc {get; set;}
Managed Extensions for C++
__property float get_Departure_headway_awsc();
__property void set_Departure_headway_awsc(
   float value
);
C++/CLI
property float Departure_headway_awsc {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Grade As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Grade = value

value = instance.Grade
C#
float Grade {get; set;}
Managed Extensions for C++
__property float get_Grade();
__property void set_Grade(
   float value
);
C++/CLI
property float Grade {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_capacity_adj_for_network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Is_capacity_adj_for_network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_capacity_adj_for_network As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Is_capacity_adj_for_network = value

value = instance.Is_capacity_adj_for_network
C#
bool Is_capacity_adj_for_network {get; set;}
Managed Extensions for C++
__property bool get_Is_capacity_adj_for_network();
__property void set_Is_capacity_adj_for_network(
   bool value
);
C++/CLI
property bool Is_capacity_adj_for_network {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_departure_headway_awsc_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Is_departure_headway_awsc_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_departure_headway_awsc_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Is_departure_headway_awsc_applied = value

value = instance.Is_departure_headway_awsc_applied
C#
bool Is_departure_headway_awsc_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_departure_headway_awsc_applied();
__property void set_Is_departure_headway_awsc_applied(
   bool value
);
C++/CLI
property bool Is_departure_headway_awsc_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_dominant_lane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Is_dominant_lane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_dominant_lane As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Is_dominant_lane = value

value = instance.Is_dominant_lane
C#
bool Is_dominant_lane {get; set;}
Managed Extensions for C++
__property bool get_Is_dominant_lane();
__property void set_Is_dominant_lane(
   bool value
);
C++/CLI
property bool Is_dominant_lane {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_sliplane_excluded_from_signal_analysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Is_sliplane_excluded_from_signal_analysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_sliplane_excluded_from_signal_analysis As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Is_sliplane_excluded_from_signal_analysis = value

value = instance.Is_sliplane_excluded_from_signal_analysis
C#
bool Is_sliplane_excluded_from_signal_analysis {get; set;}
Managed Extensions for C++
__property bool get_Is_sliplane_excluded_from_signal_analysis();
__property void set_Is_sliplane_excluded_from_signal_analysis(
   bool value
);
C++/CLI
property bool Is_sliplane_excluded_from_signal_analysis {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_sliplane_included_in_entry_lane_count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Is_sliplane_included_in_entry_lane_count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_sliplane_included_in_entry_lane_count As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Is_sliplane_included_in_entry_lane_count = value

value = instance.Is_sliplane_included_in_entry_lane_count
C#
bool Is_sliplane_included_in_entry_lane_count {get; set;}
Managed Extensions for C++
__property bool get_Is_sliplane_included_in_entry_lane_count();
__property void set_Is_sliplane_included_in_entry_lane_count(
   bool value
);
C++/CLI
property bool Is_sliplane_included_in_entry_lane_count {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : LaneApproachMovements Property

Glossary Item Box

Approach Lane Movements, defines the OD Movements (per Movement Class) running on this Approach Lane. It always returns eight Movements to the eight destinations (0: South, 1: South East, ... 7: South West).

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproachMovements As ISIAPILaneApproachMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As ISIAPILaneApproachMovements

value = instance.LaneApproachMovements
C#
ISIAPILaneApproachMovements LaneApproachMovements {get;}
Managed Extensions for C++
__property ISIAPILaneApproachMovements* get_LaneApproachMovements();
C++/CLI
property ISIAPILaneApproachMovements^ LaneApproachMovements {
   ISIAPILaneApproachMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : LaneMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneMovements As ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As ISIAPILaneMovements

value = instance.LaneMovements
C#
ISIAPILaneMovements LaneMovements {get;}
Managed Extensions for C++
__property ISIAPILaneMovements* get_LaneMovements();
C++/CLI
property ISIAPILaneMovements^ LaneMovements {
   ISIAPILaneMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Laneno Property

Glossary Item Box

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Syntax

Visual Basic (Declaration)
ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

value = instance.Laneno
C#
int Laneno {get;}
Managed Extensions for C++
__property int get_Laneno();
C++/CLI
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As ISIAPILeg

value = instance.Leg
C#
ISIAPILeg Leg {get;}
Managed Extensions for C++
__property ISIAPILeg* get_Leg();
C++/CLI
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Length Property

Glossary Item Box

Lane Length

Syntax

Visual Basic (Declaration)
Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Length = value

value = instance.Length
C#
float Length {get; set;}
Managed Extensions for C++
__property float get_Length();
__property void set_Length(
   float value
);
C++/CLI
property float Length {
   float get();
   void set (    float value);
}

Remarks

For Full-Length Lane or Two-Segment Lane, this is the Length of the whole Lane; for Short Lane or Short Lane with Parking, this is synchronized with the Segment 1 Length

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Parking_manoeuvres Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Parking_manoeuvres Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Parking_manoeuvres As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Parking_manoeuvres = value

value = instance.Parking_manoeuvres
C#
int Parking_manoeuvres {get; set;}
Managed Extensions for C++
__property int get_Parking_manoeuvres();
__property void set_Parking_manoeuvres(
   int value
);
C++/CLI
property int Parking_manoeuvres {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Parking_manoeuvres_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Parking_manoeuvres_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Parking_manoeuvres_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Parking_manoeuvres_user = value

value = instance.Parking_manoeuvres_user
C#
bool Parking_manoeuvres_user {get; set;}
Managed Extensions for C++
__property bool get_Parking_manoeuvres_user();
__property void set_Parking_manoeuvres_user(
   bool value
);
C++/CLI
property bool Parking_manoeuvres_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Saturation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Saturation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Saturation_speed = value

value = instance.Saturation_speed
C#
float Saturation_speed {get; set;}
Managed Extensions for C++
__property float get_Saturation_speed();
__property void set_Saturation_speed(
   float value
);
C++/CLI
property float Saturation_speed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_speed_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Saturation_speed_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Saturation_speed_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Saturation_speed_user = value

value = instance.Saturation_speed_user
C#
bool Saturation_speed_user {get; set;}
Managed Extensions for C++
__property bool get_Saturation_speed_user();
__property void set_Saturation_speed_user(
   bool value
);
C++/CLI
property bool Saturation_speed_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Segment1 Property

Glossary Item Box

Lane Segement 1

Syntax

Visual Basic (Declaration)
ReadOnly Property Segment1 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As ISIAPILaneSegment

value = instance.Segment1
C#
ISIAPILaneSegment Segment1 {get;}
Managed Extensions for C++
__property ISIAPILaneSegment* get_Segment1();
C++/CLI
property ISIAPILaneSegment^ Segment1 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Segment2 Property

Glossary Item Box

Lane Segement 2

Syntax

Visual Basic (Declaration)
ReadOnly Property Segment2 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As ISIAPILaneSegment

value = instance.Segment2
C#
ISIAPILaneSegment Segment2 {get;}
Managed Extensions for C++
__property ISIAPILaneSegment* get_Segment2();
C++/CLI
property ISIAPILaneSegment^ Segment2 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Slip_control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Slip_control_type Property

Glossary Item Box

Slip/Bypass Lane Control Type, apply to exclusive Slip/Bypass Lane or the Slip/Bypass part of a Shared Slip/Bypass Lane.

Syntax

Visual Basic (Declaration)
Property Slip_control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Slip_control_type = value

value = instance.Slip_control_type
C#
int Slip_control_type {get; set;}
Managed Extensions for C++
__property int get_Slip_control_type();
__property void set_Slip_control_type(
   int value
);
C++/CLI
property int Slip_control_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Signals,
2 = Giveway/Yield,
3 = Stop,
4 = Continuous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Type Property

Glossary Item Box

Lane Type

Syntax

Visual Basic (Declaration)
Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Integer

instance.Type = value

value = instance.Type
C#
int Type {get; set;}
Managed Extensions for C++
__property int get_Type();
__property void set_Type(
   int value
);
C++/CLI
property int Type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Normal,
2 = Slip/Bypass (High Angle),
3 = Slip/Bypass (Low Angle).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Utilisation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Utilisation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Utilisation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Utilisation = value

value = instance.Utilisation
C#
float Utilisation {get; set;}
Managed Extensions for C++
__property float get_Utilisation();
__property void set_Utilisation(
   float value
);
C++/CLI
property float Utilisation {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Utilisation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Utilisation_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Utilisation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Boolean

instance.Utilisation_user = value

value = instance.Utilisation_user
C#
bool Utilisation_user {get; set;}
Managed Extensions for C++
__property bool get_Utilisation_user();
__property void set_Utilisation_user(
   bool value
);
C++/CLI
property bool Utilisation_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproach Interface : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproach
Dim value As Single

instance.Width = value

value = instance.Width
C#
float Width {get; set;}
Managed Extensions for C++
__property float get_Width();
__property void set_Width(
   float value
);
C++/CLI
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproach Interface
ISIAPILaneApproach Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovement Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovement Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovement
C#
public interface ISIAPILaneApproachMovement
Managed Extensions for C++
public __gc __interface ISIAPILaneApproachMovement
C++/CLI
public interface class ISIAPILaneApproachMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovement Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovement Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproachMovement.

Public Properties

 | Name | Description
Property | Destination | Movement Destination Leg
Property | Free_queue |
Property | LaneApproach |
Property | LaneApproachMovementMCs |
Top

See Also

Reference

ISIAPILaneApproachMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovement Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovement Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovement members.

Public Properties

 | Name | Description
Property | Destination | Movement Destination Leg
Property | Free_queue |
Property | LaneApproach |
Property | LaneApproachMovementMCs |
Top

See Also

Reference

ISIAPILaneApproachMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovement Interface : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovement
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovement Interface
ISIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Free_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovement Interface : Free_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Free_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovement
Dim value As Single

instance.Free_queue = value

value = instance.Free_queue
C#
float Free_queue {get; set;}
Managed Extensions for C++
__property float get_Free_queue();
__property void set_Free_queue(
   float value
);
C++/CLI
property float Free_queue {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovement Interface
ISIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproach Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovement Interface : LaneApproach Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproach As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovement
Dim value As ISIAPILaneApproach

value = instance.LaneApproach
C#
ISIAPILaneApproach LaneApproach {get;}
Managed Extensions for C++
__property ISIAPILaneApproach* get_LaneApproach();
C++/CLI
property ISIAPILaneApproach^ LaneApproach {
   ISIAPILaneApproach^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovement Interface
ISIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovementMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovement Interface : LaneApproachMovementMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproachMovementMCs As ISIAPILaneApproachMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovement
Dim value As ISIAPILaneApproachMovementMCs

value = instance.LaneApproachMovementMCs
C#
ISIAPILaneApproachMovementMCs LaneApproachMovementMCs {get;}
Managed Extensions for C++
__property ISIAPILaneApproachMovementMCs* get_LaneApproachMovementMCs();
C++/CLI
property ISIAPILaneApproachMovementMCs^ LaneApproachMovementMCs {
   ISIAPILaneApproachMovementMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovement Interface
ISIAPILaneApproachMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproachMovementMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMC
C#
public interface ISIAPILaneApproachMovementMC
Managed Extensions for C++
public __gc __interface ISIAPILaneApproachMovementMC
C++/CLI
public interface class ISIAPILaneApproachMovementMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproachMovementMC.

Public Properties

 | Name | Description
Property | Exists | Flag indicating whether this Movement Class OD Movement is running on this Approach Lane. The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.
Property | LaneApproachMovement |
Property | MC_class | Movement Class Number
Top

See Also

Reference

ISIAPILaneApproachMovementMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovementMC members.

Public Properties

 | Name | Description
Property | Exists | Flag indicating whether this Movement Class OD Movement is running on this Approach Lane. The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.
Property | LaneApproachMovement |
Property | MC_class | Movement Class Number
Top

See Also

Reference

ISIAPILaneApproachMovementMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovementMC Interface : Exists Property

Glossary Item Box

Flag indicating whether this Movement Class OD Movement is running on this Approach Lane.

The state of this property corresponds to the setting of the "Lane Discipline" checkbox in the SIDRA INTERSECTION "Lane Geometry" dialog - "Lane Disciplines" tab for the given Movement Class OD movement.

Syntax

Visual Basic (Declaration)
Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMC
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
bool Exists {get; set;}
Managed Extensions for C++
__property bool get_Exists();
__property void set_Exists(
   bool value
);
C++/CLI
property bool Exists {
   bool get();
   void set (    bool value);
}

Remarks

SIAPISite.ResetLaneMovements() needs to be called manually or the related SIAPILaneMovementMC.Flow_proportion need to be revised manually after Lane Discipline changes.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMC Interface
ISIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovementMC Interface : LaneApproachMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproachMovement As ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMC
Dim value As ISIAPILaneApproachMovement

value = instance.LaneApproachMovement
C#
ISIAPILaneApproachMovement LaneApproachMovement {get;}
Managed Extensions for C++
__property ISIAPILaneApproachMovement* get_LaneApproachMovement();
C++/CLI
property ISIAPILaneApproachMovement^ LaneApproachMovement {
   ISIAPILaneApproachMovement^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMC Interface
ISIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovementMC Interface : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMC Interface
ISIAPILaneApproachMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproachMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMCs
C#
public interface ISIAPILaneApproachMovementMCs
Managed Extensions for C++
public __gc __interface ISIAPILaneApproachMovementMCs
C++/CLI
public interface class ISIAPILaneApproachMovementMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproachMovementMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneApproachMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovementMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneApproachMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovementMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMCs Interface
ISIAPILaneApproachMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovementMCs Interface : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneApproachMovementMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovementMCs
Dim mcClass As Integer
Dim value As ISIAPILaneApproachMovementMC

value = instance.Item(mcClass)
C#
ISIAPILaneApproachMovementMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPILaneApproachMovementMC* get_Item   int mcClass
;
C++/CLI
property ISIAPILaneApproachMovementMC^ default [int] {
   ISIAPILaneApproachMovementMC^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovementMCs Interface
ISIAPILaneApproachMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovements Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovements Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproachMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovements
C#
public interface ISIAPILaneApproachMovements
Managed Extensions for C++
public __gc __interface ISIAPILaneApproachMovements
C++/CLI
public interface class ISIAPILaneApproachMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovements Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovements Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproachMovements.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneApproachMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovements Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovements members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneApproachMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovements Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovements
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovements Interface
ISIAPILaneApproachMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachMovements Interface : Item Property

destination

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal destination As Integer _
) As ISIAPILaneApproachMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachMovements
Dim destination As Integer
Dim value As ISIAPILaneApproachMovement

value = instance.Item(destination)
C#
ISIAPILaneApproachMovement this[
   int destination
]; {get;}
Managed Extensions for C++
__property ISIAPILaneApproachMovement* get_Item   int destination
;
C++/CLI
property ISIAPILaneApproachMovement^ default [int] {
   ISIAPILaneApproachMovement^ get(int destination);
}

Parameters

destination

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachMovements Interface
ISIAPILaneApproachMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneApproachs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs
C#
public interface ISIAPILaneApproachs
Managed Extensions for C++
public __gc __interface ISIAPILaneApproachs
C++/CLI
public interface class ISIAPILaneApproachs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneApproachs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | AddLane | Add an Approach Lane If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Approach Lane, a new default Approach Lane is added.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneApproachExists |
Method | RemoveLane | Remove an Approach Lane If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

ISIAPILaneApproachs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachs members.

Public Methods

 | Name | Description
Method | AddLane | Add an Approach Lane If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Approach Lane, a new default Approach Lane is added.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneApproachExists |
Method | RemoveLane | Remove an Approach Lane If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

ISIAPILaneApproachs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachs Interface : AddLane Method

Glossary Item Box

Add an Approach Lane

If the Leg has Approach Lane(s), if driving-on-left, the rightmost Approach Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Approach Lane is cloned. The cloned Lane is added to the left.
If the Leg does not have any Approach Lane, a new default Approach Lane is added.

Syntax

Visual Basic (Declaration)
Function AddLane() As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs
Dim value As ISIAPILaneApproach

value = instance.AddLane()
C#
ISIAPILaneApproach AddLane()
Managed Extensions for C++
ISIAPILaneApproach* AddLane();
C++/CLI
ISIAPILaneApproach^ AddLane();

Return Value

The new added Approach Lane

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Interface
ISIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachs Interface : LaneApproachExists Method

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneApproachExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneApproachExists(laneno)
C#
bool LaneApproachExists(
   int laneno
)
Managed Extensions for C++
bool LaneApproachExists(
   int laneno
)
C++/CLI
bool LaneApproachExists(
   int laneno
)

Parameters

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Interface
ISIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachs Interface : RemoveLane Method

Glossary Item Box

Remove an Approach Lane

If driving-on-left, the rightmost Approach Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.

Syntax

Visual Basic (Declaration)
Sub RemoveLane()
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs

instance.RemoveLane()
C#
void RemoveLane()
Managed Extensions for C++
void RemoveLane();
C++/CLI
void RemoveLane();

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Interface
ISIAPILaneApproachs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneApproachs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Interface
ISIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneApproachs Interface : Item Property

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneApproachs
Dim laneno As Integer
Dim value As ISIAPILaneApproach

value = instance.Item(laneno)
C#
ISIAPILaneApproach this[
   int laneno
]; {get;}
Managed Extensions for C++
__property ISIAPILaneApproach* get_Item   int laneno
;
C++/CLI
property ISIAPILaneApproach^ default [int] {
   ISIAPILaneApproach^ get(int laneno);
}

Parameters

laneno

Approach Lane Number, a one-based integer, counts Approach Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneApproachs Interface
ISIAPILaneApproachs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExit Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExit Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
C#
public interface ISIAPILaneExit
Managed Extensions for C++
public __gc __interface ISIAPILaneExit
C++/CLI
public interface class ISIAPILaneExit

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExit Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExit Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneExit.

Public Properties

 | Name | Description
Property | Configuration | Lane Configuration
Property | Grade |
Property | LaneMovements |
Property | Laneno | Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.
Property | Leg |
Property | Length | Lane Length
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Segment1 | Lane Segement 1
Property | Segment2 | Lane Segement 2
Property | Width |
Top

See Also

Reference

ISIAPILaneExit Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExit Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExit Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneExit members.

Public Properties

 | Name | Description
Property | Configuration | Lane Configuration
Property | Grade |
Property | LaneMovements |
Property | Laneno | Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.
Property | Leg |
Property | Length | Lane Length
Property | Position | Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.
Property | Segment1 | Lane Segement 1
Property | Segment2 | Lane Segement 2
Property | Width |
Top

See Also

Reference

ISIAPILaneExit Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Configuration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Configuration Property

Glossary Item Box

Lane Configuration

Syntax

Visual Basic (Declaration)
Property Configuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Integer

instance.Configuration = value

value = instance.Configuration
C#
int Configuration {get; set;}
Managed Extensions for C++
__property int get_Configuration();
__property void set_Configuration(
   int value
);
C++/CLI
property int Configuration {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Full-Length Lane,
2 = Short Lane,
3 = Short Lane with Parking,
4 = Two-Segment Lane.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Grade As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Single

instance.Grade = value

value = instance.Grade
C#
float Grade {get; set;}
Managed Extensions for C++
__property float get_Grade();
__property void set_Grade(
   float value
);
C++/CLI
property float Grade {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : LaneMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneMovements As ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As ISIAPILaneMovements

value = instance.LaneMovements
C#
ISIAPILaneMovements LaneMovements {get;}
Managed Extensions for C++
__property ISIAPILaneMovements* get_LaneMovements();
C++/CLI
property ISIAPILaneMovements^ LaneMovements {
   ISIAPILaneMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Laneno Property

Glossary Item Box

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Syntax

Visual Basic (Declaration)
ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Integer

value = instance.Laneno
C#
int Laneno {get;}
Managed Extensions for C++
__property int get_Laneno();
C++/CLI
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As ISIAPILeg

value = instance.Leg
C#
ISIAPILeg Leg {get;}
Managed Extensions for C++
__property ISIAPILeg* get_Leg();
C++/CLI
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Length Property

Glossary Item Box

Lane Length

Syntax

Visual Basic (Declaration)
Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Single

instance.Length = value

value = instance.Length
C#
float Length {get; set;}
Managed Extensions for C++
__property float get_Length();
__property void set_Length(
   float value
);
C++/CLI
property float Length {
   float get();
   void set (    float value);
}

Remarks

For Full-Length Lane or Two-Segment Lane, this is the Full Lane Length; for Short Lane or Short Lane with Parking, this is synchronized with the Segment 1 Length

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Position Property

Glossary Item Box

Postion in the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Segment1 Property

Glossary Item Box

Lane Segement 1

Syntax

Visual Basic (Declaration)
ReadOnly Property Segment1 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As ISIAPILaneSegment

value = instance.Segment1
C#
ISIAPILaneSegment Segment1 {get;}
Managed Extensions for C++
__property ISIAPILaneSegment* get_Segment1();
C++/CLI
property ISIAPILaneSegment^ Segment1 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Segment2 Property

Glossary Item Box

Lane Segement 2

Syntax

Visual Basic (Declaration)
ReadOnly Property Segment2 As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As ISIAPILaneSegment

value = instance.Segment2
C#
ISIAPILaneSegment Segment2 {get;}
Managed Extensions for C++
__property ISIAPILaneSegment* get_Segment2();
C++/CLI
property ISIAPILaneSegment^ Segment2 {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExit Interface : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExit
Dim value As Single

instance.Width = value

value = instance.Width
C#
float Width {get; set;}
Managed Extensions for C++
__property float get_Width();
__property void set_Width(
   float value
);
C++/CLI
property float Width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExit Interface
ISIAPILaneExit Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExits Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExits Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneExits
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits
C#
public interface ISIAPILaneExits
Managed Extensions for C++
public __gc __interface ISIAPILaneExits
C++/CLI
public interface class ISIAPILaneExits

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExits Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExits Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneExits.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | AddLane | Add an Exit Lane If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Exit Lane, a new default Exit Lane is added.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExitExists |
Method | RemoveLane | Remove an Exit Lane If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

ISIAPILaneExits Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExits Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExits Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneExits members.

Public Methods

 | Name | Description
Method | AddLane | Add an Exit Lane If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left. If the Leg does not have any Exit Lane, a new default Exit Lane is added.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExitExists |
Method | RemoveLane | Remove an Exit Lane If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.
Top

See Also

Reference

ISIAPILaneExits Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExits Interface : AddLane Method

Glossary Item Box

Add an Exit Lane

If the Leg has Exit Lane(s), if driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is cloned. The cloned Lane is added to the right. If driving-on-right, the leftmost Exit Lane is cloned. The cloned Lane is added to the left.
If the Leg does not have any Exit Lane, a new default Exit Lane is added.

Syntax

Visual Basic (Declaration)
Function AddLane() As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits
Dim value As ISIAPILaneExit

value = instance.AddLane()
C#
ISIAPILaneExit AddLane()
Managed Extensions for C++
ISIAPILaneExit* AddLane();
C++/CLI
ISIAPILaneExit^ AddLane();

Return Value

The new added Exit Lane

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Interface
ISIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExitExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExits Interface : LaneExitExists Method

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneExitExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExitExists(laneno)
C#
bool LaneExitExists(
   int laneno
)
Managed Extensions for C++
bool LaneExitExists(
   int laneno
)
C++/CLI
bool LaneExitExists(
   int laneno
)

Parameters

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Interface
ISIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExits Interface : RemoveLane Method

Glossary Item Box

Remove an Exit Lane

If driving-on-left, the rightmost (looking in the direction of departure) Exit Lane is removed. If driving-on-right, the leftmost Approach Lane is removed.

Syntax

Visual Basic (Declaration)
Sub RemoveLane()
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits

instance.RemoveLane()
C#
void RemoveLane()
Managed Extensions for C++
void RemoveLane();
C++/CLI
void RemoveLane();

Remarks

Call SIAPISite.ResetLaneMovements() manually after adding / removing Lanes. If Leg(s) has been added or removed, call SIAPISite.UpdateGeometryData() instead of ResetLaneMovements().

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Interface
ISIAPILaneExits Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneExits Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneExits Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneExits members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneExits Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExits Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Interface
ISIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneExits Interface : Item Property

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneExits
Dim laneno As Integer
Dim value As ISIAPILaneExit

value = instance.Item(laneno)
C#
ISIAPILaneExit this[
   int laneno
]; {get;}
Managed Extensions for C++
__property ISIAPILaneExit* get_Item   int laneno
;
C++/CLI
property ISIAPILaneExit^ default [int] {
   ISIAPILaneExit^ get(int laneno);
}

Parameters

laneno

Exit Lane Number, a one-based integer, counts Exit Lanes only from left to right looking in the direction of departure.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneExits Interface
ISIAPILaneExits Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovement Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovement Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
C#
public interface ISIAPILaneMovement
Managed Extensions for C++
public __gc __interface ISIAPILaneMovement
C++/CLI
public interface class ISIAPILaneMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovement Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovement Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneMovement.

Public Properties

 | Name | Description
Property | Destination |
Property | DestinationLaneno |
Property | Lane_blockage_calib_factor |
Property | LaneMovementMCs |
Property | Origin |
Property | OriginLaneno |
Top

See Also

Reference

ISIAPILaneMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovement Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovement Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovement members.

Public Properties

 | Name | Description
Property | Destination |
Property | DestinationLaneno |
Property | Lane_blockage_calib_factor |
Property | LaneMovementMCs |
Property | Origin |
Property | OriginLaneno |
Top

See Also

Reference

ISIAPILaneMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DestinationLaneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : DestinationLaneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DestinationLaneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As Integer

value = instance.DestinationLaneno
C#
int DestinationLaneno {get;}
Managed Extensions for C++
__property int get_DestinationLaneno();
C++/CLI
property int DestinationLaneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_calib_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : Lane_blockage_calib_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Lane_blockage_calib_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As Single

instance.Lane_blockage_calib_factor = value

value = instance.Lane_blockage_calib_factor
C#
float Lane_blockage_calib_factor {get; set;}
Managed Extensions for C++
__property float get_Lane_blockage_calib_factor();
__property void set_Lane_blockage_calib_factor(
   float value
);
C++/CLI
property float Lane_blockage_calib_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovementMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : LaneMovementMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneMovementMCs As ISIAPILaneMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As ISIAPILaneMovementMCs

value = instance.LaneMovementMCs
C#
ISIAPILaneMovementMCs LaneMovementMCs {get;}
Managed Extensions for C++
__property ISIAPILaneMovementMCs* get_LaneMovementMCs();
C++/CLI
property ISIAPILaneMovementMCs^ LaneMovementMCs {
   ISIAPILaneMovementMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OriginLaneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovement Interface : OriginLaneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OriginLaneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovement
Dim value As Integer

value = instance.OriginLaneno
C#
int OriginLaneno {get;}
Managed Extensions for C++
__property int get_OriginLaneno();
C++/CLI
property int OriginLaneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovement Interface
ISIAPILaneMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneMovementMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMC
C#
public interface ISIAPILaneMovementMC
Managed Extensions for C++
public __gc __interface ISIAPILaneMovementMC
C++/CLI
public interface class ISIAPILaneMovementMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneMovementMC.

Public Properties

 | Name | Description
Property | Flow_proportion |
Property | LaneMovement |
Property | MC_class | Movement Class Number
Top

See Also

Reference

ISIAPILaneMovementMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovementMC members.

Public Properties

 | Name | Description
Property | Flow_proportion |
Property | LaneMovement |
Property | MC_class | Movement Class Number
Top

See Also

Reference

ISIAPILaneMovementMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_proportion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovementMC Interface : Flow_proportion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_proportion As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMC
Dim value As Single

instance.Flow_proportion = value

value = instance.Flow_proportion
C#
float Flow_proportion {get; set;}
Managed Extensions for C++
__property float get_Flow_proportion();
__property void set_Flow_proportion(
   float value
);
C++/CLI
property float Flow_proportion {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMC Interface
ISIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovementMC Interface : LaneMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneMovement As ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMC
Dim value As ISIAPILaneMovement

value = instance.LaneMovement
C#
ISIAPILaneMovement LaneMovement {get;}
Managed Extensions for C++
__property ISIAPILaneMovement* get_LaneMovement();
C++/CLI
property ISIAPILaneMovement^ LaneMovement {
   ISIAPILaneMovement^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMC Interface
ISIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovementMC Interface : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMC Interface
ISIAPILaneMovementMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneMovementMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMCs
C#
public interface ISIAPILaneMovementMCs
Managed Extensions for C++
public __gc __interface ISIAPILaneMovementMCs
C++/CLI
public interface class ISIAPILaneMovementMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneMovementMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovementMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovementMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMCs Interface
ISIAPILaneMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovementMCs Interface : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneMovementMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovementMCs
Dim mcClass As Integer
Dim value As ISIAPILaneMovementMC

value = instance.Item(mcClass)
C#
ISIAPILaneMovementMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPILaneMovementMC* get_Item   int mcClass
;
C++/CLI
property ISIAPILaneMovementMC^ default [int] {
   ISIAPILaneMovementMC^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovementMCs Interface
ISIAPILaneMovementMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovements Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovements Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovements
C#
public interface ISIAPILaneMovements
Managed Extensions for C++
public __gc __interface ISIAPILaneMovements
C++/CLI
public interface class ISIAPILaneMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovements Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovements Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneMovements.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneMovementExists |
Top

See Also

Reference

ISIAPILaneMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovements Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovements members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneMovementExists |
Top

See Also

Reference

ISIAPILaneMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneMovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovements Interface : LaneMovementExists Method

leg
laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneMovementExists( _
   ByVal leg As Integer, _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovements
Dim leg As Integer
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneMovementExists(leg, laneno)
C#
bool LaneMovementExists(
   int leg,
   int laneno
)
Managed Extensions for C++
bool LaneMovementExists(
   int leg,
   int laneno
)
C++/CLI
bool LaneMovementExists(
   int leg,
   int laneno
)

Parameters

leg
laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovements Interface
ISIAPILaneMovements Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovements Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovements members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovements Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovements
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovements Interface
ISIAPILaneMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneMovements Interface : Item Property

leg
laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal leg As Integer, _
   ByVal laneno As Integer _
) As ISIAPILaneMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneMovements
Dim leg As Integer
Dim laneno As Integer
Dim value As ISIAPILaneMovement

value = instance.Item(leg, laneno)
C#
ISIAPILaneMovement this[
   int leg,
   int laneno
]; {get;}
Managed Extensions for C++
__property ISIAPILaneMovement* get_Item   int leg,
   int laneno
;
C++/CLI
property ISIAPILaneMovement^ default [int,int] {
   ISIAPILaneMovement^ get(int leg, int laneno);
}

Parameters

leg
laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneMovements Interface
ISIAPILaneMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegment Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegment Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
C#
public interface ISIAPILaneSegment
Managed Extensions for C++
public __gc __interface ISIAPILaneSegment
C++/CLI
public interface class ISIAPILaneSegment

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegment Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegment Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneSegment.

Public Properties

 | Name | Description
Property | Colour |
Property | Display_id |
Property | LaneApproach |
Property | LaneExit |
Property | LaneSegmentMCs |
Property | Length |
Property | Overflow_merge_lane_num_1 |
Property | Segment_no |
Property | Type | Lane Segment Type
Top

See Also

Reference

ISIAPILaneSegment Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegment Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegment Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneSegment members.

Public Properties

 | Name | Description
Property | Colour |
Property | Display_id |
Property | LaneApproach |
Property | LaneExit |
Property | LaneSegmentMCs |
Property | Length |
Property | Overflow_merge_lane_num_1 |
Property | Segment_no |
Property | Type | Lane Segment Type
Top

See Also

Reference

ISIAPILaneSegment Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Colour Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Colour Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Colour As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As Integer

instance.Colour = value

value = instance.Colour
C#
int Colour {get; set;}
Managed Extensions for C++
__property int get_Colour();
__property void set_Colour(
   int value
);
C++/CLI
property int Colour {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Display_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
string Display_id {get; set;}
Managed Extensions for C++
__property string* get_Display_id();
__property void set_Display_id(
   string* value
);
C++/CLI
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproach Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : LaneApproach Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproach As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As ISIAPILaneApproach

value = instance.LaneApproach
C#
ISIAPILaneApproach LaneApproach {get;}
Managed Extensions for C++
__property ISIAPILaneApproach* get_LaneApproach();
C++/CLI
property ISIAPILaneApproach^ LaneApproach {
   ISIAPILaneApproach^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : LaneExit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneExit As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As ISIAPILaneExit

value = instance.LaneExit
C#
ISIAPILaneExit LaneExit {get;}
Managed Extensions for C++
__property ISIAPILaneExit* get_LaneExit();
C++/CLI
property ISIAPILaneExit^ LaneExit {
   ISIAPILaneExit^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneSegmentMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : LaneSegmentMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneSegmentMCs As ISIAPILaneSegmentMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As ISIAPILaneSegmentMCs

value = instance.LaneSegmentMCs
C#
ISIAPILaneSegmentMCs LaneSegmentMCs {get;}
Managed Extensions for C++
__property ISIAPILaneSegmentMCs* get_LaneSegmentMCs();
C++/CLI
property ISIAPILaneSegmentMCs^ LaneSegmentMCs {
   ISIAPILaneSegmentMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As Single

instance.Length = value

value = instance.Length
C#
float Length {get; set;}
Managed Extensions for C++
__property float get_Length();
__property void set_Length(
   float value
);
C++/CLI
property float Length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Overflow_merge_lane_num_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Overflow_merge_lane_num_1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Overflow_merge_lane_num_1 As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As Integer

instance.Overflow_merge_lane_num_1 = value

value = instance.Overflow_merge_lane_num_1
C#
int Overflow_merge_lane_num_1 {get; set;}
Managed Extensions for C++
__property int get_Overflow_merge_lane_num_1();
__property void set_Overflow_merge_lane_num_1(
   int value
);
C++/CLI
property int Overflow_merge_lane_num_1 {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Segment_no Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Segment_no Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Segment_no As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As Integer

value = instance.Segment_no
C#
int Segment_no {get;}
Managed Extensions for C++
__property int get_Segment_no();
C++/CLI
property int Segment_no {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegment Interface : Type Property

Glossary Item Box

Lane Segment Type

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegment
Dim value As Integer

value = instance.Type
C#
int Type {get;}
Managed Extensions for C++
__property int get_Type();
C++/CLI
property int Type {
   int get();
}

Property Value

Type: System.Int32;

0 = None,
1 = Short Lane,
2 = Parking.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegment Interface
ISIAPILaneSegment Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneSegmentMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
C#
public interface ISIAPILaneSegmentMC
Managed Extensions for C++
public __gc __interface ISIAPILaneSegmentMC
C++/CLI
public interface class ISIAPILaneSegmentMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneSegmentMC.

Public Properties

 | Name | Description
Property | Exists | Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.
Property | LaneSegment |
Property | MC_class | Movement Class Number
Property | Percent_change_to_left | Percent Lane Change to the Left (looking in the direction of departure), only applies to the Exit Lane Segment 1.
Property | Percent_change_to_right | Percent Lane Change to the Right (looking in the direction of departure), only applies to the Exit Lane Segment 1.
Top

See Also

Reference

ISIAPILaneSegmentMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneSegmentMC members.

Public Properties

 | Name | Description
Property | Exists | Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.
Property | LaneSegment |
Property | MC_class | Movement Class Number
Property | Percent_change_to_left | Percent Lane Change to the Left (looking in the direction of departure), only applies to the Exit Lane Segment 1.
Property | Percent_change_to_right | Percent Lane Change to the Right (looking in the direction of departure), only applies to the Exit Lane Segment 1.
Top

See Also

Reference

ISIAPILaneSegmentMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMC Interface : Exists Property

Glossary Item Box

Flag indicating whether the Movement Class is running on this Lane Segment. This only applies to Approach Lane Segment 2. This value in Approach Lane Segment 1, Exit Lane Segment 1 or 2 is ignored.

Syntax

Visual Basic (Declaration)
Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
bool Exists {get; set;}
Managed Extensions for C++
__property bool get_Exists();
__property void set_Exists(
   bool value
);
C++/CLI
property bool Exists {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Interface
ISIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneSegment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMC Interface : LaneSegment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneSegment As ISIAPILaneSegment
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
Dim value As ISIAPILaneSegment

value = instance.LaneSegment
C#
ISIAPILaneSegment LaneSegment {get;}
Managed Extensions for C++
__property ISIAPILaneSegment* get_LaneSegment();
C++/CLI
property ISIAPILaneSegment^ LaneSegment {
   ISIAPILaneSegment^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Interface
ISIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMC Interface : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Interface
ISIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMC Interface : Percent_change_to_left Property

Glossary Item Box

Percent Lane Change to the Left (looking in the direction of departure), only applies to the Exit Lane Segment 1.

Syntax

Visual Basic (Declaration)
Property Percent_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
Dim value As Single

instance.Percent_change_to_left = value

value = instance.Percent_change_to_left
C#
float Percent_change_to_left {get; set;}
Managed Extensions for C++
__property float get_Percent_change_to_left();
__property void set_Percent_change_to_left(
   float value
);
C++/CLI
property float Percent_change_to_left {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Interface
ISIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMC Interface : Percent_change_to_right Property

Glossary Item Box

Percent Lane Change to the Right (looking in the direction of departure), only applies to the Exit Lane Segment 1.

Syntax

Visual Basic (Declaration)
Property Percent_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMC
Dim value As Single

instance.Percent_change_to_right = value

value = instance.Percent_change_to_right
C#
float Percent_change_to_right {get; set;}
Managed Extensions for C++
__property float get_Percent_change_to_right();
__property void set_Percent_change_to_right(
   float value
);
C++/CLI
property float Percent_change_to_right {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMC Interface
ISIAPILaneSegmentMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILaneSegmentMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMCs
C#
public interface ISIAPILaneSegmentMCs
Managed Extensions for C++
public __gc __interface ISIAPILaneSegmentMCs
C++/CLI
public interface class ISIAPILaneSegmentMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILaneSegmentMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneSegmentMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneSegmentMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPILaneSegmentMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMCs Interface
ISIAPILaneSegmentMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILaneSegmentMCs Interface : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPILaneSegmentMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILaneSegmentMCs
Dim mcClass As Integer
Dim value As ISIAPILaneSegmentMC

value = instance.Item(mcClass)
C#
ISIAPILaneSegmentMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPILaneSegmentMC* get_Item   int mcClass
;
C++/CLI
property ISIAPILaneSegmentMC^ default [int] {
   ISIAPILaneSegmentMC^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILaneSegmentMCs Interface
ISIAPILaneSegmentMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
C#
public interface ISIAPILeg
Managed Extensions for C++
public __gc __interface ISIAPILeg
C++/CLI
public interface class ISIAPILeg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILeg.

Public Properties

 | Name | Description
Property | Approach_control | Approach Control Type, for Legs in Sign Controlled Site only
Property | Approach_distance |
Property | Area_type_factor | Area Type Factor, for Legs in Signalised Site only
Property | Exit_distance |
Property | Exit_distance_user |
Property | Extra_bunching |
Property | Extra_bunching_user |
Property | Is_departure_headway_awsc_applied |
Property | Islands |
Property | LaneApproachs |
Property | LaneExits |
Property | LastErrorMessage |
Property | Leg_roundabout |
Property | LegGeometry | Leg Geometry
Property | Name |
Property | Orientation | Leg Orientation
Property | Site |
Top

Public Methods

 | Name | Description
Method | InsertApproachLane | Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.
Method | InsertExitLane | Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.
Method | InsertIsland | Insert an new Island to the Leg at the specified position. The Island is created automatically.
Method | InsertIsland_RoundaboutSplitter | Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.
Method | RemoveItem | Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.
Top

See Also

Reference

ISIAPILeg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILeg members.

Public Methods

 | Name | Description
Method | InsertApproachLane | Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.
Method | InsertExitLane | Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.
Method | InsertIsland | Insert an new Island to the Leg at the specified position. The Island is created automatically.
Method | InsertIsland_RoundaboutSplitter | Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.
Method | RemoveItem | Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.
Top

See Also

Reference

ISIAPILeg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertApproachLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : InsertApproachLane Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Approach Lane to the Leg at the specified position. The Approach Lane is created automatically.

Syntax

Visual Basic (Declaration)
Function InsertApproachLane( _
   ByVal positionOnLeg As Integer _
) As ISIAPILaneApproach
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPILaneApproach

value = instance.InsertApproachLane(positionOnLeg)
C#
ISIAPILaneApproach InsertApproachLane(
   int positionOnLeg
)
Managed Extensions for C++
ISIAPILaneApproach* InsertApproachLane(
   int positionOnLeg
)
C++/CLI
ISIAPILaneApproach^ InsertApproachLane(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Approach Lane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertExitLane Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : InsertExitLane Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Exit Lane to the Leg at the specified position. The Exit Lane is created automatically.

Syntax

Visual Basic (Declaration)
Function InsertExitLane( _
   ByVal positionOnLeg As Integer _
) As ISIAPILaneExit
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPILaneExit

value = instance.InsertExitLane(positionOnLeg)
C#
ISIAPILaneExit InsertExitLane(
   int positionOnLeg
)
Managed Extensions for C++
ISIAPILaneExit* InsertExitLane(
   int positionOnLeg
)
C++/CLI
ISIAPILaneExit^ InsertExitLane(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Exit Lane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertIsland Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : InsertIsland Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Island to the Leg at the specified position. The Island is created automatically.

Syntax

Visual Basic (Declaration)
Function InsertIsland( _
   ByVal positionOnLeg As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPIIsland

value = instance.InsertIsland(positionOnLeg)
C#
ISIAPIIsland InsertIsland(
   int positionOnLeg
)
Managed Extensions for C++
ISIAPIIsland* InsertIsland(
   int positionOnLeg
)
C++/CLI
ISIAPIIsland^ InsertIsland(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Island

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertIsland_RoundaboutSplitter Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : InsertIsland_RoundaboutSplitter Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Insert an new Roundabout Splitter Island to the Leg at the specified position. The Island is created automatically.

Syntax

Visual Basic (Declaration)
Function InsertIsland_RoundaboutSplitter( _
   ByVal positionOnLeg As Integer _
) As ISIAPIIsland
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim positionOnLeg As Integer
Dim value As ISIAPIIsland

value = instance.InsertIsland_RoundaboutSplitter(positionOnLeg)
C#
ISIAPIIsland InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)
Managed Extensions for C++
ISIAPIIsland* InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)
C++/CLI
ISIAPIIsland^ InsertIsland_RoundaboutSplitter(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

The new Roundabout Splitter Island

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveItem Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : RemoveItem Method

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Glossary Item Box

Remove the item at the specified position on the Leg. The item could be an Approach Lane, Exit Lane or Island.

Syntax

Visual Basic (Declaration)
Function RemoveItem( _
   ByVal positionOnLeg As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim positionOnLeg As Integer
Dim value As Boolean

value = instance.RemoveItem(positionOnLeg)
C#
bool RemoveItem(
   int positionOnLeg
)
Managed Extensions for C++
bool RemoveItem(
   int positionOnLeg
)
C++/CLI
bool RemoveItem(
   int positionOnLeg
)

Parameters

positionOnLeg
Postion on the Leg, a one-based integer, counts Approach Lanes, Exit Lanes and Islands from left to right looking to the centre of the Intersection.

Return Value

true if the item is successfully removed. This method returns false if the item was not found.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILeg members.

Public Properties

 | Name | Description
Property | Approach_control | Approach Control Type, for Legs in Sign Controlled Site only
Property | Approach_distance |
Property | Area_type_factor | Area Type Factor, for Legs in Signalised Site only
Property | Exit_distance |
Property | Exit_distance_user |
Property | Extra_bunching |
Property | Extra_bunching_user |
Property | Is_departure_headway_awsc_applied |
Property | Islands |
Property | LaneApproachs |
Property | LaneExits |
Property | LastErrorMessage |
Property | Leg_roundabout |
Property | LegGeometry | Leg Geometry
Property | Name |
Property | Orientation | Leg Orientation
Property | Site |
Top

See Also

Reference

ISIAPILeg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Approach_control Property

Glossary Item Box

Approach Control Type, for Legs in Sign Controlled Site only

Syntax

Visual Basic (Declaration)
Property Approach_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Integer

instance.Approach_control = value

value = instance.Approach_control
C#
int Approach_control {get; set;}
Managed Extensions for C++
__property int get_Approach_control();
__property void set_Approach_control(
   int value
);
C++/CLI
property int Approach_control {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Major Road,
2 = Giveway,
3 = Stop.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Approach_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Approach_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Single

instance.Approach_distance = value

value = instance.Approach_distance
C#
float Approach_distance {get; set;}
Managed Extensions for C++
__property float get_Approach_distance();
__property void set_Approach_distance(
   float value
);
C++/CLI
property float Approach_distance {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Area_type_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Area_type_factor Property

Glossary Item Box

Area Type Factor, for Legs in Signalised Site only

Syntax

Visual Basic (Declaration)
Property Area_type_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Single

instance.Area_type_factor = value

value = instance.Area_type_factor
C#
float Area_type_factor {get; set;}
Managed Extensions for C++
__property float get_Area_type_factor();
__property void set_Area_type_factor(
   float value
);
C++/CLI
property float Area_type_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Exit_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
float Exit_distance {get; set;}
Managed Extensions for C++
__property float get_Exit_distance();
__property void set_Exit_distance(
   float value
);
C++/CLI
property float Exit_distance {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Exit_distance_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Exit_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Boolean

instance.Exit_distance_user = value

value = instance.Exit_distance_user
C#
bool Exit_distance_user {get; set;}
Managed Extensions for C++
__property bool get_Exit_distance_user();
__property void set_Exit_distance_user(
   bool value
);
C++/CLI
property bool Exit_distance_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Extra_bunching Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Extra_bunching As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Single

instance.Extra_bunching = value

value = instance.Extra_bunching
C#
float Extra_bunching {get; set;}
Managed Extensions for C++
__property float get_Extra_bunching();
__property void set_Extra_bunching(
   float value
);
C++/CLI
property float Extra_bunching {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Extra_bunching_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Extra_bunching_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Boolean

instance.Extra_bunching_user = value

value = instance.Extra_bunching_user
C#
bool Extra_bunching_user {get; set;}
Managed Extensions for C++
__property bool get_Extra_bunching_user();
__property void set_Extra_bunching_user(
   bool value
);
C++/CLI
property bool Extra_bunching_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_departure_headway_awsc_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Is_departure_headway_awsc_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_departure_headway_awsc_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Boolean

instance.Is_departure_headway_awsc_applied = value

value = instance.Is_departure_headway_awsc_applied
C#
bool Is_departure_headway_awsc_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_departure_headway_awsc_applied();
__property void set_Is_departure_headway_awsc_applied(
   bool value
);
C++/CLI
property bool Is_departure_headway_awsc_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Islands Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Islands Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Islands As ISIAPIIslands
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As ISIAPIIslands

value = instance.Islands
C#
ISIAPIIslands Islands {get;}
Managed Extensions for C++
__property ISIAPIIslands* get_Islands();
C++/CLI
property ISIAPIIslands^ Islands {
   ISIAPIIslands^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneApproachs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : LaneApproachs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneApproachs As ISIAPILaneApproachs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As ISIAPILaneApproachs

value = instance.LaneApproachs
C#
ISIAPILaneApproachs LaneApproachs {get;}
Managed Extensions for C++
__property ISIAPILaneApproachs* get_LaneApproachs();
C++/CLI
property ISIAPILaneApproachs^ LaneApproachs {
   ISIAPILaneApproachs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExits Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : LaneExits Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LaneExits As ISIAPILaneExits
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As ISIAPILaneExits

value = instance.LaneExits
C#
ISIAPILaneExits LaneExits {get;}
Managed Extensions for C++
__property ISIAPILaneExits* get_LaneExits();
C++/CLI
property ISIAPILaneExits^ LaneExits {
   ISIAPILaneExits^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg_roundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Leg_roundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg_roundabout As ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As ISIAPILeg_roundabout

value = instance.Leg_roundabout
C#
ISIAPILeg_roundabout Leg_roundabout {get;}
Managed Extensions for C++
__property ISIAPILeg_roundabout* get_Leg_roundabout();
C++/CLI
property ISIAPILeg_roundabout^ Leg_roundabout {
   ISIAPILeg_roundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegGeometry Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : LegGeometry Property

Glossary Item Box

Leg Geometry

Syntax

Visual Basic (Declaration)
Property LegGeometry As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Integer

instance.LegGeometry = value

value = instance.LegGeometry
C#
int LegGeometry {get; set;}
Managed Extensions for C++
__property int get_LegGeometry();
__property void set_LegGeometry(
   int value
);
C++/CLI
property int LegGeometry {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = No Leg,
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Remarks

Cannot remove a Leg by setting LegGeometry to 0. Call ISIAPILegs.RemoveLeg() method to remove a Leg.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Orientation Property

Glossary Item Box

Leg Orientation

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As Integer

value = instance.Orientation
C#
int Orientation {get;}
Managed Extensions for C++
__property int get_Orientation();
C++/CLI
property int Orientation {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg Interface
ISIAPILeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_rou_hcm Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_rou_hcm Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
C#
public interface ISIAPILeg_rou_hcm
Managed Extensions for C++
public __gc __interface ISIAPILeg_rou_hcm
C++/CLI
public interface class ISIAPILeg_rou_hcm

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_rou_hcm Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_rou_hcm Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILeg_rou_hcm.

Public Properties

 | Name | Description
Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment (HCM)
Property | Hcm_model | HCM Model
Property | Leg_roundabout |
Property | Model_calib_factor |
Property | Multi_circ_multi_entry_dominant_param_a |
Property | Multi_circ_multi_entry_dominant_param_b |
Property | Multi_circ_multi_entry_subdominant_param_a |
Property | Multi_circ_multi_entry_subdominant_param_b |
Property | Multi_circ_single_entry_param_a |
Property | Multi_circ_single_entry_param_b |
Property | Single_circ_multi_entry_param_a |
Property | Single_circ_multi_entry_param_b |
Property | Single_circ_single_entry_param_a |
Property | Single_circ_single_entry_param_b |
Top

See Also

Reference

ISIAPILeg_rou_hcm Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_rou_hcm Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_rou_hcm Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILeg_rou_hcm members.

Public Properties

 | Name | Description
Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment (HCM)
Property | Hcm_model | HCM Model
Property | Leg_roundabout |
Property | Model_calib_factor |
Property | Multi_circ_multi_entry_dominant_param_a |
Property | Multi_circ_multi_entry_dominant_param_b |
Property | Multi_circ_multi_entry_subdominant_param_a |
Property | Multi_circ_multi_entry_subdominant_param_b |
Property | Multi_circ_single_entry_param_a |
Property | Multi_circ_single_entry_param_b |
Property | Single_circ_multi_entry_param_a |
Property | Single_circ_multi_entry_param_b |
Property | Single_circ_single_entry_param_a |
Property | Single_circ_single_entry_param_b |
Top

See Also

Reference

ISIAPILeg_rou_hcm Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Entry_circ_adj Property

Glossary Item Box

Roundabout Entry/Circulating Flow Adjustment (HCM)

Syntax

Visual Basic (Declaration)
Property Entry_circ_adj As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Integer

instance.Entry_circ_adj = value

value = instance.Entry_circ_adj
C#
int Entry_circ_adj {get; set;}
Managed Extensions for C++
__property int get_Entry_circ_adj();
__property void set_Entry_circ_adj(
   int value
);
C++/CLI
property int Entry_circ_adj {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hcm_model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Hcm_model Property

Glossary Item Box

HCM Model

Syntax

Visual Basic (Declaration)
ReadOnly Property Hcm_model As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Integer

value = instance.Hcm_model
C#
int Hcm_model {get;}
Managed Extensions for C++
__property int get_Hcm_model();
C++/CLI
property int Hcm_model {
   int get();
}

Property Value

Type: System.Int32;

1 = HCM 2010,
2 = HCM 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg_roundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Leg_roundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg_roundabout As ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As ISIAPILeg_roundabout

value = instance.Leg_roundabout
C#
ISIAPILeg_roundabout Leg_roundabout {get;}
Managed Extensions for C++
__property ISIAPILeg_roundabout* get_Leg_roundabout();
C++/CLI
property ISIAPILeg_roundabout^ Leg_roundabout {
   ISIAPILeg_roundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_calib_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Model_calib_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Model_calib_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Model_calib_factor = value

value = instance.Model_calib_factor
C#
float Model_calib_factor {get; set;}
Managed Extensions for C++
__property float get_Model_calib_factor();
__property void set_Model_calib_factor(
   float value
);
C++/CLI
property float Model_calib_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_dominant_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_multi_entry_dominant_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_multi_entry_dominant_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_dominant_param_a = value

value = instance.Multi_circ_multi_entry_dominant_param_a
C#
float Multi_circ_multi_entry_dominant_param_a {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_multi_entry_dominant_param_a();
__property void set_Multi_circ_multi_entry_dominant_param_a(
   float value
);
C++/CLI
property float Multi_circ_multi_entry_dominant_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_dominant_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_multi_entry_dominant_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_multi_entry_dominant_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_dominant_param_b = value

value = instance.Multi_circ_multi_entry_dominant_param_b
C#
float Multi_circ_multi_entry_dominant_param_b {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_multi_entry_dominant_param_b();
__property void set_Multi_circ_multi_entry_dominant_param_b(
   float value
);
C++/CLI
property float Multi_circ_multi_entry_dominant_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_subdominant_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_multi_entry_subdominant_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_multi_entry_subdominant_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_subdominant_param_a = value

value = instance.Multi_circ_multi_entry_subdominant_param_a
C#
float Multi_circ_multi_entry_subdominant_param_a {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_multi_entry_subdominant_param_a();
__property void set_Multi_circ_multi_entry_subdominant_param_a(
   float value
);
C++/CLI
property float Multi_circ_multi_entry_subdominant_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_multi_entry_subdominant_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_multi_entry_subdominant_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_multi_entry_subdominant_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_multi_entry_subdominant_param_b = value

value = instance.Multi_circ_multi_entry_subdominant_param_b
C#
float Multi_circ_multi_entry_subdominant_param_b {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_multi_entry_subdominant_param_b();
__property void set_Multi_circ_multi_entry_subdominant_param_b(
   float value
);
C++/CLI
property float Multi_circ_multi_entry_subdominant_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_single_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_single_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_single_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_single_entry_param_a = value

value = instance.Multi_circ_single_entry_param_a
C#
float Multi_circ_single_entry_param_a {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_single_entry_param_a();
__property void set_Multi_circ_single_entry_param_a(
   float value
);
C++/CLI
property float Multi_circ_single_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Multi_circ_single_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Multi_circ_single_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Multi_circ_single_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Multi_circ_single_entry_param_b = value

value = instance.Multi_circ_single_entry_param_b
C#
float Multi_circ_single_entry_param_b {get; set;}
Managed Extensions for C++
__property float get_Multi_circ_single_entry_param_b();
__property void set_Multi_circ_single_entry_param_b(
   float value
);
C++/CLI
property float Multi_circ_single_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_multi_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Single_circ_multi_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Single_circ_multi_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_multi_entry_param_a = value

value = instance.Single_circ_multi_entry_param_a
C#
float Single_circ_multi_entry_param_a {get; set;}
Managed Extensions for C++
__property float get_Single_circ_multi_entry_param_a();
__property void set_Single_circ_multi_entry_param_a(
   float value
);
C++/CLI
property float Single_circ_multi_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_multi_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Single_circ_multi_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Single_circ_multi_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_multi_entry_param_b = value

value = instance.Single_circ_multi_entry_param_b
C#
float Single_circ_multi_entry_param_b {get; set;}
Managed Extensions for C++
__property float get_Single_circ_multi_entry_param_b();
__property void set_Single_circ_multi_entry_param_b(
   float value
);
C++/CLI
property float Single_circ_multi_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_single_entry_param_a Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Single_circ_single_entry_param_a Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Single_circ_single_entry_param_a As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_single_entry_param_a = value

value = instance.Single_circ_single_entry_param_a
C#
float Single_circ_single_entry_param_a {get; set;}
Managed Extensions for C++
__property float get_Single_circ_single_entry_param_a();
__property void set_Single_circ_single_entry_param_a(
   float value
);
C++/CLI
property float Single_circ_single_entry_param_a {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_circ_single_entry_param_b Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_rou_hcm Interface : Single_circ_single_entry_param_b Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Single_circ_single_entry_param_b As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_rou_hcm
Dim value As Single

instance.Single_circ_single_entry_param_b = value

value = instance.Single_circ_single_entry_param_b
C#
float Single_circ_single_entry_param_b {get; set;}
Managed Extensions for C++
__property float get_Single_circ_single_entry_param_b();
__property void set_Single_circ_single_entry_param_b(
   float value
);
C++/CLI
property float Single_circ_single_entry_param_b {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_rou_hcm Interface
ISIAPILeg_rou_hcm Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_roundabout Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_roundabout Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILeg_roundabout
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
C#
public interface ISIAPILeg_roundabout
Managed Extensions for C++
public __gc __interface ISIAPILeg_roundabout
C++/CLI
public interface class ISIAPILeg_roundabout

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_roundabout Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_roundabout Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILeg_roundabout.

Public Properties

 | Name | Description
Property | App_half_width |
Property | Capacity_at_zero_flow |
Property | Capacity_at_zero_flow_user |
Property | Circulating_transition_line |
Property | Circulating_width |
Property | Entry_angle |
Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment
Property | Entry_circ_adj_user |
Property | Entry_radius |
Property | Environment_factor |
Property | Environment_factor_user |
Property | Flare_length |
Property | Grade_separated |
Property | Inscribed_diameter |
Property | Inscribed_diameter_user |
Property | Is_raindrop_design |
Property | Island_diameter |
Property | Leg |
Property | LegRouHCM2010 |
Property | LegRouHCM6 |
Property | Num_circulating_lanes |
Property | Num_downstream_circulating_lanes |
Property | Num_downstream_circulating_lanes_user |
Top

See Also

Reference

ISIAPILeg_roundabout Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILeg_roundabout Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILeg_roundabout Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILeg_roundabout members.

Public Properties

 | Name | Description
Property | App_half_width |
Property | Capacity_at_zero_flow |
Property | Capacity_at_zero_flow_user |
Property | Circulating_transition_line |
Property | Circulating_width |
Property | Entry_angle |
Property | Entry_circ_adj | Roundabout Entry/Circulating Flow Adjustment
Property | Entry_circ_adj_user |
Property | Entry_radius |
Property | Environment_factor |
Property | Environment_factor_user |
Property | Flare_length |
Property | Grade_separated |
Property | Inscribed_diameter |
Property | Inscribed_diameter_user |
Property | Is_raindrop_design |
Property | Island_diameter |
Property | Leg |
Property | LegRouHCM2010 |
Property | LegRouHCM6 |
Property | Num_circulating_lanes |
Property | Num_downstream_circulating_lanes |
Property | Num_downstream_circulating_lanes_user |
Top

See Also

Reference

ISIAPILeg_roundabout Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
App_half_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : App_half_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property App_half_width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.App_half_width = value

value = instance.App_half_width
C#
float App_half_width {get; set;}
Managed Extensions for C++
__property float get_App_half_width();
__property void set_App_half_width(
   float value
);
C++/CLI
property float App_half_width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_at_zero_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Capacity_at_zero_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Capacity_at_zero_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Capacity_at_zero_flow = value

value = instance.Capacity_at_zero_flow
C#
float Capacity_at_zero_flow {get; set;}
Managed Extensions for C++
__property float get_Capacity_at_zero_flow();
__property void set_Capacity_at_zero_flow(
   float value
);
C++/CLI
property float Capacity_at_zero_flow {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_at_zero_flow_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Capacity_at_zero_flow_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Capacity_at_zero_flow_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Capacity_at_zero_flow_user = value

value = instance.Capacity_at_zero_flow_user
C#
bool Capacity_at_zero_flow_user {get; set;}
Managed Extensions for C++
__property bool get_Capacity_at_zero_flow_user();
__property void set_Capacity_at_zero_flow_user(
   bool value
);
C++/CLI
property bool Capacity_at_zero_flow_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_transition_line Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Circulating_transition_line Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Circulating_transition_line As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Circulating_transition_line = value

value = instance.Circulating_transition_line
C#
bool Circulating_transition_line {get; set;}
Managed Extensions for C++
__property bool get_Circulating_transition_line();
__property void set_Circulating_transition_line(
   bool value
);
C++/CLI
property bool Circulating_transition_line {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Circulating_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Circulating_width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Circulating_width = value

value = instance.Circulating_width
C#
float Circulating_width {get; set;}
Managed Extensions for C++
__property float get_Circulating_width();
__property void set_Circulating_width(
   float value
);
C++/CLI
property float Circulating_width {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_angle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Entry_angle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Entry_angle As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Entry_angle = value

value = instance.Entry_angle
C#
float Entry_angle {get; set;}
Managed Extensions for C++
__property float get_Entry_angle();
__property void set_Entry_angle(
   float value
);
C++/CLI
property float Entry_angle {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Entry_circ_adj Property

Glossary Item Box

Roundabout Entry/Circulating Flow Adjustment

Syntax

Visual Basic (Declaration)
Property Entry_circ_adj As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Integer

instance.Entry_circ_adj = value

value = instance.Entry_circ_adj
C#
int Entry_circ_adj {get; set;}
Managed Extensions for C++
__property int get_Entry_circ_adj();
__property void set_Entry_circ_adj(
   int value
);
C++/CLI
property int Entry_circ_adj {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_circ_adj_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Entry_circ_adj_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Entry_circ_adj_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Entry_circ_adj_user = value

value = instance.Entry_circ_adj_user
C#
bool Entry_circ_adj_user {get; set;}
Managed Extensions for C++
__property bool get_Entry_circ_adj_user();
__property void set_Entry_circ_adj_user(
   bool value
);
C++/CLI
property bool Entry_circ_adj_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Entry_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Entry_radius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Entry_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Entry_radius = value

value = instance.Entry_radius
C#
float Entry_radius {get; set;}
Managed Extensions for C++
__property float get_Entry_radius();
__property void set_Entry_radius(
   float value
);
C++/CLI
property float Entry_radius {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Environment_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Environment_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Environment_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Environment_factor = value

value = instance.Environment_factor
C#
float Environment_factor {get; set;}
Managed Extensions for C++
__property float get_Environment_factor();
__property void set_Environment_factor(
   float value
);
C++/CLI
property float Environment_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Environment_factor_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Environment_factor_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Environment_factor_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Environment_factor_user = value

value = instance.Environment_factor_user
C#
bool Environment_factor_user {get; set;}
Managed Extensions for C++
__property bool get_Environment_factor_user();
__property void set_Environment_factor_user(
   bool value
);
C++/CLI
property bool Environment_factor_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flare_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Flare_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flare_length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Flare_length = value

value = instance.Flare_length
C#
float Flare_length {get; set;}
Managed Extensions for C++
__property float get_Flare_length();
__property void set_Flare_length(
   float value
);
C++/CLI
property float Flare_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Grade_separated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Grade_separated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Grade_separated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Grade_separated = value

value = instance.Grade_separated
C#
bool Grade_separated {get; set;}
Managed Extensions for C++
__property bool get_Grade_separated();
__property void set_Grade_separated(
   bool value
);
C++/CLI
property bool Grade_separated {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Inscribed_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Inscribed_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Inscribed_diameter = value

value = instance.Inscribed_diameter
C#
float Inscribed_diameter {get; set;}
Managed Extensions for C++
__property float get_Inscribed_diameter();
__property void set_Inscribed_diameter(
   float value
);
C++/CLI
property float Inscribed_diameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Inscribed_diameter_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Inscribed_diameter_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Inscribed_diameter_user = value

value = instance.Inscribed_diameter_user
C#
bool Inscribed_diameter_user {get; set;}
Managed Extensions for C++
__property bool get_Inscribed_diameter_user();
__property void set_Inscribed_diameter_user(
   bool value
);
C++/CLI
property bool Inscribed_diameter_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_raindrop_design Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Is_raindrop_design Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_raindrop_design As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Is_raindrop_design = value

value = instance.Is_raindrop_design
C#
bool Is_raindrop_design {get; set;}
Managed Extensions for C++
__property bool get_Is_raindrop_design();
__property void set_Is_raindrop_design(
   bool value
);
C++/CLI
property bool Is_raindrop_design {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Island_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Island_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Island_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Single

instance.Island_diameter = value

value = instance.Island_diameter
C#
float Island_diameter {get; set;}
Managed Extensions for C++
__property float get_Island_diameter();
__property void set_Island_diameter(
   float value
);
C++/CLI
property float Island_diameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Leg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As ISIAPILeg

value = instance.Leg
C#
ISIAPILeg Leg {get;}
Managed Extensions for C++
__property ISIAPILeg* get_Leg();
C++/CLI
property ISIAPILeg^ Leg {
   ISIAPILeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegRouHCM2010 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : LegRouHCM2010 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LegRouHCM2010 As ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As ISIAPILeg_rou_hcm

value = instance.LegRouHCM2010
C#
ISIAPILeg_rou_hcm LegRouHCM2010 {get;}
Managed Extensions for C++
__property ISIAPILeg_rou_hcm* get_LegRouHCM2010();
C++/CLI
property ISIAPILeg_rou_hcm^ LegRouHCM2010 {
   ISIAPILeg_rou_hcm^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegRouHCM6 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : LegRouHCM6 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LegRouHCM6 As ISIAPILeg_rou_hcm
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As ISIAPILeg_rou_hcm

value = instance.LegRouHCM6
C#
ISIAPILeg_rou_hcm LegRouHCM6 {get;}
Managed Extensions for C++
__property ISIAPILeg_rou_hcm* get_LegRouHCM6();
C++/CLI
property ISIAPILeg_rou_hcm^ LegRouHCM6 {
   ISIAPILeg_rou_hcm^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_circulating_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Num_circulating_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Num_circulating_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Integer

instance.Num_circulating_lanes = value

value = instance.Num_circulating_lanes
C#
int Num_circulating_lanes {get; set;}
Managed Extensions for C++
__property int get_Num_circulating_lanes();
__property void set_Num_circulating_lanes(
   int value
);
C++/CLI
property int Num_circulating_lanes {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_downstream_circulating_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Num_downstream_circulating_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Num_downstream_circulating_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Integer

instance.Num_downstream_circulating_lanes = value

value = instance.Num_downstream_circulating_lanes
C#
int Num_downstream_circulating_lanes {get; set;}
Managed Extensions for C++
__property int get_Num_downstream_circulating_lanes();
__property void set_Num_downstream_circulating_lanes(
   int value
);
C++/CLI
property int Num_downstream_circulating_lanes {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_downstream_circulating_lanes_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILeg_roundabout Interface : Num_downstream_circulating_lanes_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Num_downstream_circulating_lanes_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILeg_roundabout
Dim value As Boolean

instance.Num_downstream_circulating_lanes_user = value

value = instance.Num_downstream_circulating_lanes_user
C#
bool Num_downstream_circulating_lanes_user {get; set;}
Managed Extensions for C++
__property bool get_Num_downstream_circulating_lanes_user();
__property void set_Num_downstream_circulating_lanes_user(
   bool value
);
C++/CLI
property bool Num_downstream_circulating_lanes_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILeg_roundabout Interface
ISIAPILeg_roundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILegs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILegs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPILegs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILegs
C#
public interface ISIAPILegs
Managed Extensions for C++
public __gc __interface ISIAPILegs
C++/CLI
public interface class ISIAPILegs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILegs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILegs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILegs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPILegs.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Leg. Return a Leg if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegExists | Get a value indicating whether a Leg data exists in the data structure.
Top

See Also

Reference

ISIAPILegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILegs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILegs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILegs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegExists | Get a value indicating whether a Leg data exists in the data structure.
Top

See Also

Reference

ISIAPILegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILegs Interface : LegExists Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Get a value indicating whether a Leg data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function LegExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILegs
Dim orientation As Integer
Dim value As Boolean

value = instance.LegExists(orientation)
C#
bool LegExists(
   int orientation
)
Managed Extensions for C++
bool LegExists(
   int orientation
)
C++/CLI
bool LegExists(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILegs Interface
ISIAPILegs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILegs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILegs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILegs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Leg. Return a Leg if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPILegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILegs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILegs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILegs Interface
ISIAPILegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPILegs Interface : Item Property

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Get a Leg.
Return a Leg if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPILegs
Dim orientation As Integer
Dim value As ISIAPILeg

value = instance.Item(orientation)
C#
ISIAPILeg this[
   int orientation
]; {get;}
Managed Extensions for C++
__property ISIAPILeg* get_Item   int orientation
;
C++/CLI
property ISIAPILeg^ default [int] {
   ISIAPILeg^ get(int orientation);
}

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPILegs Interface
ISIAPILegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIModelSetting Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIModelSetting Interface

Glossary Item Box

SIDRA INTERSECTION Model Setting wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIModelSetting
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
C#
public interface ISIAPIModelSetting
Managed Extensions for C++
public __gc __interface ISIAPIModelSetting
C++/CLI
public interface class ISIAPIModelSetting

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIModelSetting Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIModelSetting Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIModelSetting.

Public Properties

 | Name | Description
Property | Calibration_note |
Property | Downstream_SL_CalibrationParameter |
Property | Downstream_SL_Distance_FullLaneUtil |
Property | Downstream_SL_Distance_Min |
Property | Downstream_SL_Util_Ratio_Min |
Property | Gap_Acceptance_Capacity | Gap Acceptance Capacity
Property | Hours_per_Year |
Property | Is_geometric_delay_excluded |
Property | Is_hcm_delay_formula_applied |
Property | Is_hcm_queue_formula_applied |
Property | Is_ped_cost_included |
Property | LOS_Method | Level of Service Method
Property | LOS_Target | Level of Service Target
Property | Major_road_turn_flow_factor |
Property | Min_prob_blockage |
Property | Ped_average_income |
Property | Ped_LOS_Method |
Property | Ped_los_target | Pedestrian Level of Service Target
Property | Ped_time_value_factor |
Property | Percentile_Queue |
Property | Percentile_queue_option | Percentile Queue Option
Property | Performance_Measure | Performance Measure
Property | Platoon_disp_distance_max |
Property | Platoon_disp_distance_min |
Property | Platoon_disp_factor_max |
Property | Platoon_disp_factor_min |
Property | Platoon_disp_n |
Property | Platoon_front_factor |
Property | Reduct_opposing_flow_rate_level | Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)
Property | Rou_Capacity_Model | Roundabout Capacity Model
Property | Rou_FHWA_2000_model_applied |
Property | Rou_FHWA_2000_Urban_compact_applied |
Property | Rou_HCM_2000_model_applied |
Property | Rou_HCM_2010_OD_pattern_effects_included |
Property | Rou_HCM_6_OD_pattern_effects_included |
Property | Rou_LOS_Method | Roundabout LOS Method
Property | Rou_NAASRA_1986_model_applied |
Property | Shortlane_queue_storage_ratio_incl |
Top

See Also

Reference

ISIAPIModelSetting Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIModelSetting Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIModelSetting Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIModelSetting members.

Public Properties

 | Name | Description
Property | Calibration_note |
Property | Downstream_SL_CalibrationParameter |
Property | Downstream_SL_Distance_FullLaneUtil |
Property | Downstream_SL_Distance_Min |
Property | Downstream_SL_Util_Ratio_Min |
Property | Gap_Acceptance_Capacity | Gap Acceptance Capacity
Property | Hours_per_Year |
Property | Is_geometric_delay_excluded |
Property | Is_hcm_delay_formula_applied |
Property | Is_hcm_queue_formula_applied |
Property | Is_ped_cost_included |
Property | LOS_Method | Level of Service Method
Property | LOS_Target | Level of Service Target
Property | Major_road_turn_flow_factor |
Property | Min_prob_blockage |
Property | Ped_average_income |
Property | Ped_LOS_Method |
Property | Ped_los_target | Pedestrian Level of Service Target
Property | Ped_time_value_factor |
Property | Percentile_Queue |
Property | Percentile_queue_option | Percentile Queue Option
Property | Performance_Measure | Performance Measure
Property | Platoon_disp_distance_max |
Property | Platoon_disp_distance_min |
Property | Platoon_disp_factor_max |
Property | Platoon_disp_factor_min |
Property | Platoon_disp_n |
Property | Platoon_front_factor |
Property | Reduct_opposing_flow_rate_level | Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)
Property | Rou_Capacity_Model | Roundabout Capacity Model
Property | Rou_FHWA_2000_model_applied |
Property | Rou_FHWA_2000_Urban_compact_applied |
Property | Rou_HCM_2000_model_applied |
Property | Rou_HCM_2010_OD_pattern_effects_included |
Property | Rou_HCM_6_OD_pattern_effects_included |
Property | Rou_LOS_Method | Roundabout LOS Method
Property | Rou_NAASRA_1986_model_applied |
Property | Shortlane_queue_storage_ratio_incl |
Top

See Also

Reference

ISIAPIModelSetting Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calibration_note Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Calibration_note Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Calibration_note As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As String

instance.Calibration_note = value

value = instance.Calibration_note
C#
string Calibration_note {get; set;}
Managed Extensions for C++
__property string* get_Calibration_note();
__property void set_Calibration_note(
   string* value
);
C++/CLI
property String^ Calibration_note {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_CalibrationParameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Downstream_SL_CalibrationParameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Downstream_SL_CalibrationParameter As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Downstream_SL_CalibrationParameter = value

value = instance.Downstream_SL_CalibrationParameter
C#
float Downstream_SL_CalibrationParameter {get; set;}
Managed Extensions for C++
__property float get_Downstream_SL_CalibrationParameter();
__property void set_Downstream_SL_CalibrationParameter(
   float value
);
C++/CLI
property float Downstream_SL_CalibrationParameter {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Distance_FullLaneUtil Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Downstream_SL_Distance_FullLaneUtil Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Downstream_SL_Distance_FullLaneUtil As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Distance_FullLaneUtil = value

value = instance.Downstream_SL_Distance_FullLaneUtil
C#
float Downstream_SL_Distance_FullLaneUtil {get; set;}
Managed Extensions for C++
__property float get_Downstream_SL_Distance_FullLaneUtil();
__property void set_Downstream_SL_Distance_FullLaneUtil(
   float value
);
C++/CLI
property float Downstream_SL_Distance_FullLaneUtil {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Distance_Min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Downstream_SL_Distance_Min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Downstream_SL_Distance_Min As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Distance_Min = value

value = instance.Downstream_SL_Distance_Min
C#
float Downstream_SL_Distance_Min {get; set;}
Managed Extensions for C++
__property float get_Downstream_SL_Distance_Min();
__property void set_Downstream_SL_Distance_Min(
   float value
);
C++/CLI
property float Downstream_SL_Distance_Min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Downstream_SL_Util_Ratio_Min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Downstream_SL_Util_Ratio_Min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Downstream_SL_Util_Ratio_Min As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Downstream_SL_Util_Ratio_Min = value

value = instance.Downstream_SL_Util_Ratio_Min
C#
float Downstream_SL_Util_Ratio_Min {get; set;}
Managed Extensions for C++
__property float get_Downstream_SL_Util_Ratio_Min();
__property void set_Downstream_SL_Util_Ratio_Min(
   float value
);
C++/CLI
property float Downstream_SL_Util_Ratio_Min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_Acceptance_Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Gap_Acceptance_Capacity Property

Glossary Item Box

Gap Acceptance Capacity

Syntax

Visual Basic (Declaration)
Property Gap_Acceptance_Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Gap_Acceptance_Capacity = value

value = instance.Gap_Acceptance_Capacity
C#
int Gap_Acceptance_Capacity {get; set;}
Managed Extensions for C++
__property int get_Gap_Acceptance_Capacity();
__property void set_Gap_Acceptance_Capacity(
   int value
);
C++/CLI
property int Gap_Acceptance_Capacity {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Standard (Akcelik M3D),
1 = Akcelik M1,
2 = Siegloch M1,
3 = Traditional M1.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hours_per_Year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Hours_per_Year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Hours_per_Year As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Hours_per_Year = value

value = instance.Hours_per_Year
C#
int Hours_per_Year {get; set;}
Managed Extensions for C++
__property int get_Hours_per_Year();
__property void set_Hours_per_Year(
   int value
);
C++/CLI
property int Hours_per_Year {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_geometric_delay_excluded Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Is_geometric_delay_excluded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_geometric_delay_excluded As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Is_geometric_delay_excluded = value

value = instance.Is_geometric_delay_excluded
C#
bool Is_geometric_delay_excluded {get; set;}
Managed Extensions for C++
__property bool get_Is_geometric_delay_excluded();
__property void set_Is_geometric_delay_excluded(
   bool value
);
C++/CLI
property bool Is_geometric_delay_excluded {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_hcm_delay_formula_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Is_hcm_delay_formula_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_hcm_delay_formula_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Is_hcm_delay_formula_applied = value

value = instance.Is_hcm_delay_formula_applied
C#
bool Is_hcm_delay_formula_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_hcm_delay_formula_applied();
__property void set_Is_hcm_delay_formula_applied(
   bool value
);
C++/CLI
property bool Is_hcm_delay_formula_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_hcm_queue_formula_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Is_hcm_queue_formula_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_hcm_queue_formula_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Is_hcm_queue_formula_applied = value

value = instance.Is_hcm_queue_formula_applied
C#
bool Is_hcm_queue_formula_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_hcm_queue_formula_applied();
__property void set_Is_hcm_queue_formula_applied(
   bool value
);
C++/CLI
property bool Is_hcm_queue_formula_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_ped_cost_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Is_ped_cost_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_ped_cost_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Is_ped_cost_included = value

value = instance.Is_ped_cost_included
C#
bool Is_ped_cost_included {get; set;}
Managed Extensions for C++
__property bool get_Is_ped_cost_included();
__property void set_Is_ped_cost_included(
   bool value
);
C++/CLI
property bool Is_ped_cost_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : LOS_Method Property

Glossary Item Box

Level of Service Method

Syntax

Visual Basic (Declaration)
Property LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.LOS_Method = value

value = instance.LOS_Method
C#
int LOS_Method {get; set;}
Managed Extensions for C++
__property int get_LOS_Method();
__property void set_LOS_Method(
   int value
);
C++/CLI
property int LOS_Method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Delay (SIDRA),
1 = Degree of Saturation (SIDRA),
2 = Delay and v/c (HCM 2010),
3 = Delay (RTA NSW),
4 = Degree of Saturation (ICU),
5 = Delay and Degree of Saturation (SIDRA),
6 = Delay and v/c (HCM 6).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOS_Target Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : LOS_Target Property

Glossary Item Box

Level of Service Target

Syntax

Visual Basic (Declaration)
Property LOS_Target As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.LOS_Target = value

value = instance.LOS_Target
C#
int LOS_Target {get; set;}
Managed Extensions for C++
__property int get_LOS_Target();
__property void set_LOS_Target(
   int value
);
C++/CLI
property int LOS_Target {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Major_road_turn_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Major_road_turn_flow_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Major_road_turn_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Major_road_turn_flow_factor = value

value = instance.Major_road_turn_flow_factor
C#
float Major_road_turn_flow_factor {get; set;}
Managed Extensions for C++
__property float get_Major_road_turn_flow_factor();
__property void set_Major_road_turn_flow_factor(
   float value
);
C++/CLI
property float Major_road_turn_flow_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_prob_blockage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Min_prob_blockage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Min_prob_blockage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Min_prob_blockage = value

value = instance.Min_prob_blockage
C#
float Min_prob_blockage {get; set;}
Managed Extensions for C++
__property float get_Min_prob_blockage();
__property void set_Min_prob_blockage(
   float value
);
C++/CLI
property float Min_prob_blockage {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_average_income Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Ped_average_income Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Ped_average_income As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Ped_average_income = value

value = instance.Ped_average_income
C#
float Ped_average_income {get; set;}
Managed Extensions for C++
__property float get_Ped_average_income();
__property void set_Ped_average_income(
   float value
);
C++/CLI
property float Ped_average_income {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Ped_LOS_Method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Ped_LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Ped_LOS_Method = value

value = instance.Ped_LOS_Method
C#
int Ped_LOS_Method {get; set;}
Managed Extensions for C++
__property int get_Ped_LOS_Method();
__property void set_Ped_LOS_Method(
   int value
);
C++/CLI
property int Ped_LOS_Method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_los_target Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Ped_los_target Property

Glossary Item Box

Pedestrian Level of Service Target

Syntax

Visual Basic (Declaration)
Property Ped_los_target As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Ped_los_target = value

value = instance.Ped_los_target
C#
int Ped_los_target {get; set;}
Managed Extensions for C++
__property int get_Ped_los_target();
__property void set_Ped_los_target(
   int value
);
C++/CLI
property int Ped_los_target {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_time_value_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Ped_time_value_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Ped_time_value_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Ped_time_value_factor = value

value = instance.Ped_time_value_factor
C#
float Ped_time_value_factor {get; set;}
Managed Extensions for C++
__property float get_Ped_time_value_factor();
__property void set_Ped_time_value_factor(
   float value
);
C++/CLI
property float Ped_time_value_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_Queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Percentile_Queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Percentile_Queue As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Percentile_Queue = value

value = instance.Percentile_Queue
C#
int Percentile_Queue {get; set;}
Managed Extensions for C++
__property int get_Percentile_Queue();
__property void set_Percentile_Queue(
   int value
);
C++/CLI
property int Percentile_Queue {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Percentile_queue_option Property

Glossary Item Box

Percentile Queue Option

Syntax

Visual Basic (Declaration)
Property Percentile_queue_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Percentile_queue_option = value

value = instance.Percentile_queue_option
C#
int Percentile_queue_option {get; set;}
Managed Extensions for C++
__property int get_Percentile_queue_option();
__property void set_Percentile_queue_option(
   int value
);
C++/CLI
property int Percentile_queue_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Percentile,
2 = Average.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_Measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Performance_Measure Property

Glossary Item Box

Performance Measure

Syntax

Visual Basic (Declaration)
Property Performance_Measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Performance_Measure = value

value = instance.Performance_Measure
C#
int Performance_Measure {get; set;}
Managed Extensions for C++
__property int get_Performance_Measure();
__property void set_Performance_Measure(
   int value
);
C++/CLI
property int Performance_Measure {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Delay,
1 = Queue,
2 = Stop Rate,
3 = Performance Index,
4 = Degree of Saturation,
5 = Capacity,
6 = Spare Capacity,
7 = Cost,
8 = Fuel,
9 = CO2,
10 = HC,
11 = CO,
12 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_distance_max Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_disp_distance_max Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_disp_distance_max As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_disp_distance_max = value

value = instance.Platoon_disp_distance_max
C#
float Platoon_disp_distance_max {get; set;}
Managed Extensions for C++
__property float get_Platoon_disp_distance_max();
__property void set_Platoon_disp_distance_max(
   float value
);
C++/CLI
property float Platoon_disp_distance_max {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_distance_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_disp_distance_min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_disp_distance_min As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_disp_distance_min = value

value = instance.Platoon_disp_distance_min
C#
float Platoon_disp_distance_min {get; set;}
Managed Extensions for C++
__property float get_Platoon_disp_distance_min();
__property void set_Platoon_disp_distance_min(
   float value
);
C++/CLI
property float Platoon_disp_distance_min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_factor_max Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_disp_factor_max Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_disp_factor_max As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_disp_factor_max = value

value = instance.Platoon_disp_factor_max
C#
float Platoon_disp_factor_max {get; set;}
Managed Extensions for C++
__property float get_Platoon_disp_factor_max();
__property void set_Platoon_disp_factor_max(
   float value
);
C++/CLI
property float Platoon_disp_factor_max {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_factor_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_disp_factor_min Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_disp_factor_min As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_disp_factor_min = value

value = instance.Platoon_disp_factor_min
C#
float Platoon_disp_factor_min {get; set;}
Managed Extensions for C++
__property float get_Platoon_disp_factor_min();
__property void set_Platoon_disp_factor_min(
   float value
);
C++/CLI
property float Platoon_disp_factor_min {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_disp_n Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_disp_n Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_disp_n As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_disp_n = value

value = instance.Platoon_disp_n
C#
float Platoon_disp_n {get; set;}
Managed Extensions for C++
__property float get_Platoon_disp_n();
__property void set_Platoon_disp_n(
   float value
);
C++/CLI
property float Platoon_disp_n {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_front_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Platoon_front_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Platoon_front_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Single

instance.Platoon_front_factor = value

value = instance.Platoon_front_factor
C#
float Platoon_front_factor {get; set;}
Managed Extensions for C++
__property float get_Platoon_front_factor();
__property void set_Platoon_front_factor(
   float value
);
C++/CLI
property float Platoon_front_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reduct_opposing_flow_rate_level Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Reduct_opposing_flow_rate_level Property

Glossary Item Box

Level of Reduction with Opposing Flow Rate (for Two-Way Sign Control Calibration)

Syntax

Visual Basic (Declaration)
Property Reduct_opposing_flow_rate_level As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Reduct_opposing_flow_rate_level = value

value = instance.Reduct_opposing_flow_rate_level
C#
int Reduct_opposing_flow_rate_level {get; set;}
Managed Extensions for C++
__property int get_Reduct_opposing_flow_rate_level();
__property void set_Reduct_opposing_flow_rate_level(
   int value
);
C++/CLI
property int Reduct_opposing_flow_rate_level {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Low,
2 = Medium,
3 = High.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_Capacity_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_Capacity_Model Property

Glossary Item Box

Roundabout Capacity Model

Syntax

Visual Basic (Declaration)
Property Rou_Capacity_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Rou_Capacity_Model = value

value = instance.Rou_Capacity_Model
C#
int Rou_Capacity_Model {get; set;}
Managed Extensions for C++
__property int get_Rou_Capacity_Model();
__property void set_Rou_Capacity_Model(
   int value
);
C++/CLI
property int Rou_Capacity_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Standard,
1 = HCM 2010.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_FHWA_2000_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_FHWA_2000_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_FHWA_2000_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_FHWA_2000_model_applied = value

value = instance.Rou_FHWA_2000_model_applied
C#
bool Rou_FHWA_2000_model_applied {get; set;}
Managed Extensions for C++
__property bool get_Rou_FHWA_2000_model_applied();
__property void set_Rou_FHWA_2000_model_applied(
   bool value
);
C++/CLI
property bool Rou_FHWA_2000_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_FHWA_2000_Urban_compact_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_FHWA_2000_Urban_compact_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_FHWA_2000_Urban_compact_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_FHWA_2000_Urban_compact_applied = value

value = instance.Rou_FHWA_2000_Urban_compact_applied
C#
bool Rou_FHWA_2000_Urban_compact_applied {get; set;}
Managed Extensions for C++
__property bool get_Rou_FHWA_2000_Urban_compact_applied();
__property void set_Rou_FHWA_2000_Urban_compact_applied(
   bool value
);
C++/CLI
property bool Rou_FHWA_2000_Urban_compact_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_2000_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_HCM_2000_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_HCM_2000_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_2000_model_applied = value

value = instance.Rou_HCM_2000_model_applied
C#
bool Rou_HCM_2000_model_applied {get; set;}
Managed Extensions for C++
__property bool get_Rou_HCM_2000_model_applied();
__property void set_Rou_HCM_2000_model_applied(
   bool value
);
C++/CLI
property bool Rou_HCM_2000_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_2010_OD_pattern_effects_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_HCM_2010_OD_pattern_effects_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_HCM_2010_OD_pattern_effects_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_2010_OD_pattern_effects_included = value

value = instance.Rou_HCM_2010_OD_pattern_effects_included
C#
bool Rou_HCM_2010_OD_pattern_effects_included {get; set;}
Managed Extensions for C++
__property bool get_Rou_HCM_2010_OD_pattern_effects_included();
__property void set_Rou_HCM_2010_OD_pattern_effects_included(
   bool value
);
C++/CLI
property bool Rou_HCM_2010_OD_pattern_effects_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_HCM_6_OD_pattern_effects_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_HCM_6_OD_pattern_effects_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_HCM_6_OD_pattern_effects_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_HCM_6_OD_pattern_effects_included = value

value = instance.Rou_HCM_6_OD_pattern_effects_included
C#
bool Rou_HCM_6_OD_pattern_effects_included {get; set;}
Managed Extensions for C++
__property bool get_Rou_HCM_6_OD_pattern_effects_included();
__property void set_Rou_HCM_6_OD_pattern_effects_included(
   bool value
);
C++/CLI
property bool Rou_HCM_6_OD_pattern_effects_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_LOS_Method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_LOS_Method Property

Glossary Item Box

Roundabout LOS Method

Syntax

Visual Basic (Declaration)
Property Rou_LOS_Method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Integer

instance.Rou_LOS_Method = value

value = instance.Rou_LOS_Method
C#
int Rou_LOS_Method {get; set;}
Managed Extensions for C++
__property int get_Rou_LOS_Method();
__property void set_Rou_LOS_Method(
   int value
);
C++/CLI
property int Rou_LOS_Method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = SIDRA Roundabout LOS,
1 = Same as Signalised Intersections,
2 = Same as Sign Control.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_NAASRA_1986_model_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Rou_NAASRA_1986_model_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_NAASRA_1986_model_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Rou_NAASRA_1986_model_applied = value

value = instance.Rou_NAASRA_1986_model_applied
C#
bool Rou_NAASRA_1986_model_applied {get; set;}
Managed Extensions for C++
__property bool get_Rou_NAASRA_1986_model_applied();
__property void set_Rou_NAASRA_1986_model_applied(
   bool value
);
C++/CLI
property bool Rou_NAASRA_1986_model_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_queue_storage_ratio_incl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIModelSetting Interface : Shortlane_queue_storage_ratio_incl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Shortlane_queue_storage_ratio_incl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIModelSetting
Dim value As Boolean

instance.Shortlane_queue_storage_ratio_incl = value

value = instance.Shortlane_queue_storage_ratio_incl
C#
bool Shortlane_queue_storage_ratio_incl {get; set;}
Managed Extensions for C++
__property bool get_Shortlane_queue_storage_ratio_incl();
__property void set_Shortlane_queue_storage_ratio_incl(
   bool value
);
C++/CLI
property bool Shortlane_queue_storage_ratio_incl {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIModelSetting Interface
ISIAPIModelSetting Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_ped Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_ped Interface

Glossary Item Box

SIDRA INTERSECTION Pedestrian Movement wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
C#
public interface ISIAPIMovement_ped
Managed Extensions for C++
public __gc __interface ISIAPIMovement_ped
C++/CLI
public interface class ISIAPIMovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_ped Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_ped Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_ped.

Public Properties

 | Name | Description
Property | Actuation_option |
Property | Actuation_percent |
Property | Approach_distance | Approach Travel Distance
Property | Clearance_time_overlap |
Property | Conflict_zone_length |
Property | Conflict_zone_length_user |
Property | Crossing_distance | Crossing Distance
Property | Crossing_distance_user | Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.
Property | Crossing_speed |
Property | Crosswalk_space |
Property | Display_id | Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.
Property | End_gain |
Property | Exists | Flag indicating whether this Pedestrian Movement "exists" (not banned) in the current Site.
Property | Exit_distance | Exit (Downstream) Distance
Property | Flow_scale | Flow Scale (Constant)
Property | Growth_rate | Growth Rate (%/year)
Property | Is_high_priority | High Priority for Green Splits
Property | Is_walk_time_extended |
Property | Maximum_green_time |
Property | Maximum_green_time_user |
Property | Minimum_clearance_time |
Property | Minimum_green_time |
Property | Minimum_green_time_user |
Property | Minimum_walk_time |
Property | Opposing_ped_factor |
Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Property | Peak_flow_factor | Peak Flow Factor (%)
Property | Practical_degree_of_saturation | Practical degree of saturation
Property | Practical_degree_of_saturation_user | Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.
Property | Queue_space | Queue Space
Property | Saturation_flow_rate | Saturation Flow (ped/h)
Property | Site |
Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Property | Start_loss |
Property | Type | The type of a Pedestrian Movement
Property | Volume | Pedestrian Volume
Property | Walking_speed | Walking Speed (Average)
Top

See Also

Reference

ISIAPIMovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_ped Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_ped Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_ped members.

Public Properties

 | Name | Description
Property | Actuation_option |
Property | Actuation_percent |
Property | Approach_distance | Approach Travel Distance
Property | Clearance_time_overlap |
Property | Conflict_zone_length |
Property | Conflict_zone_length_user |
Property | Crossing_distance | Crossing Distance
Property | Crossing_distance_user | Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.
Property | Crossing_speed |
Property | Crosswalk_space |
Property | Display_id | Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.
Property | End_gain |
Property | Exists | Flag indicating whether this Pedestrian Movement "exists" (not banned) in the current Site.
Property | Exit_distance | Exit (Downstream) Distance
Property | Flow_scale | Flow Scale (Constant)
Property | Growth_rate | Growth Rate (%/year)
Property | Is_high_priority | High Priority for Green Splits
Property | Is_walk_time_extended |
Property | Maximum_green_time |
Property | Maximum_green_time_user |
Property | Minimum_clearance_time |
Property | Minimum_green_time |
Property | Minimum_green_time_user |
Property | Minimum_walk_time |
Property | Opposing_ped_factor |
Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Property | Peak_flow_factor | Peak Flow Factor (%)
Property | Practical_degree_of_saturation | Practical degree of saturation
Property | Practical_degree_of_saturation_user | Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.
Property | Queue_space | Queue Space
Property | Saturation_flow_rate | Saturation Flow (ped/h)
Property | Site |
Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Property | Start_loss |
Property | Type | The type of a Pedestrian Movement
Property | Volume | Pedestrian Volume
Property | Walking_speed | Walking Speed (Average)
Top

See Also

Reference

ISIAPIMovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuation_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Actuation_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuation_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Actuation_option = value

value = instance.Actuation_option
C#
int Actuation_option {get; set;}
Managed Extensions for C++
__property int get_Actuation_option();
__property void set_Actuation_option(
   int value
);
C++/CLI
property int Actuation_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuation_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Actuation_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuation_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Actuation_percent = value

value = instance.Actuation_percent
C#
float Actuation_percent {get; set;}
Managed Extensions for C++
__property float get_Actuation_percent();
__property void set_Actuation_percent(
   float value
);
C++/CLI
property float Actuation_percent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Approach_distance Property

Glossary Item Box

Approach Travel Distance

Syntax

Visual Basic (Declaration)
Property Approach_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Approach_distance = value

value = instance.Approach_distance
C#
float Approach_distance {get; set;}
Managed Extensions for C++
__property float get_Approach_distance();
__property void set_Approach_distance(
   float value
);
C++/CLI
property float Approach_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Clearance_time_overlap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Clearance_time_overlap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Clearance_time_overlap As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Clearance_time_overlap = value

value = instance.Clearance_time_overlap
C#
int Clearance_time_overlap {get; set;}
Managed Extensions for C++
__property int get_Clearance_time_overlap();
__property void set_Clearance_time_overlap(
   int value
);
C++/CLI
property int Clearance_time_overlap {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Conflict_zone_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Conflict_zone_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Conflict_zone_length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Conflict_zone_length = value

value = instance.Conflict_zone_length
C#
float Conflict_zone_length {get; set;}
Managed Extensions for C++
__property float get_Conflict_zone_length();
__property void set_Conflict_zone_length(
   float value
);
C++/CLI
property float Conflict_zone_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Conflict_zone_length_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Conflict_zone_length_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Conflict_zone_length_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Conflict_zone_length_user = value

value = instance.Conflict_zone_length_user
C#
bool Conflict_zone_length_user {get; set;}
Managed Extensions for C++
__property bool get_Conflict_zone_length_user();
__property void set_Conflict_zone_length_user(
   bool value
);
C++/CLI
property bool Conflict_zone_length_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Crossing_distance Property

Glossary Item Box

Crossing Distance

Syntax

Visual Basic (Declaration)
Property Crossing_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Crossing_distance = value

value = instance.Crossing_distance
C#
float Crossing_distance {get; set;}
Managed Extensions for C++
__property float get_Crossing_distance();
__property void set_Crossing_distance(
   float value
);
C++/CLI
property float Crossing_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Crossing_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Crossing_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Property Crossing_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Crossing_distance_user = value

value = instance.Crossing_distance_user
C#
bool Crossing_distance_user {get; set;}
Managed Extensions for C++
__property bool get_Crossing_distance_user();
__property void set_Crossing_distance_user(
   bool value
);
C++/CLI
property bool Crossing_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crossing_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Crossing_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Crossing_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Crossing_speed = value

value = instance.Crossing_speed
C#
float Crossing_speed {get; set;}
Managed Extensions for C++
__property float get_Crossing_speed();
__property void set_Crossing_speed(
   float value
);
C++/CLI
property float Crossing_speed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crosswalk_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Crosswalk_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Crosswalk_space As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Crosswalk_space = value

value = instance.Crosswalk_space
C#
float Crosswalk_space {get; set;}
Managed Extensions for C++
__property float get_Crosswalk_space();
__property void set_Crosswalk_space(
   float value
);
C++/CLI
property float Crosswalk_space {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Display_id Property

Glossary Item Box

Movement ID, a simple text descriptor for the movement used in many SIDRA INTERSECTION reports to signify the movement.

Syntax

Visual Basic (Declaration)
Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
string Display_id {get; set;}
Managed Extensions for C++
__property string* get_Display_id();
__property void set_Display_id(
   string* value
);
C++/CLI
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : End_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property End_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.End_gain = value

value = instance.End_gain
C#
int End_gain {get; set;}
Managed Extensions for C++
__property int get_End_gain();
__property void set_End_gain(
   int value
);
C++/CLI
property int End_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Exists Property

Glossary Item Box

Flag indicating whether this Pedestrian Movement "exists" (not banned) in the current Site.

Syntax

Visual Basic (Declaration)
Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
bool Exists {get; set;}
Managed Extensions for C++
__property bool get_Exists();
__property void set_Exists(
   bool value
);
C++/CLI
property bool Exists {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Exit_distance Property

Glossary Item Box

Exit (Downstream) Distance

Syntax

Visual Basic (Declaration)
Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
float Exit_distance {get; set;}
Managed Extensions for C++
__property float get_Exit_distance();
__property void set_Exit_distance(
   float value
);
C++/CLI
property float Exit_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Flow_scale Property

Glossary Item Box

Flow Scale (Constant)

Syntax

Visual Basic (Declaration)
Property Flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Flow_scale = value

value = instance.Flow_scale
C#
float Flow_scale {get; set;}
Managed Extensions for C++
__property float get_Flow_scale();
__property void set_Flow_scale(
   float value
);
C++/CLI
property float Flow_scale {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Growth_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Growth_rate Property

Glossary Item Box

Growth Rate (%/year)

Syntax

Visual Basic (Declaration)
Property Growth_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Growth_rate = value

value = instance.Growth_rate
C#
float Growth_rate {get; set;}
Managed Extensions for C++
__property float get_Growth_rate();
__property void set_Growth_rate(
   float value
);
C++/CLI
property float Growth_rate {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_high_priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Is_high_priority Property

Glossary Item Box

High Priority for Green Splits

Syntax

Visual Basic (Declaration)
Property Is_high_priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Is_high_priority = value

value = instance.Is_high_priority
C#
bool Is_high_priority {get; set;}
Managed Extensions for C++
__property bool get_Is_high_priority();
__property void set_Is_high_priority(
   bool value
);
C++/CLI
property bool Is_high_priority {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_walk_time_extended Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Is_walk_time_extended Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_walk_time_extended As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Is_walk_time_extended = value

value = instance.Is_walk_time_extended
C#
bool Is_walk_time_extended {get; set;}
Managed Extensions for C++
__property bool get_Is_walk_time_extended();
__property void set_Is_walk_time_extended(
   bool value
);
C++/CLI
property bool Is_walk_time_extended {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Maximum_green_time = value

value = instance.Maximum_green_time
C#
int Maximum_green_time {get; set;}
Managed Extensions for C++
__property int get_Maximum_green_time();
__property void set_Maximum_green_time(
   int value
);
C++/CLI
property int Maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Maximum_green_time_user = value

value = instance.Maximum_green_time_user
C#
bool Maximum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Maximum_green_time_user();
__property void set_Maximum_green_time_user(
   bool value
);
C++/CLI
property bool Maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_clearance_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Minimum_clearance_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_clearance_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Minimum_clearance_time = value

value = instance.Minimum_clearance_time
C#
int Minimum_clearance_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_clearance_time();
__property void set_Minimum_clearance_time(
   int value
);
C++/CLI
property int Minimum_clearance_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Minimum_green_time = value

value = instance.Minimum_green_time
C#
int Minimum_green_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_green_time();
__property void set_Minimum_green_time(
   int value
);
C++/CLI
property int Minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Minimum_green_time_user = value

value = instance.Minimum_green_time_user
C#
bool Minimum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Minimum_green_time_user();
__property void set_Minimum_green_time_user(
   bool value
);
C++/CLI
property bool Minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Minimum_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Minimum_walk_time = value

value = instance.Minimum_walk_time
C#
int Minimum_walk_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_walk_time();
__property void set_Minimum_walk_time(
   int value
);
C++/CLI
property int Minimum_walk_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Opposing_ped_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_ped_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Opposing_ped_factor = value

value = instance.Opposing_ped_factor
C#
float Opposing_ped_factor {get; set;}
Managed Extensions for C++
__property float get_Opposing_ped_factor();
__property void set_Opposing_ped_factor(
   float value
);
C++/CLI
property float Opposing_ped_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Origin Property

Glossary Item Box

Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peak_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Peak_flow_factor Property

Glossary Item Box

Peak Flow Factor (%)

Syntax

Visual Basic (Declaration)
Property Peak_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Peak_flow_factor = value

value = instance.Peak_flow_factor
C#
float Peak_flow_factor {get; set;}
Managed Extensions for C++
__property float get_Peak_flow_factor();
__property void set_Peak_flow_factor(
   float value
);
C++/CLI
property float Peak_flow_factor {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Practical_degree_of_saturation Property

Glossary Item Box

Practical degree of saturation

Syntax

Visual Basic (Declaration)
Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Practical_degree_of_saturation = value

value = instance.Practical_degree_of_saturation
C#
float Practical_degree_of_saturation {get; set;}
Managed Extensions for C++
__property float get_Practical_degree_of_saturation();
__property void set_Practical_degree_of_saturation(
   float value
);
C++/CLI
property float Practical_degree_of_saturation {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Practical_degree_of_saturation_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Practical_degree_of_saturation or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Property Practical_degree_of_saturation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Boolean

instance.Practical_degree_of_saturation_user = value

value = instance.Practical_degree_of_saturation_user
C#
bool Practical_degree_of_saturation_user {get; set;}
Managed Extensions for C++
__property bool get_Practical_degree_of_saturation_user();
__property void set_Practical_degree_of_saturation_user(
   bool value
);
C++/CLI
property bool Practical_degree_of_saturation_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Queue_space Property

Glossary Item Box

Queue Space

Syntax

Visual Basic (Declaration)
Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Queue_space = value

value = instance.Queue_space
C#
float Queue_space {get; set;}
Managed Extensions for C++
__property float get_Queue_space();
__property void set_Queue_space(
   float value
);
C++/CLI
property float Queue_space {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Saturation_flow_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Saturation_flow_rate Property

Glossary Item Box

Saturation Flow (ped/h)

Syntax

Visual Basic (Declaration)
Property Saturation_flow_rate As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Saturation_flow_rate = value

value = instance.Saturation_flow_rate
C#
int Saturation_flow_rate {get; set;}
Managed Extensions for C++
__property int get_Saturation_flow_rate();
__property void set_Saturation_flow_rate(
   int value
);
C++/CLI
property int Saturation_flow_rate {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Stage Property

Glossary Item Box

Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

value = instance.Stage
C#
int Stage {get;}
Managed Extensions for C++
__property int get_Stage();
C++/CLI
property int Stage {
   int get();
}

Property Value

Type: System.Int32;

1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

instance.Start_loss = value

value = instance.Start_loss
C#
int Start_loss {get; set;}
Managed Extensions for C++
__property int get_Start_loss();
__property void set_Start_loss(
   int value
);
C++/CLI
property int Start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Type Property

Glossary Item Box

The type of a Pedestrian Movement

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Integer

value = instance.Type
C#
int Type {get;}
Managed Extensions for C++
__property int get_Type();
C++/CLI
property int Type {
   int get();
}

Property Value

Type: System.Int32;

1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Volume Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Volume Property

Glossary Item Box

Pedestrian Volume

Syntax

Visual Basic (Declaration)
Property Volume As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Volume = value

value = instance.Volume
C#
float Volume {get; set;}
Managed Extensions for C++
__property float get_Volume();
__property void set_Volume(
   float value
);
C++/CLI
property float Volume {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Walking_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_ped Interface : Walking_speed Property

Glossary Item Box

Walking Speed (Average)

Syntax

Visual Basic (Declaration)
Property Walking_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_ped
Dim value As Single

instance.Walking_speed = value

value = instance.Walking_speed
C#
float Walking_speed {get; set;}
Managed Extensions for C++
__property float get_Walking_speed();
__property void set_Walking_speed(
   float value
);
C++/CLI
property float Walking_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_ped Interface
ISIAPIMovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_peds Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_peds Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_peds
C#
public interface ISIAPIMovement_peds
Managed Extensions for C++
public __gc __interface ISIAPIMovement_peds
C++/CLI
public interface class ISIAPIMovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_peds Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_peds Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_peds.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIMovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_peds Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_peds members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIMovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_peds Interface : MovementExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Pedestrian Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.MovementExists(type, origin, stage)
C#
bool MovementExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
bool MovementExists(
   int type,
   int origin,
   int stage
)
C++/CLI
bool MovementExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_peds Interface
ISIAPIMovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_peds Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_peds members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement.
Top

See Also

Reference

ISIAPIMovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_peds Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_peds
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_peds Interface
ISIAPIMovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_peds Interface : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Pedestrian Movement.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIMovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIMovement_ped

value = instance.Item(type, origin, stage)
C#
ISIAPIMovement_ped this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
__property ISIAPIMovement_ped* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
property ISIAPIMovement_ped^ default [int,int,int] {
   ISIAPIMovement_ped^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Property Value

Return a Pedestrian Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_peds Interface
ISIAPIMovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od Interface

Glossary Item Box

SIDRA INTERSECTION Vehicle OD Movement wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
C#
public interface ISIAPIMovement_vehicle_od
Managed Extensions for C++
public __gc __interface ISIAPIMovement_vehicle_od
C++/CLI
public interface class ISIAPIMovement_vehicle_od

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_vehicle_od.

Public Properties

 | Name | Description
Property | Critical_gap |
Property | Destination | Movement Destination Leg
Property | Display_ltr_id |
Property | Display_od_id |
Property | End_departures |
Property | Exists | Flag indicating whether this OD movement "exists" (not banned) in the current site. The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.
Property | Exit_flow_effect |
Property | Followup_headway |
Property | Is_gap_acceptance_usergiven |
Property | Is_TWSC_adj_applied |
Property | IsPossible | Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.
Property | Minimum_departures |
Property | MovementVehicleODMCs |
Property | ODMovDesignation | OD Movement Designation
Property | Opposing_ped_effect_option | Opposing Pedestrian Effect Option
Property | Opposing_ped_effect_option_signals | Opposing Pedestrian Effect Option (Signalised)
Property | Opposing_ped_effect_start_loss |
Property | Opposing_ped_sliplane_critical_gap |
Property | Opposing_ped_sliplane_followup_headway |
Property | Opposing_ped_sliplane_gap_acceptance_option | Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)
Property | Opposing_ped_sliplane_minimum_departures |
Property | Opposingmovement_peds |
Property | Opposingmovement_vehicles |
Property | Origin | Movement Origin Leg
Property | Percent_opposed_by_nearest |
Property | Site |
Property | Turndesignation | Movement turn designation
Top

See Also

Reference

ISIAPIMovement_vehicle_od Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_od members.

Public Properties

 | Name | Description
Property | Critical_gap |
Property | Destination | Movement Destination Leg
Property | Display_ltr_id |
Property | Display_od_id |
Property | End_departures |
Property | Exists | Flag indicating whether this OD movement "exists" (not banned) in the current site. The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.
Property | Exit_flow_effect |
Property | Followup_headway |
Property | Is_gap_acceptance_usergiven |
Property | Is_TWSC_adj_applied |
Property | IsPossible | Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.
Property | Minimum_departures |
Property | MovementVehicleODMCs |
Property | ODMovDesignation | OD Movement Designation
Property | Opposing_ped_effect_option | Opposing Pedestrian Effect Option
Property | Opposing_ped_effect_option_signals | Opposing Pedestrian Effect Option (Signalised)
Property | Opposing_ped_effect_start_loss |
Property | Opposing_ped_sliplane_critical_gap |
Property | Opposing_ped_sliplane_followup_headway |
Property | Opposing_ped_sliplane_gap_acceptance_option | Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)
Property | Opposing_ped_sliplane_minimum_departures |
Property | Opposingmovement_peds |
Property | Opposingmovement_vehicles |
Property | Origin | Movement Origin Leg
Property | Percent_opposed_by_nearest |
Property | Site |
Property | Turndesignation | Movement turn designation
Top

See Also

Reference

ISIAPIMovement_vehicle_od Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Critical_gap = value

value = instance.Critical_gap
C#
float Critical_gap {get; set;}
Managed Extensions for C++
__property float get_Critical_gap();
__property void set_Critical_gap(
   float value
);
C++/CLI
property float Critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_ltr_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Display_ltr_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Display_ltr_id As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As String

instance.Display_ltr_id = value

value = instance.Display_ltr_id
C#
string Display_ltr_id {get; set;}
Managed Extensions for C++
__property string* get_Display_ltr_id();
__property void set_Display_ltr_id(
   string* value
);
C++/CLI
property String^ Display_ltr_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_od_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Display_od_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Display_od_id As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As String

instance.Display_od_id = value

value = instance.Display_od_id
C#
string Display_od_id {get; set;}
Managed Extensions for C++
__property string* get_Display_od_id();
__property void set_Display_od_id(
   string* value
);
C++/CLI
property String^ Display_od_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : End_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property End_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.End_departures = value

value = instance.End_departures
C#
float End_departures {get; set;}
Managed Extensions for C++
__property float get_End_departures();
__property void set_End_departures(
   float value
);
C++/CLI
property float End_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Exists Property

Glossary Item Box

Flag indicating whether this OD movement "exists" (not banned) in the current site.

The state of this property corresponds to the setting of the "Movement Exists" checkbox in the SIDRA INTERSECTION "Movement Definitions" dialog for the given OD movement.

Syntax

Visual Basic (Declaration)
Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Boolean

instance.Exists = value

value = instance.Exists
C#
bool Exists {get; set;}
Managed Extensions for C++
__property bool get_Exists();
__property void set_Exists(
   bool value
);
C++/CLI
property bool Exists {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_flow_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Exit_flow_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Exit_flow_effect As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Exit_flow_effect = value

value = instance.Exit_flow_effect
C#
float Exit_flow_effect {get; set;}
Managed Extensions for C++
__property float get_Exit_flow_effect();
__property void set_Exit_flow_effect(
   float value
);
C++/CLI
property float Exit_flow_effect {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Followup_headway = value

value = instance.Followup_headway
C#
float Followup_headway {get; set;}
Managed Extensions for C++
__property float get_Followup_headway();
__property void set_Followup_headway(
   float value
);
C++/CLI
property float Followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_gap_acceptance_usergiven Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Is_gap_acceptance_usergiven Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_gap_acceptance_usergiven As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Boolean

instance.Is_gap_acceptance_usergiven = value

value = instance.Is_gap_acceptance_usergiven
C#
bool Is_gap_acceptance_usergiven {get; set;}
Managed Extensions for C++
__property bool get_Is_gap_acceptance_usergiven();
__property void set_Is_gap_acceptance_usergiven(
   bool value
);
C++/CLI
property bool Is_gap_acceptance_usergiven {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_TWSC_adj_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Is_TWSC_adj_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_TWSC_adj_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Boolean

instance.Is_TWSC_adj_applied = value

value = instance.Is_TWSC_adj_applied
C#
bool Is_TWSC_adj_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_TWSC_adj_applied();
__property void set_Is_TWSC_adj_applied(
   bool value
);
C++/CLI
property bool Is_TWSC_adj_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsPossible Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : IsPossible Property

Glossary Item Box

Flag indicating whether this OD movement is Geometry Possible, i.e. the Origin Leg has Approach Lanes and the Destination Leg has Exit Lanes.

Syntax

Visual Basic (Declaration)
ReadOnly Property IsPossible As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Boolean

value = instance.IsPossible
C#
bool IsPossible {get;}
Managed Extensions for C++
__property bool get_IsPossible();
C++/CLI
property bool IsPossible {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Minimum_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Minimum_departures = value

value = instance.Minimum_departures
C#
float Minimum_departures {get; set;}
Managed Extensions for C++
__property float get_Minimum_departures();
__property void set_Minimum_departures(
   float value
);
C++/CLI
property float Minimum_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementVehicleODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : MovementVehicleODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementVehicleODMCs As ISIAPIMovement_vehicle_od_mcs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As ISIAPIMovement_vehicle_od_mcs

value = instance.MovementVehicleODMCs
C#
ISIAPIMovement_vehicle_od_mcs MovementVehicleODMCs {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od_mcs* get_MovementVehicleODMCs();
C++/CLI
property ISIAPIMovement_vehicle_od_mcs^ MovementVehicleODMCs {
   ISIAPIMovement_vehicle_od_mcs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ODMovDesignation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : ODMovDesignation Property

Glossary Item Box

OD Movement Designation

Syntax

Visual Basic (Declaration)
ReadOnly Property ODMovDesignation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

value = instance.ODMovDesignation
C#
int ODMovDesignation {get;}
Managed Extensions for C++
__property int get_ODMovDesignation();
C++/CLI
property int ODMovDesignation {
   int get();
}

Property Value

Type: System.Int32;

0 = U,
1 = L3,
2 = L2,
3 = L1,
4 = T1,
5 = R1,
6 = R2,
7 = R3.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_effect_option Property

Glossary Item Box

Opposing Pedestrian Effect Option

Syntax

Visual Basic (Declaration)
Property Opposing_ped_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_option = value

value = instance.Opposing_ped_effect_option
C#
int Opposing_ped_effect_option {get; set;}
Managed Extensions for C++
__property int get_Opposing_ped_effect_option();
__property void set_Opposing_ped_effect_option(
   int value
);
C++/CLI
property int Opposing_ped_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Program (Flow).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_option_signals Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_effect_option_signals Property

Glossary Item Box

Opposing Pedestrian Effect Option (Signalised)

Syntax

Visual Basic (Declaration)
Property Opposing_ped_effect_option_signals As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_option_signals = value

value = instance.Opposing_ped_effect_option_signals
C#
int Opposing_ped_effect_option_signals {get; set;}
Managed Extensions for C++
__property int get_Opposing_ped_effect_option_signals();
__property void set_Opposing_ped_effect_option_signals(
   int value
);
C++/CLI
property int Opposing_ped_effect_option_signals {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
4 = Start Loss (Program),
5 = Saturation Flow Adjustment,
6 = Start Loss (Input).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_effect_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_effect_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_ped_effect_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_effect_start_loss = value

value = instance.Opposing_ped_effect_start_loss
C#
int Opposing_ped_effect_start_loss {get; set;}
Managed Extensions for C++
__property int get_Opposing_ped_effect_start_loss();
__property void set_Opposing_ped_effect_start_loss(
   int value
);
C++/CLI
property int Opposing_ped_effect_start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_critical_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_sliplane_critical_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_ped_sliplane_critical_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_critical_gap = value

value = instance.Opposing_ped_sliplane_critical_gap
C#
float Opposing_ped_sliplane_critical_gap {get; set;}
Managed Extensions for C++
__property float get_Opposing_ped_sliplane_critical_gap();
__property void set_Opposing_ped_sliplane_critical_gap(
   float value
);
C++/CLI
property float Opposing_ped_sliplane_critical_gap {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_followup_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_sliplane_followup_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_ped_sliplane_followup_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_followup_headway = value

value = instance.Opposing_ped_sliplane_followup_headway
C#
float Opposing_ped_sliplane_followup_headway {get; set;}
Managed Extensions for C++
__property float get_Opposing_ped_sliplane_followup_headway();
__property void set_Opposing_ped_sliplane_followup_headway(
   float value
);
C++/CLI
property float Opposing_ped_sliplane_followup_headway {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_gap_acceptance_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_sliplane_gap_acceptance_option Property

Glossary Item Box

Gap Acceptance Option of the Opposing Pedestrian on Slip / Bypass Lane(s)

Syntax

Visual Basic (Declaration)
Property Opposing_ped_sliplane_gap_acceptance_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

instance.Opposing_ped_sliplane_gap_acceptance_option = value

value = instance.Opposing_ped_sliplane_gap_acceptance_option
C#
int Opposing_ped_sliplane_gap_acceptance_option {get; set;}
Managed Extensions for C++
__property int get_Opposing_ped_sliplane_gap_acceptance_option();
__property void set_Opposing_ped_sliplane_gap_acceptance_option(
   int value
);
C++/CLI
property int Opposing_ped_sliplane_gap_acceptance_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Program,
2 = User Input.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_sliplane_minimum_departures Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposing_ped_sliplane_minimum_departures Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_ped_sliplane_minimum_departures As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Opposing_ped_sliplane_minimum_departures = value

value = instance.Opposing_ped_sliplane_minimum_departures
C#
float Opposing_ped_sliplane_minimum_departures {get; set;}
Managed Extensions for C++
__property float get_Opposing_ped_sliplane_minimum_departures();
__property void set_Opposing_ped_sliplane_minimum_departures(
   float value
);
C++/CLI
property float Opposing_ped_sliplane_minimum_departures {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_peds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposingmovement_peds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_peds As ISIAPIOpposingmovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As ISIAPIOpposingmovement_peds

value = instance.Opposingmovement_peds
C#
ISIAPIOpposingmovement_peds Opposingmovement_peds {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_peds* get_Opposingmovement_peds();
C++/CLI
property ISIAPIOpposingmovement_peds^ Opposingmovement_peds {
   ISIAPIOpposingmovement_peds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicles Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Opposingmovement_vehicles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_vehicles As ISIAPIOpposingmovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As ISIAPIOpposingmovement_vehicles

value = instance.Opposingmovement_vehicles
C#
ISIAPIOpposingmovement_vehicles Opposingmovement_vehicles {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_vehicles* get_Opposingmovement_vehicles();
C++/CLI
property ISIAPIOpposingmovement_vehicles^ Opposingmovement_vehicles {
   ISIAPIOpposingmovement_vehicles^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_opposed_by_nearest Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Percent_opposed_by_nearest Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Percent_opposed_by_nearest As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Single

instance.Percent_opposed_by_nearest = value

value = instance.Percent_opposed_by_nearest
C#
float Percent_opposed_by_nearest {get; set;}
Managed Extensions for C++
__property float get_Percent_opposed_by_nearest();
__property void set_Percent_opposed_by_nearest(
   float value
);
C++/CLI
property float Percent_opposed_by_nearest {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turndesignation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od Interface : Turndesignation Property

Glossary Item Box

Movement turn designation

Syntax

Visual Basic (Declaration)
Property Turndesignation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od
Dim value As Integer

instance.Turndesignation = value

value = instance.Turndesignation
C#
int Turndesignation {get; set;}
Managed Extensions for C++
__property int get_Turndesignation();
__property void set_Turndesignation(
   int value
);
C++/CLI
property int Turndesignation {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Left,
2 = Through,
3 = Right.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od Interface
ISIAPIMovement_vehicle_od Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mc Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mc Interface

Glossary Item Box

SIDRA INTERSECTION Vehicle OD Movement (per Movement Class) wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_vehicle_od_mc
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
C#
public interface ISIAPIMovement_vehicle_od_mc
Managed Extensions for C++
public __gc __interface ISIAPIMovement_vehicle_od_mc
C++/CLI
public interface class ISIAPIMovement_vehicle_od_mc

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mc Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mc Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_vehicle_od_mc.

Public Properties

 | Name | Description
Property | Approach_speed | Approach Cruise Speed
Property | Arrival_percentage |
Property | Arrival_type | Arrival Type
Property | Coordination_type | Signal Coordination
Property | Early_cutoff |
Property | End_gain |
Property | Exists | Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.
Property | Exit_distance | User given Exit distance (Downstream Distance). This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Exit_distance_user | Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.
Property | Exit_speed | Exit Cruise Speed
Property | Flow_scale | Flow Scale (Constant) (%)
Property | Gap_acceptance_factor |
Property | Growth_rate | Growth rate (%/year)
Property | Is_early_cutoff |
Property | Is_high_priority | High Priority for Green Splits
Property | Is_late_release |
Property | Late_release |
Property | Maximum_green_time |
Property | Maximum_green_time_user |
Property | MC_class | Movement Class Number
Property | Minimum_green_time |
Property | Minimum_green_time_user |
Property | Movement_vehicle_od |
Property | Negotiation_distance | User given Negotiation distance. This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_distance_user | Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.
Property | Negotiation_radius | User given Negotiation radius. This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_radius_option | User given Negotiation Radius option.
Property | Negotiation_speed | User given Negotiation speed. This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_speed_user | Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.
Property | Non_actuated |
Property | Occupancy | Vehicle Occupancy (persons/veh)
Property | Opposing_veh_factor |
Property | Peak_flow_factor | Peak Flow Factor (%)
Property | Phase_actuation_option |
Property | Phase_actuation_percent |
Property | Practical_degree_of_saturation |
Property | Practical_degree_of_saturation_user |
Property | Queue_space |
Property | Start_loss |
Property | Stopline_travel_time |
Property | Stopline_travel_time_user |
Property | Turn_on_red |
Property | Turn_radius |
Property | Turn_veh_effect_option | Turning Vehicle Effect
Property | Turning_veh_factor |
Property | Vehicle_length |
Property | Volume | Volume (veh)
Top

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mc Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mc Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_od_mc members.

Public Properties

 | Name | Description
Property | Approach_speed | Approach Cruise Speed
Property | Arrival_percentage |
Property | Arrival_type | Arrival Type
Property | Coordination_type | Signal Coordination
Property | Early_cutoff |
Property | End_gain |
Property | Exists | Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.
Property | Exit_distance | User given Exit distance (Downstream Distance). This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Exit_distance_user | Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.
Property | Exit_speed | Exit Cruise Speed
Property | Flow_scale | Flow Scale (Constant) (%)
Property | Gap_acceptance_factor |
Property | Growth_rate | Growth rate (%/year)
Property | Is_early_cutoff |
Property | Is_high_priority | High Priority for Green Splits
Property | Is_late_release |
Property | Late_release |
Property | Maximum_green_time |
Property | Maximum_green_time_user |
Property | MC_class | Movement Class Number
Property | Minimum_green_time |
Property | Minimum_green_time_user |
Property | Movement_vehicle_od |
Property | Negotiation_distance | User given Negotiation distance. This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_distance_user | Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.
Property | Negotiation_radius | User given Negotiation radius. This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_radius_option | User given Negotiation Radius option.
Property | Negotiation_speed | User given Negotiation speed. This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.
Property | Negotiation_speed_user | Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.
Property | Non_actuated |
Property | Occupancy | Vehicle Occupancy (persons/veh)
Property | Opposing_veh_factor |
Property | Peak_flow_factor | Peak Flow Factor (%)
Property | Phase_actuation_option |
Property | Phase_actuation_percent |
Property | Practical_degree_of_saturation |
Property | Practical_degree_of_saturation_user |
Property | Queue_space |
Property | Start_loss |
Property | Stopline_travel_time |
Property | Stopline_travel_time_user |
Property | Turn_on_red |
Property | Turn_radius |
Property | Turn_veh_effect_option | Turning Vehicle Effect
Property | Turning_veh_factor |
Property | Vehicle_length |
Property | Volume | Volume (veh)
Top

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Approach_speed Property

Glossary Item Box

Approach Cruise Speed

Syntax

Visual Basic (Declaration)
Property Approach_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Approach_speed = value

value = instance.Approach_speed
C#
float Approach_speed {get; set;}
Managed Extensions for C++
__property float get_Approach_speed();
__property void set_Approach_speed(
   float value
);
C++/CLI
property float Approach_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_percentage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Arrival_percentage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Arrival_percentage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Arrival_percentage = value

value = instance.Arrival_percentage
C#
float Arrival_percentage {get; set;}
Managed Extensions for C++
__property float get_Arrival_percentage();
__property void set_Arrival_percentage(
   float value
);
C++/CLI
property float Arrival_percentage {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Arrival_type Property

Glossary Item Box

Arrival Type

Syntax

Visual Basic (Declaration)
Property Arrival_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Arrival_type = value

value = instance.Arrival_type
C#
int Arrival_type {get; set;}
Managed Extensions for C++
__property int get_Arrival_type();
__property void set_Arrival_type(
   int value
);
C++/CLI
property int Arrival_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Very Poor,
2 = Non-favourable,
3 = Isolated (not coord),
4 = Favourable,
5 = Highly Favourable,
6 = Exceptional.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coordination_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Coordination_type Property

Glossary Item Box

Signal Coordination

Syntax

Visual Basic (Declaration)
Property Coordination_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Coordination_type = value

value = instance.Coordination_type
C#
int Coordination_type {get; set;}
Managed Extensions for C++
__property int get_Coordination_type();
__property void set_Coordination_type(
   int value
);
C++/CLI
property int Coordination_type {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Arrival Type,
2 = Arrivals % During Green,
3 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Early_cutoff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Early_cutoff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Early_cutoff As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Early_cutoff = value

value = instance.Early_cutoff
C#
float Early_cutoff {get; set;}
Managed Extensions for C++
__property float get_Early_cutoff();
__property void set_Early_cutoff(
   float value
);
C++/CLI
property float Early_cutoff {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : End_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property End_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.End_gain = value

value = instance.End_gain
C#
int End_gain {get; set;}
Managed Extensions for C++
__property int get_End_gain();
__property void set_End_gain(
   int value
);
C++/CLI
property int End_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Exists Property

Glossary Item Box

Flag indicating whether this OD MC movement "exists" or is running (not banned) in the current site.

Syntax

Visual Basic (Declaration)
ReadOnly Property Exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

value = instance.Exists
C#
bool Exists {get;}
Managed Extensions for C++
__property bool get_Exists();
C++/CLI
property bool Exists {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Exit_distance Property

Glossary Item Box

User given Exit distance (Downstream Distance).

This value is used in processing if Exit_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Property Exit_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Exit_distance = value

value = instance.Exit_distance
C#
float Exit_distance {get; set;}
Managed Extensions for C++
__property float get_Exit_distance();
__property void set_Exit_distance(
   float value
);
C++/CLI
property float Exit_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Exit_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Exit_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Property Exit_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Exit_distance_user = value

value = instance.Exit_distance_user
C#
bool Exit_distance_user {get; set;}
Managed Extensions for C++
__property bool get_Exit_distance_user();
__property void set_Exit_distance_user(
   bool value
);
C++/CLI
property bool Exit_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Exit_speed Property

Glossary Item Box

Exit Cruise Speed

Syntax

Visual Basic (Declaration)
Property Exit_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Exit_speed = value

value = instance.Exit_speed
C#
float Exit_speed {get; set;}
Managed Extensions for C++
__property float get_Exit_speed();
__property void set_Exit_speed(
   float value
);
C++/CLI
property float Exit_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Flow_scale Property

Glossary Item Box

Flow Scale (Constant) (%)

Syntax

Visual Basic (Declaration)
Property Flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Flow_scale = value

value = instance.Flow_scale
C#
float Flow_scale {get; set;}
Managed Extensions for C++
__property float get_Flow_scale();
__property void set_Flow_scale(
   float value
);
C++/CLI
property float Flow_scale {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_acceptance_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Gap_acceptance_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Gap_acceptance_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Gap_acceptance_factor = value

value = instance.Gap_acceptance_factor
C#
float Gap_acceptance_factor {get; set;}
Managed Extensions for C++
__property float get_Gap_acceptance_factor();
__property void set_Gap_acceptance_factor(
   float value
);
C++/CLI
property float Gap_acceptance_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Growth_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Growth_rate Property

Glossary Item Box

Growth rate (%/year)

Syntax

Visual Basic (Declaration)
Property Growth_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Growth_rate = value

value = instance.Growth_rate
C#
float Growth_rate {get; set;}
Managed Extensions for C++
__property float get_Growth_rate();
__property void set_Growth_rate(
   float value
);
C++/CLI
property float Growth_rate {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_early_cutoff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Is_early_cutoff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_early_cutoff As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_early_cutoff = value

value = instance.Is_early_cutoff
C#
bool Is_early_cutoff {get; set;}
Managed Extensions for C++
__property bool get_Is_early_cutoff();
__property void set_Is_early_cutoff(
   bool value
);
C++/CLI
property bool Is_early_cutoff {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_high_priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Is_high_priority Property

Glossary Item Box

High Priority for Green Splits

Syntax

Visual Basic (Declaration)
Property Is_high_priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_high_priority = value

value = instance.Is_high_priority
C#
bool Is_high_priority {get; set;}
Managed Extensions for C++
__property bool get_Is_high_priority();
__property void set_Is_high_priority(
   bool value
);
C++/CLI
property bool Is_high_priority {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_late_release Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Is_late_release Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_late_release As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Is_late_release = value

value = instance.Is_late_release
C#
bool Is_late_release {get; set;}
Managed Extensions for C++
__property bool get_Is_late_release();
__property void set_Is_late_release(
   bool value
);
C++/CLI
property bool Is_late_release {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Late_release Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Late_release Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Late_release As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Late_release = value

value = instance.Late_release
C#
float Late_release {get; set;}
Managed Extensions for C++
__property float get_Late_release();
__property void set_Late_release(
   float value
);
C++/CLI
property float Late_release {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Maximum_green_time = value

value = instance.Maximum_green_time
C#
int Maximum_green_time {get; set;}
Managed Extensions for C++
__property int get_Maximum_green_time();
__property void set_Maximum_green_time(
   int value
);
C++/CLI
property int Maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Maximum_green_time_user = value

value = instance.Maximum_green_time_user
C#
bool Maximum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Maximum_green_time_user();
__property void set_Maximum_green_time_user(
   bool value
);
C++/CLI
property bool Maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Minimum_green_time = value

value = instance.Minimum_green_time
C#
int Minimum_green_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_green_time();
__property void set_Minimum_green_time(
   int value
);
C++/CLI
property int Minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Minimum_green_time_user = value

value = instance.Minimum_green_time_user
C#
bool Minimum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Minimum_green_time_user();
__property void set_Minimum_green_time_user(
   bool value
);
C++/CLI
property bool Minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_distance Property

Glossary Item Box

User given Negotiation distance.

This value is used in processing if Negotiation_distance_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Property Negotiation_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_distance = value

value = instance.Negotiation_distance
C#
float Negotiation_distance {get; set;}
Managed Extensions for C++
__property float get_Negotiation_distance();
__property void set_Negotiation_distance(
   float value
);
C++/CLI
property float Negotiation_distance {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_distance_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Negotiation_distance or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Property Negotiation_distance_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Negotiation_distance_user = value

value = instance.Negotiation_distance_user
C#
bool Negotiation_distance_user {get; set;}
Managed Extensions for C++
__property bool get_Negotiation_distance_user();
__property void set_Negotiation_distance_user(
   bool value
);
C++/CLI
property bool Negotiation_distance_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_radius Property

Glossary Item Box

User given Negotiation radius.
This value is used in processing if Negotiation_radius_option is set to Radius, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Property Negotiation_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_radius = value

value = instance.Negotiation_radius
C#
float Negotiation_radius {get; set;}
Managed Extensions for C++
__property float get_Negotiation_radius();
__property void set_Negotiation_radius(
   float value
);
C++/CLI
property float Negotiation_radius {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_radius_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_radius_option Property

Glossary Item Box

User given Negotiation Radius option.

Syntax

Visual Basic (Declaration)
Property Negotiation_radius_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Negotiation_radius_option = value

value = instance.Negotiation_radius_option
C#
int Negotiation_radius_option {get; set;}
Managed Extensions for C++
__property int get_Negotiation_radius_option();
__property void set_Negotiation_radius_option(
   int value
);
C++/CLI
property int Negotiation_radius_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Program,
2 = Radius,
3 = Straight.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_speed Property

Glossary Item Box

User given Negotiation speed.

This value is used in processing if Negotiation_speed_user is set to True, otherwise SIDRA INTERSECTION calculates the value automatically.

Syntax

Visual Basic (Declaration)
Property Negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Negotiation_speed = value

value = instance.Negotiation_speed
C#
float Negotiation_speed {get; set;}
Managed Extensions for C++
__property float get_Negotiation_speed();
__property void set_Negotiation_speed(
   float value
);
C++/CLI
property float Negotiation_speed {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_speed_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Negotiation_speed_user Property

Glossary Item Box

Flag indicating whether to use the value specified by Negotiation_speed or an automatically calculated value in processing.

Syntax

Visual Basic (Declaration)
Property Negotiation_speed_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Negotiation_speed_user = value

value = instance.Negotiation_speed_user
C#
bool Negotiation_speed_user {get; set;}
Managed Extensions for C++
__property bool get_Negotiation_speed_user();
__property void set_Negotiation_speed_user(
   bool value
);
C++/CLI
property bool Negotiation_speed_user {
   bool get();
   void set (    bool value);
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Non_actuated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Non_actuated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Non_actuated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Non_actuated = value

value = instance.Non_actuated
C#
bool Non_actuated {get; set;}
Managed Extensions for C++
__property bool get_Non_actuated();
__property void set_Non_actuated(
   bool value
);
C++/CLI
property bool Non_actuated {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Occupancy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Occupancy Property

Glossary Item Box

Vehicle Occupancy (persons/veh)

Syntax

Visual Basic (Declaration)
Property Occupancy As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Occupancy = value

value = instance.Occupancy
C#
float Occupancy {get; set;}
Managed Extensions for C++
__property float get_Occupancy();
__property void set_Occupancy(
   float value
);
C++/CLI
property float Occupancy {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_veh_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Opposing_veh_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing_veh_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Opposing_veh_factor = value

value = instance.Opposing_veh_factor
C#
float Opposing_veh_factor {get; set;}
Managed Extensions for C++
__property float get_Opposing_veh_factor();
__property void set_Opposing_veh_factor(
   float value
);
C++/CLI
property float Opposing_veh_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peak_flow_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Peak_flow_factor Property

Glossary Item Box

Peak Flow Factor (%)

Syntax

Visual Basic (Declaration)
Property Peak_flow_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Peak_flow_factor = value

value = instance.Peak_flow_factor
C#
float Peak_flow_factor {get; set;}
Managed Extensions for C++
__property float get_Peak_flow_factor();
__property void set_Peak_flow_factor(
   float value
);
C++/CLI
property float Peak_flow_factor {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_actuation_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Phase_actuation_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_actuation_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Phase_actuation_option = value

value = instance.Phase_actuation_option
C#
int Phase_actuation_option {get; set;}
Managed Extensions for C++
__property int get_Phase_actuation_option();
__property void set_Phase_actuation_option(
   int value
);
C++/CLI
property int Phase_actuation_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_actuation_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Phase_actuation_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_actuation_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Phase_actuation_percent = value

value = instance.Phase_actuation_percent
C#
float Phase_actuation_percent {get; set;}
Managed Extensions for C++
__property float get_Phase_actuation_percent();
__property void set_Phase_actuation_percent(
   float value
);
C++/CLI
property float Phase_actuation_percent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Practical_degree_of_saturation = value

value = instance.Practical_degree_of_saturation
C#
float Practical_degree_of_saturation {get; set;}
Managed Extensions for C++
__property float get_Practical_degree_of_saturation();
__property void set_Practical_degree_of_saturation(
   float value
);
C++/CLI
property float Practical_degree_of_saturation {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Practical_degree_of_saturation_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_degree_of_saturation_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Practical_degree_of_saturation_user = value

value = instance.Practical_degree_of_saturation_user
C#
bool Practical_degree_of_saturation_user {get; set;}
Managed Extensions for C++
__property bool get_Practical_degree_of_saturation_user();
__property void set_Practical_degree_of_saturation_user(
   bool value
);
C++/CLI
property bool Practical_degree_of_saturation_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Queue_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Queue_space = value

value = instance.Queue_space
C#
float Queue_space {get; set;}
Managed Extensions for C++
__property float get_Queue_space();
__property void set_Queue_space(
   float value
);
C++/CLI
property float Queue_space {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Start_loss = value

value = instance.Start_loss
C#
int Start_loss {get; set;}
Managed Extensions for C++
__property int get_Start_loss();
__property void set_Start_loss(
   int value
);
C++/CLI
property int Start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stopline_travel_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Stopline_travel_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Stopline_travel_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Stopline_travel_time = value

value = instance.Stopline_travel_time
C#
float Stopline_travel_time {get; set;}
Managed Extensions for C++
__property float get_Stopline_travel_time();
__property void set_Stopline_travel_time(
   float value
);
C++/CLI
property float Stopline_travel_time {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stopline_travel_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Stopline_travel_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Stopline_travel_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Stopline_travel_time_user = value

value = instance.Stopline_travel_time_user
C#
bool Stopline_travel_time_user {get; set;}
Managed Extensions for C++
__property bool get_Stopline_travel_time_user();
__property void set_Stopline_travel_time_user(
   bool value
);
C++/CLI
property bool Stopline_travel_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_on_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Turn_on_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Turn_on_red As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Boolean

instance.Turn_on_red = value

value = instance.Turn_on_red
C#
bool Turn_on_red {get; set;}
Managed Extensions for C++
__property bool get_Turn_on_red();
__property void set_Turn_on_red(
   bool value
);
C++/CLI
property bool Turn_on_red {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_radius Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Turn_radius Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Turn_radius As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Turn_radius = value

value = instance.Turn_radius
C#
float Turn_radius {get; set;}
Managed Extensions for C++
__property float get_Turn_radius();
__property void set_Turn_radius(
   float value
);
C++/CLI
property float Turn_radius {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turn_veh_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Turn_veh_effect_option Property

Glossary Item Box

Turning Vehicle Effect

Syntax

Visual Basic (Declaration)
Property Turn_veh_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Integer

instance.Turn_veh_effect_option = value

value = instance.Turn_veh_effect_option
C#
int Turn_veh_effect_option {get; set;}
Managed Extensions for C++
__property int get_Turn_veh_effect_option();
__property void set_Turn_veh_effect_option(
   int value
);
C++/CLI
property int Turn_veh_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Turning Vehicle Factor,
2 = Radius.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Turning_veh_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Turning_veh_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Turning_veh_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Turning_veh_factor = value

value = instance.Turning_veh_factor
C#
float Turning_veh_factor {get; set;}
Managed Extensions for C++
__property float get_Turning_veh_factor();
__property void set_Turning_veh_factor(
   float value
);
C++/CLI
property float Turning_veh_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Vehicle_length Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Vehicle_length Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Vehicle_length As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Vehicle_length = value

value = instance.Vehicle_length
C#
float Vehicle_length {get; set;}
Managed Extensions for C++
__property float get_Vehicle_length();
__property void set_Vehicle_length(
   float value
);
C++/CLI
property float Vehicle_length {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Volume Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mc Interface : Volume Property

Glossary Item Box

Volume (veh)

Syntax

Visual Basic (Declaration)
Property Volume As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mc
Dim value As Single

instance.Volume = value

value = instance.Volume
C#
float Volume {get; set;}
Managed Extensions for C++
__property float get_Volume();
__property void set_Volume(
   float value
);
C++/CLI
property float Volume {
   float get();
   void set (    float value);
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mc Interface
ISIAPIMovement_vehicle_od_mc Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mcs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mcs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_vehicle_od_mcs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mcs
C#
public interface ISIAPIMovement_vehicle_od_mcs
Managed Extensions for C++
public __gc __interface ISIAPIMovement_vehicle_od_mcs
C++/CLI
public interface class ISIAPIMovement_vehicle_od_mcs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mcs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mcs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_vehicle_od_mcs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mcs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mcs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_od_mcs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mcs Interface : MovementClassExists Method

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mcs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
ISIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_od_mcs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_od_mcs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_od_mcs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mcs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mcs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
ISIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_od_mcs Interface : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIMovement_vehicle_od_mc
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_od_mcs
Dim mcClass As Integer
Dim value As ISIAPIMovement_vehicle_od_mc

value = instance.Item(mcClass)
C#
ISIAPIMovement_vehicle_od_mc this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od_mc* get_Item   int mcClass
;
C++/CLI
property ISIAPIMovement_vehicle_od_mc^ default [int] {
   ISIAPIMovement_vehicle_od_mc^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_od_mcs Interface
ISIAPIMovement_vehicle_od_mcs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_ods Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_ods Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovement_vehicle_ods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_ods
C#
public interface ISIAPIMovement_vehicle_ods
Managed Extensions for C++
public __gc __interface ISIAPIMovement_vehicle_ods
C++/CLI
public interface class ISIAPIMovement_vehicle_ods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_ods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_ods Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_ods Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovement_vehicle_ods.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Vehicle Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_ods Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_ods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_ods members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Vehicle Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_ods Interface : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Vehicle Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_ods
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
bool MovementExists(
   int origin,
   int destination
)
C++/CLI
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
ISIAPIMovement_vehicle_ods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovement_vehicle_ods Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovement_vehicle_ods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovement_vehicle_ods members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement.
Top

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_ods Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_ods
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
ISIAPIMovement_vehicle_ods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovement_vehicle_ods Interface : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Vehicle Movement.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovement_vehicle_ods
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIMovement_vehicle_od

value = instance.Item(origin, destination)
C#
ISIAPIMovement_vehicle_od this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od* get_Item   int origin,
   int destination
;
C++/CLI
property ISIAPIMovement_vehicle_od^ default [int,int] {
   ISIAPIMovement_vehicle_od^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Property Value

Return a Vehicle Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovement_vehicle_ods Interface
ISIAPIMovement_vehicle_ods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClass Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClass Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovementClass
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
C#
public interface ISIAPIMovementClass
Managed Extensions for C++
public __gc __interface ISIAPIMovementClass
C++/CLI
public interface class ISIAPIMovementClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClass Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClass Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovementClass.

Public Properties

 | Name | Description
Property | Average_income |
Property | Base_class | The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Co2_to_fuel_ratio | CO2 to Fuel Consumption Rate
Property | Cost_method | Cost Method
Property | Display_id | Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Fuel_pump_price | Pump Price of Fuel
Property | Is_cost_included |
Property | Is_included | Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.
Property | Is_userclass |
Property | Mass |
Property | Max_power |
Property | MC_class | Movement Class Number
Property | Mode_designation | Model Designation
Property | MovementClassFuelEmissions |
Property | Name | Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Pc_equivalent | Passenger Car Equivalent
Property | Resource_cost_factor | Fuel Resource Cost Factor
Property | Run_cost_fuel_ratio | Ratio of Running Cost to Fuel Cost
Property | Site |
Property | Time_value_factor |
Top

See Also

Reference

ISIAPIMovementClass Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClass Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClass Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClass members.

Public Properties

 | Name | Description
Property | Average_income |
Property | Base_class | The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Co2_to_fuel_ratio | CO2 to Fuel Consumption Rate
Property | Cost_method | Cost Method
Property | Display_id | Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Fuel_pump_price | Pump Price of Fuel
Property | Is_cost_included |
Property | Is_included | Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.
Property | Is_userclass |
Property | Mass |
Property | Max_power |
Property | MC_class | Movement Class Number
Property | Mode_designation | Model Designation
Property | MovementClassFuelEmissions |
Property | Name | Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.
Property | Pc_equivalent | Passenger Car Equivalent
Property | Resource_cost_factor | Fuel Resource Cost Factor
Property | Run_cost_fuel_ratio | Ratio of Running Cost to Fuel Cost
Property | Site |
Property | Time_value_factor |
Top

See Also

Reference

ISIAPIMovementClass Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_income Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Average_income Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Average_income As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Average_income = value

value = instance.Average_income
C#
float Average_income {get; set;}
Managed Extensions for C++
__property float get_Average_income();
__property void set_Average_income(
   float value
);
C++/CLI
property float Average_income {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Base_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Base_class Property

Glossary Item Box

The Standard Movement Class that this Movement Class is based on. This Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Property Base_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Integer

instance.Base_class = value

value = instance.Base_class
C#
int Base_class {get; set;}
Managed Extensions for C++
__property int get_Base_class();
__property void set_Base_class(
   int value
);
C++/CLI
property int Base_class {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Co2_to_fuel_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Co2_to_fuel_ratio Property

Glossary Item Box

CO2 to Fuel Consumption Rate

Syntax

Visual Basic (Declaration)
Property Co2_to_fuel_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Co2_to_fuel_ratio = value

value = instance.Co2_to_fuel_ratio
C#
float Co2_to_fuel_ratio {get; set;}
Managed Extensions for C++
__property float get_Co2_to_fuel_ratio();
__property void set_Co2_to_fuel_ratio(
   float value
);
C++/CLI
property float Co2_to_fuel_ratio {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cost_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Cost_method Property

Glossary Item Box

Cost Method

Syntax

Visual Basic (Declaration)
Property Cost_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Integer

instance.Cost_method = value

value = instance.Cost_method
C#
int Cost_method {get; set;}
Managed Extensions for C++
__property int get_Cost_method();
__property void set_Cost_method(
   int value
);
C++/CLI
property int Cost_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Operating Cost,
2 = User Cost.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Display_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Display_id Property

Glossary Item Box

Movement Class Display ID, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Property Display_id As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As String

instance.Display_id = value

value = instance.Display_id
C#
string Display_id {get; set;}
Managed Extensions for C++
__property string* get_Display_id();
__property void set_Display_id(
   string* value
);
C++/CLI
property String^ Display_id {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_pump_price Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Fuel_pump_price Property

Glossary Item Box

Pump Price of Fuel

Syntax

Visual Basic (Declaration)
Property Fuel_pump_price As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Fuel_pump_price = value

value = instance.Fuel_pump_price
C#
float Fuel_pump_price {get; set;}
Managed Extensions for C++
__property float get_Fuel_pump_price();
__property void set_Fuel_pump_price(
   float value
);
C++/CLI
property float Fuel_pump_price {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_cost_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Is_cost_included Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Is_cost_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Boolean

value = instance.Is_cost_included
C#
bool Is_cost_included {get;}
Managed Extensions for C++
__property bool get_Is_cost_included();
C++/CLI
property bool Is_cost_included {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_included Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Is_included Property

Glossary Item Box

Flag indicating whether this Movement Class is included in the Site. This Property can be changed if this Movement Class is not Light Vehicles or Heavy Vehicles. These two Movement Classes must be included into any Site.

Syntax

Visual Basic (Declaration)
Property Is_included As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Boolean

instance.Is_included = value

value = instance.Is_included
C#
bool Is_included {get; set;}
Managed Extensions for C++
__property bool get_Is_included();
__property void set_Is_included(
   bool value
);
C++/CLI
property bool Is_included {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_userclass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Is_userclass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Is_userclass As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Boolean

value = instance.Is_userclass
C#
bool Is_userclass {get;}
Managed Extensions for C++
__property bool get_Is_userclass();
C++/CLI
property bool Is_userclass {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Mass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Mass As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Mass = value

value = instance.Mass
C#
float Mass {get; set;}
Managed Extensions for C++
__property float get_Mass();
__property void set_Mass(
   float value
);
C++/CLI
property float Mass {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_power Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Max_power Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Max_power As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Max_power = value

value = instance.Max_power
C#
float Max_power {get; set;}
Managed Extensions for C++
__property float get_Max_power();
__property void set_Max_power(
   float value
);
C++/CLI
property float Max_power {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : MC_class Property

Glossary Item Box

Movement Class Number

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2,
9 = User Class 3,
10 = User Class 4,
11 = User Class 5,
12 = User Class 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mode_designation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Mode_designation Property

Glossary Item Box

Model Designation

Syntax

Visual Basic (Declaration)
ReadOnly Property Mode_designation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Integer

value = instance.Mode_designation
C#
int Mode_designation {get;}
Managed Extensions for C++
__property int get_Mode_designation();
C++/CLI
property int Mode_designation {
   int get();
}

Property Value

Type: System.Int32;

1 = Light Vehicle,
2 = Heavy Vehicle.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassFuelEmissions Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : MovementClassFuelEmissions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementClassFuelEmissions As ISIAPIMovementClassFuelEmissions
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As ISIAPIMovementClassFuelEmissions

value = instance.MovementClassFuelEmissions
C#
ISIAPIMovementClassFuelEmissions MovementClassFuelEmissions {get;}
Managed Extensions for C++
__property ISIAPIMovementClassFuelEmissions* get_MovementClassFuelEmissions();
C++/CLI
property ISIAPIMovementClassFuelEmissions^ MovementClassFuelEmissions {
   ISIAPIMovementClassFuelEmissions^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Name Property

Glossary Item Box

Movement Class Name, this Property can be changed only if this is a User Movement Class, i.e. Is_userclass == true.

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Pc_equivalent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Pc_equivalent Property

Glossary Item Box

Passenger Car Equivalent

Syntax

Visual Basic (Declaration)
Property Pc_equivalent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Pc_equivalent = value

value = instance.Pc_equivalent
C#
float Pc_equivalent {get; set;}
Managed Extensions for C++
__property float get_Pc_equivalent();
__property void set_Pc_equivalent(
   float value
);
C++/CLI
property float Pc_equivalent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Resource_cost_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Resource_cost_factor Property

Glossary Item Box

Fuel Resource Cost Factor

Syntax

Visual Basic (Declaration)
Property Resource_cost_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Resource_cost_factor = value

value = instance.Resource_cost_factor
C#
float Resource_cost_factor {get; set;}
Managed Extensions for C++
__property float get_Resource_cost_factor();
__property void set_Resource_cost_factor(
   float value
);
C++/CLI
property float Resource_cost_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Run_cost_fuel_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Run_cost_fuel_ratio Property

Glossary Item Box

Ratio of Running Cost to Fuel Cost

Syntax

Visual Basic (Declaration)
Property Run_cost_fuel_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Run_cost_fuel_ratio = value

value = instance.Run_cost_fuel_ratio
C#
float Run_cost_fuel_ratio {get; set;}
Managed Extensions for C++
__property float get_Run_cost_fuel_ratio();
__property void set_Run_cost_fuel_ratio(
   float value
);
C++/CLI
property float Run_cost_fuel_ratio {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Time_value_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClass Interface : Time_value_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Time_value_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClass
Dim value As Single

instance.Time_value_factor = value

value = instance.Time_value_factor
C#
float Time_value_factor {get; set;}
Managed Extensions for C++
__property float get_Time_value_factor();
__property void set_Time_value_factor(
   float value
);
C++/CLI
property float Time_value_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClass Interface
ISIAPIMovementClass Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClasses Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClasses Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovementClasses
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClasses
C#
public interface ISIAPIMovementClasses
Managed Extensions for C++
public __gc __interface ISIAPIMovementClasses
C++/CLI
public interface class ISIAPIMovementClasses

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClasses Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClasses Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClasses Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovementClasses.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Class Object. Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists | Get a value indicating whether a Movement Class data exists in the data structure.
Top

See Also

Reference

ISIAPIMovementClasses Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClasses Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClasses Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClasses members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists | Get a value indicating whether a Movement Class data exists in the data structure.
Top

See Also

Reference

ISIAPIMovementClasses Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClasses Interface : MovementClassExists Method

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a value indicating whether a Movement Class data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClasses
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Return Value

true if the data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClasses Interface
ISIAPIMovementClasses Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClasses Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClasses Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClasses members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Class Object. Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIMovementClasses Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClasses Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClasses
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClasses Interface
ISIAPIMovementClasses Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClasses Interface : Item Property

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a Movement Class Object.
Return a Movement Class Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIMovementClass
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClasses
Dim mcClass As Integer
Dim value As ISIAPIMovementClass

value = instance.Item(mcClass)
C#
ISIAPIMovementClass this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIMovementClass* get_Item   int mcClass
;
C++/CLI
property ISIAPIMovementClass^ default [int] {
   ISIAPIMovementClass^ get(int mcClass);
}

Parameters

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClasses Interface
ISIAPIMovementClasses Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmission Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmission Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovementClassFuelEmission
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
C#
public interface ISIAPIMovementClassFuelEmission
Managed Extensions for C++
public __gc __interface ISIAPIMovementClassFuelEmission
C++/CLI
public interface class ISIAPIMovementClassFuelEmission

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmission Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmission Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovementClassFuelEmission.

Public Properties

 | Name | Description
Property | A |
Property | B |
Property | Beta1 |
Property | Emission_class | Emission Class
Property | Idle |
Top

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmission Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmission Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClassFuelEmission members.

Public Properties

 | Name | Description
Property | A |
Property | B |
Property | Beta1 |
Property | Emission_class | Emission Class
Property | Idle |
Top

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
A Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmission Interface : A Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property A As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
Dim value As Single

instance.A = value

value = instance.A
C#
float A {get; set;}
Managed Extensions for C++
__property float get_A();
__property void set_A(
   float value
);
C++/CLI
property float A {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
ISIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
B Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmission Interface : B Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property B As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
Dim value As Single

instance.B = value

value = instance.B
C#
float B {get; set;}
Managed Extensions for C++
__property float get_B();
__property void set_B(
   float value
);
C++/CLI
property float B {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
ISIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Beta1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmission Interface : Beta1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Beta1 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
Dim value As Single

instance.Beta1 = value

value = instance.Beta1
C#
float Beta1 {get; set;}
Managed Extensions for C++
__property float get_Beta1();
__property void set_Beta1(
   float value
);
C++/CLI
property float Beta1 {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
ISIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Emission_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmission Interface : Emission_class Property

Glossary Item Box

Emission Class

Syntax

Visual Basic (Declaration)
ReadOnly Property Emission_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
Dim value As Integer

value = instance.Emission_class
C#
int Emission_class {get;}
Managed Extensions for C++
__property int get_Emission_class();
C++/CLI
property int Emission_class {
   int get();
}

Property Value

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
ISIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmission Interface : Idle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Idle As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmission
Dim value As Single

instance.Idle = value

value = instance.Idle
C#
float Idle {get; set;}
Managed Extensions for C++
__property float get_Idle();
__property void set_Idle(
   float value
);
C++/CLI
property float Idle {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmission Interface
ISIAPIMovementClassFuelEmission Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmissions Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmissions Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIMovementClassFuelEmissions
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmissions
C#
public interface ISIAPIMovementClassFuelEmissions
Managed Extensions for C++
public __gc __interface ISIAPIMovementClassFuelEmissions
C++/CLI
public interface class ISIAPIMovementClassFuelEmissions

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmissions Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmissions Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmissions Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIMovementClassFuelEmissions.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Class Fuel Emission Object. Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmissions Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmissions Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClassFuelEmissions members.

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmissions Interface : Exists Method

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Glossary Item Box

Get a value indicating whether a Movement Class Fuel Emission data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function Exists( _
   ByVal emissionClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmissions
Dim emissionClass As Integer
Dim value As Boolean

value = instance.Exists(emissionClass)
C#
bool Exists(
   int emissionClass
)
Managed Extensions for C++
bool Exists(
   int emissionClass
)
C++/CLI
bool Exists(
   int emissionClass
)

Parameters

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Return Value

true if the data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
ISIAPIMovementClassFuelEmissions Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIMovementClassFuelEmissions Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIMovementClassFuelEmissions Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIMovementClassFuelEmissions members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Class Fuel Emission Object. Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmissions Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmissions
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
ISIAPIMovementClassFuelEmissions Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIMovementClassFuelEmissions Interface : Item Property

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Glossary Item Box

Get a Movement Class Fuel Emission Object.
Return a Movement Class Fuel Emission Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal emissionClass As Integer _
) As ISIAPIMovementClassFuelEmission
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIMovementClassFuelEmissions
Dim emissionClass As Integer
Dim value As ISIAPIMovementClassFuelEmission

value = instance.Item(emissionClass)
C#
ISIAPIMovementClassFuelEmission this[
   int emissionClass
]; {get;}
Managed Extensions for C++
__property ISIAPIMovementClassFuelEmission* get_Item   int emissionClass
;
C++/CLI
property ISIAPIMovementClassFuelEmission^ default [int] {
   ISIAPIMovementClassFuelEmission^ get(int emissionClass);
}

Parameters

emissionClass

Type: System.Int32;

1 = Fuel,
2 = CO,
3 = HC,
4 = NOx.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIMovementClassFuelEmissions Interface
ISIAPIMovementClassFuelEmissions Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetwork Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetwork Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
C#
public interface ISIAPINetwork
Managed Extensions for C++
public __gc __interface ISIAPINetwork
C++/CLI
public interface class ISIAPINetwork

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetwork Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetwork Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetwork.

Public Properties

 | Name | Description
Property | Category | Network Category
Property | CostUnit |
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | Cycle_time_option | Cycle Time Option
Property | DemandSensitivity |
Property | Description |
Property | DesiredSpeed |
Property | DesiredSpeedMethod | Desired Speed Method
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | DriveOnLeft |
Property | Green_split_priority_option | Green Split Priority
Property | HoursPerYear |
Property | Is_timing_optimised_for_selected_result |
Property | IsIncludedInProjectSummary |
Property | IsPlatoonDispersionApplied |
Property | IsShortlaneQueueStorageRatioIncl | Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio
Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Property | LastErrorMessage |
Property | LOSMethod | Network Level of Service Method
Property | LOSTarget | Network Level of Service Target
Property | LowerLimitOfSpeedEfficiency |
Property | MaxIterations |
Property | ModelName |
Property | ModelSignature |
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | MultiRoutesSummaryOption | Network Output by Routes Option
Property | Name |
Property | Network_id | The database row unique ID of the Network.
Property | NetworkCCGs | Collection of Common Control Group (CCG) in the Network
Property | NetworkCycleTime |
Property | NetworkID | Network ID in the Network Data dialog and reports.
Property | NetworkLegConnections | Collection of Leg Connections between the Sites in the Network
Property | NetworkSites | Collection of Sites in the Network
Property | OffsetDefinition | Signal Offset Definition
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | OutputNetwork | Network Output Data for the summary of the Whole Network
Property | OutputNetworkByRoutes | Network Output Data for the statistics summary of the selected Routes
Property | Peakflowperiod |
Property | Percentile_queue |
Property | Percentile_queue_option |
Property | Performance_measure |
Property | Position | The Network Position in the Project's Networks collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | ProcessingError | Error nessage after a failed call to Process
Property | Project |
Property | Routes | Collection of Routes in the Network
Property | SignalOffsetOption | Signal Offset Option
Property | Site_los_method |
Property | SitePhaseTimesOption | Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.
Property | StoppingDxPercent |
Property | Title |
Property | Units | General unit system used for data within the Network
Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Method | AddNetworkCCG | Add a new Common Control Group (CCG) into the Network.
Method | AddNetworkLegConnection |
Method | AddNetworkSite | Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.
Method | AddRoute | Add a new Route into the Network.
Method | CloneRoute | Clone a Route.
Method | CreateLayoutPngData |
Method | CreateLayoutPngFile |
Method | MoveNetworkCCGTo | Move a Common Control Group (CCG) to a new position.
Method | MoveRouteTo | Move a Route to a new position.
Method | Process | Processes the Whole Network This method generates the OutputNetwork data.
Method | ProcessByRoutes | Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated. If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again. If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics. This method generates the OutputNetworkByRoutes data.
Method | RemoveNetworkCCG | Remove a Common Control Group (CCG) from the Network.
Method | RemoveNetworkLegConnection |
Method | RemoveNetworkSite | Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.
Method | RemoveRoute | Remove a Route from the Network.
Method | ResetRouteSignalOffsetPriority | Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPINetwork Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetwork Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetwork Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetwork members.

Public Methods

 | Name | Description
Method | AddNetworkCCG | Add a new Common Control Group (CCG) into the Network.
Method | AddNetworkLegConnection |
Method | AddNetworkSite | Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.
Method | AddRoute | Add a new Route into the Network.
Method | CloneRoute | Clone a Route.
Method | CreateLayoutPngData |
Method | CreateLayoutPngFile |
Method | MoveNetworkCCGTo | Move a Common Control Group (CCG) to a new position.
Method | MoveRouteTo | Move a Route to a new position.
Method | Process | Processes the Whole Network This method generates the OutputNetwork data.
Method | ProcessByRoutes | Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated. If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again. If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics. This method generates the OutputNetworkByRoutes data.
Method | RemoveNetworkCCG | Remove a Common Control Group (CCG) from the Network.
Method | RemoveNetworkLegConnection |
Method | RemoveNetworkSite | Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.
Method | RemoveRoute | Remove a Route from the Network.
Method | ResetRouteSignalOffsetPriority | Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPINetwork Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkCCG Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : AddNetworkCCG Method

Glossary Item Box

Add a new Common Control Group (CCG) into the Network.

Syntax

Visual Basic (Declaration)
Function AddNetworkCCG() As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPINetworkCCG

value = instance.AddNetworkCCG()
C#
ISIAPINetworkCCG AddNetworkCCG()
Managed Extensions for C++
ISIAPINetworkCCG* AddNetworkCCG();
C++/CLI
ISIAPINetworkCCG^ AddNetworkCCG();

Return Value

The new added Common Control Group (CCG).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkLegConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : AddNetworkLegConnection Method

nwSite1
legOrientation1
nwSite2
legOrientation2

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function AddNetworkLegConnection( _
   ByVal nwSite1 As ISIAPINetworkSite, _
   ByVal legOrientation1 As Integer, _
   ByVal nwSite2 As ISIAPINetworkSite, _
   ByVal legOrientation2 As Integer _
) As ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim nwSite1 As ISIAPINetworkSite
Dim legOrientation1 As Integer
Dim nwSite2 As ISIAPINetworkSite
Dim legOrientation2 As Integer
Dim value As ISIAPINetworkLegConnection

value = instance.AddNetworkLegConnection(nwSite1, legOrientation1, nwSite2, legOrientation2)
C#
ISIAPINetworkLegConnection AddNetworkLegConnection(
   ISIAPINetworkSite nwSite1,
   int legOrientation1,
   ISIAPINetworkSite nwSite2,
   int legOrientation2
)
Managed Extensions for C++
ISIAPINetworkLegConnection* AddNetworkLegConnection(
   ISIAPINetworkSite* nwSite1,
   int legOrientation1,
   ISIAPINetworkSite* nwSite2,
   int legOrientation2
)
C++/CLI
ISIAPINetworkLegConnection^ AddNetworkLegConnection(
   ISIAPINetworkSite^ nwSite1,
   int legOrientation1,
   ISIAPINetworkSite^ nwSite2,
   int legOrientation2
)

Parameters

nwSite1
legOrientation1
nwSite2
legOrientation2

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : AddNetworkSite Method

site
The Site to add.
layoutX
The X-coordinate value of the Site position in the Network Configuration Layout.
layoutY
The Y-coordinate value of the Site position in the Network Configuration Layout.

Glossary Item Box

Add a Site into the Network. The Site's Drive Rule and Units must match this Network's ones.

Syntax

Visual Basic (Declaration)
Function AddNetworkSite( _
   ByVal site As ISIAPISite, _
   ByVal layoutX As Single, _
   ByVal layoutY As Single _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim site As ISIAPISite
Dim layoutX As Single
Dim layoutY As Single
Dim value As ISIAPINetworkSite

value = instance.AddNetworkSite(site, layoutX, layoutY)
C#
ISIAPINetworkSite AddNetworkSite(
   ISIAPISite site,
   float layoutX,
   float layoutY
)
Managed Extensions for C++
ISIAPINetworkSite* AddNetworkSite(
   ISIAPISite* site,
   float layoutX,
   float layoutY
)
C++/CLI
ISIAPINetworkSite^ AddNetworkSite(
   ISIAPISite^ site,
   float layoutX,
   float layoutY
)

Parameters

site
The Site to add.
layoutX
The X-coordinate value of the Site position in the Network Configuration Layout.
layoutY
The Y-coordinate value of the Site position in the Network Configuration Layout.

Return Value

The new added NetworkSite.

Remarks

The Network Configuration Layout is used in the Network Configuration Dialog in the SIDRA INTERSECTION program. The dimension of any Site in the Network Configuration Layout is 200 x 200 pixels. In the Network Configuration Dialog, the start point of view is (5000, 5000). So the NetworkSites created through this dialog are usually located around the point (5000, 5000). For example, Site1 (5200, 5100), Site2 (5550, 5100). The Sites' positions in the detailed Network Layout Display are based on the relative ratio of the Sites' positions in the Network Configuration Layout.

We suggest the layoutX and layoutY values to be around 5000, and between 0 and 10000.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : AddRoute Method

Glossary Item Box

Add a new Route into the Network.

Syntax

Visual Basic (Declaration)
Function AddRoute() As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIRoute

value = instance.AddRoute()
C#
ISIAPIRoute AddRoute()
Managed Extensions for C++
ISIAPIRoute* AddRoute();
C++/CLI
ISIAPIRoute^ AddRoute();

Return Value

The new added Route

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : CloneRoute Method

route
The Route to be cloned.

Glossary Item Box

Clone a Route.

Syntax

Visual Basic (Declaration)
Function CloneRoute( _
   ByVal route As ISIAPIRoute _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim route As ISIAPIRoute
Dim value As ISIAPIRoute

value = instance.CloneRoute(route)
C#
ISIAPIRoute CloneRoute(
   ISIAPIRoute route
)
Managed Extensions for C++
ISIAPIRoute* CloneRoute(
   ISIAPIRoute* route
)
C++/CLI
ISIAPIRoute^ CloneRoute(
   ISIAPIRoute^ route
)

Parameters

route
The Route to be cloned.

Return Value

The new cloned Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : CreateLayoutPngData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateLayoutPngData() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value() As Byte

value = instance.CreateLayoutPngData()
C#
byte[] CreateLayoutPngData()
Managed Extensions for C++
byte[]* CreateLayoutPngData();
C++/CLI
array<byte>^ CreateLayoutPngData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngFile Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : CreateLayoutPngFile Method

filename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateLayoutPngFile( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim filename As String
Dim value As Boolean

value = instance.CreateLayoutPngFile(filename)
C#
bool CreateLayoutPngFile(
   string filename
)
Managed Extensions for C++
bool CreateLayoutPngFile(
   string* filename
)
C++/CLI
bool CreateLayoutPngFile(
   String^ filename
)

Parameters

filename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveNetworkCCGTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : MoveNetworkCCGTo Method

ccg
The Common Control Group to move.
newPosition
The zero-based position that the CCG should be moved to.

Glossary Item Box

Move a Common Control Group (CCG) to a new position.

Syntax

Visual Basic (Declaration)
Function MoveNetworkCCGTo( _
   ByVal ccg As ISIAPINetworkCCG, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim ccg As ISIAPINetworkCCG
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveNetworkCCGTo(ccg, newPosition)
C#
bool MoveNetworkCCGTo(
   ISIAPINetworkCCG ccg,
   int newPosition
)
Managed Extensions for C++
bool MoveNetworkCCGTo(
   ISIAPINetworkCCG* ccg,
   int newPosition
)
C++/CLI
bool MoveNetworkCCGTo(
   ISIAPINetworkCCG^ ccg,
   int newPosition
)

Parameters

ccg
The Common Control Group to move.
newPosition
The zero-based position that the CCG should be moved to.

Return Value

true if the CCG is successfully moved; otherwise, false. This method also returns false if the CCG was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveRouteTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : MoveRouteTo Method

route
The Route to move.
newPosition
The zero-based position that the Route should be moved to.

Glossary Item Box

Move a Route to a new position.

Syntax

Visual Basic (Declaration)
Function MoveRouteTo( _
   ByVal route As ISIAPIRoute, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim route As ISIAPIRoute
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveRouteTo(route, newPosition)
C#
bool MoveRouteTo(
   ISIAPIRoute route,
   int newPosition
)
Managed Extensions for C++
bool MoveRouteTo(
   ISIAPIRoute* route,
   int newPosition
)
C++/CLI
bool MoveRouteTo(
   ISIAPIRoute^ route,
   int newPosition
)

Parameters

route
The Route to move.
newPosition
The zero-based position that the Route should be moved to.

Return Value

true if the Route is successfully moved; otherwise, false. This method also returns false if the Route was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Process Method

Glossary Item Box

Processes the Whole Network

This method generates the OutputNetwork data.

Syntax

Visual Basic (Declaration)
Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

value = instance.Process()
C#
bool Process()
Managed Extensions for C++
bool Process();
C++/CLI
bool Process();

Return Value

Type: System.Boolean.

True, if processing was successful. False, if errors were generated during processing - check ProcessingError for details.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessByRoutes Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : ProcessByRoutes Method

Glossary Item Box

Process this Network by selected Routes. The Whole Network needs to be processed before Network by selected Routes statistics can be calculated.
If the Network has not been processed, process the Network. The Network by selected Routes statistics will be calculated as well. It is not required to call this method again.
If Route(s) are set to be included into Network by Routes after the Network is processed, call this method to calculate the Network by selected Routes statistics.

This method generates the OutputNetworkByRoutes data.

Syntax

Visual Basic (Declaration)
Function ProcessByRoutes() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

value = instance.ProcessByRoutes()
C#
bool ProcessByRoutes()
Managed Extensions for C++
bool ProcessByRoutes();
C++/CLI
bool ProcessByRoutes();

Return Value

true if this is processed successfully.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkCCG Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : RemoveNetworkCCG Method

ccg
The Common Control Group (CCG) to remove.

Glossary Item Box

Remove a Common Control Group (CCG) from the Network.

Syntax

Visual Basic (Declaration)
Function RemoveNetworkCCG( _
   ByVal ccg As ISIAPINetworkCCG _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim ccg As ISIAPINetworkCCG
Dim value As Boolean

value = instance.RemoveNetworkCCG(ccg)
C#
bool RemoveNetworkCCG(
   ISIAPINetworkCCG ccg
)
Managed Extensions for C++
bool RemoveNetworkCCG(
   ISIAPINetworkCCG* ccg
)
C++/CLI
bool RemoveNetworkCCG(
   ISIAPINetworkCCG^ ccg
)

Parameters

ccg
The Common Control Group (CCG) to remove.

Return Value

true if the Common Control Group (CCG) is successfully removed; otherwise, false. This method also returns false if the CCG was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkLegConnection Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : RemoveNetworkLegConnection Method

nwLegConn

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function RemoveNetworkLegConnection( _
   ByVal nwLegConn As ISIAPINetworkLegConnection _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim nwLegConn As ISIAPINetworkLegConnection
Dim value As Boolean

value = instance.RemoveNetworkLegConnection(nwLegConn)
C#
bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection nwLegConn
)
Managed Extensions for C++
bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection* nwLegConn
)
C++/CLI
bool RemoveNetworkLegConnection(
   ISIAPINetworkLegConnection^ nwLegConn
)

Parameters

nwLegConn

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : RemoveNetworkSite Method

networkSite
The NetworkSite to remove.

Glossary Item Box

Remove a NetworkSite from the Network. If the NetworkSite is used in any Route(s), remove the Route(s) before removing the NetworkSite.

Syntax

Visual Basic (Declaration)
Function RemoveNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.RemoveNetworkSite(networkSite)
C#
bool RemoveNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
bool RemoveNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
bool RemoveNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The NetworkSite to remove.

Return Value

true if the NetworkSite is successfully removed; otherwise, false. This method also returns false if the NetworkSite was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveRoute Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : RemoveRoute Method

route
The Route to remove.

Glossary Item Box

Remove a Route from the Network.

Syntax

Visual Basic (Declaration)
Function RemoveRoute( _
   ByVal route As ISIAPIRoute _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim route As ISIAPIRoute
Dim value As Boolean

value = instance.RemoveRoute(route)
C#
bool RemoveRoute(
   ISIAPIRoute route
)
Managed Extensions for C++
bool RemoveRoute(
   ISIAPIRoute* route
)
C++/CLI
bool RemoveRoute(
   ISIAPIRoute^ route
)

Parameters

route
The Route to remove.

Return Value

true if the Route is successfully removed; otherwise, false. This method also returns false if the Route was not found in this Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetRouteSignalOffsetPriority Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : ResetRouteSignalOffsetPriority Method

Glossary Item Box

Reset the Offset Priority of all valid Routes for the program calculation of Signal Offsets.

Syntax

Visual Basic (Declaration)
Function ResetRouteSignalOffsetPriority() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

value = instance.ResetRouteSignalOffsetPriority()
C#
bool ResetRouteSignalOffsetPriority()
Managed Extensions for C++
bool ResetRouteSignalOffsetPriority();
C++/CLI
bool ResetRouteSignalOffsetPriority();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
bool UpdateModifiedInfo()
Managed Extensions for C++
bool UpdateModifiedInfo();
C++/CLI
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetwork Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetwork Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetwork members.

Public Properties

 | Name | Description
Property | Category | Network Category
Property | CostUnit |
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | Cycle_time_option | Cycle Time Option
Property | DemandSensitivity |
Property | Description |
Property | DesiredSpeed |
Property | DesiredSpeedMethod | Desired Speed Method
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | DriveOnLeft |
Property | Green_split_priority_option | Green Split Priority
Property | HoursPerYear |
Property | Is_timing_optimised_for_selected_result |
Property | IsIncludedInProjectSummary |
Property | IsPlatoonDispersionApplied |
Property | IsShortlaneQueueStorageRatioIncl | Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio
Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Property | LastErrorMessage |
Property | LOSMethod | Network Level of Service Method
Property | LOSTarget | Network Level of Service Target
Property | LowerLimitOfSpeedEfficiency |
Property | MaxIterations |
Property | ModelName |
Property | ModelSignature |
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | MultiRoutesSummaryOption | Network Output by Routes Option
Property | Name |
Property | Network_id | The database row unique ID of the Network.
Property | NetworkCCGs | Collection of Common Control Group (CCG) in the Network
Property | NetworkCycleTime |
Property | NetworkID | Network ID in the Network Data dialog and reports.
Property | NetworkLegConnections | Collection of Leg Connections between the Sites in the Network
Property | NetworkSites | Collection of Sites in the Network
Property | OffsetDefinition | Signal Offset Definition
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | OutputNetwork | Network Output Data for the summary of the Whole Network
Property | OutputNetworkByRoutes | Network Output Data for the statistics summary of the selected Routes
Property | Peakflowperiod |
Property | Percentile_queue |
Property | Percentile_queue_option |
Property | Performance_measure |
Property | Position | The Network Position in the Project's Networks collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | ProcessingError | Error nessage after a failed call to Process
Property | Project |
Property | Routes | Collection of Routes in the Network
Property | SignalOffsetOption | Signal Offset Option
Property | Site_los_method |
Property | SitePhaseTimesOption | Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.
Property | StoppingDxPercent |
Property | Title |
Property | Units | General unit system used for data within the Network
Property | Variable_phasing_perf_measure |
Top

See Also

Reference

ISIAPINetwork Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Category Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Category Property

Glossary Item Box

Network Category

Syntax

Visual Basic (Declaration)
Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.Category = value

value = instance.Category
C#
string Category {get; set;}
Managed Extensions for C++
__property string* get_Category();
__property void set_Category(
   string* value
);
C++/CLI
property String^ Category {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Network Category, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CostUnit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : CostUnit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property CostUnit As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.CostUnit = value

value = instance.CostUnit
C#
string CostUnit {get; set;}
Managed Extensions for C++
__property string* get_CostUnit();
__property void set_CostUnit(
   string* value
);
C++/CLI
property String^ CostUnit {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Created_by
C#
string Created_by {get;}
Managed Extensions for C++
__property string* get_Created_by();
C++/CLI
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Created_by_company
C#
string Created_by_company {get;}
Managed Extensions for C++
__property string* get_Created_by_company();
C++/CLI
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Date

value = instance.Created_date
C#
DateTime Created_date {get;}
Managed Extensions for C++
__property DateTime get_Created_date();
C++/CLI
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Created_version
C#
string Created_version {get;}
Managed Extensions for C++
__property string* get_Created_version();
C++/CLI
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
int Cycle_time_option {get; set;}
Managed Extensions for C++
__property int get_Cycle_time_option();
__property void set_Cycle_time_option(
   int value
);
C++/CLI
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Program,
2 = User-Given Cycle Time.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandSensitivity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DemandSensitivity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DemandSensitivity As ISIAPINetworkDemandSensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPINetworkDemandSensitivity

value = instance.DemandSensitivity
C#
ISIAPINetworkDemandSensitivity DemandSensitivity {get;}
Managed Extensions for C++
__property ISIAPINetworkDemandSensitivity* get_DemandSensitivity();
C++/CLI
property ISIAPINetworkDemandSensitivity^ DemandSensitivity {
   ISIAPINetworkDemandSensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Description Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Description Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.Description = value

value = instance.Description
C#
string Description {get; set;}
Managed Extensions for C++
__property string* get_Description();
__property void set_Description(
   string* value
);
C++/CLI
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Single

instance.DesiredSpeed = value

value = instance.DesiredSpeed
C#
float DesiredSpeed {get; set;}
Managed Extensions for C++
__property float get_DesiredSpeed();
__property void set_DesiredSpeed(
   float value
);
C++/CLI
property float DesiredSpeed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DesiredSpeedMethod Property

Glossary Item Box

Desired Speed Method

Syntax

Visual Basic (Declaration)
Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.DesiredSpeedMethod = value

value = instance.DesiredSpeedMethod
C#
int DesiredSpeedMethod {get; set;}
Managed Extensions for C++
__property int get_DesiredSpeedMethod();
__property void set_DesiredSpeedMethod(
   int value
);
C++/CLI
property int DesiredSpeedMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = User Input,
1 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
__property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

value = instance.DiagnosticStatus
C#
int DiagnosticStatus {get;}
Managed Extensions for C++
__property int get_DiagnosticStatus();
C++/CLI
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DriveOnLeft Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : DriveOnLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DriveOnLeft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

value = instance.DriveOnLeft
C#
bool DriveOnLeft {get;}
Managed Extensions for C++
__property bool get_DriveOnLeft();
C++/CLI
property bool DriveOnLeft {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Green_split_priority_option Property

Glossary Item Box

Green Split Priority

Syntax

Visual Basic (Declaration)
Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
int Green_split_priority_option {get; set;}
Managed Extensions for C++
__property int get_Green_split_priority_option();
__property void set_Green_split_priority_option(
   int value
);
C++/CLI
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Coordinated Movements,
2 = User-Specified Movements.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HoursPerYear Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : HoursPerYear Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property HoursPerYear As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.HoursPerYear = value

value = instance.HoursPerYear
C#
int HoursPerYear {get; set;}
Managed Extensions for C++
__property int get_HoursPerYear();
__property void set_HoursPerYear(
   int value
);
C++/CLI
property int HoursPerYear {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_timing_optimised_for_selected_result Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Is_timing_optimised_for_selected_result Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_timing_optimised_for_selected_result As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

instance.Is_timing_optimised_for_selected_result = value

value = instance.Is_timing_optimised_for_selected_result
C#
bool Is_timing_optimised_for_selected_result {get; set;}
Managed Extensions for C++
__property bool get_Is_timing_optimised_for_selected_result();
__property void set_Is_timing_optimised_for_selected_result(
   bool value
);
C++/CLI
property bool Is_timing_optimised_for_selected_result {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInProjectSummary();
__property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsPlatoonDispersionApplied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : IsPlatoonDispersionApplied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsPlatoonDispersionApplied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

instance.IsPlatoonDispersionApplied = value

value = instance.IsPlatoonDispersionApplied
C#
bool IsPlatoonDispersionApplied {get; set;}
Managed Extensions for C++
__property bool get_IsPlatoonDispersionApplied();
__property void set_IsPlatoonDispersionApplied(
   bool value
);
C++/CLI
property bool IsPlatoonDispersionApplied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsShortlaneQueueStorageRatioIncl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : IsShortlaneQueueStorageRatioIncl Property

Glossary Item Box

Flag indicating if Short Lanes are included in determining Approach Queue Storage Ratio

Syntax

Visual Basic (Declaration)
Property IsShortlaneQueueStorageRatioIncl As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

instance.IsShortlaneQueueStorageRatioIncl = value

value = instance.IsShortlaneQueueStorageRatioIncl
C#
bool IsShortlaneQueueStorageRatioIncl {get; set;}
Managed Extensions for C++
__property bool get_IsShortlaneQueueStorageRatioIncl();
__property void set_IsShortlaneQueueStorageRatioIncl(
   bool value
);
C++/CLI
property bool IsShortlaneQueueStorageRatioIncl {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Lane_blockage_effect_option Property

Glossary Item Box

Lane Blockage Effect Option:
In Network analysis, include Lane Blockage effects in determining Phase Times.

Syntax

Visual Basic (Declaration)
Property Lane_blockage_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Lane_blockage_effect_option = value

value = instance.Lane_blockage_effect_option
C#
int Lane_blockage_effect_option {get; set;}
Managed Extensions for C++
__property int get_Lane_blockage_effect_option();
__property void set_Lane_blockage_effect_option(
   int value
);
C++/CLI
property int Lane_blockage_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Without Lane Blockage Effects,
1 = With Lane Blockage Effects.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : LOSMethod Property

Glossary Item Box

Network Level of Service Method

Syntax

Visual Basic (Declaration)
Property LOSMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.LOSMethod = value

value = instance.LOSMethod
C#
int LOSMethod {get; set;}
Managed Extensions for C++
__property int get_LOSMethod();
__property void set_LOSMethod(
   int value
);
C++/CLI
property int LOSMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = SIDRA Speed Efficiency,
2 = HCM 2010 Speed Efficiency,
3 = HCM 6 Speed Efficiency.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSTarget Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : LOSTarget Property

Glossary Item Box

Network Level of Service Target

Syntax

Visual Basic (Declaration)
Property LOSTarget As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.LOSTarget = value

value = instance.LOSTarget
C#
int LOSTarget {get; set;}
Managed Extensions for C++
__property int get_LOSTarget();
__property void set_LOSTarget(
   int value
);
C++/CLI
property int LOSTarget {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = LOS A,
2 = LOS B,
3 = LOS C,
4 = LOS D,
5 = LOS E,
6 = LOS F.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LowerLimitOfSpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : LowerLimitOfSpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property LowerLimitOfSpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Single

instance.LowerLimitOfSpeedEfficiency = value

value = instance.LowerLimitOfSpeedEfficiency
C#
float LowerLimitOfSpeedEfficiency {get; set;}
Managed Extensions for C++
__property float get_LowerLimitOfSpeedEfficiency();
__property void set_LowerLimitOfSpeedEfficiency(
   float value
);
C++/CLI
property float LowerLimitOfSpeedEfficiency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MaxIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : MaxIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property MaxIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.MaxIterations = value

value = instance.MaxIterations
C#
int MaxIterations {get; set;}
Managed Extensions for C++
__property int get_MaxIterations();
__property void set_MaxIterations(
   int value
);
C++/CLI
property int MaxIterations {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : ModelName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ModelName As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.ModelName
C#
string ModelName {get;}
Managed Extensions for C++
__property string* get_ModelName();
C++/CLI
property String^ ModelName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelSignature Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : ModelSignature Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ModelSignature As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.ModelSignature
C#
string ModelSignature {get;}
Managed Extensions for C++
__property string* get_ModelSignature();
C++/CLI
property String^ ModelSignature {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Modified_by
C#
string Modified_by {get;}
Managed Extensions for C++
__property string* get_Modified_by();
C++/CLI
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Modified_by_company
C#
string Modified_by_company {get;}
Managed Extensions for C++
__property string* get_Modified_by_company();
C++/CLI
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Date

value = instance.Modified_date
C#
DateTime Modified_date {get;}
Managed Extensions for C++
__property DateTime get_Modified_date();
C++/CLI
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.Modified_version
C#
string Modified_version {get;}
Managed Extensions for C++
__property string* get_Modified_version();
C++/CLI
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MultiRoutesSummaryOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : MultiRoutesSummaryOption Property

Glossary Item Box

Network Output by Routes Option

Syntax

Visual Basic (Declaration)
Property MultiRoutesSummaryOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.MultiRoutesSummaryOption = value

value = instance.MultiRoutesSummaryOption
C#
int MultiRoutesSummaryOption {get; set;}
Managed Extensions for C++
__property int get_MultiRoutesSummaryOption();
__property void set_MultiRoutesSummaryOption(
   int value
);
C++/CLI
property int MultiRoutesSummaryOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

2 = Approaches,
3 = Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Network_id Property

Glossary Item Box

The database row unique ID of the Network.

Syntax

Visual Basic (Declaration)
ReadOnly Property Network_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

value = instance.Network_id
C#
int Network_id {get;}
Managed Extensions for C++
__property int get_Network_id();
C++/CLI
property int Network_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : NetworkCCGs Property

Glossary Item Box

Collection of Common Control Group (CCG) in the Network

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkCCGs As ISIAPINetworkCCGs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPINetworkCCGs

value = instance.NetworkCCGs
C#
ISIAPINetworkCCGs NetworkCCGs {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGs* get_NetworkCCGs();
C++/CLI
property ISIAPINetworkCCGs^ NetworkCCGs {
   ISIAPINetworkCCGs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCycleTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : NetworkCycleTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property NetworkCycleTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.NetworkCycleTime = value

value = instance.NetworkCycleTime
C#
int NetworkCycleTime {get; set;}
Managed Extensions for C++
__property int get_NetworkCycleTime();
__property void set_NetworkCycleTime(
   int value
);
C++/CLI
property int NetworkCycleTime {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : NetworkID Property

Glossary Item Box

Network ID in the Network Data dialog and reports.

Syntax

Visual Basic (Declaration)
Property NetworkID As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.NetworkID = value

value = instance.NetworkID
C#
string NetworkID {get; set;}
Managed Extensions for C++
__property string* get_NetworkID();
__property void set_NetworkID(
   string* value
);
C++/CLI
property String^ NetworkID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkLegConnections Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : NetworkLegConnections Property

Glossary Item Box

Collection of Leg Connections between the Sites in the Network

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkLegConnections As ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPINetworkLegConnections

value = instance.NetworkLegConnections
C#
ISIAPINetworkLegConnections NetworkLegConnections {get;}
Managed Extensions for C++
__property ISIAPINetworkLegConnections* get_NetworkLegConnections();
C++/CLI
property ISIAPINetworkLegConnections^ NetworkLegConnections {
   ISIAPINetworkLegConnections^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : NetworkSites Property

Glossary Item Box

Collection of Sites in the Network

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSites As ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPINetworkSites

value = instance.NetworkSites
C#
ISIAPINetworkSites NetworkSites {get;}
Managed Extensions for C++
__property ISIAPINetworkSites* get_NetworkSites();
C++/CLI
property ISIAPINetworkSites^ NetworkSites {
   ISIAPINetworkSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OffsetDefinition Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : OffsetDefinition Property

Glossary Item Box

Signal Offset Definition

Syntax

Visual Basic (Declaration)
Property OffsetDefinition As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.OffsetDefinition = value

value = instance.OffsetDefinition
C#
int OffsetDefinition {get; set;}
Managed Extensions for C++
__property int get_OffsetDefinition();
__property void set_OffsetDefinition(
   int value
);
C++/CLI
property int OffsetDefinition {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Offsets (Phase Start),
1 = Offsets (Green Start).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_increment();
__property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_lower();
__property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
__property bool get_Optimum_cycle_time_lower_user();
__property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_optim_method();
__property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_perf_measure();
__property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_upper();
__property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_optim_method();
__property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_increment();
__property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_lower();
__property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_upper();
__property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_perf_measure();
__property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetwork Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : OutputNetwork Property

Glossary Item Box

Network Output Data for the summary of the Whole Network

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetwork As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIOutputNetwork

value = instance.OutputNetwork
C#
ISIAPIOutputNetwork OutputNetwork {get;}
Managed Extensions for C++
__property ISIAPIOutputNetwork* get_OutputNetwork();
C++/CLI
property ISIAPIOutputNetwork^ OutputNetwork {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkByRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : OutputNetworkByRoutes Property

Glossary Item Box

Network Output Data for the statistics summary of the selected Routes

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetworkByRoutes As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIOutputNetwork

value = instance.OutputNetworkByRoutes
C#
ISIAPIOutputNetwork OutputNetworkByRoutes {get;}
Managed Extensions for C++
__property ISIAPIOutputNetwork* get_OutputNetworkByRoutes();
C++/CLI
property ISIAPIOutputNetwork^ OutputNetworkByRoutes {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peakflowperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Peakflowperiod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Peakflowperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Peakflowperiod = value

value = instance.Peakflowperiod
C#
int Peakflowperiod {get; set;}
Managed Extensions for C++
__property int get_Peakflowperiod();
__property void set_Peakflowperiod(
   int value
);
C++/CLI
property int Peakflowperiod {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Percentile_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Percentile_queue As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Percentile_queue = value

value = instance.Percentile_queue
C#
int Percentile_queue {get; set;}
Managed Extensions for C++
__property int get_Percentile_queue();
__property void set_Percentile_queue(
   int value
);
C++/CLI
property int Percentile_queue {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percentile_queue_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Percentile_queue_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Percentile_queue_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Percentile_queue_option = value

value = instance.Percentile_queue_option
C#
int Percentile_queue_option {get; set;}
Managed Extensions for C++
__property int get_Percentile_queue_option();
__property void set_Percentile_queue_option(
   int value
);
C++/CLI
property int Percentile_queue_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Performance_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Performance_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Performance_measure = value

value = instance.Performance_measure
C#
int Performance_measure {get; set;}
Managed Extensions for C++
__property int get_Performance_measure();
__property void set_Performance_measure(
   int value
);
C++/CLI
property int Performance_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Position Property

Glossary Item Box

The Network Position in the Project's Networks collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
__property int get_Practical_cycle_rounding();
__property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
__property int get_Practical_max_cycle_time();
__property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingError Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : ProcessingError Property

Glossary Item Box

Error nessage after a failed call to Process

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcessingError As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

value = instance.ProcessingError
C#
string ProcessingError {get;}
Managed Extensions for C++
__property string* get_ProcessingError();
C++/CLI
property String^ ProcessingError {
   String^ get();
}

Property Value

Type: System.String.

Error message

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Project Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIProject

value = instance.Project
C#
ISIAPIProject Project {get;}
Managed Extensions for C++
__property ISIAPIProject* get_Project();
C++/CLI
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Routes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Routes Property

Glossary Item Box

Collection of Routes in the Network

Syntax

Visual Basic (Declaration)
ReadOnly Property Routes As ISIAPIRoutes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As ISIAPIRoutes

value = instance.Routes
C#
ISIAPIRoutes Routes {get;}
Managed Extensions for C++
__property ISIAPIRoutes* get_Routes();
C++/CLI
property ISIAPIRoutes^ Routes {
   ISIAPIRoutes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : SignalOffsetOption Property

Glossary Item Box

Signal Offset Option

Syntax

Visual Basic (Declaration)
Property SignalOffsetOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.SignalOffsetOption = value

value = instance.SignalOffsetOption
C#
int SignalOffsetOption {get; set;}
Managed Extensions for C++
__property int get_SignalOffsetOption();
__property void set_SignalOffsetOption(
   int value
);
C++/CLI
property int SignalOffsetOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Program,
1 = User-Given.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site_los_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Site_los_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Site_los_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Site_los_method = value

value = instance.Site_los_method
C#
int Site_los_method {get; set;}
Managed Extensions for C++
__property int get_Site_los_method();
__property void set_Site_los_method(
   int value
);
C++/CLI
property int Site_los_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SitePhaseTimesOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : SitePhaseTimesOption Property

Glossary Item Box

Site or CCG Phase Times Option. It is applied when Cycle Time Option is User-Given Cycle Time.

Syntax

Visual Basic (Declaration)
Property SitePhaseTimesOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.SitePhaseTimesOption = value

value = instance.SitePhaseTimesOption
C#
int SitePhaseTimesOption {get; set;}
Managed Extensions for C++
__property int get_SitePhaseTimesOption();
__property void set_SitePhaseTimesOption(
   int value
);
C++/CLI
property int SitePhaseTimesOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Program,
1 = User-Given.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StoppingDxPercent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : StoppingDxPercent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property StoppingDxPercent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Single

instance.StoppingDxPercent = value

value = instance.StoppingDxPercent
C#
float StoppingDxPercent {get; set;}
Managed Extensions for C++
__property float get_StoppingDxPercent();
__property void set_StoppingDxPercent(
   float value
);
C++/CLI
property float StoppingDxPercent {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As String

instance.Title = value

value = instance.Title
C#
string Title {get; set;}
Managed Extensions for C++
__property string* get_Title();
__property void set_Title(
   string* value
);
C++/CLI
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Units Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Units Property

Glossary Item Box

General unit system used for data within the Network

Syntax

Visual Basic (Declaration)
ReadOnly Property Units As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

value = instance.Units
C#
int Units {get;}
Managed Extensions for C++
__property int get_Units();
C++/CLI
property int Units {
   int get();
}

Property Value

Type: System.Int32.

0 = Metric,
1 = US Units.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetwork Interface : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetwork
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Variable_phasing_perf_measure();
__property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetwork Interface
ISIAPINetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCG Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCG Interface

Glossary Item Box

Wrapper interface for a Common Control Group (CCG) in a particular Network

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
C#
public interface ISIAPINetworkCCG
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCG
C++/CLI
public interface class ISIAPINetworkCCG

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCG Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCG Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCG.

Public Properties

 | Name | Description
Property | CCGSequences |
Property | CoordinatedOption | Coordinated Option
Property | IsReference |
Property | LastErrorMessage |
Property | Name |
Property | Network |
Property | NetworkCCGID | Network Common Control Group (CCG) ID for displaying in reports.
Property | NetworkSites |
Property | Offset |
Property | Position | The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.
Property | Signal_analysis_method | Signalised analysis method, applied to the Sites in this Common Control Group (CCG).
Top

Public Methods

 | Name | Description
Method | AddCCGSequence | Add a Sequence. A new Sequence is created and added to this Network CCG.
Method | AddNetworkSite | Add a Network Site into this Network CCG.
Method | CloneCCGSequence | Clone a Sequence.
Method | MoveCCGSequenceTo | Move a Sequence to a new position.
Method | RemoveCCGSequence | Remove a Sequence from this Network CCG.
Method | RemoveNetworkSite | Remove a Network Site from this Network CCG.
Top

See Also

Reference

ISIAPINetworkCCG Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCG Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCG Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCG members.

Public Methods

 | Name | Description
Method | AddCCGSequence | Add a Sequence. A new Sequence is created and added to this Network CCG.
Method | AddNetworkSite | Add a Network Site into this Network CCG.
Method | CloneCCGSequence | Clone a Sequence.
Method | MoveCCGSequenceTo | Move a Sequence to a new position.
Method | RemoveCCGSequence | Remove a Sequence from this Network CCG.
Method | RemoveNetworkSite | Remove a Network Site from this Network CCG.
Top

See Also

Reference

ISIAPINetworkCCG Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : AddCCGSequence Method

name
The name of the new Sequence.

Glossary Item Box

Add a Sequence. A new Sequence is created and added to this Network CCG.

Syntax

Visual Basic (Declaration)
Function AddCCGSequence( _
   ByVal name As String _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim name As String
Dim value As ISIAPINetworkCCGSequence

value = instance.AddCCGSequence(name)
C#
ISIAPINetworkCCGSequence AddCCGSequence(
   string name
)
Managed Extensions for C++
ISIAPINetworkCCGSequence* AddCCGSequence(
   string* name
)
C++/CLI
ISIAPINetworkCCGSequence^ AddCCGSequence(
   String^ name
)

Parameters

name
The name of the new Sequence.

Return Value

The new Sequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : AddNetworkSite Method

networkSite
The Network Site to add.

Glossary Item Box

Add a Network Site into this Network CCG.

Syntax

Visual Basic (Declaration)
Function AddNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.AddNetworkSite(networkSite)
C#
bool AddNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
bool AddNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
bool AddNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The Network Site to add.

Return Value

true if the Network Site is successfully added; otherwise, false.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : CloneCCGSequence Method

ccgSequence
The Sequence to be cloned.

Glossary Item Box

Clone a Sequence.

Syntax

Visual Basic (Declaration)
Function CloneCCGSequence( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCGSequence

value = instance.CloneCCGSequence(ccgSequence)
C#
ISIAPINetworkCCGSequence CloneCCGSequence(
   ISIAPINetworkCCGSequence ccgSequence
)
Managed Extensions for C++
ISIAPINetworkCCGSequence* CloneCCGSequence(
   ISIAPINetworkCCGSequence* ccgSequence
)
C++/CLI
ISIAPINetworkCCGSequence^ CloneCCGSequence(
   ISIAPINetworkCCGSequence^ ccgSequence
)

Parameters

ccgSequence
The Sequence to be cloned.

Return Value

The new cloned Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveCCGSequenceTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : MoveCCGSequenceTo Method

ccgSequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Glossary Item Box

Move a Sequence to a new position.

Syntax

Visual Basic (Declaration)
Function MoveCCGSequenceTo( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveCCGSequenceTo(ccgSequence, newPosition)
C#
bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence ccgSequence,
   int newPosition
)
Managed Extensions for C++
bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence* ccgSequence,
   int newPosition
)
C++/CLI
bool MoveCCGSequenceTo(
   ISIAPINetworkCCGSequence^ ccgSequence,
   int newPosition
)

Parameters

ccgSequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Return Value

true if the Sequence is successfully moved; otherwise, false. This method also returns false if the Sequence was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveCCGSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : RemoveCCGSequence Method

ccgSequence
The Sequence to remove.

Glossary Item Box

Remove a Sequence from this Network CCG.

Syntax

Visual Basic (Declaration)
Function RemoveCCGSequence( _
   ByVal ccgSequence As ISIAPINetworkCCGSequence _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim ccgSequence As ISIAPINetworkCCGSequence
Dim value As Boolean

value = instance.RemoveCCGSequence(ccgSequence)
C#
bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence ccgSequence
)
Managed Extensions for C++
bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence* ccgSequence
)
C++/CLI
bool RemoveCCGSequence(
   ISIAPINetworkCCGSequence^ ccgSequence
)

Parameters

ccgSequence
The Sequence to remove.

Return Value

true if the Sequence is successfully removed; otherwise, false. This method also returns false if the Sequence was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : RemoveNetworkSite Method

networkSite
The Network Site to remove.

Glossary Item Box

Remove a Network Site from this Network CCG.

Syntax

Visual Basic (Declaration)
Function RemoveNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim networkSite As ISIAPINetworkSite
Dim value As Boolean

value = instance.RemoveNetworkSite(networkSite)
C#
bool RemoveNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
bool RemoveNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
bool RemoveNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite
The Network Site to remove.

Return Value

true if the Network Site is successfully removed; otherwise, false. This method also returns false if the Network Site was not found in this Network CCG.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCG Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCG Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCG members.

Public Properties

 | Name | Description
Property | CCGSequences |
Property | CoordinatedOption | Coordinated Option
Property | IsReference |
Property | LastErrorMessage |
Property | Name |
Property | Network |
Property | NetworkCCGID | Network Common Control Group (CCG) ID for displaying in reports.
Property | NetworkSites |
Property | Offset |
Property | Position | The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.
Property | Signal_analysis_method | Signalised analysis method, applied to the Sites in this Common Control Group (CCG).
Top

See Also

Reference

ISIAPINetworkCCG Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGSequences Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : CCGSequences Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CCGSequences As ISIAPINetworkCCGSequences
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As ISIAPINetworkCCGSequences

value = instance.CCGSequences
C#
ISIAPINetworkCCGSequences CCGSequences {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGSequences* get_CCGSequences();
C++/CLI
property ISIAPINetworkCCGSequences^ CCGSequences {
   ISIAPINetworkCCGSequences^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CoordinatedOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : CoordinatedOption Property

Glossary Item Box

Coordinated Option

Syntax

Visual Basic (Declaration)
Property CoordinatedOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As Integer

instance.CoordinatedOption = value

value = instance.CoordinatedOption
C#
int CoordinatedOption {get; set;}
Managed Extensions for C++
__property int get_CoordinatedOption();
__property void set_CoordinatedOption(
   int value
);
C++/CLI
property int CoordinatedOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = NA,
1 = Yes,
2 = No.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReference Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : IsReference Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsReference As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As Boolean

instance.IsReference = value

value = instance.IsReference
C#
bool IsReference {get; set;}
Managed Extensions for C++
__property bool get_IsReference();
__property void set_IsReference(
   bool value
);
C++/CLI
property bool IsReference {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : NetworkCCGID Property

Glossary Item Box

Network Common Control Group (CCG) ID for displaying in reports.

Syntax

Visual Basic (Declaration)
Property NetworkCCGID As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As String

instance.NetworkCCGID = value

value = instance.NetworkCCGID
C#
string NetworkCCGID {get; set;}
Managed Extensions for C++
__property string* get_NetworkCCGID();
__property void set_NetworkCCGID(
   string* value
);
C++/CLI
property String^ NetworkCCGID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : NetworkSites Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSites As ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As ISIAPINetworkSites

value = instance.NetworkSites
C#
ISIAPINetworkSites NetworkSites {get;}
Managed Extensions for C++
__property ISIAPINetworkSites* get_NetworkSites();
C++/CLI
property ISIAPINetworkSites^ NetworkSites {
   ISIAPINetworkSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As Integer

instance.Offset = value

value = instance.Offset
C#
int Offset {get; set;}
Managed Extensions for C++
__property int get_Offset();
__property void set_Offset(
   int value
);
C++/CLI
property int Offset {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : Position Property

Glossary Item Box

The Common Control Group (CCG) Position in the Network's CCGs collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCG Interface : Signal_analysis_method Property

Glossary Item Box

Signalised analysis method, applied to the Sites in this Common Control Group (CCG).

Syntax

Visual Basic (Declaration)
Property Signal_analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCG
Dim value As Integer

instance.Signal_analysis_method = value

value = instance.Signal_analysis_method
C#
int Signal_analysis_method {get; set;}
Managed Extensions for C++
__property int get_Signal_analysis_method();
__property void set_Signal_analysis_method(
   int value
);
C++/CLI
property int Signal_analysis_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Fixed-Time/Pretimed,
1 = Actuated.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCG Interface
ISIAPINetworkCCG Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhase Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhase Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
C#
public interface ISIAPINetworkCCGPhase
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCGPhase
C++/CLI
public interface class ISIAPINetworkCCGPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhase Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhase Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCGPhase.

Public Properties

 | Name | Description
Property | All_red_time |
Property | CCGSequence |
Property | Dummy_maximum_green_time |
Property | Dummy_maximum_green_time_user |
Property | Dummy_minimum_green_time |
Property | Dummy_minimum_green_time_user |
Property | Has_dummy |
Property | Is_variable |
Property | IsReferencePhase |
Property | Minimum_time |
Property | Name |
Property | Phase_frequency |
Property | Phase_frequency_user |
Property | Phase_time |
Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Property | Yellow_time |
Top

Public Methods

 | Name | Description
Method | GetPhasemovementPedsByNetworkSite |
Method | GetPhasemovementVehiclesByNetworkSite |
Top

See Also

Reference

ISIAPINetworkCCGPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhase Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhase Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGPhase members.

Public Methods

 | Name | Description
Method | GetPhasemovementPedsByNetworkSite |
Method | GetPhasemovementVehiclesByNetworkSite |
Top

See Also

Reference

ISIAPINetworkCCGPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhasemovementPedsByNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : GetPhasemovementPedsByNetworkSite Method

networkSite

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetPhasemovementPedsByNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim networkSite As ISIAPINetworkSite
Dim value As ISIAPIPhasemovement_peds

value = instance.GetPhasemovementPedsByNetworkSite(networkSite)
C#
ISIAPIPhasemovement_peds GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
ISIAPIPhasemovement_peds* GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
ISIAPIPhasemovement_peds^ GetPhasemovementPedsByNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhasemovementVehiclesByNetworkSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : GetPhasemovementVehiclesByNetworkSite Method

networkSite

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetPhasemovementVehiclesByNetworkSite( _
   ByVal networkSite As ISIAPINetworkSite _
) As ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim networkSite As ISIAPINetworkSite
Dim value As ISIAPIPhasemovement_vehicles

value = instance.GetPhasemovementVehiclesByNetworkSite(networkSite)
C#
ISIAPIPhasemovement_vehicles GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite networkSite
)
Managed Extensions for C++
ISIAPIPhasemovement_vehicles* GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite* networkSite
)
C++/CLI
ISIAPIPhasemovement_vehicles^ GetPhasemovementVehiclesByNetworkSite(
   ISIAPINetworkSite^ networkSite
)

Parameters

networkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhase Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhase Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGPhase members.

Public Properties

 | Name | Description
Property | All_red_time |
Property | CCGSequence |
Property | Dummy_maximum_green_time |
Property | Dummy_maximum_green_time_user |
Property | Dummy_minimum_green_time |
Property | Dummy_minimum_green_time_user |
Property | Has_dummy |
Property | Is_variable |
Property | IsReferencePhase |
Property | Minimum_time |
Property | Name |
Property | Phase_frequency |
Property | Phase_frequency_user |
Property | Phase_time |
Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Property | Yellow_time |
Top

See Also

Reference

ISIAPINetworkCCGPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.All_red_time = value

value = instance.All_red_time
C#
int All_red_time {get; set;}
Managed Extensions for C++
__property int get_All_red_time();
__property void set_All_red_time(
   int value
);
C++/CLI
property int All_red_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : CCGSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CCGSequence As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As ISIAPINetworkCCGSequence

value = instance.CCGSequence
C#
ISIAPINetworkCCGSequence CCGSequence {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGSequence* get_CCGSequence();
C++/CLI
property ISIAPINetworkCCGSequence^ CCGSequence {
   ISIAPINetworkCCGSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Dummy_maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.Dummy_maximum_green_time = value

value = instance.Dummy_maximum_green_time
C#
int Dummy_maximum_green_time {get; set;}
Managed Extensions for C++
__property int get_Dummy_maximum_green_time();
__property void set_Dummy_maximum_green_time(
   int value
);
C++/CLI
property int Dummy_maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Dummy_maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.Dummy_maximum_green_time_user = value

value = instance.Dummy_maximum_green_time_user
C#
bool Dummy_maximum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Dummy_maximum_green_time_user();
__property void set_Dummy_maximum_green_time_user(
   bool value
);
C++/CLI
property bool Dummy_maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Dummy_minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.Dummy_minimum_green_time = value

value = instance.Dummy_minimum_green_time
C#
int Dummy_minimum_green_time {get; set;}
Managed Extensions for C++
__property int get_Dummy_minimum_green_time();
__property void set_Dummy_minimum_green_time(
   int value
);
C++/CLI
property int Dummy_minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Dummy_minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.Dummy_minimum_green_time_user = value

value = instance.Dummy_minimum_green_time_user
C#
bool Dummy_minimum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Dummy_minimum_green_time_user();
__property void set_Dummy_minimum_green_time_user(
   bool value
);
C++/CLI
property bool Dummy_minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.Has_dummy = value

value = instance.Has_dummy
C#
bool Has_dummy {get; set;}
Managed Extensions for C++
__property bool get_Has_dummy();
__property void set_Has_dummy(
   bool value
);
C++/CLI
property bool Has_dummy {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_variable Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Is_variable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_variable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.Is_variable = value

value = instance.Is_variable
C#
bool Is_variable {get; set;}
Managed Extensions for C++
__property bool get_Is_variable();
__property void set_Is_variable(
   bool value
);
C++/CLI
property bool Is_variable {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.IsReferencePhase = value

value = instance.IsReferencePhase
C#
bool IsReferencePhase {get; set;}
Managed Extensions for C++
__property bool get_IsReferencePhase();
__property void set_IsReferencePhase(
   bool value
);
C++/CLI
property bool IsReferencePhase {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Minimum_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.Minimum_time = value

value = instance.Minimum_time
C#
int Minimum_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_time();
__property void set_Minimum_time(
   int value
);
C++/CLI
property int Minimum_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Phase_frequency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_frequency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Single

instance.Phase_frequency = value

value = instance.Phase_frequency
C#
float Phase_frequency {get; set;}
Managed Extensions for C++
__property float get_Phase_frequency();
__property void set_Phase_frequency(
   float value
);
C++/CLI
property float Phase_frequency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Phase_frequency_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_frequency_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Boolean

instance.Phase_frequency_user = value

value = instance.Phase_frequency_user
C#
bool Phase_frequency_user {get; set;}
Managed Extensions for C++
__property bool get_Phase_frequency_user();
__property void set_Phase_frequency_user(
   bool value
);
C++/CLI
property bool Phase_frequency_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.Phase_time = value

value = instance.Phase_time
C#
int Phase_time {get; set;}
Managed Extensions for C++
__property int get_Phase_time();
__property void set_Phase_time(
   int value
);
C++/CLI
property int Phase_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Position Property

Glossary Item Box

The Phase Position in the Sequence's Phases collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhase Interface : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhase
Dim value As Integer

instance.Yellow_time = value

value = instance.Yellow_time
C#
int Yellow_time {get; set;}
Managed Extensions for C++
__property int get_Yellow_time();
__property void set_Yellow_time(
   int value
);
C++/CLI
property int Yellow_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhase Interface
ISIAPINetworkCCGPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhases Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhases Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCGPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhases
C#
public interface ISIAPINetworkCCGPhases
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCGPhases
C++/CLI
public interface class ISIAPINetworkCCGPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhases Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhases Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCGPhases.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhaseExists |
Top

See Also

Reference

ISIAPINetworkCCGPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhases Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGPhases members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhaseExists |
Top

See Also

Reference

ISIAPINetworkCCGPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhaseExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhases Interface : PhaseExists Method

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function PhaseExists( _
   ByVal phasename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhases
Dim phasename As String
Dim value As Boolean

value = instance.PhaseExists(phasename)
C#
bool PhaseExists(
   string phasename
)
Managed Extensions for C++
bool PhaseExists(
   string* phasename
)
C++/CLI
bool PhaseExists(
   String^ phasename
)

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Interface
ISIAPINetworkCCGPhases Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGPhases Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGPhases members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPINetworkCCGPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhases Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhases
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Interface
ISIAPINetworkCCGPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhases Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Interface
ISIAPINetworkCCGPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhases Interface > Item Property : Item(String) Property

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal phasename As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhases
Dim phasename As String
Dim value As ISIAPINetworkCCGPhase

value = instance.Item(phasename)
C#
ISIAPINetworkCCGPhase Item(
   string phasename
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGPhase* get_Item(
   string* phasename
);
C++/CLI
property ISIAPINetworkCCGPhase^ Item {
   ISIAPINetworkCCGPhase^ get(String^ phasename);
}

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Interface
ISIAPINetworkCCGPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGPhases Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGPhases
Dim index As Integer
Dim value As ISIAPINetworkCCGPhase

value = instance.Item(index)
C#
ISIAPINetworkCCGPhase Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGPhase* get_Item(
   int index
);
C++/CLI
property ISIAPINetworkCCGPhase^ Item {
   ISIAPINetworkCCGPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGPhases Interface
ISIAPINetworkCCGPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCGs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGs
C#
public interface ISIAPINetworkCCGs
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCGs
C++/CLI
public interface class ISIAPINetworkCCGs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCGs.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | NetworkCCGExists | Queries whether a particular Network Common Control Group (CCG) exists in the collection
Top

See Also

Reference

ISIAPINetworkCCGs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | NetworkCCGExists | Queries whether a particular Network Common Control Group (CCG) exists in the collection
Top

See Also

Reference

ISIAPINetworkCCGs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCGExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGs Interface : NetworkCCGExists Method

ccgName
CCG name to query

Glossary Item Box

Queries whether a particular Network Common Control Group (CCG) exists in the collection

Syntax

Visual Basic (Declaration)
Function NetworkCCGExists( _
   ByVal ccgName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGs
Dim ccgName As String
Dim value As Boolean

value = instance.NetworkCCGExists(ccgName)
C#
bool NetworkCCGExists(
   string ccgName
)
Managed Extensions for C++
bool NetworkCCGExists(
   string* ccgName
)
C++/CLI
bool NetworkCCGExists(
   String^ ccgName
)

Parameters

ccgName
CCG name to query

Return Value

Type: System.Bool

True, if a Network CCG with the given CCG name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Interface
ISIAPINetworkCCGs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPINetworkCCGs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Interface
ISIAPINetworkCCGs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGs Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Interface
ISIAPINetworkCCGs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGs Interface > Item Property : Item(String) Property

ccgName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal ccgName As String _
) As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGs
Dim ccgName As String
Dim value As ISIAPINetworkCCG

value = instance.Item(ccgName)
C#
ISIAPINetworkCCG Item(
   string ccgName
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCG* get_Item(
   string* ccgName
);
C++/CLI
property ISIAPINetworkCCG^ Item {
   ISIAPINetworkCCG^ get(String^ ccgName);
}

Parameters

ccgName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Interface
ISIAPINetworkCCGs Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGs Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGs
Dim index As Integer
Dim value As ISIAPINetworkCCG

value = instance.Item(index)
C#
ISIAPINetworkCCG Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCG* get_Item(
   int index
);
C++/CLI
property ISIAPINetworkCCG^ Item {
   ISIAPINetworkCCG^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGs Interface
ISIAPINetworkCCGs Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequence Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequence Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
C#
public interface ISIAPINetworkCCGSequence
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCGSequence
C++/CLI
public interface class ISIAPINetworkCCGSequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequence Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequence Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCGSequence.

Public Properties

 | Name | Description
Property | Actuated_gap_major_mov |
Property | Actuated_gap_minor_mov |
Property | Actuated_max_green_major_mov |
Property | Actuated_max_green_minor_mov |
Property | CCGPhases |
Property | Cycle_time_option | Cycle Time Option
Property | Eff_det_zone_len_major_mov |
Property | Eff_det_zone_len_minor_mov |
Property | Green_split_priority_option |
Property | Is_selected |
Property | LastErrorMessage |
Property | Name |
Property | NetworkCCG |
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | Position | The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | Usergiven_cycle_time |
Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Method | AddCCGPhase | Add a new Phase to the end of this Sequence.
Method | CloneCCGPhase | Clone a Phase.
Method | InsertCCGPhase | Insert a new Phase into this Sequence at the specified position.
Method | MoveCCGPhaseTo | Move a Phase to a new position.
Method | RemoveCCGPhase | Remove a Phase from this Sequence.
Top

See Also

Reference

ISIAPINetworkCCGSequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequence Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequence Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGSequence members.

Public Methods

 | Name | Description
Method | AddCCGPhase | Add a new Phase to the end of this Sequence.
Method | CloneCCGPhase | Clone a Phase.
Method | InsertCCGPhase | Insert a new Phase into this Sequence at the specified position.
Method | MoveCCGPhaseTo | Move a Phase to a new position.
Method | RemoveCCGPhase | Remove a Phase from this Sequence.
Top

See Also

Reference

ISIAPINetworkCCGSequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : AddCCGPhase Method

name
The name of the new Phase.

Glossary Item Box

Add a new Phase to the end of this Sequence.

Syntax

Visual Basic (Declaration)
Function AddCCGPhase( _
   ByVal name As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim name As String
Dim value As ISIAPINetworkCCGPhase

value = instance.AddCCGPhase(name)
C#
ISIAPINetworkCCGPhase AddCCGPhase(
   string name
)
Managed Extensions for C++
ISIAPINetworkCCGPhase* AddCCGPhase(
   string* name
)
C++/CLI
ISIAPINetworkCCGPhase^ AddCCGPhase(
   String^ name
)

Parameters

name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : CloneCCGPhase Method

ccgPhase
The Phase to clone.

Glossary Item Box

Clone a Phase.

Syntax

Visual Basic (Declaration)
Function CloneCCGPhase( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim value As ISIAPINetworkCCGPhase

value = instance.CloneCCGPhase(ccgPhase)
C#
ISIAPINetworkCCGPhase CloneCCGPhase(
   ISIAPINetworkCCGPhase ccgPhase
)
Managed Extensions for C++
ISIAPINetworkCCGPhase* CloneCCGPhase(
   ISIAPINetworkCCGPhase* ccgPhase
)
C++/CLI
ISIAPINetworkCCGPhase^ CloneCCGPhase(
   ISIAPINetworkCCGPhase^ ccgPhase
)

Parameters

ccgPhase
The Phase to clone.

Return Value

The new cloned Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : InsertCCGPhase Method

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Glossary Item Box

Insert a new Phase into this Sequence at the specified position.

Syntax

Visual Basic (Declaration)
Function InsertCCGPhase( _
   ByVal position As Integer, _
   ByVal name As String _
) As ISIAPINetworkCCGPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim position As Integer
Dim name As String
Dim value As ISIAPINetworkCCGPhase

value = instance.InsertCCGPhase(position, name)
C#
ISIAPINetworkCCGPhase InsertCCGPhase(
   int position,
   string name
)
Managed Extensions for C++
ISIAPINetworkCCGPhase* InsertCCGPhase(
   int position,
   string* name
)
C++/CLI
ISIAPINetworkCCGPhase^ InsertCCGPhase(
   int position,
   String^ name
)

Parameters

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveCCGPhaseTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : MoveCCGPhaseTo Method

ccgPhase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Glossary Item Box

Move a Phase to a new position.

Syntax

Visual Basic (Declaration)
Function MoveCCGPhaseTo( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveCCGPhaseTo(ccgPhase, newPosition)
C#
bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase ccgPhase,
   int newPosition
)
Managed Extensions for C++
bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase* ccgPhase,
   int newPosition
)
C++/CLI
bool MoveCCGPhaseTo(
   ISIAPINetworkCCGPhase^ ccgPhase,
   int newPosition
)

Parameters

ccgPhase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Return Value

true if the Phase is successfully moved; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveCCGPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : RemoveCCGPhase Method

ccgPhase
The Phase to remove.

Glossary Item Box

Remove a Phase from this Sequence.

Syntax

Visual Basic (Declaration)
Function RemoveCCGPhase( _
   ByVal ccgPhase As ISIAPINetworkCCGPhase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim ccgPhase As ISIAPINetworkCCGPhase
Dim value As Boolean

value = instance.RemoveCCGPhase(ccgPhase)
C#
bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase ccgPhase
)
Managed Extensions for C++
bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase* ccgPhase
)
C++/CLI
bool RemoveCCGPhase(
   ISIAPINetworkCCGPhase^ ccgPhase
)

Parameters

ccgPhase
The Phase to remove.

Return Value

true if the Phase is successfully removed; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequence Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequence Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGSequence members.

Public Properties

 | Name | Description
Property | Actuated_gap_major_mov |
Property | Actuated_gap_minor_mov |
Property | Actuated_max_green_major_mov |
Property | Actuated_max_green_minor_mov |
Property | CCGPhases |
Property | Cycle_time_option | Cycle Time Option
Property | Eff_det_zone_len_major_mov |
Property | Eff_det_zone_len_minor_mov |
Property | Green_split_priority_option |
Property | Is_selected |
Property | LastErrorMessage |
Property | Name |
Property | NetworkCCG |
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | Position | The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | Usergiven_cycle_time |
Property | Variable_phasing_perf_measure |
Top

See Also

Reference

ISIAPINetworkCCGSequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Actuated_gap_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_gap_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_gap_major_mov = value

value = instance.Actuated_gap_major_mov
C#
float Actuated_gap_major_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_gap_major_mov();
__property void set_Actuated_gap_major_mov(
   float value
);
C++/CLI
property float Actuated_gap_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Actuated_gap_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_gap_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_gap_minor_mov = value

value = instance.Actuated_gap_minor_mov
C#
float Actuated_gap_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_gap_minor_mov();
__property void set_Actuated_gap_minor_mov(
   float value
);
C++/CLI
property float Actuated_gap_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Actuated_max_green_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_max_green_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_max_green_major_mov = value

value = instance.Actuated_max_green_major_mov
C#
float Actuated_max_green_major_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_max_green_major_mov();
__property void set_Actuated_max_green_major_mov(
   float value
);
C++/CLI
property float Actuated_max_green_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Actuated_max_green_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_max_green_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Actuated_max_green_minor_mov = value

value = instance.Actuated_max_green_minor_mov
C#
float Actuated_max_green_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_max_green_minor_mov();
__property void set_Actuated_max_green_minor_mov(
   float value
);
C++/CLI
property float Actuated_max_green_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CCGPhases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : CCGPhases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CCGPhases As ISIAPINetworkCCGPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCGPhases

value = instance.CCGPhases
C#
ISIAPINetworkCCGPhases CCGPhases {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGPhases* get_CCGPhases();
C++/CLI
property ISIAPINetworkCCGPhases^ CCGPhases {
   ISIAPINetworkCCGPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
int Cycle_time_option {get; set;}
Managed Extensions for C++
__property int get_Cycle_time_option();
__property void set_Cycle_time_option(
   int value
);
C++/CLI
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Cycle Time,
1 = Optimum Cycle Time,
2 = User-Given Cycle Time,
3 = User-Given Phase Time,
4 = Optimum Maximum Green Settings.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Eff_det_zone_len_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Eff_det_zone_len_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Eff_det_zone_len_major_mov = value

value = instance.Eff_det_zone_len_major_mov
C#
float Eff_det_zone_len_major_mov {get; set;}
Managed Extensions for C++
__property float get_Eff_det_zone_len_major_mov();
__property void set_Eff_det_zone_len_major_mov(
   float value
);
C++/CLI
property float Eff_det_zone_len_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Eff_det_zone_len_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Eff_det_zone_len_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Single

instance.Eff_det_zone_len_minor_mov = value

value = instance.Eff_det_zone_len_minor_mov
C#
float Eff_det_zone_len_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Eff_det_zone_len_minor_mov();
__property void set_Eff_det_zone_len_minor_mov(
   float value
);
C++/CLI
property float Eff_det_zone_len_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Green_split_priority_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
int Green_split_priority_option {get; set;}
Managed Extensions for C++
__property int get_Green_split_priority_option();
__property void set_Green_split_priority_option(
   int value
);
C++/CLI
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_selected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Is_selected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Boolean

instance.Is_selected = value

value = instance.Is_selected
C#
bool Is_selected {get; set;}
Managed Extensions for C++
__property bool get_Is_selected();
__property void set_Is_selected(
   bool value
);
C++/CLI
property bool Is_selected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCG Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : NetworkCCG Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkCCG As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As ISIAPINetworkCCG

value = instance.NetworkCCG
C#
ISIAPINetworkCCG NetworkCCG {get;}
Managed Extensions for C++
__property ISIAPINetworkCCG* get_NetworkCCG();
C++/CLI
property ISIAPINetworkCCG^ NetworkCCG {
   ISIAPINetworkCCG^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_increment();
__property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_lower();
__property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
__property bool get_Optimum_cycle_time_lower_user();
__property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_optim_method();
__property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_perf_measure();
__property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_upper();
__property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_optim_method();
__property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_increment();
__property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_lower();
__property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_upper();
__property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_perf_measure();
__property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Position Property

Glossary Item Box

The Sequence Position in the Netowrk CCG's Sequences collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
__property int get_Practical_cycle_rounding();
__property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
__property int get_Practical_max_cycle_time();
__property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Usergiven_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Usergiven_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Usergiven_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Usergiven_cycle_time = value

value = instance.Usergiven_cycle_time
C#
int Usergiven_cycle_time {get; set;}
Managed Extensions for C++
__property int get_Usergiven_cycle_time();
__property void set_Usergiven_cycle_time(
   int value
);
C++/CLI
property int Usergiven_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequence Interface : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequence
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Variable_phasing_perf_measure();
__property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequence Interface
ISIAPINetworkCCGSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequences Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequences Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkCCGSequences
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
C#
public interface ISIAPINetworkCCGSequences
Managed Extensions for C++
public __gc __interface ISIAPINetworkCCGSequences
C++/CLI
public interface class ISIAPINetworkCCGSequences

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequences Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequences Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkCCGSequences.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Property | SelectedSequence |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | SequenceExists |
Top

See Also

Reference

ISIAPINetworkCCGSequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequences Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequences Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGSequences members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | SequenceExists |
Top

See Also

Reference

ISIAPINetworkCCGSequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SequenceExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface : SequenceExists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function SequenceExists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
Dim name As String
Dim value As Boolean

value = instance.SequenceExists(name)
C#
bool SequenceExists(
   string name
)
Managed Extensions for C++
bool SequenceExists(
   string* name
)
C++/CLI
bool SequenceExists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkCCGSequences Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkCCGSequences Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkCCGSequences members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Property | SelectedSequence |
Top

See Also

Reference

ISIAPINetworkCCGSequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface > Item Property : Item(String) Property

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
Dim name As String
Dim value As ISIAPINetworkCCGSequence

value = instance.Item(name)
C#
ISIAPINetworkCCGSequence Item(
   string name
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGSequence* get_Item(
   string* name
);
C++/CLI
property ISIAPINetworkCCGSequence^ Item {
   ISIAPINetworkCCGSequence^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
Dim index As Integer
Dim value As ISIAPINetworkCCGSequence

value = instance.Item(index)
C#
ISIAPINetworkCCGSequence Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGSequence* get_Item(
   int index
);
C++/CLI
property ISIAPINetworkCCGSequence^ Item {
   ISIAPINetworkCCGSequence^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SelectedSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkCCGSequences Interface : SelectedSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SelectedSequence As ISIAPINetworkCCGSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkCCGSequences
Dim value As ISIAPINetworkCCGSequence

value = instance.SelectedSequence
C#
ISIAPINetworkCCGSequence SelectedSequence {get;}
Managed Extensions for C++
__property ISIAPINetworkCCGSequence* get_SelectedSequence();
C++/CLI
property ISIAPINetworkCCGSequence^ SelectedSequence {
   ISIAPINetworkCCGSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkCCGSequences Interface
ISIAPINetworkCCGSequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkDemandSensitivity Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkDemandSensitivity Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkDemandSensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
C#
public interface ISIAPINetworkDemandSensitivity
Managed Extensions for C++
public __gc __interface ISIAPINetworkDemandSensitivity
C++/CLI
public interface class ISIAPINetworkDemandSensitivity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkDemandSensitivity Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkDemandSensitivity Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkDemandSensitivity.

Public Properties

 | Name | Description
Property | Analysis_option | Analysis Option
Property | Design_Life_Constant_num_years |
Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Property | Design_Life_Is_constant_num_years_applied |
Property | Design_Life_Objective | Design Life Analysis Objective
Property | Design_Life_Years |
Property | Flow_Scale_Constant_factor |
Property | Flow_Scale_Is_constant_factor_applied |
Property | Flow_Scale_Lower |
Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Property | Flow_Scale_Upper |
Property | Network |
Property | Result_option | Results For
Property | SensitivityGeneralParameterGroup |
Top

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkDemandSensitivity Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkDemandSensitivity Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkDemandSensitivity members.

Public Properties

 | Name | Description
Property | Analysis_option | Analysis Option
Property | Design_Life_Constant_num_years |
Property | Design_Life_Growth_Model | Design Life Analysis Growth Model
Property | Design_Life_Is_constant_num_years_applied |
Property | Design_Life_Objective | Design Life Analysis Objective
Property | Design_Life_Years |
Property | Flow_Scale_Constant_factor |
Property | Flow_Scale_Is_constant_factor_applied |
Property | Flow_Scale_Lower |
Property | Flow_Scale_Objective | Flow Scale Analysis Objective
Property | Flow_Scale_Upper |
Property | Network |
Property | Result_option | Results For
Property | SensitivityGeneralParameterGroup |
Top

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Analysis_option Property

Glossary Item Box

Analysis Option

Syntax

Visual Basic (Declaration)
Property Analysis_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Analysis_option = value

value = instance.Analysis_option
C#
int Analysis_option {get; set;}
Managed Extensions for C++
__property int get_Analysis_option();
__property void set_Analysis_option(
   int value
);
C++/CLI
property int Analysis_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Sensitivity,
2 = Design Life,
3 = Flow Scale.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Constant_num_years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Design_Life_Constant_num_years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Constant_num_years As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Constant_num_years = value

value = instance.Design_Life_Constant_num_years
C#
int Design_Life_Constant_num_years {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Constant_num_years();
__property void set_Design_Life_Constant_num_years(
   int value
);
C++/CLI
property int Design_Life_Constant_num_years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Growth_Model Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Design_Life_Growth_Model Property

Glossary Item Box

Design Life Analysis Growth Model

Syntax

Visual Basic (Declaration)
Property Design_Life_Growth_Model As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Growth_Model = value

value = instance.Design_Life_Growth_Model
C#
int Design_Life_Growth_Model {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Growth_Model();
__property void set_Design_Life_Growth_Model(
   int value
);
C++/CLI
property int Design_Life_Growth_Model {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Uniform,
1 = Compound.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Is_constant_num_years_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Design_Life_Is_constant_num_years_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Is_constant_num_years_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Boolean

instance.Design_Life_Is_constant_num_years_applied = value

value = instance.Design_Life_Is_constant_num_years_applied
C#
bool Design_Life_Is_constant_num_years_applied {get; set;}
Managed Extensions for C++
__property bool get_Design_Life_Is_constant_num_years_applied();
__property void set_Design_Life_Is_constant_num_years_applied(
   bool value
);
C++/CLI
property bool Design_Life_Is_constant_num_years_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Design_Life_Objective Property

Glossary Item Box

Design Life Analysis Objective

Syntax

Visual Basic (Declaration)
Property Design_Life_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Objective = value

value = instance.Design_Life_Objective
C#
int Design_Life_Objective {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Objective();
__property void set_Design_Life_Objective(
   int value
);
C++/CLI
property int Design_Life_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
4 = Final Year,
5 = Network Level of Service Target.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Years Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Design_Life_Years Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Design_Life_Years As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Design_Life_Years = value

value = instance.Design_Life_Years
C#
int Design_Life_Years {get; set;}
Managed Extensions for C++
__property int get_Design_Life_Years();
__property void set_Design_Life_Years(
   int value
);
C++/CLI
property int Design_Life_Years {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Flow_Scale_Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Constant_factor = value

value = instance.Flow_Scale_Constant_factor
C#
float Flow_Scale_Constant_factor {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Constant_factor();
__property void set_Flow_Scale_Constant_factor(
   float value
);
C++/CLI
property float Flow_Scale_Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Flow_Scale_Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Boolean

instance.Flow_Scale_Is_constant_factor_applied = value

value = instance.Flow_Scale_Is_constant_factor_applied
C#
bool Flow_Scale_Is_constant_factor_applied {get; set;}
Managed Extensions for C++
__property bool get_Flow_Scale_Is_constant_factor_applied();
__property void set_Flow_Scale_Is_constant_factor_applied(
   bool value
);
C++/CLI
property bool Flow_Scale_Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Flow_Scale_Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Lower = value

value = instance.Flow_Scale_Lower
C#
float Flow_Scale_Lower {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Lower();
__property void set_Flow_Scale_Lower(
   float value
);
C++/CLI
property float Flow_Scale_Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Objective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Flow_Scale_Objective Property

Glossary Item Box

Flow Scale Analysis Objective

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Objective As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Flow_Scale_Objective = value

value = instance.Flow_Scale_Objective
C#
int Flow_Scale_Objective {get; set;}
Managed Extensions for C++
__property int get_Flow_Scale_Objective();
__property void set_Flow_Scale_Objective(
   int value
);
C++/CLI
property int Flow_Scale_Objective {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Capacity (v/c ratio = xp),
1 = Capacity (v/c ratio = 1),
4 = Final Year,
5 = Network Level of Service Target.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Flow_Scale_Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Flow_Scale_Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Single

instance.Flow_Scale_Upper = value

value = instance.Flow_Scale_Upper
C#
float Flow_Scale_Upper {get; set;}
Managed Extensions for C++
__property float get_Flow_Scale_Upper();
__property void set_Flow_Scale_Upper(
   float value
);
C++/CLI
property float Flow_Scale_Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Result_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : Result_option Property

Glossary Item Box

Results For

Syntax

Visual Basic (Declaration)
Property Result_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As Integer

instance.Result_option = value

value = instance.Result_option
C#
int Result_option {get; set;}
Managed Extensions for C++
__property int get_Result_option();
__property void set_Result_option(
   int value
);
C++/CLI
property int Result_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Network (Vehicles),
2 = Network (Pedestrians),
3 = Network (Persons).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SensitivityGeneralParameterGroup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkDemandSensitivity Interface : SensitivityGeneralParameterGroup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SensitivityGeneralParameterGroup As ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkDemandSensitivity
Dim value As ISIAPISensitivity

value = instance.SensitivityGeneralParameterGroup
C#
ISIAPISensitivity SensitivityGeneralParameterGroup {get;}
Managed Extensions for C++
__property ISIAPISensitivity* get_SensitivityGeneralParameterGroup();
C++/CLI
property ISIAPISensitivity^ SensitivityGeneralParameterGroup {
   ISIAPISensitivity^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkDemandSensitivity Interface
ISIAPINetworkDemandSensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnection Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnection Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
C#
public interface ISIAPINetworkLegConnection
Managed Extensions for C++
public __gc __interface ISIAPINetworkLegConnection
C++/CLI
public interface class ISIAPINetworkLegConnection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnection Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnection Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkLegConnection.

Public Properties

 | Name | Description
Property | ConnectionType |
Property | Leg1_Orientation |
Property | Leg2_Orientation |
Property | Network |
Property | NetworkSite1 |
Property | NetworkSite2 |
Property | Site1_Name |
Property | Site2_Name |
Property | ZIndex |
Top

See Also

Reference

ISIAPINetworkLegConnection Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnection Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnection Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkLegConnection members.

Public Properties

 | Name | Description
Property | ConnectionType |
Property | Leg1_Orientation |
Property | Leg2_Orientation |
Property | Network |
Property | NetworkSite1 |
Property | NetworkSite2 |
Property | Site1_Name |
Property | Site2_Name |
Property | ZIndex |
Top

See Also

Reference

ISIAPINetworkLegConnection Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ConnectionType Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : ConnectionType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property ConnectionType As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As Integer

instance.ConnectionType = value

value = instance.ConnectionType
C#
int ConnectionType {get; set;}
Managed Extensions for C++
__property int get_ConnectionType();
__property void set_ConnectionType(
   int value
);
C++/CLI
property int ConnectionType {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg1_Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : Leg1_Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg1_Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As Integer

value = instance.Leg1_Orientation
C#
int Leg1_Orientation {get;}
Managed Extensions for C++
__property int get_Leg1_Orientation();
C++/CLI
property int Leg1_Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Leg2_Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : Leg2_Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Leg2_Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As Integer

value = instance.Leg2_Orientation
C#
int Leg2_Orientation {get;}
Managed Extensions for C++
__property int get_Leg2_Orientation();
C++/CLI
property int Leg2_Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : NetworkSite1 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSite1 As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As ISIAPINetworkSite

value = instance.NetworkSite1
C#
ISIAPINetworkSite NetworkSite1 {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_NetworkSite1();
C++/CLI
property ISIAPINetworkSite^ NetworkSite1 {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : NetworkSite2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSite2 As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As ISIAPINetworkSite

value = instance.NetworkSite2
C#
ISIAPINetworkSite NetworkSite2 {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_NetworkSite2();
C++/CLI
property ISIAPINetworkSite^ NetworkSite2 {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site1_Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : Site1_Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site1_Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As String

value = instance.Site1_Name
C#
string Site1_Name {get;}
Managed Extensions for C++
__property string* get_Site1_Name();
C++/CLI
property String^ Site1_Name {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site2_Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : Site2_Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site2_Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As String

value = instance.Site2_Name
C#
string Site2_Name {get;}
Managed Extensions for C++
__property string* get_Site2_Name();
C++/CLI
property String^ Site2_Name {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ZIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnection Interface : ZIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property ZIndex As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnection
Dim value As Integer

instance.ZIndex = value

value = instance.ZIndex
C#
int ZIndex {get; set;}
Managed Extensions for C++
__property int get_ZIndex();
__property void set_ZIndex(
   int value
);
C++/CLI
property int ZIndex {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnection Interface
ISIAPINetworkLegConnection Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnections Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnections Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnections
C#
public interface ISIAPINetworkLegConnections
Managed Extensions for C++
public __gc __interface ISIAPINetworkLegConnections
C++/CLI
public interface class ISIAPINetworkLegConnections

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnections Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnections Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnections Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkLegConnections.

Public Properties

 | Name | Description
Property | Count | Gets the number of elements contained in the collection
Property | Item | Gets the element at the specified index.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPINetworkLegConnections Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnections Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnections Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkLegConnections members.

Public Properties

 | Name | Description
Property | Count | Gets the number of elements contained in the collection
Property | Item | Gets the element at the specified index.
Top

See Also

Reference

ISIAPINetworkLegConnections Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnections Interface : Count Property

Glossary Item Box

Gets the number of elements contained in the collection

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnections
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnections Interface
ISIAPINetworkLegConnections Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkLegConnections Interface : Item Property

index

Type: System.Int32;
The zero-based index of the element to get.

Glossary Item Box

Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkLegConnection
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkLegConnections
Dim index As Integer
Dim value As ISIAPINetworkLegConnection

value = instance.Item(index)
C#
ISIAPINetworkLegConnection this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPINetworkLegConnection* get_Item   int index
;
C++/CLI
property ISIAPINetworkLegConnection^ default [int] {
   ISIAPINetworkLegConnection^ get(int index);
}

Parameters

index

Type: System.Int32;
The zero-based index of the element to get.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkLegConnections Interface
ISIAPINetworkLegConnections Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworks Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworks Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworks
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
C#
public interface ISIAPINetworks
Managed Extensions for C++
public __gc __interface ISIAPINetworks
C++/CLI
public interface class ISIAPINetworks

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworks Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworks Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworks.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetNetworkByID | Get the Network by the database row unique ID.
Method | NetworkExists | Queries whether a particular Network exists in the collection
Top

See Also

Reference

ISIAPINetworks Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworks Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworks Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworks members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetNetworkByID | Get the Network by the database row unique ID.
Method | NetworkExists | Queries whether a particular Network exists in the collection
Top

See Also

Reference

ISIAPINetworks Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetNetworkByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface : GetNetworkByID Method

network_id

Type: System.Int32;
The database row unique ID of the Network.
This is different from the "Network ID" in the Network Data dialog which can be accessed through ISIAPINetwork.NetworkID.

Glossary Item Box

Get the Network by the database row unique ID.

Syntax

Visual Basic (Declaration)
Function GetNetworkByID( _
   ByVal network_id As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
Dim network_id As Integer
Dim value As ISIAPINetwork

value = instance.GetNetworkByID(network_id)
C#
ISIAPINetwork GetNetworkByID(
   int network_id
)
Managed Extensions for C++
ISIAPINetwork* GetNetworkByID(
   int network_id
)
C++/CLI
ISIAPINetwork^ GetNetworkByID(
   int network_id
)

Parameters

network_id

Type: System.Int32;
The database row unique ID of the Network.
This is different from the "Network ID" in the Network Data dialog which can be accessed through ISIAPINetwork.NetworkID.

Remarks

Use ISIAPINetworks.Item[] to get a Network by its name or its position in the Network List. In C++, use ISIAPINetworks->get_Item() to get a Network by its name or get_Item_2() by its position.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface : NetworkExists Method

networkname
Network name to query

Glossary Item Box

Queries whether a particular Network exists in the collection

Syntax

Visual Basic (Declaration)
Function NetworkExists( _
   ByVal networkname As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
Dim networkname As String
Dim value As Boolean

value = instance.NetworkExists(networkname)
C#
bool NetworkExists(
   string networkname
)
Managed Extensions for C++
bool NetworkExists(
   string* networkname
)
C++/CLI
bool NetworkExists(
   String^ networkname
)

Parameters

networkname
Network name to query

Return Value

Type: System.Bool

True, if a Network with the given name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworks Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworks Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworks members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPINetworks Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface > Item Property : Item(String) Property

networkname

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal networkname As String _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
Dim networkname As String
Dim value As ISIAPINetwork

value = instance.Item(networkname)
C#
ISIAPINetwork Item(
   string networkname
) {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Item(
   string* networkname
);
C++/CLI
property ISIAPINetwork^ Item {
   ISIAPINetwork^ get(String^ networkname);
}

Parameters

networkname

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworks Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworks
Dim index As Integer
Dim value As ISIAPINetwork

value = instance.Item(index)
C#
ISIAPINetwork Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Item(
   int index
);
C++/CLI
property ISIAPINetwork^ Item {
   ISIAPINetwork^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworks Interface
ISIAPINetworks Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSite Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSite Interface

Glossary Item Box

Wrapper interface for the Site in a particular Network

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
C#
public interface ISIAPINetworkSite
Managed Extensions for C++
public __gc __interface ISIAPINetworkSite
C++/CLI
public interface class ISIAPINetworkSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSite Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSite Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkSite.

Public Properties

 | Name | Description
Property | CoordinatedOption | Coordinated Option
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | IsIncludedInProjectSummary |
Property | IsReference |
Property | LayoutX |
Property | LayoutY |
Property | Network |
Property | NetworkCCG |
Property | NetworkLegConnections |
Property | NetworkSite_id | The database row unique ID of the NetworkSite.
Property | Offset |
Property | Site |
Property | SiteName |
Property | SiteOutputset | Site output data of this Site in the particular Network
Top

See Also

Reference

ISIAPINetworkSite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSite Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSite Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkSite members.

Public Properties

 | Name | Description
Property | CoordinatedOption | Coordinated Option
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | IsIncludedInProjectSummary |
Property | IsReference |
Property | LayoutX |
Property | LayoutY |
Property | Network |
Property | NetworkCCG |
Property | NetworkLegConnections |
Property | NetworkSite_id | The database row unique ID of the NetworkSite.
Property | Offset |
Property | Site |
Property | SiteName |
Property | SiteOutputset | Site output data of this Site in the particular Network
Top

See Also

Reference

ISIAPINetworkSite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CoordinatedOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : CoordinatedOption Property

Glossary Item Box

Coordinated Option

Syntax

Visual Basic (Declaration)
Property CoordinatedOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Integer

instance.CoordinatedOption = value

value = instance.CoordinatedOption
C#
int CoordinatedOption {get; set;}
Managed Extensions for C++
__property int get_CoordinatedOption();
__property void set_CoordinatedOption(
   int value
);
C++/CLI
property int CoordinatedOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = NA,
1 = Yes,
2 = No.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
__property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Integer

value = instance.DiagnosticStatus
C#
int DiagnosticStatus {get;}
Managed Extensions for C++
__property int get_DiagnosticStatus();
C++/CLI
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInProjectSummary();
__property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReference Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : IsReference Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsReference As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Boolean

instance.IsReference = value

value = instance.IsReference
C#
bool IsReference {get; set;}
Managed Extensions for C++
__property bool get_IsReference();
__property void set_IsReference(
   bool value
);
C++/CLI
property bool IsReference {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LayoutX Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : LayoutX Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property LayoutX As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Single

instance.LayoutX = value

value = instance.LayoutX
C#
float LayoutX {get; set;}
Managed Extensions for C++
__property float get_LayoutX();
__property void set_LayoutX(
   float value
);
C++/CLI
property float LayoutX {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LayoutY Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : LayoutY Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property LayoutY As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Single

instance.LayoutY = value

value = instance.LayoutY
C#
float LayoutY {get; set;}
Managed Extensions for C++
__property float get_LayoutY();
__property void set_LayoutY(
   float value
);
C++/CLI
property float LayoutY {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCCG Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : NetworkCCG Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkCCG As ISIAPINetworkCCG
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPINetworkCCG

value = instance.NetworkCCG
C#
ISIAPINetworkCCG NetworkCCG {get;}
Managed Extensions for C++
__property ISIAPINetworkCCG* get_NetworkCCG();
C++/CLI
property ISIAPINetworkCCG^ NetworkCCG {
   ISIAPINetworkCCG^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkLegConnections Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : NetworkLegConnections Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkLegConnections As ISIAPINetworkLegConnections
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPINetworkLegConnections

value = instance.NetworkLegConnections
C#
ISIAPINetworkLegConnections NetworkLegConnections {get;}
Managed Extensions for C++
__property ISIAPINetworkLegConnections* get_NetworkLegConnections();
C++/CLI
property ISIAPINetworkLegConnections^ NetworkLegConnections {
   ISIAPINetworkLegConnections^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : NetworkSite_id Property

Glossary Item Box

The database row unique ID of the NetworkSite.

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSite_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Integer

value = instance.NetworkSite_id
C#
int NetworkSite_id {get;}
Managed Extensions for C++
__property int get_NetworkSite_id();
C++/CLI
property int NetworkSite_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : Offset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Offset As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As Integer

instance.Offset = value

value = instance.Offset
C#
int Offset {get; set;}
Managed Extensions for C++
__property int get_Offset();
__property void set_Offset(
   int value
);
C++/CLI
property int Offset {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : SiteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteName As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As String

value = instance.SiteName
C#
string SiteName {get;}
Managed Extensions for C++
__property string* get_SiteName();
C++/CLI
property String^ SiteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteOutputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSite Interface : SiteOutputset Property

Glossary Item Box

Site output data of this Site in the particular Network

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteOutputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSite
Dim value As ISIAPIOutputset

value = instance.SiteOutputset
C#
ISIAPIOutputset SiteOutputset {get;}
Managed Extensions for C++
__property ISIAPIOutputset* get_SiteOutputset();
C++/CLI
property ISIAPIOutputset^ SiteOutputset {
   ISIAPIOutputset^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSite Interface
ISIAPINetworkSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSites Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSites Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPINetworkSites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSites
C#
public interface ISIAPINetworkSites
Managed Extensions for C++
public __gc __interface ISIAPINetworkSites
C++/CLI
public interface class ISIAPINetworkSites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSites Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSites Interface

Glossary Item Box

The following tables list the members exposed by ISIAPINetworkSites.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | NetworkSiteExists | Queries whether a particular Network Site exists in the collection
Top

See Also

Reference

ISIAPINetworkSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSites Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkSites members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | NetworkSiteExists | Queries whether a particular Network Site exists in the collection
Top

See Also

Reference

ISIAPINetworkSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSites Interface : NetworkSiteExists Method

sitename
Site name to query

Glossary Item Box

Queries whether a particular Network Site exists in the collection

Syntax

Visual Basic (Declaration)
Function NetworkSiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSites
Dim sitename As String
Dim value As Boolean

value = instance.NetworkSiteExists(sitename)
C#
bool NetworkSiteExists(
   string sitename
)
Managed Extensions for C++
bool NetworkSiteExists(
   string* sitename
)
C++/CLI
bool NetworkSiteExists(
   String^ sitename
)

Parameters

sitename
Site name to query

Return Value

Type: System.Bool

True, if a Network Site with the given Site name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Interface
ISIAPINetworkSites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkSites Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkSites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkSites members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPINetworkSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSites Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSites
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Interface
ISIAPINetworkSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSites Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Interface
ISIAPINetworkSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSites Interface > Item Property : Item(String) Property

sitename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSites
Dim sitename As String
Dim value As ISIAPINetworkSite

value = instance.Item(sitename)
C#
ISIAPINetworkSite Item(
   string sitename
) {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_Item(
   string* sitename
);
C++/CLI
property ISIAPINetworkSite^ Item {
   ISIAPINetworkSite^ get(String^ sitename);
}

Parameters

sitename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Interface
ISIAPINetworkSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPINetworkSites Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPINetworkSites
Dim index As Integer
Dim value As ISIAPINetworkSite

value = instance.Item(index)
C#
ISIAPINetworkSite Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_Item(
   int index
);
C++/CLI
property ISIAPINetworkSite^ Item {
   ISIAPINetworkSite^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPINetworkSites Interface
ISIAPINetworkSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_ped Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_ped Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
C#
public interface ISIAPIOpposingmovement_ped
Managed Extensions for C++
public __gc __interface ISIAPIOpposingmovement_ped
C++/CLI
public interface class ISIAPIOpposingmovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_ped Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_ped Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOpposingmovement_ped.

Public Properties

 | Name | Description
Property | Movement_vehicle_od |
Property | Opposing |
Property | Opposingmovement_ped_origin |
Property | Opposingmovement_ped_stage |
Property | Opposingmovement_ped_type |
Top

See Also

Reference

ISIAPIOpposingmovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_ped Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_ped Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_ped members.

Public Properties

 | Name | Description
Property | Movement_vehicle_od |
Property | Opposing |
Property | Opposingmovement_ped_origin |
Property | Opposingmovement_ped_stage |
Property | Opposingmovement_ped_type |
Top

See Also

Reference

ISIAPIOpposingmovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_ped Interface : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Interface
ISIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_ped Interface : Opposing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
Dim value As Boolean

instance.Opposing = value

value = instance.Opposing
C#
bool Opposing {get; set;}
Managed Extensions for C++
__property bool get_Opposing();
__property void set_Opposing(
   bool value
);
C++/CLI
property bool Opposing {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Interface
ISIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_ped Interface : Opposingmovement_ped_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_ped_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_origin
C#
int Opposingmovement_ped_origin {get;}
Managed Extensions for C++
__property int get_Opposingmovement_ped_origin();
C++/CLI
property int Opposingmovement_ped_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Interface
ISIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_ped Interface : Opposingmovement_ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_stage
C#
int Opposingmovement_ped_stage {get;}
Managed Extensions for C++
__property int get_Opposingmovement_ped_stage();
C++/CLI
property int Opposingmovement_ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Interface
ISIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_ped Interface : Opposingmovement_ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_ped
Dim value As Integer

value = instance.Opposingmovement_ped_type
C#
int Opposingmovement_ped_type {get;}
Managed Extensions for C++
__property int get_Opposingmovement_ped_type();
C++/CLI
property int Opposingmovement_ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_ped Interface
ISIAPIOpposingmovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_peds Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_peds Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOpposingmovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_peds
C#
public interface ISIAPIOpposingmovement_peds
Managed Extensions for C++
public __gc __interface ISIAPIOpposingmovement_peds
C++/CLI
public interface class ISIAPIOpposingmovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_peds Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_peds Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOpposingmovement_peds.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | OpposingmovementPedExists |
Top

See Also

Reference

ISIAPIOpposingmovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_peds Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_peds members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | OpposingmovementPedExists |
Top

See Also

Reference

ISIAPIOpposingmovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpposingmovementPedExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_peds Interface : OpposingmovementPedExists Method

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function OpposingmovementPedExists( _
   ByVal opposing_ped_type As Integer, _
   ByVal opposing_ped_origin As Integer, _
   ByVal opposin_ped_stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_peds
Dim opposing_ped_type As Integer
Dim opposing_ped_origin As Integer
Dim opposin_ped_stage As Integer
Dim value As Boolean

value = instance.OpposingmovementPedExists(opposing_ped_type, opposing_ped_origin, opposin_ped_stage)
C#
bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)
Managed Extensions for C++
bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)
C++/CLI
bool OpposingmovementPedExists(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
)

Parameters

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Interface
ISIAPIOpposingmovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_peds Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_peds members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIOpposingmovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_peds Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_peds
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Interface
ISIAPIOpposingmovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_peds Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(Int32,Int32,Int32) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Interface
ISIAPIOpposingmovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32,Int32,Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_peds Interface > Item Property : Item(Int32,Int32,Int32) Property

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal opposing_ped_type As Integer, _
   ByVal opposing_ped_origin As Integer, _
   ByVal opposin_ped_stage As Integer _
) As ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_peds
Dim opposing_ped_type As Integer
Dim opposing_ped_origin As Integer
Dim opposin_ped_stage As Integer
Dim value As ISIAPIOpposingmovement_ped

value = instance.Item(opposing_ped_type, opposing_ped_origin, opposin_ped_stage)
C#
ISIAPIOpposingmovement_ped Item(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
) {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_ped* get_Item(
   int opposing_ped_type,
   int opposing_ped_origin,
   int opposin_ped_stage
);
C++/CLI
property ISIAPIOpposingmovement_ped^ Item {
   ISIAPIOpposingmovement_ped^ get(int opposing_ped_type, int opposing_ped_origin, int opposin_ped_stage);
}

Parameters

opposing_ped_type
opposing_ped_origin
opposin_ped_stage

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Interface
ISIAPIOpposingmovement_peds Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_peds Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOpposingmovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_peds
Dim index As Integer
Dim value As ISIAPIOpposingmovement_ped

value = instance.Item(index)
C#
ISIAPIOpposingmovement_ped Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_ped* get_Item(
   int index
);
C++/CLI
property ISIAPIOpposingmovement_ped^ Item {
   ISIAPIOpposingmovement_ped^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_peds Interface
ISIAPIOpposingmovement_peds Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicle Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicle Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicle
C#
public interface ISIAPIOpposingmovement_vehicle
Managed Extensions for C++
public __gc __interface ISIAPIOpposingmovement_vehicle
C++/CLI
public interface class ISIAPIOpposingmovement_vehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicle Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicle Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOpposingmovement_vehicle.

Public Properties

 | Name | Description
Property | Movement_vehicle_od |
Property | Opposing |
Property | Opposingmovement_vehicle_destination |
Property | Opposingmovement_vehicle_origin |
Top

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicle Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicle Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_vehicle members.

Public Properties

 | Name | Description
Property | Movement_vehicle_od |
Property | Opposing |
Property | Opposingmovement_vehicle_destination |
Property | Opposingmovement_vehicle_origin |
Top

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_od Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicle Interface : Movement_vehicle_od Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_vehicle_od As ISIAPIMovement_vehicle_od
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicle
Dim value As ISIAPIMovement_vehicle_od

value = instance.Movement_vehicle_od
C#
ISIAPIMovement_vehicle_od Movement_vehicle_od {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_od* get_Movement_vehicle_od();
C++/CLI
property ISIAPIMovement_vehicle_od^ Movement_vehicle_od {
   ISIAPIMovement_vehicle_od^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
ISIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicle Interface : Opposing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Opposing As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicle
Dim value As Boolean

instance.Opposing = value

value = instance.Opposing
C#
bool Opposing {get; set;}
Managed Extensions for C++
__property bool get_Opposing();
__property void set_Opposing(
   bool value
);
C++/CLI
property bool Opposing {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
ISIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicle_destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicle Interface : Opposingmovement_vehicle_destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_vehicle_destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicle
Dim value As Integer

value = instance.Opposingmovement_vehicle_destination
C#
int Opposingmovement_vehicle_destination {get;}
Managed Extensions for C++
__property int get_Opposingmovement_vehicle_destination();
C++/CLI
property int Opposingmovement_vehicle_destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
ISIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposingmovement_vehicle_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicle Interface : Opposingmovement_vehicle_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposingmovement_vehicle_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicle
Dim value As Integer

value = instance.Opposingmovement_vehicle_origin
C#
int Opposingmovement_vehicle_origin {get;}
Managed Extensions for C++
__property int get_Opposingmovement_vehicle_origin();
C++/CLI
property int Opposingmovement_vehicle_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicle Interface
ISIAPIOpposingmovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicles Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicles Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOpposingmovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicles
C#
public interface ISIAPIOpposingmovement_vehicles
Managed Extensions for C++
public __gc __interface ISIAPIOpposingmovement_vehicles
C++/CLI
public interface class ISIAPIOpposingmovement_vehicles

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicles Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicles Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOpposingmovement_vehicles.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | OpposingmovementVehicleExists |
Top

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicles Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicles Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_vehicles members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | OpposingmovementVehicleExists |
Top

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OpposingmovementVehicleExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicles Interface : OpposingmovementVehicleExists Method

opposing_veh_origin
opposing_veh_destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function OpposingmovementVehicleExists( _
   ByVal opposing_veh_origin As Integer, _
   ByVal opposing_veh_destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicles
Dim opposing_veh_origin As Integer
Dim opposing_veh_destination As Integer
Dim value As Boolean

value = instance.OpposingmovementVehicleExists(opposing_veh_origin, opposing_veh_destination)
C#
bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)
Managed Extensions for C++
bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)
C++/CLI
bool OpposingmovementVehicleExists(
   int opposing_veh_origin,
   int opposing_veh_destination
)

Parameters

opposing_veh_origin
opposing_veh_destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
ISIAPIOpposingmovement_vehicles Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOpposingmovement_vehicles Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOpposingmovement_vehicles Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOpposingmovement_vehicles members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicles Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicles
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
ISIAPIOpposingmovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicles Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(Int32,Int32) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
ISIAPIOpposingmovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32,Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicles Interface > Item Property : Item(Int32,Int32) Property

opposing_veh_origin
opposing_veh_destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal opposing_veh_origin As Integer, _
   ByVal opposing_veh_destination As Integer _
) As ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicles
Dim opposing_veh_origin As Integer
Dim opposing_veh_destination As Integer
Dim value As ISIAPIOpposingmovement_vehicle

value = instance.Item(opposing_veh_origin, opposing_veh_destination)
C#
ISIAPIOpposingmovement_vehicle Item(
   int opposing_veh_origin,
   int opposing_veh_destination
) {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_vehicle* get_Item(
   int opposing_veh_origin,
   int opposing_veh_destination
);
C++/CLI
property ISIAPIOpposingmovement_vehicle^ Item {
   ISIAPIOpposingmovement_vehicle^ get(int opposing_veh_origin, int opposing_veh_destination);
}

Parameters

opposing_veh_origin
opposing_veh_destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
ISIAPIOpposingmovement_vehicles Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOpposingmovement_vehicles Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOpposingmovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOpposingmovement_vehicles
Dim index As Integer
Dim value As ISIAPIOpposingmovement_vehicle

value = instance.Item(index)
C#
ISIAPIOpposingmovement_vehicle Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIOpposingmovement_vehicle* get_Item(
   int index
);
C++/CLI
property ISIAPIOpposingmovement_vehicle^ Item {
   ISIAPIOpposingmovement_vehicle^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOpposingmovement_vehicles Interface
ISIAPIOpposingmovement_vehicles Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputAnalysis Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputAnalysis Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputAnalysis
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
C#
public interface ISIAPIOutputAnalysis
Managed Extensions for C++
public __gc __interface ISIAPIOutputAnalysis
C++/CLI
public interface class ISIAPIOutputAnalysis

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputAnalysis Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputAnalysis Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputAnalysis.

Public Properties

 | Name | Description
Property | Design_Life_Analysis_status |
Property | Design_Life_Selected_future_year |
Property | Flow_Scale_Analysis_status |
Property | Flow_Scale_Largest_movement_flow_scale |
Property | Sensitivity_Analysis_status |
Property | Sensitivity_Selected_parameter_scale |
Top

See Also

Reference

ISIAPIOutputAnalysis Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputAnalysis Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputAnalysis Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputAnalysis members.

Public Properties

 | Name | Description
Property | Design_Life_Analysis_status |
Property | Design_Life_Selected_future_year |
Property | Flow_Scale_Analysis_status |
Property | Flow_Scale_Largest_movement_flow_scale |
Property | Sensitivity_Analysis_status |
Property | Sensitivity_Selected_parameter_scale |
Top

See Also

Reference

ISIAPIOutputAnalysis Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Design_Life_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Design_Life_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Integer

value = instance.Design_Life_Analysis_status
C#
int Design_Life_Analysis_status {get;}
Managed Extensions for C++
__property int get_Design_Life_Analysis_status();
C++/CLI
property int Design_Life_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Design_Life_Selected_future_year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Design_Life_Selected_future_year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Design_Life_Selected_future_year As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Integer

value = instance.Design_Life_Selected_future_year
C#
int Design_Life_Selected_future_year {get;}
Managed Extensions for C++
__property int get_Design_Life_Selected_future_year();
C++/CLI
property int Design_Life_Selected_future_year {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Flow_Scale_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_Scale_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Integer

value = instance.Flow_Scale_Analysis_status
C#
int Flow_Scale_Analysis_status {get;}
Managed Extensions for C++
__property int get_Flow_Scale_Analysis_status();
C++/CLI
property int Flow_Scale_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_Scale_Largest_movement_flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Flow_Scale_Largest_movement_flow_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_Scale_Largest_movement_flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Single

value = instance.Flow_Scale_Largest_movement_flow_scale
C#
float Flow_Scale_Largest_movement_flow_scale {get;}
Managed Extensions for C++
__property float get_Flow_Scale_Largest_movement_flow_scale();
C++/CLI
property float Flow_Scale_Largest_movement_flow_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sensitivity_Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Sensitivity_Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Sensitivity_Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Integer

value = instance.Sensitivity_Analysis_status
C#
int Sensitivity_Analysis_status {get;}
Managed Extensions for C++
__property int get_Sensitivity_Analysis_status();
C++/CLI
property int Sensitivity_Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sensitivity_Selected_parameter_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputAnalysis Interface : Sensitivity_Selected_parameter_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Sensitivity_Selected_parameter_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputAnalysis
Dim value As Single

value = instance.Sensitivity_Selected_parameter_scale
C#
float Sensitivity_Selected_parameter_scale {get;}
Managed Extensions for C++
__property float get_Sensitivity_Selected_parameter_scale();
C++/CLI
property float Sensitivity_Selected_parameter_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputAnalysis Interface
ISIAPIOutputAnalysis Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLane Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLane Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputCirculatingLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
C#
public interface ISIAPIOutputCirculatingLane
Managed Extensions for C++
public __gc __interface ISIAPIOutputCirculatingLane
C++/CLI
public interface class ISIAPIOutputCirculatingLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLane Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLane Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputCirculatingLane.

Public Properties

 | Name | Description
Property | Laneno |
Property | Orientation |
Property | OutputLeg |
Property | Roucircf_pcu |
Property | Roucircf_percent |
Property | Roucircf_veh |
Top

See Also

Reference

ISIAPIOutputCirculatingLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLane Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLane Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputCirculatingLane members.

Public Properties

 | Name | Description
Property | Laneno |
Property | Orientation |
Property | OutputLeg |
Property | Roucircf_pcu |
Property | Roucircf_percent |
Property | Roucircf_veh |
Top

See Also

Reference

ISIAPIOutputCirculatingLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : Laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As Integer

value = instance.Laneno
C#
int Laneno {get;}
Managed Extensions for C++
__property int get_Laneno();
C++/CLI
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As Integer

value = instance.Orientation
C#
int Orientation {get;}
Managed Extensions for C++
__property int get_Orientation();
C++/CLI
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
__property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : Roucircf_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Roucircf_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_pcu
C#
float Roucircf_pcu {get;}
Managed Extensions for C++
__property float get_Roucircf_pcu();
C++/CLI
property float Roucircf_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : Roucircf_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Roucircf_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_percent
C#
float Roucircf_percent {get;}
Managed Extensions for C++
__property float get_Roucircf_percent();
C++/CLI
property float Roucircf_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Roucircf_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLane Interface : Roucircf_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Roucircf_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLane
Dim value As Single

value = instance.Roucircf_veh
C#
float Roucircf_veh {get;}
Managed Extensions for C++
__property float get_Roucircf_veh();
C++/CLI
property float Roucircf_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLane Interface
ISIAPIOutputCirculatingLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLanes Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLanes Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputCirculatingLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLanes
C#
public interface ISIAPIOutputCirculatingLanes
Managed Extensions for C++
public __gc __interface ISIAPIOutputCirculatingLanes
C++/CLI
public interface class ISIAPIOutputCirculatingLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLanes Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLanes Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputCirculatingLanes.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExists |
Top

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLanes Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputCirculatingLanes members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExists |
Top

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLanes Interface : LaneExists Method

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLanes
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExists(laneno)
C#
bool LaneExists(
   int laneno
)
Managed Extensions for C++
bool LaneExists(
   int laneno
)
C++/CLI
bool LaneExists(
   int laneno
)

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
ISIAPIOutputCirculatingLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputCirculatingLanes Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputCirculatingLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputCirculatingLanes members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLanes Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLanes
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
ISIAPIOutputCirculatingLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputCirculatingLanes Interface : Item Property

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPIOutputCirculatingLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputCirculatingLanes
Dim laneno As Integer
Dim value As ISIAPIOutputCirculatingLane

value = instance.Item(laneno)
C#
ISIAPIOutputCirculatingLane this[
   int laneno
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputCirculatingLane* get_Item   int laneno
;
C++/CLI
property ISIAPIOutputCirculatingLane^ default [int] {
   ISIAPIOutputCirculatingLane^ get(int laneno);
}

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputCirculatingLanes Interface
ISIAPIOutputCirculatingLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuple Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuple Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
C#
public interface ISIAPIOutputGraphTuple
Managed Extensions for C++
public __gc __interface ISIAPIOutputGraphTuple
C++/CLI
public interface class ISIAPIOutputGraphTuple

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuple Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuple Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputGraphTuple.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Arrival_flow_total_person |
Property | Capacity_effective |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_total |
Property | Cycle_time |
Property | Deg_satn |
Property | Deg_satn_ped |
Property | Delay_control_average |
Property | Delay_control_average_ped |
Property | Delay_control_average_veh |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_average_worstmov_ped |
Property | Delay_control_average_worstmov_person |
Property | Delay_control_total_ped |
Property | Delay_control_total_person |
Property | Delay_control_total_veh |
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Demand_flow_total |
Property | Demand_flow_total_ped |
Property | Demand_flow_total_person |
Property | Fuel_consumption_total |
Property | Hydrocarbons_total |
Property | Level_of_service |
Property | Level_of_service_ped |
Property | Level_of_service_veh |
Property | Nox_total |
Property | Operating_cost_total |
Property | Operating_cost_total_ped |
Property | Operating_cost_total_veh |
Property | Perc_heavy_veh |
Property | Performance_index |
Property | Performance_index_ped |
Property | Performance_index_veh |
Property | Practical_spare_capacity |
Property | Prop_queued_ped |
Property | Prop_queued_person |
Property | Prop_queued_veh |
Property | Queue_dist_maxback_percentile |
Property | Queue_maxback_percentile |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stop_rate_ped |
Property | Stop_rate_veh |
Property | Total_stops_ped |
Property | Total_stops_person |
Property | Total_stops_veh |
Property | Travel_dist_av_ped |
Property | Travel_dist_av_person |
Property | Travel_dist_av_veh |
Property | Travel_dist_total_ped |
Property | Travel_dist_total_person |
Property | Travel_dist_total_veh |
Property | Travel_speed |
Property | Travel_speed_ped |
Property | Travel_speed_person |
Property | Travel_time_av_ped |
Property | Travel_time_av_person |
Property | Travel_time_av_veh |
Property | Travel_time_total_ped |
Property | Travel_time_total_person |
Property | Travel_time_total_veh |
Property | Unsettled |
Property | X_value |
Top

See Also

Reference

ISIAPIOutputGraphTuple Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuple Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuple Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputGraphTuple members.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Arrival_flow_total_person |
Property | Capacity_effective |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_total |
Property | Cycle_time |
Property | Deg_satn |
Property | Deg_satn_ped |
Property | Delay_control_average |
Property | Delay_control_average_ped |
Property | Delay_control_average_veh |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_average_worstmov_ped |
Property | Delay_control_average_worstmov_person |
Property | Delay_control_total_ped |
Property | Delay_control_total_person |
Property | Delay_control_total_veh |
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Demand_flow_total |
Property | Demand_flow_total_ped |
Property | Demand_flow_total_person |
Property | Fuel_consumption_total |
Property | Hydrocarbons_total |
Property | Level_of_service |
Property | Level_of_service_ped |
Property | Level_of_service_veh |
Property | Nox_total |
Property | Operating_cost_total |
Property | Operating_cost_total_ped |
Property | Operating_cost_total_veh |
Property | Perc_heavy_veh |
Property | Performance_index |
Property | Performance_index_ped |
Property | Performance_index_veh |
Property | Practical_spare_capacity |
Property | Prop_queued_ped |
Property | Prop_queued_person |
Property | Prop_queued_veh |
Property | Queue_dist_maxback_percentile |
Property | Queue_maxback_percentile |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stop_rate_ped |
Property | Stop_rate_veh |
Property | Total_stops_ped |
Property | Total_stops_person |
Property | Total_stops_veh |
Property | Travel_dist_av_ped |
Property | Travel_dist_av_person |
Property | Travel_dist_av_veh |
Property | Travel_dist_total_ped |
Property | Travel_dist_total_person |
Property | Travel_dist_total_veh |
Property | Travel_speed |
Property | Travel_speed_ped |
Property | Travel_speed_person |
Property | Travel_time_av_ped |
Property | Travel_time_av_person |
Property | Travel_time_av_veh |
Property | Travel_time_total_ped |
Property | Travel_time_total_person |
Property | Travel_time_total_veh |
Property | Unsettled |
Property | X_value |
Top

See Also

Reference

ISIAPIOutputGraphTuple Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Arrival_flow_total
C#
float Arrival_flow_total {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total();
C++/CLI
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Arrival_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Arrival_flow_total_person
C#
float Arrival_flow_total_person {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total_person();
C++/CLI
property float Arrival_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Capacity_effective
C#
float Capacity_effective {get;}
Managed Extensions for C++
__property float get_Capacity_effective();
C++/CLI
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Cycle_time
C#
float Cycle_time {get;}
Managed Extensions for C++
__property float get_Cycle_time();
C++/CLI
property float Cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Deg_satn_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Deg_satn_ped
C#
float Deg_satn_ped {get;}
Managed Extensions for C++
__property float get_Deg_satn_ped();
C++/CLI
property float Deg_satn_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_ped
C#
float Delay_control_average_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_average_ped();
C++/CLI
property float Delay_control_average_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_veh
C#
float Delay_control_average_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_average_veh();
C++/CLI
property float Delay_control_average_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
float Delay_control_average_worstlane {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstlane();
C++/CLI
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_worstmov_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_ped
C#
float Delay_control_average_worstmov_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov_ped();
C++/CLI
property float Delay_control_average_worstmov_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_average_worstmov_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_person
C#
float Delay_control_average_worstmov_person {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov_person();
C++/CLI
property float Delay_control_average_worstmov_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_ped
C#
float Delay_control_total_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_total_ped();
C++/CLI
property float Delay_control_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_person
C#
float Delay_control_total_person {get;}
Managed Extensions for C++
__property float get_Delay_control_total_person();
C++/CLI
property float Delay_control_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_control_total_veh
C#
float Delay_control_total_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_total_veh();
C++/CLI
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_geometric_average
C#
float Delay_geometric_average {get;}
Managed Extensions for C++
__property float get_Delay_geometric_average();
C++/CLI
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Demand_flow_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total_ped
C#
float Demand_flow_total_ped {get;}
Managed Extensions for C++
__property float get_Demand_flow_total_ped();
C++/CLI
property float Demand_flow_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Demand_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Demand_flow_total_person
C#
float Demand_flow_total_person {get;}
Managed Extensions for C++
__property float get_Demand_flow_total_person();
C++/CLI
property float Demand_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service
C#
int Level_of_service {get;}
Managed Extensions for C++
__property int get_Level_of_service();
C++/CLI
property int Level_of_service {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Level_of_service_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_ped As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service_ped
C#
int Level_of_service_ped {get;}
Managed Extensions for C++
__property int get_Level_of_service_ped();
C++/CLI
property int Level_of_service_ped {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Level_of_service_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_veh As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Integer

value = instance.Level_of_service_veh
C#
int Level_of_service_veh {get;}
Managed Extensions for C++
__property int get_Level_of_service_veh();
C++/CLI
property int Level_of_service_veh {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Operating_cost_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total_ped
C#
float Operating_cost_total_ped {get;}
Managed Extensions for C++
__property float get_Operating_cost_total_ped();
C++/CLI
property float Operating_cost_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Operating_cost_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Operating_cost_total_veh
C#
float Operating_cost_total_veh {get;}
Managed Extensions for C++
__property float get_Operating_cost_total_veh();
C++/CLI
property float Operating_cost_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_heavy_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Perc_heavy_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Perc_heavy_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Perc_heavy_veh
C#
float Perc_heavy_veh {get;}
Managed Extensions for C++
__property float get_Perc_heavy_veh();
C++/CLI
property float Perc_heavy_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Performance_index_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index_ped
C#
float Performance_index_ped {get;}
Managed Extensions for C++
__property float get_Performance_index_ped();
C++/CLI
property float Performance_index_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Performance_index_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Performance_index_veh
C#
float Performance_index_veh {get;}
Managed Extensions for C++
__property float get_Performance_index_veh();
C++/CLI
property float Performance_index_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Prop_queued_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_ped
C#
float Prop_queued_ped {get;}
Managed Extensions for C++
__property float get_Prop_queued_ped();
C++/CLI
property float Prop_queued_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Prop_queued_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_person
C#
float Prop_queued_person {get;}
Managed Extensions for C++
__property float get_Prop_queued_person();
C++/CLI
property float Prop_queued_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Prop_queued_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Prop_queued_veh
C#
float Prop_queued_veh {get;}
Managed Extensions for C++
__property float get_Prop_queued_veh();
C++/CLI
property float Prop_queued_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Stop_rate_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate_ped
C#
float Stop_rate_ped {get;}
Managed Extensions for C++
__property float get_Stop_rate_ped();
C++/CLI
property float Stop_rate_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Stop_rate_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Stop_rate_veh
C#
float Stop_rate_veh {get;}
Managed Extensions for C++
__property float get_Stop_rate_veh();
C++/CLI
property float Stop_rate_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Total_stops_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_ped
C#
float Total_stops_ped {get;}
Managed Extensions for C++
__property float get_Total_stops_ped();
C++/CLI
property float Total_stops_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Total_stops_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_person
C#
float Total_stops_person {get;}
Managed Extensions for C++
__property float get_Total_stops_person();
C++/CLI
property float Total_stops_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Total_stops_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Total_stops_veh
C#
float Total_stops_veh {get;}
Managed Extensions for C++
__property float get_Total_stops_veh();
C++/CLI
property float Total_stops_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_ped
C#
float Travel_dist_av_ped {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_ped();
C++/CLI
property float Travel_dist_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_person
C#
float Travel_dist_av_person {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_person();
C++/CLI
property float Travel_dist_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_av_veh
C#
float Travel_dist_av_veh {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_veh();
C++/CLI
property float Travel_dist_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_ped
C#
float Travel_dist_total_ped {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_ped();
C++/CLI
property float Travel_dist_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_person
C#
float Travel_dist_total_person {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_person();
C++/CLI
property float Travel_dist_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_dist_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_dist_total_veh
C#
float Travel_dist_total_veh {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_veh();
C++/CLI
property float Travel_dist_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_speed_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed_ped
C#
float Travel_speed_ped {get;}
Managed Extensions for C++
__property float get_Travel_speed_ped();
C++/CLI
property float Travel_speed_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_speed_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_speed_person
C#
float Travel_speed_person {get;}
Managed Extensions for C++
__property float get_Travel_speed_person();
C++/CLI
property float Travel_speed_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_ped
C#
float Travel_time_av_ped {get;}
Managed Extensions for C++
__property float get_Travel_time_av_ped();
C++/CLI
property float Travel_time_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_person
C#
float Travel_time_av_person {get;}
Managed Extensions for C++
__property float get_Travel_time_av_person();
C++/CLI
property float Travel_time_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_av_veh
C#
float Travel_time_av_veh {get;}
Managed Extensions for C++
__property float get_Travel_time_av_veh();
C++/CLI
property float Travel_time_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_ped
C#
float Travel_time_total_ped {get;}
Managed Extensions for C++
__property float get_Travel_time_total_ped();
C++/CLI
property float Travel_time_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_person
C#
float Travel_time_total_person {get;}
Managed Extensions for C++
__property float get_Travel_time_total_person();
C++/CLI
property float Travel_time_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Travel_time_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.Travel_time_total_veh
C#
float Travel_time_total_veh {get;}
Managed Extensions for C++
__property float get_Travel_time_total_veh();
C++/CLI
property float Travel_time_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unsettled Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : Unsettled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unsettled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Boolean

value = instance.Unsettled
C#
bool Unsettled {get;}
Managed Extensions for C++
__property bool get_Unsettled();
C++/CLI
property bool Unsettled {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X_value Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuple Interface : X_value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property X_value As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuple
Dim value As Single

value = instance.X_value
C#
float X_value {get;}
Managed Extensions for C++
__property float get_X_value();
C++/CLI
property float X_value {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuple Interface
ISIAPIOutputGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuples Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuples Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuples
C#
public interface ISIAPIOutputGraphTuples
Managed Extensions for C++
public __gc __interface ISIAPIOutputGraphTuples
C++/CLI
public interface class ISIAPIOutputGraphTuples

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuples Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuples Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuples Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputGraphTuples.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuples Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuples Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputGraphTuples members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuples Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuples
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuples Interface
ISIAPIOutputGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputGraphTuples Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputGraphTuples
Dim index As Integer
Dim value As ISIAPIOutputGraphTuple

value = instance.Item(index)
C#
ISIAPIOutputGraphTuple this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputGraphTuple* get_Item   int index
;
C++/CLI
property ISIAPIOutputGraphTuple^ default [int] {
   ISIAPIOutputGraphTuple^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputGraphTuples Interface
ISIAPIOutputGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLane Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLane Interface

Glossary Item Box

SIDRA INTERSECTION Output Lane wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
C#
public interface ISIAPIOutputLane
Managed Extensions for C++
public __gc __interface ISIAPIOutputLane
C++/CLI
public interface class ISIAPIOutputLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLane Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLane Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLane.

Public Properties

 | Name | Description
Property | Adjfactor_buses |
Property | Adjfactor_flowscale |
Property | Adjfactor_grade |
Property | Adjfactor_lanewidth |
Property | Adjfactor_parking |
Property | Adjfactor_trafficflow |
Property | Arrival_flow_flag |
Property | Average_queue_space |
Property | Avg_num_of_cycles_to_depart |
Property | Calc_mf_flag |
Property | Capacity | Capacity (veh/h) total for both green periods.
Property | Capacity_adj |
Property | Capacity_adj_flag |
Property | Capacity_end_deps | Capacity (veh/h) due to "end departures" (Signals only).
Property | Capacity_min | Minimum Capacity (veh/h) (Roundabouts/Sign Control only).
Property | Capacity_shortlane_affected | Flag indicating if short lane affects capacity.
Property | Contlane_affect_by_adjshortlane |
Property | Control_type |
Property | Deg_satn |
Property | Delay_acc_dec_dn |
Property | Delay_ctrl | Average control delay (sec/veh).
Property | Delay_geo | Geometric delay (sec/veh).
Property | Delay_idle | Idle delay (sec/veh).
Property | Delay_model_1 | Model delay (sec/veh) 1st term.
Property | Delay_model_2 | Model delay (sec/veh) 2nd term.
Property | Delay_n | Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.
Property | Delay_q | "Queuing" ("stopped") delay.
Property | Delay_queue_moveup |
Property | Driver_response_time |
Property | Equivalent_AT |
Property | Flag_na |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Headway_scats_mf |
Property | Initial_demand_vol |
Property | Initial_demand_vol_clear_time |
Property | Is_dominant |
Property | Is_nw_connected |
Property | Lane_block_adj |
Property | Lane_change_from_left |
Property | Lane_change_from_right |
Property | Lane_change_to_left |
Property | Lane_change_to_right |
Property | Laneno |
Property | Level_of_service | Lane LOS.
Property | Minimum_delay |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | Occupancy_scats_mf |
Property | Opposing_ped_factor |
Property | Orientation |
Property | OutputLaneGreenPeriods |
Property | OutputLaneMCs |
Property | OutputLaneODs |
Property | OutputLeg |
Property | Oversatn_duration |
Property | Perc_arriving_during_green |
Property | Platoon_ratio |
Property | Prob_blockage | Probability of blockage.
Property | Prob_shortlane_overflow |
Property | Progression_factor_delay |
Property | Progression_factor_queue |
Property | Prop_queued | Proportion queued.
Property | Queue_constraint_flag |
Property | Queue_cycav_1 | Cycle-average queue (veh), 1st term.
Property | Queue_cycav_2 | Cycle-average queue (veh), 2nd term.
Property | Queue_cycav_mean | Cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_1 | Maximum back of queue (veh), 1st term.
Property | Queue_maxback_2 | Maximum back of queue (veh), 2nd term.
Property | Queue_maxback_mean | Maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Maximum back of queue (veh), user-specified percentile.
Property | Queue_overflow | Overflow queue (veh).
Property | Queue_space | Queue space averaged over LV & HV in the lane.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | Residual_demand_vol |
Property | Residual_demand_vol_clear_time |
Property | Satflow_basic | "Adjusted Basic" saturation flow (tcu).
Property | Satflow_basic_adj |
Property | Satflow_scats | "SCATS" saturation flow.
Property | Satflow_scats_mf | "SCATS" MF.
Property | Satn_flow |
Property | Satn_headway |
Property | Satn_spacing |
Property | Satn_speed |
Property | Shortlane_flow_moved | Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.
Property | Space_scats_mf |
Property | Stop_rate |
Property | Stoprate_1 | Stop rate 1st term.
Property | Stoprate_2 | Stop rate 2nd term.
Property | Stoprate_geo | "Geometric" stop rate.
Property | Stoprate_overall | Overall Stop Rate.
Property | Stoprate_qmovup | Queue move up rate (sum of both green periods).
Property | T2_reduced | Flag indicating if second terms reduced due to short lane effects.
Property | Total_stops |
Property | Unblocked_time_ratio |
Property | Underutil_flag | Reason for lane underutilisation.
Property | Upstr_flow_after_exit_sl |
Property | Util_factor | Utilisation factor determined by the program.
Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

ISIAPIOutputLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLane Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLane Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLane members.

Public Properties

 | Name | Description
Property | Adjfactor_buses |
Property | Adjfactor_flowscale |
Property | Adjfactor_grade |
Property | Adjfactor_lanewidth |
Property | Adjfactor_parking |
Property | Adjfactor_trafficflow |
Property | Arrival_flow_flag |
Property | Average_queue_space |
Property | Avg_num_of_cycles_to_depart |
Property | Calc_mf_flag |
Property | Capacity | Capacity (veh/h) total for both green periods.
Property | Capacity_adj |
Property | Capacity_adj_flag |
Property | Capacity_end_deps | Capacity (veh/h) due to "end departures" (Signals only).
Property | Capacity_min | Minimum Capacity (veh/h) (Roundabouts/Sign Control only).
Property | Capacity_shortlane_affected | Flag indicating if short lane affects capacity.
Property | Contlane_affect_by_adjshortlane |
Property | Control_type |
Property | Deg_satn |
Property | Delay_acc_dec_dn |
Property | Delay_ctrl | Average control delay (sec/veh).
Property | Delay_geo | Geometric delay (sec/veh).
Property | Delay_idle | Idle delay (sec/veh).
Property | Delay_model_1 | Model delay (sec/veh) 1st term.
Property | Delay_model_2 | Model delay (sec/veh) 2nd term.
Property | Delay_n | Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.
Property | Delay_q | "Queuing" ("stopped") delay.
Property | Delay_queue_moveup |
Property | Driver_response_time |
Property | Equivalent_AT |
Property | Flag_na |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Headway_scats_mf |
Property | Initial_demand_vol |
Property | Initial_demand_vol_clear_time |
Property | Is_dominant |
Property | Is_nw_connected |
Property | Lane_block_adj |
Property | Lane_change_from_left |
Property | Lane_change_from_right |
Property | Lane_change_to_left |
Property | Lane_change_to_right |
Property | Laneno |
Property | Level_of_service | Lane LOS.
Property | Minimum_delay |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | Occupancy_scats_mf |
Property | Opposing_ped_factor |
Property | Orientation |
Property | OutputLaneGreenPeriods |
Property | OutputLaneMCs |
Property | OutputLaneODs |
Property | OutputLeg |
Property | Oversatn_duration |
Property | Perc_arriving_during_green |
Property | Platoon_ratio |
Property | Prob_blockage | Probability of blockage.
Property | Prob_shortlane_overflow |
Property | Progression_factor_delay |
Property | Progression_factor_queue |
Property | Prop_queued | Proportion queued.
Property | Queue_constraint_flag |
Property | Queue_cycav_1 | Cycle-average queue (veh), 1st term.
Property | Queue_cycav_2 | Cycle-average queue (veh), 2nd term.
Property | Queue_cycav_mean | Cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_1 | Maximum back of queue (veh), 1st term.
Property | Queue_maxback_2 | Maximum back of queue (veh), 2nd term.
Property | Queue_maxback_mean | Maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Maximum back of queue (veh), user-specified percentile.
Property | Queue_overflow | Overflow queue (veh).
Property | Queue_space | Queue space averaged over LV & HV in the lane.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | Residual_demand_vol |
Property | Residual_demand_vol_clear_time |
Property | Satflow_basic | "Adjusted Basic" saturation flow (tcu).
Property | Satflow_basic_adj |
Property | Satflow_scats | "SCATS" saturation flow.
Property | Satflow_scats_mf | "SCATS" MF.
Property | Satn_flow |
Property | Satn_headway |
Property | Satn_spacing |
Property | Satn_speed |
Property | Shortlane_flow_moved | Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.
Property | Space_scats_mf |
Property | Stop_rate |
Property | Stoprate_1 | Stop rate 1st term.
Property | Stoprate_2 | Stop rate 2nd term.
Property | Stoprate_geo | "Geometric" stop rate.
Property | Stoprate_overall | Overall Stop Rate.
Property | Stoprate_qmovup | Queue move up rate (sum of both green periods).
Property | T2_reduced | Flag indicating if second terms reduced due to short lane effects.
Property | Total_stops |
Property | Unblocked_time_ratio |
Property | Underutil_flag | Reason for lane underutilisation.
Property | Upstr_flow_after_exit_sl |
Property | Util_factor | Utilisation factor determined by the program.
Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

ISIAPIOutputLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_buses Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_buses Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_buses As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_buses
C#
float Adjfactor_buses {get;}
Managed Extensions for C++
__property float get_Adjfactor_buses();
C++/CLI
property float Adjfactor_buses {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_flowscale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_flowscale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_flowscale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_flowscale
C#
float Adjfactor_flowscale {get;}
Managed Extensions for C++
__property float get_Adjfactor_flowscale();
C++/CLI
property float Adjfactor_flowscale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_grade Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_grade Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_grade As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_grade
C#
float Adjfactor_grade {get;}
Managed Extensions for C++
__property float get_Adjfactor_grade();
C++/CLI
property float Adjfactor_grade {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_lanewidth Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_lanewidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_lanewidth As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_lanewidth
C#
float Adjfactor_lanewidth {get;}
Managed Extensions for C++
__property float get_Adjfactor_lanewidth();
C++/CLI
property float Adjfactor_lanewidth {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_parking Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_parking Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_parking As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_parking
C#
float Adjfactor_parking {get;}
Managed Extensions for C++
__property float get_Adjfactor_parking();
C++/CLI
property float Adjfactor_parking {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjfactor_trafficflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Adjfactor_trafficflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjfactor_trafficflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Adjfactor_trafficflow
C#
float Adjfactor_trafficflow {get;}
Managed Extensions for C++
__property float get_Adjfactor_trafficflow();
C++/CLI
property float Adjfactor_trafficflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Average_queue_space Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Average_queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Average_queue_space
C#
float Average_queue_space {get;}
Managed Extensions for C++
__property float get_Average_queue_space();
C++/CLI
property float Average_queue_space {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
__property float get_Avg_num_of_cycles_to_depart();
C++/CLI
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_mf_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Calc_mf_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Calc_mf_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Calc_mf_flag
C#
int Calc_mf_flag {get;}
Managed Extensions for C++
__property int get_Calc_mf_flag();
C++/CLI
property int Calc_mf_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity Property

Glossary Item Box

Capacity (veh/h) total for both green periods.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Capacity
C#
float Capacity {get;}
Managed Extensions for C++
__property float get_Capacity();
C++/CLI
property float Capacity {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Capacity_adj
C#
float Capacity_adj {get;}
Managed Extensions for C++
__property float get_Capacity_adj();
C++/CLI
property float Capacity_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity_adj_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Capacity_adj_flag
C#
int Capacity_adj_flag {get;}
Managed Extensions for C++
__property int get_Capacity_adj_flag();
C++/CLI
property int Capacity_adj_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_end_deps Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity_end_deps Property

Glossary Item Box

Capacity (veh/h) due to "end departures" (Signals only).

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_end_deps As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Capacity_end_deps
C#
float Capacity_end_deps {get;}
Managed Extensions for C++
__property float get_Capacity_end_deps();
C++/CLI
property float Capacity_end_deps {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_min Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity_min Property

Glossary Item Box

Minimum Capacity (veh/h) (Roundabouts/Sign Control only).

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_min As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Capacity_min
C#
float Capacity_min {get;}
Managed Extensions for C++
__property float get_Capacity_min();
C++/CLI
property float Capacity_min {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_shortlane_affected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Capacity_shortlane_affected Property

Glossary Item Box

Flag indicating if short lane affects capacity.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_shortlane_affected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Boolean

value = instance.Capacity_shortlane_affected
C#
bool Capacity_shortlane_affected {get;}
Managed Extensions for C++
__property bool get_Capacity_shortlane_affected();
C++/CLI
property bool Capacity_shortlane_affected {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Contlane_affect_by_adjshortlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Contlane_affect_by_adjshortlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Contlane_affect_by_adjshortlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Contlane_affect_by_adjshortlane
C#
int Contlane_affect_by_adjshortlane {get;}
Managed Extensions for C++
__property int get_Contlane_affect_by_adjshortlane();
C++/CLI
property int Contlane_affect_by_adjshortlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Control_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Control_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Control_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Control_type
C#
int Control_type {get;}
Managed Extensions for C++
__property int get_Control_type();
C++/CLI
property int Control_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_acc_dec_dn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_acc_dec_dn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_acc_dec_dn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_acc_dec_dn
C#
float Delay_acc_dec_dn {get;}
Managed Extensions for C++
__property float get_Delay_acc_dec_dn();
C++/CLI
property float Delay_acc_dec_dn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_ctrl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_ctrl Property

Glossary Item Box

Average control delay (sec/veh).

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_ctrl As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_ctrl
C#
float Delay_ctrl {get;}
Managed Extensions for C++
__property float get_Delay_ctrl();
C++/CLI
property float Delay_ctrl {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geo Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_geo Property

Glossary Item Box

Geometric delay (sec/veh).

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geo As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_geo
C#
float Delay_geo {get;}
Managed Extensions for C++
__property float get_Delay_geo();
C++/CLI
property float Delay_geo {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_idle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_idle Property

Glossary Item Box

Idle delay (sec/veh).

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_idle As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_idle
C#
float Delay_idle {get;}
Managed Extensions for C++
__property float get_Delay_idle();
C++/CLI
property float Delay_idle {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_model_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_model_1 Property

Glossary Item Box

Model delay (sec/veh) 1st term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_model_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_model_1
C#
float Delay_model_1 {get;}
Managed Extensions for C++
__property float get_Delay_model_1();
C++/CLI
property float Delay_model_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_model_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_model_2 Property

Glossary Item Box

Model delay (sec/veh) 2nd term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_model_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_model_2
C#
float Delay_model_2 {get;}
Managed Extensions for C++
__property float get_Delay_model_2();
C++/CLI
property float Delay_model_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_n Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_n Property

Glossary Item Box

Accel/Decel delay (the difference between "stopped" delay and model delay). LV value only used.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_n As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_n
C#
float Delay_n {get;}
Managed Extensions for C++
__property float get_Delay_n();
C++/CLI
property float Delay_n {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_q Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_q Property

Glossary Item Box

"Queuing" ("stopped") delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_q As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_q
C#
float Delay_q {get;}
Managed Extensions for C++
__property float get_Delay_q();
C++/CLI
property float Delay_q {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_queue_moveup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Delay_queue_moveup Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_queue_moveup As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Delay_queue_moveup
C#
float Delay_queue_moveup {get;}
Managed Extensions for C++
__property float get_Delay_queue_moveup();
C++/CLI
property float Delay_queue_moveup {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Driver_response_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Driver_response_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Driver_response_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Driver_response_time
C#
float Driver_response_time {get;}
Managed Extensions for C++
__property float get_Driver_response_time();
C++/CLI
property float Driver_response_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Equivalent_AT
C#
int Equivalent_AT {get;}
Managed Extensions for C++
__property int get_Equivalent_AT();
C++/CLI
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flag_na Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flag_na Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flag_na As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Flag_na
C#
int Flag_na {get;}
Managed Extensions for C++
__property int get_Flag_na();
C++/CLI
property int Flag_na {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_HV
C#
float Flow_HV {get;}
Managed Extensions for C++
__property float get_Flow_HV();
C++/CLI
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_capconstr
C#
float Flow_HV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_capconstr();
C++/CLI
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_HV_pct Property

Glossary Item Box

Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_pct
C#
float Flow_HV_pct {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct();
C++/CLI
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct_capconstr();
C++/CLI
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_LV
C#
float Flow_LV {get;}
Managed Extensions for C++
__property float get_Flow_LV();
C++/CLI
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_LV_capconstr
C#
float Flow_LV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_LV_capconstr();
C++/CLI
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_total
C#
float Flow_total {get;}
Managed Extensions for C++
__property float get_Flow_total();
C++/CLI
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Flow_total_capconstr
C#
float Flow_total_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_total_capconstr();
C++/CLI
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
float Gap_accept_blocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_blocked_time();
C++/CLI
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
float Gap_accept_cycle_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_cycle_time();
C++/CLI
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_unblocked_time();
C++/CLI
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Green_periods
C#
int Green_periods {get;}
Managed Extensions for C++
__property int get_Green_periods();
C++/CLI
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Headway_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Headway_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Headway_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Headway_scats_mf
C#
float Headway_scats_mf {get;}
Managed Extensions for C++
__property float get_Headway_scats_mf();
C++/CLI
property float Headway_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Initial_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Initial_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Initial_demand_vol
C#
float Initial_demand_vol {get;}
Managed Extensions for C++
__property float get_Initial_demand_vol();
C++/CLI
property float Initial_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Initial_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Initial_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Initial_demand_vol_clear_time
C#
float Initial_demand_vol_clear_time {get;}
Managed Extensions for C++
__property float get_Initial_demand_vol_clear_time();
C++/CLI
property float Initial_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_dominant Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Is_dominant Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Is_dominant As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Boolean

value = instance.Is_dominant
C#
bool Is_dominant {get;}
Managed Extensions for C++
__property bool get_Is_dominant();
C++/CLI
property bool Is_dominant {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_nw_connected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Is_nw_connected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Is_nw_connected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Boolean

value = instance.Is_nw_connected
C#
bool Is_nw_connected {get;}
Managed Extensions for C++
__property bool get_Is_nw_connected();
C++/CLI
property bool Is_nw_connected {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_block_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Lane_block_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_block_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Lane_block_adj
C#
float Lane_block_adj {get;}
Managed Extensions for C++
__property float get_Lane_block_adj();
C++/CLI
property float Lane_block_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Lane_change_from_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_from_left As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Lane_change_from_left
C#
float Lane_change_from_left {get;}
Managed Extensions for C++
__property float get_Lane_change_from_left();
C++/CLI
property float Lane_change_from_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Lane_change_from_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_from_right As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Lane_change_from_right
C#
float Lane_change_from_right {get;}
Managed Extensions for C++
__property float get_Lane_change_from_right();
C++/CLI
property float Lane_change_from_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Lane_change_to_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Lane_change_to_left
C#
float Lane_change_to_left {get;}
Managed Extensions for C++
__property float get_Lane_change_to_left();
C++/CLI
property float Lane_change_to_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Lane_change_to_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Lane_change_to_right
C#
float Lane_change_to_right {get;}
Managed Extensions for C++
__property float get_Lane_change_to_right();
C++/CLI
property float Lane_change_to_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Laneno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Laneno Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Laneno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Laneno
C#
int Laneno {get;}
Managed Extensions for C++
__property int get_Laneno();
C++/CLI
property int Laneno {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Level_of_service Property

Glossary Item Box

Lane LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Minimum_delay
C#
float Minimum_delay {get;}
Managed Extensions for C++
__property float get_Minimum_delay();
C++/CLI
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Net_inflow
C#
float Net_inflow {get;}
Managed Extensions for C++
__property float get_Net_inflow();
C++/CLI
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Net_inflow_capconstr
C#
float Net_inflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_inflow_capconstr();
C++/CLI
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Net_outflow
C#
float Net_outflow {get;}
Managed Extensions for C++
__property float get_Net_outflow();
C++/CLI
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Net_outflow_capconstr
C#
float Net_outflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_outflow_capconstr();
C++/CLI
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Occupancy_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Occupancy_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Occupancy_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Occupancy_scats_mf
C#
float Occupancy_scats_mf {get;}
Managed Extensions for C++
__property float get_Occupancy_scats_mf();
C++/CLI
property float Occupancy_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_ped_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Opposing_ped_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_ped_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Opposing_ped_factor
C#
float Opposing_ped_factor {get;}
Managed Extensions for C++
__property float get_Opposing_ped_factor();
C++/CLI
property float Opposing_ped_factor {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Orientation
C#
int Orientation {get;}
Managed Extensions for C++
__property int get_Orientation();
C++/CLI
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneGreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : OutputLaneGreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLaneGreenPeriods As ISIAPIOutputLaneGreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As ISIAPIOutputLaneGreenPeriods

value = instance.OutputLaneGreenPeriods
C#
ISIAPIOutputLaneGreenPeriods OutputLaneGreenPeriods {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneGreenPeriods* get_OutputLaneGreenPeriods();
C++/CLI
property ISIAPIOutputLaneGreenPeriods^ OutputLaneGreenPeriods {
   ISIAPIOutputLaneGreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : OutputLaneMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLaneMCs As ISIAPIOutputLaneMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As ISIAPIOutputLaneMCs

value = instance.OutputLaneMCs
C#
ISIAPIOutputLaneMCs OutputLaneMCs {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneMCs* get_OutputLaneMCs();
C++/CLI
property ISIAPIOutputLaneMCs^ OutputLaneMCs {
   ISIAPIOutputLaneMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : OutputLaneODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLaneODs As ISIAPIOutputLaneODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As ISIAPIOutputLaneODs

value = instance.OutputLaneODs
C#
ISIAPIOutputLaneODs OutputLaneODs {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneODs* get_OutputLaneODs();
C++/CLI
property ISIAPIOutputLaneODs^ OutputLaneODs {
   ISIAPIOutputLaneODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
__property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Oversatn_duration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Oversatn_duration Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Oversatn_duration As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Oversatn_duration
C#
float Oversatn_duration {get;}
Managed Extensions for C++
__property float get_Oversatn_duration();
C++/CLI
property float Oversatn_duration {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Perc_arriving_during_green
C#
float Perc_arriving_during_green {get;}
Managed Extensions for C++
__property float get_Perc_arriving_during_green();
C++/CLI
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Platoon_ratio
C#
float Platoon_ratio {get;}
Managed Extensions for C++
__property float get_Platoon_ratio();
C++/CLI
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prob_blockage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Prob_blockage Property

Glossary Item Box

Probability of blockage.

Syntax

Visual Basic (Declaration)
ReadOnly Property Prob_blockage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Prob_blockage
C#
float Prob_blockage {get;}
Managed Extensions for C++
__property float get_Prob_blockage();
C++/CLI
property float Prob_blockage {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prob_shortlane_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Prob_shortlane_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prob_shortlane_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Prob_shortlane_overflow
C#
float Prob_shortlane_overflow {get;}
Managed Extensions for C++
__property float get_Prob_shortlane_overflow();
C++/CLI
property float Prob_shortlane_overflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Progression_factor_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Progression_factor_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Progression_factor_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Progression_factor_delay
C#
float Progression_factor_delay {get;}
Managed Extensions for C++
__property float get_Progression_factor_delay();
C++/CLI
property float Progression_factor_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Progression_factor_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Progression_factor_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Progression_factor_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Progression_factor_queue
C#
float Progression_factor_queue {get;}
Managed Extensions for C++
__property float get_Progression_factor_queue();
C++/CLI
property float Progression_factor_queue {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Prop_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Prop_queued
C#
float Prop_queued {get;}
Managed Extensions for C++
__property float get_Prop_queued();
C++/CLI
property float Prop_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_constraint_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_constraint_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_constraint_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Queue_constraint_flag
C#
int Queue_constraint_flag {get;}
Managed Extensions for C++
__property int get_Queue_constraint_flag();
C++/CLI
property int Queue_constraint_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_cycav_1 Property

Glossary Item Box

Cycle-average queue (veh), 1st term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_1
C#
float Queue_cycav_1 {get;}
Managed Extensions for C++
__property float get_Queue_cycav_1();
C++/CLI
property float Queue_cycav_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_cycav_2 Property

Glossary Item Box

Cycle-average queue (veh), 2nd term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_2
C#
float Queue_cycav_2 {get;}
Managed Extensions for C++
__property float get_Queue_cycav_2();
C++/CLI
property float Queue_cycav_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_cycav_mean Property

Glossary Item Box

Cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_mean
C#
float Queue_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_cycav_mean();
C++/CLI
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_cycav_percentile Property

Glossary Item Box

Cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_cycav_percentile
C#
float Queue_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_cycav_percentile();
C++/CLI
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_mean();
C++/CLI
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_percentile();
C++/CLI
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_mean();
C++/CLI
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_percentile();
C++/CLI
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_greenstart_mean
C#
float Queue_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_mean();
C++/CLI
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
float Queue_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_percentile();
C++/CLI
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_maxback_1 Property

Glossary Item Box

Maximum back of queue (veh), 1st term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_1
C#
float Queue_maxback_1 {get;}
Managed Extensions for C++
__property float get_Queue_maxback_1();
C++/CLI
property float Queue_maxback_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_maxback_2 Property

Glossary Item Box

Maximum back of queue (veh), 2nd term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_2
C#
float Queue_maxback_2 {get;}
Managed Extensions for C++
__property float get_Queue_maxback_2();
C++/CLI
property float Queue_maxback_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_maxback_mean Property

Glossary Item Box

Maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_maxback_percentile Property

Glossary Item Box

Maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_overflow Property

Glossary Item Box

Overflow queue (veh).

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_overflow
C#
float Queue_overflow {get;}
Managed Extensions for C++
__property float get_Queue_overflow();
C++/CLI
property float Queue_overflow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_space Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_space Property

Glossary Item Box

Queue space averaged over LV & HV in the lane.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_space As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_space
C#
float Queue_space {get;}
Managed Extensions for C++
__property float get_Queue_space();
C++/CLI
property float Queue_space {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_avg();
C++/CLI
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_percentile();
C++/CLI
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Residual_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Residual_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Residual_demand_vol
C#
float Residual_demand_vol {get;}
Managed Extensions for C++
__property float get_Residual_demand_vol();
C++/CLI
property float Residual_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Residual_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Residual_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Residual_demand_vol_clear_time
C#
float Residual_demand_vol_clear_time {get;}
Managed Extensions for C++
__property float get_Residual_demand_vol_clear_time();
C++/CLI
property float Residual_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_basic Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satflow_basic Property

Glossary Item Box

"Adjusted Basic" saturation flow (tcu).

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_basic As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satflow_basic
C#
float Satflow_basic {get;}
Managed Extensions for C++
__property float get_Satflow_basic();
C++/CLI
property float Satflow_basic {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_basic_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satflow_basic_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_basic_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satflow_basic_adj
C#
float Satflow_basic_adj {get;}
Managed Extensions for C++
__property float get_Satflow_basic_adj();
C++/CLI
property float Satflow_basic_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_scats Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satflow_scats Property

Glossary Item Box

"SCATS" saturation flow.

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_scats As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satflow_scats
C#
float Satflow_scats {get;}
Managed Extensions for C++
__property float get_Satflow_scats();
C++/CLI
property float Satflow_scats {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satflow_scats_mf Property

Glossary Item Box

"SCATS" MF.

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satflow_scats_mf
C#
float Satflow_scats_mf {get;}
Managed Extensions for C++
__property float get_Satflow_scats_mf();
C++/CLI
property float Satflow_scats_mf {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satn_flow
C#
float Satn_flow {get;}
Managed Extensions for C++
__property float get_Satn_flow();
C++/CLI
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satn_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satn_headway
C#
float Satn_headway {get;}
Managed Extensions for C++
__property float get_Satn_headway();
C++/CLI
property float Satn_headway {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_spacing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satn_spacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_spacing As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satn_spacing
C#
float Satn_spacing {get;}
Managed Extensions for C++
__property float get_Satn_spacing();
C++/CLI
property float Satn_spacing {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Satn_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Satn_speed
C#
float Satn_speed {get;}
Managed Extensions for C++
__property float get_Satn_speed();
C++/CLI
property float Satn_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_flow_moved Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Shortlane_flow_moved Property

Glossary Item Box

Flag indicating if flow moved out of this lane to adjacent lane due to short lane effects.

Syntax

Visual Basic (Declaration)
ReadOnly Property Shortlane_flow_moved As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Boolean

value = instance.Shortlane_flow_moved
C#
bool Shortlane_flow_moved {get;}
Managed Extensions for C++
__property bool get_Shortlane_flow_moved();
C++/CLI
property bool Shortlane_flow_moved {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Space_scats_mf Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Space_scats_mf Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Space_scats_mf As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Space_scats_mf
C#
float Space_scats_mf {get;}
Managed Extensions for C++
__property float get_Space_scats_mf();
C++/CLI
property float Space_scats_mf {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_1 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stoprate_1 Property

Glossary Item Box

Stop rate 1st term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stoprate_1 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stoprate_1
C#
float Stoprate_1 {get;}
Managed Extensions for C++
__property float get_Stoprate_1();
C++/CLI
property float Stoprate_1 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stoprate_2 Property

Glossary Item Box

Stop rate 2nd term.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stoprate_2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stoprate_2
C#
float Stoprate_2 {get;}
Managed Extensions for C++
__property float get_Stoprate_2();
C++/CLI
property float Stoprate_2 {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_geo Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stoprate_geo Property

Glossary Item Box

"Geometric" stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stoprate_geo As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stoprate_geo
C#
float Stoprate_geo {get;}
Managed Extensions for C++
__property float get_Stoprate_geo();
C++/CLI
property float Stoprate_geo {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_overall Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stoprate_overall Property

Glossary Item Box

Overall Stop Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stoprate_overall As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stoprate_overall
C#
float Stoprate_overall {get;}
Managed Extensions for C++
__property float get_Stoprate_overall();
C++/CLI
property float Stoprate_overall {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stoprate_qmovup Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Stoprate_qmovup Property

Glossary Item Box

Queue move up rate (sum of both green periods).

Syntax

Visual Basic (Declaration)
ReadOnly Property Stoprate_qmovup As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Stoprate_qmovup
C#
float Stoprate_qmovup {get;}
Managed Extensions for C++
__property float get_Stoprate_qmovup();
C++/CLI
property float Stoprate_qmovup {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
T2_reduced Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : T2_reduced Property

Glossary Item Box

Flag indicating if second terms reduced due to short lane effects.

Syntax

Visual Basic (Declaration)
ReadOnly Property T2_reduced As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Boolean

value = instance.T2_reduced
C#
bool T2_reduced {get;}
Managed Extensions for C++
__property bool get_T2_reduced();
C++/CLI
property bool T2_reduced {
   bool get();
}

Property Value

Type: System.Boolean

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Total_stops Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Total_stops
C#
float Total_stops {get;}
Managed Extensions for C++
__property float get_Total_stops();
C++/CLI
property float Total_stops {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Unblocked_time_ratio
C#
float Unblocked_time_ratio {get;}
Managed Extensions for C++
__property float get_Unblocked_time_ratio();
C++/CLI
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Underutil_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Underutil_flag Property

Glossary Item Box

Reason for lane underutilisation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Underutil_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.Underutil_flag
C#
int Underutil_flag {get;}
Managed Extensions for C++
__property int get_Underutil_flag();
C++/CLI
property int Underutil_flag {
   int get();
}

Property Value

Type: System.Int32

0 = not underutilised
1 = program
2 = downstream
3 = user-specified

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upstr_flow_after_exit_sl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Upstr_flow_after_exit_sl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Upstr_flow_after_exit_sl As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Upstr_flow_after_exit_sl
C#
float Upstr_flow_after_exit_sl {get;}
Managed Extensions for C++
__property float get_Upstr_flow_after_exit_sl();
C++/CLI
property float Upstr_flow_after_exit_sl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Util_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : Util_factor Property

Glossary Item Box

Utilisation factor determined by the program.

Syntax

Visual Basic (Declaration)
ReadOnly Property Util_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Single

value = instance.Util_factor
C#
float Util_factor {get;}
Managed Extensions for C++
__property float get_Util_factor();
C++/CLI
property float Util_factor {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLane Interface : X1_flag Property

Glossary Item Box

Degree of saturation = 1 flag.

Syntax

Visual Basic (Declaration)
ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLane
Dim value As Integer

value = instance.X1_flag
C#
int X1_flag {get;}
Managed Extensions for C++
__property int get_X1_flag();
C++/CLI
property int X1_flag {
   int get();
}

Property Value

Type: System.Int32

0 = x != 1
1 = x = 1 due to short lane
2 = x = 1 due to minimum capacity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLane Interface
ISIAPIOutputLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriod Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriod Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneGreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
C#
public interface ISIAPIOutputLaneGreenPeriod
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneGreenPeriod
C++/CLI
public interface class ISIAPIOutputLaneGreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriod Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriod Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneGreenPeriod.

Public Properties

 | Name | Description
Property | Capacity |
Property | Depflow_gt_adjsatn |
Property | Eff_green_end |
Property | Eff_green_start |
Property | End_sat_green |
Property | Flow_ratio |
Property | Green_end_time |
Property | Green_ratio |
Property | Green_satn_time |
Property | Green_start_time |
Property | GreenPeriod | Green Period value is a one-based integer.
Property | OutputLane |
Property | Queclearance_time |
Property | Queue_discharge_rate |
Property | Residual_queue |
Property | Satflow_full |
Property | Satflow_laneblock_adj |
Property | Satflow_queuecleartime_adj |
Property | Satflow_reduced |
Property | Shortlane_effect |
Property | Subcycle |
Top

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriod Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriod Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneGreenPeriod members.

Public Properties

 | Name | Description
Property | Capacity |
Property | Depflow_gt_adjsatn |
Property | Eff_green_end |
Property | Eff_green_start |
Property | End_sat_green |
Property | Flow_ratio |
Property | Green_end_time |
Property | Green_ratio |
Property | Green_satn_time |
Property | Green_start_time |
Property | GreenPeriod | Green Period value is a one-based integer.
Property | OutputLane |
Property | Queclearance_time |
Property | Queue_discharge_rate |
Property | Residual_queue |
Property | Satflow_full |
Property | Satflow_laneblock_adj |
Property | Satflow_queuecleartime_adj |
Property | Satflow_reduced |
Property | Shortlane_effect |
Property | Subcycle |
Top

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Capacity
C#
float Capacity {get;}
Managed Extensions for C++
__property float get_Capacity();
C++/CLI
property float Capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Depflow_gt_adjsatn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Depflow_gt_adjsatn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Depflow_gt_adjsatn As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Depflow_gt_adjsatn
C#
int Depflow_gt_adjsatn {get;}
Managed Extensions for C++
__property int get_Depflow_gt_adjsatn();
C++/CLI
property int Depflow_gt_adjsatn {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green_end Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Eff_green_end Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_green_end As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Eff_green_end
C#
int Eff_green_end {get;}
Managed Extensions for C++
__property int get_Eff_green_end();
C++/CLI
property int Eff_green_end {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green_start Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Eff_green_start Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_green_start As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Eff_green_start
C#
int Eff_green_start {get;}
Managed Extensions for C++
__property int get_Eff_green_start();
C++/CLI
property int Eff_green_start {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_sat_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : End_sat_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property End_sat_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.End_sat_green
C#
int End_sat_green {get;}
Managed Extensions for C++
__property int get_End_sat_green();
C++/CLI
property int End_sat_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
float Flow_ratio {get;}
Managed Extensions for C++
__property float get_Flow_ratio();
C++/CLI
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Green_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Green_end_time
C#
int Green_end_time {get;}
Managed Extensions for C++
__property int get_Green_end_time();
C++/CLI
property int Green_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Green_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Green_ratio
C#
float Green_ratio {get;}
Managed Extensions for C++
__property float get_Green_ratio();
C++/CLI
property float Green_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_satn_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Green_satn_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_satn_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Green_satn_time
C#
float Green_satn_time {get;}
Managed Extensions for C++
__property float get_Green_satn_time();
C++/CLI
property float Green_satn_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Green_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Green_start_time
C#
int Green_start_time {get;}
Managed Extensions for C++
__property int get_Green_start_time();
C++/CLI
property int Green_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : GreenPeriod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property GreenPeriod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.GreenPeriod
C#
int GreenPeriod {get;}
Managed Extensions for C++
__property int get_GreenPeriod();
C++/CLI
property int GreenPeriod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
__property ISIAPIOutputLane* get_OutputLane();
C++/CLI
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queclearance_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Queclearance_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queclearance_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Queclearance_time
C#
float Queclearance_time {get;}
Managed Extensions for C++
__property float get_Queclearance_time();
C++/CLI
property float Queclearance_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_discharge_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Queue_discharge_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_discharge_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Queue_discharge_rate
C#
float Queue_discharge_rate {get;}
Managed Extensions for C++
__property float get_Queue_discharge_rate();
C++/CLI
property float Queue_discharge_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_queue Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Residual_queue Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Residual_queue As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Residual_queue
C#
float Residual_queue {get;}
Managed Extensions for C++
__property float get_Residual_queue();
C++/CLI
property float Residual_queue {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_full Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Satflow_full Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_full As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_full
C#
float Satflow_full {get;}
Managed Extensions for C++
__property float get_Satflow_full();
C++/CLI
property float Satflow_full {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_laneblock_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Satflow_laneblock_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_laneblock_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_laneblock_adj
C#
float Satflow_laneblock_adj {get;}
Managed Extensions for C++
__property float get_Satflow_laneblock_adj();
C++/CLI
property float Satflow_laneblock_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_queuecleartime_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Satflow_queuecleartime_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_queuecleartime_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_queuecleartime_adj
C#
float Satflow_queuecleartime_adj {get;}
Managed Extensions for C++
__property float get_Satflow_queuecleartime_adj();
C++/CLI
property float Satflow_queuecleartime_adj {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satflow_reduced Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Satflow_reduced Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satflow_reduced As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Single

value = instance.Satflow_reduced
C#
float Satflow_reduced {get;}
Managed Extensions for C++
__property float get_Satflow_reduced();
C++/CLI
property float Satflow_reduced {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Shortlane_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Shortlane_effect As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Boolean

value = instance.Shortlane_effect
C#
bool Shortlane_effect {get;}
Managed Extensions for C++
__property bool get_Shortlane_effect();
C++/CLI
property bool Shortlane_effect {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Subcycle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriod Interface : Subcycle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Subcycle As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriod
Dim value As Integer

value = instance.Subcycle
C#
int Subcycle {get;}
Managed Extensions for C++
__property int get_Subcycle();
C++/CLI
property int Subcycle {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriod Interface
ISIAPIOutputLaneGreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriods Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriods Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneGreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriods
C#
public interface ISIAPIOutputLaneGreenPeriods
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneGreenPeriods
C++/CLI
public interface class ISIAPIOutputLaneGreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriods Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriods Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneGreenPeriods.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an Approach Lane Output Green Period Data. Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriods Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneGreenPeriods members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriods Interface : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether an Approach Lane Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
ISIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneGreenPeriods Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneGreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneGreenPeriods members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an Approach Lane Output Green Period Data. Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriods Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriods
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
ISIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneGreenPeriods Interface : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get an Approach Lane Output Green Period Data.
Return an Approach Lane Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputLaneGreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneGreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputLaneGreenPeriod

value = instance.Item(greenperiod)
C#
ISIAPIOutputLaneGreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneGreenPeriod* get_Item   int greenperiod
;
C++/CLI
property ISIAPIOutputLaneGreenPeriod^ default [int] {
   ISIAPIOutputLaneGreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneGreenPeriods Interface
ISIAPIOutputLaneGreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
C#
public interface ISIAPIOutputLaneMC
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneMC
C++/CLI
public interface class ISIAPIOutputLaneMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneMC.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Calc_exists |
Property | Exist_in_nw_upstream_only |
Property | Flow_total |
Property | Flow_total_capconstr |
Property | Lane_change_from_left |
Property | Lane_change_from_right |
Property | Lane_change_to_left |
Property | Lane_change_to_right |
Property | MC_class |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | OutputLane |
Property | Upstr_flow_after_exit_sl |
Top

See Also

Reference

ISIAPIOutputLaneMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneMC members.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Calc_exists |
Property | Exist_in_nw_upstream_only |
Property | Flow_total |
Property | Flow_total_capconstr |
Property | Lane_change_from_left |
Property | Lane_change_from_right |
Property | Lane_change_to_left |
Property | Lane_change_to_right |
Property | MC_class |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | OutputLane |
Property | Upstr_flow_after_exit_sl |
Top

See Also

Reference

ISIAPIOutputLaneMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Boolean

value = instance.Calc_exists
C#
bool Calc_exists {get;}
Managed Extensions for C++
__property bool get_Calc_exists();
C++/CLI
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exist_in_nw_upstream_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Exist_in_nw_upstream_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exist_in_nw_upstream_only As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Boolean

value = instance.Exist_in_nw_upstream_only
C#
bool Exist_in_nw_upstream_only {get;}
Managed Extensions for C++
__property bool get_Exist_in_nw_upstream_only();
C++/CLI
property bool Exist_in_nw_upstream_only {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Flow_total
C#
float Flow_total {get;}
Managed Extensions for C++
__property float get_Flow_total();
C++/CLI
property float Flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Flow_total_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Flow_total_capconstr
C#
float Flow_total_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_total_capconstr();
C++/CLI
property float Flow_total_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Lane_change_from_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_from_left As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_from_left
C#
float Lane_change_from_left {get;}
Managed Extensions for C++
__property float get_Lane_change_from_left();
C++/CLI
property float Lane_change_from_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_from_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Lane_change_from_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_from_right As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_from_right
C#
float Lane_change_from_right {get;}
Managed Extensions for C++
__property float get_Lane_change_from_right();
C++/CLI
property float Lane_change_from_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_left Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Lane_change_to_left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_to_left As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_to_left
C#
float Lane_change_to_left {get;}
Managed Extensions for C++
__property float get_Lane_change_to_left();
C++/CLI
property float Lane_change_to_left {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_change_to_right Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Lane_change_to_right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_change_to_right As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Lane_change_to_right
C#
float Lane_change_to_right {get;}
Managed Extensions for C++
__property float get_Lane_change_to_right();
C++/CLI
property float Lane_change_to_right {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Net_inflow
C#
float Net_inflow {get;}
Managed Extensions for C++
__property float get_Net_inflow();
C++/CLI
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Net_inflow_capconstr
C#
float Net_inflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_inflow_capconstr();
C++/CLI
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
__property ISIAPIOutputLane* get_OutputLane();
C++/CLI
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upstr_flow_after_exit_sl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMC Interface : Upstr_flow_after_exit_sl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Upstr_flow_after_exit_sl As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMC
Dim value As Single

value = instance.Upstr_flow_after_exit_sl
C#
float Upstr_flow_after_exit_sl {get;}
Managed Extensions for C++
__property float get_Upstr_flow_after_exit_sl();
C++/CLI
property float Upstr_flow_after_exit_sl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMC Interface
ISIAPIOutputLaneMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMCs
C#
public interface ISIAPIOutputLaneMCs
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneMCs
C++/CLI
public interface class ISIAPIOutputLaneMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLaneMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLaneMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMCs Interface : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMCs Interface
ISIAPIOutputLaneMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLaneMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMCs Interface
ISIAPIOutputLaneMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneMCs Interface : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLaneMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLaneMC

value = instance.Item(mcClass)
C#
ISIAPIOutputLaneMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneMC* get_Item   int mcClass
;
C++/CLI
property ISIAPIOutputLaneMC^ default [int] {
   ISIAPIOutputLaneMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneMCs Interface
ISIAPIOutputLaneMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneOD Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneOD Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
C#
public interface ISIAPIOutputLaneOD
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneOD
C++/CLI
public interface class ISIAPIOutputLaneOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneOD Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneOD Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneOD.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Average_speed |
Property | Average_speed_flag |
Property | Calc_exists |
Property | Cap_constraint_effect |
Property | Crit_gap |
Property | Crit_gap_flag |
Property | Critical_spacing |
Property | Destination |
Property | Flow |
Property | Flow_capconstr |
Property | Foll_up_hdwy |
Property | Foll_up_hdwy_flag |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | HVE_for_entry |
Property | HVE_pcu |
Property | Intrabunch_headway |
Property | Intrabunch_headway_flag |
Property | Lane_output_type |
Property | Minimum_delay |
Property | OD_factor |
Property | OD_factor_flag |
Property | Opposing_flow |
Property | Opposing_flow_flag |
Property | Opposing_flow_pcu |
Property | Opposing_flow_ped |
Property | Opposing_flow_ped_flag |
Property | OutputLane |
Property | OutputLaneODMCs |
Property | Percent_exit_flow_incl |
Property | Percent_nearest_lane_only |
Property | Priority_sharing_flag |
Property | Proportion_bunched |
Property | Proportion_bunched_flag |
Property | Subdom_eq_dom |
Property | Unblocked_time_ratio |
Top

See Also

Reference

ISIAPIOutputLaneOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneOD Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneOD Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneOD members.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Average_speed |
Property | Average_speed_flag |
Property | Calc_exists |
Property | Cap_constraint_effect |
Property | Crit_gap |
Property | Crit_gap_flag |
Property | Critical_spacing |
Property | Destination |
Property | Flow |
Property | Flow_capconstr |
Property | Foll_up_hdwy |
Property | Foll_up_hdwy_flag |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | HVE_for_entry |
Property | HVE_pcu |
Property | Intrabunch_headway |
Property | Intrabunch_headway_flag |
Property | Lane_output_type |
Property | Minimum_delay |
Property | OD_factor |
Property | OD_factor_flag |
Property | Opposing_flow |
Property | Opposing_flow_flag |
Property | Opposing_flow_pcu |
Property | Opposing_flow_ped |
Property | Opposing_flow_ped_flag |
Property | OutputLane |
Property | OutputLaneODMCs |
Property | Percent_exit_flow_incl |
Property | Percent_nearest_lane_only |
Property | Priority_sharing_flag |
Property | Proportion_bunched |
Property | Proportion_bunched_flag |
Property | Subdom_eq_dom |
Property | Unblocked_time_ratio |
Top

See Also

Reference

ISIAPIOutputLaneOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Average_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Average_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Average_speed
C#
float Average_speed {get;}
Managed Extensions for C++
__property float get_Average_speed();
C++/CLI
property float Average_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_speed_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Average_speed_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Average_speed_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Average_speed_flag
C#
int Average_speed_flag {get;}
Managed Extensions for C++
__property int get_Average_speed_flag();
C++/CLI
property int Average_speed_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Boolean

value = instance.Calc_exists
C#
bool Calc_exists {get;}
Managed Extensions for C++
__property bool get_Calc_exists();
C++/CLI
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cap_constraint_effect Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Cap_constraint_effect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cap_constraint_effect As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Cap_constraint_effect
C#
int Cap_constraint_effect {get;}
Managed Extensions for C++
__property int get_Cap_constraint_effect();
C++/CLI
property int Cap_constraint_effect {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crit_gap Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Crit_gap Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Crit_gap As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Crit_gap
C#
float Crit_gap {get;}
Managed Extensions for C++
__property float get_Crit_gap();
C++/CLI
property float Crit_gap {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Crit_gap_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Crit_gap_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Crit_gap_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Crit_gap_flag
C#
int Crit_gap_flag {get;}
Managed Extensions for C++
__property int get_Crit_gap_flag();
C++/CLI
property int Crit_gap_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_spacing Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Critical_spacing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_spacing As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Critical_spacing
C#
float Critical_spacing {get;}
Managed Extensions for C++
__property float get_Critical_spacing();
C++/CLI
property float Critical_spacing {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Flow
C#
float Flow {get;}
Managed Extensions for C++
__property float get_Flow();
C++/CLI
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Flow_capconstr
C#
float Flow_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_capconstr();
C++/CLI
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Foll_up_hdwy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Foll_up_hdwy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Foll_up_hdwy As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Foll_up_hdwy
C#
float Foll_up_hdwy {get;}
Managed Extensions for C++
__property float get_Foll_up_hdwy();
C++/CLI
property float Foll_up_hdwy {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Foll_up_hdwy_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Foll_up_hdwy_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Foll_up_hdwy_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Foll_up_hdwy_flag
C#
int Foll_up_hdwy_flag {get;}
Managed Extensions for C++
__property int get_Foll_up_hdwy_flag();
C++/CLI
property int Foll_up_hdwy_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
float Gap_accept_blocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_blocked_time();
C++/CLI
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
float Gap_accept_cycle_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_cycle_time();
C++/CLI
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_unblocked_time();
C++/CLI
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HVE_for_entry Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : HVE_for_entry Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property HVE_for_entry As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.HVE_for_entry
C#
float HVE_for_entry {get;}
Managed Extensions for C++
__property float get_HVE_for_entry();
C++/CLI
property float HVE_for_entry {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HVE_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : HVE_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property HVE_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.HVE_pcu
C#
float HVE_pcu {get;}
Managed Extensions for C++
__property float get_HVE_pcu();
C++/CLI
property float HVE_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intrabunch_headway Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Intrabunch_headway Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Intrabunch_headway As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Intrabunch_headway
C#
float Intrabunch_headway {get;}
Managed Extensions for C++
__property float get_Intrabunch_headway();
C++/CLI
property float Intrabunch_headway {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intrabunch_headway_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Intrabunch_headway_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Intrabunch_headway_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Intrabunch_headway_flag
C#
int Intrabunch_headway_flag {get;}
Managed Extensions for C++
__property int get_Intrabunch_headway_flag();
C++/CLI
property int Intrabunch_headway_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_output_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Lane_output_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lane_output_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Lane_output_type
C#
int Lane_output_type {get;}
Managed Extensions for C++
__property int get_Lane_output_type();
C++/CLI
property int Lane_output_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Minimum_delay
C#
float Minimum_delay {get;}
Managed Extensions for C++
__property float get_Minimum_delay();
C++/CLI
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OD_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : OD_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OD_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.OD_factor
C#
float OD_factor {get;}
Managed Extensions for C++
__property float get_OD_factor();
C++/CLI
property float OD_factor {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OD_factor_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : OD_factor_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OD_factor_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.OD_factor_flag
C#
int OD_factor_flag {get;}
Managed Extensions for C++
__property int get_OD_factor_flag();
C++/CLI
property int OD_factor_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Opposing_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow
C#
float Opposing_flow {get;}
Managed Extensions for C++
__property float get_Opposing_flow();
C++/CLI
property float Opposing_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Opposing_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Opposing_flow_flag
C#
int Opposing_flow_flag {get;}
Managed Extensions for C++
__property int get_Opposing_flow_flag();
C++/CLI
property int Opposing_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Opposing_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow_pcu
C#
float Opposing_flow_pcu {get;}
Managed Extensions for C++
__property float get_Opposing_flow_pcu();
C++/CLI
property float Opposing_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Opposing_flow_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_flow_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Opposing_flow_ped
C#
float Opposing_flow_ped {get;}
Managed Extensions for C++
__property float get_Opposing_flow_ped();
C++/CLI
property float Opposing_flow_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposing_flow_ped_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Opposing_flow_ped_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposing_flow_ped_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Opposing_flow_ped_flag
C#
int Opposing_flow_ped_flag {get;}
Managed Extensions for C++
__property int get_Opposing_flow_ped_flag();
C++/CLI
property int Opposing_flow_ped_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : OutputLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLane As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As ISIAPIOutputLane

value = instance.OutputLane
C#
ISIAPIOutputLane OutputLane {get;}
Managed Extensions for C++
__property ISIAPIOutputLane* get_OutputLane();
C++/CLI
property ISIAPIOutputLane^ OutputLane {
   ISIAPIOutputLane^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : OutputLaneODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLaneODMCs As ISIAPIOutputLaneODMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As ISIAPIOutputLaneODMCs

value = instance.OutputLaneODMCs
C#
ISIAPIOutputLaneODMCs OutputLaneODMCs {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneODMCs* get_OutputLaneODMCs();
C++/CLI
property ISIAPIOutputLaneODMCs^ OutputLaneODMCs {
   ISIAPIOutputLaneODMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_exit_flow_incl Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Percent_exit_flow_incl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Percent_exit_flow_incl As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Percent_exit_flow_incl
C#
float Percent_exit_flow_incl {get;}
Managed Extensions for C++
__property float get_Percent_exit_flow_incl();
C++/CLI
property float Percent_exit_flow_incl {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Percent_nearest_lane_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Percent_nearest_lane_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Percent_nearest_lane_only As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Percent_nearest_lane_only
C#
float Percent_nearest_lane_only {get;}
Managed Extensions for C++
__property float get_Percent_nearest_lane_only();
C++/CLI
property float Percent_nearest_lane_only {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority_sharing_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Priority_sharing_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Priority_sharing_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Priority_sharing_flag
C#
int Priority_sharing_flag {get;}
Managed Extensions for C++
__property int get_Priority_sharing_flag();
C++/CLI
property int Priority_sharing_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_bunched Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Proportion_bunched Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_bunched As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Proportion_bunched
C#
float Proportion_bunched {get;}
Managed Extensions for C++
__property float get_Proportion_bunched();
C++/CLI
property float Proportion_bunched {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_bunched_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Proportion_bunched_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_bunched_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Integer

value = instance.Proportion_bunched_flag
C#
int Proportion_bunched_flag {get;}
Managed Extensions for C++
__property int get_Proportion_bunched_flag();
C++/CLI
property int Proportion_bunched_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Subdom_eq_dom Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Subdom_eq_dom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Subdom_eq_dom As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Boolean

value = instance.Subdom_eq_dom
C#
bool Subdom_eq_dom {get;}
Managed Extensions for C++
__property bool get_Subdom_eq_dom();
C++/CLI
property bool Subdom_eq_dom {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneOD Interface : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneOD
Dim value As Single

value = instance.Unblocked_time_ratio
C#
float Unblocked_time_ratio {get;}
Managed Extensions for C++
__property float get_Unblocked_time_ratio();
C++/CLI
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneOD Interface
ISIAPIOutputLaneOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneODMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
C#
public interface ISIAPIOutputLaneODMC
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneODMC
C++/CLI
public interface class ISIAPIOutputLaneODMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneODMC.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Calc_exists |
Property | Flow |
Property | Flow_capconstr |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | MC_class |
Property | Minimum_delay |
Property | OutputLaneOD |
Property | Shortlane_overflow |
Property | Sl_overflow |
Property | Unblocked_time_ratio |
Top

See Also

Reference

ISIAPIOutputLaneODMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneODMC members.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Calc_exists |
Property | Flow |
Property | Flow_capconstr |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | MC_class |
Property | Minimum_delay |
Property | OutputLaneOD |
Property | Shortlane_overflow |
Property | Sl_overflow |
Property | Unblocked_time_ratio |
Top

See Also

Reference

ISIAPIOutputLaneODMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Boolean

value = instance.Calc_exists
C#
bool Calc_exists {get;}
Managed Extensions for C++
__property bool get_Calc_exists();
C++/CLI
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Flow
C#
float Flow {get;}
Managed Extensions for C++
__property float get_Flow();
C++/CLI
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Flow_capconstr
C#
float Flow_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_capconstr();
C++/CLI
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
float Gap_accept_blocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_blocked_time();
C++/CLI
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
float Gap_accept_cycle_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_cycle_time();
C++/CLI
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_unblocked_time();
C++/CLI
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Minimum_delay
C#
float Minimum_delay {get;}
Managed Extensions for C++
__property float get_Minimum_delay();
C++/CLI
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLaneOD Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : OutputLaneOD Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLaneOD As ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As ISIAPIOutputLaneOD

value = instance.OutputLaneOD
C#
ISIAPIOutputLaneOD OutputLaneOD {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneOD* get_OutputLaneOD();
C++/CLI
property ISIAPIOutputLaneOD^ OutputLaneOD {
   ISIAPIOutputLaneOD^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Shortlane_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Shortlane_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Shortlane_overflow As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Boolean

value = instance.Shortlane_overflow
C#
bool Shortlane_overflow {get;}
Managed Extensions for C++
__property bool get_Shortlane_overflow();
C++/CLI
property bool Shortlane_overflow {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sl_overflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Sl_overflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Sl_overflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Sl_overflow
C#
float Sl_overflow {get;}
Managed Extensions for C++
__property float get_Sl_overflow();
C++/CLI
property float Sl_overflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMC Interface : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMC
Dim value As Single

value = instance.Unblocked_time_ratio
C#
float Unblocked_time_ratio {get;}
Managed Extensions for C++
__property float get_Unblocked_time_ratio();
C++/CLI
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMC Interface
ISIAPIOutputLaneODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneODMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMCs
C#
public interface ISIAPIOutputLaneODMCs
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneODMCs
C++/CLI
public interface class ISIAPIOutputLaneODMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneODMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLaneODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneODMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLaneODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMCs Interface : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMCs Interface
ISIAPIOutputLaneODMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneODMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLaneODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMCs Interface
ISIAPIOutputLaneODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODMCs Interface : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLaneODMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLaneODMC

value = instance.Item(mcClass)
C#
ISIAPIOutputLaneODMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneODMC* get_Item   int mcClass
;
C++/CLI
property ISIAPIOutputLaneODMC^ default [int] {
   ISIAPIOutputLaneODMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODMCs Interface
ISIAPIOutputLaneODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLaneODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODs
C#
public interface ISIAPIOutputLaneODs
Managed Extensions for C++
public __gc __interface ISIAPIOutputLaneODs
C++/CLI
public interface class ISIAPIOutputLaneODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLaneODs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneODExists |
Top

See Also

Reference

ISIAPIOutputLaneODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneODs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneODExists |
Top

See Also

Reference

ISIAPIOutputLaneODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneODExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODs Interface : LaneODExists Method

destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneODExists( _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODs
Dim destination As Integer
Dim value As Boolean

value = instance.LaneODExists(destination)
C#
bool LaneODExists(
   int destination
)
Managed Extensions for C++
bool LaneODExists(
   int destination
)
C++/CLI
bool LaneODExists(
   int destination
)

Parameters

destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODs Interface
ISIAPIOutputLaneODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLaneODs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLaneODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLaneODs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLaneODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODs Interface
ISIAPIOutputLaneODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLaneODs Interface : Item Property

destination

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal destination As Integer _
) As ISIAPIOutputLaneOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLaneODs
Dim destination As Integer
Dim value As ISIAPIOutputLaneOD

value = instance.Item(destination)
C#
ISIAPIOutputLaneOD this[
   int destination
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLaneOD* get_Item   int destination
;
C++/CLI
property ISIAPIOutputLaneOD^ default [int] {
   ISIAPIOutputLaneOD^ get(int destination);
}

Parameters

destination

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLaneODs Interface
ISIAPIOutputLaneODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLanes Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLanes Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLanes
C#
public interface ISIAPIOutputLanes
Managed Extensions for C++
public __gc __interface ISIAPIOutputLanes
C++/CLI
public interface class ISIAPIOutputLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLanes Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLanes Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLanes.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExists |
Top

See Also

Reference

ISIAPIOutputLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLanes Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLanes members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LaneExists |
Top

See Also

Reference

ISIAPIOutputLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LaneExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLanes Interface : LaneExists Method

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LaneExists( _
   ByVal laneno As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLanes
Dim laneno As Integer
Dim value As Boolean

value = instance.LaneExists(laneno)
C#
bool LaneExists(
   int laneno
)
Managed Extensions for C++
bool LaneExists(
   int laneno
)
C++/CLI
bool LaneExists(
   int laneno
)

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLanes Interface
ISIAPIOutputLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLanes Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLanes members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLanes Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLanes
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLanes Interface
ISIAPIOutputLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLanes Interface : Item Property

laneno

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal laneno As Integer _
) As ISIAPIOutputLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLanes
Dim laneno As Integer
Dim value As ISIAPIOutputLane

value = instance.Item(laneno)
C#
ISIAPIOutputLane this[
   int laneno
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLane* get_Item   int laneno
;
C++/CLI
property ISIAPIOutputLane^ default [int] {
   ISIAPIOutputLane^ get(int laneno);
}

Parameters

laneno

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLanes Interface
ISIAPIOutputLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLeg Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLeg Interface

Glossary Item Box

SIDRA INTERSECTION Output Leg wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
C#
public interface ISIAPIOutputLeg
Managed Extensions for C++
public __gc __interface ISIAPIOutputLeg
C++/CLI
public interface class ISIAPIOutputLeg

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLeg Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLeg Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLeg.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Average_entry_lane_width |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_effective | Effective intersection capacity.
Property | Capacity_lane_total | Sum of all lane capacities.
Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Property | Circulating_flow | Flow circulating in front of leg (veh) (roundabouts).
Property | Circulating_flow_pcu |
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_total | Total control delay.
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Exiting_flow | Flow exiting to leg (veh).
Property | Exiting_flow_capconstr |
Property | Extra_bunching |
Property | Extra_bunching_flag |
Property | FHWA_capacity_zero_circ_flow |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate | Fuel consumption rate.
Property | Fuel_consumption_total | Total fuel consumption.
Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Property | Idling_time_average |
Property | Inscribed_diameter |
Property | Level_of_service | Approach LOS.
Property | Level_of_service_worstlane | Worst lane LOS on approach.
Property | Level_of_service_worstmov | Worst movement LOS on approach.
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | Nox_rate | NOX emission rate (g/km).
Property | Nox_total | Total NOX emissions (kg/h).
Property | Num_entry_lanes |
Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Orientation |
Property | OutputCirculatingLanes |
Property | OutputLanes |
Property | OutputLegMCs |
Property | Performance_index | Performance index.
Property | Platoonmode_type |
Property | Prop_queued_upstr_signal |
Property | Prop_queued_upstr_signal_flag |
Property | Proportion_queued | Proportion queued.
Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | SpeedEfficiency |
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Total_lane_changes |
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time.
Property | Travel_time_total | Total travel time.
Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

ISIAPIOutputLeg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLeg Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLeg Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLeg members.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Average_entry_lane_width |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_effective | Effective intersection capacity.
Property | Capacity_lane_total | Sum of all lane capacities.
Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Property | Circulating_flow | Flow circulating in front of leg (veh) (roundabouts).
Property | Circulating_flow_pcu |
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_total | Total control delay.
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Exiting_flow | Flow exiting to leg (veh).
Property | Exiting_flow_capconstr |
Property | Extra_bunching |
Property | Extra_bunching_flag |
Property | FHWA_capacity_zero_circ_flow |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate | Fuel consumption rate.
Property | Fuel_consumption_total | Total fuel consumption.
Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Property | Idling_time_average |
Property | Inscribed_diameter |
Property | Level_of_service | Approach LOS.
Property | Level_of_service_worstlane | Worst lane LOS on approach.
Property | Level_of_service_worstmov | Worst movement LOS on approach.
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | Nox_rate | NOX emission rate (g/km).
Property | Nox_total | Total NOX emissions (kg/h).
Property | Num_entry_lanes |
Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Orientation |
Property | OutputCirculatingLanes |
Property | OutputLanes |
Property | OutputLegMCs |
Property | Performance_index | Performance index.
Property | Platoonmode_type |
Property | Prop_queued_upstr_signal |
Property | Prop_queued_upstr_signal_flag |
Property | Proportion_queued | Proportion queued.
Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | SpeedEfficiency |
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Total_lane_changes |
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time.
Property | Travel_time_total | Total travel time.
Property | X1_flag | Degree of saturation = 1 flag.
Top

See Also

Reference

ISIAPIOutputLeg Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Average_entry_lane_width Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Average_entry_lane_width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Average_entry_lane_width As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Average_entry_lane_width
C#
float Average_entry_lane_width {get;}
Managed Extensions for C++
__property float get_Average_entry_lane_width();
C++/CLI
property float Average_entry_lane_width {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
__property float get_Avg_num_of_cycles_to_depart();
C++/CLI
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
__property int get_Capacity_adj_flag_worstlane();
C++/CLI
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
float Capacity_adj_worstlane {get;}
Managed Extensions for C++
__property float get_Capacity_adj_worstlane();
C++/CLI
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Capacity_effective Property

Glossary Item Box

Effective intersection capacity.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Capacity_effective
C#
float Capacity_effective {get;}
Managed Extensions for C++
__property float get_Capacity_effective();
C++/CLI
property float Capacity_effective {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_lane_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Capacity_lane_total Property

Glossary Item Box

Sum of all lane capacities.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_lane_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Capacity_lane_total
C#
float Capacity_lane_total {get;}
Managed Extensions for C++
__property float get_Capacity_lane_total();
C++/CLI
property float Capacity_lane_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Capacity_mov_total Property

Glossary Item Box

Sum of movement capacities (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_mov_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Capacity_mov_total
C#
float Capacity_mov_total {get;}
Managed Extensions for C++
__property float get_Capacity_mov_total();
C++/CLI
property float Capacity_mov_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Carbon_dioxide_rate Property

Glossary Item Box

Carbon Dioxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
float Carbon_dioxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_rate();
C++/CLI
property float Carbon_dioxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Carbon_dioxide_total Property

Glossary Item Box

Total Carbon Dioxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Carbon_monoxide_rate Property

Glossary Item Box

Carbon Monoxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
float Carbon_monoxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_rate();
C++/CLI
property float Carbon_monoxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Carbon_monoxide_total Property

Glossary Item Box

Total Carbon Monoxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Circulating_flow Property

Glossary Item Box

Flow circulating in front of leg (veh) (roundabouts).

Syntax

Visual Basic (Declaration)
ReadOnly Property Circulating_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Circulating_flow
C#
float Circulating_flow {get;}
Managed Extensions for C++
__property float get_Circulating_flow();
C++/CLI
property float Circulating_flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Circulating_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Circulating_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Circulating_flow_pcu
C#
float Circulating_flow_pcu {get;}
Managed Extensions for C++
__property float get_Circulating_flow_pcu();
C++/CLI
property float Circulating_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
float Delay_control_average_worstlane {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstlane();
C++/CLI
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_geometric
C#
float Delay_geometric {get;}
Managed Extensions for C++
__property float get_Delay_geometric();
C++/CLI
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Exiting_flow Property

Glossary Item Box

Flow exiting to leg (veh).

Syntax

Visual Basic (Declaration)
ReadOnly Property Exiting_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Exiting_flow
C#
float Exiting_flow {get;}
Managed Extensions for C++
__property float get_Exiting_flow();
C++/CLI
property float Exiting_flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Exiting_flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exiting_flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Exiting_flow_capconstr
C#
float Exiting_flow_capconstr {get;}
Managed Extensions for C++
__property float get_Exiting_flow_capconstr();
C++/CLI
property float Exiting_flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Extra_bunching Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Extra_bunching As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Extra_bunching
C#
float Extra_bunching {get;}
Managed Extensions for C++
__property float get_Extra_bunching();
C++/CLI
property float Extra_bunching {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Extra_bunching_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Extra_bunching_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Extra_bunching_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Extra_bunching_flag
C#
int Extra_bunching_flag {get;}
Managed Extensions for C++
__property int get_Extra_bunching_flag();
C++/CLI
property int Extra_bunching_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FHWA_capacity_zero_circ_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : FHWA_capacity_zero_circ_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property FHWA_capacity_zero_circ_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.FHWA_capacity_zero_circ_flow
C#
float FHWA_capacity_zero_circ_flow {get;}
Managed Extensions for C++
__property float get_FHWA_capacity_zero_circ_flow();
C++/CLI
property float FHWA_capacity_zero_circ_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV
C#
float Flow_HV {get;}
Managed Extensions for C++
__property float get_Flow_HV();
C++/CLI
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_capconstr
C#
float Flow_HV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_capconstr();
C++/CLI
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_HV_pct Property

Glossary Item Box

Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_pct
C#
float Flow_HV_pct {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct();
C++/CLI
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct_capconstr();
C++/CLI
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_LV
C#
float Flow_LV {get;}
Managed Extensions for C++
__property float get_Flow_LV();
C++/CLI
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_LV_capconstr
C#
float Flow_LV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_LV_capconstr();
C++/CLI
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_total
C#
float Flow_total {get;}
Managed Extensions for C++
__property float get_Flow_total();
C++/CLI
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Flow_total_capconstr
C#
float Flow_total_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_total_capconstr();
C++/CLI
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Fuel_consumption_rate Property

Glossary Item Box

Fuel consumption rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Fuel_consumption_rate
C#
float Fuel_consumption_rate {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_rate();
C++/CLI
property float Fuel_consumption_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Fuel_consumption_total Property

Glossary Item Box

Total fuel consumption.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Hydrocarbons_rate Property

Glossary Item Box

Hydrocarbon emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Hydrocarbons_rate
C#
float Hydrocarbons_rate {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_rate();
C++/CLI
property float Hydrocarbons_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Hydrocarbons_total Property

Glossary Item Box

Total Hydrocarbon emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Idling_time_average
C#
float Idling_time_average {get;}
Managed Extensions for C++
__property float get_Idling_time_average();
C++/CLI
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Inscribed_diameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Inscribed_diameter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Inscribed_diameter As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Inscribed_diameter
C#
float Inscribed_diameter {get;}
Managed Extensions for C++
__property float get_Inscribed_diameter();
C++/CLI
property float Inscribed_diameter {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Level_of_service Property

Glossary Item Box

Approach LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Level_of_service_worstlane Property

Glossary Item Box

Worst lane LOS on approach.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_worstlane As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As String

value = instance.Level_of_service_worstlane
C#
string Level_of_service_worstlane {get;}
Managed Extensions for C++
__property string* get_Level_of_service_worstlane();
C++/CLI
property String^ Level_of_service_worstlane {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Level_of_service_worstmov Property

Glossary Item Box

Worst movement LOS on approach.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As String

value = instance.Level_of_service_worstmov
C#
string Level_of_service_worstmov {get;}
Managed Extensions for C++
__property string* get_Level_of_service_worstmov();
C++/CLI
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Net_inflow
C#
float Net_inflow {get;}
Managed Extensions for C++
__property float get_Net_inflow();
C++/CLI
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Net_inflow_capconstr
C#
float Net_inflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_inflow_capconstr();
C++/CLI
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Net_outflow
C#
float Net_outflow {get;}
Managed Extensions for C++
__property float get_Net_outflow();
C++/CLI
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Net_outflow_capconstr
C#
float Net_outflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_outflow_capconstr();
C++/CLI
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Nox_rate Property

Glossary Item Box

NOX emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Nox_rate
C#
float Nox_rate {get;}
Managed Extensions for C++
__property float get_Nox_rate();
C++/CLI
property float Nox_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Nox_total Property

Glossary Item Box

Total NOX emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Num_entry_lanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Num_entry_lanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Num_entry_lanes As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Num_entry_lanes
C#
int Num_entry_lanes {get;}
Managed Extensions for C++
__property int get_Num_entry_lanes();
C++/CLI
property int Num_entry_lanes {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Operating_cost_rate Property

Glossary Item Box

Operating cost rate (cost unit/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Operating_cost_rate
C#
float Operating_cost_rate {get;}
Managed Extensions for C++
__property float get_Operating_cost_rate();
C++/CLI
property float Operating_cost_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Orientation
C#
int Orientation {get;}
Managed Extensions for C++
__property int get_Orientation();
C++/CLI
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputCirculatingLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : OutputCirculatingLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputCirculatingLanes As ISIAPIOutputCirculatingLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As ISIAPIOutputCirculatingLanes

value = instance.OutputCirculatingLanes
C#
ISIAPIOutputCirculatingLanes OutputCirculatingLanes {get;}
Managed Extensions for C++
__property ISIAPIOutputCirculatingLanes* get_OutputCirculatingLanes();
C++/CLI
property ISIAPIOutputCirculatingLanes^ OutputCirculatingLanes {
   ISIAPIOutputCirculatingLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : OutputLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLanes As ISIAPIOutputLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As ISIAPIOutputLanes

value = instance.OutputLanes
C#
ISIAPIOutputLanes OutputLanes {get;}
Managed Extensions for C++
__property ISIAPIOutputLanes* get_OutputLanes();
C++/CLI
property ISIAPIOutputLanes^ OutputLanes {
   ISIAPIOutputLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : OutputLegMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLegMCs As ISIAPIOutputLegMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As ISIAPIOutputLegMCs

value = instance.OutputLegMCs
C#
ISIAPIOutputLegMCs OutputLegMCs {get;}
Managed Extensions for C++
__property ISIAPIOutputLegMCs* get_OutputLegMCs();
C++/CLI
property ISIAPIOutputLegMCs^ OutputLegMCs {
   ISIAPIOutputLegMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoonmode_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Platoonmode_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Platoonmode_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Platoonmode_type
C#
int Platoonmode_type {get;}
Managed Extensions for C++
__property int get_Platoonmode_type();
C++/CLI
property int Platoonmode_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_upstr_signal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Prop_queued_upstr_signal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_upstr_signal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Prop_queued_upstr_signal
C#
float Prop_queued_upstr_signal {get;}
Managed Extensions for C++
__property float get_Prop_queued_upstr_signal();
C++/CLI
property float Prop_queued_upstr_signal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_upstr_signal_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Prop_queued_upstr_signal_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_upstr_signal_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.Prop_queued_upstr_signal_flag
C#
int Prop_queued_upstr_signal_flag {get;}
Managed Extensions for C++
__property int get_Prop_queued_upstr_signal_flag();
C++/CLI
property int Prop_queued_upstr_signal_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_cycav_mean
C#
float Queue_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_cycav_mean();
C++/CLI
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_cycav_percentile
C#
float Queue_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_cycav_percentile();
C++/CLI
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_mean();
C++/CLI
property float Queue_dist_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_percentile();
C++/CLI
property float Queue_dist_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_mean();
C++/CLI
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_percentile();
C++/CLI
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_greenstart_mean
C#
float Queue_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_mean();
C++/CLI
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
float Queue_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_percentile();
C++/CLI
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_avg();
C++/CLI
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_percentile();
C++/CLI
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_lane_changes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Total_lane_changes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_lane_changes As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Total_lane_changes
C#
float Total_lane_changes {get;}
Managed Extensions for C++
__property float get_Total_lane_changes();
C++/CLI
property float Total_lane_changes {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Travel_time_average Property

Glossary Item Box

Average travel time.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : Travel_time_total Property

Glossary Item Box

Total travel time.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLeg Interface : X1_flag Property

Glossary Item Box

Degree of saturation = 1 flag.

Syntax

Visual Basic (Declaration)
ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLeg
Dim value As Integer

value = instance.X1_flag
C#
int X1_flag {get;}
Managed Extensions for C++
__property int get_X1_flag();
C++/CLI
property int X1_flag {
   int get();
}

Property Value

Type: System.Int32

0 = x != 1
1 = x = 1 due to short lane
2 = x = 1 due to minimum capacity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLeg Interface
ISIAPIOutputLeg Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLegMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
C#
public interface ISIAPIOutputLegMC
Managed Extensions for C++
public __gc __interface ISIAPIOutputLegMC
C++/CLI
public interface class ISIAPIOutputLegMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLegMC.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Circulating_flow |
Property | Circulating_flow_pcu |
Property | Exist_in_nw_upstream_only |
Property | Exiting_flow |
Property | Exiting_flow_capconstr |
Property | Flow | Demand Flow Rate.
Property | Flow_capconstr | Arrival Flow Rate.
Property | MC_class |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | OutputLeg |
Property | Total_lane_changes |
Top

See Also

Reference

ISIAPIOutputLegMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegMC members.

Public Properties

 | Name | Description
Property | Arrival_flow_flag |
Property | Circulating_flow |
Property | Circulating_flow_pcu |
Property | Exist_in_nw_upstream_only |
Property | Exiting_flow |
Property | Exiting_flow_capconstr |
Property | Flow | Demand Flow Rate.
Property | Flow_capconstr | Arrival Flow Rate.
Property | MC_class |
Property | Net_inflow |
Property | Net_inflow_capconstr |
Property | Net_outflow |
Property | Net_outflow_capconstr |
Property | OutputLeg |
Property | Total_lane_changes |
Top

See Also

Reference

ISIAPIOutputLegMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Circulating_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Circulating_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Circulating_flow
C#
float Circulating_flow {get;}
Managed Extensions for C++
__property float get_Circulating_flow();
C++/CLI
property float Circulating_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Circulating_flow_pcu Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Circulating_flow_pcu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Circulating_flow_pcu As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Circulating_flow_pcu
C#
float Circulating_flow_pcu {get;}
Managed Extensions for C++
__property float get_Circulating_flow_pcu();
C++/CLI
property float Circulating_flow_pcu {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exist_in_nw_upstream_only Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Exist_in_nw_upstream_only Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exist_in_nw_upstream_only As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Boolean

value = instance.Exist_in_nw_upstream_only
C#
bool Exist_in_nw_upstream_only {get;}
Managed Extensions for C++
__property bool get_Exist_in_nw_upstream_only();
C++/CLI
property bool Exist_in_nw_upstream_only {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Exiting_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exiting_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Exiting_flow
C#
float Exiting_flow {get;}
Managed Extensions for C++
__property float get_Exiting_flow();
C++/CLI
property float Exiting_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exiting_flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Exiting_flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exiting_flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Exiting_flow_capconstr
C#
float Exiting_flow_capconstr {get;}
Managed Extensions for C++
__property float get_Exiting_flow_capconstr();
C++/CLI
property float Exiting_flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Flow Property

Glossary Item Box

Demand Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Flow
C#
float Flow {get;}
Managed Extensions for C++
__property float get_Flow();
C++/CLI
property float Flow {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Flow_capconstr Property

Glossary Item Box

Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Flow_capconstr
C#
float Flow_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_capconstr();
C++/CLI
property float Flow_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Net_inflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Net_inflow
C#
float Net_inflow {get;}
Managed Extensions for C++
__property float get_Net_inflow();
C++/CLI
property float Net_inflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_inflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Net_inflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_inflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Net_inflow_capconstr
C#
float Net_inflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_inflow_capconstr();
C++/CLI
property float Net_inflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Net_outflow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Net_outflow
C#
float Net_outflow {get;}
Managed Extensions for C++
__property float get_Net_outflow();
C++/CLI
property float Net_outflow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Net_outflow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Net_outflow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Net_outflow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Net_outflow_capconstr
C#
float Net_outflow_capconstr {get;}
Managed Extensions for C++
__property float get_Net_outflow_capconstr();
C++/CLI
property float Net_outflow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLeg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : OutputLeg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLeg As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As ISIAPIOutputLeg

value = instance.OutputLeg
C#
ISIAPIOutputLeg OutputLeg {get;}
Managed Extensions for C++
__property ISIAPIOutputLeg* get_OutputLeg();
C++/CLI
property ISIAPIOutputLeg^ OutputLeg {
   ISIAPIOutputLeg^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_lane_changes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMC Interface : Total_lane_changes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_lane_changes As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMC
Dim value As Single

value = instance.Total_lane_changes
C#
float Total_lane_changes {get;}
Managed Extensions for C++
__property float get_Total_lane_changes();
C++/CLI
property float Total_lane_changes {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMC Interface
ISIAPIOutputLegMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLegMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMCs
C#
public interface ISIAPIOutputLegMCs
Managed Extensions for C++
public __gc __interface ISIAPIOutputLegMCs
C++/CLI
public interface class ISIAPIOutputLegMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLegMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLegMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputLegMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMCs Interface : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMCs Interface
ISIAPIOutputLegMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLegMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMCs Interface
ISIAPIOutputLegMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegMCs Interface : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputLegMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputLegMC

value = instance.Item(mcClass)
C#
ISIAPIOutputLegMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLegMC* get_Item   int mcClass
;
C++/CLI
property ISIAPIOutputLegMC^ default [int] {
   ISIAPIOutputLegMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegMCs Interface
ISIAPIOutputLegMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPerson Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPerson Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLegPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
C#
public interface ISIAPIOutputLegPerson
Managed Extensions for C++
public __gc __interface ISIAPIOutputLegPerson
C++/CLI
public interface class ISIAPIOutputLegPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPerson Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPerson Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLegPerson.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Delay_control_average |
Property | Delay_control_average_worstmov |
Property | Delay_control_total |
Property | Demand_flow_total |
Property | Operating_cost_total |
Property | Orientation |
Property | Performance_index |
Property | Proportion_queued |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_total |
Top

See Also

Reference

ISIAPIOutputLegPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPerson Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPerson Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegPerson members.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Delay_control_average |
Property | Delay_control_average_worstmov |
Property | Delay_control_total |
Property | Demand_flow_total |
Property | Operating_cost_total |
Property | Orientation |
Property | Performance_index |
Property | Proportion_queued |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_total |
Top

See Also

Reference

ISIAPIOutputLegPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Arrival_flow_total
C#
float Arrival_flow_total {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total();
C++/CLI
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Delay_control_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Integer

value = instance.Orientation
C#
int Orientation {get;}
Managed Extensions for C++
__property int get_Orientation();
C++/CLI
property int Orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPerson Interface : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPerson
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPerson Interface
ISIAPIOutputLegPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPersons Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPersons Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLegPersons
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPersons
C#
public interface ISIAPIOutputLegPersons
Managed Extensions for C++
public __gc __interface ISIAPIOutputLegPersons
C++/CLI
public interface class ISIAPIOutputLegPersons

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPersons Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPersons Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPersons Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLegPersons.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegPersonExists |
Top

See Also

Reference

ISIAPIOutputLegPersons Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPersons Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPersons Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegPersons members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegPersonExists |
Top

See Also

Reference

ISIAPIOutputLegPersons Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegPersonExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPersons Interface : LegPersonExists Method

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LegPersonExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPersons
Dim orientation As Integer
Dim value As Boolean

value = instance.LegPersonExists(orientation)
C#
bool LegPersonExists(
   int orientation
)
Managed Extensions for C++
bool LegPersonExists(
   int orientation
)
C++/CLI
bool LegPersonExists(
   int orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPersons Interface
ISIAPIOutputLegPersons Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegPersons Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegPersons Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegPersons members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLegPersons Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPersons Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPersons
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPersons Interface
ISIAPIOutputLegPersons Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegPersons Interface : Item Property

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPIOutputLegPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegPersons
Dim orientation As Integer
Dim value As ISIAPIOutputLegPerson

value = instance.Item(orientation)
C#
ISIAPIOutputLegPerson this[
   int orientation
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLegPerson* get_Item   int orientation
;
C++/CLI
property ISIAPIOutputLegPerson^ default [int] {
   ISIAPIOutputLegPerson^ get(int orientation);
}

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegPersons Interface
ISIAPIOutputLegPersons Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputLegs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegs
C#
public interface ISIAPIOutputLegs
Managed Extensions for C++
public __gc __interface ISIAPIOutputLegs
C++/CLI
public interface class ISIAPIOutputLegs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputLegs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegExists |
Top

See Also

Reference

ISIAPIOutputLegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | LegExists |
Top

See Also

Reference

ISIAPIOutputLegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LegExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegs Interface : LegExists Method

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function LegExists( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegs
Dim orientation As Integer
Dim value As Boolean

value = instance.LegExists(orientation)
C#
bool LegExists(
   int orientation
)
Managed Extensions for C++
bool LegExists(
   int orientation
)
C++/CLI
bool LegExists(
   int orientation
)

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegs Interface
ISIAPIOutputLegs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputLegs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputLegs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputLegs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputLegs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegs Interface
ISIAPIOutputLegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputLegs Interface : Item Property

orientation

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal orientation As Integer _
) As ISIAPIOutputLeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputLegs
Dim orientation As Integer
Dim value As ISIAPIOutputLeg

value = instance.Item(orientation)
C#
ISIAPIOutputLeg this[
   int orientation
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputLeg* get_Item   int orientation
;
C++/CLI
property ISIAPIOutputLeg^ default [int] {
   ISIAPIOutputLeg^ get(int orientation);
}

Parameters

orientation

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputLegs Interface
ISIAPIOutputLegs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMeteredRoundabout Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMeteredRoundabout Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMeteredRoundabout
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
C#
public interface ISIAPIOutputMeteredRoundabout
Managed Extensions for C++
public __gc __interface ISIAPIOutputMeteredRoundabout
C++/CLI
public interface class ISIAPIOutputMeteredRoundabout

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMeteredRoundabout Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMeteredRoundabout Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMeteredRoundabout.

Public Properties

 | Name | Description
Property | Blank_time_ratio |
Property | Controlling_queue_detection_probability |
Property | Metered_displayed_blank |
Property | Metered_displayed_red |
Property | Metered_effective_blank |
Property | Metered_effective_red |
Top

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMeteredRoundabout Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMeteredRoundabout Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMeteredRoundabout members.

Public Properties

 | Name | Description
Property | Blank_time_ratio |
Property | Controlling_queue_detection_probability |
Property | Metered_displayed_blank |
Property | Metered_displayed_red |
Property | Metered_effective_blank |
Property | Metered_effective_red |
Top

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Blank_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Blank_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Blank_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Single

value = instance.Blank_time_ratio
C#
float Blank_time_ratio {get;}
Managed Extensions for C++
__property float get_Blank_time_ratio();
C++/CLI
property float Blank_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Controlling_queue_detection_probability Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Controlling_queue_detection_probability Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Controlling_queue_detection_probability As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Single

value = instance.Controlling_queue_detection_probability
C#
float Controlling_queue_detection_probability {get;}
Managed Extensions for C++
__property float get_Controlling_queue_detection_probability();
C++/CLI
property float Controlling_queue_detection_probability {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_displayed_blank Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Metered_displayed_blank Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Metered_displayed_blank As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_displayed_blank
C#
int Metered_displayed_blank {get;}
Managed Extensions for C++
__property int get_Metered_displayed_blank();
C++/CLI
property int Metered_displayed_blank {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_displayed_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Metered_displayed_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Metered_displayed_red As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_displayed_red
C#
int Metered_displayed_red {get;}
Managed Extensions for C++
__property int get_Metered_displayed_red();
C++/CLI
property int Metered_displayed_red {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_effective_blank Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Metered_effective_blank Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Metered_effective_blank As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_effective_blank
C#
int Metered_effective_blank {get;}
Managed Extensions for C++
__property int get_Metered_effective_blank();
C++/CLI
property int Metered_effective_blank {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Metered_effective_red Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMeteredRoundabout Interface : Metered_effective_red Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Metered_effective_red As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMeteredRoundabout
Dim value As Integer

value = instance.Metered_effective_red
C#
int Metered_effective_red {get;}
Managed Extensions for C++
__property int get_Metered_effective_red();
C++/CLI
property int Metered_effective_red {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMeteredRoundabout Interface
ISIAPIOutputMeteredRoundabout Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed Interface

Glossary Item Box

SIDRA INTERSECTION Pedestrian movement output wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPed
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
C#
public interface ISIAPIOutputMovementPed
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPed
C++/CLI
public interface class ISIAPIOutputMovementPed

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPed.

Public Properties

 | Name | Description
Property | Capacity_mov | Movement capacity (includes effect of lane underutilisation within movement).
Property | Deg_satn | Movement degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_total | Total control delay (veh-h/h).
Property | Demand_flow_total | Movement total demand flow.
Property | Green_periods | Number of green periods for movement.
Property | Level_of_service | Level of service.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Property | OutputMovementPed_GreenPeriods |
Property | Performance_index | Performance index.
Property | Practical_degree_of_saturation |
Property | Proportion_queued | Proportion queued.
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel time (secs).
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Property | Type | The type of a Pedestrian Movement Type: System.Int32; 1 = Full Crossing, 2 = Slip Lane, 3 = Staged, 4 = Diagonal.
Top

See Also

Reference

ISIAPIOutputMovementPed Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPed members.

Public Properties

 | Name | Description
Property | Capacity_mov | Movement capacity (includes effect of lane underutilisation within movement).
Property | Deg_satn | Movement degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_total | Total control delay (veh-h/h).
Property | Demand_flow_total | Movement total demand flow.
Property | Green_periods | Number of green periods for movement.
Property | Level_of_service | Level of service.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Origin | Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs
Property | OutputMovementPed_GreenPeriods |
Property | Performance_index | Performance index.
Property | Practical_degree_of_saturation |
Property | Proportion_queued | Proportion queued.
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Stage | Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel time (secs).
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Property | Type | The type of a Pedestrian Movement Type: System.Int32; 1 = Full Crossing, 2 = Slip Lane, 3 = Staged, 4 = Diagonal.
Top

See Also

Reference

ISIAPIOutputMovementPed Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Capacity_mov Property

Glossary Item Box

Movement capacity (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Capacity_mov
C#
float Capacity_mov {get;}
Managed Extensions for C++
__property float get_Capacity_mov();
C++/CLI
property float Capacity_mov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Deg_satn Property

Glossary Item Box

Movement degree of saturation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Delay_control_total Property

Glossary Item Box

Total control delay (veh-h/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Demand_flow_total Property

Glossary Item Box

Movement total demand flow.

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Green_periods Property

Glossary Item Box

Number of green periods for movement.

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Integer

value = instance.Green_periods
C#
int Green_periods {get;}
Managed Extensions for C++
__property int get_Green_periods();
C++/CLI
property int Green_periods {
   int get();
}

Property Value

Type: System.Int32

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Level_of_service Property

Glossary Item Box

Level of service.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Origin Property

Glossary Item Box

Pedestrian Movement Origin Leg, ie the Leg across which the Movement runs

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPed_GreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : OutputMovementPed_GreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementPed_GreenPeriods As ISIAPIOutputMovementPed_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As ISIAPIOutputMovementPed_GreenPeriods

value = instance.OutputMovementPed_GreenPeriods
C#
ISIAPIOutputMovementPed_GreenPeriods OutputMovementPed_GreenPeriods {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPed_GreenPeriods* get_OutputMovementPed_GreenPeriods();
C++/CLI
property ISIAPIOutputMovementPed_GreenPeriods^ OutputMovementPed_GreenPeriods {
   ISIAPIOutputMovementPed_GreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Practical_degree_of_saturation
C#
float Practical_degree_of_saturation {get;}
Managed Extensions for C++
__property float get_Practical_degree_of_saturation();
C++/CLI
property float Practical_degree_of_saturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Stage Property

Glossary Item Box

Pedestrian Movement Stage. SIDRA INTERSECTION supports up to two Pedestrian Movements on each Leg allowing modelling of "staged" pedestrian crossings.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Integer

value = instance.Stage
C#
int Stage {get;}
Managed Extensions for C++
__property int get_Stage();
C++/CLI
property int Stage {
   int get();
}

Property Value

Type: System.Int32;

1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Travel_speed Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed Interface : Type Property

Glossary Item Box

The type of a Pedestrian Movement

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed
Dim value As Integer

value = instance.Type
C#
int Type {get;}
Managed Extensions for C++
__property int get_Type();
C++/CLI
property int Type {
   int get();
}

Property Value

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed Interface
ISIAPIOutputMovementPed Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriod Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriod Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPed_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
C#
public interface ISIAPIOutputMovementPed_GreenPeriod
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPed_GreenPeriod
C++/CLI
public interface class ISIAPIOutputMovementPed_GreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriod Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriod Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPed_GreenPeriod.

Public Properties

 | Name | Description
Property | Actual_walk_time |
Property | Adjusted_flow_ratio |
Property | Adjusted_lost_time |
Property | Critical_mov |
Property | Displayed_end_time |
Property | Displayed_start_time |
Property | Eff_end_gain |
Property | Eff_end_time |
Property | Eff_green |
Property | Eff_start_loss |
Property | Eff_start_time |
Property | End_phase |
Property | Flow_ratio |
Property | Greenperiod | Green Period value is a one-based integer.
Property | Lost_time |
Property | Min_max_flag |
Property | Min_walk_time |
Property | No_arrival |
Property | Priority |
Property | Reqd_green_time_ratio |
Property | Reqd_time |
Property | Satn_flow |
Property | Start_phase |
Property | Tmax |
Property | Tmin |
Top

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriod Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriod Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPed_GreenPeriod members.

Public Properties

 | Name | Description
Property | Actual_walk_time |
Property | Adjusted_flow_ratio |
Property | Adjusted_lost_time |
Property | Critical_mov |
Property | Displayed_end_time |
Property | Displayed_start_time |
Property | Eff_end_gain |
Property | Eff_end_time |
Property | Eff_green |
Property | Eff_start_loss |
Property | Eff_start_time |
Property | End_phase |
Property | Flow_ratio |
Property | Greenperiod | Green Period value is a one-based integer.
Property | Lost_time |
Property | Min_max_flag |
Property | Min_walk_time |
Property | No_arrival |
Property | Priority |
Property | Reqd_green_time_ratio |
Property | Reqd_time |
Property | Satn_flow |
Property | Start_phase |
Property | Tmax |
Property | Tmin |
Top

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actual_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Actual_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Actual_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Actual_walk_time
C#
int Actual_walk_time {get;}
Managed Extensions for C++
__property int get_Actual_walk_time();
C++/CLI
property int Actual_walk_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Adjusted_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Adjusted_flow_ratio
C#
float Adjusted_flow_ratio {get;}
Managed Extensions for C++
__property float get_Adjusted_flow_ratio();
C++/CLI
property float Adjusted_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Adjusted_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Adjusted_lost_time
C#
int Adjusted_lost_time {get;}
Managed Extensions for C++
__property int get_Adjusted_lost_time();
C++/CLI
property int Adjusted_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Critical_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.Critical_mov
C#
bool Critical_mov {get;}
Managed Extensions for C++
__property bool get_Critical_mov();
C++/CLI
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Displayed_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Displayed_end_time
C#
int Displayed_end_time {get;}
Managed Extensions for C++
__property int get_Displayed_end_time();
C++/CLI
property int Displayed_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Displayed_start_time
C#
int Displayed_start_time {get;}
Managed Extensions for C++
__property int get_Displayed_start_time();
C++/CLI
property int Displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Eff_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_end_gain
C#
int Eff_end_gain {get;}
Managed Extensions for C++
__property int get_Eff_end_gain();
C++/CLI
property int Eff_end_gain {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Eff_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_end_time
C#
int Eff_end_time {get;}
Managed Extensions for C++
__property int get_Eff_end_time();
C++/CLI
property int Eff_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_green
C#
int Eff_green {get;}
Managed Extensions for C++
__property int get_Eff_green();
C++/CLI
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Eff_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_start_loss
C#
int Eff_start_loss {get;}
Managed Extensions for C++
__property int get_Eff_start_loss();
C++/CLI
property int Eff_start_loss {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Eff_start_time
C#
int Eff_start_time {get;}
Managed Extensions for C++
__property int get_Eff_start_time();
C++/CLI
property int Eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : End_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.End_phase
C#
int End_phase {get;}
Managed Extensions for C++
__property int get_End_phase();
C++/CLI
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
float Flow_ratio {get;}
Managed Extensions for C++
__property float get_Flow_ratio();
C++/CLI
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Greenperiod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Greenperiod
C#
int Greenperiod {get;}
Managed Extensions for C++
__property int get_Greenperiod();
C++/CLI
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Lost_time
C#
int Lost_time {get;}
Managed Extensions for C++
__property int get_Lost_time();
C++/CLI
property int Lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Min_max_flag
C#
int Min_max_flag {get;}
Managed Extensions for C++
__property int get_Min_max_flag();
C++/CLI
property int Min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_walk_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Min_walk_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Min_walk_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Min_walk_time
C#
int Min_walk_time {get;}
Managed Extensions for C++
__property int get_Min_walk_time();
C++/CLI
property int Min_walk_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
No_arrival Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : No_arrival Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property No_arrival As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.No_arrival
C#
bool No_arrival {get;}
Managed Extensions for C++
__property bool get_No_arrival();
C++/CLI
property bool No_arrival {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Priority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Boolean

value = instance.Priority
C#
bool Priority {get;}
Managed Extensions for C++
__property bool get_Priority();
C++/CLI
property bool Priority {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Reqd_green_time_ratio
C#
float Reqd_green_time_ratio {get;}
Managed Extensions for C++
__property float get_Reqd_green_time_ratio();
C++/CLI
property float Reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Reqd_time
C#
float Reqd_time {get;}
Managed Extensions for C++
__property float get_Reqd_time();
C++/CLI
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Satn_flow
C#
float Satn_flow {get;}
Managed Extensions for C++
__property float get_Satn_flow();
C++/CLI
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Start_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Integer

value = instance.Start_phase
C#
int Start_phase {get;}
Managed Extensions for C++
__property int get_Start_phase();
C++/CLI
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Tmax
C#
float Tmax {get;}
Managed Extensions for C++
__property float get_Tmax();
C++/CLI
property float Tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriod Interface : Tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriod
Dim value As Single

value = instance.Tmin
C#
float Tmin {get;}
Managed Extensions for C++
__property float get_Tmin();
C++/CLI
property float Tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriod Interface
ISIAPIOutputMovementPed_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriods Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriods Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPed_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriods
C#
public interface ISIAPIOutputMovementPed_GreenPeriods
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPed_GreenPeriods
C++/CLI
public interface class ISIAPIOutputMovementPed_GreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriods Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriods Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPed_GreenPeriods.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement Output Green Period Data. Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriods Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPed_GreenPeriods members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriods Interface : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether a Pedestrian Movement Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
ISIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPed_GreenPeriods Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPed_GreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPed_GreenPeriods members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement Output Green Period Data. Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriods Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriods
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
ISIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPed_GreenPeriods Interface : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a Pedestrian Movement Output Green Period Data.
Return a Pedestrian Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputMovementPed_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPed_GreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputMovementPed_GreenPeriod

value = instance.Item(greenperiod)
C#
ISIAPIOutputMovementPed_GreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPed_GreenPeriod* get_Item   int greenperiod
;
C++/CLI
property ISIAPIOutputMovementPed_GreenPeriod^ default [int] {
   ISIAPIOutputMovementPed_GreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPed_GreenPeriods Interface
ISIAPIOutputMovementPed_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPeds Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPeds Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPeds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPeds
C#
public interface ISIAPIOutputMovementPeds
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPeds
C++/CLI
public interface class ISIAPIOutputMovementPeds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPeds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPeds Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPeds Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPeds.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement Output Data Object. Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPeds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPeds Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPeds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPeds members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPeds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPeds Interface : MovementExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Pedestrian Movement Output Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPeds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.MovementExists(type, origin, stage)
C#
bool MovementExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
bool MovementExists(
   int type,
   int origin,
   int stage
)
C++/CLI
bool MovementExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPeds Interface
ISIAPIOutputMovementPeds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPeds Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPeds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPeds members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Pedestrian Movement Output Data Object. Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputMovementPeds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPeds Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPeds
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPeds Interface
ISIAPIOutputMovementPeds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPeds Interface : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Pedestrian Movement Output Data Object.
Return a Pedestrian Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIOutputMovementPed
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPeds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIOutputMovementPed

value = instance.Item(type, origin, stage)
C#
ISIAPIOutputMovementPed this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPed* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
property ISIAPIOutputMovementPed^ default [int,int,int] {
   ISIAPIOutputMovementPed^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPeds Interface
ISIAPIOutputMovementPeds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonOD Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonOD Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPersonOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
C#
public interface ISIAPIOutputMovementPersonOD
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPersonOD
C++/CLI
public interface class ISIAPIOutputMovementPersonOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonOD Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonOD Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPersonOD.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Delay_control_average |
Property | Delay_control_average_worstmov |
Property | Delay_control_total |
Property | Demand_flow_total |
Property | Destination | Movement Destination Leg
Property | Operating_cost_total |
Property | Origin | Movement Origin Leg
Property | Performance_index |
Property | Proportion_queued |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_total |
Top

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonOD Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonOD Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPersonOD members.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Delay_control_average |
Property | Delay_control_average_worstmov |
Property | Delay_control_total |
Property | Demand_flow_total |
Property | Destination | Movement Destination Leg
Property | Operating_cost_total |
Property | Origin | Movement Origin Leg
Property | Performance_index |
Property | Proportion_queued |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_total |
Top

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Arrival_flow_total
C#
float Arrival_flow_total {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total();
C++/CLI
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Delay_control_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonOD Interface : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonOD
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonOD Interface
ISIAPIOutputMovementPersonOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonODs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonODs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementPersonODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonODs
C#
public interface ISIAPIOutputMovementPersonODs
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementPersonODs
C++/CLI
public interface class ISIAPIOutputMovementPersonODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonODs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonODs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementPersonODs.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Output Person Data Object. Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Movement Output Person Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonODs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPersonODs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Movement Output Person Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonODs Interface : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Movement Output Person Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonODs
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
bool MovementExists(
   int origin,
   int destination
)
C++/CLI
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
ISIAPIOutputMovementPersonODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementPersonODs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementPersonODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementPersonODs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Movement Output Person Data Object. Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonODs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonODs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
ISIAPIOutputMovementPersonODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementPersonODs Interface : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Movement Output Person Data Object.
Return a Movement Output Person Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIOutputMovementPersonOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementPersonODs
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIOutputMovementPersonOD

value = instance.Item(origin, destination)
C#
ISIAPIOutputMovementPersonOD this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPersonOD* get_Item   int origin,
   int destination
;
C++/CLI
property ISIAPIOutputMovementPersonOD^ default [int,int] {
   ISIAPIOutputMovementPersonOD^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementPersonODs Interface
ISIAPIOutputMovementPersonODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleOD Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleOD Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
C#
public interface ISIAPIOutputMovementVehicleOD
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleOD
C++/CLI
public interface class ISIAPIOutputMovementVehicleOD

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleOD Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleOD Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleOD.

Public Properties

 | Name | Description
Property | Approach_negotiation_speed |
Property | Arrival_flow_flag |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_data_type |
Property | Capacity_mov |
Property | Carbon_dioxide_rate |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_rate |
Property | Carbon_monoxide_total |
Property | Cruise_speed |
Property | Deg_satn |
Property | Delay_control_average |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_total_persons |
Property | Delay_control_total_veh |
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Destination | Movement Destination Leg
Property | Effective_control |
Property | Equivalent_AT |
Property | Exit_cruise_speed |
Property | Exit_negotiation_speed |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate |
Property | Fuel_consumption_total |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Has_continuous_control |
Property | Has_giveway_control |
Property | Has_highangle_slip |
Property | Has_lowangle_slip |
Property | Has_signals_control |
Property | Has_stop_control |
Property | Hydrocarbons_rate |
Property | Hydrocarbons_total |
Property | Idling_time_average |
Property | Level_of_service |
Property | Minimum_delay |
Property | Nox_rate |
Property | Nox_total |
Property | Operating_cost_rate |
Property | Operating_cost_total |
Property | Origin | Movement Origin Leg
Property | OutputMovementVehicleODMCs |
Property | Perc_arriving_during_green |
Property | Performance_index |
Property | Platoon_ratio |
Property | Practical_spare_capacity |
Property | Proportion_queued |
Property | Queue_cycav_mean |
Property | Queue_cycav_percentile |
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean |
Property | Queue_dist_maxback_percentile |
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean |
Property | Queue_maxback_percentile |
Property | Queue_storage_ratio_avg |
Property | Queue_storage_ratio_percentile |
Property | Running_speed |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_stopline_average |
Property | Travel_distance_stopline_total |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_stopline_average |
Property | Travel_time_stopline_total |
Property | Travel_time_total |
Property | Unblocked_time_ratio |
Property | X1_flag |
Top

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleOD Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleOD Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleOD members.

Public Properties

 | Name | Description
Property | Approach_negotiation_speed |
Property | Arrival_flow_flag |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_data_type |
Property | Capacity_mov |
Property | Carbon_dioxide_rate |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_rate |
Property | Carbon_monoxide_total |
Property | Cruise_speed |
Property | Deg_satn |
Property | Delay_control_average |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_total_persons |
Property | Delay_control_total_veh |
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Destination | Movement Destination Leg
Property | Effective_control |
Property | Equivalent_AT |
Property | Exit_cruise_speed |
Property | Exit_negotiation_speed |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate |
Property | Fuel_consumption_total |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Has_continuous_control |
Property | Has_giveway_control |
Property | Has_highangle_slip |
Property | Has_lowangle_slip |
Property | Has_signals_control |
Property | Has_stop_control |
Property | Hydrocarbons_rate |
Property | Hydrocarbons_total |
Property | Idling_time_average |
Property | Level_of_service |
Property | Minimum_delay |
Property | Nox_rate |
Property | Nox_total |
Property | Operating_cost_rate |
Property | Operating_cost_total |
Property | Origin | Movement Origin Leg
Property | OutputMovementVehicleODMCs |
Property | Perc_arriving_during_green |
Property | Performance_index |
Property | Platoon_ratio |
Property | Practical_spare_capacity |
Property | Proportion_queued |
Property | Queue_cycav_mean |
Property | Queue_cycav_percentile |
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean |
Property | Queue_dist_maxback_percentile |
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean |
Property | Queue_maxback_percentile |
Property | Queue_storage_ratio_avg |
Property | Queue_storage_ratio_percentile |
Property | Running_speed |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_stopline_average |
Property | Travel_distance_stopline_total |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_stopline_average |
Property | Travel_time_stopline_total |
Property | Travel_time_total |
Property | Unblocked_time_ratio |
Property | X1_flag |
Top

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Approach_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Approach_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Approach_negotiation_speed
C#
float Approach_negotiation_speed {get;}
Managed Extensions for C++
__property float get_Approach_negotiation_speed();
C++/CLI
property float Approach_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
__property float get_Avg_num_of_cycles_to_depart();
C++/CLI
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
__property int get_Capacity_adj_flag_worstlane();
C++/CLI
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
float Capacity_adj_worstlane {get;}
Managed Extensions for C++
__property float get_Capacity_adj_worstlane();
C++/CLI
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_data_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Capacity_data_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_data_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Capacity_data_type
C#
int Capacity_data_type {get;}
Managed Extensions for C++
__property int get_Capacity_data_type();
C++/CLI
property int Capacity_data_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Capacity_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Capacity_mov
C#
float Capacity_mov {get;}
Managed Extensions for C++
__property float get_Capacity_mov();
C++/CLI
property float Capacity_mov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Carbon_dioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
float Carbon_dioxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_rate();
C++/CLI
property float Carbon_dioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Carbon_monoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
float Carbon_monoxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_rate();
C++/CLI
property float Carbon_monoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Cruise_speed
C#
float Cruise_speed {get;}
Managed Extensions for C++
__property float get_Cruise_speed();
C++/CLI
property float Cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
float Delay_control_average_worstlane {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstlane();
C++/CLI
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_persons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_control_total_persons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_persons As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_total_persons
C#
float Delay_control_total_persons {get;}
Managed Extensions for C++
__property float get_Delay_control_total_persons();
C++/CLI
property float Delay_control_total_persons {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_control_total_veh
C#
float Delay_control_total_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_total_veh();
C++/CLI
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_geometric
C#
float Delay_geometric {get;}
Managed Extensions for C++
__property float get_Delay_geometric();
C++/CLI
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Destination Property

Glossary Item Box

Movement Destination Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Effective_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Effective_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Effective_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Effective_control
C#
int Effective_control {get;}
Managed Extensions for C++
__property int get_Effective_control();
C++/CLI
property int Effective_control {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Equivalent_AT
C#
int Equivalent_AT {get;}
Managed Extensions for C++
__property int get_Equivalent_AT();
C++/CLI
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Exit_cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exit_cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Exit_cruise_speed
C#
float Exit_cruise_speed {get;}
Managed Extensions for C++
__property float get_Exit_cruise_speed();
C++/CLI
property float Exit_cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Exit_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exit_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Exit_negotiation_speed
C#
float Exit_negotiation_speed {get;}
Managed Extensions for C++
__property float get_Exit_negotiation_speed();
C++/CLI
property float Exit_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV
C#
float Flow_HV {get;}
Managed Extensions for C++
__property float get_Flow_HV();
C++/CLI
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_capconstr
C#
float Flow_HV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_capconstr();
C++/CLI
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_HV_pct Property

Glossary Item Box

Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_pct
C#
float Flow_HV_pct {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct();
C++/CLI
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct_capconstr();
C++/CLI
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_LV
C#
float Flow_LV {get;}
Managed Extensions for C++
__property float get_Flow_LV();
C++/CLI
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_LV_capconstr
C#
float Flow_LV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_LV_capconstr();
C++/CLI
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_total
C#
float Flow_total {get;}
Managed Extensions for C++
__property float get_Flow_total();
C++/CLI
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Flow_total_capconstr
C#
float Flow_total_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_total_capconstr();
C++/CLI
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Fuel_consumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Fuel_consumption_rate
C#
float Fuel_consumption_rate {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_rate();
C++/CLI
property float Fuel_consumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
float Gap_accept_blocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_blocked_time();
C++/CLI
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
float Gap_accept_cycle_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_cycle_time();
C++/CLI
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_unblocked_time();
C++/CLI
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Green_periods
C#
int Green_periods {get;}
Managed Extensions for C++
__property int get_Green_periods();
C++/CLI
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_continuous_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_continuous_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_continuous_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_continuous_control
C#
bool Has_continuous_control {get;}
Managed Extensions for C++
__property bool get_Has_continuous_control();
C++/CLI
property bool Has_continuous_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_giveway_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_giveway_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_giveway_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_giveway_control
C#
bool Has_giveway_control {get;}
Managed Extensions for C++
__property bool get_Has_giveway_control();
C++/CLI
property bool Has_giveway_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_highangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_highangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_highangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_highangle_slip
C#
bool Has_highangle_slip {get;}
Managed Extensions for C++
__property bool get_Has_highangle_slip();
C++/CLI
property bool Has_highangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_lowangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_lowangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_lowangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_lowangle_slip
C#
bool Has_lowangle_slip {get;}
Managed Extensions for C++
__property bool get_Has_lowangle_slip();
C++/CLI
property bool Has_lowangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_signals_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_signals_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_signals_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_signals_control
C#
bool Has_signals_control {get;}
Managed Extensions for C++
__property bool get_Has_signals_control();
C++/CLI
property bool Has_signals_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_stop_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Has_stop_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_stop_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Boolean

value = instance.Has_stop_control
C#
bool Has_stop_control {get;}
Managed Extensions for C++
__property bool get_Has_stop_control();
C++/CLI
property bool Has_stop_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Hydrocarbons_rate
C#
float Hydrocarbons_rate {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_rate();
C++/CLI
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Idling_time_average
C#
float Idling_time_average {get;}
Managed Extensions for C++
__property float get_Idling_time_average();
C++/CLI
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Minimum_delay
C#
float Minimum_delay {get;}
Managed Extensions for C++
__property float get_Minimum_delay();
C++/CLI
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Nox_rate
C#
float Nox_rate {get;}
Managed Extensions for C++
__property float get_Nox_rate();
C++/CLI
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Operating_cost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Operating_cost_rate
C#
float Operating_cost_rate {get;}
Managed Extensions for C++
__property float get_Operating_cost_rate();
C++/CLI
property float Operating_cost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Origin Property

Glossary Item Box

Movement Origin Leg

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Property Value

Type: System.Int32;

0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODMCs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : OutputMovementVehicleODMCs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementVehicleODMCs As ISIAPIOutputMovementVehicleODMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As ISIAPIOutputMovementVehicleODMCs

value = instance.OutputMovementVehicleODMCs
C#
ISIAPIOutputMovementVehicleODMCs OutputMovementVehicleODMCs {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleODMCs* get_OutputMovementVehicleODMCs();
C++/CLI
property ISIAPIOutputMovementVehicleODMCs^ OutputMovementVehicleODMCs {
   ISIAPIOutputMovementVehicleODMCs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Perc_arriving_during_green
C#
float Perc_arriving_during_green {get;}
Managed Extensions for C++
__property float get_Perc_arriving_during_green();
C++/CLI
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Platoon_ratio
C#
float Platoon_ratio {get;}
Managed Extensions for C++
__property float get_Platoon_ratio();
C++/CLI
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_cycav_mean
C#
float Queue_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_cycav_mean();
C++/CLI
property float Queue_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_cycav_percentile
C#
float Queue_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_cycav_percentile();
C++/CLI
property float Queue_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_mean();
C++/CLI
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_percentile();
C++/CLI
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_mean();
C++/CLI
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_percentile();
C++/CLI
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_greenstart_mean
C#
float Queue_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_mean();
C++/CLI
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
float Queue_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_percentile();
C++/CLI
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_storage_ratio_avg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_avg();
C++/CLI
property float Queue_storage_ratio_avg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Queue_storage_ratio_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_percentile();
C++/CLI
property float Queue_storage_ratio_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Running_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Running_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Running_speed
C#
float Running_speed {get;}
Managed Extensions for C++
__property float get_Running_speed();
C++/CLI
property float Running_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_distance_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_stopline_average
C#
float Travel_distance_stopline_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_stopline_average();
C++/CLI
property float Travel_distance_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_distance_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_stopline_total
C#
float Travel_distance_stopline_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_stopline_total();
C++/CLI
property float Travel_distance_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_time_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_stopline_average
C#
float Travel_time_stopline_average {get;}
Managed Extensions for C++
__property float get_Travel_time_stopline_average();
C++/CLI
property float Travel_time_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_time_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_stopline_total
C#
float Travel_time_stopline_total {get;}
Managed Extensions for C++
__property float get_Travel_time_stopline_total();
C++/CLI
property float Travel_time_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Single

value = instance.Unblocked_time_ratio
C#
float Unblocked_time_ratio {get;}
Managed Extensions for C++
__property float get_Unblocked_time_ratio();
C++/CLI
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleOD Interface : X1_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleOD
Dim value As Integer

value = instance.X1_flag
C#
int X1_flag {get;}
Managed Extensions for C++
__property int get_X1_flag();
C++/CLI
property int X1_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleOD Interface
ISIAPIOutputMovementVehicleOD Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleODMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
C#
public interface ISIAPIOutputMovementVehicleODMC
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleODMC
C++/CLI
public interface class ISIAPIOutputMovementVehicleODMC

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleODMC.

Public Properties

 | Name | Description
Property | Approach_negotiation_speed |
Property | Arrival_flow_flag |
Property | Avg_num_of_cycles_to_depart |
Property | Calc_exists |
Property | Capacity_mov |
Property | Carbon_dioxide_rate |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_rate |
Property | Carbon_monoxide_total |
Property | Cruise_speed |
Property | Deg_satn |
Property | Delay_control_average |
Property | Delay_control_total_persons |
Property | Delay_control_total_veh |
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Destination |
Property | Effective_control |
Property | Equivalent_AT |
Property | Exit_cruise_speed |
Property | Exit_negotiation_speed |
Property | Flow |
Property | Flow_capconstr |
Property | Fuel_consumption_rate |
Property | Fuel_consumption_total |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Green_time_ratio |
Property | Has_continuous_control |
Property | Has_giveway_control |
Property | Has_highangle_slip |
Property | Has_lowangle_slip |
Property | Has_signals_control |
Property | Has_stop_control |
Property | Hydrocarbons_rate |
Property | Hydrocarbons_total |
Property | Initial_demand_vol |
Property | Level_of_service |
Property | MC_class |
Property | Minimum_delay |
Property | Negotiation_distance |
Property | Non_actuated |
Property | Nox_rate |
Property | Nox_total |
Property | Operating_cost_rate |
Property | Operating_cost_total |
Property | Origin |
Property | OutputMovementVehicleOD |
Property | OutputMovementVehicleODMC_GreenPeriods |
Property | Oversatn_duration |
Property | Perc_arriving_during_green |
Property | Performance_index |
Property | Platoon_ratio |
Property | Practical_degree_of_saturation |
Property | Practical_spare_capacity |
Property | Proportion_queued |
Property | Queue_cycav_mean |
Property | Queue_cycav_percentile |
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean |
Property | Queue_dist_maxback_percentile |
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean |
Property | Queue_maxback_percentile |
Property | Queue_storage_ratio_avg |
Property | Queue_storage_ratio_percentile |
Property | Residual_demand_vol |
Property | Residual_demand_vol_clear_time |
Property | Running_speed |
Property | Signal_coordination |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_stopline_average |
Property | Travel_distance_stopline_total |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_stopline_average |
Property | Travel_time_stopline_total |
Property | Travel_time_total |
Property | Unblocked_time_ratio |
Property | X1_flag |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMC members.

Public Properties

 | Name | Description
Property | Approach_negotiation_speed |
Property | Arrival_flow_flag |
Property | Avg_num_of_cycles_to_depart |
Property | Calc_exists |
Property | Capacity_mov |
Property | Carbon_dioxide_rate |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_rate |
Property | Carbon_monoxide_total |
Property | Cruise_speed |
Property | Deg_satn |
Property | Delay_control_average |
Property | Delay_control_total_persons |
Property | Delay_control_total_veh |
Property | Delay_geometric |
Property | Delay_stopline_average |
Property | Destination |
Property | Effective_control |
Property | Equivalent_AT |
Property | Exit_cruise_speed |
Property | Exit_negotiation_speed |
Property | Flow |
Property | Flow_capconstr |
Property | Fuel_consumption_rate |
Property | Fuel_consumption_total |
Property | Gap_accept_blocked_time |
Property | Gap_accept_cycle_time |
Property | Gap_accept_unblocked_time |
Property | Green_periods |
Property | Green_time_ratio |
Property | Has_continuous_control |
Property | Has_giveway_control |
Property | Has_highangle_slip |
Property | Has_lowangle_slip |
Property | Has_signals_control |
Property | Has_stop_control |
Property | Hydrocarbons_rate |
Property | Hydrocarbons_total |
Property | Initial_demand_vol |
Property | Level_of_service |
Property | MC_class |
Property | Minimum_delay |
Property | Negotiation_distance |
Property | Non_actuated |
Property | Nox_rate |
Property | Nox_total |
Property | Operating_cost_rate |
Property | Operating_cost_total |
Property | Origin |
Property | OutputMovementVehicleOD |
Property | OutputMovementVehicleODMC_GreenPeriods |
Property | Oversatn_duration |
Property | Perc_arriving_during_green |
Property | Performance_index |
Property | Platoon_ratio |
Property | Practical_degree_of_saturation |
Property | Practical_spare_capacity |
Property | Proportion_queued |
Property | Queue_cycav_mean |
Property | Queue_cycav_percentile |
Property | Queue_dist_cycav_mean |
Property | Queue_dist_cycav_percentile |
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean |
Property | Queue_dist_maxback_percentile |
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean |
Property | Queue_maxback_percentile |
Property | Queue_storage_ratio_avg |
Property | Queue_storage_ratio_percentile |
Property | Residual_demand_vol |
Property | Residual_demand_vol_clear_time |
Property | Running_speed |
Property | Signal_coordination |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stops_total |
Property | Travel_distance_average |
Property | Travel_distance_stopline_average |
Property | Travel_distance_stopline_total |
Property | Travel_distance_total |
Property | Travel_speed |
Property | Travel_time_average |
Property | Travel_time_stopline_average |
Property | Travel_time_stopline_total |
Property | Travel_time_total |
Property | Unblocked_time_ratio |
Property | X1_flag |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Approach_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Approach_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Approach_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Approach_negotiation_speed
C#
float Approach_negotiation_speed {get;}
Managed Extensions for C++
__property float get_Approach_negotiation_speed();
C++/CLI
property float Approach_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Arrival_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Arrival_flow_flag
C#
int Arrival_flow_flag {get;}
Managed Extensions for C++
__property int get_Arrival_flow_flag();
C++/CLI
property int Arrival_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
__property float get_Avg_num_of_cycles_to_depart();
C++/CLI
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Calc_exists Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Calc_exists Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Calc_exists As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Calc_exists
C#
bool Calc_exists {get;}
Managed Extensions for C++
__property bool get_Calc_exists();
C++/CLI
property bool Calc_exists {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Capacity_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Capacity_mov
C#
float Capacity_mov {get;}
Managed Extensions for C++
__property float get_Capacity_mov();
C++/CLI
property float Capacity_mov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Carbon_dioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
float Carbon_dioxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_rate();
C++/CLI
property float Carbon_dioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Carbon_monoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
float Carbon_monoxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_rate();
C++/CLI
property float Carbon_monoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Cruise_speed
C#
float Cruise_speed {get;}
Managed Extensions for C++
__property float get_Cruise_speed();
C++/CLI
property float Cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_persons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Delay_control_total_persons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_persons As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_total_persons
C#
float Delay_control_total_persons {get;}
Managed Extensions for C++
__property float get_Delay_control_total_persons();
C++/CLI
property float Delay_control_total_persons {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_control_total_veh
C#
float Delay_control_total_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_total_veh();
C++/CLI
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Delay_geometric Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_geometric
C#
float Delay_geometric {get;}
Managed Extensions for C++
__property float get_Delay_geometric();
C++/CLI
property float Delay_geometric {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Effective_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Effective_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Effective_control As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Effective_control
C#
int Effective_control {get;}
Managed Extensions for C++
__property int get_Effective_control();
C++/CLI
property int Effective_control {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Equivalent_AT Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Equivalent_AT Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Equivalent_AT As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Equivalent_AT
C#
int Equivalent_AT {get;}
Managed Extensions for C++
__property int get_Equivalent_AT();
C++/CLI
property int Equivalent_AT {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_cruise_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Exit_cruise_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exit_cruise_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Exit_cruise_speed
C#
float Exit_cruise_speed {get;}
Managed Extensions for C++
__property float get_Exit_cruise_speed();
C++/CLI
property float Exit_cruise_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exit_negotiation_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Exit_negotiation_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Exit_negotiation_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Exit_negotiation_speed
C#
float Exit_negotiation_speed {get;}
Managed Extensions for C++
__property float get_Exit_negotiation_speed();
C++/CLI
property float Exit_negotiation_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Flow
C#
float Flow {get;}
Managed Extensions for C++
__property float get_Flow();
C++/CLI
property float Flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Flow_capconstr Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Flow_capconstr
C#
float Flow_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_capconstr();
C++/CLI
property float Flow_capconstr {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Fuel_consumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Fuel_consumption_rate
C#
float Fuel_consumption_rate {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_rate();
C++/CLI
property float Fuel_consumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_blocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Gap_accept_blocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_blocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_blocked_time
C#
float Gap_accept_blocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_blocked_time();
C++/CLI
property float Gap_accept_blocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Gap_accept_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_cycle_time
C#
float Gap_accept_cycle_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_cycle_time();
C++/CLI
property float Gap_accept_cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Gap_accept_unblocked_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Gap_accept_unblocked_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Gap_accept_unblocked_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Gap_accept_unblocked_time
C#
float Gap_accept_unblocked_time {get;}
Managed Extensions for C++
__property float get_Gap_accept_unblocked_time();
C++/CLI
property float Gap_accept_unblocked_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_periods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Green_periods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_periods As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Green_periods
C#
int Green_periods {get;}
Managed Extensions for C++
__property int get_Green_periods();
C++/CLI
property int Green_periods {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Green_time_ratio
C#
float Green_time_ratio {get;}
Managed Extensions for C++
__property float get_Green_time_ratio();
C++/CLI
property float Green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_continuous_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_continuous_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_continuous_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_continuous_control
C#
bool Has_continuous_control {get;}
Managed Extensions for C++
__property bool get_Has_continuous_control();
C++/CLI
property bool Has_continuous_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_giveway_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_giveway_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_giveway_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_giveway_control
C#
bool Has_giveway_control {get;}
Managed Extensions for C++
__property bool get_Has_giveway_control();
C++/CLI
property bool Has_giveway_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_highangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_highangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_highangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_highangle_slip
C#
bool Has_highangle_slip {get;}
Managed Extensions for C++
__property bool get_Has_highangle_slip();
C++/CLI
property bool Has_highangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_lowangle_slip Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_lowangle_slip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_lowangle_slip As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_lowangle_slip
C#
bool Has_lowangle_slip {get;}
Managed Extensions for C++
__property bool get_Has_lowangle_slip();
C++/CLI
property bool Has_lowangle_slip {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_signals_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_signals_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_signals_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_signals_control
C#
bool Has_signals_control {get;}
Managed Extensions for C++
__property bool get_Has_signals_control();
C++/CLI
property bool Has_signals_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_stop_control Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Has_stop_control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_stop_control As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Has_stop_control
C#
bool Has_stop_control {get;}
Managed Extensions for C++
__property bool get_Has_stop_control();
C++/CLI
property bool Has_stop_control {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Hydrocarbons_rate
C#
float Hydrocarbons_rate {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_rate();
C++/CLI
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Initial_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Initial_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Initial_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Initial_demand_vol
C#
float Initial_demand_vol {get;}
Managed Extensions for C++
__property float get_Initial_demand_vol();
C++/CLI
property float Initial_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Minimum_delay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Minimum_delay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Minimum_delay
C#
float Minimum_delay {get;}
Managed Extensions for C++
__property float get_Minimum_delay();
C++/CLI
property float Minimum_delay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Negotiation_distance Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Negotiation_distance Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Negotiation_distance As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Negotiation_distance
C#
float Negotiation_distance {get;}
Managed Extensions for C++
__property float get_Negotiation_distance();
C++/CLI
property float Negotiation_distance {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Non_actuated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Non_actuated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Non_actuated As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Boolean

value = instance.Non_actuated
C#
bool Non_actuated {get;}
Managed Extensions for C++
__property bool get_Non_actuated();
C++/CLI
property bool Non_actuated {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Nox_rate
C#
float Nox_rate {get;}
Managed Extensions for C++
__property float get_Nox_rate();
C++/CLI
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Operating_cost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Operating_cost_rate
C#
float Operating_cost_rate {get;}
Managed Extensions for C++
__property float get_Operating_cost_rate();
C++/CLI
property float Operating_cost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleOD Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : OutputMovementVehicleOD Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementVehicleOD As ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As ISIAPIOutputMovementVehicleOD

value = instance.OutputMovementVehicleOD
C#
ISIAPIOutputMovementVehicleOD OutputMovementVehicleOD {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleOD* get_OutputMovementVehicleOD();
C++/CLI
property ISIAPIOutputMovementVehicleOD^ OutputMovementVehicleOD {
   ISIAPIOutputMovementVehicleOD^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODMC_GreenPeriods Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : OutputMovementVehicleODMC_GreenPeriods Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementVehicleODMC_GreenPeriods As ISIAPIOutputMovementVehicleODMC_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As ISIAPIOutputMovementVehicleODMC_GreenPeriods

value = instance.OutputMovementVehicleODMC_GreenPeriods
C#
ISIAPIOutputMovementVehicleODMC_GreenPeriods OutputMovementVehicleODMC_GreenPeriods {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleODMC_GreenPeriods* get_OutputMovementVehicleODMC_GreenPeriods();
C++/CLI
property ISIAPIOutputMovementVehicleODMC_GreenPeriods^ OutputMovementVehicleODMC_GreenPeriods {
   ISIAPIOutputMovementVehicleODMC_GreenPeriods^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Oversatn_duration Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Oversatn_duration Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Oversatn_duration As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Oversatn_duration
C#
float Oversatn_duration {get;}
Managed Extensions for C++
__property float get_Oversatn_duration();
C++/CLI
property float Oversatn_duration {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_arriving_during_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Perc_arriving_during_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Perc_arriving_during_green As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Perc_arriving_during_green
C#
float Perc_arriving_during_green {get;}
Managed Extensions for C++
__property float get_Perc_arriving_during_green();
C++/CLI
property float Perc_arriving_during_green {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Platoon_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Platoon_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Platoon_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Platoon_ratio
C#
float Platoon_ratio {get;}
Managed Extensions for C++
__property float get_Platoon_ratio();
C++/CLI
property float Platoon_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_degree_of_saturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Practical_degree_of_saturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_degree_of_saturation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Practical_degree_of_saturation
C#
float Practical_degree_of_saturation {get;}
Managed Extensions for C++
__property float get_Practical_degree_of_saturation();
C++/CLI
property float Practical_degree_of_saturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Proportion_queued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_cycav_mean
C#
float Queue_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_cycav_mean();
C++/CLI
property float Queue_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_cycav_percentile
C#
float Queue_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_cycav_percentile();
C++/CLI
property float Queue_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_cycav_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_mean();
C++/CLI
property float Queue_dist_cycav_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_cycav_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_percentile();
C++/CLI
property float Queue_dist_cycav_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_mean();
C++/CLI
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_percentile();
C++/CLI
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_greenstart_mean
C#
float Queue_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_mean();
C++/CLI
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
float Queue_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_percentile();
C++/CLI
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_maxback_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_storage_ratio_avg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_avg();
C++/CLI
property float Queue_storage_ratio_avg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Queue_storage_ratio_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_percentile();
C++/CLI
property float Queue_storage_ratio_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Residual_demand_vol Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Residual_demand_vol As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Residual_demand_vol
C#
float Residual_demand_vol {get;}
Managed Extensions for C++
__property float get_Residual_demand_vol();
C++/CLI
property float Residual_demand_vol {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Residual_demand_vol_clear_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Residual_demand_vol_clear_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Residual_demand_vol_clear_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Residual_demand_vol_clear_time
C#
float Residual_demand_vol_clear_time {get;}
Managed Extensions for C++
__property float get_Residual_demand_vol_clear_time();
C++/CLI
property float Residual_demand_vol_clear_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Running_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Running_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Running_speed
C#
float Running_speed {get;}
Managed Extensions for C++
__property float get_Running_speed();
C++/CLI
property float Running_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_coordination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Signal_coordination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Signal_coordination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.Signal_coordination
C#
int Signal_coordination {get;}
Managed Extensions for C++
__property int get_Signal_coordination();
C++/CLI
property int Signal_coordination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Stops_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_distance_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_distance_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_stopline_average
C#
float Travel_distance_stopline_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_stopline_average();
C++/CLI
property float Travel_distance_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_distance_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_stopline_total
C#
float Travel_distance_stopline_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_stopline_total();
C++/CLI
property float Travel_distance_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_distance_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_time_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_stopline_average
C#
float Travel_time_stopline_average {get;}
Managed Extensions for C++
__property float get_Travel_time_stopline_average();
C++/CLI
property float Travel_time_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_stopline_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_time_stopline_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_stopline_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_stopline_total
C#
float Travel_time_stopline_total {get;}
Managed Extensions for C++
__property float get_Travel_time_stopline_total();
C++/CLI
property float Travel_time_stopline_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Travel_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unblocked_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : Unblocked_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unblocked_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Single

value = instance.Unblocked_time_ratio
C#
float Unblocked_time_ratio {get;}
Managed Extensions for C++
__property float get_Unblocked_time_ratio();
C++/CLI
property float Unblocked_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X1_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC Interface : X1_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property X1_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC
Dim value As Integer

value = instance.X1_flag
C#
int X1_flag {get;}
Managed Extensions for C++
__property int get_X1_flag();
C++/CLI
property int X1_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC Interface
ISIAPIOutputMovementVehicleODMC Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleODMC_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
C#
public interface ISIAPIOutputMovementVehicleODMC_GreenPeriod
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleODMC_GreenPeriod
C++/CLI
public interface class ISIAPIOutputMovementVehicleODMC_GreenPeriod

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleODMC_GreenPeriod.

Public Properties

 | Name | Description
Property | Adjusted_flow_ratio |
Property | Adjusted_lost_time |
Property | Coord_mov_runs |
Property | Critical_mov |
Property | Displayed_end_time |
Property | Displayed_green_time |
Property | Displayed_start_time |
Property | Eff_end_gain |
Property | Eff_end_time |
Property | Eff_green |
Property | Eff_start_loss |
Property | Eff_start_time |
Property | End_phase |
Property | Flow_ratio |
Property | Greenperiod | Green Period value is a one-based integer.
Property | Lost_time |
Property | Min_max_flag |
Property | No_arrival |
Property | Opposed |
Property | Priority |
Property | Queue_move_up_speed |
Property | Reqd_green_time_ratio |
Property | Reqd_time |
Property | Satn_flow |
Property | Satn_flow_flag |
Property | Start_phase |
Property | Timing_data_type |
Property | Tmax |
Property | Tmin |
Property | Undetected |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMC_GreenPeriod members.

Public Properties

 | Name | Description
Property | Adjusted_flow_ratio |
Property | Adjusted_lost_time |
Property | Coord_mov_runs |
Property | Critical_mov |
Property | Displayed_end_time |
Property | Displayed_green_time |
Property | Displayed_start_time |
Property | Eff_end_gain |
Property | Eff_end_time |
Property | Eff_green |
Property | Eff_start_loss |
Property | Eff_start_time |
Property | End_phase |
Property | Flow_ratio |
Property | Greenperiod | Green Period value is a one-based integer.
Property | Lost_time |
Property | Min_max_flag |
Property | No_arrival |
Property | Opposed |
Property | Priority |
Property | Queue_move_up_speed |
Property | Reqd_green_time_ratio |
Property | Reqd_time |
Property | Satn_flow |
Property | Satn_flow_flag |
Property | Start_phase |
Property | Timing_data_type |
Property | Tmax |
Property | Tmin |
Property | Undetected |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Adjusted_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Adjusted_flow_ratio
C#
float Adjusted_flow_ratio {get;}
Managed Extensions for C++
__property float get_Adjusted_flow_ratio();
C++/CLI
property float Adjusted_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Adjusted_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Adjusted_lost_time
C#
int Adjusted_lost_time {get;}
Managed Extensions for C++
__property int get_Adjusted_lost_time();
C++/CLI
property int Adjusted_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_runs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Coord_mov_runs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_runs As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Coord_mov_runs
C#
bool Coord_mov_runs {get;}
Managed Extensions for C++
__property bool get_Coord_mov_runs();
C++/CLI
property bool Coord_mov_runs {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Critical_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Critical_mov
C#
bool Critical_mov {get;}
Managed Extensions for C++
__property bool get_Critical_mov();
C++/CLI
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Displayed_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_end_time
C#
int Displayed_end_time {get;}
Managed Extensions for C++
__property int get_Displayed_end_time();
C++/CLI
property int Displayed_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_green_time
C#
int Displayed_green_time {get;}
Managed Extensions for C++
__property int get_Displayed_green_time();
C++/CLI
property int Displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Displayed_start_time
C#
int Displayed_start_time {get;}
Managed Extensions for C++
__property int get_Displayed_start_time();
C++/CLI
property int Displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Eff_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_end_gain
C#
int Eff_end_gain {get;}
Managed Extensions for C++
__property int get_Eff_end_gain();
C++/CLI
property int Eff_end_gain {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_end_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Eff_end_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_end_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_end_time
C#
int Eff_end_time {get;}
Managed Extensions for C++
__property int get_Eff_end_time();
C++/CLI
property int Eff_end_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_green
C#
int Eff_green {get;}
Managed Extensions for C++
__property int get_Eff_green();
C++/CLI
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Eff_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_start_loss
C#
int Eff_start_loss {get;}
Managed Extensions for C++
__property int get_Eff_start_loss();
C++/CLI
property int Eff_start_loss {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Eff_start_time
C#
int Eff_start_time {get;}
Managed Extensions for C++
__property int get_Eff_start_time();
C++/CLI
property int Eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : End_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.End_phase
C#
int End_phase {get;}
Managed Extensions for C++
__property int get_End_phase();
C++/CLI
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Flow_ratio
C#
float Flow_ratio {get;}
Managed Extensions for C++
__property float get_Flow_ratio();
C++/CLI
property float Flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Greenperiod Property

Glossary Item Box

Green Period value is a one-based integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Greenperiod
C#
int Greenperiod {get;}
Managed Extensions for C++
__property int get_Greenperiod();
C++/CLI
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Lost_time
C#
int Lost_time {get;}
Managed Extensions for C++
__property int get_Lost_time();
C++/CLI
property int Lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Min_max_flag
C#
int Min_max_flag {get;}
Managed Extensions for C++
__property int get_Min_max_flag();
C++/CLI
property int Min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
No_arrival Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : No_arrival Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property No_arrival As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.No_arrival
C#
bool No_arrival {get;}
Managed Extensions for C++
__property bool get_No_arrival();
C++/CLI
property bool No_arrival {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Opposed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Opposed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Opposed As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Opposed
C#
bool Opposed {get;}
Managed Extensions for C++
__property bool get_Opposed();
C++/CLI
property bool Opposed {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Priority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Priority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Priority As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Priority
C#
bool Priority {get;}
Managed Extensions for C++
__property bool get_Priority();
C++/CLI
property bool Priority {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_move_up_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Queue_move_up_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_move_up_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Queue_move_up_speed
C#
float Queue_move_up_speed {get;}
Managed Extensions for C++
__property float get_Queue_move_up_speed();
C++/CLI
property float Queue_move_up_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Reqd_green_time_ratio
C#
float Reqd_green_time_ratio {get;}
Managed Extensions for C++
__property float get_Reqd_green_time_ratio();
C++/CLI
property float Reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Reqd_time
C#
float Reqd_time {get;}
Managed Extensions for C++
__property float get_Reqd_time();
C++/CLI
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Satn_flow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_flow As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Satn_flow
C#
float Satn_flow {get;}
Managed Extensions for C++
__property float get_Satn_flow();
C++/CLI
property float Satn_flow {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Satn_flow_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Satn_flow_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Satn_flow_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Satn_flow_flag
C#
int Satn_flow_flag {get;}
Managed Extensions for C++
__property int get_Satn_flow_flag();
C++/CLI
property int Satn_flow_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Start_phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Start_phase
C#
int Start_phase {get;}
Managed Extensions for C++
__property int get_Start_phase();
C++/CLI
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Timing_data_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Timing_data_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Timing_data_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Integer

value = instance.Timing_data_type
C#
int Timing_data_type {get;}
Managed Extensions for C++
__property int get_Timing_data_type();
C++/CLI
property int Timing_data_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Tmax
C#
float Tmax {get;}
Managed Extensions for C++
__property float get_Tmax();
C++/CLI
property float Tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Single

value = instance.Tmin
C#
float Tmin {get;}
Managed Extensions for C++
__property float get_Tmin();
C++/CLI
property float Tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Dim value As Boolean

value = instance.Undetected
C#
bool Undetected {get;}
Managed Extensions for C++
__property bool get_Undetected();
C++/CLI
property bool Undetected {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriod Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriod Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleODMC_GreenPeriods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriods
C#
public interface ISIAPIOutputMovementVehicleODMC_GreenPeriods
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleODMC_GreenPeriods
C++/CLI
public interface class ISIAPIOutputMovementVehicleODMC_GreenPeriods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleODMC_GreenPeriods.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement Output Green Period Data. Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMC_GreenPeriods members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GreenPeriodExists | Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GreenPeriodExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface : GreenPeriodExists Method

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a value indicating whether a Vehicle Movement Output Green Period Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function GreenPeriodExists( _
   ByVal greenperiod As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriods
Dim greenperiod As Integer
Dim value As Boolean

value = instance.GreenPeriodExists(greenperiod)
C#
bool GreenPeriodExists(
   int greenperiod
)
Managed Extensions for C++
bool GreenPeriodExists(
   int greenperiod
)
C++/CLI
bool GreenPeriodExists(
   int greenperiod
)

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMC_GreenPeriods members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement Output Green Period Data. Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriods
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface : Item Property

greenperiod

Type: System.Int32;
A one-based integer.

Glossary Item Box

Get a Vehicle Movement Output Green Period Data.
Return a Vehicle Movement Output Green Period Data if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal greenperiod As Integer _
) As ISIAPIOutputMovementVehicleODMC_GreenPeriod
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMC_GreenPeriods
Dim greenperiod As Integer
Dim value As ISIAPIOutputMovementVehicleODMC_GreenPeriod

value = instance.Item(greenperiod)
C#
ISIAPIOutputMovementVehicleODMC_GreenPeriod this[
   int greenperiod
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleODMC_GreenPeriod* get_Item   int greenperiod
;
C++/CLI
property ISIAPIOutputMovementVehicleODMC_GreenPeriod^ default [int] {
   ISIAPIOutputMovementVehicleODMC_GreenPeriod^ get(int greenperiod);
}

Parameters

greenperiod

Type: System.Int32;
A one-based integer.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMC_GreenPeriods Interface
ISIAPIOutputMovementVehicleODMC_GreenPeriods Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMCs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMCs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleODMCs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMCs
C#
public interface ISIAPIOutputMovementVehicleODMCs
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleODMCs
C++/CLI
public interface class ISIAPIOutputMovementVehicleODMCs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMCs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMCs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleODMCs.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementClassExists |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClassExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMCs Interface : MovementClassExists Method

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function MovementClassExists( _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMCs
Dim mcClass As Integer
Dim value As Boolean

value = instance.MovementClassExists(mcClass)
C#
bool MovementClassExists(
   int mcClass
)
Managed Extensions for C++
bool MovementClassExists(
   int mcClass
)
C++/CLI
bool MovementClassExists(
   int mcClass
)

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
ISIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODMCs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODMCs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMCs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMCs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
ISIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODMCs Interface : Item Property

mcClass

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal mcClass As Integer _
) As ISIAPIOutputMovementVehicleODMC
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODMCs
Dim mcClass As Integer
Dim value As ISIAPIOutputMovementVehicleODMC

value = instance.Item(mcClass)
C#
ISIAPIOutputMovementVehicleODMC this[
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleODMC* get_Item   int mcClass
;
C++/CLI
property ISIAPIOutputMovementVehicleODMC^ default [int] {
   ISIAPIOutputMovementVehicleODMC^ get(int mcClass);
}

Parameters

mcClass

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODMCs Interface
ISIAPIOutputMovementVehicleODMCs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODs Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODs Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputMovementVehicleODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODs
C#
public interface ISIAPIOutputMovementVehicleODs
Managed Extensions for C++
public __gc __interface ISIAPIOutputMovementVehicleODs
C++/CLI
public interface class ISIAPIOutputMovementVehicleODs

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODs Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODs Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODs Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputMovementVehicleODs.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement Output Data Object. Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | MovementExists | Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODs Interface : MovementExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a value indicating whether a Vehicle Movement Output Data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function MovementExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODs
Dim origin As Integer
Dim destination As Integer
Dim value As Boolean

value = instance.MovementExists(origin, destination)
C#
bool MovementExists(
   int origin,
   int destination
)
Managed Extensions for C++
bool MovementExists(
   int origin,
   int destination
)
C++/CLI
bool MovementExists(
   int origin,
   int destination
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
ISIAPIOutputMovementVehicleODs Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputMovementVehicleODs Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputMovementVehicleODs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputMovementVehicleODs members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Vehicle Movement Output Data Object. Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODs Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODs
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
ISIAPIOutputMovementVehicleODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputMovementVehicleODs Interface : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Glossary Item Box

Get a Vehicle Movement Output Data Object.
Return a Vehicle Movement Output Data Object if it exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIOutputMovementVehicleOD
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputMovementVehicleODs
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIOutputMovementVehicleOD

value = instance.Item(origin, destination)
C#
ISIAPIOutputMovementVehicleOD this[
   int origin,
   int destination
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleOD* get_Item   int origin,
   int destination
;
C++/CLI
property ISIAPIOutputMovementVehicleOD^ default [int,int] {
   ISIAPIOutputMovementVehicleOD^ get(int origin, int destination);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputMovementVehicleODs Interface
ISIAPIOutputMovementVehicleODs Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetwork Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetwork Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
C#
public interface ISIAPIOutputNetwork
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetwork
C++/CLI
public interface class ISIAPIOutputNetwork

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetwork Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetwork Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetwork.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Analysis_method_flag |
Property | Analysis_status |
Property | Cycle_time_option |
Property | GeneratedByVersion |
Property | GeneratedTime |
Property | IterationsCount | The number of iterations that have been run to get this network output result
Property | Largest_movement_flow_scale |
Property | Network |
Property | NetworkCycleTime |
Property | NetworkSummaryType | Network Summary Type, the summary type of this SIAPIOutputNetwork.
Property | OutputNetworkGraphTuples |
Property | OutputNetworkPedestrian |
Property | OutputNetworkPerson |
Property | OutputNetworkVehicle |
Property | OutputRouteMovementBasedPerson |
Property | OutputRouteMovementBasedVehicle |
Property | Route |
Property | Selected_future_year |
Property | Selected_parameter_scale |
Property | Single_ccg |
Top

See Also

Reference

ISIAPIOutputNetwork Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetwork Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetwork Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetwork members.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Analysis_method_flag |
Property | Analysis_status |
Property | Cycle_time_option |
Property | GeneratedByVersion |
Property | GeneratedTime |
Property | IterationsCount | The number of iterations that have been run to get this network output result
Property | Largest_movement_flow_scale |
Property | Network |
Property | NetworkCycleTime |
Property | NetworkSummaryType | Network Summary Type, the summary type of this SIAPIOutputNetwork.
Property | OutputNetworkGraphTuples |
Property | OutputNetworkPedestrian |
Property | OutputNetworkPerson |
Property | OutputNetworkVehicle |
Property | OutputRouteMovementBasedPerson |
Property | OutputRouteMovementBasedVehicle |
Property | Route |
Property | Selected_future_year |
Property | Selected_parameter_scale |
Property | Single_ccg |
Top

See Also

Reference

ISIAPIOutputNetwork Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_method
C#
int Analysis_method {get;}
Managed Extensions for C++
__property int get_Analysis_method();
C++/CLI
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Analysis_method_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_method_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_method_flag
C#
int Analysis_method_flag {get;}
Managed Extensions for C++
__property int get_Analysis_method_flag();
C++/CLI
property int Analysis_method_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_status Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Analysis_status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_status As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Analysis_status
C#
int Analysis_status {get;}
Managed Extensions for C++
__property int get_Analysis_status();
C++/CLI
property int Analysis_status {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Cycle_time_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Cycle_time_option
C#
int Cycle_time_option {get;}
Managed Extensions for C++
__property int get_Cycle_time_option();
C++/CLI
property int Cycle_time_option {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedByVersion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : GeneratedByVersion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneratedByVersion As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As String

value = instance.GeneratedByVersion
C#
string GeneratedByVersion {get;}
Managed Extensions for C++
__property string* get_GeneratedByVersion();
C++/CLI
property String^ GeneratedByVersion {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : GeneratedTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneratedTime As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Date

value = instance.GeneratedTime
C#
DateTime GeneratedTime {get;}
Managed Extensions for C++
__property DateTime get_GeneratedTime();
C++/CLI
property DateTime GeneratedTime {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : IterationsCount Property

Glossary Item Box

The number of iterations that have been run to get this network output result

Syntax

Visual Basic (Declaration)
ReadOnly Property IterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.IterationsCount
C#
int IterationsCount {get;}
Managed Extensions for C++
__property int get_IterationsCount();
C++/CLI
property int IterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Largest_movement_flow_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Largest_movement_flow_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Largest_movement_flow_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Single

value = instance.Largest_movement_flow_scale
C#
float Largest_movement_flow_scale {get;}
Managed Extensions for C++
__property float get_Largest_movement_flow_scale();
C++/CLI
property float Largest_movement_flow_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkCycleTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : NetworkCycleTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkCycleTime As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.NetworkCycleTime
C#
int NetworkCycleTime {get;}
Managed Extensions for C++
__property int get_NetworkCycleTime();
C++/CLI
property int NetworkCycleTime {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSummaryType Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : NetworkSummaryType Property

Glossary Item Box

Network Summary Type, the summary type of this SIAPIOutputNetwork.

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSummaryType As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.NetworkSummaryType
C#
int NetworkSummaryType {get;}
Managed Extensions for C++
__property int get_NetworkSummaryType();
C++/CLI
property int NetworkSummaryType {
   int get();
}

Property Value

Type: System.Int32;

1 = Whole Network,
2 = Summary for selected Routes,
3 = Summary for a particular Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkGraphTuples Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputNetworkGraphTuples Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetworkGraphTuples As ISIAPIOutputNetworkGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkGraphTuples

value = instance.OutputNetworkGraphTuples
C#
ISIAPIOutputNetworkGraphTuples OutputNetworkGraphTuples {get;}
Managed Extensions for C++
__property ISIAPIOutputNetworkGraphTuples* get_OutputNetworkGraphTuples();
C++/CLI
property ISIAPIOutputNetworkGraphTuples^ OutputNetworkGraphTuples {
   ISIAPIOutputNetworkGraphTuples^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkPedestrian Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputNetworkPedestrian Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetworkPedestrian As ISIAPIOutputNetworkPedestrian
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkPedestrian

value = instance.OutputNetworkPedestrian
C#
ISIAPIOutputNetworkPedestrian OutputNetworkPedestrian {get;}
Managed Extensions for C++
__property ISIAPIOutputNetworkPedestrian* get_OutputNetworkPedestrian();
C++/CLI
property ISIAPIOutputNetworkPedestrian^ OutputNetworkPedestrian {
   ISIAPIOutputNetworkPedestrian^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkPerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputNetworkPerson Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetworkPerson As ISIAPIOutputNetworkPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkPerson

value = instance.OutputNetworkPerson
C#
ISIAPIOutputNetworkPerson OutputNetworkPerson {get;}
Managed Extensions for C++
__property ISIAPIOutputNetworkPerson* get_OutputNetworkPerson();
C++/CLI
property ISIAPIOutputNetworkPerson^ OutputNetworkPerson {
   ISIAPIOutputNetworkPerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputNetworkVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputNetworkVehicle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputNetworkVehicle As ISIAPIOutputNetworkVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputNetworkVehicle

value = instance.OutputNetworkVehicle
C#
ISIAPIOutputNetworkVehicle OutputNetworkVehicle {get;}
Managed Extensions for C++
__property ISIAPIOutputNetworkVehicle* get_OutputNetworkVehicle();
C++/CLI
property ISIAPIOutputNetworkVehicle^ OutputNetworkVehicle {
   ISIAPIOutputNetworkVehicle^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRouteMovementBasedPerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputRouteMovementBasedPerson Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputRouteMovementBasedPerson As ISIAPIOutputRouteMovementBasedPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputRouteMovementBasedPerson

value = instance.OutputRouteMovementBasedPerson
C#
ISIAPIOutputRouteMovementBasedPerson OutputRouteMovementBasedPerson {get;}
Managed Extensions for C++
__property ISIAPIOutputRouteMovementBasedPerson* get_OutputRouteMovementBasedPerson();
C++/CLI
property ISIAPIOutputRouteMovementBasedPerson^ OutputRouteMovementBasedPerson {
   ISIAPIOutputRouteMovementBasedPerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRouteMovementBasedVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : OutputRouteMovementBasedVehicle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputRouteMovementBasedVehicle As ISIAPIOutputRouteMovementBasedVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIOutputRouteMovementBasedVehicle

value = instance.OutputRouteMovementBasedVehicle
C#
ISIAPIOutputRouteMovementBasedVehicle OutputRouteMovementBasedVehicle {get;}
Managed Extensions for C++
__property ISIAPIOutputRouteMovementBasedVehicle* get_OutputRouteMovementBasedVehicle();
C++/CLI
property ISIAPIOutputRouteMovementBasedVehicle^ OutputRouteMovementBasedVehicle {
   ISIAPIOutputRouteMovementBasedVehicle^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Route Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Route As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As ISIAPIRoute

value = instance.Route
C#
ISIAPIRoute Route {get;}
Managed Extensions for C++
__property ISIAPIRoute* get_Route();
C++/CLI
property ISIAPIRoute^ Route {
   ISIAPIRoute^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_future_year Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Selected_future_year Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Selected_future_year As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Selected_future_year
C#
int Selected_future_year {get;}
Managed Extensions for C++
__property int get_Selected_future_year();
C++/CLI
property int Selected_future_year {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_parameter_scale Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Selected_parameter_scale Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Selected_parameter_scale As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Single

value = instance.Selected_parameter_scale
C#
float Selected_parameter_scale {get;}
Managed Extensions for C++
__property float get_Selected_parameter_scale();
C++/CLI
property float Selected_parameter_scale {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Single_ccg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetwork Interface : Single_ccg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Single_ccg As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetwork
Dim value As Integer

value = instance.Single_ccg
C#
int Single_ccg {get;}
Managed Extensions for C++
__property int get_Single_ccg();
C++/CLI
property int Single_ccg {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetwork Interface
ISIAPIOutputNetwork Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuple Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuple Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetworkGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
C#
public interface ISIAPIOutputNetworkGraphTuple
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetworkGraphTuple
C++/CLI
public interface class ISIAPIOutputNetworkGraphTuple

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuple Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuple Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetworkGraphTuple.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Arrival_flow_total_person |
Property | Capacity_effective |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_total |
Property | Cycle_time |
Property | Deg_satn |
Property | Deg_satn_ped |
Property | Delay_control_average |
Property | Delay_control_average_ped |
Property | Delay_control_average_veh |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_average_worstmov_ped |
Property | Delay_control_average_worstmov_person |
Property | Delay_control_total_ped |
Property | Delay_control_total_person |
Property | Delay_control_total_veh |
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Demand_flow_total |
Property | Demand_flow_total_ped |
Property | Demand_flow_total_person |
Property | Fuel_consumption_total |
Property | Hydrocarbons_total |
Property | Level_of_service |
Property | Level_of_service_ped |
Property | Level_of_service_veh |
Property | Nox_total |
Property | Operating_cost_total |
Property | Operating_cost_total_ped |
Property | Operating_cost_total_veh |
Property | Perc_heavy_veh |
Property | Performance_index |
Property | Performance_index_ped |
Property | Performance_index_veh |
Property | Practical_spare_capacity |
Property | Prop_queued_ped |
Property | Prop_queued_person |
Property | Prop_queued_veh |
Property | Queue_dist_maxback_percentile |
Property | Queue_maxback_percentile |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stop_rate_ped |
Property | Stop_rate_veh |
Property | Total_stops_ped |
Property | Total_stops_person |
Property | Total_stops_veh |
Property | Travel_dist_av_ped |
Property | Travel_dist_av_person |
Property | Travel_dist_av_veh |
Property | Travel_dist_total_ped |
Property | Travel_dist_total_person |
Property | Travel_dist_total_veh |
Property | Travel_speed |
Property | Travel_speed_ped |
Property | Travel_speed_person |
Property | Travel_time_av_ped |
Property | Travel_time_av_person |
Property | Travel_time_av_veh |
Property | Travel_time_total_ped |
Property | Travel_time_total_person |
Property | Travel_time_total_veh |
Property | Unsettled |
Property | X_value |
Top

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuple Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuple Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkGraphTuple members.

Public Properties

 | Name | Description
Property | Arrival_flow_total |
Property | Arrival_flow_total_person |
Property | Capacity_effective |
Property | Carbon_dioxide_total |
Property | Carbon_monoxide_total |
Property | Cycle_time |
Property | Deg_satn |
Property | Deg_satn_ped |
Property | Delay_control_average |
Property | Delay_control_average_ped |
Property | Delay_control_average_veh |
Property | Delay_control_average_worstlane |
Property | Delay_control_average_worstmov |
Property | Delay_control_average_worstmov_ped |
Property | Delay_control_average_worstmov_person |
Property | Delay_control_total_ped |
Property | Delay_control_total_person |
Property | Delay_control_total_veh |
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Demand_flow_total |
Property | Demand_flow_total_ped |
Property | Demand_flow_total_person |
Property | Fuel_consumption_total |
Property | Hydrocarbons_total |
Property | Level_of_service |
Property | Level_of_service_ped |
Property | Level_of_service_veh |
Property | Nox_total |
Property | Operating_cost_total |
Property | Operating_cost_total_ped |
Property | Operating_cost_total_veh |
Property | Perc_heavy_veh |
Property | Performance_index |
Property | Performance_index_ped |
Property | Performance_index_veh |
Property | Practical_spare_capacity |
Property | Prop_queued_ped |
Property | Prop_queued_person |
Property | Prop_queued_veh |
Property | Queue_dist_maxback_percentile |
Property | Queue_maxback_percentile |
Property | SpeedEfficiency |
Property | Stop_rate |
Property | Stop_rate_ped |
Property | Stop_rate_veh |
Property | Total_stops_ped |
Property | Total_stops_person |
Property | Total_stops_veh |
Property | Travel_dist_av_ped |
Property | Travel_dist_av_person |
Property | Travel_dist_av_veh |
Property | Travel_dist_total_ped |
Property | Travel_dist_total_person |
Property | Travel_dist_total_veh |
Property | Travel_speed |
Property | Travel_speed_ped |
Property | Travel_speed_person |
Property | Travel_time_av_ped |
Property | Travel_time_av_person |
Property | Travel_time_av_veh |
Property | Travel_time_total_ped |
Property | Travel_time_total_person |
Property | Travel_time_total_veh |
Property | Unsettled |
Property | X_value |
Top

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Arrival_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Arrival_flow_total
C#
float Arrival_flow_total {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total();
C++/CLI
property float Arrival_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Arrival_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Arrival_flow_total_person
C#
float Arrival_flow_total_person {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total_person();
C++/CLI
property float Arrival_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Capacity_effective
C#
float Capacity_effective {get;}
Managed Extensions for C++
__property float get_Capacity_effective();
C++/CLI
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Carbon_dioxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Carbon_monoxide_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Cycle_time
C#
float Cycle_time {get;}
Managed Extensions for C++
__property float get_Cycle_time();
C++/CLI
property float Cycle_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Deg_satn Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Deg_satn_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Deg_satn_ped
C#
float Deg_satn_ped {get;}
Managed Extensions for C++
__property float get_Deg_satn_ped();
C++/CLI
property float Deg_satn_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_ped
C#
float Delay_control_average_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_average_ped();
C++/CLI
property float Delay_control_average_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_veh
C#
float Delay_control_average_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_average_veh();
C++/CLI
property float Delay_control_average_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
float Delay_control_average_worstlane {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstlane();
C++/CLI
property float Delay_control_average_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_worstmov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_worstmov_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_ped
C#
float Delay_control_average_worstmov_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov_ped();
C++/CLI
property float Delay_control_average_worstmov_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_average_worstmov_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_average_worstmov_person
C#
float Delay_control_average_worstmov_person {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov_person();
C++/CLI
property float Delay_control_average_worstmov_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_ped
C#
float Delay_control_total_ped {get;}
Managed Extensions for C++
__property float get_Delay_control_total_ped();
C++/CLI
property float Delay_control_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_person
C#
float Delay_control_total_person {get;}
Managed Extensions for C++
__property float get_Delay_control_total_person();
C++/CLI
property float Delay_control_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_control_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_control_total_veh
C#
float Delay_control_total_veh {get;}
Managed Extensions for C++
__property float get_Delay_control_total_veh();
C++/CLI
property float Delay_control_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_geometric_average
C#
float Delay_geometric_average {get;}
Managed Extensions for C++
__property float get_Delay_geometric_average();
C++/CLI
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Demand_flow_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Demand_flow_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total_ped
C#
float Demand_flow_total_ped {get;}
Managed Extensions for C++
__property float get_Demand_flow_total_ped();
C++/CLI
property float Demand_flow_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Demand_flow_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Demand_flow_total_person
C#
float Demand_flow_total_person {get;}
Managed Extensions for C++
__property float get_Demand_flow_total_person();
C++/CLI
property float Demand_flow_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Fuel_consumption_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Hydrocarbons_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Level_of_service Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service
C#
int Level_of_service {get;}
Managed Extensions for C++
__property int get_Level_of_service();
C++/CLI
property int Level_of_service {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Level_of_service_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_ped As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service_ped
C#
int Level_of_service_ped {get;}
Managed Extensions for C++
__property int get_Level_of_service_ped();
C++/CLI
property int Level_of_service_ped {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Level_of_service_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_veh As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Integer

value = instance.Level_of_service_veh
C#
int Level_of_service_veh {get;}
Managed Extensions for C++
__property int get_Level_of_service_veh();
C++/CLI
property int Level_of_service_veh {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Nox_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Operating_cost_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Operating_cost_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total_ped
C#
float Operating_cost_total_ped {get;}
Managed Extensions for C++
__property float get_Operating_cost_total_ped();
C++/CLI
property float Operating_cost_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Operating_cost_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Operating_cost_total_veh
C#
float Operating_cost_total_veh {get;}
Managed Extensions for C++
__property float get_Operating_cost_total_veh();
C++/CLI
property float Operating_cost_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Perc_heavy_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Perc_heavy_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Perc_heavy_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Perc_heavy_veh
C#
float Perc_heavy_veh {get;}
Managed Extensions for C++
__property float get_Perc_heavy_veh();
C++/CLI
property float Perc_heavy_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Performance_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Performance_index_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index_ped
C#
float Performance_index_ped {get;}
Managed Extensions for C++
__property float get_Performance_index_ped();
C++/CLI
property float Performance_index_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Performance_index_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Performance_index_veh
C#
float Performance_index_veh {get;}
Managed Extensions for C++
__property float get_Performance_index_veh();
C++/CLI
property float Performance_index_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Prop_queued_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_ped
C#
float Prop_queued_ped {get;}
Managed Extensions for C++
__property float get_Prop_queued_ped();
C++/CLI
property float Prop_queued_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Prop_queued_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_person
C#
float Prop_queued_person {get;}
Managed Extensions for C++
__property float get_Prop_queued_person();
C++/CLI
property float Prop_queued_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Prop_queued_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Prop_queued_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Prop_queued_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Prop_queued_veh
C#
float Prop_queued_veh {get;}
Managed Extensions for C++
__property float get_Prop_queued_veh();
C++/CLI
property float Prop_queued_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Queue_maxback_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Stop_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Stop_rate_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate_ped
C#
float Stop_rate_ped {get;}
Managed Extensions for C++
__property float get_Stop_rate_ped();
C++/CLI
property float Stop_rate_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Stop_rate_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Stop_rate_veh
C#
float Stop_rate_veh {get;}
Managed Extensions for C++
__property float get_Stop_rate_veh();
C++/CLI
property float Stop_rate_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Total_stops_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_ped
C#
float Total_stops_ped {get;}
Managed Extensions for C++
__property float get_Total_stops_ped();
C++/CLI
property float Total_stops_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Total_stops_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_person
C#
float Total_stops_person {get;}
Managed Extensions for C++
__property float get_Total_stops_person();
C++/CLI
property float Total_stops_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Total_stops_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Total_stops_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Total_stops_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Total_stops_veh
C#
float Total_stops_veh {get;}
Managed Extensions for C++
__property float get_Total_stops_veh();
C++/CLI
property float Total_stops_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_ped
C#
float Travel_dist_av_ped {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_ped();
C++/CLI
property float Travel_dist_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_person
C#
float Travel_dist_av_person {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_person();
C++/CLI
property float Travel_dist_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_av_veh
C#
float Travel_dist_av_veh {get;}
Managed Extensions for C++
__property float get_Travel_dist_av_veh();
C++/CLI
property float Travel_dist_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_ped
C#
float Travel_dist_total_ped {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_ped();
C++/CLI
property float Travel_dist_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_person
C#
float Travel_dist_total_person {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_person();
C++/CLI
property float Travel_dist_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_dist_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_dist_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_dist_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_dist_total_veh
C#
float Travel_dist_total_veh {get;}
Managed Extensions for C++
__property float get_Travel_dist_total_veh();
C++/CLI
property float Travel_dist_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_speed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_speed_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed_ped
C#
float Travel_speed_ped {get;}
Managed Extensions for C++
__property float get_Travel_speed_ped();
C++/CLI
property float Travel_speed_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_speed_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_speed_person
C#
float Travel_speed_person {get;}
Managed Extensions for C++
__property float get_Travel_speed_person();
C++/CLI
property float Travel_speed_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_av_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_ped
C#
float Travel_time_av_ped {get;}
Managed Extensions for C++
__property float get_Travel_time_av_ped();
C++/CLI
property float Travel_time_av_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_av_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_person
C#
float Travel_time_av_person {get;}
Managed Extensions for C++
__property float get_Travel_time_av_person();
C++/CLI
property float Travel_time_av_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_av_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_av_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_av_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_av_veh
C#
float Travel_time_av_veh {get;}
Managed Extensions for C++
__property float get_Travel_time_av_veh();
C++/CLI
property float Travel_time_av_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_ped Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_total_ped Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_ped As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_ped
C#
float Travel_time_total_ped {get;}
Managed Extensions for C++
__property float get_Travel_time_total_ped();
C++/CLI
property float Travel_time_total_ped {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_person Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_total_person Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_person As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_person
C#
float Travel_time_total_person {get;}
Managed Extensions for C++
__property float get_Travel_time_total_person();
C++/CLI
property float Travel_time_total_person {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total_veh Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Travel_time_total_veh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total_veh As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.Travel_time_total_veh
C#
float Travel_time_total_veh {get;}
Managed Extensions for C++
__property float get_Travel_time_total_veh();
C++/CLI
property float Travel_time_total_veh {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unsettled Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : Unsettled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Unsettled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Boolean

value = instance.Unsettled
C#
bool Unsettled {get;}
Managed Extensions for C++
__property bool get_Unsettled();
C++/CLI
property bool Unsettled {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
X_value Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuple Interface : X_value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property X_value As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuple
Dim value As Single

value = instance.X_value
C#
float X_value {get;}
Managed Extensions for C++
__property float get_X_value();
C++/CLI
property float X_value {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuple Interface
ISIAPIOutputNetworkGraphTuple Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuples Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuples Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetworkGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuples
C#
public interface ISIAPIOutputNetworkGraphTuples
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetworkGraphTuples
C++/CLI
public interface class ISIAPIOutputNetworkGraphTuples

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuples Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuples Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuples Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetworkGraphTuples.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputNetworkGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuples Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuples Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkGraphTuples members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputNetworkGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuples Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuples
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuples Interface
ISIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkGraphTuples Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputNetworkGraphTuple
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkGraphTuples
Dim index As Integer
Dim value As ISIAPIOutputNetworkGraphTuple

value = instance.Item(index)
C#
ISIAPIOutputNetworkGraphTuple this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputNetworkGraphTuple* get_Item   int index
;
C++/CLI
property ISIAPIOutputNetworkGraphTuple^ default [int] {
   ISIAPIOutputNetworkGraphTuple^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkGraphTuples Interface
ISIAPIOutputNetworkGraphTuples Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPedestrian Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPedestrian Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetworkPedestrian
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
C#
public interface ISIAPIOutputNetworkPedestrian
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetworkPedestrian
C++/CLI
public interface class ISIAPIOutputNetworkPedestrian

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPedestrian Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPedestrian Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetworkPedestrian.

Public Properties

 | Name | Description
Property | ArrivalFlowTotal |
Property | DelayControlAverage |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DemandFlowTotal |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | ProportionQueued |
Property | StopRate |
Property | StopsTotal |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPedestrian Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPedestrian Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkPedestrian members.

Public Properties

 | Name | Description
Property | ArrivalFlowTotal |
Property | DelayControlAverage |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DemandFlowTotal |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | ProportionQueued |
Property | StopRate |
Property | StopsTotal |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.ArrivalFlowTotal
C#
float ArrivalFlowTotal {get;}
Managed Extensions for C++
__property float get_ArrivalFlowTotal();
C++/CLI
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlAverage
C#
float DelayControlAverage {get;}
Managed Extensions for C++
__property float get_DelayControlAverage();
C++/CLI
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
__property float get_DelayControlAverageWorstMovement();
C++/CLI
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DelayControlTotal
C#
float DelayControlTotal {get;}
Managed Extensions for C++
__property float get_DelayControlTotal();
C++/CLI
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.DemandFlowTotal
C#
float DemandFlowTotal {get;}
Managed Extensions for C++
__property float get_DemandFlowTotal();
C++/CLI
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.OperatingCostTotal
C#
float OperatingCostTotal {get;}
Managed Extensions for C++
__property float get_OperatingCostTotal();
C++/CLI
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.PerformanceIndex
C#
float PerformanceIndex {get;}
Managed Extensions for C++
__property float get_PerformanceIndex();
C++/CLI
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.ProportionQueued
C#
float ProportionQueued {get;}
Managed Extensions for C++
__property float get_ProportionQueued();
C++/CLI
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.StopRate
C#
float StopRate {get;}
Managed Extensions for C++
__property float get_StopRate();
C++/CLI
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.StopsTotal
C#
float StopsTotal {get;}
Managed Extensions for C++
__property float get_StopsTotal();
C++/CLI
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelDistanceAverage
C#
float TravelDistanceAverage {get;}
Managed Extensions for C++
__property float get_TravelDistanceAverage();
C++/CLI
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelDistanceTotal
C#
float TravelDistanceTotal {get;}
Managed Extensions for C++
__property float get_TravelDistanceTotal();
C++/CLI
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelSpeed
C#
float TravelSpeed {get;}
Managed Extensions for C++
__property float get_TravelSpeed();
C++/CLI
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelTimeAverage
C#
float TravelTimeAverage {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage();
C++/CLI
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPedestrian Interface : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPedestrian
Dim value As Single

value = instance.TravelTimeTotal
C#
float TravelTimeTotal {get;}
Managed Extensions for C++
__property float get_TravelTimeTotal();
C++/CLI
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPedestrian Interface
ISIAPIOutputNetworkPedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPerson Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPerson Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetworkPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
C#
public interface ISIAPIOutputNetworkPerson
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetworkPerson
C++/CLI
public interface class ISIAPIOutputNetworkPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPerson Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPerson Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetworkPerson.

Public Properties

 | Name | Description
Property | ArrivalFlowTotal |
Property | DelayControlAverage |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DemandFlowTotal |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | ProportionQueued |
Property | StopRate |
Property | StopsTotal |
Property | TravelDelay |
Property | TravelDelayAverage |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkPerson Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkPerson Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkPerson members.

Public Properties

 | Name | Description
Property | ArrivalFlowTotal |
Property | DelayControlAverage |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DemandFlowTotal |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | ProportionQueued |
Property | StopRate |
Property | StopsTotal |
Property | TravelDelay |
Property | TravelDelayAverage |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.ArrivalFlowTotal
C#
float ArrivalFlowTotal {get;}
Managed Extensions for C++
__property float get_ArrivalFlowTotal();
C++/CLI
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlAverage
C#
float DelayControlAverage {get;}
Managed Extensions for C++
__property float get_DelayControlAverage();
C++/CLI
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
__property float get_DelayControlAverageWorstMovement();
C++/CLI
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.DelayControlTotal
C#
float DelayControlTotal {get;}
Managed Extensions for C++
__property float get_DelayControlTotal();
C++/CLI
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.DemandFlowTotal
C#
float DemandFlowTotal {get;}
Managed Extensions for C++
__property float get_DemandFlowTotal();
C++/CLI
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.OperatingCostTotal
C#
float OperatingCostTotal {get;}
Managed Extensions for C++
__property float get_OperatingCostTotal();
C++/CLI
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.PerformanceIndex
C#
float PerformanceIndex {get;}
Managed Extensions for C++
__property float get_PerformanceIndex();
C++/CLI
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.ProportionQueued
C#
float ProportionQueued {get;}
Managed Extensions for C++
__property float get_ProportionQueued();
C++/CLI
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.StopRate
C#
float StopRate {get;}
Managed Extensions for C++
__property float get_StopRate();
C++/CLI
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.StopsTotal
C#
float StopsTotal {get;}
Managed Extensions for C++
__property float get_StopsTotal();
C++/CLI
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDelay
C#
float TravelDelay {get;}
Managed Extensions for C++
__property float get_TravelDelay();
C++/CLI
property float TravelDelay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDelayAverage
C#
float TravelDelayAverage {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage();
C++/CLI
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDistanceAverage
C#
float TravelDistanceAverage {get;}
Managed Extensions for C++
__property float get_TravelDistanceAverage();
C++/CLI
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelDistanceTotal
C#
float TravelDistanceTotal {get;}
Managed Extensions for C++
__property float get_TravelDistanceTotal();
C++/CLI
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelSpeed
C#
float TravelSpeed {get;}
Managed Extensions for C++
__property float get_TravelSpeed();
C++/CLI
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelTimeAverage
C#
float TravelTimeAverage {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage();
C++/CLI
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkPerson Interface : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkPerson
Dim value As Single

value = instance.TravelTimeTotal
C#
float TravelTimeTotal {get;}
Managed Extensions for C++
__property float get_TravelTimeTotal();
C++/CLI
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkPerson Interface
ISIAPIOutputNetworkPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkVehicle Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkVehicle Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputNetworkVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
C#
public interface ISIAPIOutputNetworkVehicle
Managed Extensions for C++
public __gc __interface ISIAPIOutputNetworkVehicle
C++/CLI
public interface class ISIAPIOutputNetworkVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkVehicle Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkVehicle Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputNetworkVehicle.

Public Properties

 | Name | Description
Property | ArrivalFlow_HV_pct |
Property | ArrivalFlowTotal |
Property | Capacity_effective |
Property | CarbonDioxide_rate |
Property | CarbonDioxideTotal |
Property | CarbonMonoxide_rate |
Property | CarbonMonoxideTotal |
Property | CongestionCoefficient |
Property | DegreeSaturation |
Property | DelayControlAverage |
Property | DelayControlAverageWorstLane |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DelayGeometricAverage |
Property | DelayStoplineAverage |
Property | DemandFlow_HV_pct |
Property | DemandFlowTotal |
Property | DesiredSpeed |
Property | DesiredSpeedMethod |
Property | DesiredTripTime |
Property | DesiredTripTime_rate |
Property | FuelConsumption_rate |
Property | FuelConsumptionTotal |
Property | FuelEconomy |
Property | Hydrocarbons_rate |
Property | HydrocarbonsTotal |
Property | IdlingTimeAvg |
Property | IdlingTimeAvgerage_pct |
Property | IdlingTimeAvgerage_rate |
Property | LevelOfService |
Property | Max_dx_percent |
Property | Max_dx_percent_prev |
Property | Max_dx_percent_prev2 |
Property | Min_dx_percent |
Property | Nox_rate |
Property | NoxTotal |
Property | NwModel_vari_index |
Property | OperatingCost_rate |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | Practical_spare_capacity |
Property | ProportionQueued |
Property | QueueStorageRatioAverage |
Property | QueueStorageRatioMaximum |
Property | RunningTimeAvg |
Property | RunningTimeAvgerage_pct |
Property | RunningTimeAvgerage_rate |
Property | SpeedEfficiency |
Property | StopRate |
Property | StopRate_rate |
Property | StopsTotal |
Property | TravelDelay |
Property | TravelDelay_pct |
Property | TravelDelay_rate |
Property | TravelDelayAverage |
Property | TravelDelayAverage_rate |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeAverage_rate |
Property | TravelTimeIndex |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkVehicle Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkVehicle Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkVehicle members.

Public Properties

 | Name | Description
Property | ArrivalFlow_HV_pct |
Property | ArrivalFlowTotal |
Property | Capacity_effective |
Property | CarbonDioxide_rate |
Property | CarbonDioxideTotal |
Property | CarbonMonoxide_rate |
Property | CarbonMonoxideTotal |
Property | CongestionCoefficient |
Property | DegreeSaturation |
Property | DelayControlAverage |
Property | DelayControlAverageWorstLane |
Property | DelayControlAverageWorstMovement |
Property | DelayControlTotal |
Property | DelayGeometricAverage |
Property | DelayStoplineAverage |
Property | DemandFlow_HV_pct |
Property | DemandFlowTotal |
Property | DesiredSpeed |
Property | DesiredSpeedMethod |
Property | DesiredTripTime |
Property | DesiredTripTime_rate |
Property | FuelConsumption_rate |
Property | FuelConsumptionTotal |
Property | FuelEconomy |
Property | Hydrocarbons_rate |
Property | HydrocarbonsTotal |
Property | IdlingTimeAvg |
Property | IdlingTimeAvgerage_pct |
Property | IdlingTimeAvgerage_rate |
Property | LevelOfService |
Property | Max_dx_percent |
Property | Max_dx_percent_prev |
Property | Max_dx_percent_prev2 |
Property | Min_dx_percent |
Property | Nox_rate |
Property | NoxTotal |
Property | NwModel_vari_index |
Property | OperatingCost_rate |
Property | OperatingCostTotal |
Property | PerformanceIndex |
Property | Practical_spare_capacity |
Property | ProportionQueued |
Property | QueueStorageRatioAverage |
Property | QueueStorageRatioMaximum |
Property | RunningTimeAvg |
Property | RunningTimeAvgerage_pct |
Property | RunningTimeAvgerage_rate |
Property | SpeedEfficiency |
Property | StopRate |
Property | StopRate_rate |
Property | StopsTotal |
Property | TravelDelay |
Property | TravelDelay_pct |
Property | TravelDelay_rate |
Property | TravelDelayAverage |
Property | TravelDelayAverage_rate |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeAverage_rate |
Property | TravelTimeIndex |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : ArrivalFlow_HV_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ArrivalFlow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ArrivalFlow_HV_pct
C#
float ArrivalFlow_HV_pct {get;}
Managed Extensions for C++
__property float get_ArrivalFlow_HV_pct();
C++/CLI
property float ArrivalFlow_HV_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ArrivalFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : ArrivalFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ArrivalFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ArrivalFlowTotal
C#
float ArrivalFlowTotal {get;}
Managed Extensions for C++
__property float get_ArrivalFlowTotal();
C++/CLI
property float ArrivalFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Capacity_effective Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Capacity_effective
C#
float Capacity_effective {get;}
Managed Extensions for C++
__property float get_Capacity_effective();
C++/CLI
property float Capacity_effective {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonDioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : CarbonDioxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CarbonDioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonDioxide_rate
C#
float CarbonDioxide_rate {get;}
Managed Extensions for C++
__property float get_CarbonDioxide_rate();
C++/CLI
property float CarbonDioxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonDioxideTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : CarbonDioxideTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CarbonDioxideTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonDioxideTotal
C#
float CarbonDioxideTotal {get;}
Managed Extensions for C++
__property float get_CarbonDioxideTotal();
C++/CLI
property float CarbonDioxideTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonMonoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : CarbonMonoxide_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CarbonMonoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonMonoxide_rate
C#
float CarbonMonoxide_rate {get;}
Managed Extensions for C++
__property float get_CarbonMonoxide_rate();
C++/CLI
property float CarbonMonoxide_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CarbonMonoxideTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : CarbonMonoxideTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CarbonMonoxideTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CarbonMonoxideTotal
C#
float CarbonMonoxideTotal {get;}
Managed Extensions for C++
__property float get_CarbonMonoxideTotal();
C++/CLI
property float CarbonMonoxideTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CongestionCoefficient Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : CongestionCoefficient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CongestionCoefficient As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.CongestionCoefficient
C#
float CongestionCoefficient {get;}
Managed Extensions for C++
__property float get_CongestionCoefficient();
C++/CLI
property float CongestionCoefficient {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DegreeSaturation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DegreeSaturation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DegreeSaturation As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DegreeSaturation
C#
float DegreeSaturation {get;}
Managed Extensions for C++
__property float get_DegreeSaturation();
C++/CLI
property float DegreeSaturation {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayControlAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverage
C#
float DelayControlAverage {get;}
Managed Extensions for C++
__property float get_DelayControlAverage();
C++/CLI
property float DelayControlAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstLane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayControlAverageWorstLane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverageWorstLane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverageWorstLane
C#
float DelayControlAverageWorstLane {get;}
Managed Extensions for C++
__property float get_DelayControlAverageWorstLane();
C++/CLI
property float DelayControlAverageWorstLane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlAverageWorstMovement Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayControlAverageWorstMovement Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlAverageWorstMovement As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlAverageWorstMovement
C#
float DelayControlAverageWorstMovement {get;}
Managed Extensions for C++
__property float get_DelayControlAverageWorstMovement();
C++/CLI
property float DelayControlAverageWorstMovement {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayControlTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayControlTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayControlTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayControlTotal
C#
float DelayControlTotal {get;}
Managed Extensions for C++
__property float get_DelayControlTotal();
C++/CLI
property float DelayControlTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayGeometricAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayGeometricAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayGeometricAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayGeometricAverage
C#
float DelayGeometricAverage {get;}
Managed Extensions for C++
__property float get_DelayGeometricAverage();
C++/CLI
property float DelayGeometricAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DelayStoplineAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DelayStoplineAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DelayStoplineAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DelayStoplineAverage
C#
float DelayStoplineAverage {get;}
Managed Extensions for C++
__property float get_DelayStoplineAverage();
C++/CLI
property float DelayStoplineAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DemandFlow_HV_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DemandFlow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DemandFlow_HV_pct
C#
float DemandFlow_HV_pct {get;}
Managed Extensions for C++
__property float get_DemandFlow_HV_pct();
C++/CLI
property float DemandFlow_HV_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DemandFlowTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DemandFlowTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DemandFlowTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DemandFlowTotal
C#
float DemandFlowTotal {get;}
Managed Extensions for C++
__property float get_DemandFlowTotal();
C++/CLI
property float DemandFlowTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredSpeed
C#
float DesiredSpeed {get;}
Managed Extensions for C++
__property float get_DesiredSpeed();
C++/CLI
property float DesiredSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
int DesiredSpeedMethod {get;}
Managed Extensions for C++
__property int get_DesiredSpeedMethod();
C++/CLI
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredTripTime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DesiredTripTime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredTripTime As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredTripTime
C#
float DesiredTripTime {get;}
Managed Extensions for C++
__property float get_DesiredTripTime();
C++/CLI
property float DesiredTripTime {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredTripTime_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : DesiredTripTime_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredTripTime_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.DesiredTripTime_rate
C#
float DesiredTripTime_rate {get;}
Managed Extensions for C++
__property float get_DesiredTripTime_rate();
C++/CLI
property float DesiredTripTime_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelConsumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : FuelConsumption_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property FuelConsumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelConsumption_rate
C#
float FuelConsumption_rate {get;}
Managed Extensions for C++
__property float get_FuelConsumption_rate();
C++/CLI
property float FuelConsumption_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelConsumptionTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : FuelConsumptionTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property FuelConsumptionTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelConsumptionTotal
C#
float FuelConsumptionTotal {get;}
Managed Extensions for C++
__property float get_FuelConsumptionTotal();
C++/CLI
property float FuelConsumptionTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
FuelEconomy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : FuelEconomy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property FuelEconomy As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.FuelEconomy
C#
float FuelEconomy {get;}
Managed Extensions for C++
__property float get_FuelEconomy();
C++/CLI
property float FuelEconomy {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Hydrocarbons_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Hydrocarbons_rate
C#
float Hydrocarbons_rate {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_rate();
C++/CLI
property float Hydrocarbons_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HydrocarbonsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : HydrocarbonsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property HydrocarbonsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.HydrocarbonsTotal
C#
float HydrocarbonsTotal {get;}
Managed Extensions for C++
__property float get_HydrocarbonsTotal();
C++/CLI
property float HydrocarbonsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : IdlingTimeAvg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IdlingTimeAvg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvg
C#
float IdlingTimeAvg {get;}
Managed Extensions for C++
__property float get_IdlingTimeAvg();
C++/CLI
property float IdlingTimeAvg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvgerage_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : IdlingTimeAvgerage_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IdlingTimeAvgerage_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvgerage_pct
C#
float IdlingTimeAvgerage_pct {get;}
Managed Extensions for C++
__property float get_IdlingTimeAvgerage_pct();
C++/CLI
property float IdlingTimeAvgerage_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IdlingTimeAvgerage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : IdlingTimeAvgerage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IdlingTimeAvgerage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.IdlingTimeAvgerage_rate
C#
float IdlingTimeAvgerage_rate {get;}
Managed Extensions for C++
__property float get_IdlingTimeAvgerage_rate();
C++/CLI
property float IdlingTimeAvgerage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LevelOfService Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : LevelOfService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LevelOfService As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As String

value = instance.LevelOfService
C#
string LevelOfService {get;}
Managed Extensions for C++
__property string* get_LevelOfService();
C++/CLI
property String^ LevelOfService {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Max_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent
C#
float Max_dx_percent {get;}
Managed Extensions for C++
__property float get_Max_dx_percent();
C++/CLI
property float Max_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Max_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent_prev
C#
float Max_dx_percent_prev {get;}
Managed Extensions for C++
__property float get_Max_dx_percent_prev();
C++/CLI
property float Max_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Max_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Max_dx_percent_prev2
C#
float Max_dx_percent_prev2 {get;}
Managed Extensions for C++
__property float get_Max_dx_percent_prev2();
C++/CLI
property float Max_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Min_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Min_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Min_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Min_dx_percent
C#
float Min_dx_percent {get;}
Managed Extensions for C++
__property float get_Min_dx_percent();
C++/CLI
property float Min_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Nox_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Nox_rate
C#
float Nox_rate {get;}
Managed Extensions for C++
__property float get_Nox_rate();
C++/CLI
property float Nox_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NoxTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : NoxTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NoxTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.NoxTotal
C#
float NoxTotal {get;}
Managed Extensions for C++
__property float get_NoxTotal();
C++/CLI
property float NoxTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwModel_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : NwModel_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NwModel_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.NwModel_vari_index
C#
float NwModel_vari_index {get;}
Managed Extensions for C++
__property float get_NwModel_vari_index();
C++/CLI
property float NwModel_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : OperatingCost_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OperatingCost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.OperatingCost_rate
C#
float OperatingCost_rate {get;}
Managed Extensions for C++
__property float get_OperatingCost_rate();
C++/CLI
property float OperatingCost_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OperatingCostTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : OperatingCostTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OperatingCostTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.OperatingCostTotal
C#
float OperatingCostTotal {get;}
Managed Extensions for C++
__property float get_OperatingCostTotal();
C++/CLI
property float OperatingCostTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PerformanceIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : PerformanceIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property PerformanceIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.PerformanceIndex
C#
float PerformanceIndex {get;}
Managed Extensions for C++
__property float get_PerformanceIndex();
C++/CLI
property float PerformanceIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : Practical_spare_capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProportionQueued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : ProportionQueued Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ProportionQueued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.ProportionQueued
C#
float ProportionQueued {get;}
Managed Extensions for C++
__property float get_ProportionQueued();
C++/CLI
property float ProportionQueued {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
QueueStorageRatioAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : QueueStorageRatioAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property QueueStorageRatioAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.QueueStorageRatioAverage
C#
float QueueStorageRatioAverage {get;}
Managed Extensions for C++
__property float get_QueueStorageRatioAverage();
C++/CLI
property float QueueStorageRatioAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
QueueStorageRatioMaximum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : QueueStorageRatioMaximum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property QueueStorageRatioMaximum As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.QueueStorageRatioMaximum
C#
float QueueStorageRatioMaximum {get;}
Managed Extensions for C++
__property float get_QueueStorageRatioMaximum();
C++/CLI
property float QueueStorageRatioMaximum {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : RunningTimeAvg Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RunningTimeAvg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvg
C#
float RunningTimeAvg {get;}
Managed Extensions for C++
__property float get_RunningTimeAvg();
C++/CLI
property float RunningTimeAvg {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvgerage_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : RunningTimeAvgerage_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RunningTimeAvgerage_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvgerage_pct
C#
float RunningTimeAvgerage_pct {get;}
Managed Extensions for C++
__property float get_RunningTimeAvgerage_pct();
C++/CLI
property float RunningTimeAvgerage_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RunningTimeAvgerage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : RunningTimeAvgerage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RunningTimeAvgerage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.RunningTimeAvgerage_rate
C#
float RunningTimeAvgerage_rate {get;}
Managed Extensions for C++
__property float get_RunningTimeAvgerage_rate();
C++/CLI
property float RunningTimeAvgerage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : StopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopRate
C#
float StopRate {get;}
Managed Extensions for C++
__property float get_StopRate();
C++/CLI
property float StopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : StopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopRate_rate
C#
float StopRate_rate {get;}
Managed Extensions for C++
__property float get_StopRate_rate();
C++/CLI
property float StopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
StopsTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : StopsTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property StopsTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.StopsTotal
C#
float StopsTotal {get;}
Managed Extensions for C++
__property float get_StopsTotal();
C++/CLI
property float StopsTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDelay Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelay As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay
C#
float TravelDelay {get;}
Managed Extensions for C++
__property float get_TravelDelay();
C++/CLI
property float TravelDelay {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDelay_pct Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelay_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay_pct
C#
float TravelDelay_pct {get;}
Managed Extensions for C++
__property float get_TravelDelay_pct();
C++/CLI
property float TravelDelay_pct {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelay_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDelay_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelay_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelay_rate
C#
float TravelDelay_rate {get;}
Managed Extensions for C++
__property float get_TravelDelay_rate();
C++/CLI
property float TravelDelay_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelayAverage
C#
float TravelDelayAverage {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage();
C++/CLI
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDelayAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDelayAverage_rate
C#
float TravelDelayAverage_rate {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage_rate();
C++/CLI
property float TravelDelayAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDistanceAverage
C#
float TravelDistanceAverage {get;}
Managed Extensions for C++
__property float get_TravelDistanceAverage();
C++/CLI
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelDistanceTotal
C#
float TravelDistanceTotal {get;}
Managed Extensions for C++
__property float get_TravelDistanceTotal();
C++/CLI
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelSpeed
C#
float TravelSpeed {get;}
Managed Extensions for C++
__property float get_TravelSpeed();
C++/CLI
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeAverage
C#
float TravelTimeAverage {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage();
C++/CLI
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelTimeAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeAverage_rate
C#
float TravelTimeAverage_rate {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage_rate();
C++/CLI
property float TravelTimeAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelTimeIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeIndex
C#
float TravelTimeIndex {get;}
Managed Extensions for C++
__property float get_TravelTimeIndex();
C++/CLI
property float TravelTimeIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputNetworkVehicle Interface : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputNetworkVehicle
Dim value As Single

value = instance.TravelTimeTotal
C#
float TravelTimeTotal {get;}
Managed Extensions for C++
__property float get_TravelTimeTotal();
C++/CLI
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputNetworkVehicle Interface
ISIAPIOutputNetworkVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhase Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhase Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
C#
public interface ISIAPIOutputPhase
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhase
C++/CLI
public interface class ISIAPIOutputPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhase Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhase Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhase.

Public Properties

 | Name | Description
Property | All_red_time |
Property | Change_time |
Property | Critical_dummy_mov_flag |
Property | Displayed_green_time |
Property | Dummy_adj_flow_ratio |
Property | Dummy_adj_lost_time |
Property | Dummy_eff_green |
Property | Dummy_lost_time |
Property | Dummy_min_max_flag |
Property | Dummy_reqd_green_time_ratio |
Property | Dummy_reqd_time |
Property | Dummy_tmax |
Property | Dummy_tmin |
Property | Green_end |
Property | Green_start |
Property | Has_dummy |
Property | IsReferencePhase |
Property | Offset_change_time |
Property | Phase_split_percent |
Property | Phase_time |
Property | Position |
Property | Start_intergreen |
Property | Terminating_intergreen |
Property | Yellow_time |
Top

See Also

Reference

ISIAPIOutputPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhase Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhase Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhase members.

Public Properties

 | Name | Description
Property | All_red_time |
Property | Change_time |
Property | Critical_dummy_mov_flag |
Property | Displayed_green_time |
Property | Dummy_adj_flow_ratio |
Property | Dummy_adj_lost_time |
Property | Dummy_eff_green |
Property | Dummy_lost_time |
Property | Dummy_min_max_flag |
Property | Dummy_reqd_green_time_ratio |
Property | Dummy_reqd_time |
Property | Dummy_tmax |
Property | Dummy_tmin |
Property | Green_end |
Property | Green_start |
Property | Has_dummy |
Property | IsReferencePhase |
Property | Offset_change_time |
Property | Phase_split_percent |
Property | Phase_time |
Property | Position |
Property | Start_intergreen |
Property | Terminating_intergreen |
Property | Yellow_time |
Top

See Also

Reference

ISIAPIOutputPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.All_red_time
C#
int All_red_time {get;}
Managed Extensions for C++
__property int get_All_red_time();
C++/CLI
property int All_red_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Change_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Change_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Change_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Change_time
C#
int Change_time {get;}
Managed Extensions for C++
__property int get_Change_time();
C++/CLI
property int Change_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_dummy_mov_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Critical_dummy_mov_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_dummy_mov_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Critical_dummy_mov_flag
C#
int Critical_dummy_mov_flag {get;}
Managed Extensions for C++
__property int get_Critical_dummy_mov_flag();
C++/CLI
property int Critical_dummy_mov_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Displayed_green_time
C#
int Displayed_green_time {get;}
Managed Extensions for C++
__property int get_Displayed_green_time();
C++/CLI
property int Displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_adj_flow_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_adj_flow_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_adj_flow_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_adj_flow_ratio
C#
float Dummy_adj_flow_ratio {get;}
Managed Extensions for C++
__property float get_Dummy_adj_flow_ratio();
C++/CLI
property float Dummy_adj_flow_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_adj_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_adj_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_adj_lost_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_adj_lost_time
C#
float Dummy_adj_lost_time {get;}
Managed Extensions for C++
__property float get_Dummy_adj_lost_time();
C++/CLI
property float Dummy_adj_lost_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_eff_green
C#
int Dummy_eff_green {get;}
Managed Extensions for C++
__property int get_Dummy_eff_green();
C++/CLI
property int Dummy_eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_lost_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_lost_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_lost_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_lost_time
C#
int Dummy_lost_time {get;}
Managed Extensions for C++
__property int get_Dummy_lost_time();
C++/CLI
property int Dummy_lost_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_min_max_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_min_max_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_min_max_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Dummy_min_max_flag
C#
int Dummy_min_max_flag {get;}
Managed Extensions for C++
__property int get_Dummy_min_max_flag();
C++/CLI
property int Dummy_min_max_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_reqd_green_time_ratio Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_reqd_green_time_ratio Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_reqd_green_time_ratio As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_reqd_green_time_ratio
C#
float Dummy_reqd_green_time_ratio {get;}
Managed Extensions for C++
__property float get_Dummy_reqd_green_time_ratio();
C++/CLI
property float Dummy_reqd_green_time_ratio {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_reqd_time
C#
float Dummy_reqd_time {get;}
Managed Extensions for C++
__property float get_Dummy_reqd_time();
C++/CLI
property float Dummy_reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_tmax Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_tmax Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_tmax As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_tmax
C#
float Dummy_tmax {get;}
Managed Extensions for C++
__property float get_Dummy_tmax();
C++/CLI
property float Dummy_tmax {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_tmin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Dummy_tmin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_tmin As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Dummy_tmin
C#
float Dummy_tmin {get;}
Managed Extensions for C++
__property float get_Dummy_tmin();
C++/CLI
property float Dummy_tmin {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_end Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Green_end Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_end As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Green_end
C#
int Green_end {get;}
Managed Extensions for C++
__property int get_Green_end();
C++/CLI
property int Green_end {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_start Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Green_start Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_start As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Green_start
C#
int Green_start {get;}
Managed Extensions for C++
__property int get_Green_start();
C++/CLI
property int Green_start {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Boolean

value = instance.Has_dummy
C#
bool Has_dummy {get;}
Managed Extensions for C++
__property bool get_Has_dummy();
C++/CLI
property bool Has_dummy {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Boolean

value = instance.IsReferencePhase
C#
bool IsReferencePhase {get;}
Managed Extensions for C++
__property bool get_IsReferencePhase();
C++/CLI
property bool IsReferencePhase {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Offset_change_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Offset_change_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Offset_change_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Offset_change_time
C#
int Offset_change_time {get;}
Managed Extensions for C++
__property int get_Offset_change_time();
C++/CLI
property int Offset_change_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_split_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Phase_split_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phase_split_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Single

value = instance.Phase_split_percent
C#
float Phase_split_percent {get;}
Managed Extensions for C++
__property float get_Phase_split_percent();
C++/CLI
property float Phase_split_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Phase_time
C#
int Phase_time {get;}
Managed Extensions for C++
__property int get_Phase_time();
C++/CLI
property int Phase_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_intergreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Start_intergreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Start_intergreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Start_intergreen
C#
int Start_intergreen {get;}
Managed Extensions for C++
__property int get_Start_intergreen();
C++/CLI
property int Start_intergreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminating_intergreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Terminating_intergreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Terminating_intergreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Terminating_intergreen
C#
int Terminating_intergreen {get;}
Managed Extensions for C++
__property int get_Terminating_intergreen();
C++/CLI
property int Terminating_intergreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhase Interface : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhase
Dim value As Integer

value = instance.Yellow_time
C#
int Yellow_time {get;}
Managed Extensions for C++
__property int get_Yellow_time();
C++/CLI
property int Yellow_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhase Interface
ISIAPIOutputPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPath Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPath Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPath
C#
public interface ISIAPIOutputPhaseMovTimingPath
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhaseMovTimingPath
C++/CLI
public interface class ISIAPIOutputPhaseMovTimingPath

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPath Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPath Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhaseMovTimingPath.

Public Properties

 | Name | Description
Property | OutputPhaseMovTimingPathMovements |
Property | Outputset |
Property | Position |
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPath Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPath Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPath members.

Public Properties

 | Name | Description
Property | OutputPhaseMovTimingPathMovements |
Property | Outputset |
Property | Position |
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPathMovements Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPath Interface : OutputPhaseMovTimingPathMovements Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputPhaseMovTimingPathMovements As ISIAPIOutputPhaseMovTimingPathMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPath
Dim value As ISIAPIOutputPhaseMovTimingPathMovements

value = instance.OutputPhaseMovTimingPathMovements
C#
ISIAPIOutputPhaseMovTimingPathMovements OutputPhaseMovTimingPathMovements {get;}
Managed Extensions for C++
__property ISIAPIOutputPhaseMovTimingPathMovements* get_OutputPhaseMovTimingPathMovements();
C++/CLI
property ISIAPIOutputPhaseMovTimingPathMovements^ OutputPhaseMovTimingPathMovements {
   ISIAPIOutputPhaseMovTimingPathMovements^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Interface
ISIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Outputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPath Interface : Outputset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Outputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPath
Dim value As ISIAPIOutputset

value = instance.Outputset
C#
ISIAPIOutputset Outputset {get;}
Managed Extensions for C++
__property ISIAPIOutputset* get_Outputset();
C++/CLI
property ISIAPIOutputset^ Outputset {
   ISIAPIOutputset^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Interface
ISIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPath Interface : Position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPath
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPath Interface
ISIAPIOutputPhaseMovTimingPath Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovement Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovement Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhaseMovTimingPathMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
C#
public interface ISIAPIOutputPhaseMovTimingPathMovement
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhaseMovTimingPathMovement
C++/CLI
public interface class ISIAPIOutputPhaseMovTimingPathMovement

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovement Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovement Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhaseMovTimingPathMovement.

Public Properties

 | Name | Description
Property | Critical_mov | Flag indicating this Movement is a critical movement or not.
Property | Destination |
Property | Dummy_phase_original_position |
Property | Eff_green |
Property | End_phase | The position / index of the Phase that this Movement finishes at.
Property | Green_time |
Property | Greenperiod |
Property | MaxGreenPeriod |
Property | MC_class |
Property | Mov_type | Movement Type
Property | MovementDisplayID |
Property | Origin |
Property | OutputPhaseMovTimingPath |
Property | Ped_stage |
Property | Ped_type |
Property | Position | The index of this Movement in the Timing Path. It is a zero-base integer.
Property | Reqd_time |
Property | SiteDisplayID |
Property | Start_phase | The position / index of the Phase that this Movement starts from
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovement Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovement Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPathMovement members.

Public Properties

 | Name | Description
Property | Critical_mov | Flag indicating this Movement is a critical movement or not.
Property | Destination |
Property | Dummy_phase_original_position |
Property | Eff_green |
Property | End_phase | The position / index of the Phase that this Movement finishes at.
Property | Green_time |
Property | Greenperiod |
Property | MaxGreenPeriod |
Property | MC_class |
Property | Mov_type | Movement Type
Property | MovementDisplayID |
Property | Origin |
Property | OutputPhaseMovTimingPath |
Property | Ped_stage |
Property | Ped_type |
Property | Position | The index of this Movement in the Timing Path. It is a zero-base integer.
Property | Reqd_time |
Property | SiteDisplayID |
Property | Start_phase | The position / index of the Phase that this Movement starts from
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Critical_mov Property

Glossary Item Box

Flag indicating this Movement is a critical movement or not.

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_mov As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Boolean

value = instance.Critical_mov
C#
bool Critical_mov {get;}
Managed Extensions for C++
__property bool get_Critical_mov();
C++/CLI
property bool Critical_mov {
   bool get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_phase_original_position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Dummy_phase_original_position Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Dummy_phase_original_position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Dummy_phase_original_position
C#
int Dummy_phase_original_position {get;}
Managed Extensions for C++
__property int get_Dummy_phase_original_position();
C++/CLI
property int Dummy_phase_original_position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_green Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Eff_green Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Eff_green As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Eff_green
C#
int Eff_green {get;}
Managed Extensions for C++
__property int get_Eff_green();
C++/CLI
property int Eff_green {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
End_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : End_phase Property

Glossary Item Box

The position / index of the Phase that this Movement finishes at.

Syntax

Visual Basic (Declaration)
ReadOnly Property End_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.End_phase
C#
int End_phase {get;}
Managed Extensions for C++
__property int get_End_phase();
C++/CLI
property int End_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Green_time
C#
int Green_time {get;}
Managed Extensions for C++
__property int get_Green_time();
C++/CLI
property int Green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Greenperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Greenperiod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Greenperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Greenperiod
C#
int Greenperiod {get;}
Managed Extensions for C++
__property int get_Greenperiod();
C++/CLI
property int Greenperiod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MaxGreenPeriod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : MaxGreenPeriod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MaxGreenPeriod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.MaxGreenPeriod
C#
int MaxGreenPeriod {get;}
Managed Extensions for C++
__property int get_MaxGreenPeriod();
C++/CLI
property int MaxGreenPeriod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Mov_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Mov_type Property

Glossary Item Box

Movement Type

Syntax

Visual Basic (Declaration)
ReadOnly Property Mov_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Mov_type
C#
int Mov_type {get;}
Managed Extensions for C++
__property int get_Mov_type();
C++/CLI
property int Mov_type {
   int get();
}

Property Value

Type: System.Int32;

1 = Vehicle OD Movement,
2 = Pedestrian Movement,
3 = Dummy Movement in a Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementDisplayID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : MovementDisplayID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementDisplayID As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As String

value = instance.MovementDisplayID
C#
string MovementDisplayID {get;}
Managed Extensions for C++
__property string* get_MovementDisplayID();
C++/CLI
property String^ MovementDisplayID {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPath Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : OutputPhaseMovTimingPath Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputPhaseMovTimingPath As ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As ISIAPIOutputPhaseMovTimingPath

value = instance.OutputPhaseMovTimingPath
C#
ISIAPIOutputPhaseMovTimingPath OutputPhaseMovTimingPath {get;}
Managed Extensions for C++
__property ISIAPIOutputPhaseMovTimingPath* get_OutputPhaseMovTimingPath();
C++/CLI
property ISIAPIOutputPhaseMovTimingPath^ OutputPhaseMovTimingPath {
   ISIAPIOutputPhaseMovTimingPath^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Ped_stage
C#
int Ped_stage {get;}
Managed Extensions for C++
__property int get_Ped_stage();
C++/CLI
property int Ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Ped_type
C#
int Ped_type {get;}
Managed Extensions for C++
__property int get_Ped_type();
C++/CLI
property int Ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Position Property

Glossary Item Box

The index of this Movement in the Timing Path. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Reqd_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_time As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Single

value = instance.Reqd_time
C#
float Reqd_time {get;}
Managed Extensions for C++
__property float get_Reqd_time();
C++/CLI
property float Reqd_time {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteDisplayID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : SiteDisplayID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteDisplayID As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As String

value = instance.SiteDisplayID
C#
string SiteDisplayID {get;}
Managed Extensions for C++
__property string* get_SiteDisplayID();
C++/CLI
property String^ SiteDisplayID {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Start_phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovement Interface : Start_phase Property

Glossary Item Box

The position / index of the Phase that this Movement starts from

Syntax

Visual Basic (Declaration)
ReadOnly Property Start_phase As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovement
Dim value As Integer

value = instance.Start_phase
C#
int Start_phase {get;}
Managed Extensions for C++
__property int get_Start_phase();
C++/CLI
property int Start_phase {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovement Interface
ISIAPIOutputPhaseMovTimingPathMovement Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovements Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovements Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhaseMovTimingPathMovements
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovements
C#
public interface ISIAPIOutputPhaseMovTimingPathMovements
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhaseMovTimingPathMovements
C++/CLI
public interface class ISIAPIOutputPhaseMovTimingPathMovements

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovements Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovements Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhaseMovTimingPathMovements.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovements Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPathMovements members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovements Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovements
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Interface
ISIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPathMovements Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhaseMovTimingPathMovement
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPathMovements
Dim index As Integer
Dim value As ISIAPIOutputPhaseMovTimingPathMovement

value = instance.Item(index)
C#
ISIAPIOutputPhaseMovTimingPathMovement this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputPhaseMovTimingPathMovement* get_Item   int index
;
C++/CLI
property ISIAPIOutputPhaseMovTimingPathMovement^ default [int] {
   ISIAPIOutputPhaseMovTimingPathMovement^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Interface
ISIAPIOutputPhaseMovTimingPathMovements Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPaths Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPaths Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhaseMovTimingPaths
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPaths
C#
public interface ISIAPIOutputPhaseMovTimingPaths
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhaseMovTimingPaths
C++/CLI
public interface class ISIAPIOutputPhaseMovTimingPaths

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPaths Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPaths Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhaseMovTimingPaths.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPaths Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPaths Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPaths members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPaths Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPaths
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Interface
ISIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhaseMovTimingPaths Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhaseMovTimingPath
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhaseMovTimingPaths
Dim index As Integer
Dim value As ISIAPIOutputPhaseMovTimingPath

value = instance.Item(index)
C#
ISIAPIOutputPhaseMovTimingPath this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputPhaseMovTimingPath* get_Item   int index
;
C++/CLI
property ISIAPIOutputPhaseMovTimingPath^ default [int] {
   ISIAPIOutputPhaseMovTimingPath^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Interface
ISIAPIOutputPhaseMovTimingPaths Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhases Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhases Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhases
C#
public interface ISIAPIOutputPhases
Managed Extensions for C++
public __gc __interface ISIAPIOutputPhases
C++/CLI
public interface class ISIAPIOutputPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhases Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhases Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputPhases.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhases Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhases members.

Public Properties

 | Name | Description
Property | Count |
Property | Item |
Top

See Also

Reference

ISIAPIOutputPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhases Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhases
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhases Interface
ISIAPIOutputPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputPhases Interface : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputPhases
Dim index As Integer
Dim value As ISIAPIOutputPhase

value = instance.Item(index)
C#
ISIAPIOutputPhase this[
   int index
]; {get;}
Managed Extensions for C++
__property ISIAPIOutputPhase* get_Item   int index
;
C++/CLI
property ISIAPIOutputPhase^ default [int] {
   ISIAPIOutputPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputPhases Interface
ISIAPIOutputPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedPerson Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedPerson Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputRouteMovementBasedPerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
C#
public interface ISIAPIOutputRouteMovementBasedPerson
Managed Extensions for C++
public __gc __interface ISIAPIOutputRouteMovementBasedPerson
C++/CLI
public interface class ISIAPIOutputRouteMovementBasedPerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedPerson Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedPerson Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputRouteMovementBasedPerson.

Public Properties

 | Name | Description
Property | DesiredSpeedMethod |
Property | RouteStopRate |
Property | RouteStopRate_rate |
Property | TravelDelayAverage |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedPerson Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedPerson Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputRouteMovementBasedPerson members.

Public Properties

 | Name | Description
Property | DesiredSpeedMethod |
Property | RouteStopRate |
Property | RouteStopRate_rate |
Property | TravelDelayAverage |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
int DesiredSpeedMethod {get;}
Managed Extensions for C++
__property int get_DesiredSpeedMethod();
C++/CLI
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : RouteStopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteStopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.RouteStopRate
C#
float RouteStopRate {get;}
Managed Extensions for C++
__property float get_RouteStopRate();
C++/CLI
property float RouteStopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : RouteStopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteStopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.RouteStopRate_rate
C#
float RouteStopRate_rate {get;}
Managed Extensions for C++
__property float get_RouteStopRate_rate();
C++/CLI
property float RouteStopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDelayAverage
C#
float TravelDelayAverage {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage();
C++/CLI
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDistanceAverage
C#
float TravelDistanceAverage {get;}
Managed Extensions for C++
__property float get_TravelDistanceAverage();
C++/CLI
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelDistanceTotal
C#
float TravelDistanceTotal {get;}
Managed Extensions for C++
__property float get_TravelDistanceTotal();
C++/CLI
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelSpeed
C#
float TravelSpeed {get;}
Managed Extensions for C++
__property float get_TravelSpeed();
C++/CLI
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelTimeAverage
C#
float TravelTimeAverage {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage();
C++/CLI
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedPerson Interface : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedPerson
Dim value As Single

value = instance.TravelTimeTotal
C#
float TravelTimeTotal {get;}
Managed Extensions for C++
__property float get_TravelTimeTotal();
C++/CLI
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedPerson Interface
ISIAPIOutputRouteMovementBasedPerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedVehicle Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedVehicle Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputRouteMovementBasedVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
C#
public interface ISIAPIOutputRouteMovementBasedVehicle
Managed Extensions for C++
public __gc __interface ISIAPIOutputRouteMovementBasedVehicle
C++/CLI
public interface class ISIAPIOutputRouteMovementBasedVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedVehicle Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedVehicle Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputRouteMovementBasedVehicle.

Public Properties

 | Name | Description
Property | CongestionCoefficient |
Property | DesiredSpeed |
Property | DesiredSpeedMethod |
Property | LevelOfService |
Property | RouteStopRate |
Property | RouteStopRate_rate |
Property | SpeedEfficiency |
Property | TravelDelayAverage |
Property | TravelDelayAverage_rate |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeAverage_rate |
Property | TravelTimeIndex |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputRouteMovementBasedVehicle Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputRouteMovementBasedVehicle Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputRouteMovementBasedVehicle members.

Public Properties

 | Name | Description
Property | CongestionCoefficient |
Property | DesiredSpeed |
Property | DesiredSpeedMethod |
Property | LevelOfService |
Property | RouteStopRate |
Property | RouteStopRate_rate |
Property | SpeedEfficiency |
Property | TravelDelayAverage |
Property | TravelDelayAverage_rate |
Property | TravelDistanceAverage |
Property | TravelDistanceTotal |
Property | TravelSpeed |
Property | TravelTimeAverage |
Property | TravelTimeAverage_rate |
Property | TravelTimeIndex |
Property | TravelTimeTotal |
Top

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CongestionCoefficient Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : CongestionCoefficient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property CongestionCoefficient As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.CongestionCoefficient
C#
float CongestionCoefficient {get;}
Managed Extensions for C++
__property float get_CongestionCoefficient();
C++/CLI
property float CongestionCoefficient {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.DesiredSpeed
C#
float DesiredSpeed {get;}
Managed Extensions for C++
__property float get_DesiredSpeed();
C++/CLI
property float DesiredSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : DesiredSpeedMethod Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Integer

value = instance.DesiredSpeedMethod
C#
int DesiredSpeedMethod {get;}
Managed Extensions for C++
__property int get_DesiredSpeedMethod();
C++/CLI
property int DesiredSpeedMethod {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LevelOfService Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : LevelOfService Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LevelOfService As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Integer

value = instance.LevelOfService
C#
int LevelOfService {get;}
Managed Extensions for C++
__property int get_LevelOfService();
C++/CLI
property int LevelOfService {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : RouteStopRate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteStopRate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.RouteStopRate
C#
float RouteStopRate {get;}
Managed Extensions for C++
__property float get_RouteStopRate();
C++/CLI
property float RouteStopRate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteStopRate_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : RouteStopRate_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteStopRate_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.RouteStopRate_rate
C#
float RouteStopRate_rate {get;}
Managed Extensions for C++
__property float get_RouteStopRate_rate();
C++/CLI
property float RouteStopRate_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelDelayAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDelayAverage
C#
float TravelDelayAverage {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage();
C++/CLI
property float TravelDelayAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDelayAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelDelayAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDelayAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDelayAverage_rate
C#
float TravelDelayAverage_rate {get;}
Managed Extensions for C++
__property float get_TravelDelayAverage_rate();
C++/CLI
property float TravelDelayAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelDistanceAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDistanceAverage
C#
float TravelDistanceAverage {get;}
Managed Extensions for C++
__property float get_TravelDistanceAverage();
C++/CLI
property float TravelDistanceAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelDistanceTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelDistanceTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelDistanceTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelDistanceTotal
C#
float TravelDistanceTotal {get;}
Managed Extensions for C++
__property float get_TravelDistanceTotal();
C++/CLI
property float TravelDistanceTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelSpeed
C#
float TravelSpeed {get;}
Managed Extensions for C++
__property float get_TravelSpeed();
C++/CLI
property float TravelSpeed {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelTimeAverage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeAverage
C#
float TravelTimeAverage {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage();
C++/CLI
property float TravelTimeAverage {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeAverage_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelTimeAverage_rate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeAverage_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeAverage_rate
C#
float TravelTimeAverage_rate {get;}
Managed Extensions for C++
__property float get_TravelTimeAverage_rate();
C++/CLI
property float TravelTimeAverage_rate {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeIndex Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelTimeIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeIndex As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeIndex
C#
float TravelTimeIndex {get;}
Managed Extensions for C++
__property float get_TravelTimeIndex();
C++/CLI
property float TravelTimeIndex {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TravelTimeTotal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputRouteMovementBasedVehicle Interface : TravelTimeTotal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TravelTimeTotal As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputRouteMovementBasedVehicle
Dim value As Single

value = instance.TravelTimeTotal
C#
float TravelTimeTotal {get;}
Managed Extensions for C++
__property float get_TravelTimeTotal();
C++/CLI
property float TravelTimeTotal {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputRouteMovementBasedVehicle Interface
ISIAPIOutputRouteMovementBasedVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSequence Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSequence Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
C#
public interface ISIAPIOutputSequence
Managed Extensions for C++
public __gc __interface ISIAPIOutputSequence
C++/CLI
public interface class ISIAPIOutputSequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSequence Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSequence Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSequence.

Public Properties

 | Name | Description
Property | Adjusted_flow_ratio_total |
Property | Adjusted_lost_time_total |
Property | Cmaxsl_flag |
Property | Critical_in_network |
Property | Cycle_time |
Property | Cycle_time_maximum |
Property | Cycle_time_maximum_flag |
Property | Cycle_time_minimum |
Property | Cycle_time_minimum_flag |
Property | Cycle_time_option |
Property | Cycle_time_option_flag |
Property | Cycle_time_practical |
Property | Largeyu_flag |
Property | Max_green_percent |
Property | Phases |
Property | Reqd_green_time_ratio_total |
Property | Reqd_movement_time_total |
Property | Warning_flag |
Top

See Also

Reference

ISIAPIOutputSequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSequence Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSequence Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSequence members.

Public Properties

 | Name | Description
Property | Adjusted_flow_ratio_total |
Property | Adjusted_lost_time_total |
Property | Cmaxsl_flag |
Property | Critical_in_network |
Property | Cycle_time |
Property | Cycle_time_maximum |
Property | Cycle_time_maximum_flag |
Property | Cycle_time_minimum |
Property | Cycle_time_minimum_flag |
Property | Cycle_time_option |
Property | Cycle_time_option_flag |
Property | Cycle_time_practical |
Property | Largeyu_flag |
Property | Max_green_percent |
Property | Phases |
Property | Reqd_green_time_ratio_total |
Property | Reqd_movement_time_total |
Property | Warning_flag |
Top

See Also

Reference

ISIAPIOutputSequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_flow_ratio_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Adjusted_flow_ratio_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_flow_ratio_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Single

value = instance.Adjusted_flow_ratio_total
C#
float Adjusted_flow_ratio_total {get;}
Managed Extensions for C++
__property float get_Adjusted_flow_ratio_total();
C++/CLI
property float Adjusted_flow_ratio_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Adjusted_lost_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Adjusted_lost_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Adjusted_lost_time_total As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Adjusted_lost_time_total
C#
int Adjusted_lost_time_total {get;}
Managed Extensions for C++
__property int get_Adjusted_lost_time_total();
C++/CLI
property int Adjusted_lost_time_total {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cmaxsl_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cmaxsl_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cmaxsl_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cmaxsl_flag
C#
int Cmaxsl_flag {get;}
Managed Extensions for C++
__property int get_Cmaxsl_flag();
C++/CLI
property int Cmaxsl_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_in_network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Critical_in_network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Critical_in_network As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Critical_in_network
C#
int Critical_in_network {get;}
Managed Extensions for C++
__property int get_Critical_in_network();
C++/CLI
property int Critical_in_network {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time
C#
int Cycle_time {get;}
Managed Extensions for C++
__property int get_Cycle_time();
C++/CLI
property int Cycle_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_maximum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_maximum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_maximum As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_maximum
C#
int Cycle_time_maximum {get;}
Managed Extensions for C++
__property int get_Cycle_time_maximum();
C++/CLI
property int Cycle_time_maximum {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_maximum_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_maximum_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_maximum_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_maximum_flag
C#
int Cycle_time_maximum_flag {get;}
Managed Extensions for C++
__property int get_Cycle_time_maximum_flag();
C++/CLI
property int Cycle_time_maximum_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_minimum Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_minimum Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_minimum As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_minimum
C#
int Cycle_time_minimum {get;}
Managed Extensions for C++
__property int get_Cycle_time_minimum();
C++/CLI
property int Cycle_time_minimum {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_minimum_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_minimum_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_minimum_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_minimum_flag
C#
int Cycle_time_minimum_flag {get;}
Managed Extensions for C++
__property int get_Cycle_time_minimum_flag();
C++/CLI
property int Cycle_time_minimum_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_option Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_option
C#
int Cycle_time_option {get;}
Managed Extensions for C++
__property int get_Cycle_time_option();
C++/CLI
property int Cycle_time_option {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_option_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_option_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_option_flag
C#
int Cycle_time_option_flag {get;}
Managed Extensions for C++
__property int get_Cycle_time_option_flag();
C++/CLI
property int Cycle_time_option_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_practical Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Cycle_time_practical Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Cycle_time_practical As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Cycle_time_practical
C#
int Cycle_time_practical {get;}
Managed Extensions for C++
__property int get_Cycle_time_practical();
C++/CLI
property int Cycle_time_practical {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Largeyu_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Largeyu_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Largeyu_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Largeyu_flag
C#
int Largeyu_flag {get;}
Managed Extensions for C++
__property int get_Largeyu_flag();
C++/CLI
property int Largeyu_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_green_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Max_green_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_green_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Single

value = instance.Max_green_percent
C#
float Max_green_percent {get;}
Managed Extensions for C++
__property float get_Max_green_percent();
C++/CLI
property float Max_green_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Phases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phases As ISIAPIOutputPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As ISIAPIOutputPhases

value = instance.Phases
C#
ISIAPIOutputPhases Phases {get;}
Managed Extensions for C++
__property ISIAPIOutputPhases* get_Phases();
C++/CLI
property ISIAPIOutputPhases^ Phases {
   ISIAPIOutputPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_green_time_ratio_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Reqd_green_time_ratio_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_green_time_ratio_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Single

value = instance.Reqd_green_time_ratio_total
C#
float Reqd_green_time_ratio_total {get;}
Managed Extensions for C++
__property float get_Reqd_green_time_ratio_total();
C++/CLI
property float Reqd_green_time_ratio_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Reqd_movement_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Reqd_movement_time_total Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Reqd_movement_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Single

value = instance.Reqd_movement_time_total
C#
float Reqd_movement_time_total {get;}
Managed Extensions for C++
__property float get_Reqd_movement_time_total();
C++/CLI
property float Reqd_movement_time_total {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Warning_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSequence Interface : Warning_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Warning_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSequence
Dim value As Integer

value = instance.Warning_flag
C#
int Warning_flag {get;}
Managed Extensions for C++
__property int get_Warning_flag();
C++/CLI
property int Warning_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSequence Interface
ISIAPIOutputSequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputset Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputset Interface

Glossary Item Box

SIDRA INTERSECTION Outputset wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
C#
public interface ISIAPIOutputset
Managed Extensions for C++
public __gc __interface ISIAPIOutputset
C++/CLI
public interface class ISIAPIOutputset

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputset Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputset Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputset.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Analysis_method_flag |
Property | Generated | Date and Time site output was created (Processed).
Property | GeneratedByVersion |
Property | NetworkSite |
Property | NwSite_SignalPlatoonMode |
Property | NwSiteOffset |
Property | OutputAnalysis |
Property | OutputGraphTuples |
Property | OutputLegPersons |
Property | OutputLegs |
Property | OutputMeteredRoundabout |
Property | OutputMovementPeds |
Property | OutputMovementPersonODs |
Property | OutputMovementVehicleODs |
Property | OutputPhaseMovTimingPaths |
Property | OutputSequence |
Property | OutputSitePedestrian | Pedestrian specific site output.
Property | OutputSitePerson | Person specific site output.
Property | OutputSiteRoutes |
Property | OutputSiteVehicle | Vehicle specific site output.
Property | Site |
Property | TWSC_calib_adjusted |
Top

See Also

Reference

ISIAPIOutputset Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputset Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputset Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputset members.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Analysis_method_flag |
Property | Generated | Date and Time site output was created (Processed).
Property | GeneratedByVersion |
Property | NetworkSite |
Property | NwSite_SignalPlatoonMode |
Property | NwSiteOffset |
Property | OutputAnalysis |
Property | OutputGraphTuples |
Property | OutputLegPersons |
Property | OutputLegs |
Property | OutputMeteredRoundabout |
Property | OutputMovementPeds |
Property | OutputMovementPersonODs |
Property | OutputMovementVehicleODs |
Property | OutputPhaseMovTimingPaths |
Property | OutputSequence |
Property | OutputSitePedestrian | Pedestrian specific site output.
Property | OutputSitePerson | Person specific site output.
Property | OutputSiteRoutes |
Property | OutputSiteVehicle | Vehicle specific site output.
Property | Site |
Property | TWSC_calib_adjusted |
Top

See Also

Reference

ISIAPIOutputset Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Integer

value = instance.Analysis_method
C#
int Analysis_method {get;}
Managed Extensions for C++
__property int get_Analysis_method();
C++/CLI
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method_flag Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : Analysis_method_flag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_method_flag As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Integer

value = instance.Analysis_method_flag
C#
int Analysis_method_flag {get;}
Managed Extensions for C++
__property int get_Analysis_method_flag();
C++/CLI
property int Analysis_method_flag {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Generated Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : Generated Property

Glossary Item Box

Date and Time site output was created (Processed).

Syntax

Visual Basic (Declaration)
ReadOnly Property Generated As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Date

value = instance.Generated
C#
DateTime Generated {get;}
Managed Extensions for C++
__property DateTime get_Generated();
C++/CLI
property DateTime Generated {
   DateTime get();
}

Property Value

Type: System.DateTime

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GeneratedByVersion Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : GeneratedByVersion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property GeneratedByVersion As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As String

value = instance.GeneratedByVersion
C#
string GeneratedByVersion {get;}
Managed Extensions for C++
__property string* get_GeneratedByVersion();
C++/CLI
property String^ GeneratedByVersion {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : NetworkSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSite As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPINetworkSite

value = instance.NetworkSite
C#
ISIAPINetworkSite NetworkSite {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_NetworkSite();
C++/CLI
property ISIAPINetworkSite^ NetworkSite {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwSite_SignalPlatoonMode Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : NwSite_SignalPlatoonMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NwSite_SignalPlatoonMode As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Integer

value = instance.NwSite_SignalPlatoonMode
C#
int NwSite_SignalPlatoonMode {get;}
Managed Extensions for C++
__property int get_NwSite_SignalPlatoonMode();
C++/CLI
property int NwSite_SignalPlatoonMode {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NwSiteOffset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : NwSiteOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NwSiteOffset As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Integer

value = instance.NwSiteOffset
C#
int NwSiteOffset {get;}
Managed Extensions for C++
__property int get_NwSiteOffset();
C++/CLI
property int NwSiteOffset {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputAnalysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputAnalysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputAnalysis As ISIAPIOutputAnalysis
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputAnalysis

value = instance.OutputAnalysis
C#
ISIAPIOutputAnalysis OutputAnalysis {get;}
Managed Extensions for C++
__property ISIAPIOutputAnalysis* get_OutputAnalysis();
C++/CLI
property ISIAPIOutputAnalysis^ OutputAnalysis {
   ISIAPIOutputAnalysis^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputGraphTuples Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputGraphTuples Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputGraphTuples As ISIAPIOutputGraphTuples
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputGraphTuples

value = instance.OutputGraphTuples
C#
ISIAPIOutputGraphTuples OutputGraphTuples {get;}
Managed Extensions for C++
__property ISIAPIOutputGraphTuples* get_OutputGraphTuples();
C++/CLI
property ISIAPIOutputGraphTuples^ OutputGraphTuples {
   ISIAPIOutputGraphTuples^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegPersons Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputLegPersons Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLegPersons As ISIAPIOutputLegPersons
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputLegPersons

value = instance.OutputLegPersons
C#
ISIAPIOutputLegPersons OutputLegPersons {get;}
Managed Extensions for C++
__property ISIAPIOutputLegPersons* get_OutputLegPersons();
C++/CLI
property ISIAPIOutputLegPersons^ OutputLegPersons {
   ISIAPIOutputLegPersons^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputLegs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputLegs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputLegs As ISIAPIOutputLegs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputLegs

value = instance.OutputLegs
C#
ISIAPIOutputLegs OutputLegs {get;}
Managed Extensions for C++
__property ISIAPIOutputLegs* get_OutputLegs();
C++/CLI
property ISIAPIOutputLegs^ OutputLegs {
   ISIAPIOutputLegs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMeteredRoundabout Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputMeteredRoundabout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMeteredRoundabout As ISIAPIOutputMeteredRoundabout
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputMeteredRoundabout

value = instance.OutputMeteredRoundabout
C#
ISIAPIOutputMeteredRoundabout OutputMeteredRoundabout {get;}
Managed Extensions for C++
__property ISIAPIOutputMeteredRoundabout* get_OutputMeteredRoundabout();
C++/CLI
property ISIAPIOutputMeteredRoundabout^ OutputMeteredRoundabout {
   ISIAPIOutputMeteredRoundabout^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPeds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputMovementPeds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementPeds As ISIAPIOutputMovementPeds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputMovementPeds

value = instance.OutputMovementPeds
C#
ISIAPIOutputMovementPeds OutputMovementPeds {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPeds* get_OutputMovementPeds();
C++/CLI
property ISIAPIOutputMovementPeds^ OutputMovementPeds {
   ISIAPIOutputMovementPeds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementPersonODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputMovementPersonODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementPersonODs As ISIAPIOutputMovementPersonODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputMovementPersonODs

value = instance.OutputMovementPersonODs
C#
ISIAPIOutputMovementPersonODs OutputMovementPersonODs {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementPersonODs* get_OutputMovementPersonODs();
C++/CLI
property ISIAPIOutputMovementPersonODs^ OutputMovementPersonODs {
   ISIAPIOutputMovementPersonODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputMovementVehicleODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputMovementVehicleODs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputMovementVehicleODs As ISIAPIOutputMovementVehicleODs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputMovementVehicleODs

value = instance.OutputMovementVehicleODs
C#
ISIAPIOutputMovementVehicleODs OutputMovementVehicleODs {get;}
Managed Extensions for C++
__property ISIAPIOutputMovementVehicleODs* get_OutputMovementVehicleODs();
C++/CLI
property ISIAPIOutputMovementVehicleODs^ OutputMovementVehicleODs {
   ISIAPIOutputMovementVehicleODs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputPhaseMovTimingPaths Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputPhaseMovTimingPaths Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputPhaseMovTimingPaths As ISIAPIOutputPhaseMovTimingPaths
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputPhaseMovTimingPaths

value = instance.OutputPhaseMovTimingPaths
C#
ISIAPIOutputPhaseMovTimingPaths OutputPhaseMovTimingPaths {get;}
Managed Extensions for C++
__property ISIAPIOutputPhaseMovTimingPaths* get_OutputPhaseMovTimingPaths();
C++/CLI
property ISIAPIOutputPhaseMovTimingPaths^ OutputPhaseMovTimingPaths {
   ISIAPIOutputPhaseMovTimingPaths^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputSequence As ISIAPIOutputSequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputSequence

value = instance.OutputSequence
C#
ISIAPIOutputSequence OutputSequence {get;}
Managed Extensions for C++
__property ISIAPIOutputSequence* get_OutputSequence();
C++/CLI
property ISIAPIOutputSequence^ OutputSequence {
   ISIAPIOutputSequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSitePedestrian Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputSitePedestrian Property

Glossary Item Box

Pedestrian specific site output.

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputSitePedestrian As ISIAPIOutputSitePedestrian
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputSitePedestrian

value = instance.OutputSitePedestrian
C#
ISIAPIOutputSitePedestrian OutputSitePedestrian {get;}
Managed Extensions for C++
__property ISIAPIOutputSitePedestrian* get_OutputSitePedestrian();
C++/CLI
property ISIAPIOutputSitePedestrian^ OutputSitePedestrian {
   ISIAPIOutputSitePedestrian^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSitePerson Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputSitePerson Property

Glossary Item Box

Person specific site output.

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputSitePerson As ISIAPIOutputSitePerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputSitePerson

value = instance.OutputSitePerson
C#
ISIAPIOutputSitePerson OutputSitePerson {get;}
Managed Extensions for C++
__property ISIAPIOutputSitePerson* get_OutputSitePerson();
C++/CLI
property ISIAPIOutputSitePerson^ OutputSitePerson {
   ISIAPIOutputSitePerson^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSiteRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputSiteRoutes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputSiteRoutes As ISIAPIOutputSiteRoutes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputSiteRoutes

value = instance.OutputSiteRoutes
C#
ISIAPIOutputSiteRoutes OutputSiteRoutes {get;}
Managed Extensions for C++
__property ISIAPIOutputSiteRoutes* get_OutputSiteRoutes();
C++/CLI
property ISIAPIOutputSiteRoutes^ OutputSiteRoutes {
   ISIAPIOutputSiteRoutes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputSiteVehicle Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : OutputSiteVehicle Property

Glossary Item Box

Vehicle specific site output.

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputSiteVehicle As ISIAPIOutputSiteVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPIOutputSiteVehicle

value = instance.OutputSiteVehicle
C#
ISIAPIOutputSiteVehicle OutputSiteVehicle {get;}
Managed Extensions for C++
__property ISIAPIOutputSiteVehicle* get_OutputSiteVehicle();
C++/CLI
property ISIAPIOutputSiteVehicle^ OutputSiteVehicle {
   ISIAPIOutputSiteVehicle^ get();
}

Property Value

Type:

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TWSC_calib_adjusted Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputset Interface : TWSC_calib_adjusted Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TWSC_calib_adjusted As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputset
Dim value As Integer

value = instance.TWSC_calib_adjusted
C#
int TWSC_calib_adjusted {get;}
Managed Extensions for C++
__property int get_TWSC_calib_adjusted();
C++/CLI
property int TWSC_calib_adjusted {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputset Interface
ISIAPIOutputset Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePedestrian Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePedestrian Interface

Glossary Item Box

SIDRA INTERSECTION Pedestrian specific site output wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSitePedestrian
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
C#
public interface ISIAPIOutputSitePedestrian
Managed Extensions for C++
public __gc __interface ISIAPIOutputSitePedestrian
C++/CLI
public interface class ISIAPIOutputSitePedestrian

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePedestrian Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePedestrian Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSitePedestrian.

Public Properties

 | Name | Description
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Property | Delay_control_total | Total control delay.
Property | Demand_flow_total | Total pedestrian demand flow.
Property | Level_of_service | Intersection pedestrian LOS.
Property | Level_of_service_worstmov | Worst pedestrian movement LOS.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Performance_index | Performance index.
Property | Proportion_queued | Proportion queued.
Property | Queue_dist_maxback_mean | Longest pedestrian queue (distance), mean.
Property | Queue_maxback_mean | Pedestrian queue (peds), mean.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

ISIAPIOutputSitePedestrian Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePedestrian Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePedestrian Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSitePedestrian members.

Public Properties

 | Name | Description
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Property | Delay_control_total | Total control delay.
Property | Demand_flow_total | Total pedestrian demand flow.
Property | Level_of_service | Intersection pedestrian LOS.
Property | Level_of_service_worstmov | Worst pedestrian movement LOS.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Performance_index | Performance index.
Property | Proportion_queued | Proportion queued.
Property | Queue_dist_maxback_mean | Longest pedestrian queue (distance), mean.
Property | Queue_maxback_mean | Pedestrian queue (peds), mean.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

ISIAPIOutputSitePedestrian Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst pedestrian movement.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Demand_flow_total Property

Glossary Item Box

Total pedestrian demand flow.

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Level_of_service Property

Glossary Item Box

Intersection pedestrian LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Level_of_service_worstmov Property

Glossary Item Box

Worst pedestrian movement LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As String

value = instance.Level_of_service_worstmov
C#
string Level_of_service_worstmov {get;}
Managed Extensions for C++
__property string* get_Level_of_service_worstmov();
C++/CLI
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Longest pedestrian queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Queue_maxback_mean Property

Glossary Item Box

Pedestrian queue (peds), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePedestrian Interface : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePedestrian
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePedestrian Interface
ISIAPIOutputSitePedestrian Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePerson Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePerson Interface

Glossary Item Box

SIDRA INTERSECTION Person specific site output wrapper interface.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSitePerson
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
C#
public interface ISIAPIOutputSitePerson
Managed Extensions for C++
public __gc __interface ISIAPIOutputSitePerson
C++/CLI
public interface class ISIAPIOutputSitePerson

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePerson Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePerson Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSitePerson.

Public Properties

 | Name | Description
Property | Arrival_flow_total | Total person Arrival Flow.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Property | Delay_control_total | Total control delay.
Property | Demand_flow_total | Total person Demand Flow.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Performance_index | Performance index.
Property | Proportion_queued | Proportion queued.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

ISIAPIOutputSitePerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSitePerson Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSitePerson Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSitePerson members.

Public Properties

 | Name | Description
Property | Arrival_flow_total | Total person Arrival Flow.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstmov | Average control delay for worst pedestrian movement.
Property | Delay_control_total | Total control delay.
Property | Demand_flow_total | Total person Demand Flow.
Property | Operating_cost_total | Total operating cost (cost unit/h).
Property | Performance_index | Performance index.
Property | Proportion_queued | Proportion queued.
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time (secs).
Property | Travel_time_total | Total travel time (veh-h/h).
Top

See Also

Reference

ISIAPIOutputSitePerson Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Arrival_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Arrival_flow_total Property

Glossary Item Box

Total person Arrival Flow.

Syntax

Visual Basic (Declaration)
ReadOnly Property Arrival_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Arrival_flow_total
C#
float Arrival_flow_total {get;}
Managed Extensions for C++
__property float get_Arrival_flow_total();
C++/CLI
property float Arrival_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst pedestrian movement.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Demand_flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Demand_flow_total Property

Glossary Item Box

Total person Demand Flow.

Syntax

Visual Basic (Declaration)
ReadOnly Property Demand_flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Demand_flow_total
C#
float Demand_flow_total {get;}
Managed Extensions for C++
__property float get_Demand_flow_total();
C++/CLI
property float Demand_flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Travel_time_average Property

Glossary Item Box

Average travel time (secs).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSitePerson Interface : Travel_time_total Property

Glossary Item Box

Total travel time (veh-h/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSitePerson
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSitePerson Interface
ISIAPIOutputSitePerson Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoute Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoute Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
C#
public interface ISIAPIOutputSiteRoute
Managed Extensions for C++
public __gc __interface ISIAPIOutputSiteRoute
C++/CLI
public interface class ISIAPIOutputSiteRoute

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoute Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoute Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSiteRoute.

Public Properties

 | Name | Description
Property | Coord_mov_displayed_green_time |
Property | Coord_mov_displayed_start_time |
Property | Coord_mov_eff_start_time |
Property | Coord_mov_effgreen |
Property | Coord_mov_phasetime |
Property | Route_id |
Property | RouteName |
Property | RouteSignalOffsetPriority |
Top

See Also

Reference

ISIAPIOutputSiteRoute Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoute Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoute Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSiteRoute members.

Public Properties

 | Name | Description
Property | Coord_mov_displayed_green_time |
Property | Coord_mov_displayed_start_time |
Property | Coord_mov_eff_start_time |
Property | Coord_mov_effgreen |
Property | Coord_mov_phasetime |
Property | Route_id |
Property | RouteName |
Property | RouteSignalOffsetPriority |
Top

See Also

Reference

ISIAPIOutputSiteRoute Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_displayed_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Coord_mov_displayed_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_displayed_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_displayed_green_time
C#
int Coord_mov_displayed_green_time {get;}
Managed Extensions for C++
__property int get_Coord_mov_displayed_green_time();
C++/CLI
property int Coord_mov_displayed_green_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_displayed_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Coord_mov_displayed_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_displayed_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_displayed_start_time
C#
int Coord_mov_displayed_start_time {get;}
Managed Extensions for C++
__property int get_Coord_mov_displayed_start_time();
C++/CLI
property int Coord_mov_displayed_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_eff_start_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Coord_mov_eff_start_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_eff_start_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_eff_start_time
C#
int Coord_mov_eff_start_time {get;}
Managed Extensions for C++
__property int get_Coord_mov_eff_start_time();
C++/CLI
property int Coord_mov_eff_start_time {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_effgreen Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Coord_mov_effgreen Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_effgreen As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_effgreen
C#
int Coord_mov_effgreen {get;}
Managed Extensions for C++
__property int get_Coord_mov_effgreen();
C++/CLI
property int Coord_mov_effgreen {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Coord_mov_phasetime Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Coord_mov_phasetime Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Coord_mov_phasetime As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Coord_mov_phasetime
C#
int Coord_mov_phasetime {get;}
Managed Extensions for C++
__property int get_Coord_mov_phasetime();
C++/CLI
property int Coord_mov_phasetime {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : Route_id Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Route_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.Route_id
C#
int Route_id {get;}
Managed Extensions for C++
__property int get_Route_id();
C++/CLI
property int Route_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : RouteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteName As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As String

value = instance.RouteName
C#
string RouteName {get;}
Managed Extensions for C++
__property string* get_RouteName();
C++/CLI
property String^ RouteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteSignalOffsetPriority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoute Interface : RouteSignalOffsetPriority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteSignalOffsetPriority As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoute
Dim value As Integer

value = instance.RouteSignalOffsetPriority
C#
int RouteSignalOffsetPriority {get;}
Managed Extensions for C++
__property int get_RouteSignalOffsetPriority();
C++/CLI
property int RouteSignalOffsetPriority {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoute Interface
ISIAPIOutputSiteRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoutes Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoutes Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSiteRoutes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoutes
C#
public interface ISIAPIOutputSiteRoutes
Managed Extensions for C++
public __gc __interface ISIAPIOutputSiteRoutes
C++/CLI
public interface class ISIAPIOutputSiteRoutes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoutes Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoutes Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSiteRoutes.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | Exists |
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputSiteRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoutes Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoutes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSiteRoutes members.

Public Methods

 | Name | Description
Method | Exists |
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputSiteRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoutes Interface : Exists Method

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function Exists( _
   ByVal routeName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoutes
Dim routeName As String
Dim value As Boolean

value = instance.Exists(routeName)
C#
bool Exists(
   string routeName
)
Managed Extensions for C++
bool Exists(
   string* routeName
)
C++/CLI
bool Exists(
   String^ routeName
)

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Interface
ISIAPIOutputSiteRoutes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteRoutes Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteRoutes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSiteRoutes members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIOutputSiteRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoutes Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoutes
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Interface
ISIAPIOutputSiteRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoutes Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Interface
ISIAPIOutputSiteRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoutes Interface > Item Property : Item(String) Property

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal routeName As String _
) As ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoutes
Dim routeName As String
Dim value As ISIAPIOutputSiteRoute

value = instance.Item(routeName)
C#
ISIAPIOutputSiteRoute Item(
   string routeName
) {get;}
Managed Extensions for C++
__property ISIAPIOutputSiteRoute* get_Item(
   string* routeName
);
C++/CLI
property ISIAPIOutputSiteRoute^ Item {
   ISIAPIOutputSiteRoute^ get(String^ routeName);
}

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Interface
ISIAPIOutputSiteRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteRoutes Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIOutputSiteRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteRoutes
Dim index As Integer
Dim value As ISIAPIOutputSiteRoute

value = instance.Item(index)
C#
ISIAPIOutputSiteRoute Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIOutputSiteRoute* get_Item(
   int index
);
C++/CLI
property ISIAPIOutputSiteRoute^ Item {
   ISIAPIOutputSiteRoute^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteRoutes Interface
ISIAPIOutputSiteRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteVehicle Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteVehicle Interface

Glossary Item Box

SIDRA INTERSECTION Vehicle specific site output wrapper class.

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIOutputSiteVehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
C#
public interface ISIAPIOutputSiteVehicle
Managed Extensions for C++
public __gc __interface ISIAPIOutputSiteVehicle
C++/CLI
public interface class ISIAPIOutputSiteVehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteVehicle Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteVehicle Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIOutputSiteVehicle.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_effective | Effective intersection capacity.
Property | Capacity_lane_total | Sum of all lane capacities.
Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstlane | Average control delay for worst lane.
Property | Delay_control_average_worstmov | Average control delay for worst movement.
Property | Delay_control_total | Total control delay.
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate | Fuel consumption rate.
Property | Fuel_consumption_total | Total fuel consumption.
Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Property | Idling_time_average |
Property | Level_of_service | Intersection LOS.
Property | Level_of_service_av_int_delay | Average intersection delay LOS.
Property | Level_of_service_worstlane | Worst lane LOS.
Property | Level_of_service_worstmov | Worst movement LOS.
Property | Max_subit_capacity_diff |
Property | Max_subit_capacity_percent |
Property | Max_subit_dx_percent |
Property | Max_subit_dx_percent_prev |
Property | Max_subit_dx_percent_prev2 |
Property | Max_SubIterations |
Property | Max_timit_dx_percent |
Property | Max_timit_dx_percent_prev |
Property | Max_timit_dx_percent_prev2 |
Property | Max_TimIterations |
Property | Model_flowcap_vari_index |
Property | Model_timing_vari_index |
Property | Nox_rate | NOX emission rate (g/km).
Property | Nox_total | Total NOX emissions (kg/h).
Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Property | Operating_cost_total | Total operating cost (cost unit/h)
Property | Performance_index | Performance index.
Property | Practical_spare_capacity | Lowest practical degree of saturation.
Property | Proportion_queued | Proportion queued.
Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | SpeedEfficiency |
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | SubIterationsCount |
Property | TimIterationsCount |
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time.
Property | Travel_time_total | Total travel time.
Top

See Also

Reference

ISIAPIOutputSiteVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputSiteVehicle Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputSiteVehicle Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputSiteVehicle members.

Public Properties

 | Name | Description
Property | Analysis_method |
Property | Avg_num_of_cycles_to_depart |
Property | Capacity_adj_flag_worstlane |
Property | Capacity_adj_worstlane |
Property | Capacity_effective | Effective intersection capacity.
Property | Capacity_lane_total | Sum of all lane capacities.
Property | Capacity_mov_total | Sum of movement capacities (includes effect of lane underutilisation within movement).
Property | Carbon_dioxide_rate | Carbon Dioxide emission rate (g/km).
Property | Carbon_dioxide_total | Total Carbon Dioxide emissions (kg/h).
Property | Carbon_monoxide_rate | Carbon Monoxide emission rate (g/km).
Property | Carbon_monoxide_total | Total Carbon Monoxide emissions (kg/h).
Property | Deg_satn | Intersection degree of saturation.
Property | Delay_control_average | Average control delay.
Property | Delay_control_average_worstlane | Average control delay for worst lane.
Property | Delay_control_average_worstmov | Average control delay for worst movement.
Property | Delay_control_total | Total control delay.
Property | Delay_geometric_average |
Property | Delay_stopline_average |
Property | Flow_HV | Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_capconstr | Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct | Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_HV_pct_capconstr | Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.
Property | Flow_LV | Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_LV_capconstr | Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.
Property | Flow_total | Total Demand Flow Rate.
Property | Flow_total_capconstr | Total Arrival Flow Rate.
Property | Fuel_consumption_rate | Fuel consumption rate.
Property | Fuel_consumption_total | Total fuel consumption.
Property | Hydrocarbons_rate | Hydrocarbon emission rate (g/km).
Property | Hydrocarbons_total | Total Hydrocarbon emissions (kg/h).
Property | Idling_time_average |
Property | Level_of_service | Intersection LOS.
Property | Level_of_service_av_int_delay | Average intersection delay LOS.
Property | Level_of_service_worstlane | Worst lane LOS.
Property | Level_of_service_worstmov | Worst movement LOS.
Property | Max_subit_capacity_diff |
Property | Max_subit_capacity_percent |
Property | Max_subit_dx_percent |
Property | Max_subit_dx_percent_prev |
Property | Max_subit_dx_percent_prev2 |
Property | Max_SubIterations |
Property | Max_timit_dx_percent |
Property | Max_timit_dx_percent_prev |
Property | Max_timit_dx_percent_prev2 |
Property | Max_TimIterations |
Property | Model_flowcap_vari_index |
Property | Model_timing_vari_index |
Property | Nox_rate | NOX emission rate (g/km).
Property | Nox_total | Total NOX emissions (kg/h).
Property | Operating_cost_rate | Operating cost rate (cost unit/km).
Property | Operating_cost_total | Total operating cost (cost unit/h)
Property | Performance_index | Performance index.
Property | Practical_spare_capacity | Lowest practical degree of saturation.
Property | Proportion_queued | Proportion queued.
Property | Queue_cycav_mean | Longest cycle-average queue (veh), mean.
Property | Queue_cycav_percentile | Longest cycle-average queue (veh), user-specified percentile.
Property | Queue_dist_cycav_mean | Longest cycle-average queue (distance), mean.
Property | Queue_dist_cycav_percentile | Longest cycle-average queue (distance), user-specified percentile.
Property | Queue_dist_greenstart_mean |
Property | Queue_dist_greenstart_percentile |
Property | Queue_dist_maxback_mean | Longest maximum back of queue (distance), mean.
Property | Queue_dist_maxback_percentile | Longest maximum back of queue (distance), user-specified percentile.
Property | Queue_greenstart_mean |
Property | Queue_greenstart_percentile |
Property | Queue_maxback_mean | Longest maximum back of queue (veh), mean.
Property | Queue_maxback_percentile | Longest maximum back of queue (veh), user-specified percentile.
Property | Queue_storage_ratio_avg | Queue storage ratio based on maximum back of queue (distance), mean
Property | Queue_storage_ratio_percentile | Queue storage ratio based on maximum back of queue (distance), user-specified percentile
Property | SpeedEfficiency |
Property | Stop_rate | Effective stop rate.
Property | Stops_total | Total effective stops.
Property | SubIterationsCount |
Property | TimIterationsCount |
Property | Travel_distance_average | Average travel distance.
Property | Travel_distance_total | Total travel distance.
Property | Travel_speed | Average travel speed.
Property | Travel_time_average | Average travel time.
Property | Travel_time_total | Total travel time.
Top

See Also

Reference

ISIAPIOutputSiteVehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Analysis_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Analysis_method
C#
int Analysis_method {get;}
Managed Extensions for C++
__property int get_Analysis_method();
C++/CLI
property int Analysis_method {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Avg_num_of_cycles_to_depart Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Avg_num_of_cycles_to_depart Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Avg_num_of_cycles_to_depart As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Avg_num_of_cycles_to_depart
C#
float Avg_num_of_cycles_to_depart {get;}
Managed Extensions for C++
__property float get_Avg_num_of_cycles_to_depart();
C++/CLI
property float Avg_num_of_cycles_to_depart {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_flag_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Capacity_adj_flag_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_flag_worstlane As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Capacity_adj_flag_worstlane
C#
int Capacity_adj_flag_worstlane {get;}
Managed Extensions for C++
__property int get_Capacity_adj_flag_worstlane();
C++/CLI
property int Capacity_adj_flag_worstlane {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_adj_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Capacity_adj_worstlane Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_adj_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_adj_worstlane
C#
float Capacity_adj_worstlane {get;}
Managed Extensions for C++
__property float get_Capacity_adj_worstlane();
C++/CLI
property float Capacity_adj_worstlane {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_effective Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Capacity_effective Property

Glossary Item Box

Effective intersection capacity.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_effective As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_effective
C#
float Capacity_effective {get;}
Managed Extensions for C++
__property float get_Capacity_effective();
C++/CLI
property float Capacity_effective {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_lane_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Capacity_lane_total Property

Glossary Item Box

Sum of all lane capacities.

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_lane_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_lane_total
C#
float Capacity_lane_total {get;}
Managed Extensions for C++
__property float get_Capacity_lane_total();
C++/CLI
property float Capacity_lane_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Capacity_mov_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Capacity_mov_total Property

Glossary Item Box

Sum of movement capacities (includes effect of lane underutilisation within movement).

Syntax

Visual Basic (Declaration)
ReadOnly Property Capacity_mov_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Capacity_mov_total
C#
float Capacity_mov_total {get;}
Managed Extensions for C++
__property float get_Capacity_mov_total();
C++/CLI
property float Capacity_mov_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Carbon_dioxide_rate Property

Glossary Item Box

Carbon Dioxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_dioxide_rate
C#
float Carbon_dioxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_rate();
C++/CLI
property float Carbon_dioxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_dioxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Carbon_dioxide_total Property

Glossary Item Box

Total Carbon Dioxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_dioxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_dioxide_total
C#
float Carbon_dioxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_dioxide_total();
C++/CLI
property float Carbon_dioxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Carbon_monoxide_rate Property

Glossary Item Box

Carbon Monoxide emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_monoxide_rate
C#
float Carbon_monoxide_rate {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_rate();
C++/CLI
property float Carbon_monoxide_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Carbon_monoxide_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Carbon_monoxide_total Property

Glossary Item Box

Total Carbon Monoxide emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Carbon_monoxide_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Carbon_monoxide_total
C#
float Carbon_monoxide_total {get;}
Managed Extensions for C++
__property float get_Carbon_monoxide_total();
C++/CLI
property float Carbon_monoxide_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Deg_satn Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Deg_satn Property

Glossary Item Box

Intersection degree of saturation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Deg_satn As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Deg_satn
C#
float Deg_satn {get;}
Managed Extensions for C++
__property float get_Deg_satn();
C++/CLI
property float Deg_satn {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_control_average Property

Glossary Item Box

Average control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average
C#
float Delay_control_average {get;}
Managed Extensions for C++
__property float get_Delay_control_average();
C++/CLI
property float Delay_control_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_control_average_worstlane Property

Glossary Item Box

Average control delay for worst lane.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstlane As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average_worstlane
C#
float Delay_control_average_worstlane {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstlane();
C++/CLI
property float Delay_control_average_worstlane {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_average_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_control_average_worstmov Property

Glossary Item Box

Average control delay for worst movement.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_average_worstmov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_average_worstmov
C#
float Delay_control_average_worstmov {get;}
Managed Extensions for C++
__property float get_Delay_control_average_worstmov();
C++/CLI
property float Delay_control_average_worstmov {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_control_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_control_total Property

Glossary Item Box

Total control delay.

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_control_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_control_total
C#
float Delay_control_total {get;}
Managed Extensions for C++
__property float get_Delay_control_total();
C++/CLI
property float Delay_control_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_geometric_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_geometric_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_geometric_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_geometric_average
C#
float Delay_geometric_average {get;}
Managed Extensions for C++
__property float get_Delay_geometric_average();
C++/CLI
property float Delay_geometric_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Delay_stopline_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Delay_stopline_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Delay_stopline_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Delay_stopline_average
C#
float Delay_stopline_average {get;}
Managed Extensions for C++
__property float get_Delay_stopline_average();
C++/CLI
property float Delay_stopline_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_HV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV
C#
float Flow_HV {get;}
Managed Extensions for C++
__property float get_Flow_HV();
C++/CLI
property float Flow_HV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_HV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_capconstr
C#
float Flow_HV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_capconstr();
C++/CLI
property float Flow_HV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_HV_pct Property

Glossary Item Box

Demand Flow Rate Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_pct
C#
float Flow_HV_pct {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct();
C++/CLI
property float Flow_HV_pct {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_HV_pct_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_HV_pct_capconstr Property

Glossary Item Box

Arrival Flow Percentage (%) of all Movement Classes with Heavy Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_HV_pct_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_HV_pct_capconstr
C#
float Flow_HV_pct_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_HV_pct_capconstr();
C++/CLI
property float Flow_HV_pct_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_LV Property

Glossary Item Box

Demand Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_LV
C#
float Flow_LV {get;}
Managed Extensions for C++
__property float get_Flow_LV();
C++/CLI
property float Flow_LV {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_LV_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_LV_capconstr Property

Glossary Item Box

Arrival Flow Rate of all Movement Classes with Light Vehicle Model Designation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_LV_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_LV_capconstr
C#
float Flow_LV_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_LV_capconstr();
C++/CLI
property float Flow_LV_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_total Property

Glossary Item Box

Total Demand Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_total
C#
float Flow_total {get;}
Managed Extensions for C++
__property float get_Flow_total();
C++/CLI
property float Flow_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Flow_total_capconstr Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Flow_total_capconstr Property

Glossary Item Box

Total Arrival Flow Rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Flow_total_capconstr As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Flow_total_capconstr
C#
float Flow_total_capconstr {get;}
Managed Extensions for C++
__property float get_Flow_total_capconstr();
C++/CLI
property float Flow_total_capconstr {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Fuel_consumption_rate Property

Glossary Item Box

Fuel consumption rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Fuel_consumption_rate
C#
float Fuel_consumption_rate {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_rate();
C++/CLI
property float Fuel_consumption_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Fuel_consumption_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Fuel_consumption_total Property

Glossary Item Box

Total fuel consumption.

Syntax

Visual Basic (Declaration)
ReadOnly Property Fuel_consumption_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Fuel_consumption_total
C#
float Fuel_consumption_total {get;}
Managed Extensions for C++
__property float get_Fuel_consumption_total();
C++/CLI
property float Fuel_consumption_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Hydrocarbons_rate Property

Glossary Item Box

Hydrocarbon emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Hydrocarbons_rate
C#
float Hydrocarbons_rate {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_rate();
C++/CLI
property float Hydrocarbons_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hydrocarbons_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Hydrocarbons_total Property

Glossary Item Box

Total Hydrocarbon emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Hydrocarbons_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Hydrocarbons_total
C#
float Hydrocarbons_total {get;}
Managed Extensions for C++
__property float get_Hydrocarbons_total();
C++/CLI
property float Hydrocarbons_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Idling_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Idling_time_average Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Idling_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Idling_time_average
C#
float Idling_time_average {get;}
Managed Extensions for C++
__property float get_Idling_time_average();
C++/CLI
property float Idling_time_average {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Level_of_service Property

Glossary Item Box

Intersection LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service
C#
string Level_of_service {get;}
Managed Extensions for C++
__property string* get_Level_of_service();
C++/CLI
property String^ Level_of_service {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_av_int_delay Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Level_of_service_av_int_delay Property

Glossary Item Box

Average intersection delay LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_av_int_delay As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_av_int_delay
C#
string Level_of_service_av_int_delay {get;}
Managed Extensions for C++
__property string* get_Level_of_service_av_int_delay();
C++/CLI
property String^ Level_of_service_av_int_delay {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstlane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Level_of_service_worstlane Property

Glossary Item Box

Worst lane LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_worstlane As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_worstlane
C#
string Level_of_service_worstlane {get;}
Managed Extensions for C++
__property string* get_Level_of_service_worstlane();
C++/CLI
property String^ Level_of_service_worstlane {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Level_of_service_worstmov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Level_of_service_worstmov Property

Glossary Item Box

Worst movement LOS.

Syntax

Visual Basic (Declaration)
ReadOnly Property Level_of_service_worstmov As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As String

value = instance.Level_of_service_worstmov
C#
string Level_of_service_worstmov {get;}
Managed Extensions for C++
__property string* get_Level_of_service_worstmov();
C++/CLI
property String^ Level_of_service_worstmov {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_capacity_diff Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_subit_capacity_diff Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_subit_capacity_diff As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_capacity_diff
C#
float Max_subit_capacity_diff {get;}
Managed Extensions for C++
__property float get_Max_subit_capacity_diff();
C++/CLI
property float Max_subit_capacity_diff {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_capacity_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_subit_capacity_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_subit_capacity_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_capacity_percent
C#
float Max_subit_capacity_percent {get;}
Managed Extensions for C++
__property float get_Max_subit_capacity_percent();
C++/CLI
property float Max_subit_capacity_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_subit_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_subit_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent
C#
float Max_subit_dx_percent {get;}
Managed Extensions for C++
__property float get_Max_subit_dx_percent();
C++/CLI
property float Max_subit_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_subit_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_subit_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent_prev
C#
float Max_subit_dx_percent_prev {get;}
Managed Extensions for C++
__property float get_Max_subit_dx_percent_prev();
C++/CLI
property float Max_subit_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_subit_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_subit_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_subit_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_subit_dx_percent_prev2
C#
float Max_subit_dx_percent_prev2 {get;}
Managed Extensions for C++
__property float get_Max_subit_dx_percent_prev2();
C++/CLI
property float Max_subit_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_SubIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_SubIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_SubIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Max_SubIterations
C#
int Max_SubIterations {get;}
Managed Extensions for C++
__property int get_Max_SubIterations();
C++/CLI
property int Max_SubIterations {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_timit_dx_percent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_timit_dx_percent As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent
C#
float Max_timit_dx_percent {get;}
Managed Extensions for C++
__property float get_Max_timit_dx_percent();
C++/CLI
property float Max_timit_dx_percent {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent_prev Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_timit_dx_percent_prev Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_timit_dx_percent_prev As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent_prev
C#
float Max_timit_dx_percent_prev {get;}
Managed Extensions for C++
__property float get_Max_timit_dx_percent_prev();
C++/CLI
property float Max_timit_dx_percent_prev {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_timit_dx_percent_prev2 Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_timit_dx_percent_prev2 Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_timit_dx_percent_prev2 As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Max_timit_dx_percent_prev2
C#
float Max_timit_dx_percent_prev2 {get;}
Managed Extensions for C++
__property float get_Max_timit_dx_percent_prev2();
C++/CLI
property float Max_timit_dx_percent_prev2 {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Max_TimIterations Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Max_TimIterations Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Max_TimIterations As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.Max_TimIterations
C#
int Max_TimIterations {get;}
Managed Extensions for C++
__property int get_Max_TimIterations();
C++/CLI
property int Max_TimIterations {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_flowcap_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Model_flowcap_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Model_flowcap_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Model_flowcap_vari_index
C#
float Model_flowcap_vari_index {get;}
Managed Extensions for C++
__property float get_Model_flowcap_vari_index();
C++/CLI
property float Model_flowcap_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Model_timing_vari_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Model_timing_vari_index Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Model_timing_vari_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Model_timing_vari_index
C#
float Model_timing_vari_index {get;}
Managed Extensions for C++
__property float get_Model_timing_vari_index();
C++/CLI
property float Model_timing_vari_index {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Nox_rate Property

Glossary Item Box

NOX emission rate (g/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Nox_rate
C#
float Nox_rate {get;}
Managed Extensions for C++
__property float get_Nox_rate();
C++/CLI
property float Nox_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Nox_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Nox_total Property

Glossary Item Box

Total NOX emissions (kg/h).

Syntax

Visual Basic (Declaration)
ReadOnly Property Nox_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Nox_total
C#
float Nox_total {get;}
Managed Extensions for C++
__property float get_Nox_total();
C++/CLI
property float Nox_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Operating_cost_rate Property

Glossary Item Box

Operating cost rate (cost unit/km).

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Operating_cost_rate
C#
float Operating_cost_rate {get;}
Managed Extensions for C++
__property float get_Operating_cost_rate();
C++/CLI
property float Operating_cost_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Operating_cost_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Operating_cost_total Property

Glossary Item Box

Total operating cost (cost unit/h)

Syntax

Visual Basic (Declaration)
ReadOnly Property Operating_cost_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Operating_cost_total
C#
float Operating_cost_total {get;}
Managed Extensions for C++
__property float get_Operating_cost_total();
C++/CLI
property float Operating_cost_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Performance_index Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Performance_index Property

Glossary Item Box

Performance index.

Syntax

Visual Basic (Declaration)
ReadOnly Property Performance_index As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Performance_index
C#
float Performance_index {get;}
Managed Extensions for C++
__property float get_Performance_index();
C++/CLI
property float Performance_index {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_spare_capacity Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Practical_spare_capacity Property

Glossary Item Box

Lowest practical degree of saturation.

Syntax

Visual Basic (Declaration)
ReadOnly Property Practical_spare_capacity As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Practical_spare_capacity
C#
float Practical_spare_capacity {get;}
Managed Extensions for C++
__property float get_Practical_spare_capacity();
C++/CLI
property float Practical_spare_capacity {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Proportion_queued Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Proportion_queued Property

Glossary Item Box

Proportion queued.

Syntax

Visual Basic (Declaration)
ReadOnly Property Proportion_queued As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Proportion_queued
C#
float Proportion_queued {get;}
Managed Extensions for C++
__property float get_Proportion_queued();
C++/CLI
property float Proportion_queued {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_cycav_mean
C#
float Queue_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_cycav_mean();
C++/CLI
property float Queue_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_cycav_percentile
C#
float Queue_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_cycav_percentile();
C++/CLI
property float Queue_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_cycav_mean Property

Glossary Item Box

Longest cycle-average queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_cycav_mean
C#
float Queue_dist_cycav_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_mean();
C++/CLI
property float Queue_dist_cycav_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_cycav_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_cycav_percentile Property

Glossary Item Box

Longest cycle-average queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_cycav_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_cycav_percentile
C#
float Queue_dist_cycav_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_cycav_percentile();
C++/CLI
property float Queue_dist_cycav_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_greenstart_mean
C#
float Queue_dist_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_mean();
C++/CLI
property float Queue_dist_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_greenstart_percentile
C#
float Queue_dist_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_greenstart_percentile();
C++/CLI
property float Queue_dist_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (distance), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_maxback_mean
C#
float Queue_dist_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_mean();
C++/CLI
property float Queue_dist_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_dist_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_dist_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (distance), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_dist_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_dist_maxback_percentile
C#
float Queue_dist_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_dist_maxback_percentile();
C++/CLI
property float Queue_dist_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_greenstart_mean Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_greenstart_mean
C#
float Queue_greenstart_mean {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_mean();
C++/CLI
property float Queue_greenstart_mean {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_greenstart_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_greenstart_percentile Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_greenstart_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_greenstart_percentile
C#
float Queue_greenstart_percentile {get;}
Managed Extensions for C++
__property float get_Queue_greenstart_percentile();
C++/CLI
property float Queue_greenstart_percentile {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_mean Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_maxback_mean Property

Glossary Item Box

Longest maximum back of queue (veh), mean.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_mean As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_maxback_mean
C#
float Queue_maxback_mean {get;}
Managed Extensions for C++
__property float get_Queue_maxback_mean();
C++/CLI
property float Queue_maxback_mean {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_maxback_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_maxback_percentile Property

Glossary Item Box

Longest maximum back of queue (veh), user-specified percentile.

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_maxback_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_maxback_percentile
C#
float Queue_maxback_percentile {get;}
Managed Extensions for C++
__property float get_Queue_maxback_percentile();
C++/CLI
property float Queue_maxback_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_avg Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_storage_ratio_avg Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), mean

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_avg As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_storage_ratio_avg
C#
float Queue_storage_ratio_avg {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_avg();
C++/CLI
property float Queue_storage_ratio_avg {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Queue_storage_ratio_percentile Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Queue_storage_ratio_percentile Property

Glossary Item Box

Queue storage ratio based on maximum back of queue (distance), user-specified percentile

Syntax

Visual Basic (Declaration)
ReadOnly Property Queue_storage_ratio_percentile As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Queue_storage_ratio_percentile
C#
float Queue_storage_ratio_percentile {get;}
Managed Extensions for C++
__property float get_Queue_storage_ratio_percentile();
C++/CLI
property float Queue_storage_ratio_percentile {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : SpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.SpeedEfficiency
C#
float SpeedEfficiency {get;}
Managed Extensions for C++
__property float get_SpeedEfficiency();
C++/CLI
property float SpeedEfficiency {
   float get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stop_rate Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Stop_rate Property

Glossary Item Box

Effective stop rate.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stop_rate As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Stop_rate
C#
float Stop_rate {get;}
Managed Extensions for C++
__property float get_Stop_rate();
C++/CLI
property float Stop_rate {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Stops_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Stops_total Property

Glossary Item Box

Total effective stops.

Syntax

Visual Basic (Declaration)
ReadOnly Property Stops_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Stops_total
C#
float Stops_total {get;}
Managed Extensions for C++
__property float get_Stops_total();
C++/CLI
property float Stops_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SubIterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : SubIterationsCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SubIterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.SubIterationsCount
C#
int SubIterationsCount {get;}
Managed Extensions for C++
__property int get_SubIterationsCount();
C++/CLI
property int SubIterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TimIterationsCount Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : TimIterationsCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TimIterationsCount As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Integer

value = instance.TimIterationsCount
C#
int TimIterationsCount {get;}
Managed Extensions for C++
__property int get_TimIterationsCount();
C++/CLI
property int TimIterationsCount {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Travel_distance_average Property

Glossary Item Box

Average travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_distance_average
C#
float Travel_distance_average {get;}
Managed Extensions for C++
__property float get_Travel_distance_average();
C++/CLI
property float Travel_distance_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_distance_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Travel_distance_total Property

Glossary Item Box

Total travel distance.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_distance_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_distance_total
C#
float Travel_distance_total {get;}
Managed Extensions for C++
__property float get_Travel_distance_total();
C++/CLI
property float Travel_distance_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_speed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Travel_speed Property

Glossary Item Box

Average travel speed.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_speed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_speed
C#
float Travel_speed {get;}
Managed Extensions for C++
__property float get_Travel_speed();
C++/CLI
property float Travel_speed {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_average Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Travel_time_average Property

Glossary Item Box

Average travel time.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_average As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_time_average
C#
float Travel_time_average {get;}
Managed Extensions for C++
__property float get_Travel_time_average();
C++/CLI
property float Travel_time_average {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Travel_time_total Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIOutputSiteVehicle Interface : Travel_time_total Property

Glossary Item Box

Total travel time.

Syntax

Visual Basic (Declaration)
ReadOnly Property Travel_time_total As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIOutputSiteVehicle
Dim value As Single

value = instance.Travel_time_total
C#
float Travel_time_total {get;}
Managed Extensions for C++
__property float get_Travel_time_total();
C++/CLI
property float Travel_time_total {
   float get();
}

Property Value

Type: System.Single

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIOutputSiteVehicle Interface
ISIAPIOutputSiteVehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhase Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhase Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
C#
public interface ISIAPIPhase
Managed Extensions for C++
public __gc __interface ISIAPIPhase
C++/CLI
public interface class ISIAPIPhase

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhase Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhase Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhase.

Public Properties

 | Name | Description
Property | All_red_time |
Property | Dummy_maximum_green_time |
Property | Dummy_maximum_green_time_user |
Property | Dummy_minimum_green_time |
Property | Dummy_minimum_green_time_user |
Property | Has_dummy |
Property | Is_variable |
Property | IsReferencePhase |
Property | Minimum_time |
Property | Name |
Property | Phase_frequency |
Property | Phase_frequency_user |
Property | Phase_id | The database row unique ID of the Phase.
Property | Phase_time |
Property | Phasemovement_peds |
Property | Phasemovement_vehicles |
Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Property | Sequence |
Property | Yellow_time |
Top

See Also

Reference

ISIAPIPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhase Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhase Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhase members.

Public Properties

 | Name | Description
Property | All_red_time |
Property | Dummy_maximum_green_time |
Property | Dummy_maximum_green_time_user |
Property | Dummy_minimum_green_time |
Property | Dummy_minimum_green_time_user |
Property | Has_dummy |
Property | Is_variable |
Property | IsReferencePhase |
Property | Minimum_time |
Property | Name |
Property | Phase_frequency |
Property | Phase_frequency_user |
Property | Phase_id | The database row unique ID of the Phase.
Property | Phase_time |
Property | Phasemovement_peds |
Property | Phasemovement_vehicles |
Property | Position | The Phase Position in the Sequence's Phases collection. It is a zero-base integer.
Property | Sequence |
Property | Yellow_time |
Top

See Also

Reference

ISIAPIPhase Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
All_red_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : All_red_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property All_red_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.All_red_time = value

value = instance.All_red_time
C#
int All_red_time {get; set;}
Managed Extensions for C++
__property int get_All_red_time();
__property void set_All_red_time(
   int value
);
C++/CLI
property int All_red_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Dummy_maximum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_maximum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.Dummy_maximum_green_time = value

value = instance.Dummy_maximum_green_time
C#
int Dummy_maximum_green_time {get; set;}
Managed Extensions for C++
__property int get_Dummy_maximum_green_time();
__property void set_Dummy_maximum_green_time(
   int value
);
C++/CLI
property int Dummy_maximum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_maximum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Dummy_maximum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_maximum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.Dummy_maximum_green_time_user = value

value = instance.Dummy_maximum_green_time_user
C#
bool Dummy_maximum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Dummy_maximum_green_time_user();
__property void set_Dummy_maximum_green_time_user(
   bool value
);
C++/CLI
property bool Dummy_maximum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Dummy_minimum_green_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_minimum_green_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.Dummy_minimum_green_time = value

value = instance.Dummy_minimum_green_time
C#
int Dummy_minimum_green_time {get; set;}
Managed Extensions for C++
__property int get_Dummy_minimum_green_time();
__property void set_Dummy_minimum_green_time(
   int value
);
C++/CLI
property int Dummy_minimum_green_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Dummy_minimum_green_time_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Dummy_minimum_green_time_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Dummy_minimum_green_time_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.Dummy_minimum_green_time_user = value

value = instance.Dummy_minimum_green_time_user
C#
bool Dummy_minimum_green_time_user {get; set;}
Managed Extensions for C++
__property bool get_Dummy_minimum_green_time_user();
__property void set_Dummy_minimum_green_time_user(
   bool value
);
C++/CLI
property bool Dummy_minimum_green_time_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Has_dummy Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Has_dummy Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Has_dummy As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.Has_dummy = value

value = instance.Has_dummy
C#
bool Has_dummy {get; set;}
Managed Extensions for C++
__property bool get_Has_dummy();
__property void set_Has_dummy(
   bool value
);
C++/CLI
property bool Has_dummy {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_variable Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Is_variable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_variable As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.Is_variable = value

value = instance.Is_variable
C#
bool Is_variable {get; set;}
Managed Extensions for C++
__property bool get_Is_variable();
__property void set_Is_variable(
   bool value
);
C++/CLI
property bool Is_variable {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsReferencePhase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : IsReferencePhase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsReferencePhase As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.IsReferencePhase = value

value = instance.IsReferencePhase
C#
bool IsReferencePhase {get; set;}
Managed Extensions for C++
__property bool get_IsReferencePhase();
__property void set_IsReferencePhase(
   bool value
);
C++/CLI
property bool IsReferencePhase {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Minimum_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Minimum_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Minimum_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.Minimum_time = value

value = instance.Minimum_time
C#
int Minimum_time {get; set;}
Managed Extensions for C++
__property int get_Minimum_time();
__property void set_Minimum_time(
   int value
);
C++/CLI
property int Minimum_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phase_frequency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_frequency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Single

instance.Phase_frequency = value

value = instance.Phase_frequency
C#
float Phase_frequency {get; set;}
Managed Extensions for C++
__property float get_Phase_frequency();
__property void set_Phase_frequency(
   float value
);
C++/CLI
property float Phase_frequency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_frequency_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phase_frequency_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_frequency_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Boolean

instance.Phase_frequency_user = value

value = instance.Phase_frequency_user
C#
bool Phase_frequency_user {get; set;}
Managed Extensions for C++
__property bool get_Phase_frequency_user();
__property void set_Phase_frequency_user(
   bool value
);
C++/CLI
property bool Phase_frequency_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phase_id Property

Glossary Item Box

The database row unique ID of the Phase.

Syntax

Visual Basic (Declaration)
ReadOnly Property Phase_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

value = instance.Phase_id
C#
int Phase_id {get;}
Managed Extensions for C++
__property int get_Phase_id();
C++/CLI
property int Phase_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phase_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Phase_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.Phase_time = value

value = instance.Phase_time
C#
int Phase_time {get; set;}
Managed Extensions for C++
__property int get_Phase_time();
__property void set_Phase_time(
   int value
);
C++/CLI
property int Phase_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phasemovement_peds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phasemovement_peds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phasemovement_peds As ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As ISIAPIPhasemovement_peds

value = instance.Phasemovement_peds
C#
ISIAPIPhasemovement_peds Phasemovement_peds {get;}
Managed Extensions for C++
__property ISIAPIPhasemovement_peds* get_Phasemovement_peds();
C++/CLI
property ISIAPIPhasemovement_peds^ Phasemovement_peds {
   ISIAPIPhasemovement_peds^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phasemovement_vehicles Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Phasemovement_vehicles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phasemovement_vehicles As ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As ISIAPIPhasemovement_vehicles

value = instance.Phasemovement_vehicles
C#
ISIAPIPhasemovement_vehicles Phasemovement_vehicles {get;}
Managed Extensions for C++
__property ISIAPIPhasemovement_vehicles* get_Phasemovement_vehicles();
C++/CLI
property ISIAPIPhasemovement_vehicles^ Phasemovement_vehicles {
   ISIAPIPhasemovement_vehicles^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Position Property

Glossary Item Box

The Phase Position in the Sequence's Phases collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Sequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Sequence As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As ISIAPISequence

value = instance.Sequence
C#
ISIAPISequence Sequence {get;}
Managed Extensions for C++
__property ISIAPISequence* get_Sequence();
C++/CLI
property ISIAPISequence^ Sequence {
   ISIAPISequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Yellow_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhase Interface : Yellow_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Yellow_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhase
Dim value As Integer

instance.Yellow_time = value

value = instance.Yellow_time
C#
int Yellow_time {get; set;}
Managed Extensions for C++
__property int get_Yellow_time();
__property void set_Yellow_time(
   int value
);
C++/CLI
property int Yellow_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhase Interface
ISIAPIPhase Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_ped Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_ped Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhasemovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
C#
public interface ISIAPIPhasemovement_ped
Managed Extensions for C++
public __gc __interface ISIAPIPhasemovement_ped
C++/CLI
public interface class ISIAPIPhasemovement_ped

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_ped Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_ped Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhasemovement_ped.

Public Properties

 | Name | Description
Property | Movement_ped_origin |
Property | Movement_ped_stage |
Property | Movement_ped_type |
Property | Phase |
Property | Running |
Property | Terminates |
Property | Undetected |
Top

See Also

Reference

ISIAPIPhasemovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_ped Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_ped Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_ped members.

Public Properties

 | Name | Description
Property | Movement_ped_origin |
Property | Movement_ped_stage |
Property | Movement_ped_type |
Property | Phase |
Property | Running |
Property | Terminates |
Property | Undetected |
Top

See Also

Reference

ISIAPIPhasemovement_ped Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Movement_ped_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_ped_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_origin
C#
int Movement_ped_origin {get;}
Managed Extensions for C++
__property int get_Movement_ped_origin();
C++/CLI
property int Movement_ped_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_stage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Movement_ped_stage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_ped_stage As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_stage
C#
int Movement_ped_stage {get;}
Managed Extensions for C++
__property int get_Movement_ped_stage();
C++/CLI
property int Movement_ped_stage {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_ped_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Movement_ped_type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_ped_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Integer

value = instance.Movement_ped_type
C#
int Movement_ped_type {get;}
Managed Extensions for C++
__property int get_Movement_ped_type();
C++/CLI
property int Movement_ped_type {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phase As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As ISIAPIPhase

value = instance.Phase
C#
ISIAPIPhase Phase {get;}
Managed Extensions for C++
__property ISIAPIPhase* get_Phase();
C++/CLI
property ISIAPIPhase^ Phase {
   ISIAPIPhase^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Running Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Running As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Boolean

instance.Running = value

value = instance.Running
C#
bool Running {get; set;}
Managed Extensions for C++
__property bool get_Running();
__property void set_Running(
   bool value
);
C++/CLI
property bool Running {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminates Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Terminates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Terminates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Boolean

instance.Terminates = value

value = instance.Terminates
C#
bool Terminates {get; set;}
Managed Extensions for C++
__property bool get_Terminates();
__property void set_Terminates(
   bool value
);
C++/CLI
property bool Terminates {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_ped Interface : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_ped
Dim value As Boolean

instance.Undetected = value

value = instance.Undetected
C#
bool Undetected {get; set;}
Managed Extensions for C++
__property bool get_Undetected();
__property void set_Undetected(
   bool value
);
C++/CLI
property bool Undetected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_ped Interface
ISIAPIPhasemovement_ped Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_peds Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_peds Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhasemovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_peds
C#
public interface ISIAPIPhasemovement_peds
Managed Extensions for C++
public __gc __interface ISIAPIPhasemovement_peds
C++/CLI
public interface class ISIAPIPhasemovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_peds Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_peds Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_peds Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhasemovement_peds.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Phase's Pedestrian Movement.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhasemovementPedExists | Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIPhasemovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_peds Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_peds members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhasemovementPedExists | Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIPhasemovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhasemovementPedExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_peds Interface : PhasemovementPedExists Method

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a value indicating whether a Phase's Pedestrian Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function PhasemovementPedExists( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As Boolean

value = instance.PhasemovementPedExists(type, origin, stage)
C#
bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)
Managed Extensions for C++
bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)
C++/CLI
bool PhasemovementPedExists(
   int type,
   int origin,
   int stage
)

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_peds Interface
ISIAPIPhasemovement_peds Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_peds Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_peds Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_peds members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Phase's Pedestrian Movement.
Top

See Also

Reference

ISIAPIPhasemovement_peds Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_peds Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_peds
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_peds Interface
ISIAPIPhasemovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_peds Interface : Item Property

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Glossary Item Box

Get a Phase's Pedestrian Movement.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal type As Integer, _
   ByVal origin As Integer, _
   ByVal stage As Integer _
) As ISIAPIPhasemovement_ped
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_peds
Dim type As Integer
Dim origin As Integer
Dim stage As Integer
Dim value As ISIAPIPhasemovement_ped

value = instance.Item(type, origin, stage)
C#
ISIAPIPhasemovement_ped this[
   int type,
   int origin,
   int stage
]; {get;}
Managed Extensions for C++
__property ISIAPIPhasemovement_ped* get_Item   int type,
   int origin,
   int stage
;
C++/CLI
property ISIAPIPhasemovement_ped^ default [int,int,int] {
   ISIAPIPhasemovement_ped^ get(int type, int origin, int stage);
}

Parameters

type

Type: System.Int32;
1 = Full Crossing,
2 = Slip Lane,
3 = Staged,
4 = Diagonal

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

stage

Type: System.Int32;
1 = Stage 1 (Approach-side crossing),
2 = Stage 2 (Exit-side crossing)

Property Value

Return a Phase's Pedestrian Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_peds Interface
ISIAPIPhasemovement_peds Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicle Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicle Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhasemovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
C#
public interface ISIAPIPhasemovement_vehicle
Managed Extensions for C++
public __gc __interface ISIAPIPhasemovement_vehicle
C++/CLI
public interface class ISIAPIPhasemovement_vehicle

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicle Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicle Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhasemovement_vehicle.

Public Properties

 | Name | Description
Property | MC_class |
Property | Movement_vehicle_destination |
Property | Movement_vehicle_origin |
Property | Phase |
Property | Running |
Property | Terminates |
Property | Undetected |
Top

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicle Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicle Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_vehicle members.

Public Properties

 | Name | Description
Property | MC_class |
Property | Movement_vehicle_destination |
Property | Movement_vehicle_origin |
Property | Phase |
Property | Running |
Property | Terminates |
Property | Undetected |
Top

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MC_class Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : MC_class Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MC_class As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.MC_class
C#
int MC_class {get;}
Managed Extensions for C++
__property int get_MC_class();
C++/CLI
property int MC_class {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Movement_vehicle_destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_vehicle_destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.Movement_vehicle_destination
C#
int Movement_vehicle_destination {get;}
Managed Extensions for C++
__property int get_Movement_vehicle_destination();
C++/CLI
property int Movement_vehicle_destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_vehicle_origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Movement_vehicle_origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_vehicle_origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Integer

value = instance.Movement_vehicle_origin
C#
int Movement_vehicle_origin {get;}
Managed Extensions for C++
__property int get_Movement_vehicle_origin();
C++/CLI
property int Movement_vehicle_origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phase Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Phase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phase As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As ISIAPIPhase

value = instance.Phase
C#
ISIAPIPhase Phase {get;}
Managed Extensions for C++
__property ISIAPIPhase* get_Phase();
C++/CLI
property ISIAPIPhase^ Phase {
   ISIAPIPhase^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Running Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Running Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Running As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Running = value

value = instance.Running
C#
bool Running {get; set;}
Managed Extensions for C++
__property bool get_Running();
__property void set_Running(
   bool value
);
C++/CLI
property bool Running {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Terminates Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Terminates Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Terminates As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Terminates = value

value = instance.Terminates
C#
bool Terminates {get; set;}
Managed Extensions for C++
__property bool get_Terminates();
__property void set_Terminates(
   bool value
);
C++/CLI
property bool Terminates {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Undetected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicle Interface : Undetected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Undetected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicle
Dim value As Boolean

instance.Undetected = value

value = instance.Undetected
C#
bool Undetected {get; set;}
Managed Extensions for C++
__property bool get_Undetected();
__property void set_Undetected(
   bool value
);
C++/CLI
property bool Undetected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicle Interface
ISIAPIPhasemovement_vehicle Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicles Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicles Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhasemovement_vehicles
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicles
C#
public interface ISIAPIPhasemovement_vehicles
Managed Extensions for C++
public __gc __interface ISIAPIPhasemovement_vehicles
C++/CLI
public interface class ISIAPIPhasemovement_vehicles

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicles Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicles Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicles Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhasemovement_vehicles.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Phase's Vehicle Movement.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhasemovementVehicleExists | Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicles Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicles Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_vehicles members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | PhasemovementVehicleExists | Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.
Top

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhasemovementVehicleExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicles Interface : PhasemovementVehicleExists Method

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a value indicating whether a Phase's Vehicle Movement data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function PhasemovementVehicleExists( _
   ByVal origin As Integer, _
   ByVal destination As Integer, _
   ByVal mcClass As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicles
Dim origin As Integer
Dim destination As Integer
Dim mcClass As Integer
Dim value As Boolean

value = instance.PhasemovementVehicleExists(origin, destination, mcClass)
C#
bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)
Managed Extensions for C++
bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)
C++/CLI
bool PhasemovementVehicleExists(
   int origin,
   int destination,
   int mcClass
)

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
ISIAPIPhasemovement_vehicles Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhasemovement_vehicles Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhasemovement_vehicles Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhasemovement_vehicles members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get a Phase's Vehicle Movement.
Top

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicles Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicles
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
ISIAPIPhasemovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhasemovement_vehicles Interface : Item Property

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Glossary Item Box

Get a Phase's Vehicle Movement.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal origin As Integer, _
   ByVal destination As Integer, _
   ByVal mcClass As Integer _
) As ISIAPIPhasemovement_vehicle
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhasemovement_vehicles
Dim origin As Integer
Dim destination As Integer
Dim mcClass As Integer
Dim value As ISIAPIPhasemovement_vehicle

value = instance.Item(origin, destination, mcClass)
C#
ISIAPIPhasemovement_vehicle this[
   int origin,
   int destination,
   int mcClass
]; {get;}
Managed Extensions for C++
__property ISIAPIPhasemovement_vehicle* get_Item   int origin,
   int destination,
   int mcClass
;
C++/CLI
property ISIAPIPhasemovement_vehicle^ default [int,int,int] {
   ISIAPIPhasemovement_vehicle^ get(int origin, int destination, int mcClass);
}

Parameters

origin

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

destination

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West

mcClass

Type: System.Int32;

1 = Light Vehicles,
2 = Heavy Vehicles,
3 = Buses,
4 = Bicycles,
5 = Large Trucks,
6 = Trams,
7 = User Class 1,
8 = User Class 2.

Property Value

Return a Phase's Vehicle Movement if its data exists in the data structure; otherwise, null/Nothing.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhasemovement_vehicles Interface
ISIAPIPhasemovement_vehicles Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhases Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhases Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
C#
public interface ISIAPIPhases
Managed Extensions for C++
public __gc __interface ISIAPIPhases
C++/CLI
public interface class ISIAPIPhases

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhases Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhases Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIPhases.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetPhaseByID |
Method | PhaseExists |
Top

See Also

Reference

ISIAPIPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhases Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhases members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetPhaseByID |
Method | PhaseExists |
Top

See Also

Reference

ISIAPIPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetPhaseByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface : GetPhaseByID Method

phase_id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function GetPhaseByID( _
   ByVal phase_id As Integer _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
Dim phase_id As Integer
Dim value As ISIAPIPhase

value = instance.GetPhaseByID(phase_id)
C#
ISIAPIPhase GetPhaseByID(
   int phase_id
)
Managed Extensions for C++
ISIAPIPhase* GetPhaseByID(
   int phase_id
)
C++/CLI
ISIAPIPhase^ GetPhaseByID(
   int phase_id
)

Parameters

phase_id

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
PhaseExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface : PhaseExists Method

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function PhaseExists( _
   ByVal phasename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
Dim phasename As String
Dim value As Boolean

value = instance.PhaseExists(phasename)
C#
bool PhaseExists(
   string phasename
)
Managed Extensions for C++
bool PhaseExists(
   string* phasename
)
C++/CLI
bool PhaseExists(
   String^ phasename
)

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIPhases Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIPhases members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIPhases Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface > Item Property : Item(String) Property

phasename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal phasename As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
Dim phasename As String
Dim value As ISIAPIPhase

value = instance.Item(phasename)
C#
ISIAPIPhase Item(
   string phasename
) {get;}
Managed Extensions for C++
__property ISIAPIPhase* get_Item(
   string* phasename
);
C++/CLI
property ISIAPIPhase^ Item {
   ISIAPIPhase^ get(String^ phasename);
}

Parameters

phasename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIPhases Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIPhases
Dim index As Integer
Dim value As ISIAPIPhase

value = instance.Item(index)
C#
ISIAPIPhase Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIPhase* get_Item(
   int index
);
C++/CLI
property ISIAPIPhase^ Item {
   ISIAPIPhase^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIPhases Interface
ISIAPIPhases Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIProject Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIProject Interface

Glossary Item Box

SIDRA INTERSECTION Project wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
C#
public interface ISIAPIProject
Managed Extensions for C++
public __gc __interface ISIAPIProject
C++/CLI
public interface class ISIAPIProject

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIProject Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIProject Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIProject.

Public Properties

 | Name | Description
Property | LastErrorMessage |
Property | Name | Project name
Property | Networks | Collection of Networks in the current Project
Property | Sites | Collection of Sites in the current Project
Top

Public Methods

 | Name | Description
Method | AddNetwork | Overloaded. Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
Method | AddSite | Overloaded. Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
Method | AddSiteWithGeometry | Overloaded. Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
Method | CloneNetwork | Clone a Network.
Method | CloneNetworkWithSites | Clone a Network with its Sites.
Method | CloneSite | Clone a Site.
Method | ImportNetworksFromProject | Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.
Method | ImportSitesFromProject | Import Site(s) from another Project file into this Project file.
Method | MoveNetworkTo | Move a Network to a new position.
Method | MoveSiteTo | Move a Site to a new position.
Method | RemoveNetwork | Remove a Network from the Project.
Method | RemoveSite | Remove a Site from the Project.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPIProject Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIProject Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIProject Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIProject members.

Public Methods

 | Name | Description
Method | AddNetwork | Overloaded. Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
Method | AddSite | Overloaded. Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
Method | AddSiteWithGeometry | Overloaded. Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
Method | CloneNetwork | Clone a Network.
Method | CloneNetworkWithSites | Clone a Network with its Sites.
Method | CloneSite | Clone a Site.
Method | ImportNetworksFromProject | Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.
Method | ImportSitesFromProject | Import Site(s) from another Project file into this Project file.
Method | MoveNetworkTo | Move a Network to a new position.
Method | MoveSiteTo | Move a Site to a new position.
Method | RemoveNetwork | Remove a Network from the Project.
Method | RemoveSite | Remove a Site from the Project.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPIProject Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : AddNetwork Method

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.

Overload List

Overload | Description
AddNetwork(Int32) | Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.
AddNetwork(String) | Add a new Network into the Project. The new Network does not include any Sites. It is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork(Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddNetwork Method : AddNetwork(Int32) Method

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Network.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Overloads Function AddNetwork( _
   ByVal softwareSetup As Integer _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim softwareSetup As Integer
Dim value As ISIAPINetwork

value = instance.AddNetwork(softwareSetup)
C#
ISIAPINetwork AddNetwork(
   int softwareSetup
)
Managed Extensions for C++
ISIAPINetwork* AddNetwork(
   int softwareSetup
)
C++/CLI
ISIAPINetwork^ AddNetwork(
   int softwareSetup
)

Parameters

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Network.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Return Value

The new added Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddNetwork(String) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddNetwork Method : AddNetwork(String) Method

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Glossary Item Box

Add a new Network into the Project. The new Network does not include any Sites. It is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Overloads Function AddNetwork( _
   ByVal softwareSetupSignature As String _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim softwareSetupSignature As String
Dim value As ISIAPINetwork

value = instance.AddNetwork(softwareSetupSignature)
C#
ISIAPINetwork AddNetwork(
   string softwareSetupSignature
)
Managed Extensions for C++
ISIAPINetwork* AddNetwork(
   string* softwareSetupSignature
)
C++/CLI
ISIAPINetwork^ AddNetwork(
   String^ softwareSetupSignature
)

Parameters

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Return Value

The new added Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : AddSite Method

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a Standard Software Setup.

Overload List

Overload | Description
AddSite(Int32,Int32) | Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a Standard Software Setup.
AddSite(Int32,String) | Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data. The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite(Int32,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddSite Method : AddSite(Int32,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Overloads Function AddSite( _
   ByVal siteType As Integer, _
   ByVal softwareSetup As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim siteType As Integer
Dim softwareSetup As Integer
Dim value As ISIAPISite

value = instance.AddSite(siteType, softwareSetup)
C#
ISIAPISite AddSite(
   int siteType,
   int softwareSetup
)
Managed Extensions for C++
ISIAPISite* AddSite(
   int siteType,
   int softwareSetup
)
C++/CLI
ISIAPISite^ AddSite(
   int siteType,
   int softwareSetup
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

Return Value

The new added Site.

Remarks

"Single Point Interchange" or "Pedestrian Crossing" Site cannot be created by this method. Use the method AddSiteWithGeometry() to add these Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSite(Int32,String) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddSite Method : AddSite(Int32,String) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically without the Geometry data ( e.g. Legs and Lanes) or Phasing and Timing data.
The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Overloads Function AddSite( _
   ByVal siteType As Integer, _
   ByVal softwareSetupSignature As String _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim siteType As Integer
Dim softwareSetupSignature As String
Dim value As ISIAPISite

value = instance.AddSite(siteType, softwareSetupSignature)
C#
ISIAPISite AddSite(
   int siteType,
   string softwareSetupSignature
)
Managed Extensions for C++
ISIAPISite* AddSite(
   int siteType,
   string* softwareSetupSignature
)
C++/CLI
ISIAPISite^ AddSite(
   int siteType,
   String^ softwareSetupSignature
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

Return Value

The new added Site.

Remarks

"Single Point Interchange" or "Pedestrian Crossing" Site cannot be created by this method. Use the method AddSiteWithGeometry() to add these Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : AddSiteWithGeometry Method

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a Standard Software Setup.

Overload List

Overload | Description
AddSiteWithGeometry(Int32,Int32,Int32) | Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a Standard Software Setup.
AddSiteWithGeometry(Int32,String,Int32) | Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added. The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry(Int32,Int32,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddSiteWithGeometry Method : AddSiteWithGeometry(Int32,Int32,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a Standard Software Setup.

Syntax

Visual Basic (Declaration)
Overloads Function AddSiteWithGeometry( _
   ByVal siteType As Integer, _
   ByVal softwareSetup As Integer, _
   ByVal majorRoadOrientation As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim siteType As Integer
Dim softwareSetup As Integer
Dim majorRoadOrientation As Integer
Dim value As ISIAPISite

value = instance.AddSiteWithGeometry(siteType, softwareSetup, majorRoadOrientation)
C#
ISIAPISite AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)
Managed Extensions for C++
ISIAPISite* AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)
C++/CLI
ISIAPISite^ AddSiteWithGeometry(
   int siteType,
   int softwareSetup,
   int majorRoadOrientation
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetup

Type: System.Int32;
Standard Software Setup that is used to create the Site.
1 = Standard Left,
2 = New Zealand,
3 = New South Wales,
4 = Standard Right,
5 = US HCM (Metric),
6 = US HCM (Customary).

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Return Value

The new added Site.

Remarks

If the default Legs do not match the actual Geometry Layout, they can be changed by rotating the Site, removing Leg(s) or adding Leg(s) to the Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSiteWithGeometry(Int32,String,Int32) Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface > AddSiteWithGeometry Method : AddSiteWithGeometry(Int32,String,Int32) Method

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Glossary Item Box

Add a new Site into the Project. The Site is created automatically with the default Geometry data, e.g. Legs and Lanes. If it is a Signalised Site, the default set of Sequences and Phases are added.
The Site is created by using a User Software Setup or a Standard Software Setup. The Software Setup is identified by the string parameter softwareSetupSignature.

Syntax

Visual Basic (Declaration)
Overloads Function AddSiteWithGeometry( _
   ByVal siteType As Integer, _
   ByVal softwareSetupSignature As String, _
   ByVal majorRoadOrientation As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim siteType As Integer
Dim softwareSetupSignature As String
Dim majorRoadOrientation As Integer
Dim value As ISIAPISite

value = instance.AddSiteWithGeometry(siteType, softwareSetupSignature, majorRoadOrientation)
C#
ISIAPISite AddSiteWithGeometry(
   int siteType,
   string softwareSetupSignature,
   int majorRoadOrientation
)
Managed Extensions for C++
ISIAPISite* AddSiteWithGeometry(
   int siteType,
   string* softwareSetupSignature,
   int majorRoadOrientation
)
C++/CLI
ISIAPISite^ AddSiteWithGeometry(
   int siteType,
   String^ softwareSetupSignature,
   int majorRoadOrientation
)

Parameters

siteType

Type: System.Int32;
Site Intersection Type:
0 = At-Grade Intersection,
1 = Roundabout (Unsignalised),
2 = Giveway / Yield (Two-Way),
3 = Stop (Two-Way),
4 = Stop (All-Way),
5 = Single Point Interchange,
6 = Pedestrian Crossing,
7 = Roundabout (Metering Signals).

softwareSetupSignature

The signature string of a User Software Setup or a Standard Software Setup.

majorRoadOrientation

Type: System.Int32;
Major Road Orientation, for Giveway / Yield (Two-Way) or Stop (Two-Way) Site only. This parameter is ignored on the other types of Sites.
0 = Major Road on North and South,
1 = Major Road on NorthWest and SouthEast,
2 = Major Road on East and West,
3 = Major Road on NorthEast and SouthWest.

Return Value

The new added Site.

Remarks

If the default Legs do not match the actual Geometry Layout, they can be changed by rotating the Site, removing Leg(s) or adding Leg(s) to the Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : CloneNetwork Method

network
The Network to be cloned.

Glossary Item Box

Clone a Network.

Syntax

Visual Basic (Declaration)
Function CloneNetwork( _
   ByVal network As ISIAPINetwork _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim network As ISIAPINetwork
Dim value As ISIAPINetwork

value = instance.CloneNetwork(network)
C#
ISIAPINetwork CloneNetwork(
   ISIAPINetwork network
)
Managed Extensions for C++
ISIAPINetwork* CloneNetwork(
   ISIAPINetwork* network
)
C++/CLI
ISIAPINetwork^ CloneNetwork(
   ISIAPINetwork^ network
)

Parameters

network
The Network to be cloned.

Return Value

The new cloned Network.

Remarks

This funciton will create a new Network with the same Sites as those in the original Network, i.e. the Sites will not be cloned.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneNetworkWithSites Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : CloneNetworkWithSites Method

network
The Network to be cloned.

Glossary Item Box

Clone a Network with its Sites.

Syntax

Visual Basic (Declaration)
Function CloneNetworkWithSites( _
   ByVal network As ISIAPINetwork _
) As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim network As ISIAPINetwork
Dim value As ISIAPINetwork

value = instance.CloneNetworkWithSites(network)
C#
ISIAPINetwork CloneNetworkWithSites(
   ISIAPINetwork network
)
Managed Extensions for C++
ISIAPINetwork* CloneNetworkWithSites(
   ISIAPINetwork* network
)
C++/CLI
ISIAPINetwork^ CloneNetworkWithSites(
   ISIAPINetwork^ network
)

Parameters

network
The Network to be cloned.

Return Value

The new cloned Network.

Remarks

This function will clone the Network and its Sites as well, i.e. there will be new cloned Sites in the new cloned Network.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : CloneSite Method

site
The Site to be cloned.

Glossary Item Box

Clone a Site.

Syntax

Visual Basic (Declaration)
Function CloneSite( _
   ByVal site As ISIAPISite _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim site As ISIAPISite
Dim value As ISIAPISite

value = instance.CloneSite(site)
C#
ISIAPISite CloneSite(
   ISIAPISite site
)
Managed Extensions for C++
ISIAPISite* CloneSite(
   ISIAPISite* site
)
C++/CLI
ISIAPISite^ CloneSite(
   ISIAPISite^ site
)

Parameters

site
The Site to be cloned.

Return Value

The new cloned Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ImportNetworksFromProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : ImportNetworksFromProject Method

projectFilePath
The file path of the other Project file.
networkNames

The name(s) of the Network(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Network 1"
  • "Network 1;Network 2"
  • "Network 1;Network 2;Network;; Test"

Glossary Item Box

Import Network(s) from another Project file into this Project file. This function will import the Sites in the Network(s) too.

Syntax

Visual Basic (Declaration)
Function ImportNetworksFromProject( _
   ByVal projectFilePath As String, _
   ByVal networkNames As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim projectFilePath As String
Dim networkNames As String
Dim value As Integer

value = instance.ImportNetworksFromProject(projectFilePath, networkNames)
C#
int ImportNetworksFromProject(
   string projectFilePath,
   string networkNames
)
Managed Extensions for C++
int ImportNetworksFromProject(
   string* projectFilePath,
   string* networkNames
)
C++/CLI
int ImportNetworksFromProject(
   String^ projectFilePath,
   String^ networkNames
)

Parameters

projectFilePath
The file path of the other Project file.
networkNames

The name(s) of the Network(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Network 1"
  • "Network 1;Network 2"
  • "Network 1;Network 2;Network;; Test"

Return Value

The number of successfully imported Networks

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ImportSitesFromProject Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : ImportSitesFromProject Method

projectFilePath
The file path of the other Project file.
siteNames

The name(s) of the Site(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Site 1"
  • "Site 1;Site 2"
  • "Site 1;Site 2;Site;; Test"

Glossary Item Box

Import Site(s) from another Project file into this Project file.

Syntax

Visual Basic (Declaration)
Function ImportSitesFromProject( _
   ByVal projectFilePath As String, _
   ByVal siteNames As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim projectFilePath As String
Dim siteNames As String
Dim value As Integer

value = instance.ImportSitesFromProject(projectFilePath, siteNames)
C#
int ImportSitesFromProject(
   string projectFilePath,
   string siteNames
)
Managed Extensions for C++
int ImportSitesFromProject(
   string* projectFilePath,
   string* siteNames
)
C++/CLI
int ImportSitesFromProject(
   String^ projectFilePath,
   String^ siteNames
)

Parameters

projectFilePath
The file path of the other Project file.
siteNames

The name(s) of the Site(s) to import.

Use semicolon ";" to separate the names. If a name already has ";", replace each ";" with ";;". For examples:

  • "Site 1"
  • "Site 1;Site 2"
  • "Site 1;Site 2;Site;; Test"

Return Value

The number of successfully imported Sites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveNetworkTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : MoveNetworkTo Method

network
The Network to move.
newPosition
The zero-based position that the Network should be moved to.

Glossary Item Box

Move a Network to a new position.

Syntax

Visual Basic (Declaration)
Function MoveNetworkTo( _
   ByVal network As ISIAPINetwork, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim network As ISIAPINetwork
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveNetworkTo(network, newPosition)
C#
bool MoveNetworkTo(
   ISIAPINetwork network,
   int newPosition
)
Managed Extensions for C++
bool MoveNetworkTo(
   ISIAPINetwork* network,
   int newPosition
)
C++/CLI
bool MoveNetworkTo(
   ISIAPINetwork^ network,
   int newPosition
)

Parameters

network
The Network to move.
newPosition
The zero-based position that the Network should be moved to.

Return Value

true if the Network is successfully moved; otherwise, false. This method also returns false if the Network was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveSiteTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : MoveSiteTo Method

site
The Site to move.
newPosition
The zero-based position that the Site should be moved to.

Glossary Item Box

Move a Site to a new position.

Syntax

Visual Basic (Declaration)
Function MoveSiteTo( _
   ByVal site As ISIAPISite, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim site As ISIAPISite
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveSiteTo(site, newPosition)
C#
bool MoveSiteTo(
   ISIAPISite site,
   int newPosition
)
Managed Extensions for C++
bool MoveSiteTo(
   ISIAPISite* site,
   int newPosition
)
C++/CLI
bool MoveSiteTo(
   ISIAPISite^ site,
   int newPosition
)

Parameters

site
The Site to move.
newPosition
The zero-based position that the Site should be moved to.

Return Value

true if the Site is successfully moved; otherwise, false. This method also returns false if the Site was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveNetwork Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : RemoveNetwork Method

network
The Network to remove.

Glossary Item Box

Remove a Network from the Project.

Syntax

Visual Basic (Declaration)
Function RemoveNetwork( _
   ByVal network As ISIAPINetwork _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim network As ISIAPINetwork
Dim value As Boolean

value = instance.RemoveNetwork(network)
C#
bool RemoveNetwork(
   ISIAPINetwork network
)
Managed Extensions for C++
bool RemoveNetwork(
   ISIAPINetwork* network
)
C++/CLI
bool RemoveNetwork(
   ISIAPINetwork^ network
)

Parameters

network
The Network to remove.

Return Value

true if the Network is successfully removed; otherwise, false. This method also returns false if the Network was not found in this Project.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : RemoveSite Method

site
The Site to remove.

Glossary Item Box

Remove a Site from the Project.

Syntax

Visual Basic (Declaration)
Function RemoveSite( _
   ByVal site As ISIAPISite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim site As ISIAPISite
Dim value As Boolean

value = instance.RemoveSite(site)
C#
bool RemoveSite(
   ISIAPISite site
)
Managed Extensions for C++
bool RemoveSite(
   ISIAPISite* site
)
C++/CLI
bool RemoveSite(
   ISIAPISite^ site
)

Parameters

site
The Site to remove.

Return Value

true if the Site is successfully removed; otherwise, false. This method also returns false if the Site was not found in the Project.

Remarks

The Site cannot be used in any Networks.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
bool UpdateModifiedInfo()
Managed Extensions for C++
bool UpdateModifiedInfo();
C++/CLI
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIProject Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIProject Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIProject members.

Public Properties

 | Name | Description
Property | LastErrorMessage |
Property | Name | Project name
Property | Networks | Collection of Networks in the current Project
Property | Sites | Collection of Sites in the current Project
Top

See Also

Reference

ISIAPIProject Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : Name Property

Glossary Item Box

Project name

Syntax

Visual Basic (Declaration)
ReadOnly Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim value As String

value = instance.Name
C#
string Name {get;}
Managed Extensions for C++
__property string* get_Name();
C++/CLI
property String^ Name {
   String^ get();
}

Property Value

Type: System.String

Project name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Networks Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : Networks Property

Glossary Item Box

Collection of Networks in the current Project

Syntax

Visual Basic (Declaration)
ReadOnly Property Networks As ISIAPINetworks
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim value As ISIAPINetworks

value = instance.Networks
C#
ISIAPINetworks Networks {get;}
Managed Extensions for C++
__property ISIAPINetworks* get_Networks();
C++/CLI
property ISIAPINetworks^ Networks {
   ISIAPINetworks^ get();
}

Property Value

Type: ISIAPINetworks

Networks collection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIProject Interface : Sites Property

Glossary Item Box

Collection of Sites in the current Project

Syntax

Visual Basic (Declaration)
ReadOnly Property Sites As ISIAPISites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIProject
Dim value As ISIAPISites

value = instance.Sites
C#
ISIAPISites Sites {get;}
Managed Extensions for C++
__property ISIAPISites* get_Sites();
C++/CLI
property ISIAPISites^ Sites {
   ISIAPISites^ get();
}

Property Value

Type: ISIAPISites

Sites collection

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIProject Interface
ISIAPIProject Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoute Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoute Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
C#
public interface ISIAPIRoute
Managed Extensions for C++
public __gc __interface ISIAPIRoute
C++/CLI
public interface class ISIAPIRoute

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoute Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoute Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIRoute.

Public Properties

 | Name | Description
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | DesiredSpeed |
Property | DesiredSpeedMethod | Desired Speed Method
Property | IsIncludedInOutputNetworkByRoutes |
Property | IsIncludedInProjectSummary |
Property | IsIncludedInSignalOffsetCal |
Property | LastErrorMessage |
Property | LOSMethod | Network Level of Service Method
Property | LowerLimitOfSpeedEfficiency |
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | Name |
Property | Network |
Property | OutputRoute | Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.
Property | Position | The Route Position in the Network's Routes collection. It is a zero-base integer.
Property | RouteID |
Property | RouteNwSites | Collection of Network Sites in the Route
Property | RouteSummaryOption | Route Summary Output Option
Property | SignalOffsetCalMCClass | Movement Class in this Route for the program calculation of Signal Offsets
Property | SignalOffsetMethod | The method of this Route for the program calculation of Signal Offsets
Property | SignalOffsetPriority | The priority of the Route in the Signal Offset Calculation.
Property | Title |
Top

Public Methods

 | Name | Description
Method | AddRouteNwSite | Add a Network Site to the Route to build the path of the Route.
Method | CheckIsValidForSignalOffsetCalc |
Method | Process | Process this Route. The Network needs to be processed before Route statistics can be calculated. If the Network has not been processed, process the Network. The Routes in the Network will be processed as well. If the Route is created after the Network is processed, call this method to process this Route only.
Method | RemoveRouteNwSite | Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPIRoute Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoute Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoute Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRoute members.

Public Methods

 | Name | Description
Method | AddRouteNwSite | Add a Network Site to the Route to build the path of the Route.
Method | CheckIsValidForSignalOffsetCalc |
Method | Process | Process this Route. The Network needs to be processed before Route statistics can be calculated. If the Network has not been processed, process the Network. The Routes in the Network will be processed as well. If the Route is created after the Network is processed, call this method to process this Route only.
Method | RemoveRouteNwSite | Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPIRoute Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddRouteNwSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : AddRouteNwSite Method

networkSite
The Network Site to add into the Route
origin
The origin of the vehicle movement on the Network Site that will be added into the Route
destination
The destination of the vehicle movement on the Network Site that will be added into the Route

Glossary Item Box

Add a Network Site to the Route to build the path of the Route.

Syntax

Visual Basic (Declaration)
Function AddRouteNwSite( _
   ByVal networkSite As ISIAPINetworkSite, _
   ByVal origin As Integer, _
   ByVal destination As Integer _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim networkSite As ISIAPINetworkSite
Dim origin As Integer
Dim destination As Integer
Dim value As ISIAPIRouteNwSite

value = instance.AddRouteNwSite(networkSite, origin, destination)
C#
ISIAPIRouteNwSite AddRouteNwSite(
   ISIAPINetworkSite networkSite,
   int origin,
   int destination
)
Managed Extensions for C++
ISIAPIRouteNwSite* AddRouteNwSite(
   ISIAPINetworkSite* networkSite,
   int origin,
   int destination
)
C++/CLI
ISIAPIRouteNwSite^ AddRouteNwSite(
   ISIAPINetworkSite^ networkSite,
   int origin,
   int destination
)

Parameters

networkSite
The Network Site to add into the Route
origin
The origin of the vehicle movement on the Network Site that will be added into the Route
destination
The destination of the vehicle movement on the Network Site that will be added into the Route

Return Value

A new added Route Network Site

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CheckIsValidForSignalOffsetCalc Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : CheckIsValidForSignalOffsetCalc Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CheckIsValidForSignalOffsetCalc() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

value = instance.CheckIsValidForSignalOffsetCalc()
C#
bool CheckIsValidForSignalOffsetCalc()
Managed Extensions for C++
bool CheckIsValidForSignalOffsetCalc();
C++/CLI
bool CheckIsValidForSignalOffsetCalc();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Process Method

Glossary Item Box

Process this Route. The Network needs to be processed before Route statistics can be calculated. If the Network has not been processed, process the Network. The Routes in the Network will be processed as well. If the Route is created after the Network is processed, call this method to process this Route only.

Syntax

Visual Basic (Declaration)
Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

value = instance.Process()
C#
bool Process()
Managed Extensions for C++
bool Process();
C++/CLI
bool Process();

Return Value

true if this Route is processed successfully.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveRouteNwSite Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : RemoveRouteNwSite Method

routeNwSite
The Network Site to remove.

Glossary Item Box

Remove a Network Site from the Route. The Network Sites that are after this one in the Route will also be removed.

Syntax

Visual Basic (Declaration)
Function RemoveRouteNwSite( _
   ByVal routeNwSite As ISIAPIRouteNwSite _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim routeNwSite As ISIAPIRouteNwSite
Dim value As Boolean

value = instance.RemoveRouteNwSite(routeNwSite)
C#
bool RemoveRouteNwSite(
   ISIAPIRouteNwSite routeNwSite
)
Managed Extensions for C++
bool RemoveRouteNwSite(
   ISIAPIRouteNwSite* routeNwSite
)
C++/CLI
bool RemoveRouteNwSite(
   ISIAPIRouteNwSite^ routeNwSite
)

Parameters

routeNwSite
The Network Site to remove.

Return Value

true if the Network Site is successfully removed; otherwise, false. This method also returns false if the Network Site was not found in this Route.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
bool UpdateModifiedInfo()
Managed Extensions for C++
bool UpdateModifiedInfo();
C++/CLI
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoute Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoute Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRoute members.

Public Properties

 | Name | Description
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | DesiredSpeed |
Property | DesiredSpeedMethod | Desired Speed Method
Property | IsIncludedInOutputNetworkByRoutes |
Property | IsIncludedInProjectSummary |
Property | IsIncludedInSignalOffsetCal |
Property | LastErrorMessage |
Property | LOSMethod | Network Level of Service Method
Property | LowerLimitOfSpeedEfficiency |
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | Name |
Property | Network |
Property | OutputRoute | Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.
Property | Position | The Route Position in the Network's Routes collection. It is a zero-base integer.
Property | RouteID |
Property | RouteNwSites | Collection of Network Sites in the Route
Property | RouteSummaryOption | Route Summary Output Option
Property | SignalOffsetCalMCClass | Movement Class in this Route for the program calculation of Signal Offsets
Property | SignalOffsetMethod | The method of this Route for the program calculation of Signal Offsets
Property | SignalOffsetPriority | The priority of the Route in the Signal Offset Calculation.
Property | Title |
Top

See Also

Reference

ISIAPIRoute Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Created_by
C#
string Created_by {get;}
Managed Extensions for C++
__property string* get_Created_by();
C++/CLI
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Created_by_company
C#
string Created_by_company {get;}
Managed Extensions for C++
__property string* get_Created_by_company();
C++/CLI
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Date

value = instance.Created_date
C#
DateTime Created_date {get;}
Managed Extensions for C++
__property DateTime get_Created_date();
C++/CLI
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Created_version
C#
string Created_version {get;}
Managed Extensions for C++
__property string* get_Created_version();
C++/CLI
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : DesiredSpeed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property DesiredSpeed As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Single

instance.DesiredSpeed = value

value = instance.DesiredSpeed
C#
float DesiredSpeed {get; set;}
Managed Extensions for C++
__property float get_DesiredSpeed();
__property void set_DesiredSpeed(
   float value
);
C++/CLI
property float DesiredSpeed {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DesiredSpeedMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : DesiredSpeedMethod Property

Glossary Item Box

Desired Speed Method

Syntax

Visual Basic (Declaration)
Property DesiredSpeedMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.DesiredSpeedMethod = value

value = instance.DesiredSpeedMethod
C#
int DesiredSpeedMethod {get; set;}
Managed Extensions for C++
__property int get_DesiredSpeedMethod();
__property void set_DesiredSpeedMethod(
   int value
);
C++/CLI
property int DesiredSpeedMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = User Input,
1 = Program.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInOutputNetworkByRoutes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : IsIncludedInOutputNetworkByRoutes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInOutputNetworkByRoutes As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

instance.IsIncludedInOutputNetworkByRoutes = value

value = instance.IsIncludedInOutputNetworkByRoutes
C#
bool IsIncludedInOutputNetworkByRoutes {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInOutputNetworkByRoutes();
__property void set_IsIncludedInOutputNetworkByRoutes(
   bool value
);
C++/CLI
property bool IsIncludedInOutputNetworkByRoutes {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInProjectSummary();
__property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInSignalOffsetCal Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : IsIncludedInSignalOffsetCal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInSignalOffsetCal As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Boolean

instance.IsIncludedInSignalOffsetCal = value

value = instance.IsIncludedInSignalOffsetCal
C#
bool IsIncludedInSignalOffsetCal {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInSignalOffsetCal();
__property void set_IsIncludedInSignalOffsetCal(
   bool value
);
C++/CLI
property bool IsIncludedInSignalOffsetCal {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LOSMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : LOSMethod Property

Glossary Item Box

Network Level of Service Method

Syntax

Visual Basic (Declaration)
Property LOSMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.LOSMethod = value

value = instance.LOSMethod
C#
int LOSMethod {get; set;}
Managed Extensions for C++
__property int get_LOSMethod();
__property void set_LOSMethod(
   int value
);
C++/CLI
property int LOSMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = SIDRA Speed Efficiency,
2 = HCM 2010 Speed Efficiency,
3 = HCM 6 Speed Efficiency.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LowerLimitOfSpeedEfficiency Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : LowerLimitOfSpeedEfficiency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property LowerLimitOfSpeedEfficiency As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Single

instance.LowerLimitOfSpeedEfficiency = value

value = instance.LowerLimitOfSpeedEfficiency
C#
float LowerLimitOfSpeedEfficiency {get; set;}
Managed Extensions for C++
__property float get_LowerLimitOfSpeedEfficiency();
__property void set_LowerLimitOfSpeedEfficiency(
   float value
);
C++/CLI
property float LowerLimitOfSpeedEfficiency {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Modified_by
C#
string Modified_by {get;}
Managed Extensions for C++
__property string* get_Modified_by();
C++/CLI
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Modified_by_company
C#
string Modified_by_company {get;}
Managed Extensions for C++
__property string* get_Modified_by_company();
C++/CLI
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Date

value = instance.Modified_date
C#
DateTime Modified_date {get;}
Managed Extensions for C++
__property DateTime get_Modified_date();
C++/CLI
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

value = instance.Modified_version
C#
string Modified_version {get;}
Managed Extensions for C++
__property string* get_Modified_version();
C++/CLI
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Network Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Network Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Network As ISIAPINetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As ISIAPINetwork

value = instance.Network
C#
ISIAPINetwork Network {get;}
Managed Extensions for C++
__property ISIAPINetwork* get_Network();
C++/CLI
property ISIAPINetwork^ Network {
   ISIAPINetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
OutputRoute Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : OutputRoute Property

Glossary Item Box

Route Output Data, this data structure is same as the OutputNetwork but it is a different set of output data.

Syntax

Visual Basic (Declaration)
ReadOnly Property OutputRoute As ISIAPIOutputNetwork
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As ISIAPIOutputNetwork

value = instance.OutputRoute
C#
ISIAPIOutputNetwork OutputRoute {get;}
Managed Extensions for C++
__property ISIAPIOutputNetwork* get_OutputRoute();
C++/CLI
property ISIAPIOutputNetwork^ OutputRoute {
   ISIAPIOutputNetwork^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Position Property

Glossary Item Box

The Route Position in the Network's Routes collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteID Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : RouteID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property RouteID As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

instance.RouteID = value

value = instance.RouteID
C#
string RouteID {get; set;}
Managed Extensions for C++
__property string* get_RouteID();
__property void set_RouteID(
   string* value
);
C++/CLI
property String^ RouteID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteNwSites Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : RouteNwSites Property

Glossary Item Box

Collection of Network Sites in the Route

Syntax

Visual Basic (Declaration)
ReadOnly Property RouteNwSites As ISIAPIRouteNwSites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As ISIAPIRouteNwSites

value = instance.RouteNwSites
C#
ISIAPIRouteNwSites RouteNwSites {get;}
Managed Extensions for C++
__property ISIAPIRouteNwSites* get_RouteNwSites();
C++/CLI
property ISIAPIRouteNwSites^ RouteNwSites {
   ISIAPIRouteNwSites^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteSummaryOption Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : RouteSummaryOption Property

Glossary Item Box

Route Summary Output Option

Syntax

Visual Basic (Declaration)
Property RouteSummaryOption As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.RouteSummaryOption = value

value = instance.RouteSummaryOption
C#
int RouteSummaryOption {get; set;}
Managed Extensions for C++
__property int get_RouteSummaryOption();
__property void set_RouteSummaryOption(
   int value
);
C++/CLI
property int RouteSummaryOption {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Movements,
2 = Approaches,
3 = Sites.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetCalMCClass Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : SignalOffsetCalMCClass Property

Glossary Item Box

Movement Class in this Route for the program calculation of Signal Offsets

Syntax

Visual Basic (Declaration)
Property SignalOffsetCalMCClass As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.SignalOffsetCalMCClass = value

value = instance.SignalOffsetCalMCClass
C#
int SignalOffsetCalMCClass {get; set;}
Managed Extensions for C++
__property int get_SignalOffsetCalMCClass();
__property void set_SignalOffsetCalMCClass(
   int value
);
C++/CLI
property int SignalOffsetCalMCClass {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetMethod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : SignalOffsetMethod Property

Glossary Item Box

The method of this Route for the program calculation of Signal Offsets

Syntax

Visual Basic (Declaration)
Property SignalOffsetMethod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.SignalOffsetMethod = value

value = instance.SignalOffsetMethod
C#
int SignalOffsetMethod {get; set;}
Managed Extensions for C++
__property int get_SignalOffsetMethod();
__property void set_SignalOffsetMethod(
   int value
);
C++/CLI
property int SignalOffsetMethod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Start of Green (Leading),
2 = End of Green (Trailing),
3 = Middle of Green,
4 = Simultaneous.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SignalOffsetPriority Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : SignalOffsetPriority Property

Glossary Item Box

The priority of the Route in the Signal Offset Calculation.

Syntax

Visual Basic (Declaration)
Property SignalOffsetPriority As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As Integer

instance.SignalOffsetPriority = value

value = instance.SignalOffsetPriority
C#
int SignalOffsetPriority {get; set;}
Managed Extensions for C++
__property int get_SignalOffsetPriority();
__property void set_SignalOffsetPriority(
   int value
);
C++/CLI
property int SignalOffsetPriority {
   int get();
   void set (    int value);
}

Remarks

When Network Signal Offset Option is set to Program, i.e. SIAPINetwork.SignalOffsetOption = 0, the program will use selected Signal valid Routes to calculate the Signals Offsets. Call SIAPIRoute.CheckIsValidForSignalOffsetCalc() method to determine if the Route is valid for Signal Offset Calculation. This method will initialise the SignalOffsetPriority value. Set SIAPIRoute.IsIncludedInSignalOffsetCal = true to include the Route into the program calculation of Signal Offsets.

If the Route is not valid for the program calculation of Signals Offsets, its SignalOffsetPriority will be larger than 1000 and cannot be changed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoute Interface : Title Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoute
Dim value As String

instance.Title = value

value = instance.Title
C#
string Title {get; set;}
Managed Extensions for C++
__property string* get_Title();
__property void set_Title(
   string* value
);
C++/CLI
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoute Interface
ISIAPIRoute Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSite Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSite Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
C#
public interface ISIAPIRouteNwSite
Managed Extensions for C++
public __gc __interface ISIAPIRouteNwSite
C++/CLI
public interface class ISIAPIRouteNwSite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSite Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSite Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIRouteNwSite.

Public Properties

 | Name | Description
Property | Destination |
Property | NetworkSite |
Property | Origin |
Property | Position | The RouteNwSite position in the Route. It is a zero-base integer.
Property | Route |
Property | SiteName |
Top

See Also

Reference

ISIAPIRouteNwSite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSite Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSite Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRouteNwSite members.

Public Properties

 | Name | Description
Property | Destination |
Property | NetworkSite |
Property | Origin |
Property | Position | The RouteNwSite position in the Route. It is a zero-base integer.
Property | Route |
Property | SiteName |
Top

See Also

Reference

ISIAPIRouteNwSite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Destination Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : Destination Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Destination As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As Integer

value = instance.Destination
C#
int Destination {get;}
Managed Extensions for C++
__property int get_Destination();
C++/CLI
property int Destination {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
NetworkSite Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : NetworkSite Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property NetworkSite As ISIAPINetworkSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As ISIAPINetworkSite

value = instance.NetworkSite
C#
ISIAPINetworkSite NetworkSite {get;}
Managed Extensions for C++
__property ISIAPINetworkSite* get_NetworkSite();
C++/CLI
property ISIAPINetworkSite^ NetworkSite {
   ISIAPINetworkSite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Origin Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : Origin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Origin As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As Integer

value = instance.Origin
C#
int Origin {get;}
Managed Extensions for C++
__property int get_Origin();
C++/CLI
property int Origin {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : Position Property

Glossary Item Box

The RouteNwSite position in the Route. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Route Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : Route Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Route As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As ISIAPIRoute

value = instance.Route
C#
ISIAPIRoute Route {get;}
Managed Extensions for C++
__property ISIAPIRoute* get_Route();
C++/CLI
property ISIAPIRoute^ Route {
   ISIAPIRoute^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSite Interface : SiteName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SiteName As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSite
Dim value As String

value = instance.SiteName
C#
string SiteName {get;}
Managed Extensions for C++
__property string* get_SiteName();
C++/CLI
property String^ SiteName {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSite Interface
ISIAPIRouteNwSite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSites Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSites Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIRouteNwSites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSites
C#
public interface ISIAPIRouteNwSites
Managed Extensions for C++
public __gc __interface ISIAPIRouteNwSites
C++/CLI
public interface class ISIAPIRouteNwSites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSites Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSites Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIRouteNwSites.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | RouteNwSiteExists | Queries whether a particular Route Network Site exists in the collection
Top

See Also

Reference

ISIAPIRouteNwSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSites Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRouteNwSites members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | RouteNwSiteExists | Queries whether a particular Route Network Site exists in the collection
Top

See Also

Reference

ISIAPIRouteNwSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteNwSiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSites Interface : RouteNwSiteExists Method

sitename
Site name to query

Glossary Item Box

Queries whether a particular Route Network Site exists in the collection

Syntax

Visual Basic (Declaration)
Function RouteNwSiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSites
Dim sitename As String
Dim value As Boolean

value = instance.RouteNwSiteExists(sitename)
C#
bool RouteNwSiteExists(
   string sitename
)
Managed Extensions for C++
bool RouteNwSiteExists(
   string* sitename
)
C++/CLI
bool RouteNwSiteExists(
   String^ sitename
)

Parameters

sitename
Site name to query

Return Value

Type: System.Bool

True, if a Route Network Site with the given Site name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Interface
ISIAPIRouteNwSites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRouteNwSites Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRouteNwSites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRouteNwSites members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIRouteNwSites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSites Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSites
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Interface
ISIAPIRouteNwSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSites Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Interface
ISIAPIRouteNwSites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSites Interface > Item Property : Item(String) Property

sitename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSites
Dim sitename As String
Dim value As ISIAPIRouteNwSite

value = instance.Item(sitename)
C#
ISIAPIRouteNwSite Item(
   string sitename
) {get;}
Managed Extensions for C++
__property ISIAPIRouteNwSite* get_Item(
   string* sitename
);
C++/CLI
property ISIAPIRouteNwSite^ Item {
   ISIAPIRouteNwSite^ get(String^ sitename);
}

Parameters

sitename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Interface
ISIAPIRouteNwSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRouteNwSites Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIRouteNwSite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRouteNwSites
Dim index As Integer
Dim value As ISIAPIRouteNwSite

value = instance.Item(index)
C#
ISIAPIRouteNwSite Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIRouteNwSite* get_Item(
   int index
);
C++/CLI
property ISIAPIRouteNwSite^ Item {
   ISIAPIRouteNwSite^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRouteNwSites Interface
ISIAPIRouteNwSites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoutes Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoutes Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPIRoutes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoutes
C#
public interface ISIAPIRoutes
Managed Extensions for C++
public __gc __interface ISIAPIRoutes
C++/CLI
public interface class ISIAPIRoutes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoutes Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoutes Interface

Glossary Item Box

The following tables list the members exposed by ISIAPIRoutes.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | RouteExists | Queries whether a particular Route exists in the collection
Top

See Also

Reference

ISIAPIRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoutes Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoutes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRoutes members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | RouteExists | Queries whether a particular Route exists in the collection
Top

See Also

Reference

ISIAPIRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RouteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoutes Interface : RouteExists Method

routeName
Route name to query

Glossary Item Box

Queries whether a particular Route exists in the collection

Syntax

Visual Basic (Declaration)
Function RouteExists( _
   ByVal routeName As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoutes
Dim routeName As String
Dim value As Boolean

value = instance.RouteExists(routeName)
C#
bool RouteExists(
   string routeName
)
Managed Extensions for C++
bool RouteExists(
   string* routeName
)
C++/CLI
bool RouteExists(
   String^ routeName
)

Parameters

routeName
Route name to query

Return Value

Type: System.Bool

True, if a Route with the given name exists in the collection. False otherwise

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Interface
ISIAPIRoutes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIRoutes Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIRoutes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIRoutes members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Top

See Also

Reference

ISIAPIRoutes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoutes Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoutes
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Interface
ISIAPIRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoutes Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Interface
ISIAPIRoutes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoutes Interface > Item Property : Item(String) Property

routeName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal routeName As String _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoutes
Dim routeName As String
Dim value As ISIAPIRoute

value = instance.Item(routeName)
C#
ISIAPIRoute Item(
   string routeName
) {get;}
Managed Extensions for C++
__property ISIAPIRoute* get_Item(
   string* routeName
);
C++/CLI
property ISIAPIRoute^ Item {
   ISIAPIRoute^ get(String^ routeName);
}

Parameters

routeName

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Interface
ISIAPIRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPIRoutes Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPIRoute
Visual Basic (Usage) Copy Code
Dim instance As ISIAPIRoutes
Dim index As Integer
Dim value As ISIAPIRoute

value = instance.Item(index)
C#
ISIAPIRoute Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPIRoute* get_Item(
   int index
);
C++/CLI
property ISIAPIRoute^ Item {
   ISIAPIRoute^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPIRoutes Interface
ISIAPIRoutes Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISensitivity Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISensitivity Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPISensitivity
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
C#
public interface ISIAPISensitivity
Managed Extensions for C++
public __gc __interface ISIAPISensitivity
C++/CLI
public interface class ISIAPISensitivity

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISensitivity Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISensitivity Interface

Glossary Item Box

The following tables list the members exposed by ISIAPISensitivity.

Public Properties

 | Name | Description
Property | Constant_factor |
Property | Groupno | Sensitivity Parameter Group Number
Property | Increment |
Property | Is_constant_factor_applied |
Property | Lower |
Property | Selected_parameter | Selected Sensitivity Parameter
Property | Upper |
Top

See Also

Reference

ISIAPISensitivity Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISensitivity Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISensitivity Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISensitivity members.

Public Properties

 | Name | Description
Property | Constant_factor |
Property | Groupno | Sensitivity Parameter Group Number
Property | Increment |
Property | Is_constant_factor_applied |
Property | Lower |
Property | Selected_parameter | Selected Sensitivity Parameter
Property | Upper |
Top

See Also

Reference

ISIAPISensitivity Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Constant_factor Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Constant_factor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Constant_factor As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Single

instance.Constant_factor = value

value = instance.Constant_factor
C#
float Constant_factor {get; set;}
Managed Extensions for C++
__property float get_Constant_factor();
__property void set_Constant_factor(
   float value
);
C++/CLI
property float Constant_factor {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Groupno Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Groupno Property

Glossary Item Box

Sensitivity Parameter Group Number

Syntax

Visual Basic (Declaration)
ReadOnly Property Groupno As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Integer

value = instance.Groupno
C#
int Groupno {get;}
Managed Extensions for C++
__property int get_Groupno();
C++/CLI
property int Groupno {
   int get();
}

Property Value

Type: System.Int32;

0 = General Parameter Group,
1 = Roundabout Parameter Group.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Increment As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Single

instance.Increment = value

value = instance.Increment
C#
float Increment {get; set;}
Managed Extensions for C++
__property float get_Increment();
__property void set_Increment(
   float value
);
C++/CLI
property float Increment {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_constant_factor_applied Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Is_constant_factor_applied Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_constant_factor_applied As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Boolean

instance.Is_constant_factor_applied = value

value = instance.Is_constant_factor_applied
C#
bool Is_constant_factor_applied {get; set;}
Managed Extensions for C++
__property bool get_Is_constant_factor_applied();
__property void set_Is_constant_factor_applied(
   bool value
);
C++/CLI
property bool Is_constant_factor_applied {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Lower As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Single

instance.Lower = value

value = instance.Lower
C#
float Lower {get; set;}
Managed Extensions for C++
__property float get_Lower();
__property void set_Lower(
   float value
);
C++/CLI
property float Lower {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Selected_parameter Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Selected_parameter Property

Glossary Item Box

Selected Sensitivity Parameter

Syntax

Visual Basic (Declaration)
Property Selected_parameter As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Integer

instance.Selected_parameter = value

value = instance.Selected_parameter
C#
int Selected_parameter {get; set;}
Managed Extensions for C++
__property int get_Selected_parameter();
__property void set_Selected_parameter(
   int value
);
C++/CLI
property int Selected_parameter {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

1 = Critical Gap Follow-up Headway,
2 = Basic Saturation Flow,
3 = Lane Width,
4 = Lane Utilisation Ratio,
5 = Cruise Speed,
6 = Vehicle Queue Space,
7 = Inscribed Diameter,
8 = Entry Angle,
9 = Entry Radius.

Remarks

Values 1 - 6 are only available in General Parameter Group (Group No. = 0). Values 7 - 9 are only available in Roundabout Parameter Group (Group No. = 1)

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISensitivity Interface : Upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Upper As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISensitivity
Dim value As Single

instance.Upper = value

value = instance.Upper
C#
float Upper {get; set;}
Managed Extensions for C++
__property float get_Upper();
__property void set_Upper(
   float value
);
C++/CLI
property float Upper {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISensitivity Interface
ISIAPISensitivity Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequence Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequence Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
C#
public interface ISIAPISequence
Managed Extensions for C++
public __gc __interface ISIAPISequence
C++/CLI
public interface class ISIAPISequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequence Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequence Interface

Glossary Item Box

The following tables list the members exposed by ISIAPISequence.

Public Properties

 | Name | Description
Property | Actuated_gap_major_mov |
Property | Actuated_gap_minor_mov |
Property | Actuated_max_green_major_mov |
Property | Actuated_max_green_minor_mov |
Property | Cycle_time_option | Cycle Time Option
Property | Eff_det_zone_len_major_mov |
Property | Eff_det_zone_len_minor_mov |
Property | Green_split_priority_option | Green Split Priority
Property | Is_selected |
Property | Is_timing_optimised_for_selected_result |
Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Property | LastErrorMessage |
Property | Name |
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | Phases |
Property | Position | The Sequence Position in the Site's Sequences collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | Sequence_id | The database row unique ID of the Sequence.
Property | Site |
Property | Usergiven_cycle_time |
Property | Variable_phasing_perf_measure |
Top

Public Methods

 | Name | Description
Method | AddPhase | Add a new Phase to the end of this Sequence.
Method | ClonePhase | Clone a Phase.
Method | InsertPhase | Insert a new Phase into this Sequence at the specified position.
Method | MovePhaseTo | Move a Phase to a new position.
Method | RemovePhase | Remove a Phase from this Sequence.
Top

See Also

Reference

ISIAPISequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequence Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequence Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISequence members.

Public Methods

 | Name | Description
Method | AddPhase | Add a new Phase to the end of this Sequence.
Method | ClonePhase | Clone a Phase.
Method | InsertPhase | Insert a new Phase into this Sequence at the specified position.
Method | MovePhaseTo | Move a Phase to a new position.
Method | RemovePhase | Remove a Phase from this Sequence.
Top

See Also

Reference

ISIAPISequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : AddPhase Method

name
The name of the new Phase.

Glossary Item Box

Add a new Phase to the end of this Sequence.

Syntax

Visual Basic (Declaration)
Function AddPhase( _
   ByVal name As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim name As String
Dim value As ISIAPIPhase

value = instance.AddPhase(name)
C#
ISIAPIPhase AddPhase(
   string name
)
Managed Extensions for C++
ISIAPIPhase* AddPhase(
   string* name
)
C++/CLI
ISIAPIPhase^ AddPhase(
   String^ name
)

Parameters

name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ClonePhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : ClonePhase Method

phase
The Phase to clone.

Glossary Item Box

Clone a Phase.

Syntax

Visual Basic (Declaration)
Function ClonePhase( _
   ByVal phase As ISIAPIPhase _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim phase As ISIAPIPhase
Dim value As ISIAPIPhase

value = instance.ClonePhase(phase)
C#
ISIAPIPhase ClonePhase(
   ISIAPIPhase phase
)
Managed Extensions for C++
ISIAPIPhase* ClonePhase(
   ISIAPIPhase* phase
)
C++/CLI
ISIAPIPhase^ ClonePhase(
   ISIAPIPhase^ phase
)

Parameters

phase
The Phase to clone.

Return Value

The new cloned Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
InsertPhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : InsertPhase Method

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Glossary Item Box

Insert a new Phase into this Sequence at the specified position.

Syntax

Visual Basic (Declaration)
Function InsertPhase( _
   ByVal position As Integer, _
   ByVal name As String _
) As ISIAPIPhase
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim position As Integer
Dim name As String
Dim value As ISIAPIPhase

value = instance.InsertPhase(position, name)
C#
ISIAPIPhase InsertPhase(
   int position,
   string name
)
Managed Extensions for C++
ISIAPIPhase* InsertPhase(
   int position,
   string* name
)
C++/CLI
ISIAPIPhase^ InsertPhase(
   int position,
   String^ name
)

Parameters

position
The zero-based position at which the new Phase should be inserted.
name
The name of the new Phase.

Return Value

The new added Phase.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovePhaseTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : MovePhaseTo Method

phase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Glossary Item Box

Move a Phase to a new position.

Syntax

Visual Basic (Declaration)
Function MovePhaseTo( _
   ByVal phase As ISIAPIPhase, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim phase As ISIAPIPhase
Dim newPosition As Integer
Dim value As Boolean

value = instance.MovePhaseTo(phase, newPosition)
C#
bool MovePhaseTo(
   ISIAPIPhase phase,
   int newPosition
)
Managed Extensions for C++
bool MovePhaseTo(
   ISIAPIPhase* phase,
   int newPosition
)
C++/CLI
bool MovePhaseTo(
   ISIAPIPhase^ phase,
   int newPosition
)

Parameters

phase
The Phase to move.
newPosition
The zero-based position that the Phase should be moved to.

Return Value

true if the Phase is successfully moved; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemovePhase Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : RemovePhase Method

phase
The Phase to remove.

Glossary Item Box

Remove a Phase from this Sequence.

Syntax

Visual Basic (Declaration)
Function RemovePhase( _
   ByVal phase As ISIAPIPhase _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim phase As ISIAPIPhase
Dim value As Boolean

value = instance.RemovePhase(phase)
C#
bool RemovePhase(
   ISIAPIPhase phase
)
Managed Extensions for C++
bool RemovePhase(
   ISIAPIPhase* phase
)
C++/CLI
bool RemovePhase(
   ISIAPIPhase^ phase
)

Parameters

phase
The Phase to remove.

Return Value

true if the Phase is successfully removed; otherwise, false. This method also returns false if the Phase was not found in this Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequence Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequence Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISequence members.

Public Properties

 | Name | Description
Property | Actuated_gap_major_mov |
Property | Actuated_gap_minor_mov |
Property | Actuated_max_green_major_mov |
Property | Actuated_max_green_minor_mov |
Property | Cycle_time_option | Cycle Time Option
Property | Eff_det_zone_len_major_mov |
Property | Eff_det_zone_len_minor_mov |
Property | Green_split_priority_option | Green Split Priority
Property | Is_selected |
Property | Is_timing_optimised_for_selected_result |
Property | Lane_blockage_effect_option | Lane Blockage Effect Option: In Network analysis, include Lane Blockage effects in determining Phase Times.
Property | LastErrorMessage |
Property | Name |
Property | Optimum_cycle_time_increment |
Property | Optimum_cycle_time_lower |
Property | Optimum_cycle_time_lower_user |
Property | Optimum_cycle_time_optim_method |
Property | Optimum_cycle_time_perf_measure |
Property | Optimum_cycle_time_upper |
Property | Optimum_max_green_optim_method |
Property | Optimum_max_green_percent_increment |
Property | Optimum_max_green_percent_lower |
Property | Optimum_max_green_percent_upper |
Property | Optimum_max_green_perf_measure |
Property | Phases |
Property | Position | The Sequence Position in the Site's Sequences collection. It is a zero-base integer.
Property | Practical_cycle_rounding |
Property | Practical_max_cycle_time |
Property | Sequence_id | The database row unique ID of the Sequence.
Property | Site |
Property | Usergiven_cycle_time |
Property | Variable_phasing_perf_measure |
Top

See Also

Reference

ISIAPISequence Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Actuated_gap_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_gap_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Actuated_gap_major_mov = value

value = instance.Actuated_gap_major_mov
C#
float Actuated_gap_major_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_gap_major_mov();
__property void set_Actuated_gap_major_mov(
   float value
);
C++/CLI
property float Actuated_gap_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_gap_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Actuated_gap_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_gap_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Actuated_gap_minor_mov = value

value = instance.Actuated_gap_minor_mov
C#
float Actuated_gap_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_gap_minor_mov();
__property void set_Actuated_gap_minor_mov(
   float value
);
C++/CLI
property float Actuated_gap_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Actuated_max_green_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_max_green_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Actuated_max_green_major_mov = value

value = instance.Actuated_max_green_major_mov
C#
float Actuated_max_green_major_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_max_green_major_mov();
__property void set_Actuated_max_green_major_mov(
   float value
);
C++/CLI
property float Actuated_max_green_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Actuated_max_green_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Actuated_max_green_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Actuated_max_green_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Actuated_max_green_minor_mov = value

value = instance.Actuated_max_green_minor_mov
C#
float Actuated_max_green_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Actuated_max_green_minor_mov();
__property void set_Actuated_max_green_minor_mov(
   float value
);
C++/CLI
property float Actuated_max_green_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Cycle_time_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Cycle_time_option Property

Glossary Item Box

Cycle Time Option

Syntax

Visual Basic (Declaration)
Property Cycle_time_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Cycle_time_option = value

value = instance.Cycle_time_option
C#
int Cycle_time_option {get; set;}
Managed Extensions for C++
__property int get_Cycle_time_option();
__property void set_Cycle_time_option(
   int value
);
C++/CLI
property int Cycle_time_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Practical Cycle Time,
1 = Optimum Cycle Time,
2 = User-Given Cycle Time,
3 = User-Given Phase Time,
4 = Optimum Maximum Green Settings.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_major_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Eff_det_zone_len_major_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Eff_det_zone_len_major_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Eff_det_zone_len_major_mov = value

value = instance.Eff_det_zone_len_major_mov
C#
float Eff_det_zone_len_major_mov {get; set;}
Managed Extensions for C++
__property float get_Eff_det_zone_len_major_mov();
__property void set_Eff_det_zone_len_major_mov(
   float value
);
C++/CLI
property float Eff_det_zone_len_major_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Eff_det_zone_len_minor_mov Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Eff_det_zone_len_minor_mov Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Eff_det_zone_len_minor_mov As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Single

instance.Eff_det_zone_len_minor_mov = value

value = instance.Eff_det_zone_len_minor_mov
C#
float Eff_det_zone_len_minor_mov {get; set;}
Managed Extensions for C++
__property float get_Eff_det_zone_len_minor_mov();
__property void set_Eff_det_zone_len_minor_mov(
   float value
);
C++/CLI
property float Eff_det_zone_len_minor_mov {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Green_split_priority_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Green_split_priority_option Property

Glossary Item Box

Green Split Priority

Syntax

Visual Basic (Declaration)
Property Green_split_priority_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Green_split_priority_option = value

value = instance.Green_split_priority_option
C#
int Green_split_priority_option {get; set;}
Managed Extensions for C++
__property int get_Green_split_priority_option();
__property void set_Green_split_priority_option(
   int value
);
C++/CLI
property int Green_split_priority_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = None,
1 = Coordinated Movements,
2 = User-Specified Movements.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_selected Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Is_selected Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_selected As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Boolean

instance.Is_selected = value

value = instance.Is_selected
C#
bool Is_selected {get; set;}
Managed Extensions for C++
__property bool get_Is_selected();
__property void set_Is_selected(
   bool value
);
C++/CLI
property bool Is_selected {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Is_timing_optimised_for_selected_result Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Is_timing_optimised_for_selected_result Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Is_timing_optimised_for_selected_result As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Boolean

instance.Is_timing_optimised_for_selected_result = value

value = instance.Is_timing_optimised_for_selected_result
C#
bool Is_timing_optimised_for_selected_result {get; set;}
Managed Extensions for C++
__property bool get_Is_timing_optimised_for_selected_result();
__property void set_Is_timing_optimised_for_selected_result(
   bool value
);
C++/CLI
property bool Is_timing_optimised_for_selected_result {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Lane_blockage_effect_option Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Lane_blockage_effect_option Property

Glossary Item Box

Lane Blockage Effect Option:
In Network analysis, include Lane Blockage effects in determining Phase Times.

Syntax

Visual Basic (Declaration)
Property Lane_blockage_effect_option As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Lane_blockage_effect_option = value

value = instance.Lane_blockage_effect_option
C#
int Lane_blockage_effect_option {get; set;}
Managed Extensions for C++
__property int get_Lane_blockage_effect_option();
__property void set_Lane_blockage_effect_option(
   int value
);
C++/CLI
property int Lane_blockage_effect_option {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Without Lane Blockage Effects,
1 = With Lane Blockage Effects.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_increment = value

value = instance.Optimum_cycle_time_increment
C#
int Optimum_cycle_time_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_increment();
__property void set_Optimum_cycle_time_increment(
   int value
);
C++/CLI
property int Optimum_cycle_time_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_lower = value

value = instance.Optimum_cycle_time_lower
C#
int Optimum_cycle_time_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_lower();
__property void set_Optimum_cycle_time_lower(
   int value
);
C++/CLI
property int Optimum_cycle_time_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_lower_user Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_lower_user Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_lower_user As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Boolean

instance.Optimum_cycle_time_lower_user = value

value = instance.Optimum_cycle_time_lower_user
C#
bool Optimum_cycle_time_lower_user {get; set;}
Managed Extensions for C++
__property bool get_Optimum_cycle_time_lower_user();
__property void set_Optimum_cycle_time_lower_user(
   bool value
);
C++/CLI
property bool Optimum_cycle_time_lower_user {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_optim_method = value

value = instance.Optimum_cycle_time_optim_method
C#
int Optimum_cycle_time_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_optim_method();
__property void set_Optimum_cycle_time_optim_method(
   int value
);
C++/CLI
property int Optimum_cycle_time_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_perf_measure = value

value = instance.Optimum_cycle_time_perf_measure
C#
int Optimum_cycle_time_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_perf_measure();
__property void set_Optimum_cycle_time_perf_measure(
   int value
);
C++/CLI
property int Optimum_cycle_time_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_cycle_time_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_cycle_time_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_cycle_time_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_cycle_time_upper = value

value = instance.Optimum_cycle_time_upper
C#
int Optimum_cycle_time_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_cycle_time_upper();
__property void set_Optimum_cycle_time_upper(
   int value
);
C++/CLI
property int Optimum_cycle_time_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_optim_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_max_green_optim_method Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_optim_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_max_green_optim_method = value

value = instance.Optimum_max_green_optim_method
C#
int Optimum_max_green_optim_method {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_optim_method();
__property void set_Optimum_max_green_optim_method(
   int value
);
C++/CLI
property int Optimum_max_green_optim_method {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_increment Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_max_green_percent_increment Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_increment As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_increment = value

value = instance.Optimum_max_green_percent_increment
C#
int Optimum_max_green_percent_increment {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_increment();
__property void set_Optimum_max_green_percent_increment(
   int value
);
C++/CLI
property int Optimum_max_green_percent_increment {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_lower Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_max_green_percent_lower Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_lower As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_lower = value

value = instance.Optimum_max_green_percent_lower
C#
int Optimum_max_green_percent_lower {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_lower();
__property void set_Optimum_max_green_percent_lower(
   int value
);
C++/CLI
property int Optimum_max_green_percent_lower {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_percent_upper Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_max_green_percent_upper Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_percent_upper As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_max_green_percent_upper = value

value = instance.Optimum_max_green_percent_upper
C#
int Optimum_max_green_percent_upper {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_percent_upper();
__property void set_Optimum_max_green_percent_upper(
   int value
);
C++/CLI
property int Optimum_max_green_percent_upper {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Optimum_max_green_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Optimum_max_green_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Optimum_max_green_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Optimum_max_green_perf_measure = value

value = instance.Optimum_max_green_perf_measure
C#
int Optimum_max_green_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Optimum_max_green_perf_measure();
__property void set_Optimum_max_green_perf_measure(
   int value
);
C++/CLI
property int Optimum_max_green_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Phases Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Phases Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Phases As ISIAPIPhases
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As ISIAPIPhases

value = instance.Phases
C#
ISIAPIPhases Phases {get;}
Managed Extensions for C++
__property ISIAPIPhases* get_Phases();
C++/CLI
property ISIAPIPhases^ Phases {
   ISIAPIPhases^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Position Property

Glossary Item Box

The Sequence Position in the Site's Sequences collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_cycle_rounding Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Practical_cycle_rounding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_cycle_rounding As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Practical_cycle_rounding = value

value = instance.Practical_cycle_rounding
C#
int Practical_cycle_rounding {get; set;}
Managed Extensions for C++
__property int get_Practical_cycle_rounding();
__property void set_Practical_cycle_rounding(
   int value
);
C++/CLI
property int Practical_cycle_rounding {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Practical_max_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Practical_max_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Practical_max_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Practical_max_cycle_time = value

value = instance.Practical_max_cycle_time
C#
int Practical_max_cycle_time {get; set;}
Managed Extensions for C++
__property int get_Practical_max_cycle_time();
__property void set_Practical_max_cycle_time(
   int value
);
C++/CLI
property int Practical_max_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequence_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Sequence_id Property

Glossary Item Box

The database row unique ID of the Sequence.

Syntax

Visual Basic (Declaration)
ReadOnly Property Sequence_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

value = instance.Sequence_id
C#
int Sequence_id {get;}
Managed Extensions for C++
__property int get_Sequence_id();
C++/CLI
property int Sequence_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Site As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As ISIAPISite

value = instance.Site
C#
ISIAPISite Site {get;}
Managed Extensions for C++
__property ISIAPISite* get_Site();
C++/CLI
property ISIAPISite^ Site {
   ISIAPISite^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Usergiven_cycle_time Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Usergiven_cycle_time Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Usergiven_cycle_time As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Usergiven_cycle_time = value

value = instance.Usergiven_cycle_time
C#
int Usergiven_cycle_time {get; set;}
Managed Extensions for C++
__property int get_Usergiven_cycle_time();
__property void set_Usergiven_cycle_time(
   int value
);
C++/CLI
property int Usergiven_cycle_time {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Variable_phasing_perf_measure Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequence Interface : Variable_phasing_perf_measure Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Variable_phasing_perf_measure As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequence
Dim value As Integer

instance.Variable_phasing_perf_measure = value

value = instance.Variable_phasing_perf_measure
C#
int Variable_phasing_perf_measure {get; set;}
Managed Extensions for C++
__property int get_Variable_phasing_perf_measure();
__property void set_Variable_phasing_perf_measure(
   int value
);
C++/CLI
property int Variable_phasing_perf_measure {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequence Interface
ISIAPISequence Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequences Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequences Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPISequences
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
C#
public interface ISIAPISequences
Managed Extensions for C++
public __gc __interface ISIAPISequences
C++/CLI
public interface class ISIAPISequences

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequences Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequences Interface

Glossary Item Box

The following tables list the members exposed by ISIAPISequences.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Property | SelectedSequence |
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetSequenceByID | Get a Sequence from the collection by the database row unique ID of the Sequence.
Method | Select_Sequence | Select a Sequence for analysis.
Method | SequenceExists |
Top

See Also

Reference

ISIAPISequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequences Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequences Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISequences members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetSequenceByID | Get a Sequence from the collection by the database row unique ID of the Sequence.
Method | Select_Sequence | Select a Sequence for analysis.
Method | SequenceExists |
Top

See Also

Reference

ISIAPISequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetSequenceByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : GetSequenceByID Method

sequence_id
The database row unique ID of the Sequence.

Glossary Item Box

Get a Sequence from the collection by the database row unique ID of the Sequence.

Syntax

Visual Basic (Declaration)
Function GetSequenceByID( _
   ByVal sequence_id As Integer _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim sequence_id As Integer
Dim value As ISIAPISequence

value = instance.GetSequenceByID(sequence_id)
C#
ISIAPISequence GetSequenceByID(
   int sequence_id
)
Managed Extensions for C++
ISIAPISequence* GetSequenceByID(
   int sequence_id
)
C++/CLI
ISIAPISequence^ GetSequenceByID(
   int sequence_id
)

Parameters

sequence_id
The database row unique ID of the Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Select_Sequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : Select_Sequence Method

sequence_id
The database row unique ID of the Sequence.

Glossary Item Box

Select a Sequence for analysis.

Syntax

Visual Basic (Declaration)
Sub Select_Sequence( _
   ByVal sequence_id As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim sequence_id As Integer

instance.Select_Sequence(sequence_id)
C#
void Select_Sequence(
   int sequence_id
)
Managed Extensions for C++
void Select_Sequence(
   int sequence_id
)
C++/CLI
void Select_Sequence(
   int sequence_id
)

Parameters

sequence_id
The database row unique ID of the Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SequenceExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : SequenceExists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function SequenceExists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim name As String
Dim value As Boolean

value = instance.SequenceExists(name)
C#
bool SequenceExists(
   string name
)
Managed Extensions for C++
bool SequenceExists(
   string* name
)
C++/CLI
bool SequenceExists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISequences Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISequences Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISequences members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded.
Property | SelectedSequence |
Top

See Also

Reference

ISIAPISequences Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : Item Property

Glossary Item Box

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface > Item Property : Item(String) Property

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal name As String _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim name As String
Dim value As ISIAPISequence

value = instance.Item(name)
C#
ISIAPISequence Item(
   string name
) {get;}
Managed Extensions for C++
__property ISIAPISequence* get_Item(
   string* name
);
C++/CLI
property ISIAPISequence^ Item {
   ISIAPISequence^ get(String^ name);
}

Parameters

name

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface > Item Property : Item(Int32) Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim index As Integer
Dim value As ISIAPISequence

value = instance.Item(index)
C#
ISIAPISequence Item(
   int index
) {get;}
Managed Extensions for C++
__property ISIAPISequence* get_Item(
   int index
);
C++/CLI
property ISIAPISequence^ Item {
   ISIAPISequence^ get(int index);
}

Parameters

index

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SelectedSequence Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISequences Interface : SelectedSequence Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property SelectedSequence As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISequences
Dim value As ISIAPISequence

value = instance.SelectedSequence
C#
ISIAPISequence SelectedSequence {get;}
Managed Extensions for C++
__property ISIAPISequence* get_SelectedSequence();
C++/CLI
property ISIAPISequence^ SelectedSequence {
   ISIAPISequence^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISequences Interface
ISIAPISequences Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISite Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISite Interface

Glossary Item Box

SIDRA INTERSECTION Site wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
C#
public interface ISIAPISite
Managed Extensions for C++
public __gc __interface ISIAPISite
C++/CLI
public interface class ISIAPISite

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISite Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISite Interface

Glossary Item Box

The following tables list the members exposed by ISIAPISite.

Public Properties

 | Name | Description
Property | Analysis |
Property | Category | Site Category
Property | Costunit |
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | Description | Site description
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | Driveonleft | Flag indicating the "Drive Rule" of the site
Property | Freeway_orientation |
Property | GapAcceptanceTurnOnRed |
Property | HasWarnings | Flag indicating whether warnings were generated during a call to Process
Property | Hcm | Flag indicating whether the site uses HCM
Property | Intersectionid | Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.
Property | IsIncludedInProjectSummary |
Property | LastErrorMessage |
Property | Legs |
Property | ModelName | The internal SIDRA INTERSECTION Software Setup name
Property | ModelSetting |
Property | Modelsignature | The internal SIDRA INTERSECTION Software Setup signature GUID used by this site
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | MovementClasses |
Property | MovementPeds | Collection of the Site's Pedestrian Movements
Property | MovementVehicleODs | Collection of the Site's Vehicle OD Movements
Property | Name | Site name
Property | Outputset | Site output data
Property | Peakflowperiod | Peak flow period
Property | Position | The Site Position in the Project's Sites collection. It is a zero-base integer.
Property | ProcessingError | Error message after a failed call to Process
Property | ProcessingWarnings | Processing warnings generated during a call to Process
Property | Project |
Property | Rou_controlling_detector_setback_dist |
Property | Rou_controlling_leg_orientation |
Property | Rou_metered_end_gain |
Property | Rou_metered_leg_orientation |
Property | Rou_metered_start_loss |
Property | Rou_stopline_setback_dist |
Property | Sequences |
Property | Signal_analysis_method | Signalised Site analysis method
Property | Site_id | The database row unique ID of the Site.
Property | Sitecontroltype | Control method used at site
Property | Sitetype | Site Intersection type
Property | Title | Site title
Property | TwoWaySignControlAdjGeometryControls |
Property | TwoWaySignControlAdjMajorNumLanes |
Property | Units | General unit system used for data within the site
Property | Unittimeforvolumes | Unit time for traffic volumes in minutes
Top

Public Methods

 | Name | Description
Method | AddLeg | Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.
Method | AddLegWithLanes | Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.
Method | AddSequence | Add a Sequence. A new Sequence is created and added to this Site.
Method | CloneSequence | Clone a Sequence.
Method | CreateLayoutPngData |
Method | CreateLayoutPngFile |
Method | MoveSequenceTo | Move a Sequence to a new position.
Method | Process | Processes the Site
Method | RemoveLeg | Remove a Leg from the Site.
Method | RemoveSequence | Remove a Sequence from the Site.
Method | ResetLaneMovements | Reset the Lane Movements to the default vaules
Method | ResetMovementVehicleODMCExists | Reset all Movement_vehicle_od_mc.Exists values according to the LaneApproachMovementMC.Exists values (i.e. Lane Disciplines)
Method | ResetSitePrioritiesData | Reset Priority Data to the default vaules
Method | Rotate | Rotate the Site.
Method | UpdateGeometryData | Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPISite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISite Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISite Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISite members.

Public Methods

 | Name | Description
Method | AddLeg | Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.
Method | AddLegWithLanes | Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.
Method | AddSequence | Add a Sequence. A new Sequence is created and added to this Site.
Method | CloneSequence | Clone a Sequence.
Method | CreateLayoutPngData |
Method | CreateLayoutPngFile |
Method | MoveSequenceTo | Move a Sequence to a new position.
Method | Process | Processes the Site
Method | RemoveLeg | Remove a Leg from the Site.
Method | RemoveSequence | Remove a Sequence from the Site.
Method | ResetLaneMovements | Reset the Lane Movements to the default vaules
Method | ResetMovementVehicleODMCExists | Reset all Movement_vehicle_od_mc.Exists values according to the LaneApproachMovementMC.Exists values (i.e. Lane Disciplines)
Method | ResetSitePrioritiesData | Reset Priority Data to the default vaules
Method | Rotate | Rotate the Site.
Method | UpdateGeometryData | Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.
Method | UpdateModifiedInfo | Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number
Top

See Also

Reference

ISIAPISite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLeg Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : AddLeg Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Add a new Leg to the Site at the specified orientation. The Leg is created automatically without any Approach Lane, Exit Lane or Island.

Syntax

Visual Basic (Declaration)
Function AddLeg( _
   ByVal orientation As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim orientation As Integer
Dim value As ISIAPILeg

value = instance.AddLeg(orientation)
C#
ISIAPILeg AddLeg(
   int orientation
)
Managed Extensions for C++
ISIAPILeg* AddLeg(
   int orientation
)
C++/CLI
ISIAPILeg^ AddLeg(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

The new added Leg

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddLegWithLanes Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : AddLegWithLanes Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

legGeometry

Type: System.Int32;
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Glossary Item Box

Add a new Leg to the Site at the specified orientation. The Leg is created automatically with a default set of Approach Lanes, Exit Lanes and / or Island depending on the legGeometry parameter.

Syntax

Visual Basic (Declaration)
Function AddLegWithLanes( _
   ByVal orientation As Integer, _
   ByVal legGeometry As Integer _
) As ISIAPILeg
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim orientation As Integer
Dim legGeometry As Integer
Dim value As ISIAPILeg

value = instance.AddLegWithLanes(orientation, legGeometry)
C#
ISIAPILeg AddLegWithLanes(
   int orientation,
   int legGeometry
)
Managed Extensions for C++
ISIAPILeg* AddLegWithLanes(
   int orientation,
   int legGeometry
)
C++/CLI
ISIAPILeg^ AddLegWithLanes(
   int orientation,
   int legGeometry
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

legGeometry

Type: System.Int32;
1 = Two Way,
2 = One-Way Approach,
3 = One-Way Exit.

Return Value

The new added Leg

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
AddSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : AddSequence Method

name
The name of the new Sequence.

Glossary Item Box

Add a Sequence. A new Sequence is created and added to this Site.

Syntax

Visual Basic (Declaration)
Function AddSequence( _
   ByVal name As String _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim name As String
Dim value As ISIAPISequence

value = instance.AddSequence(name)
C#
ISIAPISequence AddSequence(
   string name
)
Managed Extensions for C++
ISIAPISequence* AddSequence(
   string* name
)
C++/CLI
ISIAPISequence^ AddSequence(
   String^ name
)

Parameters

name
The name of the new Sequence.

Return Value

The new Sequence

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CloneSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : CloneSequence Method

sequence
The Sequence to be cloned.

Glossary Item Box

Clone a Sequence.

Syntax

Visual Basic (Declaration)
Function CloneSequence( _
   ByVal sequence As ISIAPISequence _
) As ISIAPISequence
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim sequence As ISIAPISequence
Dim value As ISIAPISequence

value = instance.CloneSequence(sequence)
C#
ISIAPISequence CloneSequence(
   ISIAPISequence sequence
)
Managed Extensions for C++
ISIAPISequence* CloneSequence(
   ISIAPISequence* sequence
)
C++/CLI
ISIAPISequence^ CloneSequence(
   ISIAPISequence^ sequence
)

Parameters

sequence
The Sequence to be cloned.

Return Value

The new cloned Sequence.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : CreateLayoutPngData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateLayoutPngData() As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value() As Byte

value = instance.CreateLayoutPngData()
C#
byte[] CreateLayoutPngData()
Managed Extensions for C++
byte[]* CreateLayoutPngData();
C++/CLI
array<byte>^ CreateLayoutPngData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
CreateLayoutPngFile Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : CreateLayoutPngFile Method

filename

Glossary Item Box

Syntax

Visual Basic (Declaration)
Function CreateLayoutPngFile( _
   ByVal filename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim filename As String
Dim value As Boolean

value = instance.CreateLayoutPngFile(filename)
C#
bool CreateLayoutPngFile(
   string filename
)
Managed Extensions for C++
bool CreateLayoutPngFile(
   string* filename
)
C++/CLI
bool CreateLayoutPngFile(
   String^ filename
)

Parameters

filename

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MoveSequenceTo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : MoveSequenceTo Method

sequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Glossary Item Box

Move a Sequence to a new position.

Syntax

Visual Basic (Declaration)
Function MoveSequenceTo( _
   ByVal sequence As ISIAPISequence, _
   ByVal newPosition As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim sequence As ISIAPISequence
Dim newPosition As Integer
Dim value As Boolean

value = instance.MoveSequenceTo(sequence, newPosition)
C#
bool MoveSequenceTo(
   ISIAPISequence sequence,
   int newPosition
)
Managed Extensions for C++
bool MoveSequenceTo(
   ISIAPISequence* sequence,
   int newPosition
)
C++/CLI
bool MoveSequenceTo(
   ISIAPISequence^ sequence,
   int newPosition
)

Parameters

sequence
The Sequence to move.
newPosition
The zero-based position that the Sequence should be moved to.

Return Value

true if the Sequence is successfully moved; otherwise, false. This method also returns false if the Sequence was not found in this Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Process Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Process Method

Glossary Item Box

Processes the Site

Syntax

Visual Basic (Declaration)
Function Process() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.Process()
C#
bool Process()
Managed Extensions for C++
bool Process();
C++/CLI
bool Process();

Return Value

Type: System.Boolean.

True, if processing was successful. False, if errors were generated during processing - check ProcessingError for details.

Note: The HasWarnings property should always be checked after processing in case warnings were generated. Warnings may occur even if processing was successful.

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveLeg Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : RemoveLeg Method

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Glossary Item Box

Remove a Leg from the Site.

Syntax

Visual Basic (Declaration)
Function RemoveLeg( _
   ByVal orientation As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim orientation As Integer
Dim value As Boolean

value = instance.RemoveLeg(orientation)
C#
bool RemoveLeg(
   int orientation
)
Managed Extensions for C++
bool RemoveLeg(
   int orientation
)
C++/CLI
bool RemoveLeg(
   int orientation
)

Parameters

orientation

Type: System.Int32;
0 = South,
1 = South East,
2 = East,
3 = North East,
4 = North,
5 = North West,
6 = West,
7 = South West.

Return Value

true if the Leg is successfully removed. This method returns false if the Leg was not found.

Remarks

Call ISIAPISite.UpdateGeometryData() manually after Leg(s) are added or removed.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
RemoveSequence Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : RemoveSequence Method

sequence
The Sequence to remove.

Glossary Item Box

Remove a Sequence from the Site.

Syntax

Visual Basic (Declaration)
Function RemoveSequence( _
   ByVal sequence As ISIAPISequence _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim sequence As ISIAPISequence
Dim value As Boolean

value = instance.RemoveSequence(sequence)
C#
bool RemoveSequence(
   ISIAPISequence sequence
)
Managed Extensions for C++
bool RemoveSequence(
   ISIAPISequence* sequence
)
C++/CLI
bool RemoveSequence(
   ISIAPISequence^ sequence
)

Parameters

sequence
The Sequence to remove.

Return Value

true if the Sequence is successfully removed; otherwise, false. This method also returns false if the Sequence was not found in this Site.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetLaneMovements Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ResetLaneMovements Method

Glossary Item Box

Reset the Lane Movements to the default vaules

Syntax

Visual Basic (Declaration)
Function ResetLaneMovements() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.ResetLaneMovements()
C#
bool ResetLaneMovements()
Managed Extensions for C++
bool ResetLaneMovements();
C++/CLI
bool ResetLaneMovements();

Remarks

This needs to be called manually after Approach / Exit Lanes are added or removed, or after SIAPILaneApproachMovementMC.Exists (i.e. Lane Discipline) values are changed.

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetMovementVehicleODMCExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ResetMovementVehicleODMCExists Method

Glossary Item Box

Reset all Movement_vehicle_od_mc.Exists values according to the LaneApproachMovementMC.Exists values (i.e. Lane Disciplines)

Syntax

Visual Basic (Declaration)
Function ResetMovementVehicleODMCExists() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.ResetMovementVehicleODMCExists()
C#
bool ResetMovementVehicleODMCExists()
Managed Extensions for C++
bool ResetMovementVehicleODMCExists();
C++/CLI
bool ResetMovementVehicleODMCExists();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ResetSitePrioritiesData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ResetSitePrioritiesData Method

Glossary Item Box

Reset Priority Data to the default vaules

Syntax

Visual Basic (Declaration)
Function ResetSitePrioritiesData() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.ResetSitePrioritiesData()
C#
bool ResetSitePrioritiesData()
Managed Extensions for C++
bool ResetSitePrioritiesData();
C++/CLI
bool ResetSitePrioritiesData();

Remarks

The changes to the data are submitted to the database (i.e. the Project file) automatically when this is called.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rotate Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rotate Method

step

Type: System.Int32;

If step is a positive integer, rotate the Site clockwise. If step is a negative integer, rotate the Site anti-clockwise. One step equals 45 degrees.

Glossary Item Box

Rotate the Site.

Syntax

Visual Basic (Declaration)
Function Rotate( _
   ByVal step As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim step As Integer
Dim value As Boolean

value = instance.Rotate(step)
C#
bool Rotate(
   int step
)
Managed Extensions for C++
bool Rotate(
   int step
)
C++/CLI
bool Rotate(
   int step
)

Parameters

step

Type: System.Int32;

If step is a positive integer, rotate the Site clockwise. If step is a negative integer, rotate the Site anti-clockwise. One step equals 45 degrees.

Remarks

If the Site Geometry has been changed, e.g. a Leg or Lane has been added or removed, call the method UpdateGeometryData() to update the Geometry Data before calling this.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateGeometryData Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : UpdateGeometryData Method

Glossary Item Box

Update the Geometry Data. Call this method manually after Leg(s) are added / removed, or after Lane(s) are added / removed.

Syntax

Visual Basic (Declaration)
Function UpdateGeometryData() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.UpdateGeometryData()
C#
bool UpdateGeometryData()
Managed Extensions for C++
bool UpdateGeometryData();
C++/CLI
bool UpdateGeometryData();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
UpdateModifiedInfo Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : UpdateModifiedInfo Method

Glossary Item Box

Update the Last Modified Information, such as Date, User Name, Organisation Name, Software Version Number

Syntax

Visual Basic (Declaration)
Function UpdateModifiedInfo() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.UpdateModifiedInfo()
C#
bool UpdateModifiedInfo()
Managed Extensions for C++
bool UpdateModifiedInfo();
C++/CLI
bool UpdateModifiedInfo();

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISite Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISite Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISite members.

Public Properties

 | Name | Description
Property | Analysis |
Property | Category | Site Category
Property | Costunit |
Property | Created_by |
Property | Created_by_company |
Property | Created_date |
Property | Created_version |
Property | Description | Site description
Property | DiagnosticMsgs |
Property | DiagnosticStatus | Diagnostic Status
Property | Driveonleft | Flag indicating the "Drive Rule" of the site
Property | Freeway_orientation |
Property | GapAcceptanceTurnOnRed |
Property | HasWarnings | Flag indicating whether warnings were generated during a call to Process
Property | Hcm | Flag indicating whether the site uses HCM
Property | Intersectionid | Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.
Property | IsIncludedInProjectSummary |
Property | LastErrorMessage |
Property | Legs |
Property | ModelName | The internal SIDRA INTERSECTION Software Setup name
Property | ModelSetting |
Property | Modelsignature | The internal SIDRA INTERSECTION Software Setup signature GUID used by this site
Property | Modified_by |
Property | Modified_by_company |
Property | Modified_date |
Property | Modified_version |
Property | MovementClasses |
Property | MovementPeds | Collection of the Site's Pedestrian Movements
Property | MovementVehicleODs | Collection of the Site's Vehicle OD Movements
Property | Name | Site name
Property | Outputset | Site output data
Property | Peakflowperiod | Peak flow period
Property | Position | The Site Position in the Project's Sites collection. It is a zero-base integer.
Property | ProcessingError | Error message after a failed call to Process
Property | ProcessingWarnings | Processing warnings generated during a call to Process
Property | Project |
Property | Rou_controlling_detector_setback_dist |
Property | Rou_controlling_leg_orientation |
Property | Rou_metered_end_gain |
Property | Rou_metered_leg_orientation |
Property | Rou_metered_start_loss |
Property | Rou_stopline_setback_dist |
Property | Sequences |
Property | Signal_analysis_method | Signalised Site analysis method
Property | Site_id | The database row unique ID of the Site.
Property | Sitecontroltype | Control method used at site
Property | Sitetype | Site Intersection type
Property | Title | Site title
Property | TwoWaySignControlAdjGeometryControls |
Property | TwoWaySignControlAdjMajorNumLanes |
Property | Units | General unit system used for data within the site
Property | Unittimeforvolumes | Unit time for traffic volumes in minutes
Top

See Also

Reference

ISIAPISite Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Analysis Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Analysis Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Analysis As ISIAPIAnalysis
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIAnalysis

value = instance.Analysis
C#
ISIAPIAnalysis Analysis {get;}
Managed Extensions for C++
__property ISIAPIAnalysis* get_Analysis();
C++/CLI
property ISIAPIAnalysis^ Analysis {
   ISIAPIAnalysis^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Category Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Category Property

Glossary Item Box

Site Category

Syntax

Visual Basic (Declaration)
Property Category As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Category = value

value = instance.Category
C#
string Category {get; set;}
Managed Extensions for C++
__property string* get_Category();
__property void set_Category(
   string* value
);
C++/CLI
property String^ Category {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site Category, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Costunit Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Costunit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Costunit As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Costunit = value

value = instance.Costunit
C#
string Costunit {get; set;}
Managed Extensions for C++
__property string* get_Costunit();
__property void set_Costunit(
   string* value
);
C++/CLI
property String^ Costunit {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Created_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Created_by
C#
string Created_by {get;}
Managed Extensions for C++
__property string* get_Created_by();
C++/CLI
property String^ Created_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Created_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Created_by_company
C#
string Created_by_company {get;}
Managed Extensions for C++
__property string* get_Created_by_company();
C++/CLI
property String^ Created_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Created_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Date

value = instance.Created_date
C#
DateTime Created_date {get;}
Managed Extensions for C++
__property DateTime get_Created_date();
C++/CLI
property DateTime Created_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Created_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Created_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Created_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Created_version
C#
string Created_version {get;}
Managed Extensions for C++
__property string* get_Created_version();
C++/CLI
property String^ Created_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Description Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Description Property

Glossary Item Box

Site description

Syntax

Visual Basic (Declaration)
Property Description As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Description = value

value = instance.Description
C#
string Description {get; set;}
Managed Extensions for C++
__property string* get_Description();
__property void set_Description(
   string* value
);
C++/CLI
property String^ Description {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site description, max length = 500.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticMsgs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : DiagnosticMsgs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticMsgs As ISIAPIDiagnosticMsgs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIDiagnosticMsgs

value = instance.DiagnosticMsgs
C#
ISIAPIDiagnosticMsgs DiagnosticMsgs {get;}
Managed Extensions for C++
__property ISIAPIDiagnosticMsgs* get_DiagnosticMsgs();
C++/CLI
property ISIAPIDiagnosticMsgs^ DiagnosticMsgs {
   ISIAPIDiagnosticMsgs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
DiagnosticStatus Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : DiagnosticStatus Property

Glossary Item Box

Diagnostic Status

Syntax

Visual Basic (Declaration)
ReadOnly Property DiagnosticStatus As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.DiagnosticStatus
C#
int DiagnosticStatus {get;}
Managed Extensions for C++
__property int get_DiagnosticStatus();
C++/CLI
property int DiagnosticStatus {
   int get();
}

Property Value

Type: System.Int32;

1 = Processed,
2 = Not Processed,
3 = Input Warning,
4 = Processing Warning,
5 = Error.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Driveonleft Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Driveonleft Property

Glossary Item Box

Flag indicating the "Drive Rule" of the site

Syntax

Visual Basic (Declaration)
ReadOnly Property Driveonleft As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.Driveonleft
C#
bool Driveonleft {get;}
Managed Extensions for C++
__property bool get_Driveonleft();
C++/CLI
property bool Driveonleft {
   bool get();
}

Property Value

Type: System.Boolean.

True if driving on the left. False if driving on the right.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Freeway_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Freeway_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Freeway_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Freeway_orientation
C#
int Freeway_orientation {get;}
Managed Extensions for C++
__property int get_Freeway_orientation();
C++/CLI
property int Freeway_orientation {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GapAcceptanceTurnOnRed Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : GapAcceptanceTurnOnRed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property GapAcceptanceTurnOnRed As ISIAPIGapAcceptanceSpecificApp
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIGapAcceptanceSpecificApp

value = instance.GapAcceptanceTurnOnRed
C#
ISIAPIGapAcceptanceSpecificApp GapAcceptanceTurnOnRed {get;}
Managed Extensions for C++
__property ISIAPIGapAcceptanceSpecificApp* get_GapAcceptanceTurnOnRed();
C++/CLI
property ISIAPIGapAcceptanceSpecificApp^ GapAcceptanceTurnOnRed {
   ISIAPIGapAcceptanceSpecificApp^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
HasWarnings Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : HasWarnings Property

Glossary Item Box

Flag indicating whether warnings were generated during a call to Process

Syntax

Visual Basic (Declaration)
ReadOnly Property HasWarnings As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.HasWarnings
C#
bool HasWarnings {get;}
Managed Extensions for C++
__property bool get_HasWarnings();
C++/CLI
property bool HasWarnings {
   bool get();
}

Property Value

Type: System.Boolean.

True if warnings were generated. False otherwise.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Hcm Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Hcm Property

Glossary Item Box

Flag indicating whether the site uses HCM

Syntax

Visual Basic (Declaration)
ReadOnly Property Hcm As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

value = instance.Hcm
C#
bool Hcm {get;}
Managed Extensions for C++
__property bool get_Hcm();
C++/CLI
property bool Hcm {
   bool get();
}

Property Value

Type: System.Boolean.

True, if site uses HCM, False otherwise.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Intersectionid Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Intersectionid Property

Glossary Item Box

Site ID in the Intersection dialog and reports. It was named as "Intersection ID" in the old versions.

Syntax

Visual Basic (Declaration)
Property Intersectionid As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Intersectionid = value

value = instance.Intersectionid
C#
string Intersectionid {get; set;}
Managed Extensions for C++
__property string* get_Intersectionid();
__property void set_Intersectionid(
   string* value
);
C++/CLI
property String^ Intersectionid {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site ID, max length = 10.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
IsIncludedInProjectSummary Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : IsIncludedInProjectSummary Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property IsIncludedInProjectSummary As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Boolean

instance.IsIncludedInProjectSummary = value

value = instance.IsIncludedInProjectSummary
C#
bool IsIncludedInProjectSummary {get; set;}
Managed Extensions for C++
__property bool get_IsIncludedInProjectSummary();
__property void set_IsIncludedInProjectSummary(
   bool value
);
C++/CLI
property bool IsIncludedInProjectSummary {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
LastErrorMessage Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : LastErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property LastErrorMessage As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.LastErrorMessage
C#
string LastErrorMessage {get;}
Managed Extensions for C++
__property string* get_LastErrorMessage();
C++/CLI
property String^ LastErrorMessage {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Legs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Legs Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Legs As ISIAPILegs
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPILegs

value = instance.Legs
C#
ISIAPILegs Legs {get;}
Managed Extensions for C++
__property ISIAPILegs* get_Legs();
C++/CLI
property ISIAPILegs^ Legs {
   ISIAPILegs^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelName Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ModelName Property

Glossary Item Box

The internal SIDRA INTERSECTION Software Setup name

Syntax

Visual Basic (Declaration)
ReadOnly Property ModelName As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.ModelName
C#
string ModelName {get;}
Managed Extensions for C++
__property string* get_ModelName();
C++/CLI
property String^ ModelName {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ModelSetting Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ModelSetting Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property ModelSetting As ISIAPIModelSetting
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIModelSetting

value = instance.ModelSetting
C#
ISIAPIModelSetting ModelSetting {get;}
Managed Extensions for C++
__property ISIAPIModelSetting* get_ModelSetting();
C++/CLI
property ISIAPIModelSetting^ ModelSetting {
   ISIAPIModelSetting^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modelsignature Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Modelsignature Property

Glossary Item Box

The internal SIDRA INTERSECTION Software Setup signature GUID used by this site

Syntax

Visual Basic (Declaration)
ReadOnly Property Modelsignature As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Modelsignature
C#
string Modelsignature {get;}
Managed Extensions for C++
__property string* get_Modelsignature();
C++/CLI
property String^ Modelsignature {
   String^ get();
}

Property Value

Type: System.String

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Modified_by Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Modified_by
C#
string Modified_by {get;}
Managed Extensions for C++
__property string* get_Modified_by();
C++/CLI
property String^ Modified_by {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_by_company Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Modified_by_company Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_by_company As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Modified_by_company
C#
string Modified_by_company {get;}
Managed Extensions for C++
__property string* get_Modified_by_company();
C++/CLI
property String^ Modified_by_company {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_date Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Modified_date Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_date As Date
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Date

value = instance.Modified_date
C#
DateTime Modified_date {get;}
Managed Extensions for C++
__property DateTime get_Modified_date();
C++/CLI
property DateTime Modified_date {
   DateTime get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Modified_version Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Modified_version Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Modified_version As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.Modified_version
C#
string Modified_version {get;}
Managed Extensions for C++
__property string* get_Modified_version();
C++/CLI
property String^ Modified_version {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementClasses Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : MovementClasses Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementClasses As ISIAPIMovementClasses
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIMovementClasses

value = instance.MovementClasses
C#
ISIAPIMovementClasses MovementClasses {get;}
Managed Extensions for C++
__property ISIAPIMovementClasses* get_MovementClasses();
C++/CLI
property ISIAPIMovementClasses^ MovementClasses {
   ISIAPIMovementClasses^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementPeds Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : MovementPeds Property

Glossary Item Box

Collection of the Site's Pedestrian Movements

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementPeds As ISIAPIMovement_peds
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIMovement_peds

value = instance.MovementPeds
C#
ISIAPIMovement_peds MovementPeds {get;}
Managed Extensions for C++
__property ISIAPIMovement_peds* get_MovementPeds();
C++/CLI
property ISIAPIMovement_peds^ MovementPeds {
   ISIAPIMovement_peds^ get();
}

Property Value

Type: ISIAPIMovement_peds

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
MovementVehicleODs Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : MovementVehicleODs Property

Glossary Item Box

Collection of the Site's Vehicle OD Movements

Syntax

Visual Basic (Declaration)
ReadOnly Property MovementVehicleODs As ISIAPIMovement_vehicle_ods
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIMovement_vehicle_ods

value = instance.MovementVehicleODs
C#
ISIAPIMovement_vehicle_ods MovementVehicleODs {get;}
Managed Extensions for C++
__property ISIAPIMovement_vehicle_ods* get_MovementVehicleODs();
C++/CLI
property ISIAPIMovement_vehicle_ods^ MovementVehicleODs {
   ISIAPIMovement_vehicle_ods^ get();
}

Property Value

Type: ISIAPIMovement_vehicle_ods

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Name Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Name Property

Glossary Item Box

Site name

Syntax

Visual Basic (Declaration)
Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Name = value

value = instance.Name
C#
string Name {get; set;}
Managed Extensions for C++
__property string* get_Name();
__property void set_Name(
   string* value
);
C++/CLI
property String^ Name {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

The site name, max length = 100.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Outputset Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Outputset Property

Glossary Item Box

Site output data

Syntax

Visual Basic (Declaration)
ReadOnly Property Outputset As ISIAPIOutputset
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIOutputset

value = instance.Outputset
C#
ISIAPIOutputset Outputset {get;}
Managed Extensions for C++
__property ISIAPIOutputset* get_Outputset();
C++/CLI
property ISIAPIOutputset^ Outputset {
   ISIAPIOutputset^ get();
}

Property Value

Type: ISIAPIOutputset

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Peakflowperiod Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Peakflowperiod Property

Glossary Item Box

Peak flow period

Syntax

Visual Basic (Declaration)
Property Peakflowperiod As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Peakflowperiod = value

value = instance.Peakflowperiod
C#
int Peakflowperiod {get; set;}
Managed Extensions for C++
__property int get_Peakflowperiod();
__property void set_Peakflowperiod(
   int value
);
C++/CLI
property int Peakflowperiod {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Position Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Position Property

Glossary Item Box

The Site Position in the Project's Sites collection. It is a zero-base integer.

Syntax

Visual Basic (Declaration)
ReadOnly Property Position As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Position
C#
int Position {get;}
Managed Extensions for C++
__property int get_Position();
C++/CLI
property int Position {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingError Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ProcessingError Property

Glossary Item Box

Error message after a failed call to Process

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcessingError As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.ProcessingError
C#
string ProcessingError {get;}
Managed Extensions for C++
__property string* get_ProcessingError();
C++/CLI
property String^ ProcessingError {
   String^ get();
}

Property Value

Type: System.String.

Error message

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ProcessingWarnings Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : ProcessingWarnings Property

Glossary Item Box

Processing warnings generated during a call to Process

Syntax

Visual Basic (Declaration)
ReadOnly Property ProcessingWarnings As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

value = instance.ProcessingWarnings
C#
string ProcessingWarnings {get;}
Managed Extensions for C++
__property string* get_ProcessingWarnings();
C++/CLI
property String^ ProcessingWarnings {
   String^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Project Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Project Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Project As ISIAPIProject
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPIProject

value = instance.Project
C#
ISIAPIProject Project {get;}
Managed Extensions for C++
__property ISIAPIProject* get_Project();
C++/CLI
property ISIAPIProject^ Project {
   ISIAPIProject^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_controlling_detector_setback_dist Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_controlling_detector_setback_dist Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_controlling_detector_setback_dist As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Single

instance.Rou_controlling_detector_setback_dist = value

value = instance.Rou_controlling_detector_setback_dist
C#
float Rou_controlling_detector_setback_dist {get; set;}
Managed Extensions for C++
__property float get_Rou_controlling_detector_setback_dist();
__property void set_Rou_controlling_detector_setback_dist(
   float value
);
C++/CLI
property float Rou_controlling_detector_setback_dist {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_controlling_leg_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_controlling_leg_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_controlling_leg_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Rou_controlling_leg_orientation = value

value = instance.Rou_controlling_leg_orientation
C#
int Rou_controlling_leg_orientation {get; set;}
Managed Extensions for C++
__property int get_Rou_controlling_leg_orientation();
__property void set_Rou_controlling_leg_orientation(
   int value
);
C++/CLI
property int Rou_controlling_leg_orientation {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_end_gain Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_metered_end_gain Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_metered_end_gain As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Rou_metered_end_gain = value

value = instance.Rou_metered_end_gain
C#
int Rou_metered_end_gain {get; set;}
Managed Extensions for C++
__property int get_Rou_metered_end_gain();
__property void set_Rou_metered_end_gain(
   int value
);
C++/CLI
property int Rou_metered_end_gain {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_leg_orientation Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_metered_leg_orientation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_metered_leg_orientation As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Rou_metered_leg_orientation = value

value = instance.Rou_metered_leg_orientation
C#
int Rou_metered_leg_orientation {get; set;}
Managed Extensions for C++
__property int get_Rou_metered_leg_orientation();
__property void set_Rou_metered_leg_orientation(
   int value
);
C++/CLI
property int Rou_metered_leg_orientation {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_metered_start_loss Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_metered_start_loss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_metered_start_loss As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Rou_metered_start_loss = value

value = instance.Rou_metered_start_loss
C#
int Rou_metered_start_loss {get; set;}
Managed Extensions for C++
__property int get_Rou_metered_start_loss();
__property void set_Rou_metered_start_loss(
   int value
);
C++/CLI
property int Rou_metered_start_loss {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Rou_stopline_setback_dist Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Rou_stopline_setback_dist Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Rou_stopline_setback_dist As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Single

instance.Rou_stopline_setback_dist = value

value = instance.Rou_stopline_setback_dist
C#
float Rou_stopline_setback_dist {get; set;}
Managed Extensions for C++
__property float get_Rou_stopline_setback_dist();
__property void set_Rou_stopline_setback_dist(
   float value
);
C++/CLI
property float Rou_stopline_setback_dist {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sequences Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Sequences Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Sequences As ISIAPISequences
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPISequences

value = instance.Sequences
C#
ISIAPISequences Sequences {get;}
Managed Extensions for C++
__property ISIAPISequences* get_Sequences();
C++/CLI
property ISIAPISequences^ Sequences {
   ISIAPISequences^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Signal_analysis_method Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Signal_analysis_method Property

Glossary Item Box

Signalised Site analysis method

Syntax

Visual Basic (Declaration)
Property Signal_analysis_method As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Signal_analysis_method = value

value = instance.Signal_analysis_method
C#
int Signal_analysis_method {get; set;}
Managed Extensions for C++
__property int get_Signal_analysis_method();
__property void set_Signal_analysis_method(
   int value
);
C++/CLI
property int Signal_analysis_method {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32;

0 = Fixed-Time/Pretimed,
1 = Actuated.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Site_id Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Site_id Property

Glossary Item Box

The database row unique ID of the Site.

Syntax

Visual Basic (Declaration)
ReadOnly Property Site_id As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Site_id
C#
int Site_id {get;}
Managed Extensions for C++
__property int get_Site_id();
C++/CLI
property int Site_id {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sitecontroltype Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Sitecontroltype Property

Glossary Item Box

Control method used at site

Syntax

Visual Basic (Declaration)
ReadOnly Property Sitecontroltype As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Sitecontroltype
C#
int Sitecontroltype {get;}
Managed Extensions for C++
__property int get_Sitecontroltype();
C++/CLI
property int Sitecontroltype {
   int get();
}

Property Value

Type: System.Int32;

0 = Signals,
1 = Roundabout,
2 = Sign Control,
3 = All Way Stop.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Sitetype Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Sitetype Property

Glossary Item Box

Site Intersection type

Syntax

Visual Basic (Declaration)
ReadOnly Property Sitetype As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Sitetype
C#
int Sitetype {get;}
Managed Extensions for C++
__property int get_Sitetype();
C++/CLI
property int Sitetype {
   int get();
}

Property Value

Type: System.Int32;

0 = Signalised,
1 = Roundabout,
2 = Giveway/Yield,
3 = Stop (Two-Way),
4 = All-way Stop (AWSC),
5 = Single Point Urban Interchange (SPUI),
6 = Pedestrian Crossing,
7 = Metered Roundabout.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Title Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Title Property

Glossary Item Box

Site title

Syntax

Visual Basic (Declaration)
Property Title As String
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As String

instance.Title = value

value = instance.Title
C#
string Title {get; set;}
Managed Extensions for C++
__property string* get_Title();
__property void set_Title(
   string* value
);
C++/CLI
property String^ Title {
   String^ get();
   void set (    String^ value);
}

Property Value

Type: System.String.

Site title, max length = 500.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TwoWaySignControlAdjGeometryControls Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : TwoWaySignControlAdjGeometryControls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TwoWaySignControlAdjGeometryControls As ISIAPITwoWaySignControlAdjGeometryControls
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPITwoWaySignControlAdjGeometryControls

value = instance.TwoWaySignControlAdjGeometryControls
C#
ISIAPITwoWaySignControlAdjGeometryControls TwoWaySignControlAdjGeometryControls {get;}
Managed Extensions for C++
__property ISIAPITwoWaySignControlAdjGeometryControls* get_TwoWaySignControlAdjGeometryControls();
C++/CLI
property ISIAPITwoWaySignControlAdjGeometryControls^ TwoWaySignControlAdjGeometryControls {
   ISIAPITwoWaySignControlAdjGeometryControls^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
TwoWaySignControlAdjMajorNumLanes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : TwoWaySignControlAdjMajorNumLanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property TwoWaySignControlAdjMajorNumLanes As ISIAPITwoWaySignControlAdjMajorNumLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As ISIAPITwoWaySignControlAdjMajorNumLanes

value = instance.TwoWaySignControlAdjMajorNumLanes
C#
ISIAPITwoWaySignControlAdjMajorNumLanes TwoWaySignControlAdjMajorNumLanes {get;}
Managed Extensions for C++
__property ISIAPITwoWaySignControlAdjMajorNumLanes* get_TwoWaySignControlAdjMajorNumLanes();
C++/CLI
property ISIAPITwoWaySignControlAdjMajorNumLanes^ TwoWaySignControlAdjMajorNumLanes {
   ISIAPITwoWaySignControlAdjMajorNumLanes^ get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Units Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Units Property

Glossary Item Box

General unit system used for data within the site

Syntax

Visual Basic (Declaration)
ReadOnly Property Units As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

value = instance.Units
C#
int Units {get;}
Managed Extensions for C++
__property int get_Units();
C++/CLI
property int Units {
   int get();
}

Property Value

Type: System.Int32.

0 = Metric,
1 = US Units.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Unittimeforvolumes Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISite Interface : Unittimeforvolumes Property

Glossary Item Box

Unit time for traffic volumes in minutes

Syntax

Visual Basic (Declaration)
Property Unittimeforvolumes As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISite
Dim value As Integer

instance.Unittimeforvolumes = value

value = instance.Unittimeforvolumes
C#
int Unittimeforvolumes {get; set;}
Managed Extensions for C++
__property int get_Unittimeforvolumes();
__property void set_Unittimeforvolumes(
   int value
);
C++/CLI
property int Unittimeforvolumes {
   int get();
   void set (    int value);
}

Property Value

Type: System.Int32.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISite Interface
ISIAPISite Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISites Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISites Interface

Glossary Item Box

Site collection wrapper interface

Syntax

Visual Basic (Declaration)
Public Interface ISIAPISites
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
C#
public interface ISIAPISites
Managed Extensions for C++
public __gc __interface ISIAPISites
C++/CLI
public interface class ISIAPISites

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISites Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISites Interface

Glossary Item Box

The following tables list the members exposed by ISIAPISites.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded. Get the Site from the collection by the Site name.
Top

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetSiteByID | Get the Site by the database row unique ID.
Method | SiteExists | Queries whether a particular Site exists in the collection
Top

See Also

Reference

ISIAPISites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISites Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISites members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Method | GetSiteByID | Get the Site by the database row unique ID.
Method | SiteExists | Queries whether a particular Site exists in the collection
Top

See Also

Reference

ISIAPISites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
GetSiteByID Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface : GetSiteByID Method

site_id

Type: System.Int32;
The database row unique ID of the Site.
This is different from the "Site ID" in the Intersection dialog which can be accessed through ISIAPISite.Intersectionid.

Glossary Item Box

Get the Site by the database row unique ID.

Syntax

Visual Basic (Declaration)
Function GetSiteByID( _
   ByVal site_id As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
Dim site_id As Integer
Dim value As ISIAPISite

value = instance.GetSiteByID(site_id)
C#
ISIAPISite GetSiteByID(
   int site_id
)
Managed Extensions for C++
ISIAPISite* GetSiteByID(
   int site_id
)
C++/CLI
ISIAPISite^ GetSiteByID(
   int site_id
)

Parameters

site_id

Type: System.Int32;
The database row unique ID of the Site.
This is different from the "Site ID" in the Intersection dialog which can be accessed through ISIAPISite.Intersectionid.

Remarks

Use ISIAPISites.Item[] to get a Site by its name or its position in the Site List. In C++, use ISIAPISites->get_Item() to get a Site by its name or get_Item_2() by its position.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
SiteExists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface : SiteExists Method

sitename
Site name to query

Glossary Item Box

Queries whether a particular Site exists in the collection

Syntax

Visual Basic (Declaration)
Function SiteExists( _
   ByVal sitename As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
Dim sitename As String
Dim value As Boolean

value = instance.SiteExists(sitename)
C#
bool SiteExists(
   string sitename
)
Managed Extensions for C++
bool SiteExists(
   string* sitename
)
C++/CLI
bool SiteExists(
   String^ sitename
)

Parameters

sitename
Site name to query

Return Value

Type: System.Bool

True, if a Site with the given site name exists in the collection. False otherwise

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPISites Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPISites Interface

Glossary Item Box

For a list of all members of this type, see ISIAPISites members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Overloaded. Get the Site from the collection by the Site name.
Top

See Also

Reference

ISIAPISites Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface : Item Property

Glossary Item Box

Get the Site from the collection by the Site name.

Overload List

Overload | Description
Item(String) | Get the Site from the collection by the Site name.
Item(Int32) | Gets the element at the specified index.

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(String) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface > Item Property : Item(String) Property

sitename
Site name

Glossary Item Box

Get the Site from the collection by the Site name.

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal sitename As String _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
Dim sitename As String
Dim value As ISIAPISite

value = instance.Item(sitename)
C#
ISIAPISite Item(
   string sitename
) {get;}
Managed Extensions for C++
__property ISIAPISite* get_Item(
   string* sitename
);
C++/CLI
property ISIAPISite^ Item {
   ISIAPISite^ get(String^ sitename);
}

Parameters

sitename
Site name

Remarks

The Site name is not unique in the collection. It is possible that more than one Site has the same name.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item(Int32) Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPISites Interface > Item Property : Item(Int32) Property

siteindex

Type: System.Int32;
The zero-based index of the element to get.

Glossary Item Box

Gets the element at the specified index.

Syntax

Visual Basic (Declaration)
Overloads ReadOnly Property Item( _
   ByVal siteindex As Integer _
) As ISIAPISite
Visual Basic (Usage) Copy Code
Dim instance As ISIAPISites
Dim siteindex As Integer
Dim value As ISIAPISite

value = instance.Item(siteindex)
C#
ISIAPISite Item(
   int siteindex
) {get;}
Managed Extensions for C++
__property ISIAPISite* get_Item(
   int siteindex
);
C++/CLI
property ISIAPISite^ Item {
   ISIAPISite^ get(int siteindex);
}

Parameters

siteindex

Type: System.Int32;
The zero-based index of the element to get.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPISites Interface
ISIAPISites Members
Overload List


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControl Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControl Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPITwoWaySignControlAdjGeometryControl
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControl
C#
public interface ISIAPITwoWaySignControlAdjGeometryControl
Managed Extensions for C++
public __gc __interface ISIAPITwoWaySignControlAdjGeometryControl
C++/CLI
public interface class ISIAPITwoWaySignControlAdjGeometryControl

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControl Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControl Interface

Glossary Item Box

The following tables list the members exposed by ISIAPITwoWaySignControlAdjGeometryControl.

Public Properties

 | Name | Description
Property | Critical_gap_adj |
Property | Followup_headway_adj |
Property | Type | The type of adjustment
Top

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControl Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControl Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjGeometryControl members.

Public Properties

 | Name | Description
Property | Critical_gap_adj |
Property | Followup_headway_adj |
Property | Type | The type of adjustment
Top

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControl Interface : Critical_gap_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Critical_gap_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControl
Dim value As Single

instance.Critical_gap_adj = value

value = instance.Critical_gap_adj
C#
float Critical_gap_adj {get; set;}
Managed Extensions for C++
__property float get_Critical_gap_adj();
__property void set_Critical_gap_adj(
   float value
);
C++/CLI
property float Critical_gap_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Interface
ISIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControl Interface : Followup_headway_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Followup_headway_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControl
Dim value As Single

instance.Followup_headway_adj = value

value = instance.Followup_headway_adj
C#
float Followup_headway_adj {get; set;}
Managed Extensions for C++
__property float get_Followup_headway_adj();
__property void set_Followup_headway_adj(
   float value
);
C++/CLI
property float Followup_headway_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Interface
ISIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControl Interface : Type Property

Glossary Item Box

The type of adjustment

Syntax

Visual Basic (Declaration)
ReadOnly Property Type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControl
Dim value As Integer

value = instance.Type
C#
int Type {get;}
Managed Extensions for C++
__property int get_Type();
C++/CLI
property int Type {
   int get();
}

Property Value

Type: System.Int32;

1 = Giveway/Yield Sign Control,
2 = One-Way Major Road,
3 = T-Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControl Interface
ISIAPITwoWaySignControlAdjGeometryControl Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControls Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControls Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPITwoWaySignControlAdjGeometryControls
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControls
C#
public interface ISIAPITwoWaySignControlAdjGeometryControls
Managed Extensions for C++
public __gc __interface ISIAPITwoWaySignControlAdjGeometryControls
C++/CLI
public interface class ISIAPITwoWaySignControlAdjGeometryControls

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControls Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControls Interface

Glossary Item Box

The following tables list the members exposed by ISIAPITwoWaySignControlAdjGeometryControls.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an entry of the data for the specified Type of Geometry and Control. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether the data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControls Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControls Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjGeometryControls members.

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether the data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControls Interface : Exists Method

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Glossary Item Box

Get a value indicating whether the data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function Exists( _
   ByVal geoControlType As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControls
Dim geoControlType As Integer
Dim value As Boolean

value = instance.Exists(geoControlType)
C#
bool Exists(
   int geoControlType
)
Managed Extensions for C++
bool Exists(
   int geoControlType
)
C++/CLI
bool Exists(
   int geoControlType
)

Parameters

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
ISIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjGeometryControls Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjGeometryControls Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjGeometryControls members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an entry of the data for the specified Type of Geometry and Control. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControls Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControls
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
ISIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjGeometryControls Interface : Item Property

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Glossary Item Box

Get an entry of the data for the specified Type of Geometry and Control.
Return an object if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal geoControlType As Integer _
) As ISIAPITwoWaySignControlAdjGeometryControl
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjGeometryControls
Dim geoControlType As Integer
Dim value As ISIAPITwoWaySignControlAdjGeometryControl

value = instance.Item(geoControlType)
C#
ISIAPITwoWaySignControlAdjGeometryControl this[
   int geoControlType
]; {get;}
Managed Extensions for C++
__property ISIAPITwoWaySignControlAdjGeometryControl* get_Item   int geoControlType
;
C++/CLI
property ISIAPITwoWaySignControlAdjGeometryControl^ default [int] {
   ISIAPITwoWaySignControlAdjGeometryControl^ get(int geoControlType);
}

Parameters

geoControlType

Type: System.Int32;

1 = Give-Way / Yield Sign Control,
2 = One-Way Major Road,
3 = T Intersection (Minor Road Turn),
4 = Entry Road Grade (for each per cent grade),
5 = Staged Crossing - Stage 1,
6 = Staged Crossing - Stage 2,
7 = U Turn (Major Road),
8 = User Adjustment.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjGeometryControls Interface
ISIAPITwoWaySignControlAdjGeometryControls Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLane Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLane Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPITwoWaySignControlAdjMajorNumLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLane
C#
public interface ISIAPITwoWaySignControlAdjMajorNumLane
Managed Extensions for C++
public __gc __interface ISIAPITwoWaySignControlAdjMajorNumLane
C++/CLI
public interface class ISIAPITwoWaySignControlAdjMajorNumLane

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLane Interface Members
See Also Properties Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLane Interface

Glossary Item Box

The following tables list the members exposed by ISIAPITwoWaySignControlAdjMajorNumLane.

Public Properties

 | Name | Description
Property | Critical_gap_adj |
Property | Followup_headway_adj |
Property | Major_num_lane | Major Road Number of Lanes
Property | Movement_type | Movement Type
Top

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLane Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLane Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjMajorNumLane members.

Public Properties

 | Name | Description
Property | Critical_gap_adj |
Property | Followup_headway_adj |
Property | Major_num_lane | Major Road Number of Lanes
Property | Movement_type | Movement Type
Top

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Critical_gap_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLane Interface : Critical_gap_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Critical_gap_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLane
Dim value As Single

instance.Critical_gap_adj = value

value = instance.Critical_gap_adj
C#
float Critical_gap_adj {get; set;}
Managed Extensions for C++
__property float get_Critical_gap_adj();
__property void set_Critical_gap_adj(
   float value
);
C++/CLI
property float Critical_gap_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
ISIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Followup_headway_adj Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLane Interface : Followup_headway_adj Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Property Followup_headway_adj As Single
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLane
Dim value As Single

instance.Followup_headway_adj = value

value = instance.Followup_headway_adj
C#
float Followup_headway_adj {get; set;}
Managed Extensions for C++
__property float get_Followup_headway_adj();
__property void set_Followup_headway_adj(
   float value
);
C++/CLI
property float Followup_headway_adj {
   float get();
   void set (    float value);
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
ISIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Major_num_lane Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLane Interface : Major_num_lane Property

Glossary Item Box

Major Road Number of Lanes

Syntax

Visual Basic (Declaration)
ReadOnly Property Major_num_lane As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLane
Dim value As Integer

value = instance.Major_num_lane
C#
int Major_num_lane {get;}
Managed Extensions for C++
__property int get_Major_num_lane();
C++/CLI
property int Major_num_lane {
   int get();
}

Property Value

Type: System.Int32;

Can be 2, 3, 5, 6.

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
ISIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Movement_type Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLane Interface : Movement_type Property

Glossary Item Box

Movement Type

Syntax

Visual Basic (Declaration)
ReadOnly Property Movement_type As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLane
Dim value As Integer

value = instance.Movement_type
C#
int Movement_type {get;}
Managed Extensions for C++
__property int get_Movement_type();
C++/CLI
property int Movement_type {
   int get();
}

Property Value

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLane Interface
ISIAPITwoWaySignControlAdjMajorNumLane Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLanes Interface
Members See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLanes Interface

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Interface ISIAPITwoWaySignControlAdjMajorNumLanes
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLanes
C#
public interface ISIAPITwoWaySignControlAdjMajorNumLanes
Managed Extensions for C++
public __gc __interface ISIAPITwoWaySignControlAdjMajorNumLanes
C++/CLI
public interface class ISIAPITwoWaySignControlAdjMajorNumLanes

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Members
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Members$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLanes Interface Members
See Also Properties Methods Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLanes Interface

Glossary Item Box

The following tables list the members exposed by ISIAPITwoWaySignControlAdjMajorNumLanes.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether the data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLanes Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjMajorNumLanes members.

Public Methods

 | Name | Description
Method | Exists | Get a value indicating whether the data exists in the data structure.
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Exists Method
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLanes Interface : Exists Method

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Glossary Item Box

Get a value indicating whether the data exists in the data structure.

Syntax

Visual Basic (Declaration)
Function Exists( _
   ByVal majorRoadNumOfLane As Integer, _
   ByVal movType As Integer _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLanes
Dim majorRoadNumOfLane As Integer
Dim movType As Integer
Dim value As Boolean

value = instance.Exists(majorRoadNumOfLane, movType)
C#
bool Exists(
   int majorRoadNumOfLane,
   int movType
)
Managed Extensions for C++
bool Exists(
   int majorRoadNumOfLane,
   int movType
)
C++/CLI
bool Exists(
   int majorRoadNumOfLane,
   int movType
)

Parameters

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Return Value

true if its data exists in the data structure; otherwise, false

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
ISIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%% $$Properties$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPITwoWaySignControlAdjMajorNumLanes Interface Properties
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPITwoWaySignControlAdjMajorNumLanes Interface

Glossary Item Box

For a list of all members of this type, see ISIAPITwoWaySignControlAdjMajorNumLanes members.

Public Properties

 | Name | Description
Property | Count |
Property | Item | Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type. Return an object if its data exists in the data structure; otherwise, null/Nothing.
Top

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Count Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLanes Interface : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLanes
Dim value As Integer

value = instance.Count
C#
int Count {get;}
Managed Extensions for C++
__property int get_Count();
C++/CLI
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
ISIAPITwoWaySignControlAdjMajorNumLanes Members


%%PageItemTitle%%

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
Item Property
See Also Send Feedback
SIDRASolutions.SI.API Namespace > ISIAPITwoWaySignControlAdjMajorNumLanes Interface : Item Property

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Glossary Item Box

Get an entry of the data for the specified Number of Lanes on Major Road and the Movement Type.
Return an object if its data exists in the data structure; otherwise, null/Nothing.

Syntax

Visual Basic (Declaration)
ReadOnly Default Property Item( _
   ByVal majorRoadNumOfLane As Integer, _
   ByVal movType As Integer _
) As ISIAPITwoWaySignControlAdjMajorNumLane
Visual Basic (Usage) Copy Code
Dim instance As ISIAPITwoWaySignControlAdjMajorNumLanes
Dim majorRoadNumOfLane As Integer
Dim movType As Integer
Dim value As ISIAPITwoWaySignControlAdjMajorNumLane

value = instance.Item(majorRoadNumOfLane, movType)
C#
ISIAPITwoWaySignControlAdjMajorNumLane this[
   int majorRoadNumOfLane,
   int movType
]; {get;}
Managed Extensions for C++
__property ISIAPITwoWaySignControlAdjMajorNumLane* get_Item   int majorRoadNumOfLane,
   int movType
;
C++/CLI
property ISIAPITwoWaySignControlAdjMajorNumLane^ default [int,int] {
   ISIAPITwoWaySignControlAdjMajorNumLane^ get(int majorRoadNumOfLane, int movType);
}

Parameters

majorRoadNumOfLane

Type: System.Int32;

Can be 2, 3, 5, 6.

movType

Type: System.Int32;

1 = Minor Road Left Turn,
2 = Minor Road Through,
3 = Minor Road Right Turn,
4 = Major Road Turn (Right or Left).

Requirements

Target Platforms: Windows 10, Windows 8.1, Windows 8, Windows 7, Windows Server 2012 family, Windows Server 2008 family

See Also

Reference

ISIAPITwoWaySignControlAdjMajorNumLanes Interface
ISIAPITwoWaySignControlAdjMajorNumLanes Members


%%phrase%%

SIDRASolutions.SI.API Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
SIDRASolutions.SI.API |


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback

Glossary Item Box


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIDiagnosticMsgs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIDiagnosticMsgs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIDiagnosticMsgs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIDiagnosticMsgs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovementMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovementMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovementMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneApproachMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneApproachMovements Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneApproachMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneApproachMovements members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneApproachMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneMovementMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneMovementMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneMovementMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneMovementMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPILaneSegmentMCs Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPILaneSegmentMCs Interface

Glossary Item Box

For a list of all members of this type, see ISIAPILaneSegmentMCs members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPILaneSegmentMCs Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPINetworkLegConnections Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPINetworkLegConnections Interface

Glossary Item Box

For a list of all members of this type, see ISIAPINetworkLegConnections members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPINetworkLegConnections Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputGraphTuples Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputGraphTuples Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputGraphTuples members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputNetworkGraphTuples Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputNetworkGraphTuples Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputNetworkGraphTuples members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputNetworkGraphTuples Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPathMovements Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPathMovements Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPathMovements members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPathMovements Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhaseMovTimingPaths Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhaseMovTimingPaths Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhaseMovTimingPaths members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhaseMovTimingPaths Interface
SIDRASolutions.SI.API Namespace


%%PageItemTitle%% $$Methods$$

[image]
SIDRASolutions.SI.API 8.0 Reference Documentation
ISIAPIOutputPhases Interface Methods
See Also Send Feedback
SIDRASolutions.SI.API Namespace : ISIAPIOutputPhases Interface

Glossary Item Box

For a list of all members of this type, see ISIAPIOutputPhases members.

Public Methods

 | Name | Description
Method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from System.Collections.IEnumerable)
Top

See Also

Reference

ISIAPIOutputPhases Interface
SIDRASolutions.SI.API Namespace